RakNet: Module Index

  • Main Page
  • Modules
  • Namespaces
  • Classes
  • Files
  • Directories
  • Related Pages

RakNet Modules

Here is a list of all modules:
  • PluginInterface
    • AutoRPC
    • ConnectionGraph
    • DirectoryDeltaTransfer
    • FileListTransfer
    • FullyConnectedMesh
    • LightweightDatabase
    • MessageFilter
    • NatPunchthrough
    • PacketLogger
    • ReadyEvent
    • ReplicaManager
    • ReplicaManager2
    • Router
    • RPC3
  • Remote Procedure Call Subsystem
  • Plugins
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: PluginInterface

  • Classes
  • Files
  • Directories
  • Related Pages

PluginInterface

The server plugin for the autopatcher. Must be running for the client to get patches. More...

Modules

AutoRPC
ConnectionGraph
DirectoryDeltaTransfer
FileListTransfer
FullyConnectedMesh
LightweightDatabase
MessageFilter
NatPunchthrough
PacketLogger
ReadyEvent
ReplicaManager
ReplicaManager2
Router
RPC3

Classes

class | PluginInterface
PluginInterface provides a mechanism to add functionality in a modular way. MessageHandlers should derive from PluginInterface and be attached to RakPeer using the function AttachPlugin On a user call to Receive, OnReceive is called for every PluginInterface, which can then take action based on the message passed to it. This is used to transparently add game-independent functional modules, similar to browser plugins. More...
class | RakNet::LobbyClientPC
PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality. More...
class | RakNet::Lobby2::LobbyClient
PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality. More...
class | RakNet::Lobby2::LobbyClientPC
PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality. More...

Detailed Description

The server plugin for the autopatcher. Must be running for the client to get patches.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: AutoRPC

  • Related Pages

AutoRPC
[PluginInterface]

Classes

class RakNet::AutoRPC
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ConnectionGraph

ConnectionGraph
[PluginInterface]

Classes

class ConnectionGraph
A connection graph. Each peer will know about all other peers. More...
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DirectoryDeltaTransfer

DirectoryDeltaTransfer
[PluginInterface]

Classes

class DirectoryDeltaTransfer
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc. More...
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: FileListTransfer

FileListTransfer
[PluginInterface]

Classes

class FileListTransfer
A plugin to provide a simple way to compress and incrementally send the files in the FileList structure. Similar to the DirectoryDeltaTransfer plugin, except that it doesn't send deltas based on pre-existing files or actually write the files to disk. More...
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: FullyConnectedMesh

FullyConnectedMesh
[PluginInterface]

Classes

class FullyConnectedMesh
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LightweightDatabase

LightweightDatabase
[PluginInterface]

Classes

class | LightweightDatabaseClient
The client interface to the simple database included with RakNet, useful for a server browser or a lobby server. More...
class | LightweightDatabaseServer
A simple flat database included with RakNet, useful for a server browser or a lobby server. A flat database interface. Adds the ability to track IPs of row updaters and passwords for table read and write operations, Best used for data in which queries which do not need to be updated in real-time. More...
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: MessageFilter

MessageFilter
[PluginInterface]

Classes

class MessageFilter
Assigns systems to FilterSets. Each FilterSet limits what kinds of messages are allowed. The MessageFilter plugin is used for security where you limit what systems can send what kind of messages. You implicitly define FilterSets, and add allowed message IDs and RPC calls to these FilterSets. You then add systems to these filters, such that those systems are limited to sending what the filters allows. You can automatically assign systems to a filter. You can automatically kick and possibly ban users that stay in a filter too long, or send the wrong message. Each system is a member of either zero or one filters. Add this plugin before any plugin you wish to filter (most likely just add this plugin before any other). More...
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: NatPunchthrough

NatPunchthrough
[PluginInterface]

Classes

class | NatPunchthroughLogger
Prints logging output for NatPunchthrough. More...
class | NatPunchthrough
The NatPunchthrough class implements the NAT punch through technique, allowing two systems to connect to each other that are both behind NATs. More...
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: PacketLogger

PacketLogger
[PluginInterface]

Classes

class | PacketConsoleLogger
Packetlogger that logs to a remote command console. More...
class | PacketFileLogger
Packetlogger that outputs to a file. More...
class | PacketLogger
Writes incoming and outgoing messages to the screen. This will write all incoming and outgoing messages to the console window, or to a file if you override it and give it this functionality. More...
class | ThreadsafePacketLogger
Same as PacketLogger, but writes output in the user thread. More...
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ReadyEvent

ReadyEvent
[PluginInterface]

Classes

class ReadyEvent

Enumerations

enum ReadyEventSystemStatus {
RES_NOT_WAITING, RES_WAITING, RES_READY, RES_ALL_READY,
RES_UNKNOWN_EVENT
}

Enumeration Type Documentation

enum ReadyEventSystemStatus

Returns the status of a remote system when querying with ReadyEvent::GetReadyStatus

Enumerator:
RES_NOT_WAITING | ----------- Normal states --------------- The remote system is not in the wait list, and we have never gotten a ready or complete message from it. This is the default state for valid events
RES_WAITING | We are waiting for this remote system to call SetEvent(thisEvent,true).
RES_READY | The remote system called SetEvent(thisEvent,true), but it still waiting for other systems before completing the ReadyEvent.
RES_ALL_READY | The remote system called SetEvent(thisEvent,true), and is no longer waiting for any other systems. This remote system has completed the ReadyEvent
RES_UNKNOWN_EVENT | Error code, we couldn't look up the system because the event was unknown.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ReplicaManager

ReplicaManager
[PluginInterface]

Classes

class | Replica
The interface to derive your game's networked classes from. More...
class | ReceiveConstructionInterface
class | SendDownloadCompleteInterface
class | ReceiveDownloadCompleteInterface
class | ReplicaManager
A management system for your game objects and players to make serialization, scoping, and object creation and destruction easier. More...
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ReplicaManager2

ReplicaManager2
[PluginInterface]

Classes

class | RakNet::ReplicaManager2
A management system for your game objects and players to make serialization, scoping, and object creation and destruction easier. More...
struct | RakNet::SerializationContext
Contextual information about serialization, passed to some functions in Replica2. More...
class | RakNet::Replica2
Base class for game objects that use the ReplicaManager2 system All game objects that want to use the ReplicaManager2 functionality must inherit from Replica2. Generally you will want to implement at a minimum Serialize(), Deserialize(), and SerializeConstruction(). More...
class | RakNet::Connection_RM2Factory
Implement this factory class to return instances of your Connection_RM2 derived object. This is used as a class factory and exposes functionality related to the connection and the system. More...
class | RakNet::Connection_RM2
This class represents a connection between two instances of ReplicaManager2 Represents a connection. Allocated by user supplied factory interface Connection_RM2Factory Implicitly created as needed Generally you will want to implement at a minimum the Construct() function, used as a factory function to create your game objects. More...

Enumerations

enum RakNet::SerializationType {
RakNet::SEND_SERIALIZATION_GENERIC_TO_SYSTEM, RakNet::BROADCAST_SERIALIZATION_GENERIC_TO_SYSTEM, RakNet::SEND_SERIALIZATION_CONSTRUCTION_TO_SYSTEM, RakNet::BROADCAST_SERIALIZATION_CONSTRUCTION_TO_SYSTEM,
RakNet::SEND_AUTO_SERIALIZE_TO_SYSTEM, RakNet::BROADCAST_AUTO_SERIALIZE_TO_SYSTEM, RakNet::RELAY_SERIALIZATION_TO_SYSTEMS, RakNet::SEND_CONSTRUCTION_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM ,
RakNet::SEND_DATA_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM, RakNet::SEND_DESTRUCTION_GENERIC_TO_SYSTEM, RakNet::SEND_DESTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM, RakNet::BROADCAST_DESTRUCTION_GENERIC_TO_SYSTEM,
RakNet::RELAY_DESTRUCTION_TO_SYSTEMS, RakNet::SEND_CONSTRUCTION_GENERIC_TO_SYSTEM, RakNet::SEND_CONSTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM, RakNet::BROADCAST_CONSTRUCTION_GENERIC_TO_SYSTEM,
RakNet::SEND_CONSTRUCTION_REQUEST_TO_SERVER, RakNet::BROADCAST_CONSTRUCTION_REQUEST_ACCEPTED_TO_SYSTEM, RakNet::SEND_CONSTRUCTION_REPLY_ACCEPTED_TO_CLIENT, RakNet::SEND_CONSTRUCTION_REPLY_DENIED_TO_CLIENT,
RakNet::SEND_VISIBILITY_TRUE_TO_SYSTEM, RakNet::BROADCAST_VISIBILITY_TRUE_TO_SYSTEM, RakNet::SEND_VISIBILITY_FALSE_TO_SYSTEM, RakNet::BROADCAST_VISIBILITY_FALSE_TO_SYSTEM,
RakNet::RELAY_VISIBILITY_TRUE_TO_SYSTEMS, RakNet::RELAY_VISIBILITY_FALSE_TO_SYSTEMS, RakNet::AUTOSERIALIZE_RESYNCH_ONLY, RakNet::AUTOSERIALIZE_DEFAULT,
RakNet::UNDEFINED_REASON
}
These are the types of events that can cause network data to be transmitted. More...

Enumeration Type Documentation

enum RakNet::SerializationType

These are the types of events that can cause network data to be transmitted.

Enumerator:
SEND_SERIALIZATION_GENERIC_TO_SYSTEM | Serialization command initiated by the user.
BROADCAST_SERIALIZATION_GENERIC_TO_SYSTEM | Serialization command initiated by the user.
SEND_SERIALIZATION_CONSTRUCTION_TO_SYSTEM | Serialization command automatically called after sending construction of the object.
BROADCAST_SERIALIZATION_CONSTRUCTION_TO_SYSTEM | Serialization command automatically called after sending construction of the object.
SEND_AUTO_SERIALIZE_TO_SYSTEM | Automatic serialization of data, based on Replica2::AddAutoSerializeTimer.
BROADCAST_AUTO_SERIALIZE_TO_SYSTEM | Automatic serialization of data, based on Replica2::AddAutoSerializeTimer.
RELAY_SERIALIZATION_TO_SYSTEMS | Received a serialization command, relaying to systems other than the sender.
SEND_CONSTRUCTION_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM | If SetAutoAddNewConnections is true, this is the command sent when sending all game objects to new connections automatically.
SEND_DATA_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM | The data portion of the game download, preceeded by SEND_CONSTRUCTION_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM.
SEND_DESTRUCTION_GENERIC_TO_SYSTEM | Default reason to send a destruction command.
SEND_DESTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM | Triggered by ReplicaManager2::RecalculateVisibility - A replica is now never constructed, so needs to be destroyed.
BROADCAST_DESTRUCTION_GENERIC_TO_SYSTEM | Triggered by Replica2::BroadcastDestruction.
RELAY_DESTRUCTION_TO_SYSTEMS | Received destruction message, relaying to other systems.
SEND_CONSTRUCTION_GENERIC_TO_SYSTEM | Default reason to send a construction command.
SEND_CONSTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM | Triggered by ReplicaManager2::RecalculateVisibility - A replica is now always constructed, so needs to be created.
BROADCAST_CONSTRUCTION_GENERIC_TO_SYSTEM | Triggered by Replica2::BroadcastConstruction().
SEND_CONSTRUCTION_REQUEST_TO_SERVER | Replica2::QueryIsConstructionAuthority()==false yet we called ReplicaManager2::SendConstruction().
BROADCAST_CONSTRUCTION_REQUEST_ACCEPTED_TO_SYSTEM | A non-authority object was created by a client, accepted, and is now relayed to all other connected systems.
SEND_CONSTRUCTION_REPLY_ACCEPTED_TO_CLIENT | A non-authority object was created by a client, accepted.
SEND_CONSTRUCTION_REPLY_DENIED_TO_CLIENT | A non-authority object was created by a client, denied.
SEND_VISIBILITY_TRUE_TO_SYSTEM | An object is visible.
BROADCAST_VISIBILITY_TRUE_TO_SYSTEM | An object is visible.
SEND_VISIBILITY_FALSE_TO_SYSTEM | An object is not visible.
BROADCAST_VISIBILITY_FALSE_TO_SYSTEM | An object is not visible.
RELAY_VISIBILITY_TRUE_TO_SYSTEMS | An object is visible, and we are telling other systems about this.
RELAY_VISIBILITY_FALSE_TO_SYSTEMS | An object is visible, and we are telling other systems about this.
AUTOSERIALIZE_RESYNCH_ONLY | Calling Replica2::Serialize() for the purpose of reading memory to compare against later. This read will not be transmitted.
AUTOSERIALIZE_DEFAULT | Calling Replica2::Serialize() to compare against a prior call. The serialization may be transmitted.
UNDEFINED_REASON | Start your own reasons one unit past this enum.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Router

Router
[PluginInterface]

Classes

class Router
Used to route messages between peers. More...
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RPC3

RPC3
[PluginInterface]

Classes

class RakNet::RPC3

Enumerations

enum RakNet::RPCErrorCodes {
RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST, RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST,
RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED,
RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_CALLING_CPP_AS_C, RakNet::RPC_ERROR_CALLING_CPP_AS_C,
RakNet::RPC_ERROR_CALLING_C_AS_CPP, RakNet::RPC_ERROR_CALLING_C_AS_CPP, RakNet::RPC_ERROR_STACK_TOO_SMALL, RakNet::RPC_ERROR_STACK_DESERIALIZATION_FAILED,
RakNet::RPC_ERROR_INCORRECT_NUMBER_OF_PARAMETERS, RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST,
RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST, RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED,
RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_CALLING_CPP_AS_C,
RakNet::RPC_ERROR_CALLING_CPP_AS_C, RakNet::RPC_ERROR_CALLING_C_AS_CPP, RakNet::RPC_ERROR_CALLING_C_AS_CPP
}

Enumeration Type Documentation

enum RakNet::RPCErrorCodes

Error codes returned by a remote system as to why an RPC function call cannot execute Follows packet ID ID_RPC_REMOTE_ERROR, that is packet->data[1] Name of the function will be appended starting at packet->data[2]

Enumerator:
RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE | AutoRPC::SetNetworkIDManager() was not called, and it must be called to call a C++ object member.
RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE | RPC3::SetNetworkIDManager() was not called, and it must be called to call a C++ object member.
RPC_ERROR_OBJECT_DOES_NOT_EXIST | Cannot execute C++ object member call because the object specified by SetRecipientObject() does not exist on this system.
RPC_ERROR_OBJECT_DOES_NOT_EXIST | Cannot execute C++ object member call because the object specified by SetRecipientObject() does not exist on this system.
RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE | Internal error, index optimization for function lookup does not exist.
RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE | Internal error, index optimization for function lookup does not exist.
RPC_ERROR_FUNCTION_NOT_REGISTERED | Named function was not registered with RegisterFunction(). Check your spelling.
RPC_ERROR_FUNCTION_NOT_REGISTERED | Named function was not registered with RegisterFunction(). Check your spelling.
RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED | Named function was registered, but later unregistered with UnregisterFunction() and can no longer be called.
RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED | Named function was registered, but later unregistered with UnregisterFunction() and can no longer be called.
RPC_ERROR_CALLING_CPP_AS_C | SetRecipientObject() was not called before Call(), but RegisterFunction() was called with isObjectMember=true If you intended to call a CPP function, call SetRecipientObject() with a valid object first.
RPC_ERROR_CALLING_CPP_AS_C | SetRecipientObject() was not called before Call(), but the registered pointer is a class member If you intended to call a class member function, call SetRecipientObject() with a valid object first.
RPC_ERROR_CALLING_C_AS_CPP | SetRecipientObject() was called before Call(), but RegisterFunction() was called with isObjectMember=false If you intended to call a C function, call SetRecipientObject(UNASSIGNED_NETWORK_ID) first.
RPC_ERROR_CALLING_C_AS_CPP | SetRecipientObject() was called before Call(), but RegisterFunction() was called with isObjectMember=false If you intended to call a C function, call SetRecipientObject(UNASSIGNED_NETWORK_ID) first.
RPC_ERROR_STACK_TOO_SMALL | Internal error, passed stack is bigger than current stack. Check that the version is the same on both systems.
RPC_ERROR_STACK_DESERIALIZATION_FAILED | Internal error, formatting error with how the stack was serialized.
RPC_ERROR_INCORRECT_NUMBER_OF_PARAMETERS | The parameterCount parameter passed to RegisterFunction() on this system does not match the parameterCount parameter passed to SendCall() on the remote system.
RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE | AutoRPC::SetNetworkIDManager() was not called, and it must be called to call a C++ object member.
RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE | RPC3::SetNetworkIDManager() was not called, and it must be called to call a C++ object member.
RPC_ERROR_OBJECT_DOES_NOT_EXIST | Cannot execute C++ object member call because the object specified by SetRecipientObject() does not exist on this system.
RPC_ERROR_OBJECT_DOES_NOT_EXIST | Cannot execute C++ object member call because the object specified by SetRecipientObject() does not exist on this system.
RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE | Internal error, index optimization for function lookup does not exist.
RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE | Internal error, index optimization for function lookup does not exist.
RPC_ERROR_FUNCTION_NOT_REGISTERED | Named function was not registered with RegisterFunction(). Check your spelling.
RPC_ERROR_FUNCTION_NOT_REGISTERED | Named function was not registered with RegisterFunction(). Check your spelling.
RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED | Named function was registered, but later unregistered with UnregisterFunction() and can no longer be called.
RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED | Named function was registered, but later unregistered with UnregisterFunction() and can no longer be called.
RPC_ERROR_CALLING_CPP_AS_C | SetRecipientObject() was not called before Call(), but RegisterFunction() was called with isObjectMember=true If you intended to call a CPP function, call SetRecipientObject() with a valid object first.
RPC_ERROR_CALLING_CPP_AS_C | SetRecipientObject() was not called before Call(), but the registered pointer is a class member If you intended to call a class member function, call SetRecipientObject() with a valid object first.
RPC_ERROR_CALLING_C_AS_CPP | SetRecipientObject() was called before Call(), but RegisterFunction() was called with isObjectMember=false If you intended to call a C function, call SetRecipientObject(UNASSIGNED_NETWORK_ID) first.
RPC_ERROR_CALLING_C_AS_CPP | SetRecipientObject() was called before Call(), but RegisterFunction() was called with isObjectMember=false If you intended to call a C function, call SetRecipientObject(UNASSIGNED_NETWORK_ID) first.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Remote Procedure Call Subsystem

Remote Procedure Call Subsystem

A system to call C or object member procudures on other systems, and even to return return values. More...

Files

file | RPCMap.h
[Internal] A container class for a list of RPCNodes
file | RPCNode.h
[Internal] Holds information related to a RPC

Defines

#define | REGISTER_STATIC_RPC(networkObject, functionName) (networkObject)->RegisterAsRemoteProcedureCall((#functionName),(functionName))
RPC Function Implementation.
#define | CLASS_MEMBER_ID(className, functionName) #className "_" #functionName
Concatenate two strings.
#define | REGISTER_CLASS_MEMBER_RPC(networkObject, className, functionName) {union {void (__cdecl className::*cFunc)( RPCParameters *rpcParms ); void* voidFunc;}; cFunc=&className::functionName; networkObject->RegisterClassMemberRPC(CLASS_MEMBER_ID(className, functionName),voidFunc);}
Register a member function of an instantiated object as a Remote procedure call. RPC member Functions MUST be marked __cdecl!
#define | UNREGISTER_STATIC_RPC(networkObject, functionName) (networkObject)->UnregisterAsRemoteProcedureCall((#functionName))

Functions

void | RakPeer::RegisterAsRemoteProcedureCall (const char *uniqueID, void(*functionPointer)(RPCParameters *rpcParms))
void | RakPeer::RegisterClassMemberRPC (const char *uniqueID, void *functionPointer)
void | RakPeer::UnregisterAsRemoteProcedureCall (const char *uniqueID)
void | RakPeer::SetNetworkIDManager (NetworkIDManager *manager)
bool | RakPeer::RPC (const char *uniqueID, const char *data, BitSize_t bitLength, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, RakNetTime *includedTimestamp, NetworkID networkID, RakNet::BitStream *replyFromTarget)
bool | RakPeer::RPC (const char *uniqueID, const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, RakNetTime *includedTimestamp, NetworkID networkID, RakNet::BitStream *replyFromTarget)
virtual void | RakPeerInterface::RegisterAsRemoteProcedureCall (const char *uniqueID, void(*functionPointer)(RPCParameters *rpcParms))=0
virtual void | RakPeerInterface::RegisterClassMemberRPC (const char *uniqueID, void *functionPointer)=0
virtual void | RakPeerInterface::UnregisterAsRemoteProcedureCall (const char *uniqueID)=0
virtual void | RakPeerInterface::SetNetworkIDManager (NetworkIDManager *manager)=0
virtual bool | RakPeerInterface::RPC (const char *uniqueID, const char *data, BitSize_t bitLength, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, RakNetTime *includedTimestamp, NetworkID networkID, RakNet::BitStream *replyFromTarget)=0
virtual bool | RakPeerInterface::RPC (const char *uniqueID, const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, RakNetTime *includedTimestamp, NetworkID networkID, RakNet::BitStream *replyFromTarget)=0

Detailed Description

A system to call C or object member procudures on other systems, and even to return return values.

Define Documentation

#define CLASS_MEMBER_ID | ( | className,
 |  | functionName | ) | #className "_" #functionName

Concatenate two strings.

Use the AutoRPC plugin instead

#define REGISTER_CLASS_MEMBER_RPC | ( | networkObject,
 |  | className,
 |  | functionName | ) | {union {void (__cdecl className::*cFunc)( RPCParameters *rpcParms ); void* voidFunc;}; cFunc=&className::functionName; networkObject->RegisterClassMemberRPC(CLASS_MEMBER_ID(className, functionName),voidFunc);}

Register a member function of an instantiated object as a Remote procedure call. RPC member Functions MUST be marked __cdecl!

Use the AutoRPC plugin instead

See also:
ObjectMemberRPC.cpp CLASS_MEMBER_ID is a utility macro to generate a unique signature for a class and function pair and can be used for the Raknet functions RegisterClassMemberRPC(...) and RPC(...) REGISTER_CLASS_MEMBER_RPC is a utility macro to more easily call RegisterClassMemberRPC
Parameters:
[in] | networkObject | Your instance of RakPeer, RakPeer, or RakPeer
[in] | className | The class containing the function
[in] | functionName | The name of the function (not in quotes, just the name)

#define REGISTER_STATIC_RPC | ( | networkObject,
 |  | functionName | ) | (networkObject)->RegisterAsRemoteProcedureCall((#functionName),(functionName))

RPC Function Implementation.

Use the AutoRPC plugin instead Register a C function as a Remote procedure.

Parameters:
[in] | networkObject | Your instance of RakPeer, RakPeer, or RakPeer
[in] | functionName | The name of the C function to call
Attention:
12/01/05 REGISTER_AS_REMOTE_PROCEDURE_CALL renamed to REGISTER_STATIC_RPC. Delete the old name sometime in the future

#define UNREGISTER_STATIC_RPC | ( | networkObject,
 |  | functionName | ) | (networkObject)->UnregisterAsRemoteProcedureCall((#functionName))

Use the AutoRPC plugin instead Unregisters a remote procedure call RPC member Functions MUST be marked __cdecl! See the ObjectMemberRPC example.

Parameters:
[in] | networkObject | The object that manages the function
[in] | functionName | The function name

Function Documentation

virtual void RakPeerInterface::RegisterAsRemoteProcedureCall | ( | const char * | uniqueID,
 |  | void(*)(RPCParameters *rpcParms) | functionPointer |
 | ) |  |  | [pure virtual, inherited]

Use the AutoRPC plugin instead Register a C or static member function as available for calling as a remote procedure call

Parameters:
[in] | uniqueID | A null-terminated unique string to identify this procedure. See RegisterClassMemberRPC() for class member functions.
[in] | functionPointer(...) | The name of the function to be used as a function pointer. This can be called whether active or not, and registered functions stay registered unless unregistered

Implemented in RakPeer.

void RakPeer::RegisterAsRemoteProcedureCall | ( | const char * | uniqueID,
 |  | void(*)(RPCParameters *rpcParms) | functionPointer |
 | ) |  |  | [virtual, inherited]

Register a C or static member function as available for calling as a remote procedure call

Parameters:
[in] | uniqueID | A null-terminated unique string to identify this procedure. See RegisterClassMemberRPC() for class member functions.
[in] | functionPointer(...) | The name of the function to be used as a function pointer. This can be called whether active or not, and registered functions stay registered unless unregistered

Implements RakPeerInterface.

virtual void RakPeerInterface::RegisterClassMemberRPC | ( | const char * | uniqueID,
 |  | void * | functionPointer |
 | ) |  |  | [pure virtual, inherited]

Use the AutoRPC plugin instead Register a C++ member function as available for calling as a remote procedure call.

Parameters:
[in] | uniqueID | A null terminated string to identify this procedure. Recommended you use the macro REGISTER_CLASS_MEMBER_RPC to create the string. Use RegisterAsRemoteProcedureCall() for static functions.
[in] | functionPointer | The name of the function to be used as a function pointer. This can be called whether active or not, and registered functions stay registered unless unregistered with UnregisterAsRemoteProcedureCall
See also:
The sample ObjectMemberRPC.cpp

Implemented in RakPeer.

void RakPeer::RegisterClassMemberRPC | ( | const char * | uniqueID,
 |  | void * | functionPointer |
 | ) |  |  | [virtual, inherited]

Register a C++ member function as available for calling as a remote procedure call.

Parameters:
[in] | uniqueID | A null terminated string to identify this procedure. Recommended you use the macro REGISTER_CLASS_MEMBER_RPC to create the string. Use RegisterAsRemoteProcedureCall() for static functions.
[in] | functionPointer | The name of the function to be used as a function pointer. This can be called whether active or not, and registered functions stay registered unless unregistered with UnregisterAsRemoteProcedureCall
See also:
The sample ObjectMemberRPC.cpp

Implements RakPeerInterface.

virtual bool RakPeerInterface::RPC | ( | const char * | uniqueID,
 |  | const RakNet::BitStream * | bitStream,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | RakNetTime * | includedTimestamp,
 |  | NetworkID | networkID,
 |  | RakNet::BitStream * | replyFromTarget |
 | ) |  |  | [pure virtual, inherited]

Calls a C function on the remote system that was already registered using RegisterAsRemoteProcedureCall. If you want that function to return data you should call RPC from that system in the same wayReturns true on a successful packet send (this does not indicate the recipient performed the call), false on failure

Parameters:
[in] | uniqueID | A NULL terminated string identifying the function to call. Recommended you use the macro CLASS_MEMBER_ID for class member functions.
[in] | data | The data to send
[in] | bitLength | The number of bits of data
[in] | priority | What priority level to send on. See PacketPriority.h.
[in] | reliability | How reliability to send this data. See PacketPriority.h.
[in] | orderingChannel | When using ordered or sequenced message, what channel to order these on.
[in] | systemAddress | Who to send this message to, or in the case of broadcasting who not to send it to. Use UNASSIGNED_SYSTEM_ADDRESS to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
[in] | includedTimestamp | Pass a timestamp if you wish, to be adjusted in the usual fashion as per ID_TIMESTAMP. Pass 0 to not include a timestamp.
[in] | networkID | For static functions, pass UNASSIGNED_NETWORK_ID. For member functions, you must derive from NetworkIDObject and pass the value returned by NetworkIDObject::GetNetworkID for that object.
[in] | replyFromTarget | If 0, this function is non-blocking. Otherwise it will block while waiting for a reply from the target procedure, which should be remotely written to RPCParameters::replyToSender and copied to replyFromTarget. The block will return early on disconnect or if the sent packet is unreliable and more than 3X the ping has elapsed.
Returns:
True on a successful packet send (this does not indicate the recipient performed the call), false on failure

Implemented in RakPeer.

virtual bool RakPeerInterface::RPC | ( | const char * | uniqueID,
 |  | const char * | data,
 |  | BitSize_t | bitLength,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | RakNetTime * | includedTimestamp,
 |  | NetworkID | networkID,
 |  | RakNet::BitStream * | replyFromTarget |
 | ) |  |  | [pure virtual, inherited]

Calls a C function on the remote system that was already registered using RegisterAsRemoteProcedureCall().

Parameters:
[in] | uniqueID | A NULL terminated string identifying the function to call. Recommended you use the macro CLASS_MEMBER_ID for class member functions.
[in] | data | The data to send
[in] | bitLength | The number of bits of data
[in] | priority | What priority level to send on. See PacketPriority.h.
[in] | reliability | How reliability to send this data. See PacketPriority.h.
[in] | orderingChannel | When using ordered or sequenced message, what channel to order these on.
[in] | systemAddress | Who to send this message to, or in the case of broadcasting who not to send it to. Use UNASSIGNED_SYSTEM_ADDRESS to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
[in] | includedTimestamp | Pass a timestamp if you wish, to be adjusted in the usual fashion as per ID_TIMESTAMP. Pass 0 to not include a timestamp.
[in] | networkID | For static functions, pass UNASSIGNED_NETWORK_ID. For member functions, you must derive from NetworkIDObject and pass the value returned by NetworkIDObject::GetNetworkID for that object.
[in] | replyFromTarget | If 0, this function is non-blocking. Otherwise it will block while waiting for a reply from the target procedure, which should be remotely written to RPCParameters::replyToSender and copied to replyFromTarget. The block will return early on disconnect or if the sent packet is unreliable and more than 3X the ping has elapsed.
Returns:
True on a successful packet send (this does not indicate the recipient performed the call), false on failure

Implemented in RakPeer.

bool RakPeer::RPC | ( | const char * | uniqueID,
 |  | const RakNet::BitStream * | bitStream,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | RakNetTime * | includedTimestamp,
 |  | NetworkID | networkID,
 |  | RakNet::BitStream * | replyFromTarget |
 | ) |  |  | [virtual, inherited]

Calls a C function on the remote system that was already registered using RegisterAsRemoteProcedureCall. If you want that function to return data you should call RPC from that system in the same wayReturns true on a successful packet send (this does not indicate the recipient performed the call), false on failure

Precondition:
To use object member RPC (networkID!=UNASSIGNED_OBJECT_ID), The recipient must have called SetNetworkIDManager so the system can handle the object lookups
Parameters:
[in] | uniqueID | A NULL terminated string identifying the function to call. Recommended you use the macro CLASS_MEMBER_ID for class member functions.
[in] | data | The data to send
[in] | bitLength | The number of bits of data
[in] | priority | What priority level to send on. See PacketPriority.h.
[in] | reliability | How reliability to send this data. See PacketPriority.h.
[in] | orderingChannel | When using ordered or sequenced message, what channel to order these on.
[in] | systemAddress | Who to send this message to, or in the case of broadcasting who not to send it to. Use UNASSIGNED_SYSTEM_ADDRESS to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
[in] | includedTimestamp | Pass a timestamp if you wish, to be adjusted in the usual fashion as per ID_TIMESTAMP. Pass 0 to not include a timestamp.
[in] | networkID | For static functions, pass UNASSIGNED_NETWORK_ID. For member functions, you must derive from NetworkIDObject and pass the value returned by NetworkIDObject::GetNetworkID for that object.
[in] | replyFromTarget | If 0, this function is non-blocking. Otherwise it will block while waiting for a reply from the target procedure, which should be remotely written to RPCParameters::replyToSender and copied to replyFromTarget. The block will return early on disconnect or if the sent packet is unreliable and more than 3X the ping has elapsed.
Returns:
True on a successful packet send (this does not indicate the recipient performed the call), false on failure

Implements RakPeerInterface.

bool RakPeer::RPC | ( | const char * | uniqueID,
 |  | const char * | data,
 |  | BitSize_t | bitLength,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | RakNetTime * | includedTimestamp,
 |  | NetworkID | networkID,
 |  | RakNet::BitStream * | replyFromTarget |
 | ) |  |  | [virtual, inherited]

Calls a C function on the remote system that was already registered using RegisterAsRemoteProcedureCall().

Precondition:
To use object member RPC (networkID!=UNASSIGNED_OBJECT_ID), The recipient must have called SetNetworkIDManager so the system can handle the object lookups
Parameters:
[in] | uniqueID | A NULL terminated string identifying the function to call. Recommended you use the macro CLASS_MEMBER_ID for class member functions.
[in] | data | The data to send
[in] | bitLength | The number of bits of data
[in] | priority | What priority level to send on. See PacketPriority.h.
[in] | reliability | How reliability to send this data. See PacketPriority.h.
[in] | orderingChannel | When using ordered or sequenced message, what channel to order these on.
[in] | systemAddress | Who to send this message to, or in the case of broadcasting who not to send it to. Use UNASSIGNED_SYSTEM_ADDRESS to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
[in] | includedTimestamp | Pass a timestamp if you wish, to be adjusted in the usual fashion as per ID_TIMESTAMP. Pass 0 to not include a timestamp.
[in] | networkID | For static functions, pass UNASSIGNED_NETWORK_ID. For member functions, you must derive from NetworkIDObject and pass the value returned by NetworkIDObject::GetNetworkID for that object.
[in] | replyFromTarget | If 0, this function is non-blocking. Otherwise it will block while waiting for a reply from the target procedure, which should be remotely written to RPCParameters::replyToSender and copied to replyFromTarget. The block will return early on disconnect or if the sent packet is unreliable and more than 3X the ping has elapsed.
Returns:
True on a successful packet send (this does not indicate the recipient performed the call), false on failure

Implements RakPeerInterface.

virtual void RakPeerInterface::SetNetworkIDManager ( NetworkIDManager * manager ) [pure virtual, inherited]

Used by Object member RPC to lookup objects given that object's ID Also used by the ReplicaManager plugin

Parameters:
[in] An instance of NetworkIDManager to use for the lookup.

Implemented in RakPeer.

void RakPeer::SetNetworkIDManager ( NetworkIDManager * manager ) [virtual, inherited]

Used by Object member RPC to lookup objects given that object's ID Also used by the ReplicaManager plugin

Parameters:
[in] An instance of NetworkIDManager to use for the loookup.

Implements RakPeerInterface.

virtual void RakPeerInterface::UnregisterAsRemoteProcedureCall ( const char * uniqueID ) [pure virtual, inherited]

Use the AutoRPC plugin instead Unregisters a C function as available for calling as a remote procedure call that was formerly registered with RegisterAsRemoteProcedureCall. Only call offline.

Parameters:
[in] uniqueID A string of only letters to identify this procedure. Recommended you use the macro CLASS_MEMBER_ID for class member functions.

Implemented in RakPeer.

void RakPeer::UnregisterAsRemoteProcedureCall ( const char * uniqueID ) [virtual, inherited]

Unregisters a C function as available for calling as a remote procedure call that was formerly registered with RegisterAsRemoteProcedureCall. Only call offline.

Parameters:
[in] uniqueID A string of only letters to identify this procedure. Recommended you use the macro CLASS_MEMBER_ID for class member functions.

Implements RakPeerInterface.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Plugins

Plugins

Encodes, decodes, and transmits voice data. Voice compression and transmission interface. More...
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class List

  • Alphabetical List
  • Class List
  • Class Hierarchy
  • Class Members

RakNet Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
LobbyDBSpec::AddAccountNote_Data | Adds an entry to the accountNotes table for an existing user
LobbyDBSpec::AddFriend_Data | Adds a userId / friendId to the friends table
TitleValidationDBSpec::AddTitle_Data | Adds a title to the database of titles. This can be used to look up titleIds given a title password
LobbyDBSpec::AddToIgnoreList_Data | Adds to the ignoreList table for a particular userId / userHandle
AutopatcherMySQLRepository
AutopatcherPostgreRepository
AutopatcherRepositoryInterface | An interface used by AutopatcherServer to get the data necessary to run an autopatcher. This is up to you to implement for custom repository solutions
RakNet::AutoRPC
DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType > | An AVLBalancedBinarySearchTree is a binary tree that is always balanced
DataStructures::BinarySearchTree< BinarySearchTreeType > | A binary search tree and an AVL balanced binary search tree
RakNet::BitStream
DataStructures::BPlusTree< KeyType, DataType, order >
CheckSum | Generates and validates checksums
DataStructures::CircularLinkedList< CircularLinkedListType > | (Circular) Linked List ADT (Doubly Linked Pointer to Node Style) -
RakNet::ClanJoinInvitation_Notification | A leader or subleader in a clan has invited you to join that clan
RakNet::ClanJoinInvitationAccepted_Notification
RakNet::ClanJoinInvitationRejected_Notification
RakNet::ClanJoinInvitationWithdrawn_Notification | You were invited to a clan, but this invitation has been revoked
RakNet::ClanMemberJoinRequest_Notification | Someone has asked to join your clan
RakNet::ClanMemberJoinRequestAccepted_Notification
RakNet::ClanMemberJoinRequestRejected_Notification
RakNet::ClanMemberJoinRequestWithdrawn_Notification | Someone has petitioned to join your clan, but changed their mind and have withdrawn that petition
CombFilterMem
CommandParserInterface | The interface used by command parsers
RakNet::Connection_RM2 | This class represents a connection between two instances of ReplicaManager2 Represents a connection. Allocated by user supplied factory interface Connection_RM2Factory Implicitly created as needed Generally you will want to implement at a minimum the Construct() function, used as a factory function to create your game objects
RakNet::Connection_RM2Factory | Implement this factory class to return instances of your Connection_RM2 derived object. This is used as a class factory and exposes functionality related to the connection and the system
ConnectionGraph | A connection graph. Each peer will know about all other peers
ConnectionGraph::SystemAddressAndGroupId | A node in the connection graph
ConsoleServer | The main entry point for the server portion of your remote console application support. ConsoleServer takes one TransportInterface and one or more CommandParserInterface (s) The TransportInterface will be used to send data between the server and the client. The connecting client must support the protocol used by your derivation of TransportInterface . TelnetTransport and RakNetTransport are two such derivations . When a command is sent by a remote console, it will be processed by your implementations of CommandParserInterface
LobbyDBSpec::CreateUser_Data | Adds a user to the users table
DatabaseCellUpdate | The value to write to a cell in a remote database
DataBlockEncryptor | Encrypts and decrypts data blocks
DataCompressor | Does compression on a block of data. Not very good compression, but it's small and fast so is something you can compute at runtime
DecState
LobbyDBSpec::DeleteEmail_Data | Deletes an email from either the incomingEmails or sentEmails table
DirectoryDeltaTransfer | Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc
drft_lookup
EmailSender | Rudimentary class to send email from code
EncState
FileListNode | Represents once instance of a file
FileListProgress | Callback interface set with FileList::SetCallback() in case you want progress notifications when FileList::AddFilesFromDirectory() is called
FileListTransfer | A plugin to provide a simple way to compress and incrementally send the files in the FileList structure. Similar to the DirectoryDeltaTransfer plugin, except that it doesn't send deltas based on pre-existing files or actually write the files to disk
FileListTransferCBInterface | Used by FileListTransfer plugin as a callback for when we get a file. You get the last file when fileIndex==setCount
FLP_Printf | Implementation of FileListProgress to use printf
FullyConnectedMesh
RakNet::FunctionThread
RakNet::Functor
LobbyDBSpec::GetAccountNotes_Data | Gets all account notes for an existing user
LobbyDBSpec::GetEmails_Data | Gets all emails in the emails table for a particular user
LobbyDBSpec::GetFriends_Data | Gets the friends table for a userId or userHandle
RankingServerDBSpec::GetHistoryForParticipant_Data | Given a particular player and game, get a match history
GetHistoryForParticipant_PostgreSQLImpl | Given a particular player and game, get a match history
LobbyDBSpec::GetIgnoreList_Data | Gets the ignoreList table for a particular userId / userHandle
RankingServerDBSpec::GetRatingForParticipant_Data | Given a particular player and game, get that player's rating from the database
GetRatingForParticipant_PostgreSQLImpl | Given a particular player and game, get that player's rating from the database
RankingServerDBSpec::GetRatingForParticipants_Data | Given a particular game, get ratings for all players
GetRatingForParticipants_PostgreSQLImpl | Given a particular game, get ratings for all players
TitleValidationDBSpec::GetTitles_Data | Download all titles added with AddTitle_Data
RankingServerDBSpec::GetTrustedIPList_Data
LobbyDBSpec::GetUser_Data | Get a user from the users table, using userId or userHandle for the lookup
HTTPConnection | Use HTTPConnection to communicate with a web server. Start an instance of TCPInterface via the Start() command. Instantiate a new instance of HTTPConnection, and associate TCPInterface with the class in the constructor. Use Post() to send commands to the web server, and ProcessDataPacket() to update the connection with packets returned from TCPInterface that have the system address of the web server This class will handle connecting and reconnecting as necessary
HTTPConnection::BadResponse | Encapsulates a raw HTTP response and response code
HuffmanEncodingTree | This generates special cases of the huffman encoding tree using 8 bit keys with the additional condition that unused combinations of 8 bits are treated as a frequency of 1
HuffmanEncodingTreeFactory | Creates instances of the class HuffmanEncodingTree
InlineFunctor | A base class to derive functors from for the InlineFunctorProcessor system
InlineFunctorProcessor | A base class that will allow you to call YieldOnFunctor() from within a function, and continue with that function when the asynchronous processing has completed
InternalPacket
RakNet::LeaveClan_Notification | Someone has left this clan
LightweightDatabaseClient | The client interface to the simple database included with RakNet, useful for a server browser or a lobby server
LightweightDatabaseServer | A simple flat database included with RakNet, useful for a server browser or a lobby server. A flat database interface. Adds the ability to track IPs of row updaters and passwords for table read and write operations, Best used for data in which queries which do not need to be updated in real-time
DataStructures::List< list_type > | Array based implementation of a list
RakNet::Lobby2::LobbyClient | PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality
RakNet::LobbyClientInterface | The client-side interface to the lobby system The Lobby client implements functionality commonly found in game lobbies. It is the counterpart to the LobbyServer class. This interface is system independent, but for PC functionality see LobbyClientPC For full documentation on the PC version, see LobbyClientPC.h
RakNet::Lobby2::LobbyClientPC | PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality
RakNet::LobbyClientPC | PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality
LobbyDB_PostgreSQL
LobbyDBCBInterface | If you want to forward Functor::HandleResult() the output to a callback (which is what it does by default), you can use this
RakNet::LobbyServer
RakNet::LobbyServerPostgreSQL
LogCommandParser | Adds the ability to send logging output to a remote console
LogCommandParser::SystemAddressAndChannel | One of these structures is created per player
ltp_params
DataStructures::Map< key_type, data_type, key_comparison_func >
Note:
IMPORTANT! If you use defaultMapKeyComparison then call IMPLEMENT_DEFAULT_COMPARISON or you will get an unresolved external linker error
MemoryCompressor | Compress one or more blocks of data
DataStructures::MemoryPool< MemoryBlockType >
MessageFilter | Assigns systems to FilterSets. Each FilterSet limits what kinds of messages are allowed. The MessageFilter plugin is used for security where you limit what systems can send what kind of messages. You implicitly define FilterSets, and add allowed message IDs and RPC calls to these FilterSets. You then add systems to these filters, such that those systems are limited to sending what the filters allows. You can automatically assign systems to a filter. You can automatically kick and possibly ban users that stay in a filter too long, or send the wrong message. Each system is a member of either zero or one filters. Add this plugin before any plugin you wish to filter (most likely just add this plugin before any other)
RankingServerDBSpec::ModifyTrustedIPList_Data
ModifyTrustedIPList_PostgreSQLImpl | Modify the list of IPs allowed to submit matches
NatPunchthrough | Implements the NAT punch through technique, allowing two systems to connect to each other that are both behind NATs
NatPunchthroughLogger | Prints logging output for NatPunchthrough
NetworkIDManager
NetworkIDObject | Unique shared ids for each object instance
DataStructures::OrderedList< key_type, data_type, default_comparison_function >
Note:
IMPORTANT! If you use defaultOrderedListComparison then call IMPLEMENT_DEFAULT_COMPARISON or you will get an unresolved external linker error
Packet | This represents a user message from another system
PacketConsoleLogger | Packetlogger that logs to a remote command console
PacketFileLogger | Packetlogger that outputs to a file
PacketLogger | Writes incoming and outgoing messages to the screen. This will write all incoming and outgoing messages to the console window, or to a file if you override it and give it this functionality
DataStructures::Page< KeyType, DataType, order >
RankingServerDBSpec::PairedKeyDbId
PluginInterface | PluginInterface provides a mechanism to add functionality in a modular way. MessageHandlers should derive from PluginInterface and be attached to RakPeer using the function AttachPlugin On a user call to Receive, OnReceive is called for every PluginInterface, which can then take action based on the message passed to it. This is used to transparently add game-independent functional modules, similar to browser plugins
DataStructures::Queue< queue_type > | A queue implemented as an array with a read and write index
DataStructures::QueueLinkedList< QueueType > | A queue implemented using a linked list. Rarely used
RakNetCommandParser | This allows a console client to call most of the functions in RakPeer
RakNetStatistics | Network Statisics Usage
RakNetTransport | Use RakNetTransport if you need a secure connection between the client and the console server. RakNetTransport automatically initializes security for the system. Use the project CommandConsoleClient to connect To the ConsoleServer if you use RakNetTransport
RakNetTransportCommandParser | RakNetTransport has its own command parser to enable remote users to change the command console's password
RakPeer | The main interface for network communications
RakPeer::MemoryBlock | Automatic Variable Synchronization Mechanism automatic variable synchronization takes a primary and secondary identifier The unique primary identifier is the index into the automaticVariableSynchronizationList The unique secondary identifier (UNASSIGNED_NETWORK_ID for none) is in an unsorted list of memory blocks
RakPeerInterface | The main interface for network communications
RakNet::RakString | String class Has the following improvements over std::string Reference counting: Suitable to store in lists Varidic assignment operator Doesn't cause linker errors
RankingServer_PostgreSQL
RankingServerCBInterface | If you want to forward Functor::HandleResult() the output to a callback (which is what it does by default), you can use this
ReadyEvent
ReceiveConstructionInterface
ReceiveDownloadCompleteInterface
RefCountedObj | World's simplest class :)
ReliabilityLayer | Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence
RemoteClient | Stores information about a remote client
LobbyDBSpec::RemoveFriend_Data | Removes a userId / friendId from the friends table
LobbyDBSpec::RemoveFromIgnoreList_Data | Removes from the ignoreList table for a particular userId / userHandle
Replica | The interface to derive your game's networked classes from
RakNet::Replica2 | Base class for game objects that use the ReplicaManager2 system All game objects that want to use the ReplicaManager2 functionality must inherit from Replica2. Generally you will want to implement at a minimum Serialize(), Deserialize(), and SerializeConstruction()
ReplicaManager | A management system for your game objects and players to make serialization, scoping, and object creation and destruction easier
RakNet::ReplicaManager2 | A management system for your game objects and players to make serialization, scoping, and object creation and destruction easier
Router | Used to route messages between peers
RouterInterface | On failed directed sends, RakNet can call an alternative send function to use
RakNet::RPC3
RPCParameters
SBDecState
SBEncState
SendDownloadCompleteInterface
LobbyDBSpec::SendEmail_Data | Adds an email to the emails table. Added once for the user with inbox=false, n times for n recipients with inbox=true
RakNet::SerializationContext | Contextual information about serialization, passed to some functions in Replica2
SimpleMutex | An easy to use mutex
DataStructures::SingleProducerConsumer< SingleProducerConsumerType > | A single producer consumer implementation without critical sections
SocketDescriptor | Describes the local socket to use for RakPeer::Startup
SpeexBits
SpeexCallback
SpeexEchoState_
SpeexHeader
SpeexJitter
SpeexMode
SpeexNBMode
SpeexPreprocessState
SpeexSBMode
SpeexStereoState
SpeexSubmode
split_cb_params
StrAndBool | The string plus a bool telling us if this string was copied or not
StringCompressor | Writes and reads strings to and from bitstreams
RakNet::StringTable | Writes a string index, instead of the whole string
RankingServerDBSpec::SubmitMatch_Data
SubmitMatch_PostgreSQLImpl
SystemAddress | Unique identifier for a system. Corresponds to a network address
DataStructures::Table | Holds a set of columns, a set of rows, and rows times columns cells. The table data structure is useful if you want to store a set of structures and perform queries on those structures This is a relatively simple and fast implementation of the types of tables commonly used in databases See TableSerializer to serialize data members of the table See LightweightDatabaseClient and LightweightDatabaseServer to transmit the table over the network
DataStructures::Table::Cell | Holds the actual data in the table
DataStructures::Table::ColumnDescriptor
DataStructures::Table::Row | Stores the list of cells for this row, and a special flag used for internal sorting
TelnetTransport | Use TelnetTransport to easily allow windows telnet to connect to your ConsoleServer To run Windows telnet, go to your start menu, click run, and in the edit box type "telnet <IP>" where <IP> is the ip address of your ConsoleServer (most likely the same IP as your game). This implementation always echos commands
ThreadPool< InputType, OutputType >
ThreadsafePacketLogger | Same as PacketLogger, but writes output in the user thread
TitleValidation_PostgreSQL
TitleValidationDBCBInterface | If you want to forward Functor::HandleResult() the output to a callback (which is what it does by default), you can use this
TransportInterface | Defines an interface that is used to send and receive null-terminated strings. In practice this is only used by the CommandParser system for for servers
LobbyDBSpec::UpdateEmailStatus_Data | Updates the mark flags on an email
LobbyDBSpec::UpdateUser_Data | Overwrites an existing user in the users table
TitleValidationDBSpec::UpdateUserKey_Data
VBRState
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::AddAccountNote_Data Class Reference

  • Class Hierarchy
  • Class Members
LobbyDBSpec::AddAccountNote_Data

LobbyDBSpec::AddAccountNote_Data Class Reference

Adds an entry to the accountNotes table for an existing user. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::AddAccountNote_Data:

RefCountedObj List of all members.

Public Attributes

RowIdOrHandle | id
[in] Which user
bool | writeModeratorId
[in] Write the variable moderatorId?
DatabaseKey | moderatorId
[in] internal ID of the moderator (does not have to be in the users table).
RakNet::RakString moderatorUsername
[in] internal username of the moderator (does not have to be in the users table)
RakNet::RakString type
[in] Type of account note (optional)
RakNet::RakString subject
[in] Subject of the account note (optional)
RakNet::RakString body
[in] Body of the account note (optional)
long long | time
[out] When this row was added to the database. Used by GetAccountNotes_Data only.
bool | userFound
[out] If the user was found in the database

Detailed Description

Adds an entry to the accountNotes table for an existing user.

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::AddFriend_Data Class Reference

LobbyDBSpec::AddFriend_Data

LobbyDBSpec::AddFriend_Data Class Reference

Adds a userId / friendId to the friends table. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::AddFriend_Data:

RefCountedObj List of all members.

Public Attributes

RowIdOrHandle | id
[in] Which user
RowIdOrHandle | friendId
[in] Which friend
long long | creationTime
[out] When this row was added to the database. Used by GetFriends_Data only.
bool | userFound
[out] If the user was found in the database
bool | friendFound
[out] If the friend was found in the database
bool | success
[out] If the query succeeded
RakNet::RakString queryResult
[out] Description of the query result.

Detailed Description

Adds a userId / friendId to the friends table.

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: TitleValidationDBSpec::AddTitle_Data Class Reference

TitleValidationDBSpec::AddTitle_Data

TitleValidationDBSpec::AddTitle_Data Class Reference

Adds a title to the database of titles. This can be used to look up titleIds given a title password. More...

#include <TitleValidationDBSpec.h>

Inheritance diagram for TitleValidationDBSpec::AddTitle_Data:

RefCountedObj List of all members.

Public Attributes

DatabaseKey | titleId
[out] Database id of the title.
RakNet::RakString titleName
[in] Name of the title
char * | titlePassword
[in] Password to use with the title (game servers should be provided this). Binary
int | titlePasswordLength
[in] Length of the binary data titlePassword
bool | allowClientAccountCreation
[in] Global permission (not per user): allow users to create accounts? Handled in the server code. If false, user accounts must be created on the server.
bool | lobbyIsGameIndependent
[in] Global permission (not per user): If allowLobbyChat==true, this flag controls if users can view/chat with users of any other game that also has this flag set.
bool | requireUserKeyToLogon
Should the server require that the user specify a cd key to login?
long long | creationDate
[out] Added automatically by the database on row entry. Parse with _localtime64()

Detailed Description

Adds a title to the database of titles. This can be used to look up titleIds given a title password.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/TitleValidationDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/TitleValidationDBSpec.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::AddToIgnoreList_Data Class Reference

LobbyDBSpec::AddToIgnoreList_Data

LobbyDBSpec::AddToIgnoreList_Data Class Reference

Adds to the ignoreList table for a particular userId / userHandle. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::AddToIgnoreList_Data:

RefCountedObj List of all members.

Public Attributes

RowIdOrHandle | id
[in] Which user
RakNet::RakString actions
bool | success
[out] If the query succeeded
RakNet::RakString queryResult
[out] Description of the query result.
long long | creationTime
[out] When this row was added to the database. Used by GetIgnoreList_Data only.

Detailed Description

Adds to the ignoreList table for a particular userId / userHandle.

Member Data Documentation

RakNet::RakString LobbyDBSpec::AddToIgnoreList_Data::actions

[in] If you want to specify particular actions to ignore, you can encode them into this string. [in] If this user is already in the ignore list, it will update actions

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: AutopatcherMySQLRepository Class Reference

AutopatcherMySQLRepository Class Reference

#include <AutopatcherMySQLRepository.h>

Inheritance diagram for AutopatcherMySQLRepository:

AutopatcherRepositoryInterface List of all members.

Public Member Functions

bool | CreateAutopatcherTables (void)
bool | DestroyAutopatcherTables (void)
bool | AddApplication (const char *applicationName, const char *userName)
bool | RemoveApplication (const char *applicationName)
bool | UpdateApplicationFiles (const char *applicationName, const char *applicationDirectory, const char *userName, FileListProgress *cb)
virtual bool | GetChangelistSinceDate (const char *applicationName, FileList *addedFiles, FileList *deletedFiles, const char *sinceDate, char currentDate[64])
virtual bool | GetPatches (const char *applicationName, FileList *input, FileList *patchList, char currentDate[64])
virtual const char * | GetLastError (void) const
If any of the above functions fail, the error string is stored internally. Call this to get it.

Detailed Description

An implementation of the AutopatcherRepositoryInterface to use MySQL to store the relevant data

Member Function Documentation

bool AutopatcherMySQLRepository::CreateAutopatcherTables ( void )

Create the tables used by the autopatcher, for all applications. Call this first.

Returns:
True on success, false on failure.

bool AutopatcherMySQLRepository::DestroyAutopatcherTables ( void )

Destroy the tables used by the autopatcher. Don't call this unless you don't want to use the autopatcher anymore, or are testing.

Returns:
True on success, false on failure.

bool AutopatcherMySQLRepository::AddApplication | ( | const char * | applicationName,
 |  | const char * | userName
 | ) |  |

Add an application for use by files. Call this second.

Parameters:
[in] | applicationName | A null terminated string.
[in] | userName | Stored in the database, but otherwise unused. Useful to track who added this application.
Returns:
True on success, false on failure.

bool AutopatcherMySQLRepository::RemoveApplication ( const char * applicationName )

Remove an application and files used by that application.

Parameters:
[in] applicationName A null terminated string previously passed to AddApplication
Returns:
True on success, false on failure.

bool AutopatcherMySQLRepository::UpdateApplicationFiles | ( | const char * | applicationName,
 |  | const char * | applicationDirectory,
 |  | const char * | userName,
 |  | FileListProgress * | cb
 | ) |  |

Update all the files for an application to match what is at the specified directory. Call this third. Be careful not to call this with the wrong directory. This is implemented in a Begin and Rollback block so you won't a messed up database from get partial updates.

Parameters:
[in] | applicationName | A null terminated string previously passed to AddApplication
[in] | applicationDirectory | The base directory of your application. All files in this directory and subdirectories are added.
[in] | userName | Stored in the database, but otherwise unused. Useful to track who added this revision
[in] | cb | Callback to get progress updates. Pass 0 to not use.
Returns:
True on success, false on failure.

bool AutopatcherMySQLRepository::GetChangelistSinceDate | ( | const char * | applicationName,
 |  | FileList * | addedFiles,
 |  | FileList * | deletedFiles,
 |  | const char * | sinceDate,
 |  | char | currentDate[64] |
 | ) |  |  | [virtual]

Get list of files added and deleted since a certain date. This is used by AutopatcherServer and not usually explicitly called.

Parameters:
[in] | applicationName | A null terminated string previously passed to AddApplication
[out] | addedFiles | A list of the current versions of filenames with SHA1_LENGTH byte hashes as their data that were created after sinceData
[out] | deletedFiles | A list of the current versions of filenames that were deleted after sinceData
[in] | An | input date, in the string format of a timestamp.
[out] | currentDate | The server date, in the string format of a timestamp.
Returns:
True on success, false on failure.

Implements AutopatcherRepositoryInterface.

bool AutopatcherMySQLRepository::GetPatches | ( | const char * | applicationName,
 |  | FileList * | input,
 |  | FileList * | patchList,
 |  | char | currentDate[64] |
 | ) |  |  | [virtual]

Get patches (or files) for every file in input, assuming that input has a hash for each of those files. This is used by AutopatcherServer and not usually explicitly called.

Parameters:
[in] | applicationName | A null terminated string previously passed to AddApplication
[in] | input | A list of files with hashes to get from the database. If this hash exists, a patch to the current version is returned if this file is not the current version. Otherwise the current version is returned.
[out] | patchList | A list of files with either the filedata or the patch. This is a subset of input. The context data for each file will be either PC_WRITE_FILE (to just write the file) or PC_HASH_WITH_PATCH (to patch). If PC_HASH_WITH_PATCH, then the file contains a SHA1_LENGTH byte patch followed by the hash. The datalength is patchlength + SHA1_LENGTH
[out] | currentDate | The current server date, in whatever format your repository uses
Returns:
True on success, false on failure.

Implements AutopatcherRepositoryInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/AutopatcherMySQLRepository/AutopatcherMySQLRepository.h
  • C:/RakNet/DependentExtensions/AutopatcherMySQLRepository/AutopatcherMySQLRepository.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: AutopatcherPostgreRepository Class Reference

AutopatcherPostgreRepository Class Reference

#include <AutopatcherPostgreRepository.h>

Inheritance diagram for AutopatcherPostgreRepository:

AutopatcherRepositoryInterface List of all members.

Public Member Functions

bool | CreateAutopatcherTables (void)
bool | DestroyAutopatcherTables (void)
bool | AddApplication (const char *applicationName, const char *userName)
bool | RemoveApplication (const char *applicationName)
bool | UpdateApplicationFiles (const char *applicationName, const char *applicationDirectory, const char *userName, FileListProgress *cb)
virtual bool | GetChangelistSinceDate (const char *applicationName, FileList *addedFiles, FileList *deletedFiles, const char *sinceDate, char currentDate[64])
virtual bool | GetPatches (const char *applicationName, FileList *input, FileList *patchList, char currentDate[64])
virtual const char * | GetLastError (void) const
If any of the above functions fail, the error string is stored internally. Call this to get it.

Detailed Description

An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data

Member Function Documentation

bool AutopatcherPostgreRepository::CreateAutopatcherTables ( void )

Create the tables used by the autopatcher, for all applications. Call this first.

Returns:
True on success, false on failure.

bool AutopatcherPostgreRepository::DestroyAutopatcherTables ( void )

Destroy the tables used by the autopatcher. Don't call this unless you don't want to use the autopatcher anymore, or are testing.

Returns:
True on success, false on failure.

bool AutopatcherPostgreRepository::AddApplication | ( | const char * | applicationName,
 |  | const char * | userName
 | ) |  |

Add an application for use by files. Call this second.

Parameters:
[in] | applicationName | A null terminated string.
[in] | userName | Stored in the database, but otherwise unused. Useful to track who added this application.
Returns:
True on success, false on failure.

bool AutopatcherPostgreRepository::RemoveApplication ( const char * applicationName )

Remove an application and files used by that application.

Parameters:
[in] applicationName A null terminated string previously passed to AddApplication
Returns:
True on success, false on failure.

bool AutopatcherPostgreRepository::UpdateApplicationFiles | ( | const char * | applicationName,
 |  | const char * | applicationDirectory,
 |  | const char * | userName,
 |  | FileListProgress * | cb
 | ) |  |

Update all the files for an application to match what is at the specified directory. Call this third. Be careful not to call this with the wrong directory. This is implemented in a Begin and Rollback block so you won't a messed up database from get partial updates.

Parameters:
[in] | applicationName | A null terminated string previously passed to AddApplication
[in] | applicationDirectory | The base directory of your application. All files in this directory and subdirectories are added.
[in] | userName | Stored in the database, but otherwise unused. Useful to track who added this revision
[in] | cb | Callback to get progress updates. Pass 0 to not use.
Returns:
True on success, false on failure.

bool AutopatcherPostgreRepository::GetChangelistSinceDate | ( | const char * | applicationName,
 |  | FileList * | addedFiles,
 |  | FileList * | deletedFiles,
 |  | const char * | sinceDate,
 |  | char | currentDate[64] |
 | ) |  |  | [virtual]

Get list of files added and deleted since a certain date. This is used by AutopatcherServer and not usually explicitly called.

Parameters:
[in] | applicationName | A null terminated string previously passed to AddApplication
[out] | addedFiles | A list of the current versions of filenames with SHA1_LENGTH byte hashes as their data that were created after sinceData
[out] | deletedFiles | A list of the current versions of filenames that were deleted after sinceData
[in] | An | input date, in the string format of a timestamp.
[out] | currentDate | The server date, in the string format of a timestamp.
Returns:
True on success, false on failure.

Implements AutopatcherRepositoryInterface.

bool AutopatcherPostgreRepository::GetPatches | ( | const char * | applicationName,
 |  | FileList * | input,
 |  | FileList * | patchList,
 |  | char | currentDate[64] |
 | ) |  |  | [virtual]

Get patches (or files) for every file in input, assuming that input has a hash for each of those files. This is used by AutopatcherServer and not usually explicitly called.

Parameters:
[in] | applicationName | A null terminated string previously passed to AddApplication
[in] | input | A list of files with hashes to get from the database. If this hash exists, a patch to the current version is returned if this file is not the current version. Otherwise the current version is returned.
[out] | patchList | A list of files with either the filedata or the patch. This is a subset of input. The context data for each file will be either PC_WRITE_FILE (to just write the file) or PC_HASH_WITH_PATCH (to patch). If PC_HASH_WITH_PATCH, then the file contains a SHA1_LENGTH byte patch followed by the hash. The datalength is patchlength + SHA1_LENGTH
[out] | currentDate | The current server date, in whatever format your repository uses
Returns:
True on success, false on failure.

Implements AutopatcherRepositoryInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/AutopatcherPostgreRepository/AutopatcherPostgreRepository.h
  • C:/RakNet/DependentExtensions/AutopatcherPostgreRepository/AutopatcherPostgreRepository.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: AutopatcherRepositoryInterface Class Reference

AutopatcherRepositoryInterface Class Reference

An interface used by AutopatcherServer to get the data necessary to run an autopatcher. This is up to you to implement for custom repository solutions. More...

#include <AutopatcherRepositoryInterface.h>

Inheritance diagram for AutopatcherRepositoryInterface:

AutopatcherMySQLRepository AutopatcherPostgreRepository List of all members.

Public Member Functions

virtual bool | GetChangelistSinceDate (const char *applicationName, FileList *addedFiles, FileList *deletedFiles, const char *sinceDate, char currentDate[64])=0
virtual bool | GetPatches (const char *applicationName, FileList *input, FileList *patchList, char currentDate[64])=0
virtual const char * | GetLastError (void) const =0
Returns:
Whatever this function returns is sent from the AutopatcherServer to the AutopatcherClient when one of the above functions returns false.

Detailed Description

An interface used by AutopatcherServer to get the data necessary to run an autopatcher. This is up to you to implement for custom repository solutions.

Member Function Documentation

virtual bool AutopatcherRepositoryInterface::GetChangelistSinceDate | ( | const char * | applicationName,
 |  | FileList * | addedFiles,
 |  | FileList * | deletedFiles,
 |  | const char * | sinceDate,
 |  | char | currentDate[64] |
 | ) |  |  | [pure virtual]

Get list of files added and deleted since a certain date. This is used by AutopatcherServer and not usually explicitly called.

Parameters:
[in] | applicationName | A null terminated string identifying the application
[out] | addedFiles | A list of the current versions of filenames with hashes as their data that were created after sinceData
[out] | deletedFiles | A list of the current versions of filenames that were deleted after sinceData
[in] | An | input date, in whatever format your repository uses
[out] | currentDate | The current server date, in whatever format your repository uses
Returns:
True on success, false on failure.

Implemented in AutopatcherMySQLRepository, and AutopatcherPostgreRepository.

virtual bool AutopatcherRepositoryInterface::GetPatches | ( | const char * | applicationName,
 |  | FileList * | input,
 |  | FileList * | patchList,
 |  | char | currentDate[64] |
 | ) |  |  | [pure virtual]

Get patches (or files) for every file in input, assuming that input has a hash for each of those files.

Parameters:
[in] | applicationName | A null terminated string identifying the application
[in] | input | A list of files with SHA1_LENGTH byte hashes to get from the database.
[out] | patchList | You should return list of files with either the filedata or the patch. This is a subset of input. The context data for each file will be either PC_WRITE_FILE (to just write the file) or PC_HASH_WITH_PATCH (to patch). If PC_HASH_WITH_PATCH, then the file contains a SHA1_LENGTH byte patch followed by the hash. The datalength is patchlength + SHA1_LENGTH
[out] | currentDate | The current server date, in whatever format your repository uses
Returns:
True on success, false on failure.

Implemented in AutopatcherMySQLRepository, and AutopatcherPostgreRepository.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/AutopatcherRepositoryInterface.h
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::AutoRPC Class Reference

RakNet::AutoRPC

RakNet::AutoRPC Class Reference
[AutoRPC]

#include <AutoRPC.h>

Inheritance diagram for RakNet::AutoRPC:

PluginInterface List of all members.

Public Member Functions

AutoRPC ()
Constructor.
virtual | ~AutoRPC ()
Destructor.
void | SetNetworkIDManager (NetworkIDManager *idMan)
bool | RegisterFunction (const char *uniqueIdentifier, void *functionPtr, bool isObjectMember, char parameterCount=-1)
bool | UnregisterFunction (const char *uniqueIdentifier, bool isObjectMember)
void | SetTimestamp (RakNetTime timeStamp)
void | SetSendParams (PacketPriority priority, PacketReliability reliability, char orderingChannel)
void | SetRecipientAddress (SystemAddress systemAddress, bool broadcast)
void | SetRecipientObject (NetworkID networkID)
RakNet::BitStream * | SetOutgoingExtraData (void)
RakNetTime | GetLastSenderTimestamp (void) const
SystemAddress | GetLastSenderAddress (void) const
RakPeerInterface * | GetRakPeer (void) const
Returns the instance of RakPeer this plugin was attached to.
const char * | GetCurrentExecution (void) const
RakNet::BitStream * | GetIncomingExtraData (void)
bool | Call (const char *uniqueIdentifier)
template<class P1>
bool | Call (const char *uniqueIdentifier, P1 p1)
template<class P1, class P2>
bool | Call (const char *uniqueIdentifier, P1 p1, P2 p2)
template<class P1, class P2, class P3>
bool | Call (const char *uniqueIdentifier, P1 p1, P2 p2, P3 p3)
template<class P1, class P2, class P3, class P4>
bool | Call (const char *uniqueIdentifier, P1 p1, P2 p2, P3 p3, P4 p4)
template<class P1, class P2, class P3, class P4, class P5>
bool | Call (const char *uniqueIdentifier, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5)
template<class P1, class P2, class P3, class P4, class P5, class P6>
bool | Call (const char *uniqueIdentifier, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5, P6 p6)
template<class P1, class P2, class P3, class P4, class P5, class P6, class P7>
bool | Call (const char *uniqueIdentifier, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5, P6 p6, P7 p7)
template<class P1, class P2, class P3, class P4, class P5, class P6, class P7, class P8>
bool | Call (const char *uniqueIdentifier, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5, P6 p6, P7 p7, P8 p8)
bool | CallExplicit (const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID)
template<class P1>
bool | CallExplicit (const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1)
template<class P1, class P2>
bool | CallExplicit (const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2)
template<class P1, class P2, class P3>
bool | CallExplicit (const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2, P3 p3)
template<class P1, class P2, class P3, class P4>
bool | CallExplicit (const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2, P3 p3, P4 p4)
template<class P1, class P2, class P3, class P4, class P5>
bool | CallExplicit (const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5)
template<class P1, class P2, class P3, class P4, class P5, class P6>
bool | CallExplicit (const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5, P6 p6)
template<class P1, class P2, class P3, class P4, class P5, class P6, class P7>
bool | CallExplicit (const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5, P6 p6, P7 p7)
template<class P1, class P2, class P3, class P4, class P5, class P6, class P7, class P8>
bool | CallExplicit (const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5, P6 p6, P7 p7, P8 p8)

Protected Member Functions

void | OnAttach (RakPeerInterface *peer)
virtual PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
virtual void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)
virtual void | OnShutdown (RakPeerInterface *peer)

Detailed Description

The AutoRPC plugin allows you to call remote functions as if they were local functions, using the standard function call syntax No serialization or deserialization is needed. Advantages are that this is easier to use than regular RPC system. Disadvantages is that all parameters must be passable on the stack using memcpy (shallow copy). For other types of parameters, use SetOutgoingExtraData() and GetIncomingExtraData() Pointers are automatically dereferenced and the contents copied with memcpy Use the old system, or regular message passing, if you need greater flexibility
Note:
Semi-depreciated. Use DependentExtensions unless you do not want to link with Boost

Member Function Documentation

void AutoRPC::SetNetworkIDManager ( NetworkIDManager * idMan )

Sets the network ID manager to use for object lookup Required to call C++ object member functions via SetRecipientObject()

Parameters:
[in] idMan Pointer to the network ID manager to use

bool AutoRPC::RegisterFunction | ( | const char * | uniqueIdentifier,
 |  | void * | functionPtr,
 |  | bool | isObjectMember,
 |  | char | parameterCount = -1
 | ) |  |

Registers a function pointer to be callable given an identifier for the pointer.

Parameters:
[in] | uniqueIdentifier | String identifying the function. Recommended that this is the name of the function
[in] | functionPtr | Pointer to the function. For C, just pass the name of the function. For C++, use ARPC_REGISTER_CPP_FUNCTION
[in] | isObjectMember | false if a C function. True if a member function of an object (C++)
[in] | parameterCount | Optional parameter to tell the system how many parameters this function has. If specified, and the wrong number of parameters are called by the remote system, the call is rejected. -1 indicates undefined
Returns:
True on success, false on uniqueIdentifier already used
Note:
Only use this for C functions; for C++ use one of the ARPC_REGISTER_CPP_FUNCTION_XXX macros

bool AutoRPC::UnregisterFunction | ( | const char * | uniqueIdentifier,
 |  | bool | isObjectMember
 | ) |  |

Unregisters a function pointer to be callable given an identifier for the pointer

Note:
This is not safe to call while connected
Parameters:
[in] | uniqueIdentifier | String identifying the function.
[in] | isObjectMember | false if a C function. True if a member function of an object (C++)
Returns:
True on success, false on function was not previously or is not currently registered.

void AutoRPC::SetTimestamp ( RakNetTime timeStamp )

Send or stop sending a timestamp with all following calls to Call() Use GetLastSenderTimestamp() to read the timestamp.

Parameters:
[in] timeStamp Non-zero to pass this timestamp using the ID_TIMESTAMP system. 0 to clear passing a timestamp.

void AutoRPC::SetSendParams | ( | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel
 | ) |  |

Set parameters to pass to RakPeer::Send() for all following calls to Call() Deafults to HIGH_PRIORITY, RELIABLE_ORDERED, ordering channel 0

Parameters:
[in] | priority | See RakPeer::Send()
[in] | reliability | See RakPeer::Send()
[in] | orderingChannel | See RakPeer::Send()

void AutoRPC::SetRecipientAddress | ( | SystemAddress | systemAddress,
 |  | bool | broadcast
 | ) |  |

Set system to send to for all following calls to Call() Defaults to UNASSIGNED_SYSTEM_ADDRESS, broadcast=true

Parameters:
[in] | systemAddress | See RakPeer::Send()
[in] | broadcast | See RakPeer::Send()

void AutoRPC::SetRecipientObject ( NetworkID networkID )

Set the NetworkID to pass for all following calls to Call() Defaults to UNASSIGNED_NETWORK_ID (none) If set, the remote function will be considered a C++ function, e.g. an object member function If set to UNASSIGNED_NETWORK_ID (none), the remote function will be considered a C function If this is set incorrectly, you will get back either RPC_ERROR_CALLING_C_AS_CPP or RPC_ERROR_CALLING_CPP_AS_C

See also:
NetworkIDManager
Parameters:
[in] networkID Returned from NetworkIDObject::GetNetworkID()

RakNet::BitStream * AutoRPC::SetOutgoingExtraData ( void )

Write extra data to pass for all following calls to Call() Use BitStream::Reset to clear extra data. Don't forget to do this or you will waste bandwidth.

Returns:
A bitstream you can write to to send extra data with each following call to Call()

RakNetTime AutoRPC::GetLastSenderTimestamp ( void ) const

If the last received function call has a timestamp included, it is stored and can be retrieved with this function.

Returns:
0 if the last call did not have a timestamp, else non-zero

SystemAddress AutoRPC::GetLastSenderAddress ( void ) const

Returns the system address of the last system to send us a received function call Equivalent to the old system RPCParameters::sender

Returns:
Last system to send an RPC call using this system

const char * AutoRPC::GetCurrentExecution ( void ) const

Returns the currently running RPC call identifier, set from RegisterFunction::uniqueIdentifier Returns an empty string "" if none

Returns:
which RPC call is currently running

RakNet::BitStream * AutoRPC::GetIncomingExtraData ( void )

Gets the bitstream written to via SetOutgoingExtraData(). Data is updated with each incoming function call

Returns:
A bitstream you can read from with extra data that was written with SetOutgoingExtraData();

bool RakNet::AutoRPC::Call ( const char * uniqueIdentifier ) [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] uniqueIdentifier parameter of the same name passed to RegisterFunction() on the remote system

template<class P1>
bool RakNet::AutoRPC::Call | ( | const char * | uniqueIdentifier,
 |  | P1 | p1 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] uniqueIdentifier parameter of the same name passed to RegisterFunction() on the remote system

template<class P1, class P2>
bool RakNet::AutoRPC::Call | ( | const char * | uniqueIdentifier,
 |  | P1 | p1,
 |  | P2 | p2 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] uniqueIdentifier parameter of the same name passed to RegisterFunction() on the remote system

template<class P1, class P2, class P3>
bool RakNet::AutoRPC::Call | ( | const char * | uniqueIdentifier,
 |  | P1 | p1,
 |  | P2 | p2,
 |  | P3 | p3 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] uniqueIdentifier parameter of the same name passed to RegisterFunction() on the remote system

template<class P1, class P2, class P3, class P4>
bool RakNet::AutoRPC::Call | ( | const char * | uniqueIdentifier,
 |  | P1 | p1,
 |  | P2 | p2,
 |  | P3 | p3,
 |  | P4 | p4 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] uniqueIdentifier parameter of the same name passed to RegisterFunction() on the remote system

template<class P1, class P2, class P3, class P4, class P5>
bool RakNet::AutoRPC::Call | ( | const char * | uniqueIdentifier,
 |  | P1 | p1,
 |  | P2 | p2,
 |  | P3 | p3,
 |  | P4 | p4,
 |  | P5 | p5 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] uniqueIdentifier parameter of the same name passed to RegisterFunction() on the remote system

template<class P1, class P2, class P3, class P4, class P5, class P6>
bool RakNet::AutoRPC::Call | ( | const char * | uniqueIdentifier,
 |  | P1 | p1,
 |  | P2 | p2,
 |  | P3 | p3,
 |  | P4 | p4,
 |  | P5 | p5,
 |  | P6 | p6 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] uniqueIdentifier parameter of the same name passed to RegisterFunction() on the remote system

template<class P1, class P2, class P3, class P4, class P5, class P6, class P7>
bool RakNet::AutoRPC::Call | ( | const char * | uniqueIdentifier,
 |  | P1 | p1,
 |  | P2 | p2,
 |  | P3 | p3,
 |  | P4 | p4,
 |  | P5 | p5,
 |  | P6 | p6,
 |  | P7 | p7 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] uniqueIdentifier parameter of the same name passed to RegisterFunction() on the remote system

template<class P1, class P2, class P3, class P4, class P5, class P6, class P7, class P8>
bool RakNet::AutoRPC::Call | ( | const char * | uniqueIdentifier,
 |  | P1 | p1,
 |  | P2 | p2,
 |  | P3 | p3,
 |  | P4 | p4,
 |  | P5 | p5,
 |  | P6 | p6,
 |  | P7 | p7,
 |  | P8 | p8 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] uniqueIdentifier parameter of the same name passed to RegisterFunction() on the remote system

bool RakNet::AutoRPC::CallExplicit | ( | const char * | uniqueIdentifier,
 |  | RakNetTime | timeStamp,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | NetworkID | networkID |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] | uniqueIdentifier | parameter of the same name passed to RegisterFunction() on the remote system
[in] | timeStamp | See SetTimestamp()
[in] | priority | See SetSendParams()
[in] | reliability | See SetSendParams()
[in] | orderingChannel | See SetSendParams()
[in] | systemAddress | See SetRecipientAddress()
[in] | broadcast | See SetRecipientAddress()
[in] | networkID | See SetRecipientObject()

template<class P1>
bool RakNet::AutoRPC::CallExplicit | ( | const char * | uniqueIdentifier,
 |  | RakNetTime | timeStamp,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | NetworkID | networkID,
 |  | P1 | p1 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] | uniqueIdentifier | parameter of the same name passed to RegisterFunction() on the remote system
[in] | timeStamp | See SetTimestamp()
[in] | priority | See SetSendParams()
[in] | reliability | See SetSendParams()
[in] | orderingChannel | See SetSendParams()
[in] | systemAddress | See SetRecipientAddress()
[in] | broadcast | See SetRecipientAddress()
[in] | networkID | See SetRecipientObject()

template<class P1, class P2>
bool RakNet::AutoRPC::CallExplicit | ( | const char * | uniqueIdentifier,
 |  | RakNetTime | timeStamp,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | NetworkID | networkID,
 |  | P1 | p1,
 |  | P2 | p2 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] | uniqueIdentifier | parameter of the same name passed to RegisterFunction() on the remote system
[in] | timeStamp | See SetTimestamp()
[in] | priority | See SetSendParams()
[in] | reliability | See SetSendParams()
[in] | orderingChannel | See SetSendParams()
[in] | systemAddress | See SetRecipientAddress()
[in] | broadcast | See SetRecipientAddress()
[in] | networkID | See SetRecipientObject()

template<class P1, class P2, class P3>
bool RakNet::AutoRPC::CallExplicit | ( | const char * | uniqueIdentifier,
 |  | RakNetTime | timeStamp,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | NetworkID | networkID,
 |  | P1 | p1,
 |  | P2 | p2,
 |  | P3 | p3 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] | uniqueIdentifier | parameter of the same name passed to RegisterFunction() on the remote system
[in] | timeStamp | See SetTimestamp()
[in] | priority | See SetSendParams()
[in] | reliability | See SetSendParams()
[in] | orderingChannel | See SetSendParams()
[in] | systemAddress | See SetRecipientAddress()
[in] | broadcast | See SetRecipientAddress()
[in] | networkID | See SetRecipientObject()

template<class P1, class P2, class P3, class P4>
bool RakNet::AutoRPC::CallExplicit | ( | const char * | uniqueIdentifier,
 |  | RakNetTime | timeStamp,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | NetworkID | networkID,
 |  | P1 | p1,
 |  | P2 | p2,
 |  | P3 | p3,
 |  | P4 | p4 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] | uniqueIdentifier | parameter of the same name passed to RegisterFunction() on the remote system
[in] | timeStamp | See SetTimestamp()
[in] | priority | See SetSendParams()
[in] | reliability | See SetSendParams()
[in] | orderingChannel | See SetSendParams()
[in] | systemAddress | See SetRecipientAddress()
[in] | broadcast | See SetRecipientAddress()
[in] | networkID | See SetRecipientObject()

template<class P1, class P2, class P3, class P4, class P5>
bool RakNet::AutoRPC::CallExplicit | ( | const char * | uniqueIdentifier,
 |  | RakNetTime | timeStamp,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | NetworkID | networkID,
 |  | P1 | p1,
 |  | P2 | p2,
 |  | P3 | p3,
 |  | P4 | p4,
 |  | P5 | p5 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] | uniqueIdentifier | parameter of the same name passed to RegisterFunction() on the remote system
[in] | timeStamp | See SetTimestamp()
[in] | priority | See SetSendParams()
[in] | reliability | See SetSendParams()
[in] | orderingChannel | See SetSendParams()
[in] | systemAddress | See SetRecipientAddress()
[in] | broadcast | See SetRecipientAddress()
[in] | networkID | See SetRecipientObject()

template<class P1, class P2, class P3, class P4, class P5, class P6>
bool RakNet::AutoRPC::CallExplicit | ( | const char * | uniqueIdentifier,
 |  | RakNetTime | timeStamp,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | NetworkID | networkID,
 |  | P1 | p1,
 |  | P2 | p2,
 |  | P3 | p3,
 |  | P4 | p4,
 |  | P5 | p5,
 |  | P6 | p6 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] | uniqueIdentifier | parameter of the same name passed to RegisterFunction() on the remote system
[in] | timeStamp | See SetTimestamp()
[in] | priority | See SetSendParams()
[in] | reliability | See SetSendParams()
[in] | orderingChannel | See SetSendParams()
[in] | systemAddress | See SetRecipientAddress()
[in] | broadcast | See SetRecipientAddress()
[in] | networkID | See SetRecipientObject()

template<class P1, class P2, class P3, class P4, class P5, class P6, class P7>
bool RakNet::AutoRPC::CallExplicit | ( | const char * | uniqueIdentifier,
 |  | RakNetTime | timeStamp,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | NetworkID | networkID,
 |  | P1 | p1,
 |  | P2 | p2,
 |  | P3 | p3,
 |  | P4 | p4,
 |  | P5 | p5,
 |  | P6 | p6,
 |  | P7 | p7 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] | uniqueIdentifier | parameter of the same name passed to RegisterFunction() on the remote system
[in] | timeStamp | See SetTimestamp()
[in] | priority | See SetSendParams()
[in] | reliability | See SetSendParams()
[in] | orderingChannel | See SetSendParams()
[in] | systemAddress | See SetRecipientAddress()
[in] | broadcast | See SetRecipientAddress()
[in] | networkID | See SetRecipientObject()

template<class P1, class P2, class P3, class P4, class P5, class P6, class P7, class P8>
bool RakNet::AutoRPC::CallExplicit | ( | const char * | uniqueIdentifier,
 |  | RakNetTime | timeStamp,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | NetworkID | networkID,
 |  | P1 | p1,
 |  | P2 | p2,
 |  | P3 | p3,
 |  | P4 | p4,
 |  | P5 | p5,
 |  | P6 | p6,
 |  | P7 | p7,
 |  | P8 | p8 |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are passed via memcpy and pushed on the stack for the remote function

Note:
This ONLY works with variables that are passable via memcpy! If you need more flexibility, use SetOutgoingExtraData() and GetIncomingExtraData()

The this pointer, for this instance of AutoRPC, is pushed as the last parameter on the stack. See AutoRPCSample.ccp for an example of this

Parameters:
[in] | uniqueIdentifier | parameter of the same name passed to RegisterFunction() on the remote system
[in] | timeStamp | See SetTimestamp()
[in] | priority | See SetSendParams()
[in] | reliability | See SetSendParams()
[in] | orderingChannel | See SetSendParams()
[in] | systemAddress | See SetRecipientAddress()
[in] | broadcast | See SetRecipientAddress()
[in] | networkID | See SetRecipientObject()

void AutoRPC::OnAttach ( RakPeerInterface * peer ) [protected, virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult AutoRPC::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [protected, virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void AutoRPC::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [protected, virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

void AutoRPC::OnShutdown ( RakPeerInterface * peer ) [protected, virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/AutoRPC.h
  • C:/RakNet/Source/AutoRPC.cpp
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType > Class Template Reference

DataStructures::AVLBalancedBinarySearchTree

DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType > Class Template Reference

An AVLBalancedBinarySearchTree is a binary tree that is always balanced. More...

#include <DS_BinarySearchTree.h>

Inheritance diagram for DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType >:

DataStructures::BinarySearchTree< BinarySearchTreeType > List of all members.

Detailed Description

template<class BinarySearchTreeType>
class DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType >

An AVLBalancedBinarySearchTree is a binary tree that is always balanced.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/DS_BinarySearchTree.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::BinarySearchTree< BinarySearchTreeType > Class Template Reference

DataStructures::BinarySearchTree

DataStructures::BinarySearchTree< BinarySearchTreeType > Class Template Reference

A binary search tree and an AVL balanced binary search tree. More...

#include <DS_BinarySearchTree.h>

Inheritance diagram for DataStructures::BinarySearchTree< BinarySearchTreeType >:

DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType > List of all members.

Detailed Description

template<class BinarySearchTreeType>
class DataStructures::BinarySearchTree< BinarySearchTreeType >

A binary search tree and an AVL balanced binary search tree.

Initilize with the following structure

BinarySearchTree<TYPE>

OR

AVLBalancedBinarySearchTree<TYPE>

Use the AVL balanced tree if you want the tree to be balanced after every deletion and addition. This avoids the potential worst case scenario where ordered input to a binary search tree gives linear search time results. It's not needed if input will be evenly distributed, in which case the search time is O (log n). The search time for the AVL balanced binary tree is O (log n) irregardless of input.

Has the following member functions unsigned int Height(<index>) - Returns the height of the tree at the optional specified starting index. Default is the root add(element) - adds an element to the BinarySearchTree bool del(element) - deletes the node containing element if the element is in the tree as defined by a comparison with the == operator. Returns true on success, false if the element is not found bool IsInelement) - returns true if element is in the tree as defined by a comparison with the == operator. Otherwise returns false DisplayInorder(array) - Fills an array with an inorder search of the elements in the tree. USER IS REPONSIBLE FOR ALLOCATING THE ARRAY!. DisplayPreorder(array) - Fills an array with an preorder search of the elements in the tree. USER IS REPONSIBLE FOR ALLOCATING THE ARRAY!. DisplayPostorder(array) - Fills an array with an postorder search of the elements in the tree. USER IS REPONSIBLE FOR ALLOCATING THE ARRAY!. DisplayBreadthFirstSearch(array) - Fills an array with a breadth first search of the elements in the tree. USER IS REPONSIBLE FOR ALLOCATING THE ARRAY!. clear - Destroys the tree. Same as calling the destructor unsigned int Height() - Returns the height of the tree unsigned int size() - returns the size of the BinarySearchTree GetPointerToNode(element) - returns a pointer to the comparision element in the tree, allowing for direct modification when necessary with complex data types. Be warned, it is possible to corrupt the tree if the element used for comparisons is modified. Returns NULL if the item is not found

EXAMPLE

 BinarySearchTree<int> A;
 A.Add(10);
 A.Add(15);
 A.Add(5);
 int* array = new int [A.Size()];
 A.DisplayInorder(array);
 array[0]; // returns 5
 array[1]; // returns 10
 array[2]; // returns 15
compress - reallocates memory to fit the number of elements. Best used when the number of elements decreases

clear - empties the BinarySearchTree and returns storage The assignment and copy constructors are defined

Note:
The template type must have the copy constructor and assignment operator defined and must work with >, <, and == All elements in the tree MUST be distinct The assignment operator is defined between BinarySearchTree and AVLBalancedBinarySearchTree as long as they are of the same template type. However, passing a BinarySearchTree to an AVLBalancedBinarySearchTree will lose its structure unless it happened to be AVL balanced to begin with Requires queue_linked_list.cpp for the breadth first search used in the copy constructor, overloaded assignment operator, and display_breadth_first_search.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/DS_BinarySearchTree.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::BitStream Class Reference

RakNet::BitStream

RakNet::BitStream Class Reference

#include <BitStream.h>

List of all members.

Public Member Functions

BitStream ()
Default Constructor.
BitStream (const unsigned int initialBytesToAllocate)
BitStream (unsigned char *_data, const unsigned int lengthInBytes, bool _copyData)
~BitStream ()
Destructor.
void | Reset (void)
Resets the bitstream for reuse.
template<class templateType>
bool | Serialize (bool writeToBitstream, templateType &var)
template<class templateType>
bool | SerializeDelta (bool writeToBitstream, templateType &currentValue, templateType lastValue)
template<class templateType>
bool | SerializeDelta (bool writeToBitstream, templateType &currentValue)
template<class templateType>
bool | SerializeCompressed (bool writeToBitstream, templateType &var)
template<class templateType>
bool | SerializeCompressedDelta (bool writeToBitstream, templateType &currentValue, templateType lastValue)
template<class templateType>
bool | SerializeCompressedDelta (bool writeToBitstream, templateType &currentValue)
Save as SerializeCompressedDelta(templateType &currentValue, templateType lastValue) when we have an unknown second parameter.
bool | Serialize (bool writeToBitstream, char *input, const unsigned int numberOfBytes)
template<class templateType>
bool | SerializeNormVector (bool writeToBitstream, templateType &x, templateType &y, templateType &z)
template<class templateType>
bool | SerializeVector (bool writeToBitstream, templateType &x, templateType &y, templateType &z)
template<class templateType>
bool | SerializeNormQuat (bool writeToBitstream, templateType &w, templateType &x, templateType &y, templateType &z)
template<class templateType>
bool | SerializeOrthMatrix (bool writeToBitstream, templateType &m00, templateType &m01, templateType &m02, templateType &m10, templateType &m11, templateType &m12, templateType &m20, templateType &m21, templateType &m22)
bool | SerializeBits (bool writeToBitstream, unsigned char *input, const BitSize_t numberOfBitsToSerialize, const bool rightAlignedBits=true)
template<class templateType>
void | Write (templateType var)
template<class templateType>
void | WritePtr (templateType *var)
template<class templateType>
void | WriteDelta (templateType currentValue, templateType lastValue)
template<class templateType>
void | WriteDelta (templateType currentValue)
template<class templateType>
void | WriteCompressed (templateType var)
template<class templateType>
void | WriteCompressedDelta (templateType currentValue, templateType lastValue)
template<class templateType>
void | WriteCompressedDelta (templateType currentValue)
Save as WriteCompressedDelta(templateType currentValue, templateType lastValue) when we have an unknown second parameter.
template<class templateType>
bool | Read (templateType &var)
template<class templateType>
bool | ReadPtr (templateType *var)
template<class templateType>
bool | ReadDelta (templateType &var)
template<class templateType>
bool | ReadCompressed (templateType &var)
template<class templateType>
bool | ReadCompressedDelta (templateType &var)
bool | Read (BitStream *bitStream, BitSize_t numberOfBits)
void | Write (const char *input, const unsigned int numberOfBytes)
void | Write (BitStream *bitStream, BitSize_t numberOfBits)
template<class templateType>
void | WriteNormVector (templateType x, templateType y, templateType z)
template<class templateType>
void | WriteVector (templateType x, templateType y, templateType z)
template<class templateType>
void | WriteNormQuat (templateType w, templateType x, templateType y, templateType z)
template<class templateType>
void | WriteOrthMatrix (templateType m00, templateType m01, templateType m02, templateType m10, templateType m11, templateType m12, templateType m20, templateType m21, templateType m22)
bool | Read (char *output, const unsigned int numberOfBytes)
template<class templateType>
bool | ReadNormVector (templateType &x, templateType &y, templateType &z)
template<class templateType>
bool | ReadVector (templateType &x, templateType &y, templateType &z)
template<class templateType>
bool | ReadNormQuat (templateType &w, templateType &x, templateType &y, templateType &z)
template<class templateType>
bool | ReadOrthMatrix (templateType &m00, templateType &m01, templateType &m02, templateType &m10, templateType &m11, templateType &m12, templateType &m20, templateType &m21, templateType &m22)
void | ResetReadPointer (void)
Sets the read pointer back to the beginning of your data.
void | ResetWritePointer (void)
Sets the write pointer back to the beginning of your data.
void | AssertStreamEmpty (void)
void | PrintBits (void) const
printf the bits in the stream. Great for debugging.
void | IgnoreBits (const BitSize_t numberOfBits)
void | IgnoreBytes (const unsigned int numberOfBytes)
void | SetWriteOffset (const BitSize_t offset)
BitSize_t | GetNumberOfBitsUsed (void) const
Returns the length in bits of the stream.
BitSize_t | GetNumberOfBytesUsed (void) const
Returns the length in bytes of the stream.
BitSize_t | GetReadOffset (void) const
Returns the number of bits into the stream that we have read.
BitSize_t | GetNumberOfUnreadBits (void) const
Returns the number of bits left in the stream that haven't been read.
BitSize_t | CopyData (unsigned char **_data) const
void | SetData (unsigned char *input)
unsigned char * | GetData (void) const
void | WriteBits (const unsigned char *input, BitSize_t numberOfBitsToWrite, const bool rightAlignedBits=true)
void | WriteAlignedBytes (const unsigned char *input, const unsigned int numberOfBytesToWrite)
void | WriteAlignedBytesSafe (const char *input, const unsigned int inputLength, const unsigned int maxBytesToWrite)
Aligns the bitstream, writes inputLength, and writes input. Won't write beyond maxBytesToWrite.
bool | ReadAlignedBytes (unsigned char *output, const unsigned int numberOfBytesToRead)
bool | ReadAlignedBytesSafe (char *input, int &inputLength, const int maxBytesToRead)
bool | ReadAlignedBytesSafeAlloc (char **input, int &inputLength, const unsigned int maxBytesToRead)
void | AlignWriteToByteBoundary (void)
void | AlignReadToByteBoundary (void)
bool | ReadBits (unsigned char *output, BitSize_t numberOfBitsToRead, const bool alignBitsToRight=true)
void | Write0 (void)
Write a 0.
void | Write1 (void)
Write a 1.
bool | ReadBit (void)
Reads 1 bit and returns true if that bit is 1 and false if it is 0.
void | AssertCopyData (void)
void | SetNumberOfBitsAllocated (const BitSize_t lengthInBits)
void | AddBitsAndReallocate (const BitSize_t numberOfBitsToWrite)
Reallocates (if necessary) in preparation of writing numberOfBitsToWrite.
template<>
void | Write (bool var)
template<>
void | Write (SystemAddress var)
template<>
void | Write (NetworkID var)
template<>
void | Write (RakString var)
template<>
void | WriteDelta (SystemAddress currentValue, SystemAddress lastValue)
template<>
void | WriteDelta (NetworkID currentValue, NetworkID lastValue)
template<>
void | WriteDelta (bool currentValue, bool lastValue)
template<>
void | WriteCompressed (float var)
For values between -1 and 1.
template<>
void | WriteCompressed (double var)
For values between -1 and 1.
template<>
void | WriteCompressed (RakString var)
Compress the string.
template<>
void | WriteCompressedDelta (bool currentValue, bool lastValue)
template<>
void | WriteCompressedDelta (bool currentValue)
Save as WriteCompressedDelta(bool currentValue, templateType lastValue) when we have an unknown second bool.
template<>
bool | Read (bool &var)
template<>
bool | Read (SystemAddress &var)
template<>
bool | Read (NetworkID &var)
template<>
bool | Read (RakString &var)
template<>
bool | ReadDelta (bool &var)
template<>
bool | ReadCompressed (float &var)
For values between -1 and 1.
template<>
bool | ReadCompressed (double &var)
For values between -1 and 1.
template<>
bool | ReadCompressed (RakString &var)
For strings.
template<>
bool | ReadCompressedDelta (bool &var)

Static Public Member Functions

static bool | DoEndianSwap (void)
---- Member function template specialization declarations ----

Detailed Description

This class allows you to write and read native types as a string of bits. BitStream is used extensively throughout RakNet and is designed to be used by users as well.
See also:
BitStreamSample.txt

Constructor & Destructor Documentation

BitStream::BitStream ( const unsigned int initialBytesToAllocate )

Create the bitstream, with some number of bytes to immediately allocate. There is no benefit to calling this, unless you know exactly how many bytes you need and it is greater than BITSTREAM_STACK_ALLOCATION_SIZE. In that case all it does is save you one or more realloc calls.

Parameters:
[in] initialBytesToAllocate the number of bytes to pre-allocate.

BitStream::BitStream | ( | unsigned char * | _data,
 |  | const unsigned int | lengthInBytes,
 |  | bool | _copyData
 | ) |  |

Initialize the BitStream, immediately setting the data it contains to a predefined pointer. Set _copyData to true if you want to make an internal copy of the data you are passing. Set it to false to just save a pointer to the data. You shouldn't call Write functions with _copyData as false, as this will write to unallocated memory 99% of the time you will use this function to cast Packet::data to a bitstream for reading, in which case you should write something as follows:

 RakNet::BitStream bs(packet->data, packet->length, false);
Parameters:
[in] | _data | An array of bytes.
[in] | lengthInBytes | Size of the _data.
[in] | _copyData | true or false to make a copy of _data or not.

Member Function Documentation

template<class templateType>
bool BitStream::Serialize | ( | bool | writeToBitstream,
 |  | templateType & | var |
 | ) |  |  | [inline]

Bidirectional serialize/deserialize any integral type to/from a bitstream. Undefine __BITSTREAM_NATIVE_END if you need endian swapping.

Parameters:
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | var | The value to write
Returns:
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.

template<class templateType>
bool BitStream::SerializeDelta | ( | bool | writeToBitstream,
 |  | templateType & | currentValue,
 |  | templateType | lastValue |
 | ) |  |  | [inline]

Bidirectional serialize/deserialize any integral type to/from a bitstream. If the current value is different from the last value the current value will be written. Otherwise, a single bit will be written

Parameters:
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | currentValue | The current value to write
[in] | lastValue | The last value to compare against. Only used if writeToBitstream is true.
Returns:
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.

template<class templateType>
bool BitStream::SerializeDelta | ( | bool | writeToBitstream,
 |  | templateType & | currentValue |
 | ) |  |  | [inline]

Bidirectional version of SerializeDelta when you don't know what the last value is, or there is no last value.

Parameters:
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | currentValue | The current value to write
Returns:
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.

template<class templateType>
bool BitStream::SerializeCompressed | ( | bool | writeToBitstream,
 |  | templateType & | var |
 | ) |  |  | [inline]

Bidirectional serialize/deserialize any integral type to/from a bitstream. Undefine __BITSTREAM_NATIVE_END if you need endian swapping. If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the range of the type

Parameters:
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | var | The value to write
Returns:
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.

template<class templateType>
bool BitStream::SerializeCompressedDelta | ( | bool | writeToBitstream,
 |  | templateType & | currentValue,
 |  | templateType | lastValue |
 | ) |  |  | [inline]

Bidirectional serialize/deserialize any integral type to/from a bitstream. If the current value is different from the last value the current value will be written. Otherwise, a single bit will be written For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the range of the type If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte

Parameters:
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | currentValue | The current value to write
[in] | lastValue | The last value to compare against. Only used if writeToBitstream is true.
Returns:
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.

bool BitStream::Serialize | ( | bool | writeToBitstream,
 |  | char * | input,
 |  | const unsigned int | numberOfBytes |
 | ) |  |  | [inline]

Bidirectional serialize/deserialize an array or casted stream or raw data. This does NOT do endian swapping.

Parameters:
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | input | a byte buffer
[in] | numberOfBytes | the size of input in bytes
Returns:
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.

template<class templateType>
bool BitStream::SerializeNormVector | ( | bool | writeToBitstream,
 |  | templateType & | x,
 |  | templateType & | y,
 |  | templateType & | z |
 | ) |  |  | [inline]

Bidirectional serialize/deserialize a normalized 3D vector, using (at most) 4 bytes + 3 bits instead of 12-24 bytes. Will further compress y or z axis aligned vectors. Accurate to 1/32767.5.

Parameters:
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | x | x
[in] | y | y
[in] | z | z
Returns:
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.

template<class templateType>
bool BitStream::SerializeVector | ( | bool | writeToBitstream,
 |  | templateType & | x,
 |  | templateType & | y,
 |  | templateType & | z |
 | ) |  |  | [inline]

Bidirectional serialize/deserialize a vector, using 10 bytes instead of 12. Loses accuracy to about 3/10ths and only saves 2 bytes, so only use if accuracy is not important.

Parameters:
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | x | x
[in] | y | y
[in] | z | z
Returns:
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.

template<class templateType>
bool BitStream::SerializeNormQuat | ( | bool | writeToBitstream,
 |  | templateType & | w,
 |  | templateType & | x,
 |  | templateType & | y,
 |  | templateType & | z |
 | ) |  |  | [inline]

Bidirectional serialize/deserialize a normalized quaternion in 6 bytes + 4 bits instead of 16 bytes. Slightly lossy.

Parameters:
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | w | w
[in] | x | x
[in] | y | y
[in] | z | z
Returns:
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.

template<class templateType>
bool BitStream::SerializeOrthMatrix | ( | bool | writeToBitstream,
 |  | templateType & | m00,
 |  | templateType & | m01,
 |  | templateType & | m02,
 |  | templateType & | m10,
 |  | templateType & | m11,
 |  | templateType & | m12,
 |  | templateType & | m20,
 |  | templateType & | m21,
 |  | templateType & | m22 |
 | ) |  |  | [inline]

Bidirectional serialize/deserialize an orthogonal matrix by creating a quaternion, and writing 3 components of the quaternion in 2 bytes each for 6 bytes instead of 36 Lossy, although the result is renormalized

bool BitStream::SerializeBits | ( | bool | writeToBitstream,
 |  | unsigned char * | input,
 |  | const BitSize_t | numberOfBitsToSerialize,
 |  | const bool | rightAlignedBits = true |
 | ) |  |  | [inline]

Bidirectional serialize/deserialize numberToSerialize bits to/from the input. Right aligned data means in the case of a partial byte, the bits are aligned from the right (bit 0) rather than the left (as in the normal internal representation) You would set this to true when writing user data, and false when copying bitstream data, such as writing one bitstream to another

Parameters:
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | input | The data
[in] | numberOfBitsToSerialize | The number of bits to write
[in] | rightAlignedBits | if true data will be right aligned
Returns:
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.

template<class templateType>
void BitStream::Write ( templateType var ) [inline]

Write any integral type to a bitstream. Undefine __BITSTREAM_NATIVE_END if you need endian swapping.

Parameters:
[in] var The value to write

template<class templateType>
void BitStream::WritePtr ( templateType * var ) [inline]

Write the dereferenced pointer to any integral type to a bitstream. Undefine __BITSTREAM_NATIVE_END if you need endian swapping.

Parameters:
[in] var The value to write

template<class templateType>
void BitStream::WriteDelta | ( | templateType | currentValue,
 |  | templateType | lastValue |
 | ) |  |  | [inline]

Write any integral type to a bitstream. If the current value is different from the last value the current value will be written. Otherwise, a single bit will be written

Parameters:
[in] | currentValue | The current value to write
[in] | lastValue | The last value to compare against

template<class templateType>
void BitStream::WriteDelta ( templateType currentValue ) [inline]

WriteDelta when you don't know what the last value is, or there is no last value.

Parameters:
[in] currentValue The current value to write

template<class templateType>
void BitStream::WriteCompressed ( templateType var ) [inline]

Write any integral type to a bitstream. Undefine __BITSTREAM_NATIVE_END if you need endian swapping. If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the range of the type

Parameters:
[in] var The value to write

template<class templateType>
void BitStream::WriteCompressedDelta | ( | templateType | currentValue,
 |  | templateType | lastValue |
 | ) |  |  | [inline]

Write any integral type to a bitstream. If the current value is different from the last value the current value will be written. Otherwise, a single bit will be written For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the range of the type If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte

Parameters:
[in] | currentValue | The current value to write
[in] | lastValue | The last value to compare against

template<class templateType>
bool BitStream::Read ( templateType & var ) [inline]

Read any integral type from a bitstream. Define __BITSTREAM_NATIVE_END if you need endian swapping.

Parameters:
[in] var The value to read

template<class templateType>
bool BitStream::ReadPtr ( templateType * var ) [inline]

Read into a pointer to any integral type from a bitstream. Define __BITSTREAM_NATIVE_END if you need endian swapping.

Parameters:
[in] var The value to read

template<class templateType>
bool BitStream::ReadDelta ( templateType & var ) [inline]

Read any integral type from a bitstream. If the written value differed from the value compared against in the write function, var will be updated. Otherwise it will retain the current value. ReadDelta is only valid from a previous call to WriteDelta

Parameters:
[in] var The value to read

template<class templateType>
bool BitStream::ReadCompressed ( templateType & var ) [inline]

Read any integral type from a bitstream. Undefine __BITSTREAM_NATIVE_END if you need endian swapping. For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the range of the type If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte

Parameters:
[in] var The value to read

template<class templateType>
bool BitStream::ReadCompressedDelta ( templateType & var ) [inline]

Read any integral type from a bitstream. If the written value differed from the value compared against in the write function, var will be updated. Otherwise it will retain the current value. the current value will be updated. For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the range of the type If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte ReadCompressedDelta is only valid from a previous call to WriteDelta

Parameters:
[in] var The value to read

bool BitStream::Read | ( | BitStream * | bitStream,
 |  | BitSize_t | numberOfBits
 | ) |  |

Read one bitstream to another

Parameters:
[in] | numberOfBits | bits to read
bitStream | the bitstream to read into from

void BitStream::Write | ( | const char * | input,
 |  | const unsigned int | numberOfBytes
 | ) |  |

Write an array or casted stream or raw data. This does NOT do endian swapping.

Parameters:
[in] | input | a byte buffer
[in] | numberOfBytes | the size of input in bytes

void BitStream::Write | ( | BitStream * | bitStream,
 |  | BitSize_t | numberOfBits
 | ) |  |

Write one bitstream to another

Parameters:
[in] | numberOfBits | bits to write
bitStream | the bitstream to copy from

template<class templateType>
void BitStream::WriteNormVector | ( | templateType | x,
 |  | templateType | y,
 |  | templateType | z
 | ) |  |

Read a normalized 3D vector, using (at most) 4 bytes + 3 bits instead of 12-24 bytes. Will further compress y or z axis aligned vectors. Accurate to 1/32767.5.

Parameters:
[in] | x | x
[in] | y | y
[in] | z | z

template<class templateType>
void BitStream::WriteVector | ( | templateType | x,
 |  | templateType | y,
 |  | templateType | z
 | ) |  |

Write a vector, using 10 bytes instead of 12. Loses accuracy to about 3/10ths and only saves 2 bytes, so only use if accuracy is not important.

Parameters:
[in] | x | x
[in] | y | y
[in] | z | z

template<class templateType>
void BitStream::WriteNormQuat | ( | templateType | w,
 |  | templateType | x,
 |  | templateType | y,
 |  | templateType | z
 | ) |  |

Write a normalized quaternion in 6 bytes + 4 bits instead of 16 bytes. Slightly lossy.

Parameters:
[in] | w | w
[in] | x | x
[in] | y | y
[in] | z | z

template<class templateType>
void BitStream::WriteOrthMatrix | ( | templateType | m00,
 |  | templateType | m01,
 |  | templateType | m02,
 |  | templateType | m10,
 |  | templateType | m11,
 |  | templateType | m12,
 |  | templateType | m20,
 |  | templateType | m21,
 |  | templateType | m22
 | ) |  |

Write an orthogonal matrix by creating a quaternion, and writing 3 components of the quaternion in 2 bytes each for 6 bytes instead of 36 Lossy, although the result is renormalized

bool BitStream::Read | ( | char * | output,
 |  | const unsigned int | numberOfBytes
 | ) |  |

Read an array or casted stream of byte. The array is raw data. There is no automatic endian conversion with this function

Parameters:
[in] | output | The result byte array. It should be larger than numberOfBytes.
[in] | numberOfBytes | The number of byte to read
Returns:
true on success false if there is some missing bytes.

template<class templateType>
bool BitStream::ReadNormVector | ( | templateType & | x,
 |  | templateType & | y,
 |  | templateType & | z
 | ) |  |

Read a normalized 3D vector, using (at most) 4 bytes + 3 bits instead of 12-24 bytes. Will further compress y or z axis aligned vectors. Accurate to 1/32767.5.

Parameters:
[in] | x | x
[in] | y | y
[in] | z | z

template<class templateType>
bool BitStream::ReadVector | ( | templateType & | x,
 |  | templateType & | y,
 |  | templateType & | z
 | ) |  |

Read 3 floats or doubles, using 10 bytes, where those float or doubles comprise a vector Loses accuracy to about 3/10ths and only saves 2 bytes, so only use if accuracy is not important.

Parameters:
[in] | x | x
[in] | y | y
[in] | z | z

template<class templateType>
bool BitStream::ReadNormQuat | ( | templateType & | w,
 |  | templateType & | x,
 |  | templateType & | y,
 |  | templateType & | z
 | ) |  |

Read a normalized quaternion in 6 bytes + 4 bits instead of 16 bytes.

Parameters:
[in] | w | w
[in] | x | x
[in] | y | y
[in] | z | z

template<class templateType>
bool BitStream::ReadOrthMatrix | ( | templateType & | m00,
 |  | templateType & | m01,
 |  | templateType & | m02,
 |  | templateType & | m10,
 |  | templateType & | m11,
 |  | templateType & | m12,
 |  | templateType & | m20,
 |  | templateType & | m21,
 |  | templateType & | m22
 | ) |  |

Read an orthogonal matrix from a quaternion, reading 3 components of the quaternion in 2 bytes each and extrapolatig the 4th. for 6 bytes instead of 36 Lossy, although the result is renormalized

void BitStream::AssertStreamEmpty ( void )

This is good to call when you are done with the stream to make sure you didn't leave any data left over void

void BitStream::IgnoreBits ( const BitSize_t numberOfBits )

Ignore data we don't intend to read

Parameters:
[in] numberOfBits The number of bits to ignore

void BitStream::IgnoreBytes ( const unsigned int numberOfBytes )

Ignore data we don't intend to read

Parameters:
[in] numberOfBits The number of bytes to ignore

void BitStream::SetWriteOffset ( const BitSize_t offset )

Move the write pointer to a position on the array.

Parameters:
[in] offset the offset from the start of the array.
Attention:
Dangerous if you don't know what you are doing! For efficiency reasons you can only write mid-stream if your data is byte aligned.

BitSize_t BitStream::CopyData ( unsigned char ** _data ) const

Makes a copy of the internal data for you _data will point to the stream. Returns the length in bits of the stream. Partial bytes are left aligned

Parameters:
[out] _data The allocated copy of GetData()

void BitStream::SetData ( unsigned char * input )

Set the stream to some initial data.

unsigned char* RakNet::BitStream::GetData ( void ) const [inline]

Gets the data that BitStream is writing to / reading from Partial bytes are left aligned.

Returns:
A pointer to the internal state

void BitStream::WriteBits | ( | const unsigned char * | input,
 |  | BitSize_t | numberOfBitsToWrite,
 |  | const bool | rightAlignedBits = true
 | ) |  |

Write numberToWrite bits from the input source Right aligned data means in the case of a partial byte, the bits are aligned from the right (bit 0) rather than the left (as in the normal internal representation) You would set this to true when writing user data, and false when copying bitstream data, such as writing one bitstream to another

Parameters:
[in] | input | The data
[in] | numberOfBitsToWrite | The number of bits to write
[in] | rightAlignedBits | if true data will be right aligned

void BitStream::WriteAlignedBytes | ( | const unsigned char * | input,
 |  | const unsigned int | numberOfBytesToWrite
 | ) |  |

Align the bitstream to the byte boundary and then write the specified number of bits. This is faster than WriteBits but wastes the bits to do the alignment and requires you to call ReadAlignedBits at the corresponding read position.

Parameters:
[in] | input | The data
[in] | numberOfBytesToWrite | The size of input.

void BitStream::WriteAlignedBytesSafe | ( | const char * | input,
 |  | const unsigned int | inputLength,
 |  | const unsigned int | maxBytesToWrite
 | ) |  |

Aligns the bitstream, writes inputLength, and writes input. Won't write beyond maxBytesToWrite.

Aligns the bitstream, writes inputLength, and writes input. Won't write beyond maxBytesToWrite

Parameters:
[in] | input | The data
[in] | inputLength | The size of input.
[in] | maxBytesToWrite | Max bytes to write

bool BitStream::ReadAlignedBytes | ( | unsigned char * | output,
 |  | const unsigned int | numberOfBytesToRead
 | ) |  |

Read bits, starting at the next aligned bits. Note that the modulus 8 starting offset of the sequence must be the same as was used with WriteBits. This will be a problem with packet coalescence unless you byte align the coalesced packets.

Parameters:
[in] | output | The byte array larger than numberOfBytesToRead
[in] | numberOfBytesToRead | The number of byte to read from the internal state
Returns:
true if there is enough byte.

bool BitStream::ReadAlignedBytesSafe | ( | char * | input,
 |  | int & | inputLength,
 |  | const int | maxBytesToRead
 | ) |  |

Reads what was written by WriteAlignedBytesSafe

Parameters:
[in] | input | The data
[in] | maxBytesToRead | Maximum number of bytes to read

bool BitStream::ReadAlignedBytesSafeAlloc | ( | char ** | input,
 |  | int & | inputLength,
 |  | const unsigned int | maxBytesToRead
 | ) |  |

Same as ReadAlignedBytesSafe() but allocates the memory for you using new, rather than assuming it is safe to write to

Parameters:
[in] input input will be deleted if it is not a pointer to 0

void BitStream::AlignWriteToByteBoundary ( void )

Align the next write and/or read to a byte boundary. This can be used to 'waste' bits to byte align for efficiency reasons It can also be used to force coalesced bitstreams to start on byte boundaries so so WriteAlignedBits and ReadAlignedBits both calculate the same offset when aligning.

void BitStream::AlignReadToByteBoundary ( void )

Align the next write and/or read to a byte boundary. This can be used to 'waste' bits to byte align for efficiency reasons It can also be used to force coalesced bitstreams to start on byte boundaries so so WriteAlignedBits and ReadAlignedBits both calculate the same offset when aligning.

bool BitStream::ReadBits | ( | unsigned char * | output,
 |  | BitSize_t | numberOfBitsToRead,
 |  | const bool | alignBitsToRight = true
 | ) |  |

Read numberOfBitsToRead bits to the output source alignBitsToRight should be set to true to convert internal bitstream data to userdata. It should be false if you used WriteBits with rightAlignedBits false

Parameters:
[in] | output | The resulting bits array
[in] | numberOfBitsToRead | The number of bits to read
[in] | alignBitsToRight | if true bits will be right aligned.
Returns:
true if there is enough bits to read

void BitStream::AssertCopyData ( void )

If we used the constructor version with copy data off, this makes sure it is set to on and the data pointed to is copied.

void BitStream::SetNumberOfBitsAllocated ( const BitSize_t lengthInBits )

Use this if you pass a pointer copy to the constructor (_copyData==false) and want to overallocate to prevent reallocation

void BitStream::AddBitsAndReallocate ( const BitSize_t numberOfBitsToWrite )

Reallocates (if necessary) in preparation of writing numberOfBitsToWrite.

Cap to 1 meg buffer to save on huge allocations

template<>
void RakNet::BitStream::Write ( bool var ) [inline]

Write a bool to a bitstream

Parameters:
[in] var The value to write

template<>
void RakNet::BitStream::Write ( SystemAddress var ) [inline]

Write a systemAddress to a bitstream

Parameters:
[in] var The value to write

template<>
void RakNet::BitStream::Write ( NetworkID var ) [inline]

Write an networkID to a bitstream

Parameters:
[in] var The value to write

template<>
void RakNet::BitStream::Write ( RakString var ) [inline]

Write a string to a bitstream

Parameters:
[in] var The value to write

template<>
void RakNet::BitStream::WriteDelta | ( | SystemAddress | currentValue,
 |  | SystemAddress | lastValue |
 | ) |  |  | [inline]

Write a systemAddress. If the current value is different from the last value the current value will be written. Otherwise, a single bit will be written

Parameters:
[in] | currentValue | The current value to write
[in] | lastValue | The last value to compare against

template<>
void RakNet::BitStream::WriteDelta | ( | NetworkID | currentValue,
 |  | NetworkID | lastValue |
 | ) |  |  | [inline]

Write a systemAddress. If the current value is different from the last value the current value will be written. Otherwise, a single bit will be written

Parameters:
[in] | currentValue | The current value to write
[in] | lastValue | The last value to compare against

template<>
void RakNet::BitStream::WriteDelta | ( | bool | currentValue,
 |  | bool | lastValue |
 | ) |  |  | [inline]

Write a bool delta. Same thing as just calling Write

Parameters:
[in] | currentValue | The current value to write
[in] | lastValue | The last value to compare against

template<>
void RakNet::BitStream::WriteCompressedDelta | ( | bool | currentValue,
 |  | bool | lastValue |
 | ) |  |  | [inline]

Write a bool delta. Same thing as just calling Write

Parameters:
[in] | currentValue | The current value to write
[in] | lastValue | The last value to compare against

template<>
bool RakNet::BitStream::Read ( bool & var ) [inline]

Read a bool from a bitstream

Parameters:
[in] var The value to read

template<>
bool RakNet::BitStream::Read ( SystemAddress & var ) [inline]

Read a systemAddress from a bitstream

Parameters:
[in] var The value to read

template<>
bool RakNet::BitStream::Read ( NetworkID & var ) [inline]

Read an networkID from a bitstream

Parameters:
[in] var The value to read

template<>
bool RakNet::BitStream::Read ( RakString & var ) [inline]

Read an networkID from a bitstream

Parameters:
[in] var The value to read

template<>
bool RakNet::BitStream::ReadDelta ( bool & var ) [inline]

Read a bool from a bitstream

Parameters:
[in] var The value to read

template<>
bool RakNet::BitStream::ReadCompressedDelta ( bool & var ) [inline]

Read a bool from a bitstream

Parameters:
[in] var The value to read

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/BitStream.h
  • C:/RakNet/Source/BitStream.cpp
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::BPlusTree< KeyType, DataType, order > Class Template Reference

DataStructures::BPlusTree

DataStructures::BPlusTree< KeyType, DataType, order > Class Template Reference

#include <DS_BPlusTree.h>

List of all members.

Detailed Description

template<class KeyType, class DataType, int order>
class DataStructures::BPlusTree< KeyType, DataType, order >

A BPlus tree Written with efficiency and speed in mind.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/DS_BPlusTree.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: CheckSum Class Reference

CheckSum Class Reference

Generates and validates checksums. More...

#include <CheckSum.h>

List of all members.

Public Member Functions

CheckSum ()
Default constructor.

Detailed Description

Generates and validates checksums.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/CheckSum.h
  • C:/RakNet/Source/CheckSum.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::CircularLinkedList< CircularLinkedListType > Class Template Reference

DataStructures::CircularLinkedList

DataStructures::CircularLinkedList< CircularLinkedListType > Class Template Reference

(Circular) Linked List ADT (Doubly Linked Pointer to Node Style) - More...

#include <DS_LinkedList.h>

List of all members.

Detailed Description

template<class CircularLinkedListType>
class DataStructures::CircularLinkedList< CircularLinkedListType >

(Circular) Linked List ADT (Doubly Linked Pointer to Node Style) -

By Kevin Jenkins (http://www.rakkar.org) Initilize with the following command LinkedList<TYPE> OR CircularLinkedList<Type>

Has the following member functions

  • size: returns number of elements in the linked list
  • insert(item): inserts item at the current position in the LinkedList.
  • add(item): inserts item after the current position in the LinkedList. Does not increment the position
  • replace(item): replaces the element at the current position item.
  • peek: returns the element at the current position
  • pop: returns the element at the current position and deletes it
  • del: deletes the current element. Does nothing for an empty list.
  • clear: empties the LinkedList and returns storage
  • bool IsInitem): Does a linear search for item. Does not set the position to it, only returns true on item found, false otherwise
  • bool find(item): Does a linear search for item and sets the current position to point to it if and only if the item is found. Returns true on item found, false otherwise
  • sort: Sorts the elements of the list with a mergesort and sets the current pointer to the first element
  • concatenate(list L): This appends L to the current list
  • ++(prefix): moves the pointer one element up in the list and returns the appropriate copy of the element in the list
  • --(prefix): moves the pointer one element back in the list and returns the appropriate copy of the element in the list
  • beginning - moves the pointer to the start of the list. For circular linked lists this is first 'position' created. You should call this after the sort function to read the first value.
  • end - moves the pointer to the end of the list. For circular linked lists this is one less than the first 'position' created The assignment and copy constructor operators are defined

Note:
1. LinkedList and CircularLinkedList are exactly the same except LinkedList won't let you wrap around the root and lets you jump to two positions relative to the root/ 2. Postfix ++ and -- can be used but simply call the prefix versions.
EXAMPLE:
 LinkedList<int> A;  // Creates a Linked List of integers called A
 CircularLinkedList<int> B;  // Creates a Circular Linked List of
          // integers called B

 A.Insert(20);  // Adds 20 to A.  A: 20 - current is 20
 A.Insert(5);  // Adds 5 to A.  A: 5 20 - current is 5
 A.Insert(1);  // Adds 1 to A.  A: 1 5 20 - current is 1

 A.IsIn1); // returns true
 A.IsIn200); // returns false
 A.Find(5);  // returns true and sets current to 5
 A.Peek();  // returns 5
 A.Find(1);  // returns true and sets current to 1

 (++A).Peek();  // Returns 5
 A.Peek(); // Returns 5

 A.Replace(10);  // Replaces 5 with 10.
 A.Peek();  // Returns 10

 A.Beginning();  // Current points to the beginning of the list at 1

 (++A).Peek();  // Returns 5
 A.Peek();  // Returns 10

 A.Del();  // Deletes 10.  Current points to the next element, which is 20
 A.Peek();  // Returns 20

 A.Beginning();  // Current points to the beginning of the list at 1

 (++A).Peek();  // Returns 5
 A.Peek();  // Returns 20

 A.Clear();  // Deletes all nodes in A

 A.Insert(5);  // A: 5 - current is 5
 A.Insert(6); // A: 6 5 - current is 6
 A.Insert(7); // A: 7 6 5 - current is 7

 A.Clear();
 B.Clear();

 B.Add(10);
 B.Add(20);
 B.Add(30);
 B.Add(5);
 B.Add(2);
 B.Add(25);
 // Sorts the numbers in the list and sets the current pointer to the
 // first element
 B.sort();

 // Postfix ++ just calls the prefix version and has no functional
 // difference.
 B.Peek();  // Returns 2
 B++;
 B.Peek();  // Returns 5
 B++;
 B.Peek();  // Returns 10
 B++;
 B.Peek();  // Returns 20
 B++;
 B.Peek();  // Returns 25
 B++;
 B.Peek();  // Returns 30

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/DS_LinkedList.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::ClanJoinInvitation_Notification Struct Reference

RakNet::ClanJoinInvitation_Notification

RakNet::ClanJoinInvitation_Notification Struct Reference

A leader or subleader in a clan has invited you to join that clan. More...

#include <LobbyClientInterface.h>

List of all members.

Public Attributes

LobbyClientUserId * | clanLeaderOrSubleaderId
Leader or subleader that is sending the invitation.
ClanId * | clanId
Clan this action is in reference to.

Detailed Description

A leader or subleader in a clan has invited you to join that clan.

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyClientInterface.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::ClanJoinInvitationAccepted_Notification Struct Reference

RakNet::ClanJoinInvitationAccepted_Notification

RakNet::ClanJoinInvitationAccepted_Notification Struct Reference

#include <LobbyClientInterface.h>

List of all members.

Public Attributes

LobbyClientUserId * | userId
User that this action was referring to.
LobbyClientUserId * | clanLeaderOrSubleaderId
Leader or subleader that originally sent the invitation (not necessarily you).
ClanId * | clanId
Clan this action is in reference to.
bool | userIdIsYou
If this is sent to you as the joining member, this is true.
bool | invitationSenderIsYou
If this is sent to you as the one that originally accepted the request, this is true.

Detailed Description

A clan leader invited someone to your clan, and they accepted it and have joined the clan This is sent to the new member, and also to all online members of the clan

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyClientInterface.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::ClanJoinInvitationRejected_Notification Struct Reference

RakNet::ClanJoinInvitationRejected_Notification

RakNet::ClanJoinInvitationRejected_Notification Struct Reference

#include <LobbyClientInterface.h>

List of all members.

Public Attributes

LobbyClientUserId * | userId
User that this action was referring to.
LobbyClientUserId * | clanLeaderOrSubleaderId
Leader or subleader that originally sent the invitation (not necessarily you).
ClanId * | clanId
Clan this action is in reference to.

Detailed Description

A clan leader invited someone to your clan, and they turned the offer down. Send to all clan leaders and subleaders

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyClientInterface.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::ClanJoinInvitationWithdrawn_Notification Struct Reference

RakNet::ClanJoinInvitationWithdrawn_Notification

RakNet::ClanJoinInvitationWithdrawn_Notification Struct Reference

You were invited to a clan, but this invitation has been revoked. More...

#include <LobbyClientInterface.h>

List of all members.

Public Attributes

LobbyClientUserId * | clanLeaderOrSubleaderId
Leader or subleader of the clan that performed this action.
ClanId * | clanId
Clan this action is in reference to.

Detailed Description

You were invited to a clan, but this invitation has been revoked.

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyClientInterface.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::ClanMemberJoinRequest_Notification Struct Reference

RakNet::ClanMemberJoinRequest_Notification

RakNet::ClanMemberJoinRequest_Notification Struct Reference

Someone has asked to join your clan. More...

#include <LobbyClientInterface.h>

List of all members.

Public Attributes

LobbyClientUserId * | userId
User that this action was referring to.
ClanId * | clanId
Clan this action is in reference to.

Detailed Description

Someone has asked to join your clan.

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyClientInterface.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::ClanMemberJoinRequestAccepted_Notification Struct Reference

RakNet::ClanMemberJoinRequestAccepted_Notification

RakNet::ClanMemberJoinRequestAccepted_Notification Struct Reference

#include <LobbyClientInterface.h>

List of all members.

Public Attributes

LobbyClientUserId * | userId
New member of the clan (possibly you).
LobbyClientUserId * | clanLeaderOrSubleaderId
Leader or subleader that accepted the join request (possibly you).
ClanId * | clanId
Clan this action is in reference to.
bool | userIdIsYou
If this is sent to you as the joining member, this is true.
bool | joinRequestAcceptorIsYou
If this is sent to you as the one that originally accepted the request, this is true.

Detailed Description

A clan leader or subleader has accepted a petition to join their clan This is sent to the new member, and also to all online members of the clan

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyClientInterface.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::ClanMemberJoinRequestRejected_Notification Struct Reference

RakNet::ClanMemberJoinRequestRejected_Notification

RakNet::ClanMemberJoinRequestRejected_Notification Struct Reference

#include <LobbyClientInterface.h>

List of all members.

Public Attributes

LobbyClientUserId * | clanLeaderOrSubleaderId
Leader or subleader that turned you down.
ClanId * | clanId
Clan this action is in reference to.

Detailed Description

A clan leader or subleader has rejected your petition to join their clan This is sent to the petitioner, and also to all online members of the clan

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyClientInterface.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::ClanMemberJoinRequestWithdrawn_Notification Struct Reference

RakNet::ClanMemberJoinRequestWithdrawn_Notification

RakNet::ClanMemberJoinRequestWithdrawn_Notification Struct Reference

Someone has petitioned to join your clan, but changed their mind and have withdrawn that petition. More...

#include <LobbyClientInterface.h>

List of all members.

Public Attributes

LobbyClientUserId * | userId
User that this action was referring to.
ClanId * | clanId
Clan this action is in reference to.

Detailed Description

Someone has petitioned to join your clan, but changed their mind and have withdrawn that petition.

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyClientInterface.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: CombFilterMem Struct Reference

CombFilterMem Struct Reference

#include <filters.h>

List of all members.

Detailed Description

Combined filter memory.

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/filters.h
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: CommandParserInterface Class Reference

CommandParserInterface Class Reference

The interface used by command parsers. More...

#include <CommandParserInterface.h>

Inheritance diagram for CommandParserInterface:

LogCommandParser RakNetCommandParser RakNetTransportCommandParser List of all members.

Public Member Functions

virtual const char * | GetName (void) const =0
virtual void | OnNewIncomingConnection (SystemAddress systemAddress, TransportInterface *transport)
virtual void | OnConnectionLost (SystemAddress systemAddress, TransportInterface *transport)
virtual void | SendHelp (TransportInterface *transport, SystemAddress systemAddress)=0
virtual bool | OnCommand (const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, SystemAddress systemAddress, const char *originalString)=0
virtual void | OnTransportChange (TransportInterface *transport)

Protected Member Functions

virtual void | RegisterCommand (unsigned char parameterCount, const char *command, const char *commandHelp)
virtual void | ReturnResult (bool res, const char *command, TransportInterface *transport, SystemAddress systemAddress)
virtual void | ReturnResult (const char *command, TransportInterface *transport, SystemAddress systemAddress)
SystemAddress | IntegersToSystemAddress (int binaryAddress, int port)

Detailed Description

The interface used by command parsers.

CommandParserInterface provides a set of functions and interfaces that plug into the ConsoleServer class. Each CommandParserInterface works at the same time as other interfaces in the system.

Member Function Documentation

virtual const char* CommandParserInterface::GetName ( void ) const [pure virtual]

You are responsible for overriding this function and returning a static string, which will identifier your parser. This should return a static string

Returns:
The name that you return.

Implemented in LogCommandParser, RakNetCommandParser, and RakNetTransportCommandParser.

void CommandParserInterface::OnNewIncomingConnection | ( | SystemAddress | systemAddress,
 |  | TransportInterface * | transport |
 | ) |  |  | [virtual]

A callback for when systemAddress has connected to us.

Parameters:
[in] | systemAddress | The player that has connected.
[in] | transport | The transport interface that sent us this information. Can be used to send messages to this or other players.

Reimplemented in LogCommandParser.

void CommandParserInterface::OnConnectionLost | ( | SystemAddress | systemAddress,
 |  | TransportInterface * | transport |
 | ) |  |  | [virtual]

A callback for when systemAddress has disconnected, either gracefully or forcefully

Parameters:
[in] | systemAddress | The player that has disconnected.
[in] | transport | The transport interface that sent us this information.

Reimplemented in LogCommandParser.

virtual void CommandParserInterface::SendHelp | ( | TransportInterface * | transport,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [pure virtual]

A callback for when you are expected to send a brief description of your parser to systemAddress

Parameters:
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that requested help.

Implemented in LogCommandParser, RakNetCommandParser, and RakNetTransportCommandParser.

virtual bool CommandParserInterface::OnCommand | ( | const char * | command,
 |  | unsigned | numParameters,
 |  | char ** | parameterList,
 |  | TransportInterface * | transport,
 |  | SystemAddress | systemAddress,
 |  | const char * | originalString |
 | ) |  |  | [pure virtual]

Given command with parameters parameterList , do whatever processing you wish.

Parameters:
[in] | command | The command to process
[in] | numParameters | How many parameters were passed along with the command
[in] | parameterList | The list of parameters. parameterList[0] is the first parameter and so on.
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that sent this command.
[in] | originalString | The string that was actually sent over the network, in case you want to do your own parsing

Implemented in LogCommandParser, RakNetCommandParser, and RakNetTransportCommandParser.

void CommandParserInterface::OnTransportChange ( TransportInterface * transport ) [virtual]

This is called every time transport interface is registered. If you want to save a copy of the TransportInterface pointer This is the place to do it

Parameters:
[in] transport The new TransportInterface

Reimplemented in LogCommandParser.

void CommandParserInterface::RegisterCommand | ( | unsigned char | parameterCount,
 |  | const char * | command,
 |  | const char * | commandHelp |
 | ) |  |  | [protected, virtual]

Registers a command.

Parameters:
[in] | parameterCount | How many parameters your command requires. If you want to accept a variable number of commands, pass CommandParserInterface::VARIABLE_NUMBER_OF_PARAMETERS
[in] | command | A pointer to a STATIC string that has your command. I keep a copy of the pointer here so don't deallocate the string.
[in] | commandHelp | A pointer to a STATIC string that has the help information for your command. I keep a copy of the pointer here so don't deallocate the string.

void CommandParserInterface::ReturnResult | ( | bool | res,
 |  | const char * | command,
 |  | TransportInterface * | transport,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [protected, virtual]

Just writes a string to the remote system based on the result ( res )of your operation This is not necessary to call, but makes it easier to return results of function calls

Parameters:
[in] | res | The result to write
[in] | command | The command that this result came from
[in] | transport | The transport interface that will be written to
[in] | systemAddress | The player this result will be sent to

void CommandParserInterface::ReturnResult | ( | const char * | command,
 |  | TransportInterface * | transport,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [protected, virtual]

Just writes a string to the remote system when you are calling a function that has no return value This is not necessary to call, but makes it easier to return results of function calls

Parameters:
[in] | res | The result to write
[in] | command | The command that this result came from
[in] | transport | The transport interface that will be written to
[in] | systemAddress | The player this result will be sent to

SystemAddress CommandParserInterface::IntegersToSystemAddress | ( | int | binaryAddress,
 |  | int | port |
 | ) |  |  | [protected]

Since there's no way to specify a systemAddress directly, the user needs to specify both the binary address and port. Given those parameters, this returns the corresponding SystemAddress

Parameters:
[in] | binaryAddress | The binaryAddress portion of SystemAddress
[in] | port | The port portion of SystemAddress

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/CommandParserInterface.h
  • C:/RakNet/Source/CommandParserInterface.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::Connection_RM2 Class Reference

RakNet::Connection_RM2

RakNet::Connection_RM2 Class Reference
[ReplicaManager2]

This class represents a connection between two instances of ReplicaManager2 Represents a connection. Allocated by user supplied factory interface Connection_RM2Factory Implicitly created as needed Generally you will want to implement at a minimum the Construct() function, used as a factory function to create your game objects. More...

#include <ReplicaManager2.h>

List of all members.

Public Member Functions

Connection_RM2 ()
Constructor.
virtual | ~Connection_RM2 ()
Destructor.
virtual Replica2 * | Construct (RakNet::BitStream *replicaData, SystemAddress sender, SerializationType type, ReplicaManager2 *replicaManager, RakNetTime timestamp, NetworkID networkId, bool networkIDCollision)=0
virtual void | SerializeDownloadStarted (RakNet::BitStream *objectData, ReplicaManager2 *replicaManager, SerializationContext *serializationContext)
virtual void | SerializeDownloadComplete (RakNet::BitStream *objectData, ReplicaManager2 *replicaManager, SerializationContext *serializationContext)
virtual void | DeserializeDownloadStarted (RakNet::BitStream *objectData, SystemAddress sender, ReplicaManager2 *replicaManager, RakNetTime timestamp, SerializationType serializationType)
virtual void | DeserializeDownloadComplete (RakNet::BitStream *objectData, SystemAddress sender, ReplicaManager2 *replicaManager, RakNetTime timestamp, SerializationType serializationType)
virtual void | SetConstructionByList (DataStructures::OrderedList< Replica2 *, Replica2 *, ReplicaManager2::Replica2ObjectComp > &currentVisibility, ReplicaManager2 *replicaManager)
virtual void | SetVisibilityByList (DataStructures::OrderedList< Replica2 *, Replica2 *, ReplicaManager2::Replica2ObjectComp > &currentVisibility, ReplicaManager2 *replicaManager)
virtual void | SetConstructionByReplicaQuery (ReplicaManager2 *replicaManager)
virtual void | SetVisibilityByReplicaQuery (ReplicaManager2 *replicaManager)
void | SetSystemAddress (SystemAddress sa)
Set the system address to use with this class instance. This is set internally when the object is created.
SystemAddress | GetSystemAddress (void) const
Get the system address associated with this class instance.

Detailed Description

This class represents a connection between two instances of ReplicaManager2 Represents a connection. Allocated by user supplied factory interface Connection_RM2Factory Implicitly created as needed Generally you will want to implement at a minimum the Construct() function, used as a factory function to create your game objects.

Member Function Documentation

virtual Replica2* RakNet::Connection_RM2::Construct | ( | RakNet::BitStream * | replicaData,
 |  | SystemAddress | sender,
 |  | SerializationType | type,
 |  | ReplicaManager2 * | replicaManager,
 |  | RakNetTime | timestamp,
 |  | NetworkID | networkId,
 |  | bool | networkIDCollision |
 | ) |  |  | [pure virtual]

Factory function, used to create instances of your game objects Encoding is entirely up to you. replicaData will hold whatever was written bitStream in Replica2::SerializeConstruction() One efficient way to do it is to use StringTable.h. This allows you to send predetermined strings over the network at a cost of 9 bits, up to 65536 strings

Parameters:
[in] | replicaData | Whatever was written bitStream in Replica2::SerializeConstruction()
[in] | type | Whatever was written serializationType in Replica2::SerializeConstruction()
[in] | replicaManager | ReplicaManager2 instance that created this class.
[in] | timestamp | timestamp sent with Replica2::SerializeConstruction(), 0 for none.
[in] | networkId | NetworkID that will be assigned automatically to the new object after this function returns
[in] | networkIDCollision | True if the network ID that should be assigned to this object is already in use. Usuallly this is because the object already exists, and you should just read your data and return 0.
Returns:
Return 0 to signal that construction failed or was refused for this object. Otherwise return the object that was created. A reference will be held to this object, and SetNetworkID() and SetReplicaManager() will be called automatically.

void Connection_RM2::SerializeDownloadStarted | ( | RakNet::BitStream * | objectData,
 |  | ReplicaManager2 * | replicaManager,
 |  | SerializationContext * | serializationContext |
 | ) |  |  | [virtual]

CALLBACK: Called before a download is sent to a new connection

Parameters:
[out] | objectData | What data you want to send to DeSerializeDownloadStarted()
[in] | replicaManager | Which replica manager to use to perform the send
in/out] | serializationContext Target recipient, optional timestamp, type of command

void Connection_RM2::SerializeDownloadComplete | ( | RakNet::BitStream * | objectData,
 |  | ReplicaManager2 * | replicaManager,
 |  | SerializationContext * | serializationContext |
 | ) |  |  | [virtual]

CALLBACK: Called after a download is sent to a new connection

Parameters:
[out] | objectData | What data you want to send to DeSerializeDownloadComplete()
[in] | replicaManager | Which replica manager to use to perform the send
in/out] | serializationContext Target recipient, optional timestamp, type of command

void Connection_RM2::DeserializeDownloadStarted | ( | RakNet::BitStream * | objectData,
 |  | SystemAddress | sender,
 |  | ReplicaManager2 * | replicaManager,
 |  | RakNetTime | timestamp,
 |  | SerializationType | serializationType |
 | ) |  |  | [virtual]

CALLBACK: A new connection was added. All objects that are constructed and visible for this system will arrive immediately after this message. Write data to objectData by deriving from SerializeDownloadStarted()

Note:
Only called if SetAutoUpdateScope is called with serializationVisiblity or construction true. (This is the default)
Parameters:
[in] | objectData | objectData Data written through SerializeDownloadStarted()
[in] | replicaManager | Which replica manager to use to perform the send
[in] | timestamp | timestamp sent, 0 for none
[in] | serializationType | Type of command

void Connection_RM2::DeserializeDownloadComplete | ( | RakNet::BitStream * | objectData,
 |  | SystemAddress | sender,
 |  | ReplicaManager2 * | replicaManager,
 |  | RakNetTime | timestamp,
 |  | SerializationType | serializationType |
 | ) |  |  | [virtual]

CALLBACK: A new connection was added. All objects that are constructed and visible for this system have now arrived. Write data to objectData by deriving from SerializeDownloadComplete

Note:
Only called if SetAutoUpdateScope is called with serializationVisiblity or construction true. (This is the default)
Parameters:
[in] | objectData | objectData Data written through SerializeDownloadComplete()
[in] | replicaManager | Which replica manager to use to perform the send
[in] | timestamp | timestamp sent, 0 for none
[in] | serializationType | Type of command

void Connection_RM2::SetConstructionByList | ( | DataStructures::OrderedList< Replica2 *, Replica2 *, ReplicaManager2::Replica2ObjectComp > & | currentVisibility,
 |  | ReplicaManager2 * | replicaManager |
 | ) |  |  | [virtual]

Given a list of objects, compare it against lastConstructionList. BroadcastConstruct() is called for objects that only exist in the new list. BroadcastDestruct() is called for objects that only exist in the old list. This is used by SetConstructionByReplicaQuery() for all Replica2 that do not return BQR_ALWAYS from Replica2::QueryConstruction() If you want to pass your own, more efficient list to check against, call ReplicaManager2::SetAutoUpdateScope with construction=false and call this function yourself when desired

Parameters:
[in] | List | of all objects that do not return BQR_ALWAYS from Replica2::QueryConstruction() that should currently be created on this system
[in] | replicaManager | Which replica manager to use to perform the send

void Connection_RM2::SetVisibilityByList | ( | DataStructures::OrderedList< Replica2 *, Replica2 *, ReplicaManager2::Replica2ObjectComp > & | currentVisibility,
 |  | ReplicaManager2 * | replicaManager |
 | ) |  |  | [virtual]

Given a list of objects, compare it against lastSerializationList. Replica2::BroadcastVisibility(true) is called for objects that only exist in the new list. Replica2::BroadcastVisibility(false) is called for objects that only exist in the old list. This is used by SetVisibilityByReplicaQuery() for all Replica2 that do not return BQR_ALWAYS from Replica2::QueryVisibility() If you want to pass your own, more efficient list to check against, call ReplicaManager2::SetAutoUpdateScope with construction=false and call this function yourself when desired

Parameters:
[in] | List | of all objects that do not return BQR_ALWAYS from Replica2::QueryConstruction() that should currently be created on this system
[in] | replicaManager | Which replica manager to use to perform the send

void Connection_RM2::SetConstructionByReplicaQuery ( ReplicaManager2 * replicaManager ) [virtual]

Go through all registered Replica2 objects that do not return BQR_ALWAYS from Replica2::QueryConstruction() For each of these objects that return BQR_YES, pass them to currentVisibility in SetConstructionByList() Automatically called every tick if ReplicaManager2::SetAutoUpdateScope with construction=true is called (which is the default)

Parameters:
[in] replicaManager Which replica manager to use to perform the send

void Connection_RM2::SetVisibilityByReplicaQuery ( ReplicaManager2 * replicaManager ) [virtual]

Go through all registered Replica2 objects that do not return BQR_ALWAYS from Replica2::QueryVisibility() For each of these objects that return BQR_YES, pass them to currentVisibility in SetVisibilityByList() Automatically called every tick if ReplicaManager2::SetAutoUpdateScope with construction=true is called (which is the default)

Parameters:
[in] replicaManager Which replica manager to use to perform the send

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/ReplicaManager2.h
  • C:/RakNet/Source/ReplicaManager2.cpp
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::Connection_RM2Factory Class Reference

RakNet::Connection_RM2Factory

RakNet::Connection_RM2Factory Class Reference
[ReplicaManager2]

Implement this factory class to return instances of your Connection_RM2 derived object. This is used as a class factory and exposes functionality related to the connection and the system. More...

#include <ReplicaManager2.h>

List of all members.

Detailed Description

Implement this factory class to return instances of your Connection_RM2 derived object. This is used as a class factory and exposes functionality related to the connection and the system.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/ReplicaManager2.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ConnectionGraph Class Reference

ConnectionGraph Class Reference
[ConnectionGraph]

A connection graph. Each peer will know about all other peers. More...

#include <ConnectionGraph.h>

Inheritance diagram for ConnectionGraph:

PluginInterface List of all members.

Public Member Functions

void | SetPassword (const char *password)
Plaintext encoding of the password, or 0 for none. If you use a password, use secure connections.
DataStructures::WeightedGraph<
ConnectionGraph::SystemAddressAndGroupId,
unsigned short, false > * 		GetGraph (void)
void | SetAutoAddNewConnections (bool autoAdd)
void | RequestConnectionGraph (RakPeerInterface *peer, SystemAddress systemAddress)
void | AddNewConnection (RakPeerInterface *peer, SystemAddress systemAddress, ConnectionGraphGroupID groupId)
void | SetGroupId (ConnectionGraphGroupID groupId)
void | SubscribeToGroup (ConnectionGraphGroupID groupId)
void | UnsubscribeFromGroup (ConnectionGraphGroupID groupId)
virtual void | OnShutdown (RakPeerInterface *peer)
virtual void | Update (RakPeerInterface *peer)
virtual PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
virtual void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)

Classes

struct | SystemAddressAndGroupId
A node in the connection graph. More...

Detailed Description

A connection graph. Each peer will know about all other peers.

Member Function Documentation

DataStructures::WeightedGraph< ConnectionGraph::SystemAddressAndGroupId, unsigned short, false > * ConnectionGraph::GetGraph ( void )

Returns the connection graph

Returns:
The connection graph, stored as map of adjacency lists

void ConnectionGraph::SetAutoAddNewConnections ( bool autoAdd )

Automatically add new connections to the connection graph Defaults to true If true, then the system will automatically add all new connections for you, assigning groupId 0 to these systems. If you want more control, you should call SetAutoAddNewConnections(false); When false, it is up to you to call RequestConnectionGraph and AddNewConnection to complete the graph However, this way you can choose which nodes are on the graph for this system and can assign groupIds to those nodes

Parameters:
[in] autoAdd true to automatically add new connections to the connection graph. False to not do so.

void ConnectionGraph::RequestConnectionGraph | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress
 | ) |  |

Requests the connection graph from another system Only necessary to call if SetAutoAddNewConnections(false) is called. You should call this sometime after getting ID_CONNECTION_REQUEST_ACCEPTED and systemAddress is or should be a node on the connection graph

Parameters:
[in] | peer | The instance of RakPeer to send through
[in] | systemAddress | The system to send to

void ConnectionGraph::AddNewConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress,
 |  | ConnectionGraphGroupID | groupId
 | ) |  |

Adds a new connection to the connection graph from this system to the specified system. Also assigns a group identifier for that system Only used and valid when SetAutoAddNewConnections(false) is called. Call this for this system sometime after getting ID_NEW_INCOMING_CONNECTION or ID_CONNECTION_REQUEST_ACCEPTED for systems that contain a connection graph Groups are sets of one or more nodes in the total graph We only add to the graph groups which we subscribe to

Parameters:
[in] | peer | The instance of RakPeer to send through
[in] | systemAddress | The system that is connected to us.
[in] | groupId | Just a number representing a group. Important: 0 is reserved to mean unassigned group ID and is assigned to all systems added with SetAutoAddNewConnections(true)

void ConnectionGraph::SetGroupId ( ConnectionGraphGroupID groupId )

Sets our own group ID Only used and valid when SetAutoAddNewConnections(false) is called. Defaults to 0

Parameters:
[in] groupId Our group ID

void ConnectionGraph::SubscribeToGroup ( ConnectionGraphGroupID groupId )

Allows adding to the connection graph nodes with this groupId. By default, you subscribe to group 0, which are all systems automatically added with SetAutoAddNewConnections(true) Calling this does not add nodes which were previously rejected due to an unsubscribed group - it only allows addition of nodes after the fact

Parameters:
[in] groupId Just a number representing a group. 0 is reserved to mean unassigned group ID, automatically added with SetAutoAddNewConnections(true)

void ConnectionGraph::UnsubscribeFromGroup ( ConnectionGraphGroupID groupId )

Disables addition of graph nodes with this groupId Calling this does not add remove nodes with this groupId which are already present in the graph. It only disables addition of nodes after the fact

Parameters:
[in] groupId Just a number representing a group. 0 is reserved to mean unassigned group ID, automatically added with SetAutoAddNewConnections(true)

void ConnectionGraph::OnShutdown ( RakPeerInterface * peer ) [virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void ConnectionGraph::Update ( RakPeerInterface * peer ) [virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult ConnectionGraph::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void ConnectionGraph::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/ConnectionGraph.h
  • C:/RakNet/Source/ConnectionGraph.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ConnectionGraph::SystemAddressAndGroupId Struct Reference

ConnectionGraph::SystemAddressAndGroupId

ConnectionGraph::SystemAddressAndGroupId Struct Reference

A node in the connection graph. More...

#include <ConnectionGraph.h>

List of all members.

Detailed Description

A node in the connection graph.

The documentation for this struct was generated from the following files:
  • C:/RakNet/Source/ConnectionGraph.h
  • C:/RakNet/Source/ConnectionGraph.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ConsoleServer Class Reference

ConsoleServer Class Reference

The main entry point for the server portion of your remote console application support. ConsoleServer takes one TransportInterface and one or more CommandParserInterface (s) The TransportInterface will be used to send data between the server and the client. The connecting client must support the protocol used by your derivation of TransportInterface . TelnetTransport and RakNetTransport are two such derivations . When a command is sent by a remote console, it will be processed by your implementations of CommandParserInterface. More...

#include <ConsoleServer.h>

List of all members.

Public Member Functions

void | SetTransportProvider (TransportInterface *transportInterface, unsigned short port)
void | AddCommandParser (CommandParserInterface *commandParserInterface)
void | RemoveCommandParser (CommandParserInterface *commandParserInterface)
void | Update (void)

Detailed Description

The main entry point for the server portion of your remote console application support. ConsoleServer takes one TransportInterface and one or more CommandParserInterface (s) The TransportInterface will be used to send data between the server and the client. The connecting client must support the protocol used by your derivation of TransportInterface . TelnetTransport and RakNetTransport are two such derivations . When a command is sent by a remote console, it will be processed by your implementations of CommandParserInterface.

Member Function Documentation

void ConsoleServer::SetTransportProvider | ( | TransportInterface * | transportInterface,
 |  | unsigned short | port
 | ) |  |

Call this with a derivation of TransportInterface so that the console server can send and receive commands

Parameters:
[in] | transportInterface | Your interface to use.
[in] | port | The port to host on. Telnet uses port 23 by default. RakNet can use whatever you want.

void ConsoleServer::AddCommandParser ( CommandParserInterface * commandParserInterface )

Add an implementation of CommandParserInterface to the list of command parsers.

Parameters:
[in] commandParserInterface The command parser referred to

void ConsoleServer::RemoveCommandParser ( CommandParserInterface * commandParserInterface )

Remove an implementation of CommandParserInterface previously added with AddCommandParser()

Parameters:
[in] commandParserInterface The command parser referred to

void ConsoleServer::Update ( void )

Call update to read packet sent from your TransportInterface. You should do this fairly frequently.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/ConsoleServer.h
  • C:/RakNet/Source/ConsoleServer.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::CreateUser_Data Class Reference

LobbyDBSpec::CreateUser_Data

LobbyDBSpec::CreateUser_Data Class Reference

Adds a user to the users table. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::CreateUser_Data:

RefCountedObj List of all members.

Public Attributes

RakNet::RakString handle
[in] Identifier for the user, cannot exist in the table disallowedHandles
RakNet::RakString firstName
[in] Self-apparent
RakNet::RakString middleName
[in] Self-apparent
RakNet::RakString lastName
[in] Self-apparent
RakNet::RakString race
[in] Self-apparent
RakNet::RakString sex
[in] Self-apparent
RakNet::RakString homeAddress1
[in] Self-apparent
RakNet::RakString homeAddress2
[in] Self-apparent
RakNet::RakString homeCity
[in] Self-apparent
RakNet::RakString homeState
[in] Self-apparent
RakNet::RakString homeProvince
[in] Self-apparent
RakNet::RakString homeCountry
[in] Self-apparent
RakNet::RakString homeZipCode
[in] Self-apparent
RakNet::RakString billingAddress1
[in] Self-apparent
RakNet::RakString billingAddress2
[in] Self-apparent
RakNet::RakString billingCity
[in] Self-apparent
RakNet::RakString billingState
[in] Self-apparent
RakNet::RakString billingProvince
[in] Self-apparent
RakNet::RakString billingCountry
[in] Self-apparent
RakNet::RakString billingZipCode
[in] Self-apparent
RakNet::RakString emailAddress
[in] Self-apparent
RakNet::RakString password
[in] Self-apparent
RakNet::RakString passwordRecoveryQuestion
[in] If the user needs to retrieve their password; you could ask them this question.
RakNet::RakString passwordRecoveryAnswer
[in] If the user needs to retrieve their password; you could use this for the answer.
RakNet::RakString caption1
[in] Lobbies often allow users to set a text description of their user in some fashion.
RakNet::RakString caption2
[in] Lobbies often allow users to set a text description of their user in some fashion.
RakNet::RakString caption3
[in] Lobbies often allow users to set a text description of their user in some fashion.
RakNet::RakString dateOfBirth
[in] Self-apparent
DatabaseKey | accountNumber
[in] If you want to have some kind of unique account number; it can be stored here.
RakNet::RakString creditCardNumber
[in] In case you take credit cards
RakNet::RakString creditCardExpiration
[in] In case you take credit cards
RakNet::RakString creditCardCVV
[in] In case you take credit cards
RakNet::RakString adminLevel
[in] If your lobby supports moderators; you can indicate what moderator level they have here
RakNet::RakString permissions
float | accountBalance
[in] If users can associate money with their account; the current balance can be stored here.
RakNet::RakString sourceIPAddress
[in] In case you want to log IPs
char * | binaryData
[in] If your lobby supports binary data (such as user images) it can be stored with this field.
unsigned int | binaryDataLength
[in] If your lobby supports binary data (such as user images) the length can be in this field.

Detailed Description

Adds a user to the users table.

Member Data Documentation

RakNet::RakString LobbyDBSpec::CreateUser_Data::permissions

[in] Special account permissions; such as being able to chat; join adult games; etc. Encode using text however you wish. TODO - Per-column read/write/update permissions for self or others.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DatabaseCellUpdate Struct Reference

DatabaseCellUpdate Struct Reference

The value to write to a cell in a remote database. More...

#include <LightweightDatabaseCommon.h>

List of all members.

Detailed Description

The value to write to a cell in a remote database.

The documentation for this struct was generated from the following files:
  • C:/RakNet/Source/LightweightDatabaseCommon.h
  • C:/RakNet/Source/LightweightDatabaseCommon.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataBlockEncryptor Class Reference

DataBlockEncryptor Class Reference

Encrypts and decrypts data blocks. More...

#include <DataBlockEncryptor.h>

List of all members.

Public Member Functions

DataBlockEncryptor ()
Constructor.
~DataBlockEncryptor ()
Destructor.
bool | IsKeySet (void) const
Returns:
true if SetKey has been called previously

void | SetKey (const unsigned char key[16])
void | UnsetKey (void)
Unset the encryption key.
void | Encrypt (unsigned char *input, unsigned int inputLength, unsigned char *output, unsigned int *outputLength)
bool | Decrypt (unsigned char *input, unsigned int inputLength, unsigned char *output, unsigned int *outputLength)

Detailed Description

Encrypts and decrypts data blocks.

Member Function Documentation

void DataBlockEncryptor::SetKey ( const unsigned char key[16] )

Set the encryption key

Parameters:
[in] key The new encryption key

void DataBlockEncryptor::Encrypt | ( | unsigned char * | input,
 |  | unsigned int | inputLength,
 |  | unsigned char * | output,
 |  | unsigned int * | outputLength
 | ) |  |

Encryption adds 6 data bytes and then pads the number of bytes to be a multiple of 16. Output should be large enough to hold this. Output can be the same memory block as input

Parameters:
[in] | input | the input buffer to encrypt
[in] | inputLength | the size of the input buffer
[in] | output | the output buffer to store encrypted data
[in] | outputLength | the size of the output buffer

bool DataBlockEncryptor::Decrypt | ( | unsigned char * | input,
 |  | unsigned int | inputLength,
 |  | unsigned char * | output,
 |  | unsigned int * | outputLength
 | ) |  |

Decryption removes bytes, as few as 6. Output should be large enough to hold this. Output can be the same memory block as input

Parameters:
[in] | input | the input buffer to decrypt
[in] | inputLength | the size of the input buffer
[in] | output | the output buffer to store decrypted data
[in] | outputLength | the size of the output buffer
Returns:
False on bad checksum or input, true on success

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/DataBlockEncryptor.h
  • C:/RakNet/Source/DataBlockEncryptor.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataCompressor Class Reference

DataCompressor Class Reference

Does compression on a block of data. Not very good compression, but it's small and fast so is something you can compute at runtime. More...

#include <DataCompressor.h>

List of all members.

Detailed Description

Does compression on a block of data. Not very good compression, but it's small and fast so is something you can compute at runtime.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/DataCompressor.h
  • C:/RakNet/Source/DataCompressor.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DecState Struct Reference

DecState Struct Reference

#include <nb_celp.h>

List of all members.

Public Attributes

const SpeexMode * | mode
int | first
int | count_lost
int | frameSize
int | subframeSize
int | nbSubframes
int | lpcSize
int | min_pitch
int | max_pitch
spx_word16_t | last_ol_gain
char * | stack
spx_sig_t * | inBuf
spx_sig_t * | frame
spx_sig_t * | excBuf
spx_sig_t * | exc
spx_sig_t * | innov
spx_lsp_t * | qlsp
spx_lsp_t * | old_qlsp
spx_lsp_t * | interp_qlsp
spx_coef_t * | interp_qlpc
spx_mem_t * | mem_sp
spx_word32_t * | pi_gain
int | last_pitch
spx_word16_t | last_pitch_gain
spx_word16_t | pitch_gain_buf [3]
int | pitch_gain_buf_idx
int | encode_submode
const SpeexSubmode *const * | submodes
int | submodeID
int | lpc_enh_enabled

Detailed Description

Structure representing the full state of the narrowband decoder

Member Data Documentation

const SpeexMode* DecState::mode

Mode corresponding to the state

int DecState::first

Is this the first frame?

int DecState::count_lost

Was the last frame lost?

int DecState::frameSize

Size of frames

int DecState::subframeSize

Size of sub-frames

int DecState::nbSubframes

Number of sub-frames

int DecState::lpcSize

LPC order

int DecState::min_pitch

Minimum pitch value allowed

int DecState::max_pitch

Maximum pitch value allowed

spx_word16_t DecState::last_ol_gain

Open-loop gain for previous frame

char* DecState::stack

Pseudo-stack allocation for temporary memory

spx_sig_t* DecState::inBuf

Input buffer (original signal)

spx_sig_t* DecState::frame

Start of original frame

spx_sig_t* DecState::excBuf

Excitation buffer

spx_sig_t* DecState::exc

Start of excitation frame

spx_sig_t* DecState::innov

Innovation for the frame

spx_lsp_t* DecState::qlsp

Quantized LSPs for current frame

spx_lsp_t* DecState::old_qlsp

Quantized LSPs for previous frame

spx_lsp_t* DecState::interp_qlsp

Interpolated quantized LSPs

spx_coef_t* DecState::interp_qlpc

Interpolated quantized LPCs

spx_mem_t* DecState::mem_sp

Filter memory for synthesis signal

spx_word32_t* DecState::pi_gain

Gain of LPC filter at theta=pi (fe/2)

int DecState::last_pitch

Pitch of last correctly decoded frame

spx_word16_t DecState::last_pitch_gain

Pitch gain of last correctly decoded frame

spx_word16_t DecState::pitch_gain_buf[3]

Pitch gain of last decoded frames

int DecState::pitch_gain_buf_idx

Tail of the buffer

int DecState::encode_submode

Seed used for random number generation

const SpeexSubmode* const* DecState::submodes

Sub-mode data

int DecState::submodeID

Activated sub-mode

int DecState::lpc_enh_enabled

1 when LPC enhancer is on, 0 otherwise

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/nb_celp.h
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::DeleteEmail_Data Class Reference

LobbyDBSpec::DeleteEmail_Data

LobbyDBSpec::DeleteEmail_Data Class Reference

Deletes an email from either the incomingEmails or sentEmails table. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::DeleteEmail_Data:

RefCountedObj List of all members.

Public Attributes

DatabaseKey emailMessageID
[in] Refers to what email to delete. Get from GetEmails_Data structure, member emails::emailMessageID

Detailed Description

Deletes an email from either the incomingEmails or sentEmails table.

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DirectoryDeltaTransfer Class Reference

DirectoryDeltaTransfer Class Reference
[DirectoryDeltaTransfer]

Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc. More...

#include <DirectoryDeltaTransfer.h>

Inheritance diagram for DirectoryDeltaTransfer:

PluginInterface List of all members.

Public Member Functions

DirectoryDeltaTransfer ()
Constructor.
virtual | ~DirectoryDeltaTransfer ()
Destructor.
void | SetFileListTransferPlugin (FileListTransfer *flt)
void | SetApplicationDirectory (const char *pathToApplication)
void | SetUploadSendParameters (PacketPriority _priority, char _orderingChannel)
void | AddUploadsFromSubdirectory (const char *subdir)
unsigned short | DownloadFromSubdirectory (const char *subdir, const char *outputSubdir, bool prependAppDirToOutputSubdir, SystemAddress host, FileListTransferCBInterface *onFileCallback, PacketPriority _priority, char _orderingChannel, FileListProgress *cb)
void | ClearUploads (void)
Clear all allowed uploads previously set with AddUploadsFromSubdirectory.
unsigned | GetNumberOfFilesForUpload (void) const
void | SetCompressOutgoingSends (bool compress)
virtual void | OnAttach (RakPeerInterface *peer)
virtual void | Update (RakPeerInterface *peer)
virtual PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
virtual void | OnShutdown (RakPeerInterface *peer)

Detailed Description

Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

See also:
Autopatcher class for database driven patching, including binary deltas and search by date.
To use, first set the path to your application. For example "C:/Games/MyRPG/" To allow other systems to download files, call AddUploadsFromSubdirectory, where the parameter is a path relative to the path to your application. This includes subdirectories. For example: SetApplicationDirectory("C:/Games/MyRPG/"); AddUploadsFromSubdirectory("Mods/Skins/"); would allow downloads from "C:/Games/MyRPG/Mods/Skins/*.*" as well as "C:/Games/MyRPG/Mods/Skins/Level1/*.*" It would NOT allow downloads from C:/Games/MyRPG/Levels, nor would it allow downloads from C:/Windows While pathToApplication can be anything you want, applicationSubdirectory must match either partially or fully between systems.

Member Function Documentation

void DirectoryDeltaTransfer::SetFileListTransferPlugin ( FileListTransfer * flt )

This plugin has a dependency on the FileListTransfer plugin, which it uses to actually send the files. So you need an instance of that plugin registered with RakPeerInterface, and a pointer to that interface should be passed here.

Parameters:
[in] flt A pointer to a registered instance of FileListTransfer

void DirectoryDeltaTransfer::SetApplicationDirectory ( const char * pathToApplication )

Set the local root directory to base all file uploads and downloads off of.

Parameters:
[in] pathToApplication This path will be prepended to applicationSubdirectory in AddUploadsFromSubdirectory to find the actual path on disk.

void DirectoryDeltaTransfer::SetUploadSendParameters | ( | PacketPriority | _priority,
 |  | char | _orderingChannel
 | ) |  |

What parameters to use for the RakPeerInterface::Send() call when uploading files.

Parameters:
[in] | _priority | See RakPeerInterface::Send()
[in] | _orderingChannel | See RakPeerInterface::Send()

void DirectoryDeltaTransfer::AddUploadsFromSubdirectory ( const char * subdir )

Add all files in the specified subdirectory recursively subdir is appended to pathToApplication in SetApplicationDirectory(). All files in the resultant directory and subdirectories are then hashed so that users can download them.

Precondition:
You must call SetFileListTransferPlugin with a valid FileListTransfer plugin
Parameters:
[in] subdir Concatenated with pathToApplication to form the final path from which to allow uploads.

unsigned short DirectoryDeltaTransfer::DownloadFromSubdirectory | ( | const char * | subdir,
 |  | const char * | outputSubdir,
 |  | bool | prependAppDirToOutputSubdir,
 |  | SystemAddress | host,
 |  | FileListTransferCBInterface * | onFileCallback,
 |  | PacketPriority | _priority,
 |  | char | _orderingChannel,
 |  | FileListProgress * | cb
 | ) |  |

Downloads files from the matching parameter subdir in AddUploadsFromSubdirectory. subdir must contain all starting characters in subdir in AddUploadsFromSubdirectory Therefore, AddUploadsFromSubdirectory("Levels/Level1/"); would allow you to download using DownloadFromSubdirectory("Levels/Level1/Textures/"... but it would NOT allow you to download from DownloadFromSubdirectory("Levels/"... or DownloadFromSubdirectory("Levels/Level2/"...

Precondition:
You must call SetFileListTransferPlugin with a valid FileListTransfer plugin
Parameters:
[in] | subdir | A directory passed to AddUploadsFromSubdirectory on the remote system. The passed dir can be more specific than the remote dir.
[in] | outputSubdir | The directory to write the output to. Usually this will match subdir but it can be different if you want.
[in] | prependAppDirToOutputSubdir | True to prepend outputSubdir with pathToApplication when determining the final output path. Usually you want this to be true.
[in] | host | The address of the remote system to send the message to.
[in] | onFileCallback | Callback to call per-file (optional). When fileIndex+1==setCount in the callback then the download is done
[in] | _priority | See RakPeerInterface::Send()
[in] | _orderingChannel | See RakPeerInterface::Send()
[in] | cb | Callback to get progress updates. Pass 0 to not use.
Returns:
A set ID, identifying this download set. Returns 65535 on host unreachable.

unsigned DirectoryDeltaTransfer::GetNumberOfFilesForUpload ( void ) const

Returns how many files are available for upload

Returns:
How many files are available for upload

void DirectoryDeltaTransfer::SetCompressOutgoingSends ( bool compress )

Set if we should compress outgoing sends or not Defaults to false, because this results in a noticeable freeze on large requests You can set this to true if you only send small files though

Parameters:
[in] compress True to compress, false to not.

void DirectoryDeltaTransfer::OnAttach ( RakPeerInterface * peer ) [virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void DirectoryDeltaTransfer::Update ( RakPeerInterface * peer ) [virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult DirectoryDeltaTransfer::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void DirectoryDeltaTransfer::OnShutdown ( RakPeerInterface * peer ) [virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/DirectoryDeltaTransfer.h
  • C:/RakNet/Source/DirectoryDeltaTransfer.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: drft_lookup Struct Reference

drft_lookup Struct Reference

#include <smallft.h>

List of all members.

Detailed Description

Discrete Rotational Fourier Transform lookup

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/smallft.h
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: EmailSender Class Reference

EmailSender Class Reference

Rudimentary class to send email from code. More...

#include <EmailSender.h>

List of all members.

Public Member Functions

const char * Send (const char *hostAddress, unsigned short hostPort, const char *sender, const char *recipient, const char *senderName, const char *recipientName, const char *subject, const char *body, FileList *attachedFiles, bool doPrintf, const char *password)

Detailed Description

Rudimentary class to send email from code.

Member Function Documentation

const char * EmailSender::Send | ( | const char * | hostAddress,
 |  | unsigned short | hostPort,
 |  | const char * | sender,
 |  | const char * | recipient,
 |  | const char * | senderName,
 |  | const char * | recipientName,
 |  | const char * | subject,
 |  | const char * | body,
 |  | FileList * | attachedFiles,
 |  | bool | doPrintf,
 |  | const char * | password
 | ) |  |

Sends an email

Parameters:
[in] | hostAddress | The address of the email server.
[in] | hostPort | The port of the email server (usually 25)
[in] | sender | The email address you are sending from.
[in] | recipient | The email address you are sending to.
[in] | senderName | The email address you claim to be sending from
[in] | recipientName | The email address you claim to be sending to
[in] | subject | Email subject
[in] | body | Email body
[in] | attachedFiles | List of files to attach to the email. (Can be 0 to send none).
[in] | doPrintf | true to output SMTP info to console(for debugging?)
[in] | password | Used if the server uses AUTHENTICATE PLAIN over TLS (such as gmail)
Returns:
0 on success, otherwise a string indicating the error message

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/EmailSender.h
  • C:/RakNet/Source/EmailSender.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: EncState Struct Reference

EncState Struct Reference

#include <nb_celp.h>

List of all members.

Public Attributes

const SpeexMode * | mode
int | first
int | frameSize
int | subframeSize
int | nbSubframes
int | windowSize
int | lpcSize
int | min_pitch
int | max_pitch
int | safe_pitch
int | bounded_pitch
int | ol_pitch
int | ol_voiced
spx_word16_t | gamma1
spx_word16_t | gamma2
float | lag_factor
spx_word16_t | lpc_floor
char * | stack
spx_sig_t * | inBuf
spx_sig_t * | frame
spx_sig_t * | excBuf
spx_sig_t * | exc
spx_sig_t * | swBuf
spx_sig_t * | sw
spx_sig_t * | innov
spx_word16_t * | window
spx_word16_t * | autocorr
spx_word16_t * | lagWindow
spx_coef_t * | lpc
spx_lsp_t * | lsp
spx_lsp_t * | qlsp
spx_lsp_t * | old_lsp
spx_lsp_t * | old_qlsp
spx_lsp_t * | interp_lsp
spx_lsp_t * | interp_qlsp
spx_coef_t * | interp_lpc
spx_coef_t * | interp_qlpc
spx_coef_t * | bw_lpc1
spx_coef_t * | bw_lpc2
spx_mem_t * | mem_sp
spx_mem_t * | mem_sw
spx_mem_t * | mem_sw_whole
spx_mem_t * | mem_exc
spx_word32_t * | pi_gain
VBRState * vbr
float | vbr_quality
float | relative_quality
int | vbr_enabled
int | vad_enabled
int | dtx_enabled
int | dtx_count
int | abr_enabled
int | complexity
const SpeexSubmode *const * | submodes
int | submodeID
int | submodeSelect

Detailed Description

Structure representing the full state of the narrowband encoder

Member Data Documentation

const SpeexMode* EncState::mode

Mode corresponding to the state

int EncState::first

Is this the first frame?

int EncState::frameSize

Size of frames

int EncState::subframeSize

Size of sub-frames

int EncState::nbSubframes

Number of sub-frames

int EncState::windowSize

Analysis (LPC) window length

int EncState::lpcSize

LPC order

int EncState::min_pitch

Minimum pitch value allowed

int EncState::max_pitch

Maximum pitch value allowed

int EncState::safe_pitch

Don't use too large values for pitch (in case we lose a packet)

int EncState::bounded_pitch

Next frame should not rely on previous frames for pitch

int EncState::ol_pitch

Open-loop pitch

int EncState::ol_voiced

Open-loop voiced/non-voiced decision

spx_word16_t EncState::gamma1

Perceptual filter: A(z/gamma1)

spx_word16_t EncState::gamma2

Perceptual filter: A(z/gamma2)

float EncState::lag_factor

Lag windowing Gaussian width

spx_word16_t EncState::lpc_floor

Noise floor multiplier for A[0] in LPC analysis

char* EncState::stack

Pseudo-stack allocation for temporary memory

spx_sig_t* EncState::inBuf

Input buffer (original signal)

spx_sig_t* EncState::frame

Start of original frame

spx_sig_t* EncState::excBuf

Excitation buffer

spx_sig_t* EncState::exc

Start of excitation frame

spx_sig_t* EncState::swBuf

Weighted signal buffer

spx_sig_t* EncState::sw

Start of weighted signal frame

spx_sig_t* EncState::innov

Innovation for the frame

spx_word16_t* EncState::window

Temporary (Hanning) window

spx_word16_t* EncState::autocorr

auto-correlation

spx_word16_t* EncState::lagWindow

Window applied to auto-correlation

spx_coef_t* EncState::lpc

LPCs for current frame

spx_lsp_t* EncState::lsp

LSPs for current frame

spx_lsp_t* EncState::qlsp

Quantized LSPs for current frame

spx_lsp_t* EncState::old_lsp

LSPs for previous frame

spx_lsp_t* EncState::old_qlsp

Quantized LSPs for previous frame

spx_lsp_t* EncState::interp_lsp

Interpolated LSPs

spx_lsp_t* EncState::interp_qlsp

Interpolated quantized LSPs

spx_coef_t* EncState::interp_lpc

Interpolated LPCs

spx_coef_t* EncState::interp_qlpc

Interpolated quantized LPCs

spx_coef_t* EncState::bw_lpc1

LPCs after bandwidth expansion by gamma1 for perceptual weighting

spx_coef_t* EncState::bw_lpc2

LPCs after bandwidth expansion by gamma2 for perceptual weighting

spx_mem_t* EncState::mem_sp

Filter memory for signal synthesis

spx_mem_t* EncState::mem_sw

Filter memory for perceptually-weighted signal

spx_mem_t* EncState::mem_sw_whole

Filter memory for perceptually-weighted signal (whole frame)

spx_mem_t* EncState::mem_exc

Filter memory for excitation (whole frame)

spx_word32_t* EncState::pi_gain

Gain of LPC filter at theta=pi (fe/2)

VBRState* EncState::vbr

State of the VBR data

float EncState::vbr_quality

Quality setting for VBR encoding

float EncState::relative_quality

Relative quality that will be needed by VBR

int EncState::vbr_enabled

1 for enabling VBR, 0 otherwise

int EncState::vad_enabled

1 for enabling VAD, 0 otherwise

int EncState::dtx_enabled

1 for enabling DTX, 0 otherwise

int EncState::dtx_count

Number of consecutive DTX frames

int EncState::abr_enabled

ABR setting (in bps), 0 if off

int EncState::complexity

Complexity setting (0-10 from least complex to most complex)

const SpeexSubmode* const* EncState::submodes

Sub-mode data

int EncState::submodeID

Activated sub-mode

int EncState::submodeSelect

Mode chosen by the user (may differ from submodeID if VAD is on)

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/nb_celp.h
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: FileListNode Struct Reference

FileListNode Struct Reference

Represents once instance of a file. More...

#include <FileList.h>

List of all members.

Public Attributes

char * | filename
Name of the file.
char * | data
File data (may be null if not ready).
BitSize_t | dataLengthBytes
Length of data. May be greater than fileLength if prepended with a file hash.
unsigned | fileLengthBytes
Length of the file.
unsigned char | context
User specific data for whatever, describing this file.

Detailed Description

Represents once instance of a file.

The documentation for this struct was generated from the following file:
  • C:/RakNet/Source/FileList.h
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: FileListProgress Class Reference

FileListProgress Class Reference

Callback interface set with FileList::SetCallback() in case you want progress notifications when FileList::AddFilesFromDirectory() is called. More...

#include <FileList.h>

Inheritance diagram for FileListProgress:

FLP_Printf List of all members.

Public Member Functions

virtual void | OnAddFilesFromDirectoryStarted (FileList *fileList, char *dir)
First callback called when FileList::AddFilesFromDirectory() starts.
virtual void | OnDirectory (FileList *fileList, char *dir, unsigned int directoriesRemaining)
Called for each directory, when that directory begins processing.
virtual void | OnFile (FileList *fileList, char *dir, char *fileName, unsigned int fileSize)
Called for each file, when that file begins processing.

Detailed Description

Callback interface set with FileList::SetCallback() in case you want progress notifications when FileList::AddFilesFromDirectory() is called.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/FileList.h
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: FileListTransfer Class Reference

FileListTransfer Class Reference
[FileListTransfer]

A plugin to provide a simple way to compress and incrementally send the files in the FileList structure. Similar to the DirectoryDeltaTransfer plugin, except that it doesn't send deltas based on pre-existing files or actually write the files to disk. More...

#include <FileListTransfer.h>

Inheritance diagram for FileListTransfer:

PluginInterface List of all members.

Public Member Functions

unsigned short | SetupReceive (FileListTransferCBInterface *handler, bool deleteHandler, SystemAddress allowedSender)
void | Send (FileList *fileList, RakPeerInterface *rakPeer, SystemAddress recipient, unsigned short setID, PacketPriority priority, char orderingChannel, bool compressData)
void | CancelReceive (unsigned short setId)
Stop a download.
void | RemoveReceiver (SystemAddress systemAddress)
Remove all handlers associated with a particular system address.
bool | IsHandlerActive (unsigned short setId)
Is a handler passed to SetupReceive still running?
void | SetCallback (FileListProgress *cb)
FileListProgress * | GetCallback (void) const
virtual PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
virtual void | OnShutdown (RakPeerInterface *peer)
virtual void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)
virtual void | OnAttach (RakPeerInterface *peer)
virtual void | Update (RakPeerInterface *peer)

Detailed Description

A plugin to provide a simple way to compress and incrementally send the files in the FileList structure. Similar to the DirectoryDeltaTransfer plugin, except that it doesn't send deltas based on pre-existing files or actually write the files to disk.

Usage: Call SetupReceive to allow one file set to arrive. The value returned by FileListTransfer::SetupReceive() is the setID that is allowed. It's up to you to transmit this value to the other system, along with information indicating what kind of files you want to get. The other system should then prepare a FileList and call FileListTransfer::Send(), passing the return value of FileListTransfer::SetupReceive() as the setID parameter to FileListTransfer::Send()

Member Function Documentation

unsigned short FileListTransfer::SetupReceive | ( | FileListTransferCBInterface * | handler,
 |  | bool | deleteHandler,
 |  | SystemAddress | allowedSender
 | ) |  |

Allows one corresponding Send() call from another system to arrive.

Parameters:
[in] | handler | The class to call on each file
[in] | deleteHandler | True to delete the handler when it is no longer needed. False to not do so.
[in] | allowedSender | Which system to allow files from
Returns:
A set ID value, which should be passed as the setID value to the Send() call on the other system. This value will be returned in the callback and is unique per file set. Returns 65535 on failure (not connected to sender)

void FileListTransfer::Send | ( | FileList * | fileList,
 |  | RakPeerInterface * | rakPeer,
 |  | SystemAddress | recipient,
 |  | unsigned short | setID,
 |  | PacketPriority | priority,
 |  | char | orderingChannel,
 |  | bool | compressData
 | ) |  |

Send the FileList structure to another system, which must have previously called SetupReceive()

Parameters:
[in] | fileList | A list of files. The data contained in FileList::data will be sent incrementally and compressed among all files in the set
[in] | rakPeer | The instance of RakNet to use to send the message
[in] | recipient | The address of the system to send to
[in] | setID | The return value of SetupReceive() which was previously called on recipient
[in] | priority | Passed to RakPeerInterface::Send()
[in] | orderingChannel | Passed to RakPeerInterface::Send()
[in] | compressData | Use a poor but fast compression algorithm. This makes your data larger if it is already compressed or if the amount of data to send is small so don't use it blindly.

void FileListTransfer::SetCallback ( FileListProgress * cb )

Set a callback to get progress reports about what the file list instances do

Parameters:
[in] cb A pointer to an externally defined instance of FileListProgress. This pointer is held internally, so should remain valid as long as this class is valid.

FileListProgress * FileListTransfer::GetCallback ( void ) const

Returns:
what was sent to SetCallback

What was sent to SetCallback

PluginReceiveResult FileListTransfer::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void FileListTransfer::OnShutdown ( RakPeerInterface * peer ) [virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void FileListTransfer::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

void FileListTransfer::OnAttach ( RakPeerInterface * peer ) [virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void FileListTransfer::Update ( RakPeerInterface * peer ) [virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/FileListTransfer.h
  • C:/RakNet/Source/FileListTransfer.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: FileListTransferCBInterface Class Reference

FileListTransferCBInterface Class Reference

Used by FileListTransfer plugin as a callback for when we get a file. You get the last file when fileIndex==setCount. More...

#include <FileListTransferCBInterface.h>

List of all members.

Public Member Functions

virtual bool | OnFile (OnFileStruct *onFileStruct)=0
virtual void | OnFileProgress (OnFileStruct *onFileStruct, unsigned int partCount, unsigned int partTotal, unsigned int partLength, char *firstDataChunk)
virtual bool | Update (void)
virtual bool | OnDownloadComplete (void)
virtual void | OnDereference (void)

Detailed Description

Used by FileListTransfer plugin as a callback for when we get a file. You get the last file when fileIndex==setCount.

See also:
FileListTransfer

Member Function Documentation

virtual bool FileListTransferCBInterface::OnFile ( OnFileStruct * onFileStruct ) [pure virtual]

Got a file This structure is only valid for the duration of this function call.

Returns:
Return true to have RakNet delete the memory allocated to hold this file for this function call.

virtual void FileListTransferCBInterface::OnFileProgress | ( | OnFileStruct * | onFileStruct,
 |  | unsigned int | partCount,
 |  | unsigned int | partTotal,
 |  | unsigned int | partLength,
 |  | char * | firstDataChunk |
 | ) |  |  | [inline, virtual]

Got part of a big file. You can get these notifications by calling RakPeer::SetSplitMessageProgressInterval Otherwise you will only get complete files.

Parameters:
[in] | onFileStruct | General information about this file, such as the filename and the first partLength bytes. You do NOT need to save this data yourself. The complete file will arrive normally.
[in] | partCount | The zero based index into partTotal. The percentage complete done of this file is 100 * (partCount+1)/partTotal
[in] | partTotal | The total number of parts this file was split into. Each part will be roughly the MTU size, minus the UDP header and RakNet headers
[in] | partLength | How many bytes long firstDataChunk is
[in] | firstDataChunk | The first partLength of the final file. If you store identifying information about the file in the first partLength bytes, you can read them while the download is taking place. If this hasn't arrived yet, firstDataChunk will be 0

virtual bool FileListTransferCBInterface::Update ( void ) [inline, virtual]

Called while the handler is active by FileListTransfer Return false when you are done with the class At that point OnDereference will be called and the class will no longer be maintained by the FileListTransfer plugin.

virtual bool FileListTransferCBInterface::OnDownloadComplete ( void ) [inline, virtual]

Called when the download is completed. If you are finished with this class, return false At that point OnDereference will be called and the class will no longer be maintained by the FileListTransfer plugin. Otherwise return true, and Update will continue to be called.

virtual void FileListTransferCBInterface::OnDereference ( void ) [inline, virtual]

This function is called when this instance is about to be dereferenced by the FileListTransfer plugin. Update will no longer be called. It will will be deleted automatically if true was passed to FileListTransfer::SetupReceive::deleteHandler Otherwise it is up to you to delete it yourself.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/FileListTransferCBInterface.h
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: FLP_Printf Class Reference

FLP_Printf Class Reference

Implementation of FileListProgress to use printf. More...

#include <FileList.h>

Inheritance diagram for FLP_Printf:

FileListProgress List of all members.

Public Member Functions

virtual void | OnAddFilesFromDirectoryStarted (FileList *fileList, char *dir)
First callback called when FileList::AddFilesFromDirectory() starts.
virtual void | OnDirectory (FileList *fileList, char *dir, unsigned int directoriesRemaining)
Called for each directory, when that directory begins processing.

Detailed Description

Implementation of FileListProgress to use printf.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/FileList.h
  • C:/RakNet/Source/FileList.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: FullyConnectedMesh Class Reference

FullyConnectedMesh Class Reference
[FullyConnectedMesh]

#include <FullyConnectedMesh.h>

Inheritance diagram for FullyConnectedMesh:

PluginInterface List of all members.

Public Member Functions

void | Startup (const char *password, int _passwordLength)
Set the password to use to connect to the other systems.
void | ConnectWithNatPunchthrough (NatPunchthrough *np, SystemAddress _facilitator)
virtual void | OnShutdown (RakPeerInterface *peer)
virtual void | Update (RakPeerInterface *peer)
virtual PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)

Detailed Description

Fully connected mesh plugin. This will connect RakPeer to all connecting peers, and all peers the connecting peer knows about.
Precondition:
You must also install the ConnectionGraph plugin. If you want a password, set it there.

Member Function Documentation

void FullyConnectedMesh::ConnectWithNatPunchthrough | ( | NatPunchthrough * | np,
 |  | SystemAddress | _facilitator
 | ) |  |

Use the NAT punchthrough system to connect rather than calling directly

Parameters:
[in] | np | Pointer to an attached instance of the NatPunchthrough plugin
[in] | _facilitator | Address of the NAT punchthrough facilitator

void FullyConnectedMesh::OnShutdown ( RakPeerInterface * peer ) [virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void FullyConnectedMesh::Update ( RakPeerInterface * peer ) [virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult FullyConnectedMesh::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/FullyConnectedMesh.h
  • C:/RakNet/Source/FullyConnectedMesh.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::FunctionThread Class Reference

RakNet::FunctionThread

RakNet::FunctionThread Class Reference

#include <FunctionThread.h>

List of all members.

Public Member Functions

void | StartThreads (int numThreads)
Starts the thread up.
void | StopThreads (bool blockOnCurrentProcessing)
void | Push (Functor *functor, void *context=0)
void | CallResultHandlers (void)
void | CancelFunctorsWithContext (bool(*cancelThisFunctor)(FunctorAndContext func, void *userData), void *userData)
void | SetPostResultFunction (void(*postResult)(FunctorAndContext func))

Detailed Description

FunctionThread takes a stream of classes that implement a processing function, processes them in a thread, and calls a callback with the result. It's a useful way to call blocking functions that you do not want to block, such as file writes and database operations.

Member Function Documentation

void FunctionThread::StopThreads ( bool blockOnCurrentProcessing )

Stop processing. Will also call FunctorResultHandler callbacks with /a wasCancelled set to true.

Parameters:
[in] blockOnCurrentProcessing Wait for the current processing to finish?

void FunctionThread::Push | ( | Functor * | functor,
 |  | void * | context = 0
 | ) |  |

Add a functor to the incoming stream of functors

Note:
functor MUST be a valid pointer until Functor::HandleResult() is called, at which point the pointer is returned to you.

For practical purposes this means the instance of functor you pass to this function has to be allocated using new and delete.

You should deallocate the pointer inside Functor::HandleResult()

Parameters:
[in] | functor | A pointer to an implemented Functor class
[in] | If | there is some context to this functor you want to look up to cancel it, you can set it here. Returned back to you in Functor::HandleResult

void FunctionThread::CallResultHandlers ( void )

Call FunctorResultHandler callbacks Normally you would call this once per update cycle, although you do not have to.

void FunctionThread::CancelFunctorsWithContext | ( | bool(*)(FunctorAndContext func, void *userData) | cancelThisFunctor,
 |  | void * | userData
 | ) |  |

If you want to cancel input and output functors associated with some context, you can pass a function to do that here

Parameters:
[in] | cancelThisFunctor | Function should return true to cancel the functor, false to let it process
[in] | userData | Pointer to whatever you want. Passed to the cancelThisFunctor call

void FunctionThread::SetPostResultFunction ( void(*)(FunctorAndContext func) postResult )

If you want to automatically do some kind of processing on every functor after Functor::HandleResult is called, set it here. Useful to cleanup FunctionThread::Push::context

Parameters:
[in] postResult pointer to a C function to do post-processing

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/FunctionThread.h
  • C:/RakNet/Source/FunctionThread.cpp
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::Functor Class Reference

RakNet::Functor

RakNet::Functor Class Reference

#include <FunctionThread.h>

Inheritance diagram for RakNet::Functor:

InlineFunctor List of all members.

Public Member Functions

virtual void | Process (void *context)=0
virtual void | HandleResult (bool wasCancelled, void *context)=0

Detailed Description

A functor is a single unit of processing to send to the Function thread. Derive from it, add your data, and implement the processing function.

Member Function Documentation

virtual void RakNet::Functor::Process ( void * context ) [pure virtual]

Do whatever processing you want.

Parameters:
[in] context pointer passed to FunctionThread::Push::context

virtual void RakNet::Functor::HandleResult | ( | bool | wasCancelled,
 |  | void * | context |
 | ) |  |  | [pure virtual]

Called from FunctionThread::CallResultHandlers with wasCancelled false OR Called from FunctionThread::StopThread or FunctionThread::~FunctionThread with wasCancelled true

Parameters:
[in] | wasCancelledTrue | if CallResultHandlers was called, false if StopThreads or CancelInputWithContext was called before Functor::Process()
[in] | context | pointer passed to FunctionThread::Push::context

Implemented in InlineFunctor.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/FunctionThread.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::GetAccountNotes_Data Class Reference

LobbyDBSpec::GetAccountNotes_Data

LobbyDBSpec::GetAccountNotes_Data Class Reference

Gets all account notes for an existing user. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::GetAccountNotes_Data:

RefCountedObj List of all members.

Public Attributes

RowIdOrHandle | id
[in / out] Which user.
bool | ascendingSort
[in] Sort list by creationTime, ascending. False for descending.

Detailed Description

Gets all account notes for an existing user.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::GetEmails_Data Class Reference

LobbyDBSpec::GetEmails_Data

LobbyDBSpec::GetEmails_Data Class Reference

Gets all emails in the emails table for a particular user. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::GetEmails_Data:

RefCountedObj List of all members.

Public Attributes

RowIdOrHandle | id
[in / out] Which user. If hasUserId==false userId is filled in.
bool | inbox
[in] Check the inbox or sent emails?
bool | ascendingSort
[in] Sort list by creationTime, ascending. False for descending.
bool | validParameters
[out] Are the parameters of this email valid?
RakNet::RakString failureMessage
[out] If validParameters==false, this is why

Detailed Description

Gets all emails in the emails table for a particular user.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.cpp
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::GetFriends_Data Class Reference

LobbyDBSpec::GetFriends_Data

LobbyDBSpec::GetFriends_Data Class Reference

Gets the friends table for a userId or userHandle. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::GetFriends_Data:

RefCountedObj List of all members.

Public Attributes

RowIdOrHandle | id
[in / out] Which user. If hasUserId==false userId is filled in.
bool | ascendingSort
[in] Sort list by creationTime, ascending. False for descending.

Detailed Description

Gets the friends table for a userId or userHandle.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RankingServerDBSpec::GetHistoryForParticipant_Data Class Reference

RankingServerDBSpec::GetHistoryForParticipant_Data

RankingServerDBSpec::GetHistoryForParticipant_Data Class Reference

Given a particular player and game, get a match history. More...

#include <RankingServerDBSpec.h>

Inheritance diagram for RankingServerDBSpec::GetHistoryForParticipant_Data:

RefCountedObj GetHistoryForParticipant_PostgreSQLImpl List of all members.

Public Attributes

PairedKeyDbId participantDbId
[in] An integer ID used as the primary key for the player in the database. Should have been previously been added either externally, or through SubmitRatings
PairedKeyDbId gameDbId
[in] Identifies in the game in the database with a primary and secondary integer key. User defined.
DataStructures::List< SubmitMatch_Data * > matchHistoryList

Detailed Description

Given a particular player and game, get a match history.

Member Data Documentation

DataStructures::List<SubmitMatch_Data*> RankingServerDBSpec::GetHistoryForParticipant_Data::matchHistoryList

[out] Stores a list of pointers to allocated structures, each structure holding what was previously passed to SubmitMatch. Deallocated in the destructor. If no such participant found, matchHistoryList.Size() will be 0.

Note:
All [in] parameters in SubmitMatch_Data are treated as [out] parameters.

participantA is the player we are referring to.

participantB is his/her opponent for that match.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: GetHistoryForParticipant_PostgreSQLImpl Class Reference

GetHistoryForParticipant_PostgreSQLImpl Class Reference

Given a particular player and game, get a match history. More...

#include <RankingServer_PostgreSQL.h>

Inheritance diagram for GetHistoryForParticipant_PostgreSQLImpl:

RankingServerDBSpec::GetHistoryForParticipant_Data RefCountedObj List of all members.

Public Member Functions

virtual void | Process (void *context)
Does SQL Processing.
virtual void | HandleResult (bool wasCancelled, void *context)

Static Public Member Functions

static GetHistoryForParticipant_PostgreSQLImpl * | Alloc (void)
Use these for allocation/deallocation if building to a DLL, so allocation and deallocation happen in the same DLL.

Detailed Description

Given a particular player and game, get a match history.

Member Function Documentation

void GetHistoryForParticipant_PostgreSQLImpl::HandleResult | ( | bool | wasCancelled,
 |  | void * | context |
 | ) |  |  | [virtual]

Calls the callback specified by RankingServerFunctor::callback (which you set) or RankingServer_PostgreSQL::AssignCallback() (which sets it for you) Default implementation also deallocates the structure.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.h
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::GetIgnoreList_Data Class Reference

LobbyDBSpec::GetIgnoreList_Data

LobbyDBSpec::GetIgnoreList_Data Class Reference

Gets the ignoreList table for a particular userId / userHandle. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::GetIgnoreList_Data:

RefCountedObj List of all members.

Public Attributes

RowIdOrHandle | id
[in / out] Which user. If hasUserId==false userId is filled in.
bool | ascendingSort
[in] Sort list by creationTime, ascending. False for descending.

Detailed Description

Gets the ignoreList table for a particular userId / userHandle.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.cpp
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RankingServerDBSpec::GetRatingForParticipant_Data Class Reference

RankingServerDBSpec::GetRatingForParticipant_Data

RankingServerDBSpec::GetRatingForParticipant_Data Class Reference

Given a particular player and game, get that player's rating from the database. More...

#include <RankingServerDBSpec.h>

Inheritance diagram for RankingServerDBSpec::GetRatingForParticipant_Data:

RefCountedObj GetRatingForParticipant_PostgreSQLImpl List of all members.

Public Attributes

PairedKeyDbId participantDbId
[in] An integer ID used as the primary key for the player in the database. Should have been previously been added either externally, or through SubmitRatings
PairedKeyDbId gameDbId
[in] Identifies in the game in the database with a primary and secondary integer key. User defined.
bool | participantFound
[out] Was this participant found?
float | rating
[out] Pointer to whatever you want. Returned in GetRatingForParticipantCB().

Detailed Description

Given a particular player and game, get that player's rating from the database.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: GetRatingForParticipant_PostgreSQLImpl Class Reference

GetRatingForParticipant_PostgreSQLImpl Class Reference

Given a particular player and game, get that player's rating from the database. More...

#include <RankingServer_PostgreSQL.h>

Inheritance diagram for GetRatingForParticipant_PostgreSQLImpl:

RankingServerDBSpec::GetRatingForParticipant_Data RefCountedObj List of all members.

Public Member Functions

virtual void | Process (void *context)
Does SQL Processing.
virtual void | HandleResult (bool wasCancelled, void *context)

Static Public Member Functions

static GetRatingForParticipant_PostgreSQLImpl * | Alloc (void)
Use these for allocation/deallocation if building to a DLL, so allocation and deallocation happen in the same DLL.

Detailed Description

Given a particular player and game, get that player's rating from the database.

Member Function Documentation

void GetRatingForParticipant_PostgreSQLImpl::HandleResult | ( | bool | wasCancelled,
 |  | void * | context |
 | ) |  |  | [virtual]

Calls the callback specified by RankingServerFunctor::callback (which you set) or RankingServer_PostgreSQL::AssignCallback() (which sets it for you) Default implementation also deallocates the structure.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.h
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RankingServerDBSpec::GetRatingForParticipants_Data Class Reference

RankingServerDBSpec::GetRatingForParticipants_Data

RankingServerDBSpec::GetRatingForParticipants_Data Class Reference

Given a particular game, get ratings for all players. More...

#include <RankingServerDBSpec.h>

Inheritance diagram for RankingServerDBSpec::GetRatingForParticipants_Data:

RefCountedObj GetRatingForParticipants_PostgreSQLImpl List of all members.

Public Attributes

PairedKeyDbId gameDbId
[in] Identifies in the game in the database with a primary and secondary integer key. User defined.
DataStructures::List< RatedEntity > outputList
[out] List of players and rankings for a given gameId

Detailed Description

Given a particular game, get ratings for all players.

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: GetRatingForParticipants_PostgreSQLImpl Class Reference

GetRatingForParticipants_PostgreSQLImpl Class Reference

Given a particular game, get ratings for all players. More...

#include <RankingServer_PostgreSQL.h>

Inheritance diagram for GetRatingForParticipants_PostgreSQLImpl:

RankingServerDBSpec::GetRatingForParticipants_Data RefCountedObj List of all members.

Public Member Functions

virtual void | Process (void *context)
Does SQL Processing.
virtual void | HandleResult (bool wasCancelled, void *context)

Static Public Member Functions

static GetRatingForParticipants_PostgreSQLImpl * | Alloc (void)
Use these for allocation/deallocation if building to a DLL, so allocation and deallocation happen in the same DLL.

Detailed Description

Given a particular game, get ratings for all players.

Member Function Documentation

void GetRatingForParticipants_PostgreSQLImpl::HandleResult | ( | bool | wasCancelled,
 |  | void * | context |
 | ) |  |  | [virtual]

Calls the callback specified by RankingServerFunctor::callback (which you set) or RankingServer_PostgreSQL::AssignCallback() (which sets it for you) Default implementation also deallocates the structure.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.h
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.cpp
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: TitleValidationDBSpec::GetTitles_Data Class Reference

TitleValidationDBSpec::GetTitles_Data

TitleValidationDBSpec::GetTitles_Data Class Reference

Download all titles added with AddTitle_Data. More...

#include <TitleValidationDBSpec.h>

Inheritance diagram for TitleValidationDBSpec::GetTitles_Data:

RefCountedObj List of all members.

Public Attributes

DataStructures::List< AddTitle_Data * > titles
[out] Titles previously added with AddTitle_Data

Detailed Description

Download all titles added with AddTitle_Data.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/TitleValidationDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/TitleValidationDBSpec.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RankingServerDBSpec::GetTrustedIPList_Data Class Reference

RankingServerDBSpec::GetTrustedIPList_Data

RankingServerDBSpec::GetTrustedIPList_Data Class Reference

#include <RankingServerDBSpec.h>

Inheritance diagram for RankingServerDBSpec::GetTrustedIPList_Data:

RefCountedObj List of all members.

Public Attributes

DataStructures::List< ModifyTrustedIPList_Data * > ipList
[out] List of IPs. [in] parameters in ModifyTrustedIPList_Data are now [out] parameters

Detailed Description

Add or drop an allowed IP to submit matches This is not enforced in the database, but can be enforced in code

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::GetUser_Data Class Reference

LobbyDBSpec::GetUser_Data

LobbyDBSpec::GetUser_Data Class Reference

Get a user from the users table, using userId or userHandle for the lookup. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::GetUser_Data:

RefCountedObj List of all members.

Public Attributes

bool | getCCInfo
[in] Get credit card info? (including billing info)
bool | getBinaryData
[in] Get binary data?
bool | getPersonalInfo
[in] Get personal information (Name, address)
bool | getEmailAddr
[in] Get email address?
bool | getPassword
[in] Get password, recovery question, and recovery answer?
RowIdOrHandle | id
[in / out] Which user. If hasUserId==false userId is filled in on return.
bool | userFound
[out] Does this user exist?
CreateUser_Data output
[out] All [in] parameters are now [out] parameters. Data not downloaded is not changed.
bool | isBanned
[out] Tag if this user is banned or not. Set directly in the DB (or I can add a function later).
bool | isSuspended
[out] Tag if this user is suspended or not. Suspensions are temporary
long long | suspensionExpiration
[out] When the suspension expires. Parse with _localtime64()
RakNet::RakString banOrSuspensionReason
[out] Why the user was banned or suspended.
long long | creationTime
[out] When this row was added to the database. Parse with _localtime64()

Detailed Description

Get a user from the users table, using userId or userHandle for the lookup.

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: HTTPConnection Class Reference

HTTPConnection Class Reference

Use HTTPConnection to communicate with a web server. Start an instance of TCPInterface via the Start() command. Instantiate a new instance of HTTPConnection, and associate TCPInterface with the class in the constructor. Use Post() to send commands to the web server, and ProcessDataPacket() to update the connection with packets returned from TCPInterface that have the system address of the web server This class will handle connecting and reconnecting as necessary. More...

#include <HTTPConnection.h>

List of all members.

Public Types

enum | ResponseCodes

Public Member Functions

HTTPConnection (TCPInterface &tcp, const char *host, unsigned short port=80)
void | Post (const char *path, const char *data, const char *_contentType="application/x-www-form-urlencoded")
Parameters:
contentType "Content-Type:" passed to post.

RakNet::RakString | Read (void)
void | Update (void)
Call periodically to do time-based updates.
SystemAddress | GetServerAddress (void) const
Returns the address of the server we are connected to.
bool | ProcessFinalTCPPacket (Packet *packet)
Returns:
true when all data from one Post() has been read.

bool | HasBadResponse (int *code, RakNet::RakString *data)
Queued events of failed exchanges with the HTTP server.
bool | IsBusy (void) const
Returns false if the connection is not doing anything else.

Classes

struct | BadResponse
Encapsulates a raw HTTP response and response code. More...

Detailed Description

Use HTTPConnection to communicate with a web server. Start an instance of TCPInterface via the Start() command. Instantiate a new instance of HTTPConnection, and associate TCPInterface with the class in the constructor. Use Post() to send commands to the web server, and ProcessDataPacket() to update the connection with packets returned from TCPInterface that have the system address of the web server This class will handle connecting and reconnecting as necessary.

Note that only one Post() can be handled at a time.

Member Enumeration Documentation

enum HTTPConnection::ResponseCodes

Results of HTTP requests. Standard response codes are < 999 ( define HTTP codes and our internal codes as needed )

Constructor & Destructor Documentation

HTTPConnection::HTTPConnection | ( | TCPInterface & | tcp,
 |  | const char * | host,
 |  | unsigned short | port = 80
 | ) |  |

Returns a HTTP object associated with this tcp connection

Precondition:
tcp should already be started

Member Function Documentation

void HTTPConnection::Post | ( | const char * | path,
 |  | const char * | data,
 |  | const char * | _contentType = "application/x-www-form-urlencoded"
 | ) |  |

Parameters:
contentType "Content-Type:" passed to post.

Parameters:
path | the path on the remote server you want to POST to. For example "mywebpage/index.html"
data | A NULL terminated string to submit to the server

RakString HTTPConnection::Read ( void )

Get data returned by the HTTP server If IsFinished()==false then this may be empty or a partial response.

bool HTTPConnection::ProcessFinalTCPPacket ( Packet * packet )

Returns:
true when all data from one Post() has been read.

Parameters:
packet NULL or a packet associated with our host and port

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/HTTPConnection.h
  • C:/RakNet/Source/HTTPConnection.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: HTTPConnection::BadResponse Struct Reference

HTTPConnection::BadResponse

HTTPConnection::BadResponse Struct Reference

Encapsulates a raw HTTP response and response code. More...

#include <HTTPConnection.h>

List of all members.

Detailed Description

Encapsulates a raw HTTP response and response code.

The documentation for this struct was generated from the following file:
  • C:/RakNet/Source/HTTPConnection.h
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: HuffmanEncodingTree Class Reference

HuffmanEncodingTree Class Reference

This generates special cases of the huffman encoding tree using 8 bit keys with the additional condition that unused combinations of 8 bits are treated as a frequency of 1. More...

#include <DS_HuffmanEncodingTree.h>

List of all members.

Public Member Functions

void | EncodeArray (unsigned char *input, size_t sizeInBytes, RakNet::BitStream *output)
void | GenerateFromFrequencyTable (unsigned int frequencyTable[256])
Given a frequency table of 256 elements, all with a frequency of 1 or more, generate the tree.
void | FreeMemory (void)
Free the memory used by the tree.

Detailed Description

This generates special cases of the huffman encoding tree using 8 bit keys with the additional condition that unused combinations of 8 bits are treated as a frequency of 1.

Member Function Documentation

void HuffmanEncodingTree::EncodeArray | ( | unsigned char * | input,
 |  | size_t | sizeInBytes,
 |  | RakNet::BitStream * | output
 | ) |  |

Pass an array of bytes to array and a preallocated BitStream to receive the output

Parameters:
[in] | input | Array of bytes to encode
[in] | sizeInBytes | size of input
[out] | output | The bitstream to write to

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/DS_HuffmanEncodingTree.h
  • C:/RakNet/Source/DS_HuffmanEncodingTree.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: HuffmanEncodingTreeFactory Class Reference

HuffmanEncodingTreeFactory Class Reference

Creates instances of the class HuffmanEncodingTree. More...

#include <DS_HuffmanEncodingTreeFactory.h>

List of all members.

Public Member Functions

HuffmanEncodingTreeFactory ()
Default constructor.
void | Reset (void)
Reset the frequency table. You don't need to call this unless you want to reuse the class for a new tree.
void | AddToFrequencyTable (unsigned char *array, int size)
void | GetFrequencyTable (unsigned int _frequency[256])
unsigned int * | GetFrequencyTable (void)
HuffmanEncodingTree * | GenerateTree (void)

Detailed Description

Creates instances of the class HuffmanEncodingTree.

This class takes a frequency table and given that frequence table, will generate an instance of HuffmanEncodingTree

Member Function Documentation

void HuffmanEncodingTreeFactory::AddToFrequencyTable | ( | unsigned char * | array,
 |  | int | size
 | ) |  |

Pass an array of bytes to this to add those elements to the frequency table

Parameters:
[in] | array | the data to insert into the frequency table
[in] | size | the size of the data to insert

void HuffmanEncodingTreeFactory::GetFrequencyTable ( unsigned int _frequency[256] )

Copies the frequency table to the array passed Retrieve the frequency table

Parameters:
[in] _frequency The frequency table used currently

unsigned int* HuffmanEncodingTreeFactory::GetFrequencyTable ( void )

Returns the frequency table as a pointer

Returns:
the address of the frenquency table

HuffmanEncodingTree* HuffmanEncodingTreeFactory::GenerateTree ( void )

Generate a HuffmanEncodingTree. You can also use GetFrequencyTable and GenerateFromFrequencyTable in the tree itself

Returns:
The generated instance of HuffmanEncodingTree

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/DS_HuffmanEncodingTreeFactory.h
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: InlineFunctor Class Reference

InlineFunctor Class Reference

A base class to derive functors from for the InlineFunctorProcessor system. More...

#include <InlineFunctor.h>

Inheritance diagram for InlineFunctor:

RakNet::Functor List of all members.

Protected Member Functions

virtual void | HandleResult (bool wasCancelled, void *context)

Protected Attributes

int | callDepth
Tracks the call depth when this functor was pushed. It allows the system to return from functions in the correct order.
InlineFunctorProcessor * ifp
Pointer to the calling instance of InlineFunctorProcessor.

Friends

class | InlineFunctorProcessor

Detailed Description

A base class to derive functors from for the InlineFunctorProcessor system.

Member Function Documentation

void InlineFunctor::HandleResult | ( | bool | wasCancelled,
 |  | void * | context |
 | ) |  |  | [protected, virtual]

Called from FunctionThread::CallResultHandlers with wasCancelled false OR Called from FunctionThread::StopThread or FunctionThread::~FunctionThread with wasCancelled true

Parameters:
[in] | wasCancelledTrue | if CallResultHandlers was called, false if StopThreads or CancelInputWithContext was called before Functor::Process()
[in] | context | pointer passed to FunctionThread::Push::context

Implements RakNet::Functor.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/InlineFunctor.h
  • C:/RakNet/Source/InlineFunctor.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: InlineFunctorProcessor Class Reference

InlineFunctorProcessor Class Reference

A base class that will allow you to call YieldOnFunctor() from within a function, and continue with that function when the asynchronous processing has completed. More...

#include <InlineFunctor.h>

List of all members.

Public Member Functions

void | StartThreads (int numThreads)
void | StopThreads (bool blockOnCurrentProcessing)
void | YieldOnFunctor (InlineFunctor *inlineFunctor)

Protected Member Functions

unsigned | GetCallDepth (void) const
Returns the number of functors that were passed to the system.

Protected Attributes

RakNet::FunctionThread functionThread
Used to create a thread that processes functors.
DataStructures::List< bool > | completedThreads
Tracks which threads have been completed.

Detailed Description

A base class that will allow you to call YieldOnFunctor() from within a function, and continue with that function when the asynchronous processing has completed.

Member Function Documentation

void InlineFunctorProcessor::StartThreads ( int numThreads )

Start the threads. Should call this first

Parameters:
[in] numThreads How many worker threads to start
Note:
If only one thread is started, then the calls to YieldOnFunctor will process in that order

void InlineFunctorProcessor::StopThreads ( bool blockOnCurrentProcessing )

Stop the threads

Parameters:
[in] blockOnCurrentProcessing Wait for the current processing to finish?

void InlineFunctorProcessor::YieldOnFunctor ( InlineFunctor * inlineFunctor )

Yield processing in the current function, continuing with the function implemented by CallYieldFunction When the functor completes, this function will return and the caller will continue processing

Parameters:
[in] inlineFunctor A class that implements Functor::Process() to perform processing that can work asynchronously, such as loading a file or doing a database call

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/InlineFunctor.h
  • C:/RakNet/Source/InlineFunctor.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: InternalPacket Struct Reference

InternalPacket Struct Reference

#include <InternalPacket.h>

List of all members.

Public Attributes

MessageNumberType messageNumber
A unique numerical identifier given to this user message. Used to identify messages on the network.
MessageNumberType messageInternalOrder
Identifies the order in which this number was sent. Used locally.
bool | messageNumberAssigned
unsigned | packetNumber
Used only for tracking packetloss and windowing internally, this is the aggreggate packet number that a message was last sent in.
PacketPriority priority
The priority level of this packet.
PacketReliability reliability
What type of reliability algorithm to use with this packet.
unsigned char | orderingChannel
What ordering channel this packet is on, if the reliability type uses ordering channels.
OrderingIndexType orderingIndex
The ID used as identification for ordering channels.
SplitPacketIdType | splitPacketId
The ID of the split packet, if we have split packets. This is the maximum number of split messages we can send simultaneously per connection.
SplitPacketIndexType | splitPacketIndex
If this is a split packet, the index into the array of subsplit packets.
SplitPacketIndexType | splitPacketCount
The size of the array of subsplit packets.
RakNetTimeNS | creationTime
When this packet was created.
RakNetTimeNS | nextActionTime
The next time to take action on this packet.
BitSize_t | dataBitLength
How many bits the data is.
unsigned char * | data
Buffer is a pointer to the actual data, assuming this packet has data at all.

Detailed Description

Holds a user message, and related information Don't use a constructor or destructor, due to the memory pool I am using

Member Data Documentation

bool InternalPacket::messageNumberAssigned

Has this message number been assigned yet? We don't assign until the message is actually sent. This fixes a bug where pre-determining message numbers and then sending a message on a different channel creates a huge gap. This causes performance problems and causes those messages to timeout.

The documentation for this struct was generated from the following file:
  • C:/RakNet/Source/InternalPacket.h
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::LeaveClan_Notification Struct Reference

RakNet::LeaveClan_Notification

RakNet::LeaveClan_Notification Struct Reference

Someone has left this clan. More...

#include <LobbyClientInterface.h>

List of all members.

Public Attributes

LobbyClientUserId * | userId
User that this action was referring to.
ClanId * | clanId
Clan this action is in reference to.

Detailed Description

Someone has left this clan.

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyClientInterface.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LightweightDatabaseClient Class Reference

LightweightDatabaseClient Class Reference
[LightweightDatabase]

The client interface to the simple database included with RakNet, useful for a server browser or a lobby server. More...

#include <LightweightDatabaseClient.h>

Inheritance diagram for LightweightDatabaseClient:

PluginInterface List of all members.

Public Member Functions

LightweightDatabaseClient ()
Constructor.
virtual | ~LightweightDatabaseClient ()
Destructor.
void | QueryTable (const char *tableName, const char *queryPassword, const char **columnNamesSubset, unsigned char numColumnSubset, DatabaseFilter *filter, unsigned char numFilters, unsigned *rowIds, unsigned char numRowIDs, SystemAddress systemAddress, bool broadcast)
void | UpdateRow (const char *tableName, const char *updatePassword, RowUpdateMode updateMode, bool hasRowId, unsigned rowId, DatabaseCellUpdate *cellUpdates, unsigned char numCellUpdates, SystemAddress systemAddress, bool broadcast)
void | RemoveRow (const char *tableName, const char *removePassword, unsigned rowId, SystemAddress systemAddress, bool broadcast)
void | OnAttach (RakPeerInterface *peer)
virtual PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)

Detailed Description

The client interface to the simple database included with RakNet, useful for a server browser or a lobby server.

Member Function Documentation

void LightweightDatabaseClient::QueryTable | ( | const char * | tableName,
 |  | const char * | queryPassword,
 |  | const char ** | columnNamesSubset,
 |  | unsigned char | numColumnSubset,
 |  | DatabaseFilter * | filter,
 |  | unsigned char | numFilters,
 |  | unsigned * | rowIds,
 |  | unsigned char | numRowIDs,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast
 | ) |  |

Sends a query to a remote table. The remote system should return ID_DATABASE_QUERY_REPLY, ID_DATABASE_UNKNOWN_TABLE, or ID_DATABASE_INCORRECT_PASSWORD

Note:
If the remote table uses a password and you send the wrong one you will be silently disconnected and banned for one second.
Parameters:
[in] | tableName | String name of the remote table. Case sensitive.
[in] | queryPassword | Password to query the remote table, if any.
[in] | columnSubset | An array of string names of the columns to query. The resulting table will return the columns in this same order. Pass 0 for all columns.
[in] | numColumnSubset | The number of elements in the columnSubset array
[in] | filter | Filters to apply to the query. For each row the filters are applied. All filters must be passed for the row to be returned. Pass 0 for no filters.
[in] | numFilters | The number of elements in the filter array
[in] | rowIds | Which particular rows to return. Pass 0 for all rows.
[in] | numRowIDs | The number of elements in the rowIds array
[in] | systemAddress | Which system to send to.
[in] | broadcast | Broadcast or not. Same as the parameter in RakPeer::Send

void LightweightDatabaseClient::UpdateRow | ( | const char * | tableName,
 |  | const char * | updatePassword,
 |  | RowUpdateMode | updateMode,
 |  | bool | hasRowId,
 |  | unsigned | rowId,
 |  | DatabaseCellUpdate * | cellUpdates,
 |  | unsigned char | numCellUpdates,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast
 | ) |  |

Sets one or more values in a new or existing row, assuming the server allows row creation and updates. No response is returned by the server.

Parameters:
[in] | tableName | String name of the remote table. Case sensitive.
[in] | updatePassword | Password to update the remote table, if any.
[in] | updateMode | See RowUpdateMode in LightweightDatabaseCommon.h . This determines if to update an existing or new row.
[in] | hasRowId | True if a valid value was passed for rowId, false otherwise. If false, will lookup the row by system address. Required if adding a new row and the remote system does not automatically create rowIDs.
[in] | rowId | The rowID of the new or existing row.
[in] | cellUpdates | An array of DatabaseCellUpdate structures containing the values to write to the remote row.
[in] | numCellUpdates | The number of elements in the cellUpdates array
[in] | systemAddress | Which system to send to.
[in] | broadcast | Broadcast or not. Same as the parameter in RakPeer::Send

void LightweightDatabaseClient::RemoveRow | ( | const char * | tableName,
 |  | const char * | removePassword,
 |  | unsigned | rowId,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast
 | ) |  |

Removes a remote row, assuming the server allows row removal. No response is returned by the server.

Parameters:
[in] | tableName | String name of the remote table. Case sensitive.
[in] | removePassword | Password to remove rows from the remote table, if any.
[in] | rowId | The rowID of the existing row.
[in] | systemAddress | Which system to send to.
[in] | broadcast | Broadcast or not. Same as the parameter in RakPeer::Send

void LightweightDatabaseClient::OnAttach ( RakPeerInterface * peer ) [virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult LightweightDatabaseClient::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/LightweightDatabaseClient.h
  • C:/RakNet/Source/LightweightDatabaseClient.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LightweightDatabaseServer Class Reference

LightweightDatabaseServer Class Reference
[LightweightDatabase]

A simple flat database included with RakNet, useful for a server browser or a lobby server. A flat database interface. Adds the ability to track IPs of row updaters and passwords for table read and write operations, Best used for data in which queries which do not need to be updated in real-time. More...

#include <LightweightDatabaseServer.h>

Inheritance diagram for LightweightDatabaseServer:

PluginInterface List of all members.

Public Member Functions

LightweightDatabaseServer ()
Constructor.
virtual | ~LightweightDatabaseServer ()
Destructor.
DataStructures::Table * | GetTable (char *tableName)
Returns:
The requested table, or 0 if tableName cannot be found.

DataStructures::Table * | AddTable (char *tableName, bool allowRemoteQuery, bool allowRemoteUpdate, bool allowRemoteRemove, const char *queryPassword, const char *updatePassword, const char *removePassword, bool oneRowPerSystemAddress, bool onlyUpdateOwnRows, bool removeRowOnPingFailure, bool removeRowOnDisconnect, bool autogenerateRowIDs)
bool | RemoveTable (char *tableName)
void | Clear (void)
Clears all memory.
DataStructures::Page< unsigned,
DataStructures::Table::Row *,
_TABLE_BPLUS_TREE_ORDER > * 		GetTableRows (char *tableName)
virtual void | OnAttach (RakPeerInterface *peer)
virtual void | Update (RakPeerInterface *peer)
virtual PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
virtual void | OnShutdown (RakPeerInterface *peer)
virtual void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)

Detailed Description

A simple flat database included with RakNet, useful for a server browser or a lobby server. A flat database interface. Adds the ability to track IPs of row updaters and passwords for table read and write operations, Best used for data in which queries which do not need to be updated in real-time.

Member Function Documentation

DataStructures::Table * LightweightDatabaseServer::GetTable ( char * tableName )

Returns:
The requested table, or 0 if tableName cannot be found.

Returns a table by name. It is valid to read and write to the returned pointer.

Parameters:
[in] tableName The name of the table that was passed to AddTable

DataStructures::Table * LightweightDatabaseServer::AddTable | ( | char * | tableName,
 |  | bool | allowRemoteQuery,
 |  | bool | allowRemoteUpdate,
 |  | bool | allowRemoteRemove,
 |  | const char * | queryPassword,
 |  | const char * | updatePassword,
 |  | const char * | removePassword,
 |  | bool | oneRowPerSystemAddress,
 |  | bool | onlyUpdateOwnRows,
 |  | bool | removeRowOnPingFailure,
 |  | bool | removeRowOnDisconnect,
 |  | bool | autogenerateRowIDs
 | ) |  |

Adds a new table It is valid to read and write to the returned pointer.

Parameters:
[in] | tableName | Name of the new table to create. Remote systems will refer to this table by this name.
[in] | allowRemoteQuery | true to allow remote systems to query the table. false to not allow this.
[in] | allowRemoteUpdate | true to allow remote systems to update rows in the table. false to not allow this.
[in] | allowRemoteRemove | true to allow remote systems to remove rows from the table. false to not allow this.
[in] | queryPassword | The password required to query the table. Pass an empty string for no password.
[in] | updatePassword | The password required to update rows in the table. Pass an empty string for no password.
[in] | removePassword | The password required to remove rows from the table. Pass an empty string for no password.
[in] | oneRowPerSystemAddress | Only used if allowRemoteUpdate==true. This limits remote systems to one row.
[in] | onlyUpdateOwnRows | Only used if allowRemoteUpdate==true. This limits remote systems to only updating rows they created.
[in] | removeRowOnPingFailure | Only used if allowRemoteUpdate==true and removeRowOnDisconnect==false. If true, this will periodically ping disconnected systems and remove rows created by that system if that system does not respond to pings.
[in] | removeRowOnDisconnect | Only used if allowRemoteUpdate==true. This removes rows created by a system when that system disconnects.
[in] | autogenerateRowIDs | true to automatically generate row IDs. Rows are stored in order by row ID. If false, the clients must specify a unique row ID when adding rows. If they specify a row that already exists the addition is ignored.
Returns:
The newly created table, or 0 on failure.

bool LightweightDatabaseServer::RemoveTable ( char * tableName )

Removes a table by name.

Parameters:
[in] tableName The name of the table that was passed to AddTable
Returns:
true on success, false on failure.

DataStructures::Page< unsigned, DataStructures::Table::Row *, _TABLE_BPLUS_TREE_ORDER > * LightweightDatabaseServer::GetTableRows ( char * tableName )

Returns a linked list of ordered lists containing the rows of a table, by name. The returned structure is internal to the BPlus tree. See DS_BPlusTree This is a convenience accessor, as you can also get this from the table returned from GetTable()

Parameters:
[in] tableName The name of the table that was passed to AddTable
Returns:
The requested rows, or 0 if tableName cannot be found.

void LightweightDatabaseServer::OnAttach ( RakPeerInterface * peer ) [virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void LightweightDatabaseServer::Update ( RakPeerInterface * peer ) [virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult LightweightDatabaseServer::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void LightweightDatabaseServer::OnShutdown ( RakPeerInterface * peer ) [virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void LightweightDatabaseServer::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/LightweightDatabaseServer.h
  • C:/RakNet/Source/LightweightDatabaseServer.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::List< list_type > Class Template Reference

DataStructures::List

DataStructures::List< list_type > Class Template Reference

Array based implementation of a list. More...

#include <DS_List.h>

List of all members.

Public Member Functions

List ()
Default constructor.
~List ()
Destructor.
List (const List &original_copy)
List & | operator= (const List &original_copy)
Assign one list to another.
list_type & | operator[] (const unsigned int position) const
void | Push (const list_type input)
list_type & | Pop (void)
void | Insert (const list_type input, const unsigned int position)
void | Insert (const list_type input)
void | Replace (const list_type input, const list_type filler, const unsigned int position)
void | Replace (const list_type input)
void | RemoveAtIndex (const unsigned int position)
void | RemoveAtIndexFast (const unsigned int position)
void | RemoveFromEnd (const unsigned num=1)
Delete the element at the end of the list.
unsigned int | GetIndexOf (const list_type input) const
unsigned int | Size (void) const
Returns:
The number of elements in the list

void | Clear (bool doNotDeallocateSmallBlocks=false)
Clear the list.
void | Compress (void)

Detailed Description

template<class list_type>
class DataStructures::List< list_type >

Array based implementation of a list.

Note:
ONLY USE THIS FOR SHALLOW COPIES. I don't bother with operator= to improve performance.

Constructor & Destructor Documentation

template<class list_type>
DataStructures::List< list_type >::List ( const List< list_type > & original_copy )

Copy constructor

Parameters:
[in] original_copy The list to duplicate

Member Function Documentation

template<class list_type>
list_type & DataStructures::List< list_type >::operator[] ( const unsigned int position ) const [inline]

Access an element by its index in the array

Parameters:
[in] position The index into the array.
Returns:
The element at position position.

template<class list_type>
void DataStructures::List< list_type >::Push ( const list_type input )

Push an element at the end of the stack

Parameters:
[in] input The new element.

template<class list_type>
list_type & DataStructures::List< list_type >::Pop ( void ) [inline]

Pop an element from the end of the stack

Precondition:
Size()>0
Returns:
The element at the end.

template<class list_type>
void DataStructures::List< list_type >::Insert | ( | const list_type | input,
 |  | const unsigned int | position
 | ) |  |

Insert an element at position position in the list

Parameters:
[in] | input | The new element.
[in] | position | The position of the new element.

template<class list_type>
void DataStructures::List< list_type >::Insert ( const list_type input )

Insert at the end of the list.

Parameters:
[in] input The new element.

template<class list_type>
void DataStructures::List< list_type >::Replace | ( | const list_type | input,
 |  | const list_type | filler,
 |  | const unsigned int | position |
 | ) |  |  | [inline]

Replace the value at position by input. If the size of the list is less than position, it increase the capacity of the list and fill slot with filler.

Parameters:
[in] | input | The element to replace at position position.
[in] | filler | The element use to fill new allocated capacity.
[in] | position | The position of input in the list.

template<class list_type>
void DataStructures::List< list_type >::Replace ( const list_type input ) [inline]

Replace the last element of the list by input .

Parameters:
[in] input The element used to replace the last element.

template<class list_type>
void DataStructures::List< list_type >::RemoveAtIndex ( const unsigned int position )

Delete the element at position position.

Parameters:
[in] position The index of the element to delete

template<class list_type>
void DataStructures::List< list_type >::RemoveAtIndexFast ( const unsigned int position )

Delete the element at position position.

Note:
- swaps middle with end of list, only use if list order does not matter
Parameters:
[in] position The index of the element to delete

template<class list_type>
unsigned int DataStructures::List< list_type >::GetIndexOf ( const list_type input ) const

Returns the index of the specified item or MAX_UNSIGNED_LONG if not found

Parameters:
[in] input The element to check for
Returns:
The index or position of input in the list.
Return values:
MAX_UNSIGNED_LONG | The object is not in the list
[Integer] | The index of the element in the list

template<class list_type>
void DataStructures::List< list_type >::Compress ( void )

Frees overallocated members, to use the minimum memory necessary

Attention:
This is a slow operation

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/DS_List.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::Lobby2::LobbyClient Class Reference

RakNet::Lobby2::LobbyClient

RakNet::Lobby2::LobbyClient Class Reference
[PluginInterface]

PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality. More...

#include <LobbyClient.h>

Inheritance diagram for RakNet::Lobby2::LobbyClient:

RakNet::Lobby2::LobbyClientPC List of all members.

Public Member Functions

virtual void SetCallbackInterface (LobbyClientInterfaceCB *cbi)
Sets the class to get callbacks.

Detailed Description

PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality.

LobbyClient plugin for the PC

Note:
Most function calls are asynchronous so use a callback to get the result. This callback is set with LobbyClientPC::SetCallbackInterface()
See also:
LobbyServer

LobbyServerPostgreSQL

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby2/LobbyClient.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::LobbyClientInterface Class Reference

RakNet::LobbyClientInterface

RakNet::LobbyClientInterface Class Reference

The client-side interface to the lobby system The Lobby client implements functionality commonly found in game lobbies. It is the counterpart to the LobbyServer class. This interface is system independent, but for PC functionality see LobbyClientPC For full documentation on the PC version, see LobbyClientPC.h. More...

#include <LobbyClientInterface.h>

Inheritance diagram for RakNet::LobbyClientInterface:

RakNet::LobbyClientPC List of all members.

Detailed Description

The client-side interface to the lobby system The Lobby client implements functionality commonly found in game lobbies. It is the counterpart to the LobbyServer class. This interface is system independent, but for PC functionality see LobbyClientPC For full documentation on the PC version, see LobbyClientPC.h.

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyClientInterface.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::Lobby2::LobbyClientPC Class Reference

RakNet::Lobby2::LobbyClientPC

RakNet::Lobby2::LobbyClientPC Class Reference
[PluginInterface]

PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality. More...

#include <LobbyClientPC.h>

Inheritance diagram for RakNet::Lobby2::LobbyClientPC:

PluginInterface RakNet::Lobby2::LobbyClient List of all members.

Public Member Functions

void | SetOrderingChannel (char oc)
Ordering channel to use with RakPeer::Send().
void | SetSendPriority (PacketPriority pp)
Send priority to use with RakPeer::Send().

Protected Member Functions

void | OnAttach (RakPeerInterface *peer)
PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)
void | OnShutdown (RakPeerInterface *peer)

Detailed Description

PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality.

LobbyClient plugin for the PC

Note:
Most function calls are asynchronous so use a callback to get the result. This callback is set with LobbyClientPC::SetCallbackInterface()
See also:
LobbyServer

LobbyServerPostgreSQL

Member Function Documentation

void RakNet::Lobby2::LobbyClientPC::OnAttach ( RakPeerInterface * peer ) [protected, virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult RakNet::Lobby2::LobbyClientPC::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [protected, virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void RakNet::Lobby2::LobbyClientPC::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [protected, virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

void RakNet::Lobby2::LobbyClientPC::OnShutdown ( RakPeerInterface * peer ) [protected, virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby2/LobbyClientPC.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::LobbyClientPC Class Reference

RakNet::LobbyClientPC

RakNet::LobbyClientPC Class Reference
[PluginInterface]

PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality. More...

#include <LobbyClientPC.h>

Inheritance diagram for RakNet::LobbyClientPC:

PluginInterface RakNet::LobbyClientInterface List of all members.

Public Member Functions

virtual void | Login (const char *userHandle, const char *userPassword, SystemAddress lobbyServerAddr)
virtual void | SetTitleLoginId (const char *_titleIdStr, const char *_titleLoginPW, int _titleLoginPWLength)
virtual void | Logoff (void)
virtual bool | IsConnected (void) const
virtual void | RegisterAccount (LobbyDBSpec::CreateUser_Data *input, SystemAddress lobbyServerAddr)
virtual void | UpdateAccount (LobbyDBSpec::UpdateUser_Data *input)
virtual void | ChangeHandle (const char *newHandle)
virtual LobbyUserStatus | GetLobbyUserStatus (void) const
virtual void | RetrievePasswordRecoveryQuestion (const char *userHandle, SystemAddress lobbyServerAddr)
virtual void | RetrievePassword (const char *userHandle, const char *passwordRecoveryAnswer, SystemAddress lobbyServerAddr)
virtual void | DownloadFriends (bool ascendingSortByDate)
virtual void | SendAddFriendInvite (const char *friendHandle, LobbyClientUserId *friendId, const char *messageBody, unsigned char language)
virtual void | AcceptAddFriendInvite (const char *friendHandle, LobbyClientUserId *friendId, const char *messageBody, unsigned char language)
virtual void | DeclineAddFriendInvite (const char *friendHandle, LobbyClientUserId *friendId, const char *messageBody, unsigned char language)
virtual const DataStructures::List<
LC_Friend * > & 		GetFriendsList (void) const
virtual bool | IsFriend (const char *friendHandle)
virtual bool | IsFriend (LobbyClientUserId *friendId)
virtual void | DownloadIgnoreList (bool ascendingSort)
virtual void | AddToOrUpdateIgnoreList (const char *userHandle, LobbyClientUserId *userId, const char *actionsStr)
virtual void | RemoveFromIgnoreList (LobbyClientUserId *userId)
virtual const DataStructures::List<
LC_Ignored * > & 		GetIgnoreList (void) const
virtual void | DownloadEmails (bool ascendingSort, bool inbox, unsigned char language)
virtual void | SendEmail (LobbyDBSpec::SendEmail_Data *input, unsigned char language)
virtual void | DeleteEmail (EmailId *emailId)
virtual void | UpdateEmailStatus (EmailId *emailId, int newStatus, bool wasOpened)
virtual const DataStructures::List<
LobbyDBSpec::SendEmail_Data * > & 		GetInboxEmailList (void) const
virtual const DataStructures::List<
LobbyDBSpec::SendEmail_Data * > & 		GetSentEmailList (void) const
virtual void | SendIM (const char *userHandle, LobbyClientUserId *userId, const char *chatMessage, unsigned char languageId, const char *chatBinaryData, int chatBinaryLength)
bool | IsInRoom (void) const
virtual void | CreateRoom (const char *roomName, const char *roomPassword, bool roomIsHidden, int publicSlots, int privateSlots, bool allowSpectators, DataStructures::Table *customProperties)
virtual void | DownloadRooms (DataStructures::Table::FilterQuery *inclusionFilters, unsigned numInclusionFilters)
virtual DataStructures::Table * | GetAllRooms (void)
virtual bool | IsDownloadingRoomList (void)
virtual void | LeaveRoom (void)
virtual const DataStructures::List<
LobbyClientUserId * > & 		GetAllRoomMembers (void) const
virtual const DataStructures::List<
LobbyClientUserId * > & 		GetOpenSlotMembers (void) const
virtual const DataStructures::List<
LobbyClientUserId * > & 		GetReservedSlotMembers (void) const
virtual const DataStructures::List<
LobbyClientUserId * > & 		GetSpectators (void) const
virtual LobbyClientUserId * | GetRoomModerator (void)
virtual LobbyClientRoomId * | GetRoomId (void)
virtual unsigned int | GetPublicSlotMaxCount (void) const
virtual unsigned int | GetPrivateSlotMaxCount (void) const
virtual LobbyClientTitleId * | GetTitleId (void) const
virtual const char * | GetRoomName (void) const
Returns:
The name of the room we are currently in, or 0 if none.

virtual const char * | GetTitleName (void) const
Returns:
The name of the game we are currently in, or 0 if none. Specified in the titles table as titleName

virtual bool | RoomIsHidden (void) const
Returns:
The value of roomIsHidden passed to CreateRoom()

virtual DataStructures::Table::Row * | GetRoomTableRow (void) const
virtual void | JoinRoom (LobbyClientRoomId *roomId, const char *roomName, const char *roomPassword, bool joinAsSpectator)
virtual void | JoinRoomByFilter (DataStructures::Table::FilterQuery *inclusionFilters, unsigned numInclusionFilters, bool joinAsSpectator)
virtual void | RoomChat (const char *chatMessage, unsigned char languageId, const char *chatBinaryData, int chatBinaryLength)
virtual bool | IsInReservedSlot (LobbyClientUserId *userId)
Returns:
If the specified userId is in a reserved slot in the room.

virtual bool | IsRoomModerator (LobbyClientUserId *userId)
Returns:
If the specified userId is the moderator of the room

virtual bool | IsUserInRoom (LobbyClientUserId *userId) const
Returns:
If the specified userId is in the room, in any capacity

virtual bool | RoomAllowsSpectators (void) const
Returns:
If the room allows spectators to join.

virtual void | InviteToRoom (const char *userHandle, LobbyClientUserId *userId, const char *chatMessage, unsigned char languageId, const char *chatBinaryData, int chatBinaryLength, bool inviteToPrivateSlot)
virtual void | SetReadyToPlayStatus (bool isReady)
virtual void | KickRoomMember (LobbyClientUserId *userId)
virtual void | SetRoomIsHidden (bool roomIsHidden)
virtual void | SetRoomAllowSpectators (bool spectatorsOn)
virtual void | ChangeNumSlots (int totalSlots, int privateSlots)
virtual void | GrantModerator (LobbyClientUserId *userId)
virtual void | StartGame (void)
virtual void | SubmitMatch (RankingServerDBSpec::SubmitMatch_Data *input)
virtual void | DownloadRating (RankingServerDBSpec::GetRatingForParticipant_Data *input)
virtual RankingServerDBSpec::GetRatingForParticipant_Data * | GetRating (void)
virtual bool | IsWaitingOnQuickMatch (void)
Returns:
True if we called QuickMatch(), the game did not yet start, and QuickMatch::timeoutInSeconds did not yet elapsed

virtual void | QuickMatch (int requiredPlayers, int timeoutInSeconds)
virtual void | CancelQuickMatch (void)
virtual void | DownloadActionHistory (bool ascendingSort)
virtual void | AddToActionHistory (LobbyDBSpec::AddToActionHistory_Data *input)
virtual const DataStructures::List<
LobbyDBSpec::AddToActionHistory_Data * > & 		GetActionHistoryList (void) const
virtual const DataStructures::List<
LobbyUserClientDetails * > & 		GetRecentlyMetUsersList (void) const
Users recently played against.
virtual bool | GetUserDetails (LobbyClientUserId *userId, LobbyUserClientDetails *details)
virtual LobbyClientUserId * | GerUserIdFromName (const char *name)
virtual LobbyClientUserId * | GetMyId (void)
Get my own ID.
virtual bool | EqualIDs (const LobbyClientUserId *userId1, const LobbyClientUserId *userId2)
Are two IDs equal? For the PC this is not necessary to call, as LobbyClientUserId is an unsigned integer.
virtual void | SetCallbackInterface (LobbyClientInterfaceCB *cbi)
Sets the class to get callbacks.
void | SetOrderingChannel (char oc)
Ordering channel to use with RakPeer::Send().
void | SetSendPriority (PacketPriority pp)
Send priority to use with RakPeer::Send().

Protected Member Functions

void | OnAttach (RakPeerInterface *peer)
PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)
void | OnShutdown (RakPeerInterface *peer)

Detailed Description

PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality.

LobbyClient plugin for the PC

Note:
Most function calls are asynchronous so use a callback to get the result. This callback is set with LobbyClientPC::SetCallbackInterface()
See also:
LobbyServer

LobbyServerPostgreSQL

Member Function Documentation

void LobbyClientPC::Login | ( | const char * | userHandle,
 |  | const char * | userPassword,
 |  | SystemAddress | lobbyServerAddr |
 | ) |  |  | [virtual]

Logs into the lobby server with a given handle and password. All operations other than registering an account or Retrieving passwords require that you first login.

Parameters:
[in] | userHandle | The handle used to register an account
[in] | userPassword | The password used when registering the account
[in] | lobbyServerAddr | SystemAddress of the lobby server. Must be currently connected.
Precondition:
Must be connected to the lobby server, and have previously created an account (or had one directly created on the server or in the database)
See also:
RegisterAccount()

LobbyClientInterfaceCB::Login_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::SetTitleLoginId | ( | const char * | _titleIdStr,
 |  | const char * | _titleLoginPW,
 |  | int | _titleLoginPWLength |
 | ) |  |  | [virtual]

Indicates to the system what title (game) you are playing. Games are identified by a unique key, specified in binary via _titleLoginPW and _titleLoginPWLength Games must have been already created on the server, or directly in the database. One way to add games is through the functor class AddTitle_PostgreSQLImpl . An example of this can be found in the LobbyServerTest project

Note:
When the title was added to the server, if requireUserKeyToLogon==true, then you must first call ValidateUserKey() with the name of the title. Failure to do so will return the error LC_RC_USER_KEY_NOT_SET
Parameters:
[in] | _titleIdStr | Actual name of the game. Not used at present, but may be used in the future.
[in] | _titleLoginPW | Secret binary identifer assigned with the game. This should be kept secret so that people cannot submit scores for the wrong game, etc.
[in] | _titleLoginPWLength | Length of _titleLoginPW
See also:
LobbyClientInterfaceCB::SetTitleLoginId_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::Logoff ( void ) [virtual]

Logs off the lobby system.

See also:
LobbyClientInterfaceCB::Logoff_Result()

Implements RakNet::LobbyClientInterface.

bool LobbyClientPC::IsConnected ( void ) const [virtual]

Are we connected to the Lobby server?

Returns:
true if connected, false otherwise.
See also:
Login()

void LobbyClientPC::RegisterAccount | ( | LobbyDBSpec::CreateUser_Data * | input,
 |  | SystemAddress | lobbyServerAddr |
 | ) |  |  | [virtual]

Creates an account on the lobby server. Unlike most functions you do not have to be logged in to do this. LobbyDBSpec::CreateUser_Data::handle is required and must be unique in the database. It also cannot be in the disallowedHandles table LobbyDBSpec::CreateUser_Data::password is also required

Parameters:
[in] | input | Data describing the new account. All fields optional but handle and password
[in] | lobbyServerAddr | System address of the lobby server
Precondition:
SetTitleLoginId() must have been successfully called. This is because titles can disallow account creation.
See also:
LobbyClientInterfaceCB::RegisterAccount_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::UpdateAccount ( LobbyDBSpec::UpdateUser_Data * input ) [virtual]

Updates details of a previously created account.

Parameters:
[in] input Details on the account. See LobbyDBSpec::UpdateUser_Data for more details.
Precondition:
Must be logged in
See also:
RegisterAccount();

LobbyClientInterfaceCB::UpdateAccount_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::ChangeHandle ( const char * newHandle ) [virtual]

Change the handle associated with your user. Handle must be unique and not in the disallowedHandles table

Note:
This may be disabled in the database TitleValidationDBSpec::AddTitle_Data::defaultAllowUpdateHandle
Precondition:
Must be logged in
See also:
LobbyClientInterfaceCB::ChangeHandle_Result()

Implements RakNet::LobbyClientInterface.

LobbyUserStatus LobbyClientPC::GetLobbyUserStatus ( void ) const [virtual]

Returns the current action you are performing, if any.

Returns:
Your action

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::RetrievePasswordRecoveryQuestion | ( | const char * | userHandle,
 |  | SystemAddress | lobbyServerAddr |
 | ) |  |  | [virtual]

Gets the password recovery question entered when the account was last created or updated. The question should not ask what the password is, but should ask some specific question that only the user would know

Parameters:
[in] | userHandle | Current user's handle, specified when creating the account via RegisterAccount() or ChangeHandle()
[in] | lobbyServerAddr | System address of the lobby server
See also:
LobbyClientInterfaceCB::RetrievePasswordRecoveryQuestion_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::RetrievePassword | ( | const char * | userHandle,
 |  | const char * | passwordRecoveryAnswer,
 |  | SystemAddress | lobbyServerAddr |
 | ) |  |  | [virtual]

Recovers the user's password given the handle and password recovery answer

Parameters:
[in] | userHandle | Current user's handle, specified when creating the account via RegisterAccount() or ChangeHandle()
[in] | passwordRecoveryAnswer | Specified when creating or last updating the account
[in] | lobbyServerAddr | System address of the lobby server
Note:
Note the answer is currently not case sensitive, but is spacing sensitive (stricmp())
See also:
LobbyClientInterfaceCB::RetrievePassword_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::DownloadFriends ( bool ascendingSortByDate ) [virtual]

Downloads your friends from the database, and stores the list internally Results are contained in the LC_Friend structure. Friends do not have to be online, and you will get LobbyClientInterfaceCB::FriendStatus_Notify() indicating when your friends go online and offline.

Note:
You will not get any friends information or notifications until calling DownloadFriends()
Parameters:
[in] ascendingSortByDate Sort result by date, ascending or descending
Precondition:
Must be logged in.
See also:
GetFriendsList();

LobbyClientInterfaceCB::DownloadFriends_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::SendAddFriendInvite | ( | const char * | friendHandle,
 |  | LobbyClientUserId * | friendId,
 |  | const char * | messageBody,
 |  | unsigned char | language |
 | ) |  |  | [virtual]

Invites someone to be your friend. They must be online at the time of the invite They will get the callback FriendInvitation_Notify indicating who the request is from, and can accept or deny it (or ignore it) If accepted, you will get notifications via FriendStatus_Notify of when they go on and offline

Parameters:
[in] | friendHandle | Handle of the potential friend. If you know friendId leave this at 0.
[in] | friendId | ID of the potential friend. Lookup is faster using ID. If you don't know it, specify friendHandle instead.
[in] | messageBody | Optional message to send with the friend request.
[in] | language | Language to use for string encoding for the StringCompressor class. Use 0 if unsure.
Precondition:
Must be logged in.
See also:
StringCompressor

LobbyClientInterfaceCB::SendAddFriendInvite_Result()

LobbyClientInterfaceCB::FriendInvitation_Notify()

LobbyClientInterfaceCB::FriendStatus_Notify

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::AcceptAddFriendInvite | ( | const char * | friendHandle,
 |  | LobbyClientUserId * | friendId,
 |  | const char * | messageBody,
 |  | unsigned char | language |
 | ) |  |  | [virtual]

Accept a friend invite that you were notified of with LobbyClientInterfaceCB::FriendInvitation_Notify()

Parameters:
[in] | friendHandle | Handle of potential friend, use if you don't have the Id, but less efficient
[in] | friendId | ID of the potential friend, found at FriendInvitation_Notification::invitor
[in] | messageBody | Optional message to reply with.
[in] | language | Language to use for string encoding for the StringCompressor class. Use 0 if unsure.
Precondition:
Must be logged in.
See also:
StringCompressor

LobbyClientInterfaceCB::AcceptAddFriendInvite_Result()

LobbyClientInterfaceCB::FriendInvitation_Notify()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::DeclineAddFriendInvite | ( | const char * | friendHandle,
 |  | LobbyClientUserId * | friendId,
 |  | const char * | messageBody,
 |  | unsigned char | language |
 | ) |  |  | [virtual]

Decline a friend invite that you were notified of with LobbyClientInterfaceCB::FriendInvitation_Notify()

Parameters:
[in] | friendHandle | Handle of the guy asking to be a friend, use if you don't have the Id, but less efficient
[in] | friendId | ID of the guy asking to be a friend, found at FriendInvitation_Notification::invitor
[in] | messageBody | Optional message to reply with.
[in] | language | Language to use for string encoding for the StringCompressor class. Use 0 if unsure.
Precondition:
Must be logged in.
See also:
StringCompressor

LobbyClientInterfaceCB::DeclineAddFriendInvite_Result()

LobbyClientInterfaceCB::FriendInvitation_Notify()

Implements RakNet::LobbyClientInterface.

const DataStructures::List< LC_Friend * > & LobbyClientPC::GetFriendsList ( void ) const [virtual]

Get the downloaded friends list. Pointers are guaranteed to remain valid until the next call to RakPeer::Receive()

Precondition:
Must be logged in.

Successful call to DownloadFriends

Returns:
List of structures containing information about each friend. Cleared on logoff.
See also:
LC_Friend

Implements RakNet::LobbyClientInterface.

bool LobbyClientPC::IsFriend ( const char * friendHandle ) [virtual]

Is this user a friend?

Precondition:
Must have downloaded the friends list, or will always be false
Parameters:
[in] friendHandle Handle of the friend
Returns:
True if this user is a friend, false if not, or unknown

Implements RakNet::LobbyClientInterface.

bool LobbyClientPC::IsFriend ( LobbyClientUserId * friendId ) [virtual]

Is this user a friend?

Precondition:
Must have downloaded the friends list, or will always be false
Parameters:
[in] friendId ID of the friend
Returns:
True if this user is a friend, false if not, or unknown

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::DownloadIgnoreList ( bool ascendingSort ) [virtual]

Adds a user to the ignore list, stored in the database as well Will block room chat, room invites, and instant messages Does not currently block user from joining your room, but this may change depending on user requests

Parameters:
[in] ascendingSort Which direction to sort the ignore list, sorted on date
Precondition:
Must be logged in.
See also:
LobbyClientInterfaceCB::DownloadIgnoreList_Result()

GetIgnoreList()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::AddToOrUpdateIgnoreList | ( | const char * | userHandle,
 |  | LobbyClientUserId * | userId,
 |  | const char * | actionsStr |
 | ) |  |  | [virtual]

Add / update a user on the ignore list. If this user is not currently on the ignore list, they will be added. If this user IS currently on the ignore list, LC_Ignored::actionString will be updated.

Parameters:
[in] | userHandle | Handle of the user on which to perform this action. If you know userId leave this at 0.
[in] | userId | ID of the user on which to perform this action. Lookup is faster using ID. If you don't know it, specify userHandle instead.
[in] | actionsStr | Arbitrary, user-defined string to store any extra data you wish (such as reason for the ignore)
Precondition:
Must be logged in.
See also:
LobbyClientInterfaceCB::AddToOrUpdateIgnoreList_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::RemoveFromIgnoreList ( LobbyClientUserId * userId ) [virtual]

Remove a user from the ignore list.

Parameters:
[in] userId ID of the user on which to perform this action. You can get this through GetIgnoreList()
Precondition:
Must be logged in.
See also:
LobbyClientInterfaceCB::RemoveFromIgnoreList_Result()

GetIgnoreList()

Implements RakNet::LobbyClientInterface.

const DataStructures::List< LC_Ignored * > & LobbyClientPC::GetIgnoreList ( void ) const [virtual]

Returns the internally stored list of ignored users. Pointers are guaranteed to remain valid until the next call to RakPeer::Receive()

Returns:
List of structures containing information about each ignored users. Cleared on logoff.

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::DownloadEmails | ( | bool | ascendingSort,
 |  | bool | inbox,
 |  | unsigned char | language |
 | ) |  |  | [virtual]

Downloads emails on the server. Currently (this may change) emails are purely intra-database, so the name is a bit misleading. A better name would be peristent database message.

Parameters:
[in] | ascendingSort | Which direction to sort the resulting downloaded list, by creation date
[in] | inbox | true to download mails sent to you. false to download mails that you have sent.
[in] | language | Language to use for string encoding for the StringCompressor class. Use 0 if unsure.
Precondition:
Must be logged in.
See also:
LobbyClientInterfaceCB::DownloadEmails_Result()

GetInboxEmailList()

GetSentEmailList()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::SendEmail | ( | LobbyDBSpec::SendEmail_Data * | input,
 |  | unsigned char | language |
 | ) |  |  | [virtual]

Sends an email to one or more users For each recipient, two copies of the email are stored in the database. One is in your sent mailbox, one is in the recipient incoming mailbox.

Parameters:
[in] | input | Data corresponding to the email. See LobbyDBSpec.h for all parameters.
[in] | language | Language to use for string encoding for the StringCompressor class. Use 0 if unsure.
Precondition:
Must be logged in.
See also:
LobbyClientInterfaceCB::SendEmail_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::DeleteEmail ( EmailId * emailId ) [virtual]

Deletes an email, from either your inbox or sent emails list.

Parameters:
[in] emailId Found at LobbyDBSpec::SendEmail_Data::emailMessageID
Precondition:
Must be logged in.
See also:
GetInboxEmailList()

GetSentEmailList()

LobbyClientInterfaceCB::DeleteEmail_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::UpdateEmailStatus | ( | EmailId * | emailId,
 |  | int | newStatus,
 |  | bool | wasOpened |
 | ) |  |  | [virtual]

Update the status flags associated with an email.

Parameters:
[in] | emailId | Found at LobbyDBSpec::SendEmail_Data::emailMessageID
[in] | newStatus | arbitrary integer stored alongside each email. Use to indicate user-defined fields (priority, etc).
[in] | wasOpened | boolean field. Use to indicate if an email was opened. Sent emails take the field LobbyDBSpec::SendEmail_Data::wasOpened . Inbox has this always true until set off.
Precondition:
Must be logged in.
See also:
GetInboxEmailList()

GetSentEmailList()

LobbyClientInterfaceCB::UpdateEmailStatus_Result()

Implements RakNet::LobbyClientInterface.

const DataStructures::List< LobbyDBSpec::SendEmail_Data * > & LobbyClientPC::GetInboxEmailList ( void ) const [virtual]

Gets emails downloaded with DownloadEmails(), for the inbox. Pointers are guaranteed to remain valid until the next call to RakPeer::Receive()

Note:
It takes two calls to get all emails, one call to DownloadEmails only gets the inbox or sent list.
Precondition:
Must be logged in.
Returns:
The email

Implements RakNet::LobbyClientInterface.

const DataStructures::List< LobbyDBSpec::SendEmail_Data * > & LobbyClientPC::GetSentEmailList ( void ) const [virtual]

Gets emails downloaded with DownloadEmails(), for sent emails. Pointers are guaranteed to remain valid until the next call to RakPeer::Receive()

Note:
It takes two calls to get all emails, one call to DownloadEmails only gets the inbox or sent list.
Precondition:
Must be logged in.
Returns:
The email

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::SendIM | ( | const char * | userHandle,
 |  | LobbyClientUserId * | userId,
 |  | const char * | chatMessage,
 |  | unsigned char | languageId,
 |  | const char * | chatBinaryData,
 |  | int | chatBinaryLength |
 | ) |  |  | [virtual]

Sends a message to another user. Unlike emails, this is not stored in the database. The callback will indicate failure if the user is not online. If the user has ignored us, the callback will indicate this as well.

Note:
It is valid to send an empty message with only binary data, or vice-versa
Parameters:
[in] | userHandle | Handle of the user on which to perform this action. If you know userId leave this at 0.
[in] | userId | ID of the user on which to perform this action. Lookup is faster using ID. If you don't know it, specify userHandle instead.
[in] | chatMessage | Body of the message to send
[in] | languageId | Language to use for string encoding for the StringCompressor class. Use 0 if unsure.
[in] | chatBinaryData | Any binary data you wish to send with the message (custom encoding, images, etc)
[in] | chatBinaryLength | Length in bytes of chatBinaryData
Precondition:
Must be logged in.
See also:
LobbyClientInterfaceCB::SendIM_Result()

Implements RakNet::LobbyClientInterface.

bool LobbyClientPC::IsInRoom ( void ) const [virtual]

Returns if we are in a room or not.

Returns:
True if we are in a room. False for any other state.

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::CreateRoom | ( | const char * | roomName,
 |  | const char * | roomPassword,
 |  | bool | roomIsHidden,
 |  | int | publicSlots,
 |  | int | privateSlots,
 |  | bool | allowSpectators,
 |  | DataStructures::Table * | customProperties |
 | ) |  |  | [virtual]

Creates a room

Parameters:
[in] | roomName | Name of the room (required)
[in] | roomPassword | Password for the room (optional)
[in] | roomIsHidden | Sets the DefaultTableColumns::TC_ROOM_HIDDEN column to true or false in the rooms table.
[in] | publicSlots | Number of slots that anyone can join by calling DownloadRooms() to view your room, followed by JoinRoom() to join it.
[in] | privateSlots | Number of slots that users can only join if they previously were invited by the current moderator with InviteToRoom(). Those users will join a public slot if all private slots are full when they join the room.
[in] | allowSpectators | True to allow spectators. Spectators are normal room members, but there is (currently) no limit on the number of spectators.
[in] | customProperties | A table with named columns and one row of properties to add to the server rooms table. Column names must not already be in defaultTableColumns in LobbyTypes.cpp
Precondition:
You are in the lobby (the normal state after logging on)

At least one prior successful call to SetTitleLoginId() to indicate what game to start. SetTitleLoginId() can be called multiple times to change games if desired.

See also:
LobbyClientInterfaceCB::CreateRoom_Result()

LobbyClientInterfaceCB::RoomDestroyed_Notify

LobbyClientInterfaceCB::RoomMemberDrop_Notify

LobbyClientInterfaceCB::RoomMemberJoin_Notify

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::DownloadRooms | ( | DataStructures::Table::FilterQuery * | inclusionFilters,
 |  | unsigned | numInclusionFilters |
 | ) |  |  | [virtual]

Downloads rooms, possibly based on filters

Parameters:
[in] | inclusionFilters | Filters to apply to the search query. Use 0 to get all rooms.
[in] | numInclusionFilters | Number of structures in the inclusionFilters array
Precondition:
Must be logged in.
Note:
In order to honor hidden rooms, you should set the DefaultTableColumns::TC_ROOM_HIDDEN column. Use GetAllRooms() to access the downloaded room list.
Example of setting DefaultTableColumns::TC_ROOM_HIDDEN to false, to not find hidden rooms

DataStructures::Table::FilterQuery inclusionFilters[1]; DataStructures::Table::Cell filterCells[1]; filterCells[0].Set(0); // 0 = integer value false inclusionFilters[0].cellValue=&filterCells[0]; inclusionFilters[0].columnIndex=DefaultTableColumnsTC_ROOM_HIDDEN; inclusionFilters[0].operation=DataStructuresTable::QF_EQUAL; lobbyClient.DownloadRooms(inclusionFilters, 1);

See also:
LobbyClientInterfaceCB::DownloadRooms_Result()

Implements RakNet::LobbyClientInterface.

DataStructures::Table * LobbyClientPC::GetAllRooms ( void ) [virtual]

Returns a table of all downloaded rooms, since the last time DownloadRooms() was called. This list is reset to only your own room if you create a room. Pointers are guaranteed to remain valid until the next call to RakPeer::Receive()

Returns:
Table of downloaded rooms

Implements RakNet::LobbyClientInterface.

bool LobbyClientPC::IsDownloadingRoomList ( void ) [virtual]

Are we currently waiting for DownloadRooms() to finish?

Returns:
true if DownloadRooms() is in progress. When complete, we will get the LobbyClientInterfaceCB::DownloadRooms_Result() callback.

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::LeaveRoom ( void ) [virtual]

Leave our current room. As with other asynchronous calls, this is not immediate, and you should wait for the callback for verification.

Precondition:
Must be currently in a room
See also:
LobbyClientInterfaceCB::LeaveRoom_Result()

Implements RakNet::LobbyClientInterface.

const DataStructures::List< LobbyClientUserId * > & LobbyClientPC::GetAllRoomMembers ( void ) const [virtual]

Gets a list of pointers to room member identifiers. Use GetUserDetails() to get more information about each user. Pointers are valid until next call to this same function

Returns:
All members in the room

Implements RakNet::LobbyClientInterface.

const DataStructures::List< LobbyClientUserId * > & LobbyClientPC::GetOpenSlotMembers ( void ) const [virtual]

Gets a list of pointers to room member identifiers. Use GetUserDetails() to get more information about each user. Pointers are valid until next call to this same function

Returns:
All members occupying open slots

Implements RakNet::LobbyClientInterface.

const DataStructures::List< LobbyClientUserId * > & LobbyClientPC::GetReservedSlotMembers ( void ) const [virtual]

Gets a list of pointers to room member identifiers. Use GetUserDetails() to get more information about each user. Pointers are valid until next call to this same function

Returns:
All members occupying reserved slots

Implements RakNet::LobbyClientInterface.

const DataStructures::List< LobbyClientUserId * > & LobbyClientPC::GetSpectators ( void ) const [virtual]

Gets a list of pointers to room member identifiers. Use GetUserDetails() to get more information about each user. Pointers are valid until next call to this same function

Returns:
All spectators in the room

Implements RakNet::LobbyClientInterface.

LobbyClientUserId * LobbyClientPC::GetRoomModerator ( void ) [virtual]

Get identifier of the moderator of this room The moderator will be one of the members in a public or priate slot Pointers are guaranteed to remain valid until the next call to RakPeer::Receive()

Returns:
moderator id

Implements RakNet::LobbyClientInterface.

LobbyClientRoomId * LobbyClientPC::GetRoomId ( void ) [virtual]

Get ID of this room, used in some other functions Pointers are guaranteed to remain valid until the next call to RakPeer::Receive()

Returns:
room id

Implements RakNet::LobbyClientInterface.

unsigned int LobbyClientPC::GetPublicSlotMaxCount ( void ) const [virtual]

Get number of public slots that can be filled.

Note:
This may be lower than the actual number of members in the room if ChangeNumSlots() is called.

Implements RakNet::LobbyClientInterface.

unsigned int LobbyClientPC::GetPrivateSlotMaxCount ( void ) const [virtual]

Get number of private slots that can be filled.

Note:
This may be lower than the actual number of members in the room if ChangeNumSlots() is called.

Implements RakNet::LobbyClientInterface.

LobbyClientTitleId * LobbyClientPC::GetTitleId ( void ) const [virtual]

Get unique identifier of the title (game). On the PC this corresponds to the database primary key.

Returns:
title id

Implements RakNet::LobbyClientInterface.

DataStructures::Table::Row * LobbyClientPC::GetRoomTableRow ( void ) const [virtual]

Convenience function. Calls GetAllRooms(), returning the row of the room that we are currently in This is necessary to access customProperties passed to CreateRoom()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::JoinRoom | ( | LobbyClientRoomId * | roomId,
 |  | const char * | roomName,
 |  | const char * | roomPassword,
 |  | bool | joinAsSpectator |
 | ) |  |  | [virtual]

Join an existing room

Parameters:
[in] | roomId | Identifier of the room. Get this by calling DownloadRooms(). It is also specified with room invitation requests in the roomId member of LobbyClientInterfaceCB::RoomInvite_Notify
[in] | roomName | Name identifier of the room. Can specify this or the roomId
[in] | roomPassword | Password used to enter the room. If the room does not have a password, this field is ignored.
[in] | joinAsSpectator | Spectators do not typically play in the room. There is currently no limit on the number of spectators that can be in a room
Precondition:
Must be currently in a room
See also:
LobbyClientInterfaceCB::JoinRoom_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::JoinRoomByFilter | ( | DataStructures::Table::FilterQuery * | inclusionFilters,
 |  | unsigned | numInclusionFilters,
 |  | bool | joinAsSpectator |
 | ) |  |  | [virtual]

Joins the first available room based on a search filter. The room must not have a password and if joinAsSpectator==false, must have an available open slot

Parameters:
[in] | inclusionFilters | Filters to apply to the search query. Use 0 to get all rooms.
[in] | numInclusionFilters | Number of structures in the inclusionFilters array
[in] | joinAsSpectator | Spectators do not typically play in the room. There is currently no limit on the number of spectators that can be in a room
Precondition:
Must be logged in and not in a room
Note:
In order to honor hidden rooms, you should set the DefaultTableColumns::TC_ROOM_HIDDEN column.
See also:
DownloadRooms();

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::RoomChat | ( | const char * | chatMessage,
 |  | unsigned char | languageId,
 |  | const char * | chatBinaryData,
 |  | int | chatBinaryLength |
 | ) |  |  | [virtual]

Chat to all other members in a room Members which have you on ignore will not get your messages. There is no notification of this.

Parameters:
[in] | chatMessage | Body of the message to send
[in] | languageId | Language to use for string encoding for the StringCompressor class. Use 0 if unsure.
[in] | chatBinaryData | Any binary data you wish to send with the message (custom encoding, images, etc)
[in] | chatBinaryLength | Length in bytes of chatBinaryData
Precondition:
Must be currently in a room
See also:
LobbyClientInterfaceCB::RoomChat_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::InviteToRoom | ( | const char * | userHandle,
 |  | LobbyClientUserId * | userId,
 |  | const char * | chatMessage,
 |  | unsigned char | languageId,
 |  | const char * | chatBinaryData,
 |  | int | chatBinaryLength,
 |  | bool | inviteToPrivateSlot |
 | ) |  |  | [virtual]

Invite someone to join your room Invited users will join private slots if they exist, public slots if they do not or if the private slots are full Invitations are linked to the current moderator, so if the moderator leaves or changes via GrantModerator(), those invites are cleared.

Parameters:
[in] | userHandle | Handle of the user on which to perform this action. If you know userId leave this at 0.
[in] | userId | ID of the user on which to perform this action. Lookup is faster using ID. If you don't know it, specify userHandle instead.
[in] | chatMessage | Body of the message to send
[in] | languageId | Language to use for string encoding for the StringCompressor class. Use 0 if unsure.
[in] | chatBinaryData | Any binary data you wish to send with the message (custom encoding, images, etc)
[in] | chatBinaryLength | Length in bytes of chatBinaryData
[in] | Invite | this member to an private slot. (If false, they will be under the same restrictions as normal members attempting to join the room).
Precondition:
Must be currently in a room
See also:
LobbyClientInterfaceCB::InviteToRoom_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::SetReadyToPlayStatus ( bool isReady ) [virtual]

Rooms cannot start until all members first call SetReadyToPlayStatus(true) New members to a room have this set to false by default

Precondition:
Must be currently in a room
See also:
LobbyClientInterfaceCB::SetReadyToPlayStatus_Result()

LobbyClientInterfaceCB::RoomMemberReadyStateChange_Notify()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::KickRoomMember ( LobbyClientUserId * userId ) [virtual]

Kick someone out of your room. Unfortunate recipient will get the callback KickedOutOfRoom_Notify()

Precondition:
Must be the moderator of your room.
See also:
LobbyClientInterfaceCB::KickRoomMember_Result()

LobbyClientInterfaceCB::KickedOutOfRoom_Notify

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::SetRoomIsHidden ( bool roomIsHidden ) [virtual]

Sets the DefaultTableColumns::TC_ROOM_HIDDEN column to true or false in the rooms table. Other room members will get the callback RoomSetIsHidden_Notify()

See also:
LobbyClientInterfaceCB::SetRoomIsHidden_Result()

LobbyClientInterfaceCB::RoomSetIsHidden_Notify()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::SetRoomAllowSpectators ( bool spectatorsOn ) [virtual]

Sets if the room allows spectators Other room members will get the callback RoomSetAllowSpectators_Notify()

See also:
LobbyClientInterfaceCB::SetRoomAllowSpectators_Result()

LobbyClientInterfaceCB::RoomSetAllowSpectators_Notify()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::ChangeNumSlots | ( | int | totalSlots,
 |  | int | privateSlots |
 | ) |  |  | [virtual]

Changes the number of total and private slots for the room Other room members will get the callback RoomChangeNumSlots_Notify()

See also:
LobbyClientInterfaceCB::ChangeNumSlots_Result()

RoomChangeNumSlots_Notify

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::GrantModerator ( LobbyClientUserId * userId ) [virtual]

Grants moderator to another room member. This room member cannot be a spectator. Changing moderators clears current private slot invitations Other room members will get the callback RoomNewModerator_Notify()

See also:
LobbyClientInterfaceCB::GrantModerator_Result()

LobbyClientInterfaceCB::RoomNewModerator_Notify

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::StartGame ( void ) [virtual]

Attempts to start the game. All members in the room must be ready, set by calling SetReadyToPlayStatus(true) All members, including spectators, will get the callback StartGame_Notify() if successful This callback contains a list of all members in the room, along with SystemAddresses and other pertinent information

See also:
LobbyClientInterfaceCB::StartGame_Result()

LobbyClientInterfaceCB::StartGame_Notify()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::SubmitMatch ( RankingServerDBSpec::SubmitMatch_Data * input ) [virtual]

Submits the results of a match between two users This is typically a server command, not a user command For security, your IP must be in the trustedIpList table.

Parameters:
[in] input Data corresponding to the match. See RankingServerDBSpec.h for all parameters.
See also:
LobbyClientInterfaceCB::SubmitMatch_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::DownloadRating ( RankingServerDBSpec::GetRatingForParticipant_Data * input ) [virtual]

Downloads the rating for a particular user

Parameters:
[in] input Which user you are referring to. See RankingServerDBSpec.h for all parameters.
See also:
LobbyClientInterfaceCB::DownloadRating_Result()

Implements RakNet::LobbyClientInterface.

RankingServerDBSpec::GetRatingForParticipant_Data * LobbyClientPC::GetRating ( void ) [virtual]

Returns the rating that was most recently downloaded

Returns:
A pointing to the rating structure

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::QuickMatch | ( | int | requiredPlayers,
 |  | int | timeoutInSeconds |
 | ) |  |  | [virtual]

A quick match automatically groups other users that have also called QuickMatch(). The only condition is that they are in the same game, and have at least the value of requiredPlayers When the game starts all members will get the callback StartGame_Notify() The moderator is chosen at random. If the timer elapses with not enough members to start the game, the callback QuickMatchTimeout_Notify() will be called.

Todo:
This feature is currently hacked in and will start games but does not honor the requiredPlayers. In the near future I will have it working properly
Precondition:
You must be in the lobby to start this function
See also:
LobbyClientInterfaceCB::QuickMatch_Result()

LobbyClientInterfaceCB::StartGame_Notify()

LobbyClientInterfaceCB::QuickMatchTimeout_Notify()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::CancelQuickMatch ( void ) [virtual]

Cancel a prior call to QuickMatch() assuming timeoutInSeconds did not yet elapse.

See also:
LobbyClientInterfaceCB::CancelQuickMatch_Result()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::DownloadActionHistory ( bool ascendingSort ) [virtual]

Downloads the action history for yourself

Parameters:
[in] ascendingSort Sort order, by upload date
See also:
LobbyClientInterfaceCB::DownloadActionHistory_Result()

GetActionHistoryList()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::AddToActionHistory ( LobbyDBSpec::AddToActionHistory_Data * input ) [virtual]

Adds to the history of actions for yourself For security, defaultAllowClientsUploadActionHistory must be true in the titles table OR Your IP must be in the trustedIpList table

Parameters:
[in] input Data corresponding to the action. See LobbyDBSpec.h for all parameters.
See also:
LobbyClientInterfaceCB::AddToActionHistory_Result()

GetActionHistoryList()

Implements RakNet::LobbyClientInterface.

const DataStructures::List< LobbyDBSpec::AddToActionHistory_Data * > & LobbyClientPC::GetActionHistoryList ( void ) const [virtual]

Returns the results of a previous successful call to AddToActionHistory where AddToActionHistory_Result() returned success

Returns:
The action history for your user
See also:
DownloadActionHistory()

Implements RakNet::LobbyClientInterface.

bool LobbyClientPC::GetUserDetails | ( | LobbyClientUserId * | userId,
 |  | LobbyUserClientDetails * | details |
 | ) |  |  | [virtual]

Lookup extra details on a user specified by id Currently only users in your current room are downloaded.

Note:
Only "safe" details are downloaded for other users. If you pass your own Id (GetMyId()) all fields are fully filled out.
Returns:
True if the lookup succeeded

Implements RakNet::LobbyClientInterface.

LobbyClientUserId * LobbyClientPC::GerUserIdFromName ( const char * name ) [virtual]

Given the name of a user, return the id

Note:
To get the name of a user given an id, use GetUserDetails()

Implements RakNet::LobbyClientInterface.

void LobbyClientPC::OnAttach ( RakPeerInterface * peer ) [protected, virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult LobbyClientPC::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [protected, virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void LobbyClientPC::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [protected, virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

void LobbyClientPC::OnShutdown ( RakPeerInterface * peer ) [protected, virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/LobbyClientPC.h
  • C:/RakNet/DependentExtensions/Lobby/LobbyClientPC.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDB_PostgreSQL Class Reference

LobbyDB_PostgreSQL Class Reference

#include <LobbyDB_PostgreSQL.h>

List of all members.

Public Member Functions

bool | CreateLobbyServerTables (void)
bool | DestroyLobbyServerTables (void)
virtual void | PushFunctor (LobbyDBFunctor *functor, void *context)
void | AssignCallback (LobbyDBCBInterface *cb)

Detailed Description

Provides a central class for all LobbyServerDatabase functionality using the PostgreSQL interface If you are using more than one class that uses functionThreads, you should maintain this separately and call AssignFunctionThread() to avoid unnecessary threads.

Member Function Documentation

bool LobbyDB_PostgreSQL::CreateLobbyServerTables ( void )

Create the tables used by the ranking server, for all applications. Call this first. I recommend using UTF8 for the database encoding within PostgreSQL if you are going to store binary data

Returns:
True on success, false on failure.

bool LobbyDB_PostgreSQL::DestroyLobbyServerTables ( void )

Destroy the tables used by the ranking server. Don't call this unless you don't want to use the ranking server anymore, or are testing.

Returns:
True on success, false on failure.

void LobbyDB_PostgreSQL::PushFunctor | ( | LobbyDBFunctor * | functor,
 |  | void * | context |
 | ) |  |  | [virtual]

Push one of the above *_PostgreSQLImpl functors to run.

Parameters:
functor A structure allocated on the HEAP (using new) with the input parameters filled in.

void LobbyDB_PostgreSQL::AssignCallback ( LobbyDBCBInterface * cb )

Assigns a callback to get the results of processing.

Parameters:
[in] A structure allocated on the HEAP (using new) with the input parameters filled in.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDB_PostgreRepository/LobbyDB_PostgreSQL.h
  • C:/RakNet/DependentExtensions/Lobby/LobbyDB_PostgreRepository/LobbyDB_PostgreSQL.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBCBInterface Class Reference

LobbyDBCBInterface Class Reference

If you want to forward Functor::HandleResult() the output to a callback (which is what it does by default), you can use this. More...

#include <LobbyDB_PostgreSQL.h>

Inheritance diagram for LobbyDBCBInterface:

RakNet::LobbyServerPostgreSQL List of all members.

Detailed Description

If you want to forward Functor::HandleResult() the output to a callback (which is what it does by default), you can use this.

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDB_PostgreRepository/LobbyDB_PostgreSQL.h
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::LobbyServer Class Reference

RakNet::LobbyServer

RakNet::LobbyServer Class Reference

#include <LobbyServer.h>

Inheritance diagram for RakNet::LobbyServer:

PluginInterface RakNet::LobbyServerPostgreSQL List of all members.

Public Member Functions

void | SetOrderingChannel (char oc)
Ordering channel to use with RakPeer::Send().

Protected Member Functions

void | DownloadClans_NetMsg (Packet *packet)
virtual void | UpdateClanMember_DBResult (bool dbSuccess, const char *queryErrorMessage, LobbyDBSpec::UpdateClanMember_Data *res, unsigned int lobbyMsgId, SystemAddress systemAddress, LobbyDBSpec::DatabaseKey clanSourceMemberId, RakNet::RakString clanSourceMemberHandle)
virtual void | ValidateUserKey_DBResult (bool dbSuccess, const char *queryErrorMessage, TitleValidationDBSpec::ValidateUserKey_Data *res, SystemAddress systemAddress)
virtual void | OnAttach (RakPeerInterface *peer)
PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
virtual void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)
virtual void | OnShutdown (RakPeerInterface *peer)
virtual void | Update (RakPeerInterface *peer)

Detailed Description

Features include user to user interaction, chatting, rooms, and quick match. Just attach as a plugin and go. If you want to interact with the implemented PostgreSQL database, such as adding users or titles, see LobbyServerPostgreSQL

Member Function Documentation

void LobbyServer::DownloadClans_NetMsg ( Packet * packet ) [protected]

void LobbyServer::UpdateClanMember_DBResult | ( | bool | dbSuccess,
 |  | const char * | queryErrorMessage,
 |  | LobbyDBSpec::UpdateClanMember_Data * | res,
 |  | unsigned int | lobbyMsgId,
 |  | SystemAddress | systemAddress,
 |  | LobbyDBSpec::DatabaseKey | clanSourceMemberId,
 |  | RakNet::RakString | clanSourceMemberHandle |
 | ) |  |  | [protected, virtual]

void LobbyServer::ValidateUserKey_DBResult | ( | bool | dbSuccess,
 |  | const char * | queryErrorMessage,
 |  | TitleValidationDBSpec::ValidateUserKey_Data * | res,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [protected, virtual]

void LobbyServer::OnAttach ( RakPeerInterface * peer ) [protected, virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult LobbyServer::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [protected, virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void LobbyServer::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [protected, virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

void LobbyServer::OnShutdown ( RakPeerInterface * peer ) [protected, virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void LobbyServer::Update ( RakPeerInterface * peer ) [protected, virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

Reimplemented in RakNet::LobbyServerPostgreSQL.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/LobbyServer.h
  • C:/RakNet/DependentExtensions/Lobby/LobbyServer.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::LobbyServerPostgreSQL Class Reference

RakNet::LobbyServerPostgreSQL

RakNet::LobbyServerPostgreSQL Class Reference

#include <LobbyServer_PostgreSQL.h>

Inheritance diagram for RakNet::LobbyServerPostgreSQL:

RakNet::LobbyServer RankingServerCBInterface LobbyDBCBInterface TitleValidationDBCBInterface PluginInterface List of all members.

Protected Member Functions

virtual void Update (RakPeerInterface *peer)

Detailed Description

Implementation of the database functionality for the LobbyServer. Implements callbacks for the ranking server, lobby, and title validation databases Database interaction samples are:
See also:
LobbyDB_PostgreSQLTest

TitleValidationDB_PostgreSQLTest

RankingServerDBTest

Member Function Documentation

void LobbyServerPostgreSQL::Update ( RakPeerInterface * peer ) [protected, virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented from RakNet::LobbyServer.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/LobbyServer_PostgreSQL/LobbyServer_PostgreSQL.h
  • C:/RakNet/DependentExtensions/Lobby/LobbyServer_PostgreSQL/LobbyServer_PostgreSQL.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LogCommandParser Class Reference

LogCommandParser Class Reference

Adds the ability to send logging output to a remote console. More...

#include <LogCommandParser.h>

Inheritance diagram for LogCommandParser:

CommandParserInterface List of all members.

Public Member Functions

bool | OnCommand (const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, SystemAddress systemAddress, const char *originalString)
const char * | GetName (void) const
void | SendHelp (TransportInterface *transport, SystemAddress systemAddress)
void | AddChannel (const char *channelName)
Parameters:
[in] channelName A persistent string naming the channel. Don't deallocate this string.

void | WriteLog (const char *channelName, const char *format,...)
void | OnNewIncomingConnection (SystemAddress systemAddress, TransportInterface *transport)
void | OnConnectionLost (SystemAddress systemAddress, TransportInterface *transport)
void | OnTransportChange (TransportInterface *transport)

Protected Member Functions

void | PrintChannels (SystemAddress systemAddress, TransportInterface *transport) const
unsigned | Unsubscribe (SystemAddress systemAddress, const char *channelName)
unsigned | Subscribe (SystemAddress systemAddress, const char *channelName)
unsigned | GetChannelIndexFromName (const char *channelName)

Protected Attributes

DataStructures::List< SystemAddressAndChannel > remoteUsers
The list of remote users. Added to when users subscribe, removed when they disconnect or unsubscribe.
const char * | channelNames [32]
Names of the channels at each bit, or 0 for an unused channel.
TransportInterface * trans
This is so I can save the current transport provider, solely so I can use it without having the user pass it to Log.

Classes

struct | SystemAddressAndChannel
One of these structures is created per player. More...

Detailed Description

Adds the ability to send logging output to a remote console.

Member Function Documentation

bool LogCommandParser::OnCommand | ( | const char * | command,
 |  | unsigned | numParameters,
 |  | char ** | parameterList,
 |  | TransportInterface * | transport,
 |  | SystemAddress | systemAddress,
 |  | const char * | originalString |
 | ) |  |  | [virtual]

Given command with parameters parameterList , do whatever processing you wish.

Parameters:
[in] | command | The command to process
[in] | numParameters | How many parameters were passed along with the command
[in] | parameterList | The list of parameters. parameterList[0] is the first parameter and so on.
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that sent this command.
[in] | originalString | The string that was actually sent over the network, in case you want to do your own parsing

Implements CommandParserInterface.

const char * LogCommandParser::GetName ( void ) const [virtual]

You are responsible for overriding this function and returning a static string, which will identifier your parser. This should return a static string

Returns:
The name that you return.

Implements CommandParserInterface.

void LogCommandParser::SendHelp | ( | TransportInterface * | transport,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [virtual]

A callback for when you are expected to send a brief description of your parser to systemAddress

Parameters:
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that requested help.

Implements CommandParserInterface.

void LogCommandParser::WriteLog | ( | const char * | channelName,
 |  | const char * | format,
 |  |  | ...
 | ) |  |

Write a log to a channel. Logs are not buffered, so only remote consoles connected and subscribing at the time you write will get the output.

Parameters:
[in] format Same as printf()
[in] ... Same as printf()

void LogCommandParser::OnNewIncomingConnection | ( | SystemAddress | systemAddress,
 |  | TransportInterface * | transport |
 | ) |  |  | [virtual]

A callback for when systemAddress has connected to us.

Parameters:
[in] | systemAddress | The player that has connected.
[in] | transport | The transport interface that sent us this information. Can be used to send messages to this or other players.

Reimplemented from CommandParserInterface.

void LogCommandParser::OnConnectionLost | ( | SystemAddress | systemAddress,
 |  | TransportInterface * | transport |
 | ) |  |  | [virtual]

A callback for when systemAddress has disconnected, either gracefully or forcefully

Parameters:
[in] | systemAddress | The player that has disconnected.
[in] | transport | The transport interface that sent us this information.

Reimplemented from CommandParserInterface.

void LogCommandParser::OnTransportChange ( TransportInterface * transport ) [virtual]

This is called every time transport interface is registered. If you want to save a copy of the TransportInterface pointer This is the place to do it

Parameters:
[in] transport The new TransportInterface

Reimplemented from CommandParserInterface.

void LogCommandParser::PrintChannels | ( | SystemAddress | systemAddress,
 |  | TransportInterface * | transport |
 | ) |  |  | const [protected]

Sends the currently active channels to the user

Parameters:
[in] | systemAddress | The player to send to
[in] | transport | The transport interface to use to send the channels

unsigned LogCommandParser::Unsubscribe | ( | SystemAddress | systemAddress,
 |  | const char * | channelName |
 | ) |  |  | [protected]

Unsubscribe a user from a channel (or from all channels)

Parameters:
[in] | systemAddress | The player to unsubscribe to
[in] | channelName | If 0, then unsubscribe from all channels. Otherwise unsubscribe from the named channel

unsigned LogCommandParser::Subscribe | ( | SystemAddress | systemAddress,
 |  | const char * | channelName |
 | ) |  |  | [protected]

Subscribe a user to a channel (or to all channels)

Parameters:
[in] | systemAddress | The player to subscribe to
[in] | channelName | If 0, then subscribe from all channels. Otherwise subscribe to the named channel

unsigned LogCommandParser::GetChannelIndexFromName ( const char * channelName ) [protected]

Given the name of a channel, return the index into channelNames where it is located

Parameters:
[in] channelName The name of the channel

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/LogCommandParser.h
  • C:/RakNet/Source/LogCommandParser.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LogCommandParser::SystemAddressAndChannel Struct Reference

LogCommandParser::SystemAddressAndChannel

LogCommandParser::SystemAddressAndChannel Struct Reference

One of these structures is created per player. More...

#include <LogCommandParser.h>

List of all members.

Public Attributes

SystemAddress systemAddress
The ID of the player.
unsigned channels
Bitwise representations of the channels subscribed to. If bit 0 is set, then we subscribe to channelNames[0] and so on.

Detailed Description

One of these structures is created per player.

The documentation for this struct was generated from the following file:
  • C:/RakNet/Source/LogCommandParser.h
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ltp_params Struct Reference

ltp_params Struct Reference

#include <ltp.h>

List of all members.

Detailed Description

LTP parameters.

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/ltp.h
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::Map< key_type, data_type, key_comparison_func > Class Template Reference

DataStructures::Map

DataStructures::Map< key_type, data_type, key_comparison_func > Class Template Reference

Note:
IMPORTANT! If you use defaultMapKeyComparison then call IMPLEMENT_DEFAULT_COMPARISON or you will get an unresolved external linker error.
More...

#include <DS_Map.h>

List of all members.

Detailed Description

template<class key_type, class data_type, int(*)(const key_type &, const key_type &) key_comparison_func = defaultMapKeyComparison<key_type>>
class DataStructures::Map< key_type, data_type, key_comparison_func >

Note:
IMPORTANT! If you use defaultMapKeyComparison then call IMPLEMENT_DEFAULT_COMPARISON or you will get an unresolved external linker error.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/DS_Map.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: MemoryCompressor Class Reference

MemoryCompressor Class Reference

Compress one or more blocks of data. More...

#include <MemoryCompressor.h>

List of all members.

Public Member Functions

bool | Compress (char *input, const unsigned inputLength, bool finish)
void | Clear (void)
Resets the compressor and all data.

Detailed Description

Compress one or more blocks of data.

Member Function Documentation

bool MemoryCompressor::Compress | ( | char * | input,
 |  | const unsigned | inputLength,
 |  | bool | finish
 | ) |  |

Compress a block of data. Pass true to finish if this is the last block in the series. If you don't know if it's the last block, you can call it again with 0 for inputLength

Note:
Data passed to input isn't necessarily immediately compressed to output. You can force a write by passing true to finish. Multiple calls concatenate the written data.
Parameters:
[in] | input | A pointer to a block of data
[in] | inputLength | The length of input
[in] | finish | Write the last of the data.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/MemoryCompressor.h
  • C:/RakNet/DependentExtensions/MemoryCompressor.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::MemoryPool< MemoryBlockType > Class Template Reference

DataStructures::MemoryPool

DataStructures::MemoryPool< MemoryBlockType > Class Template Reference

#include <DS_MemoryPool.h>

List of all members.

Detailed Description

template<class MemoryBlockType>
class DataStructures::MemoryPool< MemoryBlockType >

Very fast memory pool for allocating and deallocating structures that don't have constructors or destructors. Contains a list of pages, each of which has an array of the user structures

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/DS_MemoryPool.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: MessageFilter Class Reference

MessageFilter Class Reference
[MessageFilter]

Assigns systems to FilterSets. Each FilterSet limits what kinds of messages are allowed. The MessageFilter plugin is used for security where you limit what systems can send what kind of messages. You implicitly define FilterSets, and add allowed message IDs and RPC calls to these FilterSets. You then add systems to these filters, such that those systems are limited to sending what the filters allows. You can automatically assign systems to a filter. You can automatically kick and possibly ban users that stay in a filter too long, or send the wrong message. Each system is a member of either zero or one filters. Add this plugin before any plugin you wish to filter (most likely just add this plugin before any other). More...

#include <MessageFilter.h>

Inheritance diagram for MessageFilter:

PluginInterface List of all members.

Public Member Functions

void | SetAutoAddNewConnectionsToFilter (int filterSetID)
void | SetAllowMessageID (bool allow, int messageIDStart, int messageIDEnd, int filterSetID)
void | SetAllowRPC (bool allow, const char *functionName, int filterSetID)
void | SetActionOnDisallowedMessage (bool kickOnDisallowed, bool banOnDisallowed, RakNetTime banTimeMS, int filterSetID)
void | SetDisallowedMessageCallback (int filterSetID, void *userData, void(*invalidMessageCallback)(RakPeerInterface *peer, SystemAddress systemAddress, int filterSetID, void *userData, unsigned char messageID))
void | SetTimeoutCallback (int filterSetID, void *userData, void(*invalidMessageCallback)(RakPeerInterface *peer, SystemAddress systemAddress, int filterSetID, void *userData))
void | SetFilterMaxTime (int allowedTimeMS, bool banOnExceed, RakNetTime banTimeMS, int filterSetID)
int | GetSystemFilterSet (SystemAddress systemAddress)
void | SetSystemFilterSet (SystemAddress systemAddress, int filterSetID)
unsigned | GetSystemCount (int filterSetID) const
SystemAddress | GetSystemByIndex (int filterSetID, unsigned index)
unsigned | GetFilterSetCount (void) const
int | GetFilterSetIDByIndex (unsigned index)
void | DeleteFilterSet (int filterSetID)
Parameters:
[in] filterSetID The ID of the filter set to delete.

virtual void | OnAttach (RakPeerInterface *peer)
virtual void | OnDetach (RakPeerInterface *peer)
virtual void | OnShutdown (RakPeerInterface *peer)
virtual void | Update (RakPeerInterface *peer)
virtual PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
virtual void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)

Detailed Description

Assigns systems to FilterSets. Each FilterSet limits what kinds of messages are allowed. The MessageFilter plugin is used for security where you limit what systems can send what kind of messages. You implicitly define FilterSets, and add allowed message IDs and RPC calls to these FilterSets. You then add systems to these filters, such that those systems are limited to sending what the filters allows. You can automatically assign systems to a filter. You can automatically kick and possibly ban users that stay in a filter too long, or send the wrong message. Each system is a member of either zero or one filters. Add this plugin before any plugin you wish to filter (most likely just add this plugin before any other).

Member Function Documentation

void MessageFilter::SetAutoAddNewConnectionsToFilter ( int filterSetID )

Automatically add all new systems to a particular filter Defaults to -1

Parameters:
[in] filterSetID Which filter to add new systems to. <0 for do not add.

void MessageFilter::SetAllowMessageID | ( | bool | allow,
 |  | int | messageIDStart,
 |  | int | messageIDEnd,
 |  | int | filterSetID
 | ) |  |

Allow a range of message IDs Always allowed by default: ID_CONNECTION_REQUEST_ACCEPTED through ID_DOWNLOAD_PROGRESS Usually you specify a range to make it easier to add new enumerations without having to constantly refer back to this function.

Parameters:
[in] | allow | True to allow this message ID, false to disallow. By default, all messageIDs except the noted types are disallowed. This includes messages from other plugins!
[in] | messageIDStart | The first ID_* message to allow in the range. Inclusive.
[in] | messageIDEnd | The last ID_* message to allow in the range. Inclusive.
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings.

void MessageFilter::SetAllowRPC | ( | bool | allow,
 |  | const char * | functionName,
 |  | int | filterSetID
 | ) |  |

Allow an RPC function, by name

Parameters:
[in] | allow | True to allow an RPC call with this function name, false to disallow. All RPCs are disabled by default.
[in] | functionName | the function name of the RPC call. Must match the function name exactly, including case.
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings.

void MessageFilter::SetActionOnDisallowedMessage | ( | bool | kickOnDisallowed,
 |  | bool | banOnDisallowed,
 |  | RakNetTime | banTimeMS,
 |  | int | filterSetID
 | ) |  |

What action to take on a disallowed message. You can kick or not. You can add them to the ban list for some time By default no action is taken. The message is simply ignored. param[in] 0 for permanent ban, >0 for ban time in milliseconds.

Parameters:
[in] | kickOnDisallowed | kick the system that sent a disallowed message.
[in] | banOnDisallowed | ban the system that sent a disallowed message. See banTimeMS for the ban duration
[in] | banTimeMS | Passed to the milliseconds parameter of RakPeer::AddToBanList.
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings.

void MessageFilter::SetDisallowedMessageCallback | ( | int | filterSetID,
 |  | void * | userData,
 |  | void(*)(RakPeerInterface *peer, SystemAddress systemAddress, int filterSetID, void *userData, unsigned char messageID) | invalidMessageCallback
 | ) |  |

Set a user callback to be called on an invalid message for a particular filterSet

Parameters:
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings.
[in] | userData | A pointer passed with the callback
[in] | invalidMessageCallback | A pointer to a C function to be called back with the specified parameters.

void MessageFilter::SetTimeoutCallback | ( | int | filterSetID,
 |  | void * | userData,
 |  | void(*)(RakPeerInterface *peer, SystemAddress systemAddress, int filterSetID, void *userData) | invalidMessageCallback
 | ) |  |

Set a user callback to be called when a user is disconnected due to SetFilterMaxTime

Parameters:
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings.
[in] | userData | A pointer passed with the callback
[in] | invalidMessageCallback | A pointer to a C function to be called back with the specified parameters.

void MessageFilter::SetFilterMaxTime | ( | int | allowedTimeMS,
 |  | bool | banOnExceed,
 |  | RakNetTime | banTimeMS,
 |  | int | filterSetID
 | ) |  |

Limit how long a connection can stay in a particular filterSetID. After this time, the connection is kicked and possibly banned. By default there is no limit to how long a connection can stay in a particular filter set.

Parameters:
[in] | allowedTimeMS | How many milliseconds to allow a connection to stay in this filter set.
[in] | banOnExceed | True or false to ban the system, or not, when allowedTimeMS is exceeded
[in] | banTimeMS | Passed to the milliseconds parameter of RakPeer::AddToBanList.
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings.

int MessageFilter::GetSystemFilterSet ( SystemAddress systemAddress )

Get the filterSetID a system is using. Returns -1 for none.

Parameters:
[in] systemAddress The system we are referring to

void MessageFilter::SetSystemFilterSet | ( | SystemAddress | systemAddress,
 |  | int | filterSetID
 | ) |  |

Assign a system to a filter set. Systems are automatically added to filter sets (or not) based on SetAutoAddNewConnectionsToFilter() This function is used to change the filter set a system is using, to add it to a new filter set, or to remove it from all existin filter sets.

Parameters:
[in] | systemAddress | The system we are referring to
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings. If -1, the system will be removed from all filter sets.

unsigned MessageFilter::GetSystemCount ( int filterSetID ) const

Returns the number of systems subscribed to a particular filter set Using anything other than -1 for filterSetID is slow, so you should store the returned value.

Parameters:
[in] filterSetID The filter set to limit to. Use -1 for none (just returns the total number of filter systems in that case).

SystemAddress MessageFilter::GetSystemByIndex | ( | int | filterSetID,
 |  | unsigned | index
 | ) |  |

Returns a system subscribed to a particular filter set,by index. index should be between 0 and the GetSystemCount(filterSetID)-1;

Parameters:
[in] | filterSetID | The filter set to limit to. Use -1 for none (just indexes all the filtered systems in that case).
[in] | index | A number between 0 and GetSystemCount(filterSetID)-1;

unsigned MessageFilter::GetFilterSetCount ( void ) const

Returns the total number of filter sets.

Returns:
The total number of filter sets.

int MessageFilter::GetFilterSetIDByIndex ( unsigned index )

Returns the ID of a filter set, by index

Parameters:
[in] An index between 0 and GetFilterSetCount()-1 inclusive

void MessageFilter::DeleteFilterSet ( int filterSetID )

Parameters:
[in] filterSetID The ID of the filter set to delete.

Delete a FilterSet. All systems formerly subscribed to this filter are now unrestricted.

void MessageFilter::OnAttach ( RakPeerInterface * peer ) [virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void MessageFilter::OnDetach ( RakPeerInterface * peer ) [virtual]

Called when the interface is detached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void MessageFilter::OnShutdown ( RakPeerInterface * peer ) [virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void MessageFilter::Update ( RakPeerInterface * peer ) [virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult MessageFilter::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void MessageFilter::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/MessageFilter.h
  • C:/RakNet/Source/MessageFilter.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RankingServerDBSpec::ModifyTrustedIPList_Data Class Reference

RankingServerDBSpec::ModifyTrustedIPList_Data

RankingServerDBSpec::ModifyTrustedIPList_Data Class Reference

#include <RankingServerDBSpec.h>

Inheritance diagram for RankingServerDBSpec::ModifyTrustedIPList_Data:

RefCountedObj ModifyTrustedIPList_PostgreSQLImpl List of all members.

Public Attributes

RakNet::RakString ip
[in] IP of the system to allow or disallow submissions
SystemAddress systemAddress
[out] System Address corresponding to this IP. Returned in GetTrustedIPList_Data
bool addToList
[in] True to add to the list, false to remove from the list
PairedKeyDbId gameDbId
[in] Identifies in the game in the database with a primary and secondary integer key. User defined.

Detailed Description

Add or drop an allowed IP to submit matches This is not enforced in the database, but can be enforced in code

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ModifyTrustedIPList_PostgreSQLImpl Class Reference

ModifyTrustedIPList_PostgreSQLImpl Class Reference

Modify the list of IPs allowed to submit matches. More...

#include <RankingServer_PostgreSQL.h>

Inheritance diagram for ModifyTrustedIPList_PostgreSQLImpl:

RankingServerDBSpec::ModifyTrustedIPList_Data RefCountedObj List of all members.

Public Member Functions

virtual void | Process (void *context)
Does SQL Processing.
virtual void | HandleResult (bool wasCancelled, void *context)

Static Public Member Functions

static ModifyTrustedIPList_PostgreSQLImpl * | Alloc (void)
Use these for allocation/deallocation if building to a DLL, so allocation and deallocation happen in the same DLL.

Detailed Description

Modify the list of IPs allowed to submit matches.

Member Function Documentation

void ModifyTrustedIPList_PostgreSQLImpl::HandleResult | ( | bool | wasCancelled,
 |  | void * | context |
 | ) |  |  | [virtual]

Calls the callback specified by RankingServerFunctor::callback (which you set) or RankingServer_PostgreSQL::AssignCallback() (which sets it for you) Default implementation also deallocates the structure.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.h
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: NatPunchthrough Class Reference

NatPunchthrough Class Reference
[NatPunchthrough]

The NatPunchthrough class implements the NAT punch through technique, allowing two systems to connect to each other that are both behind NATs. More...

#include <NatPunchthrough.h>

Inheritance diagram for NatPunchthrough:

PluginInterface List of all members.

Public Member Functions

NatPunchthrough ()
Constructor.
virtual | ~NatPunchthrough ()
Destructor.
void | FacilitateConnections (bool allow)
bool | Connect (const char *destination, unsigned short remotePort, const char *passwordData, int passwordDataLength, SystemAddress facilitator)
bool | Connect (SystemAddress destination, const char *passwordData, int passwordDataLength, SystemAddress facilitator)
void | Clear (void)
Free internal memory.
void | SetLogger (NatPunchthroughLogger *l)
Sets the log output to print messages to.
virtual void | OnAttach (RakPeerInterface *peer)
virtual void | Update (RakPeerInterface *peer)
virtual PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
virtual void | OnShutdown (RakPeerInterface *peer)
virtual void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)

Detailed Description

The NatPunchthrough class implements the NAT punch through technique, allowing two systems to connect to each other that are both behind NATs.

A NAT (Network Address Translator) is a system that will makes it so your system's IP address is different from the IP address exposed to the internet. This provides some security and allows multiple computers, each with a different IP address, to share one IP address as seen by the internet.

The problem is that NATs also ignore packets sent to them unless they sent a packet to the sender first. If two systems are both behind NATs, then neither system can connect to each other. Furthermore, some NATs will impose a temporary ban on an IP address that send unsolicited packets to them.

This can be solved by using a third system, a facilitator, that is not behind a NAT and that both systems are already connected to. It will synchronize a send between both NAT systems such that the routers will both consider themselves as handling a reply to a message, when in fact they are handing an initial message. As replies are allowed, both systems get their corresponding messages and the connection takes place. S = system that wants to connect F = facilitator R = system to get the connection request.

S knows IP of R in advance. 1. S->F facilitate connection request to R 2. if (R is not is connected) F->S ID_NAT_TARGET_NOT_CONNECTED. Exit. 3. F -> (Ping S, Ping R), every X ms Y times. Wait Max(Ping(s), Ping(r) * multiple ms more, then go to step 4. 4. F picks time highest(ave of Ping R,S) * N from now and sends this time RELIABLE and timestamped to R,S. 5. At time picked in (4), S attempts to connect to R. R sends offline ping to S. 6. If R disconnects before or at step 4, tell this to S via ID_NAT_TARGET_CONNECTION_LOST

Note:
Timing is important with this plugin. You need to call RakPeer::Receive frequently.

Member Function Documentation

void NatPunchthrough::FacilitateConnections ( bool allow )

Call with true to allow other systems to use this system as a NAT punch through facilitator. This takes a little bandwidth but otherwise there is no reason to disallow it. Defaults to true

Parameters:
[in] allow True to allow, false to disallow.

bool NatPunchthrough::Connect | ( | const char * | destination,
 |  | unsigned short | remotePort,
 |  | const char * | passwordData,
 |  | int | passwordDataLength,
 |  | SystemAddress | facilitator
 | ) |  |

Call this to start to connect to the specified host (ip or domain name) and server port using facilitator to punch through a NAT This is a non-blocking operation You know the connection is successful when you get the message ID_CONNECTION_ACCEPTED. You know the connection failed when you get the message ID_CONNECTION_ATTEMPT_FAILED, ID_CONNECTION_BANNED, or ID_NAT_TARGET_NOT_CONNECTED Both you and the host must be connected to the facilitator.

Precondition:
Requires that you first call Initialize

Both host and this system must already be connected to the system at the address facilitator and facilitator must be running NatPunchthrough with FacilitateConnections(true) previously called.

Parameters:
[in] | destination | Either a dotted IP address or a domain name of the system you ultimately want to connect to.
[in] | remotePort | Which port to connect to of the system you ultimately want to connect to.
[in] | passwordData | A data block that must match the data block on the host. This can be just a password, or can be a stream of data
[in] | passwordDataLength | The length in bytes of passwordData
Returns:
If you are not connected to the facilitator this function returns false. Otherwise it returns true.

bool NatPunchthrough::Connect | ( | SystemAddress | destination,
 |  | const char * | passwordData,
 |  | int | passwordDataLength,
 |  | SystemAddress | facilitator
 | ) |  |

Same as above, but takes a SystemAddress for a host

Parameters:
[in] | destination | The address of the host to connect to.
[in] | remotePort | Which port to connect to of the system you ultimately want to connect to.
[in] | passwordData | A data block that must match the data block on the host. This can be just a password, or can be a stream of data
[in] | passwordDataLength | The length in bytes of passwordData
Returns:
If you are not connected to the facilitator this function returns false. Otherwise it returns true.

void NatPunchthrough::OnAttach ( RakPeerInterface * peer ) [virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void NatPunchthrough::Update ( RakPeerInterface * peer ) [virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult NatPunchthrough::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void NatPunchthrough::OnShutdown ( RakPeerInterface * peer ) [virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void NatPunchthrough::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/NatPunchthrough.h
  • C:/RakNet/Source/NatPunchthrough.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: NatPunchthroughLogger Class Reference

NatPunchthroughLogger Class Reference
[NatPunchthrough]

Prints logging output for NatPunchthrough. More...

#include <NatPunchthrough.h>

List of all members.

Detailed Description

Prints logging output for NatPunchthrough.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/NatPunchthrough.h
  • C:/RakNet/Source/NatPunchthrough.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: NetworkIDManager Class Reference

NetworkIDManager Class Reference

#include <NetworkIDManager.h>

List of all members.

Public Member Functions

void | SetIsNetworkIDAuthority (bool isAuthority)
bool | IsNetworkIDAuthority (void) const
Returns:
Returns what was passed to SetIsNetworkIDAuthority()

void | SetExternalSystemAddress (SystemAddress systemAddress)
unsigned short | GetSharedNetworkID (void)
void | SetSharedNetworkID (unsigned short i)
NetworkIDObject * | GET_BASE_OBJECT_FROM_ID (NetworkID x)
void * | GET_OBJECT_FROM_ID (NetworkID x)
template<class returnType>
returnType | GET_OBJECT_FROM_ID (NetworkID x)

Protected Attributes

DataStructures::AVLBalancedBinarySearchTree<
NetworkIDNode > 		IDTree
This AVL tree holds the pointer to NetworkID mappings.

Friends

class | NetworkIDObject

Detailed Description

This class is simply used to generate a unique number for a group of instances of NetworkIDObject An instance of this class is required to use the ObjectID to pointer lookup system You should have one instance of this class per game instance. Call SetIsNetworkIDAuthority before using any functions of this class, or of NetworkIDObject

Member Function Documentation

void NetworkIDManager::SetIsNetworkIDAuthority ( bool isAuthority )

For every group of systems, one system needs to be responsible for creating unique IDs for all objects created on all systems. This way, systems can send that id in packets to refer to objects (you can't send pointers because the memory allocations may be different). In a client/server environment, the system that creates unique IDs would be the server. If you are using peer to peer or other situations where you don't have a single system to assign ids, set this to true, and set NetworkID::peerToPeerMode to true

void NetworkIDManager::SetExternalSystemAddress ( SystemAddress systemAddress )

Necessary for peer to peer, as NetworkIDs are then composed of your external player Id (doesn't matter which, as long as unique) plus the usual object ID number. Get this from RakPeer::GetExternalSystemAddress) one time, the first time you make a connection.

Precondition:
You must first call SetNetworkIDManager before using this function
Parameters:
[in] systemAddress Your external systemAddress

unsigned short NetworkIDManager::GetSharedNetworkID ( void )

These function is only meant to be used when saving games as you should save the HIGHEST value staticItemID has achieved upon save and reload it upon load. Save AFTER you've created all the items derived from this class you are going to create.

Returns:
the HIGHEST Object Id currently used

void NetworkIDManager::SetSharedNetworkID ( unsigned short i )

These function is only meant to be used when loading games. Load BEFORE you create any new objects that are not SetIDed based on the save data.

Parameters:
[in] i the highest number of NetworkIDObject reached.

NetworkIDObject * NetworkIDManager::GET_BASE_OBJECT_FROM_ID ( NetworkID x )

If you use a parent, returns this instance rather than the parent object.

Precondition:
You must first call SetNetworkIDManager before using this function

void * NetworkIDManager::GET_OBJECT_FROM_ID ( NetworkID x )

Returns the parent object, or this instance if you don't use a parent. , use the template form. This form requires that NetworkIDObject is the basemost derived class

Precondition:
You must first call SetNetworkIDManager before using this function

template<class returnType>
returnType NetworkIDManager::GET_OBJECT_FROM_ID ( NetworkID x ) [inline]

Returns the parent object, or this instance if you don't use a parent. Supports NetworkIDObject anywhere in the inheritance hierarchy

Precondition:
You must first call SetNetworkIDManager before using this function

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/NetworkIDManager.h
  • C:/RakNet/Source/NetworkIDManager.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: NetworkIDObject Class Reference

NetworkIDObject Class Reference

Unique shared ids for each object instance. More...

#include <NetworkIDObject.h>

Inheritance diagram for NetworkIDObject:

RakNet::Replica2 Replica List of all members.

Public Member Functions

NetworkIDObject ()
Constructor. NetworkIDs, if IsNetworkIDAuthority() is true, are created here.
virtual | ~NetworkIDObject ()
Destructor. Used NetworkIDs, if any, are freed here.
virtual void | SetNetworkIDManager (NetworkIDManager *manager)
virtual NetworkIDManager * | GetNetworkIDManager (void)
Returns what was passed to SetNetworkIDManager.
virtual NetworkID | GetNetworkID (void)
virtual void | SetNetworkID (NetworkID id)
virtual void | SetParent (void *_parent)
virtual void * | GetParent (void) const
virtual bool | RequiresSetParent (void) const
unsigned int | GetAllocationNumber (void) const
Used so I can compare pointers in the ReplicaManager.

Protected Member Functions

void | GenerateID (void)
Internal function to generate an ID when needed. This is deferred until needed and is not called from the constructor.

Protected Attributes

NetworkID | networkID
The network ID of this object.
void * | parent
The parent set by SetParent().
bool | callGenerationCode
This is crap but is necessary because virtual functions don't work in the constructor.

Static Protected Attributes

static unsigned int | nextAllocationNumber
Used so I can compare pointers in the ReplicaManager.

Detailed Description

Unique shared ids for each object instance.

A class you can derive from to make it easier to represent every networked object with an integer. This way you can refer to objects over the network. One system should return true for IsNetworkIDAuthority() and the rest should return false. When an object needs to be created, have the the one system create the object. Then have that system send a message to all other systems, and include the value returned from GetNetworkID() in that packet. All other systems should then create the same class of object, and call SetNetworkID() on that class with the NetworkID in the packet.

See also:
the manual for more information on this.

Member Function Documentation

void NetworkIDObject::SetNetworkIDManager ( NetworkIDManager * manager ) [virtual]

Sets the manager class from which to request unique network IDs Unlike previous versions, the NetworkIDObject relies on a manager class to provide IDs, rather than using statics, So you can have more than one set of IDs on the same system.

NetworkID NetworkIDObject::GetNetworkID ( void ) [virtual]

Returns the NetworkID that you can use to refer to this object over the network.

Precondition:
You must first call SetNetworkIDManager before using this function
Return values:
UNASSIGNED_NETWORK_ID | UNASSIGNED_NETWORK_ID is returned IsNetworkIDAuthority() is false and SetNetworkID() was not previously called. This is also returned if you call this function in the constructor.
0-65534 | Any other value is a valid NetworkID. NetworkIDs start at 0 and go to 65534, wrapping at that point.

void NetworkIDObject::SetNetworkID ( NetworkID id ) [virtual]

Sets the NetworkID for this instance. Usually this is called by the clients and determined from the servers. However, if you save multiplayer games you would likely use This on load as well.

void NetworkIDObject::SetParent ( void * _parent ) [virtual]

Your class does not have to derive from NetworkIDObject, although that is the easiest way to implement this. If you want this to be a member object of another class, rather than inherit, then call SetParent() with a pointer to the parent class instance. GET_OBJECT_FROM_ID will then return the parent rather than this instance.

void * NetworkIDObject::GetParent ( void ) const [virtual]

Return what was passed to SetParent

Returns:
The value passed to SetParent, or 0 if it was never called.

bool NetworkIDObject::RequiresSetParent ( void ) const [virtual]

Overload this function and return true if you require that SetParent is called before this object is used. This is a safety check you should do this if you want this to be a member object of another class rather than derive from this class.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/NetworkIDObject.h
  • C:/RakNet/Source/NetworkIDObject.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::OrderedList< key_type, data_type, default_comparison_function > Class Template Reference

DataStructures::OrderedList

DataStructures::OrderedList< key_type, data_type, default_comparison_function > Class Template Reference

Note:
IMPORTANT! If you use defaultOrderedListComparison then call IMPLEMENT_DEFAULT_COMPARISON or you will get an unresolved external linker error.
More...

#include <DS_OrderedList.h>

List of all members.

Public Member Functions

bool HasData (const key_type &key, int(*cf)(const key_type &, const data_type &)=default_comparison_function) const

Detailed Description

template<class key_type, class data_type, int(*)(const key_type &, const data_type &) default_comparison_function = defaultOrderedListComparison<key_type, data_type>>
class DataStructures::OrderedList< key_type, data_type, default_comparison_function >

Note:
IMPORTANT! If you use defaultOrderedListComparison then call IMPLEMENT_DEFAULT_COMPARISON or you will get an unresolved external linker error.

Member Function Documentation

template<class key_type, class data_type, int(*)(const key_type &, const data_type &) default_comparison_function>
bool DataStructures::OrderedList< key_type, data_type, default_comparison_function >::HasData | ( | const key_type & | key,
 |  | int(*)(const key_type &, const data_type &) | cf = default_comparison_function |
 | ) |  |  | const

comparisonFunction must take a key_type and a data_type and return <0, ==0, or >0 If the data type has comparison operators already defined then you can just use defaultComparison

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/DS_OrderedList.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Packet Struct Reference

Packet Struct Reference

This represents a user message from another system. More...

#include <RakNetTypes.h>

List of all members.

Public Attributes

SystemIndex | systemIndex
Server only - this is the index into the player array that this systemAddress maps to.
SystemAddress systemAddress
The system that send this packet.
unsigned int | length
BitSize_t | bitSize
The length of the data in bits.
unsigned char * | data
The data from the sender.

Detailed Description

This represents a user message from another system.

Member Data Documentation

unsigned int Packet::length

The length of the data in bytes

Deprecated:
You should use bitSize.

The documentation for this struct was generated from the following file:
  • C:/RakNet/Source/RakNetTypes.h
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: PacketConsoleLogger Class Reference

PacketConsoleLogger Class Reference
[PacketLogger]

Packetlogger that logs to a remote command console. More...

#include <PacketConsoleLogger.h>

Inheritance diagram for PacketConsoleLogger:

PacketLogger PluginInterface List of all members.

Public Member Functions

virtual void WriteLog (const char *str)
Override this to log strings to wherever. Log should be threadsafe.

Detailed Description

Packetlogger that logs to a remote command console.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/PacketConsoleLogger.h
  • C:/RakNet/Source/PacketConsoleLogger.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: PacketFileLogger Class Reference

PacketFileLogger Class Reference
[PacketLogger]

Packetlogger that outputs to a file. More...

#include <PacketFileLogger.h>

Inheritance diagram for PacketFileLogger:

PacketLogger PluginInterface List of all members.

Public Member Functions

virtual void WriteLog (const char *str)
Override this to log strings to wherever. Log should be threadsafe.

Detailed Description

Packetlogger that outputs to a file.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/PacketFileLogger.h
  • C:/RakNet/Source/PacketFileLogger.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: PacketLogger Class Reference

PacketLogger Class Reference
[PacketLogger]

Writes incoming and outgoing messages to the screen. This will write all incoming and outgoing messages to the console window, or to a file if you override it and give it this functionality. More...

#include <PacketLogger.h>

Inheritance diagram for PacketLogger:

PluginInterface PacketConsoleLogger PacketFileLogger ThreadsafePacketLogger List of all members.

Public Member Functions

virtual void | OnAttach (RakPeerInterface *peer)
virtual void | Update (RakPeerInterface *peer)
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
Events on low level sends and receives. These functions may be called from different threads at the same time.
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend)
virtual void | LogHeader (void)
Logs out a header for all the data.
virtual void | WriteLog (const char *str)
Override this to log strings to wherever. Log should be threadsafe.
virtual void | SetPrefix (const char *_prefix)
Prepend this string to output logs.
virtual void | SetSuffix (const char *_suffix)
Append this string to output logs. (newline is useful here).

Detailed Description

Writes incoming and outgoing messages to the screen. This will write all incoming and outgoing messages to the console window, or to a file if you override it and give it this functionality.

Member Function Documentation

void PacketLogger::OnAttach ( RakPeerInterface * peer ) [virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void PacketLogger::Update ( RakPeerInterface * peer ) [virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

Reimplemented in ThreadsafePacketLogger.

void PacketLogger::OnDirectSocketReceive | ( | const char * | data,
 |  | const BitSize_t | bitsUsed,
 |  | SystemAddress | remoteSystemAddress |
 | ) |  |  | [virtual]

Called on a receive from the socket, per datagram, that does not go through the reliability layer

Parameters:
[in] | data | The data being sent
[in] | bitsUsed | How many bits long data is
[in] | remoteSystemAddress | Which system this message is being sent to

Reimplemented from PluginInterface.

void PacketLogger::OnInternalPacket | ( | InternalPacket * | internalPacket,
 |  | unsigned | frameNumber,
 |  | SystemAddress | remoteSystemAddress,
 |  | RakNetTime | time,
 |  | bool | isSend |
 | ) |  |  | [virtual]

Called on a send or recieve within the reliability layer

Parameters:
[in] | internalPacket | The user message, along with all send data.
[in] | frameNumber | The number of frames sent or received so far for this player depending on isSend . Indicates the frame of this user message.
[in] | remoteSystemAddress | The player we sent or got this packet from
[in] | time | The current time as returned by RakNet::GetTime()
[in] | isSend | Is this callback representing a send event or receive event?

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/PacketLogger.h
  • C:/RakNet/Source/PacketLogger.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::Page< KeyType, DataType, order > Struct Template Reference

DataStructures::Page

DataStructures::Page< KeyType, DataType, order > Struct Template Reference

#include <DS_BPlusTree.h>

List of all members.

Detailed Description

template<class KeyType, class DataType, int order>
struct DataStructures::Page< KeyType, DataType, order >

Used in the BPlusTree. Used for both leaf and index nodes. Don't use a constructor or destructor, due to the memory pool I am using

The documentation for this struct was generated from the following file:
  • C:/RakNet/Source/DS_BPlusTree.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RankingServerDBSpec::PairedKeyDbId Struct Reference

RankingServerDBSpec::PairedKeyDbId

RankingServerDBSpec::PairedKeyDbId Struct Reference

#include <RankingServerDBSpec.h>

List of all members.

Detailed Description

Entities are represented in the database as integer pairs For example, primaryKey = 1234, secondaryKey = player Another example: primaryKey = Asteroids, secondaryKey = Cooperative mode

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: PluginInterface Class Reference

PluginInterface Class Reference
[PluginInterface]

PluginInterface provides a mechanism to add functionality in a modular way. MessageHandlers should derive from PluginInterface and be attached to RakPeer using the function AttachPlugin On a user call to Receive, OnReceive is called for every PluginInterface, which can then take action based on the message passed to it. This is used to transparently add game-independent functional modules, similar to browser plugins. More...

#include <PluginInterface.h>

Inheritance diagram for PluginInterface:

ConnectionGraph DirectoryDeltaTransfer FileListTransfer FullyConnectedMesh LightweightDatabaseClient LightweightDatabaseServer MessageFilter NatPunchthrough PacketLogger RakNet::AutoRPC RakNet::Lobby2::LobbyClientPC RakNet::LobbyClientPC RakNet::LobbyServer RakNet::ReplicaManager2 RakNet::RPC3 ReadyEvent ReplicaManager Router List of all members.

Public Member Functions

virtual void | OnAttach (RakPeerInterface *peer)
virtual void | OnDetach (RakPeerInterface *peer)
virtual void | OnStartup (RakPeerInterface *peer)
virtual void | Update (RakPeerInterface *peer)
virtual PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
virtual void | OnShutdown (RakPeerInterface *peer)
virtual void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend)

Detailed Description

PluginInterface provides a mechanism to add functionality in a modular way. MessageHandlers should derive from PluginInterface and be attached to RakPeer using the function AttachPlugin On a user call to Receive, OnReceive is called for every PluginInterface, which can then take action based on the message passed to it. This is used to transparently add game-independent functional modules, similar to browser plugins.

See also:
ReplicaManager

FullyConnectedMesh

PacketLogger

Member Function Documentation

void PluginInterface::OnAttach ( RakPeerInterface * peer ) [virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented in RakNet::AutoRPC, DirectoryDeltaTransfer, FileListTransfer, LightweightDatabaseClient, LightweightDatabaseServer, MessageFilter, NatPunchthrough, PacketLogger, ReadyEvent, ReplicaManager, RakNet::ReplicaManager2, Router, RakNet::LobbyClientPC, RakNet::LobbyServer, RakNet::Lobby2::LobbyClientPC, and RakNet::RPC3.

void PluginInterface::OnDetach ( RakPeerInterface * peer ) [virtual]

Called when the interface is detached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented in MessageFilter, and Router.

void PluginInterface::OnStartup ( RakPeerInterface * peer ) [virtual]

Called when RakPeer is initialized

Parameters:
[in] peer the instance of RakPeer that is calling Receive

void PluginInterface::Update ( RakPeerInterface * peer ) [virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented in ConnectionGraph, DirectoryDeltaTransfer, FileListTransfer, FullyConnectedMesh, LightweightDatabaseServer, MessageFilter, NatPunchthrough, PacketLogger, ReplicaManager, RakNet::ReplicaManager2, Router, ThreadsafePacketLogger, RakNet::LobbyServer, and RakNet::LobbyServerPostgreSQL.

PluginReceiveResult PluginInterface::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented in RakNet::AutoRPC, ConnectionGraph, DirectoryDeltaTransfer, FileListTransfer, FullyConnectedMesh, LightweightDatabaseClient, LightweightDatabaseServer, MessageFilter, NatPunchthrough, ReadyEvent, ReplicaManager, RakNet::ReplicaManager2, Router, RakNet::LobbyClientPC, RakNet::LobbyServer, RakNet::Lobby2::LobbyClientPC, and RakNet::RPC3.

void PluginInterface::OnShutdown ( RakPeerInterface * peer ) [virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented in RakNet::AutoRPC, ConnectionGraph, DirectoryDeltaTransfer, FileListTransfer, FullyConnectedMesh, LightweightDatabaseServer, MessageFilter, NatPunchthrough, ReadyEvent, ReplicaManager, RakNet::ReplicaManager2, Router, RakNet::LobbyClientPC, RakNet::LobbyServer, RakNet::Lobby2::LobbyClientPC, and RakNet::RPC3.

void PluginInterface::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented in RakNet::AutoRPC, ConnectionGraph, FileListTransfer, LightweightDatabaseServer, MessageFilter, NatPunchthrough, ReadyEvent, ReplicaManager, RakNet::ReplicaManager2, Router, RakNet::LobbyClientPC, RakNet::LobbyServer, RakNet::Lobby2::LobbyClientPC, and RakNet::RPC3.

void PluginInterface::OnDirectSocketSend | ( | const char * | data,
 |  | const BitSize_t | bitsUsed,
 |  | SystemAddress | remoteSystemAddress |
 | ) |  |  | [virtual]

Called on a send to the socket, per datagram, that does not go through the reliability layer

Parameters:
[in] | data | The data being sent
[in] | bitsUsed | How many bits long data is
[in] | remoteSystemAddress | Which system this message is being sent to

Reimplemented in PacketLogger.

void PluginInterface::OnDirectSocketReceive | ( | const char * | data,
 |  | const BitSize_t | bitsUsed,
 |  | SystemAddress | remoteSystemAddress |
 | ) |  |  | [virtual]

Called on a receive from the socket, per datagram, that does not go through the reliability layer

Parameters:
[in] | data | The data being sent
[in] | bitsUsed | How many bits long data is
[in] | remoteSystemAddress | Which system this message is being sent to

Reimplemented in PacketLogger.

void PluginInterface::OnInternalPacket | ( | InternalPacket * | internalPacket,
 |  | unsigned | frameNumber,
 |  | SystemAddress | remoteSystemAddress,
 |  | RakNetTime | time,
 |  | bool | isSend |
 | ) |  |  | [virtual]

Called on a send or recieve within the reliability layer

Parameters:
[in] | internalPacket | The user message, along with all send data.
[in] | frameNumber | The number of frames sent or received so far for this player depending on isSend . Indicates the frame of this user message.
[in] | remoteSystemAddress | The player we sent or got this packet from
[in] | time | The current time as returned by RakNet::GetTime()
[in] | isSend | Is this callback representing a send event or receive event?

Reimplemented in PacketLogger.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/PluginInterface.h
  • C:/RakNet/Source/PluginInterface.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::Queue< queue_type > Class Template Reference

DataStructures::Queue

DataStructures::Queue< queue_type > Class Template Reference

A queue implemented as an array with a read and write index. More...

#include <DS_Queue.h>

List of all members.

Detailed Description

template<class queue_type>
class DataStructures::Queue< queue_type >

A queue implemented as an array with a read and write index.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/DS_Queue.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::QueueLinkedList< QueueType > Class Template Reference

DataStructures::QueueLinkedList

DataStructures::QueueLinkedList< QueueType > Class Template Reference

A queue implemented using a linked list. Rarely used. More...

#include <DS_QueueLinkedList.h>

List of all members.

Detailed Description

template<class QueueType>
class DataStructures::QueueLinkedList< QueueType >

A queue implemented using a linked list. Rarely used.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/DS_QueueLinkedList.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNetCommandParser Class Reference

RakNetCommandParser Class Reference

This allows a console client to call most of the functions in RakPeer. More...

#include <RakNetCommandParser.h>

Inheritance diagram for RakNetCommandParser:

CommandParserInterface List of all members.

Public Member Functions

bool | OnCommand (const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, SystemAddress systemAddress, const char *originalString)
const char * | GetName (void) const
void | SendHelp (TransportInterface *transport, SystemAddress systemAddress)
void | SetRakPeerInterface (RakPeerInterface *rakPeer)

Protected Attributes

RakPeerInterface * peer
Which instance of RakPeer we are working on. Set from SetRakPeerInterface().

Detailed Description

This allows a console client to call most of the functions in RakPeer.

Member Function Documentation

bool RakNetCommandParser::OnCommand | ( | const char * | command,
 |  | unsigned | numParameters,
 |  | char ** | parameterList,
 |  | TransportInterface * | transport,
 |  | SystemAddress | systemAddress,
 |  | const char * | originalString |
 | ) |  |  | [virtual]

Given command with parameters parameterList , do whatever processing you wish.

Parameters:
[in] | command | The command to process
[in] | numParameters | How many parameters were passed along with the command
[in] | parameterList | The list of parameters. parameterList[0] is the first parameter and so on.
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that sent this command.
[in] | originalString | The string that was actually sent over the network, in case you want to do your own parsing

Implements CommandParserInterface.

const char * RakNetCommandParser::GetName ( void ) const [virtual]

You are responsible for overriding this function and returning a static string, which will identifier your parser. This should return a static string

Returns:
The name that you return.

Implements CommandParserInterface.

void RakNetCommandParser::SendHelp | ( | TransportInterface * | transport,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [virtual]

A callback for when you are expected to send a brief description of your parser to systemAddress

Parameters:
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that requested help.

Implements CommandParserInterface.

void RakNetCommandParser::SetRakPeerInterface ( RakPeerInterface * rakPeer )

Records the instance of RakPeer to perform the desired commands on

Parameters:
[in] rakPeer The RakPeer instance, or a derived class (e.g. RakPeer or RakPeer)

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/RakNetCommandParser.h
  • C:/RakNet/Source/RakNetCommandParser.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNetStatistics Struct Reference

RakNetStatistics Struct Reference

Network Statisics Usage. More...

#include <RakNetStatistics.h>

List of all members.

Public Attributes

unsigned | messageSendBuffer [NUMBER_OF_PRIORITIES]
Number of Messages in the send Buffer (high, medium, low priority).
unsigned | messagesSent [NUMBER_OF_PRIORITIES]
Number of messages sent (high, medium, low priority).
uint64_t | messageDataBitsSent [NUMBER_OF_PRIORITIES]
Number of data bits used for user messages.
uint64_t | messageTotalBitsSent [NUMBER_OF_PRIORITIES]
Number of total bits used for user messages, including headers.
unsigned | packetsContainingOnlyAcknowlegements
Number of packets sent containing only acknowledgements.
unsigned | acknowlegementsSent
Number of acknowledgements sent.
unsigned | acknowlegementsPending
Number of acknowledgements waiting to be sent.
uint64_t | acknowlegementBitsSent
Number of acknowledgements bits sent.
unsigned | packetsContainingOnlyAcknowlegementsAndResends
Number of packets containing only acknowledgements and resends.
unsigned | messageResends
Number of messages resent.
uint64_t | messageDataBitsResent
Number of bits resent of actual data.
uint64_t | messagesTotalBitsResent
Total number of bits resent, including headers.
unsigned | messagesOnResendQueue
Number of messages waiting for ack (// TODO - rename this).
unsigned | numberOfUnsplitMessages
Number of messages not split for sending.
unsigned | numberOfSplitMessages
Number of messages split for sending.
unsigned | totalSplits
Total number of splits done for sending.
unsigned | packetsSent
Total packets sent.
uint64_t | encryptionBitsSent
Number of bits added by encryption.
uint64_t | totalBitsSent
total bits sent
unsigned | sequencedMessagesOutOfOrder
Number of sequenced messages arrived out of order.
unsigned | sequencedMessagesInOrder
Number of sequenced messages arrived in order.
unsigned | orderedMessagesOutOfOrder
Number of ordered messages arrived out of order.
unsigned | orderedMessagesInOrder
Number of ordered messages arrived in order.
unsigned | packetsReceived
Packets with a good CRC received.
unsigned | packetsWithBadCRCReceived
Packets with a bad CRC received.
uint64_t | bitsReceived
Bits with a good CRC received.
uint64_t | bitsWithBadCRCReceived
Bits with a bad CRC received.
unsigned | acknowlegementsReceived
Number of acknowledgement messages received for packets we are resending.
unsigned | duplicateAcknowlegementsReceived
Number of acknowledgement messages received for packets we are not resending.
unsigned | messagesReceived
Number of data messages (anything other than an ack) received that are valid and not duplicate.
unsigned | invalidMessagesReceived
Number of data messages (anything other than an ack) received that are invalid.
unsigned | duplicateMessagesReceived
Number of data messages (anything other than an ack) received that are duplicate.
unsigned | messagesWaitingForReassembly
Number of messages waiting for reassembly.
unsigned | internalOutputQueueSize
Number of messages in reliability output queue.
double | bitsPerSecond
Current bits per second.
RakNetTime | connectionStartTime
connection start time

Detailed Description

Network Statisics Usage.

Store Statistics information related to network usage

The documentation for this struct was generated from the following file:
  • C:/RakNet/Source/RakNetStatistics.h
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNetTransport Class Reference

RakNetTransport Class Reference

Use RakNetTransport if you need a secure connection between the client and the console server. RakNetTransport automatically initializes security for the system. Use the project CommandConsoleClient to connect To the ConsoleServer if you use RakNetTransport. More...

#include <RakNetTransport.h>

Inheritance diagram for RakNetTransport:

TransportInterface List of all members.

Public Member Functions

bool | Start (unsigned short port, bool serverMode)
void | Stop (void)
Stop the transport provider. You can clear memory and shutdown threads here.
void | Send (SystemAddress systemAddress, const char *data,...)
Packet * | Receive (void)
void | DeallocatePacket (Packet *packet)
void | CloseConnection (SystemAddress systemAddress)
SystemAddress | HasNewConnection (void)
SystemAddress | HasLostConnection (void)
void | SetIncomingPassword (const char *password)
char * | GetIncomingPassword (void)
CommandParserInterface * | GetCommandParser (void)
Returns RakNetTransportCommandParser so the console admin can change the password.

Detailed Description

Use RakNetTransport if you need a secure connection between the client and the console server. RakNetTransport automatically initializes security for the system. Use the project CommandConsoleClient to connect To the ConsoleServer if you use RakNetTransport.

Member Function Documentation

bool RakNetTransport::Start | ( | unsigned short | port,
 |  | bool | serverMode |
 | ) |  |  | [virtual]

Start the transport provider on the indicated port.

Parameters:
[in] | port | The port to start the transport provider on
[in] | serverMode | If true, you should allow incoming connections (I don't actually use this anywhere)
Returns:
Return true on success, false on failure.

Implements TransportInterface.

void RakNetTransport::Send | ( | SystemAddress | systemAddress,
 |  | const char * | data,
 |  |  | ... |
 | ) |  |  | [virtual]

Send a null-terminated string to systemAddress If your transport method requires particular formatting of the outgoing data (e.g. you don't just send strings) you can do it here and parse it out in Receive().

Parameters:
[in] | systemAddress | The player to send the string to
[in] | data | format specifier - same as printf
[in] ... format specification arguments - same as printf

Implements TransportInterface.

Packet * RakNetTransport::Receive ( void ) [virtual]

Return a string. The string should be allocated and written to Packet::data . The byte length should be written to Packet::length . The player/address should be written to Packet::systemAddress If your transport protocol adds special formatting to the data stream you should parse it out before returning it in the packet and thus only return a string in Packet::data

Returns:
The packet structure containing the result of Receive, or 0 if no data is available

Implements TransportInterface.

void RakNetTransport::DeallocatePacket ( Packet * packet ) [virtual]

Deallocate the Packet structure returned by Receive

Parameters:
[in] The packet to deallocate

Implements TransportInterface.

void RakNetTransport::CloseConnection ( SystemAddress systemAddress ) [virtual]

Disconnect systemAddress . The binary address and port defines the SystemAddress structure.

Parameters:
[in] systemAddress The player/address to disconnect

Implements TransportInterface.

SystemAddress RakNetTransport::HasNewConnection ( void ) [virtual]

If a new system connects to you, you should queue that event and return the systemAddress/address of that player in this function.

Returns:
The SystemAddress/address of the system

Implements TransportInterface.

SystemAddress RakNetTransport::HasLostConnection ( void ) [virtual]

If a system loses the connection, you should queue that event and return the systemAddress/address of that player in this function.

Returns:
The SystemAddress/address of the system

Implements TransportInterface.

void RakNetTransport::SetIncomingPassword ( const char * password )

Sets the password which incoming connections must match. While not required, it is highly recommended you set this in a real game environment or anyone can login and control your server. Don't set it to a fixed value, but instead require that the server admin sets it when you start the application server

Parameters:
[in] password Null-terminated string to use as a password.

char * RakNetTransport::GetIncomingPassword ( void )

Returns the password set by SetIncomingPassword().

Returns:
The password set by SetIncomingPassword()

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/RakNetTransport.h
  • C:/RakNet/Source/RakNetTransport.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNetTransportCommandParser Class Reference

RakNetTransportCommandParser Class Reference

RakNetTransport has its own command parser to enable remote users to change the command console's password. More...

#include <RakNetTransport.h>

Inheritance diagram for RakNetTransportCommandParser:

CommandParserInterface List of all members.

Public Member Functions

bool | OnCommand (const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, SystemAddress systemAddress, const char *originalString)
const char * | GetName (void) const
void | SendHelp (TransportInterface *transport, SystemAddress systemAddress)

Detailed Description

RakNetTransport has its own command parser to enable remote users to change the command console's password.

Member Function Documentation

bool RakNetTransportCommandParser::OnCommand | ( | const char * | command,
 |  | unsigned | numParameters,
 |  | char ** | parameterList,
 |  | TransportInterface * | transport,
 |  | SystemAddress | systemAddress,
 |  | const char * | originalString |
 | ) |  |  | [virtual]

Given command with parameters parameterList , do whatever processing you wish.

Parameters:
[in] | command | The command to process
[in] | numParameters | How many parameters were passed along with the command
[in] | parameterList | The list of parameters. parameterList[0] is the first parameter and so on.
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that sent this command.
[in] | originalString | The string that was actually sent over the network, in case you want to do your own parsing

Implements CommandParserInterface.

const char * RakNetTransportCommandParser::GetName ( void ) const [virtual]

You are responsible for overriding this function and returning a static string, which will identifier your parser. This should return a static string

Returns:
The name that you return.

Implements CommandParserInterface.

void RakNetTransportCommandParser::SendHelp | ( | TransportInterface * | transport,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [virtual]

A callback for when you are expected to send a brief description of your parser to systemAddress

Parameters:
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that requested help.

Implements CommandParserInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/RakNetTransport.h
  • C:/RakNet/Source/RakNetTransport.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakPeer Class Reference

RakPeer Class Reference

The main interface for network communications. More...

#include <RakPeer.h>

Inheritance diagram for RakPeer:

RakPeerInterface List of all members.

Public Member Functions

RakPeer ()
Constructor.
virtual | ~RakPeer ()
Destructor.
bool | Startup (unsigned short maxConnections, int _threadSleepTimer, SocketDescriptor *socketDescriptors, unsigned socketDescriptorCount)
Starts the network threads, opens the listen port. You must call this before calling Connect(). Multiple calls while already active are ignored. To call this function again with different settings, you must first call Shutdown().
void | InitializeSecurity (const char *pubKeyE, const char *pubKeyN, const char *privKeyP, const char *privKeyQ)
void | DisableSecurity (void)
void | AddToSecurityExceptionList (const char *ip)
void | RemoveFromSecurityExceptionList (const char *ip)
bool | IsInSecurityExceptionList (const char *ip)
void | SetMaximumIncomingConnections (unsigned short numberAllowed)
unsigned short | GetMaximumIncomingConnections (void) const
unsigned short | NumberOfConnections (void) const
void | SetIncomingPassword (const char *passwordData, int passwordDataLength)
void | GetIncomingPassword (char *passwordData, int *passwordDataLength)
bool | Connect (const char *host, unsigned short remotePort, const char *passwordData, int passwordDataLength, unsigned connectionSocketIndex=0)
Connect to the specified host (ip or domain name) and server port. Calling Connect and not calling SetMaximumIncomingConnections acts as a dedicated client. Calling both acts as a true peer. This is a non-blocking connection. You know the connection is successful when IsConnected() returns true or Receive() gets a message with the type identifier ID_CONNECTION_ACCEPTED. If the connection is not successful, such as a rejected connection or no response then neither of these things will happen.
void | Shutdown (unsigned int blockDuration, unsigned char orderingChannel=0)
Connect to the specified network ID (Platform specific console function) Does built-in NAT traversal Stops the network threads and closes all connections.
bool | IsActive (void) const
bool | GetConnectionList (SystemAddress *remoteSystems, unsigned short *numberOfSystems) const
bool | Send (const char *data, const int length, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast)
bool | Send (const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast)
bool | SendList (char **data, const int *lengths, const int numParameters, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast)
Packet * | Receive (void)
void | DeallocatePacket (Packet *packet)
unsigned short | GetMaximumNumberOfPeers (void) const
Return the total number of connections we are allowed.
void | RegisterAsRemoteProcedureCall (const char *uniqueID, void(*functionPointer)(RPCParameters *rpcParms))
void | RegisterClassMemberRPC (const char *uniqueID, void *functionPointer)
void | UnregisterAsRemoteProcedureCall (const char *uniqueID)
void | SetNetworkIDManager (NetworkIDManager *manager)
NetworkIDManager * | GetNetworkIDManager (void) const
Returns:
Returns the value passed to SetNetworkIDManager or 0 if never called.

bool | RPC (const char *uniqueID, const char *data, BitSize_t bitLength, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, RakNetTime *includedTimestamp, NetworkID networkID, RakNet::BitStream *replyFromTarget)
bool | RPC (const char *uniqueID, const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, RakNetTime *includedTimestamp, NetworkID networkID, RakNet::BitStream *replyFromTarget)
void | CloseConnection (const SystemAddress target, bool sendDisconnectionNotification, unsigned char orderingChannel=0)
bool | IsConnected (const SystemAddress systemAddress, bool includeInProgress=false, bool includeDisconnecting=false)
int | GetIndexFromSystemAddress (const SystemAddress systemAddress)
SystemAddress | GetSystemAddressFromIndex (int index)
void | AddToBanList (const char *IP, RakNetTime milliseconds=0)
void | RemoveFromBanList (const char *IP)
void | ClearBanList (void)
Allows all previously banned IPs to connect.
bool | IsBanned (const char *IP)
void | Ping (const SystemAddress target)
void | Ping (const char *host, unsigned short remotePort, bool onlyReplyOnAcceptingConnections, unsigned connectionSocketIndex=0)
int | GetAveragePing (const SystemAddress systemAddress)
int | GetLastPing (const SystemAddress systemAddress) const
int | GetLowestPing (const SystemAddress systemAddress) const
void | SetOccasionalPing (bool doPing)
void | SetOfflinePingResponse (const char *data, const unsigned int length)
void | GetOfflinePingResponse (char **data, unsigned int *length)
SystemAddress | GetInternalID (const SystemAddress systemAddress=UNASSIGNED_SYSTEM_ADDRESS) const
SystemAddress | GetExternalID (const SystemAddress target) const
void | SetTimeoutTime (RakNetTime timeMS, const SystemAddress target)
Parameters:
[in] target Which system to do this for. Pass UNASSIGNED_SYSTEM_ADDRESS for all systems.

bool | SetMTUSize (int size)
int | GetMTUSize (const SystemAddress target) const
unsigned | GetNumberOfAddresses (void)
Returns the number of IP addresses this system has internally. Get the actual addresses from GetLocalIP().
const char * | GetLocalIP (unsigned int index)
bool | IsLocalIP (const char *ip)
void | AllowConnectionResponseIPMigration (bool allow)
bool | AdvertiseSystem (const char *host, unsigned short remotePort, const char *data, int dataLength, unsigned connectionSocketIndex=0)
void | SetSplitMessageProgressInterval (int interval)
void | SetUnreliableTimeout (RakNetTime timeoutMS)
void | SendTTL (const char *host, unsigned short remotePort, int ttl, unsigned connectionSocketIndex=0)
void | SetCompileFrequencyTable (bool doCompile)
bool | GetOutgoingFrequencyTable (unsigned int outputFrequencyTable[256])
bool | GenerateCompressionLayer (unsigned int inputFrequencyTable[256], bool inputLayer)
bool | DeleteCompressionLayer (bool inputLayer)
float | GetCompressionRatio (void) const
float | GetDecompressionRatio (void) const
void | AttachPlugin (PluginInterface *plugin)
void | DetachPlugin (PluginInterface *messageHandler)
void | PushBackPacket (Packet *packet, bool pushAtHead)
void | SetRouterInterface (RouterInterface *routerInterface)

For internal use only.

void | RemoveRouterInterface (RouterInterface *routerInterface)

For internal use only.

Packet * | AllocatePacket (unsigned dataSize)
void | ApplyNetworkSimulator (double maxSendBPS, unsigned short minExtraPing, unsigned short extraPingVariance)
void | SetPerConnectionOutgoingBandwidthLimit (unsigned maxBitsPerSecond)
bool | IsNetworkSimulatorActive (void)
RakNetStatistics *const | GetStatistics (const SystemAddress systemAddress)

Protected Member Functions

RemoteSystemStruct * | GetRemoteSystemFromSystemAddress (const SystemAddress systemAddress, bool calledFromNetworkThread, bool onlyActive) const
void | ParseConnectionRequestPacket (RakPeer::RemoteSystemStruct *remoteSystem, SystemAddress systemAddress, const char *data, int byteSize)
Parse out a connection request packet.
void | OnConnectionRequest (RakPeer::RemoteSystemStruct *remoteSystem, unsigned char *AESKey, bool setAESKey)
When we get a connection request from an ip / port, accept it unless full.
void | NotifyAndFlagForShutdown (const SystemAddress systemAddress, bool performImmediate, unsigned char orderingChannel)
Send a reliable disconnect packet to this player and disconnect them when it is delivered.
unsigned short | GetNumberOfRemoteInitiatedConnections (void) const
Returns how many remote systems initiated a connection to us.
RemoteSystemStruct * | AssignSystemAddressToRemoteSystemList (const SystemAddress systemAddress, RemoteSystemStruct::ConnectMode connectionMode, unsigned connectionSocketIndex)
Get a free remote system from the list and assign our systemAddress to it. Should only be called from the update thread - not the user thread.
void | ShiftIncomingTimestamp (unsigned char *data, SystemAddress systemAddress) const
An incoming packet has a timestamp, so adjust it to be relative to this system.
RakNetTime | GetBestClockDifferential (const SystemAddress systemAddress) const
Get the most probably accurate clock differential for a certain player.
bool | HandleRPCPacket (const char *data, int length, SystemAddress systemAddress)
void | HandleRPCReplyPacket (const char *data, int length, SystemAddress systemAddress)

Protected Attributes

volatile bool | endThreads
Set this to true to terminate the Peer thread execution.
volatile bool | isMainLoopThreadActive
true if the peer thread is active.
*unsigned short | maximumNumberOfPeers
Store the maximum number of peers allowed to connect.
unsigned short | maximumIncomingConnections
Store the maximum incoming connection allowed.
SystemAddress mySystemAddress
Local Player ID.
RemoteSystemStruct * | remoteSystemList
bool | updateCycleIsRunning
RunUpdateCycle is not thread safe but we don't need to mutex calls. Just skip calls if it is running already.
unsigned int | bytesSentPerSecond
Data that both the client and the server needs.
unsigned int | frequencyTable [256]
Compression stuff.
big::RSACrypt< RSA_BIT_SIZE > | rsacrypt
Encryption and security.
bool | allowConnectionResponseIPMigration
True to allow connection accepted packets from anyone. False to only allow these packets from servers we requested a connection to.

Classes

struct | MemoryBlock
Automatic Variable Synchronization Mechanism automatic variable synchronization takes a primary and secondary identifier The unique primary identifier is the index into the automaticVariableSynchronizationList The unique secondary identifier (UNASSIGNED_NETWORK_ID for none) is in an unsorted list of memory blocks. More...

Detailed Description

The main interface for network communications.

The primary interface for RakNet, RakPeer contains all major functions for the library. See the individual functions for what the class can do.

Member Function Documentation

bool RakPeer::Startup | ( | unsigned short | maxConnections,
 |  | int | _threadSleepTimer,
 |  | SocketDescriptor * | socketDescriptors,
 |  | unsigned | socketDescriptorCount |
 | ) |  |  | [virtual]

Starts the network threads, opens the listen port. You must call this before calling Connect(). Multiple calls while already active are ignored. To call this function again with different settings, you must first call Shutdown().

Note:
Call SetMaximumIncomingConnections if you want to accept incoming connections

Set _RAKNET_THREADSAFE in RakNetDefines.h if you want to call RakNet functions from multiple threads (not recommended, as it is much slower and RakNet is already asynchronous).

Parameters:
[in] | maxConnections | The maximum number of connections between this instance of RakPeer and another instance of RakPeer. Required so the network can preallocate and for thread safety. A pure client would set this to 1. A pure server would set it to the number of allowed clients.- A hybrid would set it to the sum of both types of connections
[in] | localPort | The port to listen for connections on.
[in] | _threadSleepTimer | How many ms to Sleep each internal update cycle (30 to give the game priority, 0 for regular (recommended)
[in] | socketDescriptors | An array of SocketDescriptor structures to force RakNet to listen on a particular IP address or port (or both). Each SocketDescriptor will represent one unique socket. Do not pass redundant structures. To listen on a specific port, you can pass SocketDescriptor(myPort,0); such as for a server. For a client, it is usually OK to just pass SocketDescriptor();
[in] | socketDescriptorCount | The size of the socketDescriptors array. Pass 1 if you are not sure what to pass.
Returns:
False on failure (can't create socket or thread), true on success.

Implements RakPeerInterface.

void RakPeer::InitializeSecurity | ( | const char * | pubKeyE,
 |  | const char * | pubKeyN,
 |  | const char * | privKeyP,
 |  | const char * | privKeyQ |
 | ) |  |  | [virtual]

Secures connections though a combination of SHA1, AES128, SYN Cookies, and RSA to prevent connection spoofing, replay attacks, data eavesdropping, packet tampering, and MitM attacks. There is a significant amount of processing and a slight amount of bandwidth overhead for this feature. If you accept connections, you must call this or else secure connections will not be enabled for incoming connections. If you are connecting to another system, you can call this with values for the (e and p,q) public keys before connecting to prevent MitM

Precondition:
Must be called before Initialize
Parameters:
[in] | pubKeyE | A pointer to the public keys from the RSACrypt class.
[in] | pubKeyN | A pointer to the public keys from the RSACrypt class.
[in] | privKeyP | Public key generated from the RSACrypt class.
[in] | privKeyQ | Public key generated from the RSACrypt class. If the private keys are 0, then a new key will be generated when this function is called
See also:
the Encryption sample

Implements RakPeerInterface.

void RakPeer::DisableSecurity ( void ) [virtual]

Disables all security.

Note:
Must be called while offline

Implements RakPeerInterface.

void RakPeer::AddToSecurityExceptionList ( const char * ip ) [virtual]

If secure connections are on, do not use secure connections for a specific IP address. This is useful if you have a fixed-address internal server behind a LAN.

Note:
Secure connections are determined by the recipient of an incoming connection. This has no effect if called on the system attempting to connect.
Parameters:
[in] ip IP address to add. * wildcards are supported.

Implements RakPeerInterface.

void RakPeer::RemoveFromSecurityExceptionList ( const char * ip ) [virtual]

Remove a specific connection previously added via AddToSecurityExceptionList

Parameters:
[in] ip IP address to remove. Pass 0 to remove all IP addresses. * wildcards are supported.

Implements RakPeerInterface.

bool RakPeer::IsInSecurityExceptionList ( const char * ip ) [virtual]

Checks to see if a given IP is in the security exception list

Parameters:
[in] IP address to check.

Implements RakPeerInterface.

void RakPeer::SetMaximumIncomingConnections ( unsigned short numberAllowed ) [virtual]

Sets how many incoming connections are allowed. If this is less than the number of players currently connected, no more players will be allowed to connect. If this is greater than the maximum number of peers allowed, it will be reduced to the maximum number of peers allowed. Defaults to 0, meaning by default, nobody can connect to you

Parameters:
[in] numberAllowed Maximum number of incoming connections allowed.

Implements RakPeerInterface.

unsigned short RakPeer::GetMaximumIncomingConnections ( void ) const [virtual]

Returns the value passed to SetMaximumIncomingConnections()

Returns:
the maximum number of incoming connections, which is always <= maxConnections

Implements RakPeerInterface.

unsigned short RakPeer::NumberOfConnections ( void ) const [virtual]

Returns how many open connections there are at this time

Returns:
the number of open connections

Implements RakPeerInterface.

void RakPeer::SetIncomingPassword | ( | const char * | passwordData,
 |  | int | passwordDataLength |
 | ) |  |  | [virtual]

Sets the password incoming connections must match in the call to Connect (defaults to none). Pass 0 to passwordData to specify no password This is a way to set a low level password for all incoming connections. To selectively reject connections, implement your own scheme using CloseConnection() to remove unwanted connections

Parameters:
[in] | passwordData | A data block that incoming connections must match. This can be just a password, or can be a stream of data. Specify 0 for no password data
[in] | passwordDataLength | The length in bytes of passwordData

Implements RakPeerInterface.

void RakPeer::GetIncomingPassword | ( | char * | passwordData,
 |  | int * | passwordDataLength |
 | ) |  |  | [virtual]

Gets the password passed to SetIncomingPassword

Parameters:
[out] | passwordData | Should point to a block large enough to hold the password data you passed to SetIncomingPassword()
[in,out] | passwordDataLength | Maximum size of the array passwordData. Modified to hold the number of bytes actually written

Implements RakPeerInterface.

bool RakPeer::Connect | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | const char * | passwordData,
 |  | int | passwordDataLength,
 |  | unsigned | connectionSocketIndex = 0 |
 | ) |  |  | [virtual]

Connect to the specified host (ip or domain name) and server port. Calling Connect and not calling SetMaximumIncomingConnections acts as a dedicated client. Calling both acts as a true peer. This is a non-blocking connection. You know the connection is successful when IsConnected() returns true or Receive() gets a message with the type identifier ID_CONNECTION_ACCEPTED. If the connection is not successful, such as a rejected connection or no response then neither of these things will happen.

Precondition:
Requires that you first call Initialize
Parameters:
[in] | host | Either a dotted IP address or a domain name
[in] | remotePort | Which port to connect to on the remote machine.
[in] | passwordData | A data block that must match the data block on the server passed to SetIncomingPassword. This can be a string or can be a stream of data. Use 0 for no password.
[in] | passwordDataLength | The length in bytes of passwordData
[in] | connectionSocketIndex | Index into the array of socket descriptors passed to socketDescriptors in RakPeer::Startup() to send on.
Returns:
True on successful initiation. False on incorrect parameters, internal error, or too many existing peers. Returning true does not mean you connected!

Implements RakPeerInterface.

void RakPeer::Shutdown | ( | unsigned int | blockDuration,
 |  | unsigned char | orderingChannel = 0 |
 | ) |  |  | [virtual]

Connect to the specified network ID (Platform specific console function) Does built-in NAT traversal Stops the network threads and closes all connections.

Parameters:
[in] | blockDuration | How long, in milliseconds, you should wait for all remaining messages to go out, including ID_DISCONNECTION_NOTIFICATION. If 0, it doesn't wait at all.
[in] | orderingChannel | If blockDuration > 0, ID_DISCONNECTION_NOTIFICATION will be sent on this channel If you set it to 0 then the disconnection notification won't be sent

Implements RakPeerInterface.

bool RakPeer::IsActive ( void ) const [inline, virtual]

Returns if the network thread is running

Returns:
true if the network thread is running, false otherwise

Implements RakPeerInterface.

bool RakPeer::GetConnectionList | ( | SystemAddress * | remoteSystems,
 |  | unsigned short * | numberOfSystems |
 | ) |  |  | const [virtual]

Fills the array remoteSystems with the SystemAddress of all the systems we are connected to

Parameters:
[out] | remoteSystems | An array of SystemAddress structures to be filled with the SystemAddresss of the systems we are connected to. Pass 0 to remoteSystems to only get the number of systems we are connected to
[in,out] | numberOfSystems | As input, the size of remoteSystems array. As output, the number of elements put into the array

Implements RakPeerInterface.

bool RakPeer::Send | ( | const char * | data,
 |  | const int | length,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast |
 | ) |  |  | [virtual]

Sends a block of data to the specified system that you are connected to. This function only works while the connected The first byte should be a message identifier starting at ID_USER_PACKET_ENUM

Parameters:
[in] | data | The block of data to send
[in] | length | The size in bytes of the data to send
[in] | priority | What priority level to send on. See PacketPriority.h
[in] | reliability | How reliability to send this data. See PacketPriority.h
[in] | orderingChannel | When using ordered or sequenced messages, what channel to order these on. Messages are only ordered relative to other messages on the same stream
[in] | systemAddress | Who to send this packet to, or in the case of broadcasting who not to send it to. Use UNASSIGNED_SYSTEM_ADDRESS to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
Returns:
False if we are not connected to the specified recipient. True otherwise

Implements RakPeerInterface.

bool RakPeer::Send | ( | const RakNet::BitStream * | bitStream,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast |
 | ) |  |  | [virtual]

Sends a block of data to the specified system that you are connected to. Same as the above version, but takes a BitStream as input.

Parameters:
[in] | bitStream | The bitstream to send
[in] | priority | What priority level to send on. See PacketPriority.h
[in] | reliability | How reliability to send this data. See PacketPriority.h
[in] | orderingChannel | When using ordered or sequenced messages, what channel to order these on. Messages are only ordered relative to other messages on the same stream
[in] | systemAddress | Who to send this packet to, or in the case of broadcasting who not to send it to. Use UNASSIGNED_SYSTEM_ADDRESS to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
Returns:
False if we are not connected to the specified recipient. True otherwise
Note:
COMMON MISTAKE: When writing the first byte, bitStream->Write((unsigned char) ID_MY_TYPE) be sure it is casted to a byte, and you are not writing a 4 byte enumeration.

Implements RakPeerInterface.

bool RakPeer::SendList | ( | char ** | data,
 |  | const int * | lengths,
 |  | const int | numParameters,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast |
 | ) |  |  | [virtual]

Sends multiple blocks of data, concatenating them automatically.

This is equivalent to: RakNet::BitStream bs; bs.WriteAlignedBytes(block1, blockLength1); bs.WriteAlignedBytes(block2, blockLength2); bs.WriteAlignedBytes(block3, blockLength3); Send(&bs, ...)

This function only works while the connected

Parameters:
[in] | data | An array of pointers to blocks of data
[in] | lengths | An array of integers indicating the length of each block of data
[in] | numParameters | Length of the arrays data and lengths
[in] | priority | What priority level to send on. See PacketPriority.h
[in] | reliability | How reliability to send this data. See PacketPriority.h
[in] | orderingChannel | When using ordered or sequenced messages, what channel to order these on. Messages are only ordered relative to other messages on the same stream
[in] | systemAddress | Who to send this packet to, or in the case of broadcasting who not to send it to. Use UNASSIGNED_SYSTEM_ADDRESS to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
Returns:
False if we are not connected to the specified recipient. True otherwise
Note:
Doesn't support the router plugin

Implements RakPeerInterface.

Packet * RakPeer::Receive ( void ) [virtual]

Gets a message from the incoming message queue. Use DeallocatePacket() to deallocate the message after you are done with it. User-thread functions, such as RPC calls and the plugin function PluginInterface::Update occur here.

Returns:
0 if no packets are waiting to be handled, otherwise a pointer to a packet.
Note:
COMMON MISTAKE: Be sure to call this in a loop, once per game tick, until it returns 0. If you only process one packet per game tick they will buffer up. sa RakNetTypes.h contains struct Packet

Implements RakPeerInterface.

void RakPeer::DeallocatePacket ( Packet * packet ) [virtual]

Call this to deallocate a message returned by Receive() when you are done handling it.

Parameters:
[in] packet The message to deallocate.

Implements RakPeerInterface.

void RakPeer::CloseConnection | ( | const SystemAddress | target,
 |  | bool | sendDisconnectionNotification,
 |  | unsigned char | orderingChannel = 0 |
 | ) |  |  | [virtual]

Close the connection to another host (if we initiated the connection it will disconnect, if they did it will kick them out).

Parameters:
[in] | target | Which system to close the connection to.
[in] | sendDisconnectionNotification | True to send ID_DISCONNECTION_NOTIFICATION to the recipient. False to close it silently.
[in] | channel | Which ordering channel to send the disconnection notification on, if any

Implements RakPeerInterface.

bool RakPeer::IsConnected | ( | const SystemAddress | systemAddress,
 |  | bool | includeInProgress = false,
 |  | bool | includeDisconnecting = false |
 | ) |  |  | [virtual]

Returns if a particular systemAddress is connected to us (this also returns true if we are in the process of connecting)

Parameters:
[in] | systemAddress | The SystemAddress we are referring to
[in] | includeInProgress | If true, also return true for connections that are in progress but haven't completed
[in] | includeDisconnecting | If true, also return true for connections that are in the process of disconnecting
Returns:
True if this system is connected and active, false otherwise.

Implements RakPeerInterface.

int RakPeer::GetIndexFromSystemAddress ( const SystemAddress systemAddress ) [virtual]

Given a systemAddress, returns an index from 0 to the maximum number of players allowed - 1. This includes systems which were formerly connected, but are not now connected

Parameters:
[in] systemAddress The SystemAddress we are referring to
Returns:
The index of this SystemAddress or -1 on system not found.

Implements RakPeerInterface.

SystemAddress RakPeer::GetSystemAddressFromIndex ( int index ) [virtual]

This function is only useful for looping through all systems Given an index, will return a SystemAddress.

Parameters:
[in] index Index should range between 0 and the maximum number of players allowed - 1.
Returns:
The SystemAddress

Implements RakPeerInterface.

void RakPeer::AddToBanList | ( | const char * | IP,
 |  | RakNetTime | milliseconds = 0 |
 | ) |  |  | [virtual]

Bans an IP from connecting. Banned IPs persist between connections but are not saved on shutdown nor loaded on startup. param[in] IP Dotted IP address. Can use * as a wildcard, such as 128.0.0.* will ban all IP addresses starting with 128.0.0

Parameters:
[in] milliseconds how many ms for a temporary ban. Use 0 for a permanent ban

Implements RakPeerInterface.

void RakPeer::RemoveFromBanList ( const char * IP ) [virtual]

Allows a previously banned IP to connect. param[in] Dotted IP address. Can use * as a wildcard, such as 128.0.0.* will banAll IP addresses starting with 128.0.0

Implements RakPeerInterface.

bool RakPeer::IsBanned ( const char * IP ) [virtual]

Returns true or false indicating if a particular IP is banned.

Parameters:
[in] IP - Dotted IP address.
Returns:
true if IP matches any IPs in the ban list, accounting for any wildcards. False otherwise.

Implements RakPeerInterface.

void RakPeer::Ping ( const SystemAddress target ) [virtual]

Send a ping to the specified connected system.

Precondition:
The sender and recipient must already be started via a successful call to Startup()
Parameters:
[in] target Which system to ping

Implements RakPeerInterface.

void RakPeer::Ping | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | bool | onlyReplyOnAcceptingConnections,
 |  | unsigned | connectionSocketIndex = 0 |
 | ) |  |  | [virtual]

Send a ping to the specified unconnected system. The remote system, if it is Initialized, will respond with ID_PONG followed by sizeof(RakNetTime) containing the system time the ping was sent.(Default is 4 bytes - See __GET_TIME_64BIT in RakNetTypes.h

Parameters:
[in] | host | Either a dotted IP address or a domain name. Can be 255.255.255.255 for LAN broadcast.
[in] | remotePort | Which port to connect to on the remote machine.
[in] | onlyReplyOnAcceptingConnections | Only request a reply if the remote system is accepting connections
[in] | connectionSocketIndex | Index into the array of socket descriptors passed to socketDescriptors in RakPeer::Startup() to send on.

Implements RakPeerInterface.

int RakPeer::GetAveragePing ( const SystemAddress systemAddress ) [virtual]

Returns the average of all ping times read for the specific system or -1 if none read yet

Parameters:
[in] systemAddress Which system we are referring to
Returns:
The ping time for this system, or -1

Implements RakPeerInterface.

int RakPeer::GetLastPing ( const SystemAddress systemAddress ) const [virtual]

Returns the last ping time read for the specific system or -1 if none read yet

Parameters:
[in] systemAddress Which system we are referring to
Returns:
The last ping time for this system, or -1

Implements RakPeerInterface.

int RakPeer::GetLowestPing ( const SystemAddress systemAddress ) const [virtual]

Returns the lowest ping time read or -1 if none read yet

Parameters:
[in] systemAddress Which system we are referring to
Returns:
The lowest ping time for this system, or -1

Implements RakPeerInterface.

void RakPeer::SetOccasionalPing ( bool doPing ) [virtual]

Ping the remote systems every so often, or not. This is off by default. Can be called anytime.

Parameters:
[in] doPing True to start occasional pings. False to stop them.

Implements RakPeerInterface.

void RakPeer::SetOfflinePingResponse | ( | const char * | data,
 |  | const unsigned int | length |
 | ) |  |  | [virtual]

Sets the data to send along with a LAN server discovery or offline ping reply. length should be under 400 bytes, as a security measure against flood attacks

Parameters:
[in] | data | a block of data to store, or 0 for none
[in] | length | The length of data in bytes, or 0 for none
See also:
Ping.cpp

Implements RakPeerInterface.

void RakPeer::GetOfflinePingResponse | ( | char ** | data,
 |  | unsigned int * | length |
 | ) |  |  | [virtual]

Returns pointers to a copy of the data passed to SetOfflinePingResponse

Parameters:
[out] | data | A pointer to a copy of the data passed to SetOfflinePingResponse()
[out] | length | A pointer filled in with the length parameter passed to SetOfflinePingResponse()
See also:
SetOfflinePingResponse

Implements RakPeerInterface.

SystemAddress RakPeer::GetInternalID ( const SystemAddress systemAddress = UNASSIGNED_SYSTEM_ADDRESS ) const [virtual]

Return the unique address identifier that represents you or another system on the the network and is based on your local IP / port.

Parameters:
[in] systemAddress Use UNASSIGNED_SYSTEM_ADDRESS to get your behind-LAN address. Use a connected system to get their behind-LAN address
Returns:
the identifier of your system internally, which may not be how other systems see if you if you are behind a NAT or proxy

Implements RakPeerInterface.

SystemAddress RakPeer::GetExternalID ( const SystemAddress target ) const [virtual]

Return the unique address identifier that represents you on the the network and is based on your externalIP / port (the IP / port the specified player uses to communicate with you)

Parameters:
[in] target Which remote system you are referring to for your external ID. Usually the same for all systems, unless you have two or more network cards.

Implements RakPeerInterface.

void RakPeer::SetTimeoutTime | ( | RakNetTime | timeMS,
 |  | const SystemAddress | target |
 | ) |  |  | [virtual]

Parameters:
[in] target Which system to do this for. Pass UNASSIGNED_SYSTEM_ADDRESS for all systems.

Parameters:
[in] timeMS Time, in MS

Implements RakPeerInterface.

bool RakPeer::SetMTUSize ( int size ) [virtual]

Set the MTU per datagram. It's important to set this correctly - otherwise packets will be needlessly split, decreasing performance and throughput. Maximum allowed size is MAXIMUM_MTU_SIZE. Too high of a value will cause packets not to arrive at worst and be fragmented at best. Too low of a value will split packets unnecessarily. Recommended size is 1500 sa MTUSize.h

Parameters:
[in] size The MTU size
Precondition:
Can only be called when not connected.
Returns:
false on failure (we are connected), else true

Implements RakPeerInterface.

int RakPeer::GetMTUSize ( const SystemAddress target ) const [virtual]

Returns the current MTU size

Parameters:
[in] target Which system to get this for. UNASSIGNED_SYSTEM_ADDRESS to get the default
Returns:
The current MTU size

Implements RakPeerInterface.

const char * RakPeer::GetLocalIP ( unsigned int index ) [virtual]

Returns an IP address at index 0 to GetNumberOfAddresses-1

Parameters:
[in] index index into the list of IP addresses
Returns:
The local IP address at this index

Implements RakPeerInterface.

bool RakPeer::IsLocalIP ( const char * ip ) [virtual]

Is this a local IP?

Parameters:
[in] An IP address to check, excluding the port
Returns:
True if this is one of the IP addresses returned by GetLocalIP

Implements RakPeerInterface.

void RakPeer::AllowConnectionResponseIPMigration ( bool allow ) [virtual]

Allow or disallow connection responses from any IP. Normally this should be false, but may be necessary when connecting to servers with multiple IP addresses.

Parameters:
[in] allow - True to allow this behavior, false to not allow. Defaults to false. Value persists between connections

Implements RakPeerInterface.

bool RakPeer::AdvertiseSystem | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | const char * | data,
 |  | int | dataLength,
 |  | unsigned | connectionSocketIndex = 0 |
 | ) |  |  | [virtual]

Sends a one byte message ID_ADVERTISE_SYSTEM to the remote unconnected system. This will tell the remote system our external IP outside the LAN along with some user data.

Precondition:
The sender and recipient must already be started via a successful call to Initialize
Parameters:
[in] | host | Either a dotted IP address or a domain name
[in] | remotePort | Which port to connect to on the remote machine.
[in] | data | Optional data to append to the packet.
[in] | dataLength | length of data in bytes. Use 0 if no data.
[in] | connectionSocketIndex | Index into the array of socket descriptors passed to socketDescriptors in RakPeer::Startup() to send on.
Returns:
false if IsActive()==false or the host is unresolvable. True otherwise

Implements RakPeerInterface.

void RakPeer::SetSplitMessageProgressInterval ( int interval ) [virtual]

Controls how often to return ID_DOWNLOAD_PROGRESS for large message downloads. ID_DOWNLOAD_PROGRESS is returned to indicate a new partial message chunk, roughly the MTU size, has arrived As it can be slow or cumbersome to get this notification for every chunk, you can set the interval at which it is returned. Defaults to 0 (never return this notification)

Parameters:
[in] interval How many messages to use as an interval

Implements RakPeerInterface.

void RakPeer::SetUnreliableTimeout ( RakNetTime timeoutMS ) [virtual]

Set how long to wait before giving up on sending an unreliable message Useful if the network is clogged up. Set to 0 or less to never timeout. Defaults to 0.

Parameters:
[in] timeoutMS How many ms to wait before simply not sending an unreliable message.

Implements RakPeerInterface.

void RakPeer::SendTTL | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | int | ttl,
 |  | unsigned | connectionSocketIndex = 0 |
 | ) |  |  | [virtual]

Send a message to host, with the IP socket option TTL set to 3 This message will not reach the host, but will open the router.

Parameters:
[in] ttl Max hops of datagram Used for NAT-Punchthrough

Implements RakPeerInterface.

void RakPeer::SetCompileFrequencyTable ( bool doCompile ) [virtual]

Enables or disables frequency table tracking. This is required to get a frequency table, which is used in GenerateCompressionLayer() This value persists between connect calls and defaults to false (no frequency tracking)

Precondition:
You can call this at any time - however you SHOULD only call it when disconnected. Otherwise you will only trackpart of the values sent over the network.
Parameters:
[in] doCompile True to enable tracking

Implements RakPeerInterface.

bool RakPeer::GetOutgoingFrequencyTable ( unsigned int outputFrequencyTable[256] ) [virtual]

Returns the frequency of outgoing bytes into output frequency table The purpose is to save to file as either a master frequency table from a sample game session for passing to GenerateCompressionLayer()

Precondition:
You should only call this when disconnected. Requires that you first enable data frequency tracking by calling SetCompileFrequencyTable(true)
Parameters:
[out] outputFrequencyTable The frequency of each corresponding byte
Returns:
False (failure) if connected or if frequency table tracking is not enabled. Otherwise true (success)

Implements RakPeerInterface.

bool RakPeer::GenerateCompressionLayer | ( | unsigned int | inputFrequencyTable[256],
 |  | bool | inputLayer |
 | ) |  |  | [virtual]

This is an optional function to generate the compression layer based on the input frequency table. If you want to use it you should call this twice - once with inputLayer as true and once as false. The frequency table passed here with inputLayer=true should match the frequency table on the recipient with inputLayer=false. Likewise, the frequency table passed here with inputLayer=false should match the frequency table on the recipient with inputLayer=true. Calling this function when there is an existing layer will overwrite the old layer.

Precondition:
You should only call this when disconnected
Parameters:
[in] | inputFrequencyTable | A frequency table for your data
[in] | inputLayer | Is this the input layer?
Returns:
false (failure) if connected. Otherwise true (success)
See also:
Compression.cpp

Implements RakPeerInterface.

bool RakPeer::DeleteCompressionLayer ( bool inputLayer ) [virtual]

Delete the output or input layer as specified. This is not necessary to call and is only valuable for freeing memory.

Precondition:
You should only call this when disconnected
Parameters:
[in] inputLayer True to mean the inputLayer, false to mean the output layer
Returns:
false (failure) if connected. Otherwise true (success)

Implements RakPeerInterface.

float RakPeer::GetCompressionRatio ( void ) const [virtual]

Returns the compression ratio. A low compression ratio is good. Compression is for outgoing data

Returns:
The compression ratio

Implements RakPeerInterface.

float RakPeer::GetDecompressionRatio ( void ) const [virtual]

Returns the decompression ratio. A high decompression ratio is good. Decompression is for incoming data

Returns:
The decompression ratio

Implements RakPeerInterface.

void RakPeer::AttachPlugin ( PluginInterface * plugin ) [virtual]

Attatches a Plugin interface to run code automatically on message receipt in the Receive call

Note:
If plugins have dependencies on each other then the order does matter - for example the router plugin should go first because it might route messages for other plugins
Parameters:
[in] messageHandler Pointer to a plugin to attach

Implements RakPeerInterface.

void RakPeer::DetachPlugin ( PluginInterface * messageHandler ) [virtual]

Detaches a Plugin interface to run code automatically on message receipt

Parameters:
[in] messageHandler Pointer to a plugin to detach

Implements RakPeerInterface.

void RakPeer::PushBackPacket | ( | Packet * | packet,
 |  | bool | pushAtHead |
 | ) |  |  | [virtual]

Put a message back at the end of the receive queue in case you don't want to deal with it immediately

Parameters:
[in] | packet | The packet you want to push back.
[in] | pushAtHead | True to push the packet so that the next receive call returns it. False to push it at the end of the queue (obviously pushing it at the end makes the packets out of order)

Implements RakPeerInterface.

Packet * RakPeer::AllocatePacket ( unsigned dataSize ) [virtual]

Returns:
a packet for you to write to if you want to create a Packet for some reason. You can add it to the receive buffer with PushBackPacket
Parameters:
[in] dataSize How many bytes to allocate for the buffer
Returns:
A packet you can write to

Implements RakPeerInterface.

void RakPeer::ApplyNetworkSimulator | ( | double | maxSendBPS,
 |  | unsigned short | minExtraPing,
 |  | unsigned short | extraPingVariance |
 | ) |  |  | [virtual]

Adds simulated ping and packet loss to the outgoing data flow. To simulate bi-directional ping and packet loss, you should call this on both the sender and the recipient, with half the total ping and maxSendBPS value on each. You can exclude network simulator code with the _RELEASE define to decrease code size

Parameters:
[in] | maxSendBPS | Maximum bits per second to send. Packetloss grows linearly. 0 to disable. (CURRENTLY BROKEN - ALWAYS DISABLED)
[in] | minExtraPing | The minimum time to delay sends.
[in] | extraPingVariance | The additional random time to delay sends.

Implements RakPeerInterface.

void RakPeer::SetPerConnectionOutgoingBandwidthLimit ( unsigned maxBitsPerSecond ) [virtual]

Limits how much outgoing bandwidth can be sent per-connection. This limit does not apply to the sum of all connections! Exceeding the limit queues up outgoing traffic

Parameters:
[in] maxBitsPerSecond Maximum bits per second to send. Use 0 for unlimited (default). Once set, it takes effect immedately and persists until called again.

Implements RakPeerInterface.

bool RakPeer::IsNetworkSimulatorActive ( void ) [virtual]

Returns if you previously called ApplyNetworkSimulator

Returns:
If you previously called ApplyNetworkSimulator

Implements RakPeerInterface.

RakNetStatistics *const RakPeer::GetStatistics ( const SystemAddress systemAddress ) [virtual]

Returns a structure containing a large set of network statistics for the specified system. You can map this data to a string using the C style StatisticsToString() function

Parameters:
[in] systemAddress,: Which connected system to get statistics for
Returns:
0 on can't find the specified system. A pointer to a set of data otherwise.
See also:
RakNetStatistics.h

Implements RakPeerInterface.

RakPeer::RemoteSystemStruct * RakPeer::GetRemoteSystemFromSystemAddress | ( | const SystemAddress | systemAddress,
 |  | bool | calledFromNetworkThread,
 |  | bool | onlyActive |
 | ) |  |  | const [protected]

Get the reliability layer associated with a systemAddress.

Parameters:
[in] systemAddress The player identifier
Returns:
0 if none

RakPeer::RemoteSystemStruct * RakPeer::AssignSystemAddressToRemoteSystemList | ( | const SystemAddress | systemAddress,
 |  | RemoteSystemStruct::ConnectMode | connectionMode,
 |  | unsigned | connectionSocketIndex |
 | ) |  |  | [protected]

Get a free remote system from the list and assign our systemAddress to it. Should only be called from the update thread - not the user thread.

Add this player to the lookup tree

bool RakPeer::HandleRPCPacket | ( | const char * | data,
 |  | int | length,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [protected]

Handles an RPC packet. This is sending an RPC request

Parameters:
[in] | data | A packet returned from Receive with the ID ID_RPC
[in] | length | The size of the packet data
[in] | systemAddress | The sender of the packet
Returns:
true on success, false on a bad packet or an unregistered function

void RakPeer::HandleRPCReplyPacket | ( | const char * | data,
 |  | int | length,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [protected]

Handles an RPC reply packet. This is data returned from an RPC call

Parameters:
[in] | data | A packet returned from Receive with the ID ID_RPC
[in] | length | The size of the packet data
[in] | systemAddress | The sender of the packet

Member Data Documentation

* unsigned short RakPeer::maximumNumberOfPeers [protected]

Store the maximum number of peers allowed to connect.

Do we occasionally ping the other systems?

RemoteSystemStruct* RakPeer::remoteSystemList [protected]

This is an array of pointers to RemoteSystemStruct This allows us to preallocate the list when starting, so we don't have to allocate or delete at runtime. Another benefit is that is lets us add and remove active players simply by setting systemAddress and moving elements in the list by copying pointers variables without affecting running threads, even if they are in the reliability layer

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/RakPeer.h
  • C:/RakNet/Source/RakPeer.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakPeer::MemoryBlock Struct Reference

RakPeer::MemoryBlock

RakPeer::MemoryBlock Struct Reference

Automatic Variable Synchronization Mechanism automatic variable synchronization takes a primary and secondary identifier The unique primary identifier is the index into the automaticVariableSynchronizationList The unique secondary identifier (UNASSIGNED_NETWORK_ID for none) is in an unsorted list of memory blocks. More...

#include <RakPeer.h>

List of all members.

Detailed Description

Automatic Variable Synchronization Mechanism automatic variable synchronization takes a primary and secondary identifier The unique primary identifier is the index into the automaticVariableSynchronizationList The unique secondary identifier (UNASSIGNED_NETWORK_ID for none) is in an unsorted list of memory blocks.

The documentation for this struct was generated from the following file:
  • C:/RakNet/Source/RakPeer.h
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakPeerInterface Class Reference

RakPeerInterface Class Reference

The main interface for network communications. More...

#include <RakPeerInterface.h>

Inheritance diagram for RakPeerInterface:

RakPeer List of all members.

Public Member Functions

virtual | ~RakPeerInterface ()
Destructor.
virtual bool | Startup (unsigned short maxConnections, int _threadSleepTimer, SocketDescriptor *socketDescriptors, unsigned socketDescriptorCount)=0
Starts the network threads, opens the listen port. You must call this before calling Connect(). Multiple calls while already active are ignored. To call this function again with different settings, you must first call Shutdown().
virtual void | InitializeSecurity (const char *pubKeyE, const char *pubKeyN, const char *privKeyP, const char *privKeyQ)=0
virtual void | DisableSecurity (void)=0
virtual void | AddToSecurityExceptionList (const char *ip)=0
virtual void | RemoveFromSecurityExceptionList (const char *ip)=0
virtual bool | IsInSecurityExceptionList (const char *ip)=0
virtual void | SetMaximumIncomingConnections (unsigned short numberAllowed)=0
virtual unsigned short | GetMaximumIncomingConnections (void) const =0
virtual unsigned short | NumberOfConnections (void) const =0
virtual void | SetIncomingPassword (const char *passwordData, int passwordDataLength)=0
virtual void | GetIncomingPassword (char *passwordData, int *passwordDataLength)=0
virtual bool | Connect (const char *host, unsigned short remotePort, const char *passwordData, int passwordDataLength, unsigned connectionSocketIndex=0)=0
Connect to the specified host (ip or domain name) and server port. Calling Connect and not calling SetMaximumIncomingConnections acts as a dedicated client. Calling both acts as a true peer. This is a non-blocking connection. You know the connection is successful when IsConnected() returns true or Receive() gets a message with the type identifier ID_CONNECTION_ACCEPTED. If the connection is not successful, such as a rejected connection or no response then neither of these things will happen.
virtual void | Shutdown (unsigned int blockDuration, unsigned char orderingChannel=0)=0
Connect to the specified network ID (Platform specific console function) Does built-in NAt traversal Stops the network threads and closes all connections.
virtual bool | IsActive (void) const =0
virtual bool | GetConnectionList (SystemAddress *remoteSystems, unsigned short *numberOfSystems) const =0
virtual bool | Send (const char *data, const int length, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast)=0
virtual bool | Send (const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast)=0
virtual bool | SendList (char **data, const int *lengths, const int numParameters, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast)=0
virtual Packet * | Receive (void)=0
virtual void | DeallocatePacket (Packet *packet)=0
virtual unsigned short | GetMaximumNumberOfPeers (void) const =0
Return the total number of connections we are allowed.
virtual void | RegisterAsRemoteProcedureCall (const char *uniqueID, void(*functionPointer)(RPCParameters *rpcParms))=0
virtual void | RegisterClassMemberRPC (const char *uniqueID, void *functionPointer)=0
virtual void | UnregisterAsRemoteProcedureCall (const char *uniqueID)=0
virtual void | SetNetworkIDManager (NetworkIDManager *manager)=0
virtual NetworkIDManager * | GetNetworkIDManager (void) const =0
Returns:
Returns the value passed to SetNetworkIDManager or 0 if never called.

virtual bool | RPC (const char *uniqueID, const char *data, BitSize_t bitLength, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, RakNetTime *includedTimestamp, NetworkID networkID, RakNet::BitStream *replyFromTarget)=0
virtual bool | RPC (const char *uniqueID, const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, RakNetTime *includedTimestamp, NetworkID networkID, RakNet::BitStream *replyFromTarget)=0
virtual void | CloseConnection (const SystemAddress target, bool sendDisconnectionNotification, unsigned char orderingChannel=0)=0
virtual bool | IsConnected (const SystemAddress systemAddress, bool includeInProgress=false, bool includeDisconnecting=false)=0
virtual int | GetIndexFromSystemAddress (const SystemAddress systemAddress)=0
virtual SystemAddress | GetSystemAddressFromIndex (int index)=0
virtual void | AddToBanList (const char *IP, RakNetTime milliseconds=0)=0
virtual void | RemoveFromBanList (const char *IP)=0
virtual void | ClearBanList (void)=0
Allows all previously banned IPs to connect.
virtual bool | IsBanned (const char *IP)=0
virtual void | Ping (const SystemAddress target)=0
virtual void | Ping (const char *host, unsigned short remotePort, bool onlyReplyOnAcceptingConnections, unsigned connectionSocketIndex=0)=0
virtual int | GetAveragePing (const SystemAddress systemAddress)=0
virtual int | GetLastPing (const SystemAddress systemAddress) const =0
virtual int | GetLowestPing (const SystemAddress systemAddress) const =0
virtual void | SetOccasionalPing (bool doPing)=0
virtual void | SetOfflinePingResponse (const char *data, const unsigned int length)=0
virtual void | GetOfflinePingResponse (char **data, unsigned int *length)=0
virtual SystemAddress | GetInternalID (const SystemAddress systemAddress=UNASSIGNED_SYSTEM_ADDRESS) const =0
virtual SystemAddress | GetExternalID (const SystemAddress target) const =0
virtual void | SetTimeoutTime (RakNetTime timeMS, const SystemAddress target)=0
virtual bool | SetMTUSize (int size)=0
virtual int | GetMTUSize (const SystemAddress target) const =0
virtual unsigned | GetNumberOfAddresses (void)=0
Returns the number of IP addresses this system has internally. Get the actual addresses from GetLocalIP().
virtual const char * | GetLocalIP (unsigned int index)=0
virtual bool | IsLocalIP (const char *ip)=0
virtual void | AllowConnectionResponseIPMigration (bool allow)=0
virtual bool | AdvertiseSystem (const char *host, unsigned short remotePort, const char *data, int dataLength, unsigned connectionSocketIndex=0)=0
virtual void | SetSplitMessageProgressInterval (int interval)=0
virtual void | SetUnreliableTimeout (RakNetTime timeoutMS)=0
virtual void | SendTTL (const char *host, unsigned short remotePort, int ttl, unsigned connectionSocketIndex=0)=0
virtual void | SetCompileFrequencyTable (bool doCompile)=0
virtual bool | GetOutgoingFrequencyTable (unsigned int outputFrequencyTable[256])=0
virtual bool | GenerateCompressionLayer (unsigned int inputFrequencyTable[256], bool inputLayer)=0
virtual bool | DeleteCompressionLayer (bool inputLayer)=0
virtual float | GetCompressionRatio (void) const =0
virtual float | GetDecompressionRatio (void) const =0
virtual void | AttachPlugin (PluginInterface *plugin)=0
virtual void | DetachPlugin (PluginInterface *messageHandler)=0
virtual void | PushBackPacket (Packet *packet, bool pushAtHead)=0
virtual void | SetRouterInterface (RouterInterface *routerInterface)=0

For internal use only.

virtual void | RemoveRouterInterface (RouterInterface *routerInterface)=0

For internal use only.

virtual Packet * | AllocatePacket (unsigned dataSize)=0
virtual void | ApplyNetworkSimulator (double maxSendBPS, unsigned short minExtraPing, unsigned short extraPingVariance)=0
virtual void | SetPerConnectionOutgoingBandwidthLimit (unsigned maxBitsPerSecond)=0
virtual bool | IsNetworkSimulatorActive (void)=0
virtual RakNetStatistics
*const 		GetStatistics (const SystemAddress systemAddress)=0

Detailed Description

The main interface for network communications.

The primary interface for RakNet, RakPeer contains all major functions for the library. See the individual functions for what the class can do.

Member Function Documentation

virtual bool RakPeerInterface::Startup | ( | unsigned short | maxConnections,
 |  | int | _threadSleepTimer,
 |  | SocketDescriptor * | socketDescriptors,
 |  | unsigned | socketDescriptorCount |
 | ) |  |  | [pure virtual]

Starts the network threads, opens the listen port. You must call this before calling Connect(). Multiple calls while already active are ignored. To call this function again with different settings, you must first call Shutdown().

Note:
Call SetMaximumIncomingConnections if you want to accept incoming connections

Set _RAKNET_THREADSAFE in RakNetDefines.h if you want to call RakNet functions from multiple threads (not recommended, as it is much slower and RakNet is already asynchronous).

Parameters:
[in] | maxConnections | The maximum number of connections between this instance of RakPeer and another instance of RakPeer. Required so the network can preallocate and for thread safety. A pure client would set this to 1. A pure server would set it to the number of allowed clients.- A hybrid would set it to the sum of both types of connections
[in] | localPort | The port to listen for connections on.
[in] | _threadSleepTimer | How many ms to Sleep each internal update cycle (30 to give the game priority, 0 for regular (recommended)
[in] | socketDescriptors | An array of SocketDescriptor structures to force RakNet to listen on a particular IP address or port (or both). Each SocketDescriptor will represent one unique socket. Do not pass redundant structures. To listen on a specific port, you can pass SocketDescriptor(myPort,0); such as for a server. For a client, it is usually OK to just pass SocketDescriptor();
[in] | socketDescriptorCount | The size of the socketDescriptors array. Pass 1 if you are not sure what to pass.
Returns:
False on failure (can't create socket or thread), true on success.

Implemented in RakPeer.

virtual void RakPeerInterface::InitializeSecurity | ( | const char * | pubKeyE,
 |  | const char * | pubKeyN,
 |  | const char * | privKeyP,
 |  | const char * | privKeyQ |
 | ) |  |  | [pure virtual]

Secures connections though a combination of SHA1, AES128, SYN Cookies, and RSA to prevent connection spoofing, replay attacks, data eavesdropping, packet tampering, and MitM attacks. There is a significant amount of processing and a slight amount of bandwidth overhead for this feature. If you accept connections, you must call this or else secure connections will not be enabled for incoming connections. If you are connecting to another system, you can call this with values for the (e and p,q) public keys before connecting to prevent MitM

Precondition:
Must be called while offline
Parameters:
[in] | pubKeyE | A pointer to the public keys from the RSACrypt class.
[in] | pubKeyN | A pointer to the public keys from the RSACrypt class.
[in] | privKeyP | Public key generated from the RSACrypt class.
[in] | privKeyQ | Public key generated from the RSACrypt class. If the private keys are 0, then a new key will be generated when this function is called
See also:
the Encryption sample

Implemented in RakPeer.

virtual void RakPeerInterface::DisableSecurity ( void ) [pure virtual]

Disables all security.

Note:
Must be called while offline

Implemented in RakPeer.

virtual void RakPeerInterface::AddToSecurityExceptionList ( const char * ip ) [pure virtual]

If secure connections are on, do not use secure connections for a specific IP address. This is useful if you have a fixed-address internal server behind a LAN.

Note:
Secure connections are determined by the recipient of an incoming connection. This has no effect if called on the system attempting to connect.
Parameters:
[in] ip IP address to add. * wildcards are supported.

Implemented in RakPeer.

virtual void RakPeerInterface::RemoveFromSecurityExceptionList ( const char * ip ) [pure virtual]

Remove a specific connection previously added via AddToSecurityExceptionList

Parameters:
[in] ip IP address to remove. Pass 0 to remove all IP addresses. * wildcards are supported.

Implemented in RakPeer.

virtual bool RakPeerInterface::IsInSecurityExceptionList ( const char * ip ) [pure virtual]

Checks to see if a given IP is in the security exception list

Parameters:
[in] IP address to check.

Implemented in RakPeer.

virtual void RakPeerInterface::SetMaximumIncomingConnections ( unsigned short numberAllowed ) [pure virtual]

Sets how many incoming connections are allowed. If this is less than the number of players currently connected, no more players will be allowed to connect. If this is greater than the maximum number of peers allowed, it will be reduced to the maximum number of peers allowed. Defaults to 0, meaning by default, nobody can connect to you

Parameters:
[in] numberAllowed Maximum number of incoming connections allowed.

Implemented in RakPeer.

virtual unsigned short RakPeerInterface::GetMaximumIncomingConnections ( void ) const [pure virtual]

Returns the value passed to SetMaximumIncomingConnections()

Returns:
the maximum number of incoming connections, which is always <= maxConnections

Implemented in RakPeer.

virtual unsigned short RakPeerInterface::NumberOfConnections ( void ) const [pure virtual]

Returns how many open connections there are at this time

Returns:
the number of open connections

Implemented in RakPeer.

virtual void RakPeerInterface::SetIncomingPassword | ( | const char * | passwordData,
 |  | int | passwordDataLength |
 | ) |  |  | [pure virtual]

Sets the password incoming connections must match in the call to Connect (defaults to none). Pass 0 to passwordData to specify no password This is a way to set a low level password for all incoming connections. To selectively reject connections, implement your own scheme using CloseConnection() to remove unwanted connections

Parameters:
[in] | passwordData | A data block that incoming connections must match. This can be just a password, or can be a stream of data. Specify 0 for no password data
[in] | passwordDataLength | The length in bytes of passwordData

Implemented in RakPeer.

virtual void RakPeerInterface::GetIncomingPassword | ( | char * | passwordData,
 |  | int * | passwordDataLength |
 | ) |  |  | [pure virtual]

Gets the password passed to SetIncomingPassword

Parameters:
[out] | passwordData | Should point to a block large enough to hold the password data you passed to SetIncomingPassword()
[in,out] | passwordDataLength | Maximum size of the array passwordData. Modified to hold the number of bytes actually written

Implemented in RakPeer.

virtual bool RakPeerInterface::Connect | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | const char * | passwordData,
 |  | int | passwordDataLength,
 |  | unsigned | connectionSocketIndex = 0 |
 | ) |  |  | [pure virtual]

Connect to the specified host (ip or domain name) and server port. Calling Connect and not calling SetMaximumIncomingConnections acts as a dedicated client. Calling both acts as a true peer. This is a non-blocking connection. You know the connection is successful when IsConnected() returns true or Receive() gets a message with the type identifier ID_CONNECTION_ACCEPTED. If the connection is not successful, such as a rejected connection or no response then neither of these things will happen.

Precondition:
Requires that you first call Initialize
Parameters:
[in] | host | Either a dotted IP address or a domain name
[in] | remotePort | Which port to connect to on the remote machine.
[in] | passwordData | A data block that must match the data block on the server passed to SetIncomingPassword. This can be a string or can be a stream of data. Use 0 for no password.
[in] | passwordDataLength | The length in bytes of passwordData
[in] | connectionSocketIndex | Index into the array of socket descriptors passed to socketDescriptors in RakPeer::Startup() to send on.
Returns:
True on successful initiation. False on incorrect parameters, internal error, or too many existing peers. Returning true does not mean you connected!

Implemented in RakPeer.

virtual void RakPeerInterface::Shutdown | ( | unsigned int | blockDuration,
 |  | unsigned char | orderingChannel = 0 |
 | ) |  |  | [pure virtual]

Connect to the specified network ID (Platform specific console function) Does built-in NAt traversal Stops the network threads and closes all connections.

Parameters:
[in] | blockDuration | How long, in milliseconds, you should wait for all remaining messages to go out, including ID_DISCONNECTION_NOTIFICATION. If 0, it doesn't wait at all.
[in] | orderingChannel | If blockDuration > 0, ID_DISCONNECTION_NOTIFICATION will be sent on this channel If you set it to 0 then the disconnection notification won't be sent

Implemented in RakPeer.

virtual bool RakPeerInterface::IsActive ( void ) const [pure virtual]

Returns if the network thread is running

Returns:
true if the network thread is running, false otherwise

Implemented in RakPeer.

virtual bool RakPeerInterface::GetConnectionList | ( | SystemAddress * | remoteSystems,
 |  | unsigned short * | numberOfSystems |
 | ) |  |  | const [pure virtual]

Fills the array remoteSystems with the SystemAddress of all the systems we are connected to

Parameters:
[out] | remoteSystems | An array of SystemAddress structures to be filled with the SystemAddresss of the systems we are connected to. Pass 0 to remoteSystems to only get the number of systems we are connected to
[in,out] | numberOfSystems | As input, the size of remoteSystems array. As output, the number of elements put into the array

Implemented in RakPeer.

virtual bool RakPeerInterface::Send | ( | const char * | data,
 |  | const int | length,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast |
 | ) |  |  | [pure virtual]

Sends a block of data to the specified system that you are connected to. This function only works while the connected The first byte should be a message identifier starting at ID_USER_PACKET_ENUM

Parameters:
[in] | data | The block of data to send
[in] | length | The size in bytes of the data to send
[in] | priority | What priority level to send on. See PacketPriority.h
[in] | reliability | How reliability to send this data. See PacketPriority.h
[in] | orderingChannel | When using ordered or sequenced messages, what channel to order these on. Messages are only ordered relative to other messages on the same stream
[in] | systemAddress | Who to send this packet to, or in the case of broadcasting who not to send it to. Use UNASSIGNED_SYSTEM_ADDRESS to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
Returns:
False if we are not connected to the specified recipient. True otherwise

Implemented in RakPeer.

virtual bool RakPeerInterface::Send | ( | const RakNet::BitStream * | bitStream,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast |
 | ) |  |  | [pure virtual]

Sends a block of data to the specified system that you are connected to. Same as the above version, but takes a BitStream as input.

Parameters:
[in] | bitStream | The bitstream to send
[in] | priority | What priority level to send on. See PacketPriority.h
[in] | reliability | How reliability to send this data. See PacketPriority.h
[in] | orderingChannel | When using ordered or sequenced messages, what channel to order these on. Messages are only ordered relative to other messages on the same stream
[in] | systemAddress | Who to send this packet to, or in the case of broadcasting who not to send it to. Use UNASSIGNED_SYSTEM_ADDRESS to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
Returns:
False if we are not connected to the specified recipient. True otherwise
Note:
COMMON MISTAKE: When writing the first byte, bitStream->Write((unsigned char) ID_MY_TYPE) be sure it is casted to a byte, and you are not writing a 4 byte enumeration.

Implemented in RakPeer.

virtual bool RakPeerInterface::SendList | ( | char ** | data,
 |  | const int * | lengths,
 |  | const int | numParameters,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast |
 | ) |  |  | [pure virtual]

Sends multiple blocks of data, concatenating them automatically.

This is equivalent to: RakNet::BitStream bs; bs.WriteAlignedBytes(block1, blockLength1); bs.WriteAlignedBytes(block2, blockLength2); bs.WriteAlignedBytes(block3, blockLength3); Send(&bs, ...)

This function only works while the connected

Parameters:
[in] | data | An array of pointers to blocks of data
[in] | lengths | An array of integers indicating the length of each block of data
[in] | numParameters | Length of the arrays data and lengths
[in] | priority | What priority level to send on. See PacketPriority.h
[in] | reliability | How reliability to send this data. See PacketPriority.h
[in] | orderingChannel | When using ordered or sequenced messages, what channel to order these on. Messages are only ordered relative to other messages on the same stream
[in] | systemAddress | Who to send this packet to, or in the case of broadcasting who not to send it to. Use UNASSIGNED_SYSTEM_ADDRESS to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
Returns:
False if we are not connected to the specified recipient. True otherwise

Implemented in RakPeer.

virtual Packet* RakPeerInterface::Receive ( void ) [pure virtual]

Gets a message from the incoming message queue. Use DeallocatePacket() to deallocate the message after you are done with it. User-thread functions, such as RPC calls and the plugin function PluginInterface::Update occur here.

Returns:
0 if no packets are waiting to be handled, otherwise a pointer to a packet.
Note:
COMMON MISTAKE: Be sure to call this in a loop, once per game tick, until it returns 0. If you only process one packet per game tick they will buffer up. sa RakNetTypes.h contains struct Packet

Implemented in RakPeer.

virtual void RakPeerInterface::DeallocatePacket ( Packet * packet ) [pure virtual]

Call this to deallocate a message returned by Receive() when you are done handling it.

Parameters:
[in] packet The message to deallocate.

Implemented in RakPeer.

virtual void RakPeerInterface::CloseConnection | ( | const SystemAddress | target,
 |  | bool | sendDisconnectionNotification,
 |  | unsigned char | orderingChannel = 0 |
 | ) |  |  | [pure virtual]

Close the connection to another host (if we initiated the connection it will disconnect, if they did it will kick them out).

Parameters:
[in] | target | Which system to close the connection to.
[in] | sendDisconnectionNotification | True to send ID_DISCONNECTION_NOTIFICATION to the recipient. False to close it silently.
[in] | channel | Which ordering channel to send the disconnection notification on, if any

Implemented in RakPeer.

virtual bool RakPeerInterface::IsConnected | ( | const SystemAddress | systemAddress,
 |  | bool | includeInProgress = false,
 |  | bool | includeDisconnecting = false |
 | ) |  |  | [pure virtual]

Returns if a particular systemAddress is connected to us (this also returns true if we are in the process of connecting)

Parameters:
[in] | systemAddress | The SystemAddress we are referring to
[in] | includeInProgress | If true, also return true for connections that are in progress but haven't completed
[in] | includeDisconnecting | If true, also return true for connections that are in the process of disconnecting
Returns:
True if this system is connected and active, false otherwise.

Implemented in RakPeer.

virtual int RakPeerInterface::GetIndexFromSystemAddress ( const SystemAddress systemAddress ) [pure virtual]

Given a systemAddress, returns an index from 0 to the maximum number of players allowed - 1.

Parameters:
[in] systemAddress The SystemAddress we are referring to
Returns:
The index of this SystemAddress or -1 on system not found.

Implemented in RakPeer.

virtual SystemAddress RakPeerInterface::GetSystemAddressFromIndex ( int index ) [pure virtual]

This function is only useful for looping through all systems Given an index, will return a SystemAddress.

Parameters:
[in] index Index should range between 0 and the maximum number of players allowed - 1.
Returns:
The SystemAddress

Implemented in RakPeer.

virtual void RakPeerInterface::AddToBanList | ( | const char * | IP,
 |  | RakNetTime | milliseconds = 0 |
 | ) |  |  | [pure virtual]

Bans an IP from connecting. Banned IPs persist between connections but are not saved on shutdown nor loaded on startup. param[in] IP Dotted IP address. Can use * as a wildcard, such as 128.0.0.* will ban all IP addresses starting with 128.0.0

Parameters:
[in] milliseconds how many ms for a temporary ban. Use 0 for a permanent ban

Implemented in RakPeer.

virtual void RakPeerInterface::RemoveFromBanList ( const char * IP ) [pure virtual]

Allows a previously banned IP to connect. param[in] Dotted IP address. Can use * as a wildcard, such as 128.0.0.* will banAll IP addresses starting with 128.0.0

Implemented in RakPeer.

virtual bool RakPeerInterface::IsBanned ( const char * IP ) [pure virtual]

Returns true or false indicating if a particular IP is banned.

Parameters:
[in] IP - Dotted IP address.
Returns:
true if IP matches any IPs in the ban list, accounting for any wildcards. False otherwise.

Implemented in RakPeer.

virtual void RakPeerInterface::Ping ( const SystemAddress target ) [pure virtual]

Send a ping to the specified connected system.

Precondition:
The sender and recipient must already be started via a successful call to Startup()
Parameters:
[in] target Which system to ping

Implemented in RakPeer.

virtual void RakPeerInterface::Ping | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | bool | onlyReplyOnAcceptingConnections,
 |  | unsigned | connectionSocketIndex = 0 |
 | ) |  |  | [pure virtual]

Send a ping to the specified unconnected system. The remote system, if it is Initialized, will respond with ID_PONG followed by sizeof(RakNetTime) containing the system time the ping was sent.(Default is 4 bytes - See __GET_TIME_64BIT in RakNetTypes.h

Parameters:
[in] | host | Either a dotted IP address or a domain name. Can be 255.255.255.255 for LAN broadcast.
[in] | remotePort | Which port to connect to on the remote machine.
[in] | onlyReplyOnAcceptingConnections | Only request a reply if the remote system is accepting connections
[in] | connectionSocketIndex | Index into the array of socket descriptors passed to socketDescriptors in RakPeer::Startup() to send on.

Implemented in RakPeer.

virtual int RakPeerInterface::GetAveragePing ( const SystemAddress systemAddress ) [pure virtual]

Returns the average of all ping times read for the specific system or -1 if none read yet

Parameters:
[in] systemAddress Which system we are referring to
Returns:
The ping time for this system, or -1

Implemented in RakPeer.

virtual int RakPeerInterface::GetLastPing ( const SystemAddress systemAddress ) const [pure virtual]

Returns the last ping time read for the specific system or -1 if none read yet

Parameters:
[in] systemAddress Which system we are referring to
Returns:
The last ping time for this system, or -1

Implemented in RakPeer.

virtual int RakPeerInterface::GetLowestPing ( const SystemAddress systemAddress ) const [pure virtual]

Returns the lowest ping time read or -1 if none read yet

Parameters:
[in] systemAddress Which system we are referring to
Returns:
The lowest ping time for this system, or -1

Implemented in RakPeer.

virtual void RakPeerInterface::SetOccasionalPing ( bool doPing ) [pure virtual]

Ping the remote systems every so often, or not. This is off by default. Can be called anytime.

Parameters:
[in] doPing True to start occasional pings. False to stop them.

Implemented in RakPeer.

virtual void RakPeerInterface::SetOfflinePingResponse | ( | const char * | data,
 |  | const unsigned int | length |
 | ) |  |  | [pure virtual]

Sets the data to send along with a LAN server discovery or offline ping reply. length should be under 400 bytes, as a security measure against flood attacks

Parameters:
[in] | data | a block of data to store, or 0 for none
[in] | length | The length of data in bytes, or 0 for none
See also:
Ping.cpp

Implemented in RakPeer.

virtual void RakPeerInterface::GetOfflinePingResponse | ( | char ** | data,
 |  | unsigned int * | length |
 | ) |  |  | [pure virtual]

Returns pointers to a copy of the data passed to SetOfflinePingResponse

Parameters:
[out] | data | A pointer to a copy of the data passed to SetOfflinePingResponse()
[out] | length | A pointer filled in with the length parameter passed to SetOfflinePingResponse()
See also:
SetOfflinePingResponse

Implemented in RakPeer.

virtual SystemAddress RakPeerInterface::GetInternalID ( const SystemAddress systemAddress = UNASSIGNED_SYSTEM_ADDRESS ) const [pure virtual]

Return the unique address identifier that represents you on the the network and is based on your local IP / port.

Returns:
the identifier of your system internally, which may not be how other systems see if you if you are behind a NAT or proxy

Implemented in RakPeer.

virtual SystemAddress RakPeerInterface::GetExternalID ( const SystemAddress target ) const [pure virtual]

Return the unique address identifier that represents you on the the network and is based on your externalIP / port (the IP / port the specified player uses to communicate with you)

Parameters:
[in] target Which remote system you are referring to for your external ID. Usually the same for all systems, unless you have two or more network cards.

Implemented in RakPeer.

virtual void RakPeerInterface::SetTimeoutTime | ( | RakNetTime | timeMS,
 |  | const SystemAddress | target |
 | ) |  |  | [pure virtual]

Set the time, in MS, to use before considering ourselves disconnected after not being able to deliver a reliable message. Default time is 10,000 or 10 seconds in release and 30,000 or 30 seconds in debug.

Parameters:
[in] | timeMS | Time, in MS
[in] | target | Which system to do this for. Pass UNASSIGNED_SYSTEM_ADDRESS for all systems.

Implemented in RakPeer.

virtual bool RakPeerInterface::SetMTUSize ( int size ) [pure virtual]

Set the MTU per datagram. It's important to set this correctly - otherwise packets will be needlessly split, decreasing performance and throughput. Maximum allowed size is MAXIMUM_MTU_SIZE. Too high of a value will cause packets not to arrive at worst and be fragmented at best. Too low of a value will split packets unnecessarily. Recommended size is 1500 sa MTUSize.h

Parameters:
[in] size The MTU size
Precondition:
Can only be called when not connected.
Returns:
false on failure (we are connected), else true

Implemented in RakPeer.

virtual int RakPeerInterface::GetMTUSize ( const SystemAddress target ) const [pure virtual]

Returns the current MTU size

Parameters:
[in] target Which system to get this for. UNASSIGNED_SYSTEM_ADDRESS to get the default
Returns:
The current MTU size

Implemented in RakPeer.

virtual const char* RakPeerInterface::GetLocalIP ( unsigned int index ) [pure virtual]

Returns an IP address at index 0 to GetNumberOfAddresses-1

Parameters:
[in] index index into the list of IP addresses
Returns:
The local IP address at this index

Implemented in RakPeer.

virtual bool RakPeerInterface::IsLocalIP ( const char * ip ) [pure virtual]

Is this a local IP?

Parameters:
[in] An IP address to check, excluding the port
Returns:
True if this is one of the IP addresses returned by GetLocalIP

Implemented in RakPeer.

virtual void RakPeerInterface::AllowConnectionResponseIPMigration ( bool allow ) [pure virtual]

Allow or disallow connection responses from any IP. Normally this should be false, but may be necessary when connecting to servers with multiple IP addresses.

Parameters:
[in] allow - True to allow this behavior, false to not allow. Defaults to false. Value persists between connections

Implemented in RakPeer.

virtual bool RakPeerInterface::AdvertiseSystem | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | const char * | data,
 |  | int | dataLength,
 |  | unsigned | connectionSocketIndex = 0 |
 | ) |  |  | [pure virtual]

Sends a one byte message ID_ADVERTISE_SYSTEM to the remote unconnected system. This will tell the remote system our external IP outside the LAN along with some user data.

Precondition:
The sender and recipient must already be started via a successful call to Initialize
Parameters:
[in] | host | Either a dotted IP address or a domain name
[in] | remotePort | Which port to connect to on the remote machine.
[in] | data | Optional data to append to the packet.
[in] | dataLength | length of data in bytes. Use 0 if no data.
[in] | connectionSocketIndex | Index into the array of socket descriptors passed to socketDescriptors in RakPeer::Startup() to send on.
Returns:
false if IsActive()==false or the host is unresolvable. True otherwise

Implemented in RakPeer.

virtual void RakPeerInterface::SetSplitMessageProgressInterval ( int interval ) [pure virtual]

Controls how often to return ID_DOWNLOAD_PROGRESS for large message downloads. ID_DOWNLOAD_PROGRESS is returned to indicate a new partial message chunk, roughly the MTU size, has arrived As it can be slow or cumbersome to get this notification for every chunk, you can set the interval at which it is returned. Defaults to 0 (never return this notification)

Parameters:
[in] interval How many messages to use as an interval

Implemented in RakPeer.

virtual void RakPeerInterface::SetUnreliableTimeout ( RakNetTime timeoutMS ) [pure virtual]

Set how long to wait before giving up on sending an unreliable message Useful if the network is clogged up. Set to 0 or less to never timeout. Defaults to 0.

Parameters:
[in] timeoutMS How many ms to wait before simply not sending an unreliable message.

Implemented in RakPeer.

virtual void RakPeerInterface::SendTTL | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | int | ttl,
 |  | unsigned | connectionSocketIndex = 0 |
 | ) |  |  | [pure virtual]

Send a message to host, with the IP socket option TTL set to 3 This message will not reach the host, but will open the router. Used for NAT-Punchthrough

Implemented in RakPeer.

virtual void RakPeerInterface::SetCompileFrequencyTable ( bool doCompile ) [pure virtual]

Enables or disables frequency table tracking. This is required to get a frequency table, which is used in GenerateCompressionLayer() This value persists between connect calls and defaults to false (no frequency tracking)

Precondition:
You can call this at any time - however you SHOULD only call it when disconnected. Otherwise you will only trackpart of the values sent over the network.
Parameters:
[in] doCompile True to enable tracking

Implemented in RakPeer.

virtual bool RakPeerInterface::GetOutgoingFrequencyTable ( unsigned int outputFrequencyTable[256] ) [pure virtual]

Returns the frequency of outgoing bytes into output frequency table The purpose is to save to file as either a master frequency table from a sample game session for passing to GenerateCompressionLayer()

Precondition:
You should only call this when disconnected. Requires that you first enable data frequency tracking by calling SetCompileFrequencyTable(true)
Parameters:
[out] outputFrequencyTable The frequency of each corresponding byte
Returns:
False (failure) if connected or if frequency table tracking is not enabled. Otherwise true (success)

Implemented in RakPeer.

virtual bool RakPeerInterface::GenerateCompressionLayer | ( | unsigned int | inputFrequencyTable[256],
 |  | bool | inputLayer |
 | ) |  |  | [pure virtual]

This is an optional function to generate the compression layer based on the input frequency table. If you want to use it you should call this twice - once with inputLayer as true and once as false. The frequency table passed here with inputLayer=true should match the frequency table on the recipient with inputLayer=false. Likewise, the frequency table passed here with inputLayer=false should match the frequency table on the recipient with inputLayer=true. Calling this function when there is an existing layer will overwrite the old layer.

Precondition:
You should only call this when disconnected
Parameters:
[in] | inputFrequencyTable | A frequency table for your data
[in] | inputLayer | Is this the input layer?
Returns:
false (failure) if connected. Otherwise true (success)
See also:
Compression.cpp

Implemented in RakPeer.

virtual bool RakPeerInterface::DeleteCompressionLayer ( bool inputLayer ) [pure virtual]

Delete the output or input layer as specified. This is not necessary to call and is only valuable for freeing memory.

Precondition:
You should only call this when disconnected
Parameters:
[in] inputLayer True to mean the inputLayer, false to mean the output layer
Returns:
false (failure) if connected. Otherwise true (success)

Implemented in RakPeer.

virtual float RakPeerInterface::GetCompressionRatio ( void ) const [pure virtual]

Returns the compression ratio. A low compression ratio is good. Compression is for outgoing data

Returns:
The compression ratio

Implemented in RakPeer.

virtual float RakPeerInterface::GetDecompressionRatio ( void ) const [pure virtual]

Returns the decompression ratio. A high decompression ratio is good. Decompression is for incoming data

Returns:
The decompression ratio

Implemented in RakPeer.

virtual void RakPeerInterface::AttachPlugin ( PluginInterface * plugin ) [pure virtual]

Attatches a Plugin interface to run code automatically on message receipt in the Receive call

Note:
If plugins have dependencies on each other then the order does matter - for example the router plugin should go first because it might route messages for other plugins
Parameters:
[in] messageHandler Pointer to a plugin to attach

Implemented in RakPeer.

virtual void RakPeerInterface::DetachPlugin ( PluginInterface * messageHandler ) [pure virtual]

Detaches a Plugin interface to run code automatically on message receipt

Parameters:
[in] messageHandler Pointer to a plugin to detach

Implemented in RakPeer.

virtual void RakPeerInterface::PushBackPacket | ( | Packet * | packet,
 |  | bool | pushAtHead |
 | ) |  |  | [pure virtual]

Put a message back at the end of the receive queue in case you don't want to deal with it immediately

Parameters:
[in] | packet | The packet you want to push back.
[in] | pushAtHead | True to push the packet so that the next receive call returns it. False to push it at the end of the queue (obviously pushing it at the end makes the packets out of order)

Implemented in RakPeer.

virtual Packet* RakPeerInterface::AllocatePacket ( unsigned dataSize ) [pure virtual]

Returns:
a packet for you to write to if you want to create a Packet for some reason. You can add it to the receive buffer with PushBackPacket
Parameters:
[in] dataSize How many bytes to allocate for the buffer
Returns:
A packet you can write to

Implemented in RakPeer.

virtual void RakPeerInterface::ApplyNetworkSimulator | ( | double | maxSendBPS,
 |  | unsigned short | minExtraPing,
 |  | unsigned short | extraPingVariance |
 | ) |  |  | [pure virtual]

Adds simulated ping and packet loss to the outgoing data flow. To simulate bi-directional ping and packet loss, you should call this on both the sender and the recipient, with half the total ping and maxSendBPS value on each. You can exclude network simulator code with the _RELEASE define to decrease code size

Parameters:
[in] | maxSendBPS | Maximum bits per second to send. Packetloss grows linearly. 0 to disable. (CURRENTLY BROKEN - ALWAYS DISABLED)
[in] | minExtraPing | The minimum time to delay sends.

Implemented in RakPeer.

virtual void RakPeerInterface::SetPerConnectionOutgoingBandwidthLimit ( unsigned maxBitsPerSecond ) [pure virtual]

Limits how much outgoing bandwidth can be sent per-connection. This limit does not apply to the sum of all connections! Exceeding the limit queues up outgoing traffic

Parameters:
[in] maxBitsPerSecond Maximum bits per second to send. Use 0 for unlimited (default). Once set, it takes effect immedately and persists until called again.

Implemented in RakPeer.

virtual bool RakPeerInterface::IsNetworkSimulatorActive ( void ) [pure virtual]

Returns if you previously called ApplyNetworkSimulator

Returns:
If you previously called ApplyNetworkSimulator

Implemented in RakPeer.

virtual RakNetStatistics* const RakPeerInterface::GetStatistics ( const SystemAddress systemAddress ) [pure virtual]

Returns a structure containing a large set of network statistics for the specified system. You can map this data to a string using the C style StatisticsToString() function

Parameters:
[in] systemAddress,: Which connected system to get statistics for
Returns:
0 on can't find the specified system. A pointer to a set of data otherwise.
See also:
RakNetStatistics.h

Implemented in RakPeer.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/RakPeerInterface.h
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::RakString Class Reference

RakNet::RakString

RakNet::RakString Class Reference

String class Has the following improvements over std::string Reference counting: Suitable to store in lists Varidic assignment operator Doesn't cause linker errors. More...

#include <RakString.h>

List of all members.

Public Member Functions

RakString ()
Constructors.
operator const char * () const
Implicit return of const char*.
const char * | C_String (void) const
Same as std::string::c_str.
RakString & | operator= (const RakString &rhs)
Assigment operators.
RakString & | operator+= (const RakString &rhs)
Concatenation.
unsigned char | operator[] (const unsigned int position) const
Character index. Do not use to change the string however.
bool | operator== (const RakString &rhs) const
Equality.
bool | operator!= (const RakString &rhs) const
Inequality.
void | ToLower (void)
Change all characters to lowercase.
void | ToUpper (void)
Change all characters to uppercase.
void | Set (const char *format,...)
Set the value of the string.
bool | IsEmpty (void) const
Returns if the string is empty. Also, C_String() would return "".
size_t | GetLength (void) const
Returns the length of the string.
void | Replace (unsigned index, unsigned count, unsigned char c)
Replace character(s) in starting at index, for count, with c.
void | Erase (unsigned index, unsigned count)
Erase characters out of the string at index for count.
int | StrCmp (const RakString &rhs) const
Compare strings (case sensitive).
int | StrICmp (const RakString &rhs) const
Compare strings (not case sensitive).
void | Clear (void)
Clear the string.
void | Printf (void)
Print the string to the screen.
void | FPrintf (FILE *fp)
Print the string to a file.
bool | IPAddressMatch (const char *IP)
Does the given IP address match the IP address encoded into this string, accounting for wildcards?
void | URLEncode (void)
URL Encode the string. See http://www.codeguru.com/cpp/cpp/cpp_mfc/article.php/c4029/.
void | Serialize (BitStream *bs)
void | SerializeCompressed (BitStream *bs, int languageId=0, bool writeLanguageId=false)
bool | Deserialize (BitStream *bs)
bool | DeserializeCompressed (BitStream *bs, bool readLanguageId=false)

Static Public Member Functions

static void | FreeMemory (void)
static void | Serialize (const char *str, BitStream *bs)
Static version of the Serialize function.
static void | SerializeCompressed (const char *str, BitStream *bs, int languageId=0, bool writeLanguageId=false)
Static version of the SerializeCompressed function.
static bool | Deserialize (char *str, BitStream *bs)
Static version of the Deserialize() function.
static bool | DeserializeCompressed (char *str, BitStream *bs, bool readLanguageId=false)
Static version of the DeserializeCompressed() function.

Static Public Attributes

static unsigned int | nPos
Means undefined position.

Detailed Description

String class Has the following improvements over std::string Reference counting: Suitable to store in lists Varidic assignment operator Doesn't cause linker errors.

Member Function Documentation

void RakString::FreeMemory ( void ) [static]

RakString uses a freeList of old no-longer used strings Call this function to clear this memory on shutdown

void RakString::Serialize ( BitStream * bs )

Serialize to a bitstream, uncompressed (slightly faster)

Parameters:
[out] bs Bitstream to serialize to

void RakString::SerializeCompressed | ( | BitStream * | bs,
 |  | int | languageId = 0,
 |  | bool | writeLanguageId = false
 | ) |  |

Serialize to a bitstream, compressed (better bandwidth usage)

Parameters:
[out] | bs | Bitstream to serialize to
[in] | languageId | languageId to pass to the StringCompressor class
[in] | writeLanguageId | encode the languageId variable in the stream. If false, 0 is assumed, and DeserializeCompressed will not look for this variable in the stream (saves bandwidth)
Precondition:
StringCompressor::AddReference must have been called to instantiate the class (Happens automatically from RakPeer::Startup())

bool RakString::Deserialize ( BitStream * bs )

Deserialize what was written by Serialize

Parameters:
[in] bs Bitstream to serialize from
Returns:
true if the deserialization was successful

bool RakString::DeserializeCompressed | ( | BitStream * | bs,
 |  | bool | readLanguageId = false
 | ) |  |

Deserialize compressed string, written by SerializeCompressed

Parameters:
[in] | bs | Bitstream to serialize from
[in] | readLanguageId | If true, looks for the variable langaugeId in the data stream. Must match what was passed to SerializeCompressed
Returns:
true if the deserialization was successful
Precondition:
StringCompressor::AddReference must have been called to instantiate the class (Happens automatically from RakPeer::Startup())

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/RakString.h
  • C:/RakNet/Source/RakString.cpp
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RankingServer_PostgreSQL Class Reference

RankingServer_PostgreSQL Class Reference

#include <RankingServer_PostgreSQL.h>

List of all members.

Public Member Functions

bool | CreateRankingServerTables (void)
bool | DestroyRankingServerTables (void)
virtual void | PushFunctor (RankingServerFunctor *functor, void *context=0)
void | AssignCallback (RankingServerCBInterface *cb)

Friends

class | SubmitMatch_PostgreSQLImpl
class | ModifyTrustedIPList_PostgreSQLImpl
class | GetRatingForParticipant_PostgreSQLImpl
class | GetRatingForParticipants_PostgreSQLImpl
class | GetHistoryForParticipant_PostgreSQLImpl

Detailed Description

Provides a central class for all RankingServer functionality using the PostgreSQL interface If you are using more than one class that uses functionThreads, you should maintain this separately and call AssignFunctionThread() to avoid unnecessary threads.

Member Function Documentation

bool RankingServer_PostgreSQL::CreateRankingServerTables ( void )

Create the tables used by the ranking server, for all applications. Call this first. I recommend using UTF8 for the database encoding within PostgreSQL if you are going to store binary data

Returns:
True on success, false on failure.

bool RankingServer_PostgreSQL::DestroyRankingServerTables ( void )

Destroy the tables used by the ranking server. Don't call this unless you don't want to use the ranking server anymore, or are testing.

Returns:
True on success, false on failure.

void RankingServer_PostgreSQL::PushFunctor | ( | RankingServerFunctor * | functor,
 |  | void * | context = 0 |
 | ) |  |  | [virtual]

Push one of the above *_PostgreSQLImpl functors to run.

Parameters:
functor A structure allocated on the HEAP (using new) with the input parameters filled in.

void RankingServer_PostgreSQL::AssignCallback ( RankingServerCBInterface * cb )

Assigns a callback to get the results of processing.

Parameters:
[in] A structure allocated on the HEAP (using new) with the input parameters filled in.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.h
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.cpp
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RankingServerCBInterface Class Reference

RankingServerCBInterface Class Reference

If you want to forward Functor::HandleResult() the output to a callback (which is what it does by default), you can use this. More...

#include <RankingServer_PostgreSQL.h>

Inheritance diagram for RankingServerCBInterface:

RakNet::LobbyServerPostgreSQL List of all members.

Detailed Description

If you want to forward Functor::HandleResult() the output to a callback (which is what it does by default), you can use this.

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.h
Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ReadyEvent Class Reference

ReadyEvent Class Reference
[ReadyEvent]

#include <ReadyEvent.h>

Inheritance diagram for ReadyEvent:

PluginInterface List of all members.

Public Member Functions

ReadyEvent ()
Constructor.
virtual | ~ReadyEvent ()
Destructor.
bool | SetEvent (int eventId, bool isReady)
bool | DeleteEvent (int eventId)
bool | IsEventSet (int eventId)
bool | IsEventCompletionProcessing (int eventId) const
bool | IsEventCompleted (int eventId) const
bool | HasEvent (int eventId)
unsigned | GetEventListSize (void) const
int | GetEventAtIndex (unsigned index) const
bool | AddToWaitList (int eventId, SystemAddress address)
bool | RemoveFromWaitList (int eventId, SystemAddress address)
bool | IsInWaitList (int eventId, SystemAddress address)
unsigned | GetRemoteWaitListSize (int eventId) const
SystemAddress | GetFromWaitListAtIndex (int eventId, unsigned index) const
ReadyEventSystemStatus | GetReadyStatus (int eventId, SystemAddress address)
void | SetSendChannel (unsigned char newChannel)

Protected Member Functions

void | OnAttach (RakPeerInterface *peer)
virtual PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
virtual void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)
virtual void | OnShutdown (RakPeerInterface *peer)

Detailed Description

Ready event plugin Used to signal event completion when a set of systems all set a signal flag to true. This is usually used for lobby systems, or peer to peer turn based environments. The user will get ID_READY_EVENT_SET and ID_READY_EVENT_UNSET as the signal flag is set or unset The user will get ID_READY_EVENT_ALL_SET when all systems are done waiting for all other systems, in which case the event is considered complete, and no longer tracked.

Member Function Documentation

bool ReadyEvent::SetEvent | ( | int | eventId,
 |  | bool | isReady
 | ) |  |

Sets or updates the initial ready state for our local system. If eventId is an unknown event the event is created. If eventId was previously used and you want to reuse it, call DeleteEvent first, or else you will keep the same event signals from before Systems previously or later added through AddToWaitList() with the same eventId when isReady=true will get ID_READY_EVENT_SET Systems previously added through AddToWaitList with the same eventId will get ID_READY_EVENT_UNSET For both ID_READY_EVENT_SET and ID_READY_EVENT_UNSET, eventId is encoded in bytes 1 through 1+sizeof(int)

Parameters:
[in] | eventId | A user-defined identifier to wait on. This can be a sequence counter, an event identifier, or anything else you want.
[in] | isReady | True to signal we are ready to proceed with this event, false to unsignal
Returns:
True on success. False (failure) on unknown eventId

bool ReadyEvent::DeleteEvent ( int eventId )

Deletes an event. We will no longer wait for this event, and any systems that we know have set the event will be forgotten. Call this to clear memory when events are completed and you know you will never need them again.

Parameters:
[in] eventId A user-defined identifier
Returns:
True on success. False (failure) on unknown eventId

bool ReadyEvent::IsEventSet ( int eventId )

Returns what was passed to SetEvent()

Returns:
The value of isReady passed to SetEvent(). Also returns false on unknown event.

bool ReadyEvent::IsEventCompletionProcessing ( int eventId ) const

Returns if the event is about to be ready and we are negotiating the final packets. This will usually only be true for a very short time, after which IsEventCompleted should return true. While this is true you cannot add to the wait list, or SetEvent() isReady to false anymore.

Parameters:
[in] eventId A user-defined identifier
Returns:
True if any other system has completed processing. Will always be true if IsEventCompleted() is true

bool ReadyEvent::IsEventCompleted ( int eventId ) const

Returns if the wait list is a subset of the completion list. Call this after all systems you want to wait for have been added with AddToWaitList If you are waiting for a specific number of systems (such as players later connecting), also check GetRemoteWaitListSize(eventId) to be equal to 1 less than the total number of participants.

Parameters:
[in] eventId A user-defined identifier
Returns:
True on completion. False (failure) on unknown eventId, or the set is not completed.

bool ReadyEvent::HasEvent ( int eventId )

Returns if this is a known event. Events may be known even if we never ourselves referenced them with SetEvent, because other systems created them via ID_READY_EVENT_SET.

Parameters:
[in] eventId A user-defined identifier
Returns:
true if we have this event, false otherwise

unsigned ReadyEvent::GetEventListSize ( void ) const

Returns the total number of events stored in the system.

Returns:
The total number of events stored in the system.

int ReadyEvent::GetEventAtIndex ( unsigned index ) const

Returns the event ID stored at a particular index. EventIDs are stored sorted from least to greatest.

Parameters:
[in] index Index into the array, from 0 to GetEventListSize()
Returns:
The event ID stored at a particular index

bool ReadyEvent::AddToWaitList | ( | int | eventId,
 |  | SystemAddress | address
 | ) |  |

Adds a system to wait for to signal an event before considering the event complete and returning ID_READY_EVENT_ALL_SET. As we add systems, if this event was previously set to true with SetEvent, these systems will get ID_READY_EVENT_SET. As these systems disconnect (directly or indirectly through the router) they are removed.

Note:
If the event completion process has already started, you cannot add more systems, as this would cause the completion process to fail
Parameters:
[in] | eventId | A user-defined number previously passed to SetEvent that has not yet completed
[in] | addressArray | An address to wait for event replies from. Pass UNASSIGNED_SYSTEM_ADDRESS for all currently connected systems. Until all systems in this list have called SetEvent with this ID and true, and have this system in the list, we won't get ID_READY_EVENT_COMPLETE
Returns:
True on success, false on unknown eventId (this should be considered an error), or if the completion process has already started.

bool ReadyEvent::RemoveFromWaitList | ( | int | eventId,
 |  | SystemAddress | address
 | ) |  |

Removes systems from the wait list, which should have been previously added with AddToWaitList

Note:
Systems that directly or indirectly disconnect from us are automatically removed from the wait list
Parameters:
[in] address The system to remove from the wait list. Pass UNASSIGNED_SYSTEM_ADDRESS for all currently connected systems.
Returns:
True on success, false on unknown eventId (this should be considered an error)

bool ReadyEvent::IsInWaitList | ( | int | eventId,
 |  | SystemAddress | address
 | ) |  |

Returns if a particular system is waiting on a particular event.

Parameters:
[in] | eventId | A user-defined identifier
[in] | The | address of the system we are checking up on
Returns:
True if this system is waiting on this event, false otherwise.

unsigned ReadyEvent::GetRemoteWaitListSize ( int eventId ) const

Returns the total number of systems we are waiting on for this event. Does not include yourself

Parameters:
[in] eventId A user-defined identifier
Returns:
The total number of systems we are waiting on for this event.

SystemAddress ReadyEvent::GetFromWaitListAtIndex | ( | int | eventId,
 |  | unsigned | index |
 | ) |  |  | const

Returns the system address of a system at a particular index, for this event.

Parameters:
[in] | eventId | A user-defined identifier
[in] | index | Index into the array, from 0 to GetWaitListSize()
Returns:
The system address of a system at a particular index, for this event.

ReadyEventSystemStatus ReadyEvent::GetReadyStatus | ( | int | eventId,
 |  | SystemAddress | address
 | ) |  |

For a remote system, find out what their ready status is (waiting, signaled, complete).

Parameters:
[in] | eventId | A user-defined identifier
[in] | address | Which system we are checking up on
Returns:
The status of this system, for this particular event.
See also:
ReadyEventSystemStatus

void ReadyEvent::SetSendChannel ( unsigned char newChannel )

This channel will be used for all RakPeer::Send calls

Parameters:
[in] newChannel The channel to use for internal RakPeer::Send calls from this system. Defaults to 0.

void ReadyEvent::OnAttach ( RakPeerInterface * peer ) [protected, virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult ReadyEvent::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [protected, virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void ReadyEvent::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [protected, virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

void ReadyEvent::OnShutdown ( RakPeerInterface * peer ) [protected, virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/ReadyEvent.h
  • C:/RakNet/Source/ReadyEvent.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ReceiveConstructionInterface Class Reference

ReceiveConstructionInterface Class Reference
[ReplicaManager]

#include <ReplicaManager.h>

List of all members.

Public Member Functions

virtual ReplicaReturnResult ReceiveConstruction (RakNet::BitStream *inBitStream, RakNetTime timestamp, NetworkID networkID, NetworkIDObject *existingObject, SystemAddress senderId, ReplicaManager *caller)=0

Detailed Description

An interface for a class that handles the construction callback from the network See ReplicaManager::SetReceiveConstructionCB

Member Function Documentation

virtual ReplicaReturnResult ReceiveConstructionInterface::ReceiveConstruction | ( | RakNet::BitStream * | inBitStream,
 |  | RakNetTime | timestamp,
 |  | NetworkID | networkID,
 |  | NetworkIDObject * | existingObject,
 |  | SystemAddress | senderId,
 |  | ReplicaManager * | caller |
 | ) |  |  | [pure virtual]

Called when a network object needs to be created by the ReplicaManager class

Parameters:
[in] | inBitStream | The bitstream that was written to in Replica::SendConstruction
[in] | timestamp | If in Replica::SendConstruction you set sendTimestamp to true, this is the time the packet was sent. Otherwise it is 0.
[in] | networkID | If the remote object had an NetworkID set by the time Replica::SendConstruction was called it is here.
[in] | existingNetworkObject | If networkID is already in use, existingNetworkObject is the pointer to that object. If existingReplica is non-zero, you usually shouldn't create a new object, unless you are reusing networkIDs, such as having the client and server both on the same computer
[in] | senderId | Which SystemAddress sent this packet.
[in] | caller | Which instance of ReplicaManager is calling this interface
Returns:
See ReplicaReturnResult

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/ReplicaManager.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ReceiveDownloadCompleteInterface Class Reference

ReceiveDownloadCompleteInterface Class Reference
[ReplicaManager]

#include <ReplicaManager.h>

List of all members.

Public Member Functions

virtual ReplicaReturnResult ReceiveDownloadComplete (RakNet::BitStream *inBitStream, SystemAddress senderId, ReplicaManager *caller)=0

Detailed Description

An interface for a class that handles the call to receive the download complete notification See ReplicaManager::SetDownloadCompleteCB

Member Function Documentation

virtual ReplicaReturnResult ReceiveDownloadCompleteInterface::ReceiveDownloadComplete | ( | RakNet::BitStream * | inBitStream,
 |  | SystemAddress | senderId,
 |  | ReplicaManager * | caller |
 | ) |  |  | [pure virtual]

Parameters:
[in] | inBitStream | The bitstream that was written to in SendDownloadCompleteInterface::SendDownloadComplete
[in] | senderId | The SystemAddress of the system that send the datagram
[in] | caller | Which instance of ReplicaManager is calling this interface
Returns:
See ReplicaReturnResult

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/ReplicaManager.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RefCountedObj Class Reference

RefCountedObj Class Reference

World's simplest class :). More...

#include <RefCountedObj.h>

Inheritance diagram for RefCountedObj:

LobbyDBSpec::AddAccountNote_Data LobbyDBSpec::AddFriend_Data LobbyDBSpec::AddToIgnoreList_Data LobbyDBSpec::CreateUser_Data LobbyDBSpec::DeleteEmail_Data LobbyDBSpec::GetAccountNotes_Data LobbyDBSpec::GetEmails_Data LobbyDBSpec::GetFriends_Data LobbyDBSpec::GetIgnoreList_Data LobbyDBSpec::GetUser_Data LobbyDBSpec::RemoveFriend_Data LobbyDBSpec::RemoveFromIgnoreList_Data LobbyDBSpec::SendEmail_Data LobbyDBSpec::UpdateEmailStatus_Data LobbyDBSpec::UpdateUser_Data RankingServerDBSpec::GetHistoryForParticipant_Data RankingServerDBSpec::GetRatingForParticipant_Data RankingServerDBSpec::GetRatingForParticipants_Data RankingServerDBSpec::GetTrustedIPList_Data RankingServerDBSpec::ModifyTrustedIPList_Data RankingServerDBSpec::SubmitMatch_Data TitleValidationDBSpec::AddTitle_Data TitleValidationDBSpec::GetTitles_Data TitleValidationDBSpec::UpdateUserKey_Data List of all members.

Detailed Description

World's simplest class :).

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/RefCountedObj.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ReliabilityLayer Class Reference

ReliabilityLayer Class Reference

Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence. More...

#include <ReliabilityLayer.h>

List of all members.

Public Member Functions

ReliabilityLayer ()
Constructor.
~ReliabilityLayer ()
Destructor.
void | Reset (bool resetVariables)
Resets the layer for reuse.
void | SetEncryptionKey (const unsigned char *key)
void | SetTimeoutTime (RakNetTime time)
RakNetTime | GetTimeoutTime (void)
bool | HandleSocketReceiveFromConnectedPlayer (const char *buffer, unsigned int length, SystemAddress systemAddress, DataStructures::List< PluginInterface * > &messageHandlerList, int MTUSize)
BitSize_t | Receive (unsigned char **data)
bool | Send (char *data, BitSize_t numberOfBitsToSend, PacketPriority priority, PacketReliability reliability, unsigned char orderingChannel, bool makeDataCopy, int MTUSize, RakNetTimeNS currentTime)
void | Update (SOCKET s, SystemAddress systemAddress, int MTUSize, RakNetTimeNS time, unsigned maxBitsPerSecond, DataStructures::List< PluginInterface * > &messageHandlerList)
bool | IsCheater (void) const
bool | IsDeadConnection (void) const
void | KillConnection (void)
Causes IsDeadConnection to return true.
RakNetStatistics *const | GetStatistics (void)
bool | IsOutgoingDataWaiting (void)
Are we waiting for any data to be sent out or be processed by the player?
bool | IsNetworkSimulatorActive (void)
bool | AckTimeout (RakNetTimeNS curTime)
Has a lot of time passed since the last ack.

Detailed Description

Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence.

Member Function Documentation

void ReliabilityLayer::SetEncryptionKey ( const unsigned char * key )

Sets the encryption key. Doing so will activate secure connections

Parameters:
[in] key Byte stream for the encryption key

void ReliabilityLayer::SetTimeoutTime ( RakNetTime time )

Set the time, in MS, to use before considering ourselves disconnected after not being able to deliver a reliable packet Default time is 10,000 or 10 seconds in release and 30,000 or 30 seconds in debug.

Parameters:
[in] time Time, in MS

RakNetTime ReliabilityLayer::GetTimeoutTime ( void )

Returns the value passed to SetTimeoutTime. or the default if it was never called

Parameters:
[out] the value passed to SetTimeoutTime

bool ReliabilityLayer::HandleSocketReceiveFromConnectedPlayer | ( | const char * | buffer,
 |  | unsigned int | length,
 |  | SystemAddress | systemAddress,
 |  | DataStructures::List< PluginInterface * > & | messageHandlerList,
 |  | int | MTUSize
 | ) |  |

Packets are read directly from the socket layer and skip the reliability layer because unconnected players do not use the reliability layer This function takes packet data after a player has been confirmed as connected.

Parameters:
[in] | buffer | The socket data
[in] | length | The length of the socket data
[in] | systemAddress | The player that this data is from
[in] | messageHandlerList | A list of registered plugins
[in] | MTUSize | maximum datagram size
Return values:
true | Success
false | Modified packet

BitSize_t ReliabilityLayer::Receive ( unsigned char ** data )

This allocates bytes and writes a user-level message to those bytes.

Parameters:
[out] data The message
Returns:
Returns number of BITS put into the buffer

bool ReliabilityLayer::Send | ( | char * | data,
 |  | BitSize_t | numberOfBitsToSend,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | unsigned char | orderingChannel,
 |  | bool | makeDataCopy,
 |  | int | MTUSize,
 |  | RakNetTimeNS | currentTime
 | ) |  |

Puts data on the send queue

Parameters:
[in] | data | The data to send
[in] | numberOfBitsToSend | The length of data in bits
[in] | priority | The priority level for the send
[in] | reliability | The reliability type for the send
[in] | orderingChannel | 0 to 31. Specifies what channel to use, for relational ordering and sequencing of packets.
[in] | makeDataCopy | If true data will be copied. Otherwise, only a pointer will be stored.
[in] | MTUSize | maximum datagram size
[in] | currentTime | Current time, as per RakNet::GetTime()
Returns:
True or false for success or failure.

void ReliabilityLayer::Update | ( | SOCKET | s,
 |  | SystemAddress | systemAddress,
 |  | int | MTUSize,
 |  | RakNetTimeNS | time,
 |  | unsigned | maxBitsPerSecond,
 |  | DataStructures::List< PluginInterface * > & | messageHandlerList
 | ) |  |

Call once per game cycle. Handles internal lists and actually does the send.

Parameters:
[in] | s | the communication end point
[in] | systemAddress | The Unique Player Identifier who shouldhave sent some packets
[in] | MTUSize | maximum datagram size
[in] | time | current system time
[in] | maxBitsPerSecond | if non-zero, enforces that outgoing bandwidth does not exceed this amount
[in] | messageHandlerList | A list of registered plugins

bool ReliabilityLayer::IsCheater ( void ) const

If Read returns -1 and this returns true then a modified packetwas detected

Returns:
true when a modified packet is detected

bool ReliabilityLayer::IsDeadConnection ( void ) const

Were you ever unable to deliver a packet despite retries?

Returns:
true means the connection has been lost. Otherwise not.

RakNetStatistics *const ReliabilityLayer::GetStatistics ( void )

Get Statistics

Returns:
A pointer to a static struct, filled out with current statistical information.

bool ReliabilityLayer::IsNetworkSimulatorActive ( void )

Returns if you previously called ApplyNetworkSimulator

Returns:
If you previously called ApplyNetworkSimulator

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/ReliabilityLayer.h
  • C:/RakNet/Source/ReliabilityLayer.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RemoteClient Struct Reference

RemoteClient Struct Reference

Stores information about a remote client. More...

#include <TCPInterface.h>

List of all members.

Detailed Description

Stores information about a remote client.

The documentation for this struct was generated from the following files:
  • C:/RakNet/Source/TCPInterface.h
  • C:/RakNet/Source/TCPInterface.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::RemoveFriend_Data Class Reference

LobbyDBSpec::RemoveFriend_Data

LobbyDBSpec::RemoveFriend_Data Class Reference

Removes a userId / friendId from the friends table. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::RemoveFriend_Data:

RefCountedObj List of all members.

Public Attributes

AddFriend_Data removeFriendInput

Detailed Description

Removes a userId / friendId from the friends table.

Member Data Documentation

AddFriend_Data LobbyDBSpec::RemoveFriend_Data::removeFriendInput

[in] Same fields as AddFriend_Data, but the operation performed is different.

Note:
Bad input, such as removing someone that is not your friend, simply does nothing

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::RemoveFromIgnoreList_Data Class Reference

LobbyDBSpec::RemoveFromIgnoreList_Data

LobbyDBSpec::RemoveFromIgnoreList_Data Class Reference

Removes from the ignoreList table for a particular userId / userHandle. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::RemoveFromIgnoreList_Data:

RefCountedObj List of all members.

Public Attributes

RowIdOrHandle id
[in] Which user

Detailed Description

Removes from the ignoreList table for a particular userId / userHandle.

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Replica Class Reference

Replica Class Reference
[ReplicaManager]

The interface to derive your game's networked classes from. More...

#include <Replica.h>

Inheritance diagram for Replica:

NetworkIDObject List of all members.

Public Member Functions

virtual ReplicaReturnResult | SendConstruction (RakNetTime currentTime, SystemAddress systemAddress, unsigned int &flags, RakNet::BitStream *outBitStream, bool *includeTimestamp)=0
virtual ReplicaReturnResult | SendDestruction (RakNet::BitStream *outBitStream, SystemAddress systemAddress, bool *includeTimestamp)=0
virtual ReplicaReturnResult | ReceiveDestruction (RakNet::BitStream *inBitStream, SystemAddress systemAddress, RakNetTime timestamp)=0
virtual ReplicaReturnResult | SendScopeChange (bool inScope, RakNet::BitStream *outBitStream, RakNetTime currentTime, SystemAddress systemAddress, bool *includeTimestamp)=0
virtual ReplicaReturnResult | ReceiveScopeChange (RakNet::BitStream *inBitStream, SystemAddress systemAddress, RakNetTime timestamp)=0
virtual ReplicaReturnResult | Serialize (bool *sendTimestamp, RakNet::BitStream *outBitStream, RakNetTime lastSendTime, PacketPriority *priority, PacketReliability *reliability, RakNetTime currentTime, SystemAddress systemAddress, unsigned int &flags)=0
virtual ReplicaReturnResult | Deserialize (RakNet::BitStream *inBitStream, RakNetTime timestamp, RakNetTime lastDeserializeTime, SystemAddress systemAddress)=0
virtual int | GetSortPriority (void) const =0

Detailed Description

The interface to derive your game's networked classes from.

This is an interface of a replicated object for use in the framework of ReplicaManager You should derive from this class, implementing the functions to provide the behavior you want. If your architecture doesn't allow you to derive from this class, you can store an instance of a derived instance of this class in your base game object. In that case, use GetParent() and SetParent() and propagate the function calls up to your real classes. For an example where I do this, see Monster.h in the ReplicaManagerCS sample.

Note:
All send functions are called one for every target recipient, so you can customize the data sent per-user.

Member Function Documentation

virtual ReplicaReturnResult Replica::SendConstruction | ( | RakNetTime | currentTime,
 |  | SystemAddress | systemAddress,
 |  | unsigned int & | flags,
 |  | RakNet::BitStream * | outBitStream,
 |  | bool * | includeTimestamp |
 | ) |  |  | [pure virtual]

This function is called in the first update tick after this object is first passed to ReplicaManager::Replicate for each player, and also when a new participant joins The intent of this function is to tell another system to create an instance of this class. You can do this however you want - I recommend having each class having a string identifier which is registered with StringTable, and then using EncodeString to write the name of the class. In the callback passed to SetReceiveConstructionCB create an instance of the object based on that string.

Note:
If you return true from IsNetworkIDAuthority, which you should do for a server or peer, I recommend encoding the value returned by GetNetworkID() into your bitstream and calling SetNetworkID with that value in your SetReceiveConstructionCB callback.

Dereplicate, SetScope, and SignalSerializeNeeded all rely on being able to call GET_OBJECT_FROM_ID which requires that SetNetworkID be called on that object.

SendConstruction is called once for every new player that connects and every existing player when an object is passed to Replicate.

Parameters:
[in] | currentTime | The current time that would be returned by RakNet::GetTime(). That's a slow call I do already, so you can use the parameter instead of having to call it yourself.
[in] | systemAddress | The participant to send to.
[in,out] | flags | Per-object per-system serialization flags modified by this function, ReplicaManager::SignalSerializationFlags, and ReplicaManager::AccessSerializationFlags. Useful for simple customization of what you serialize based on application events. This value is not automatically reset.
[out] | outBitStream | The data you want to write in the message. If you do not write to outBitStream and return true, then no send call will occur and the system will consider this object as not created on that remote system.
[out] | includeTimestamp | Set to true to include a timestamp with the message. This will be reflected in the timestamp parameter of the callback. Defaults to false.
Returns:
See ReplicaReturnResult

virtual ReplicaReturnResult Replica::SendDestruction | ( | RakNet::BitStream * | outBitStream,
 |  | SystemAddress | systemAddress,
 |  | bool * | includeTimestamp |
 | ) |  |  | [pure virtual]

The purpose of the function is to send a packet containing the data in outBitStream to systemAddress telling that system that Dereplicate was called. In the code, this is called in the update cycle after you call ReplicaManager::Destruct(). Then, if you write to outBitStream, a message is sent to that participant. This is the one send you cannot delay because objects may be deleted and we can't read into them past this.

Parameters:
[out] | outBitStream | The data to send. If you do not write to outBitStream, then no send call will occur
[in] | systemAddress | The participant to send to.
[out] | includeTimestamp | Set to true to include a timestamp with the message. This will be reflected in the timestamp parameter of the callback. Defaults to false.
Returns:
See ReplicaReturnResult

virtual ReplicaReturnResult Replica::ReceiveDestruction | ( | RakNet::BitStream * | inBitStream,
 |  | SystemAddress | systemAddress,
 |  | RakNetTime | timestamp |
 | ) |  |  | [pure virtual]

This function is called when SendDestruction is sent from another system. Delete your object if you want.

Parameters:
[in] | inBitStream | What was sent in SendDestruction::outBitStream
[in] | systemAddress | The participant that sent this message to us.
[in] | timestamp | if Serialize::SendDestruction was set to true, the time the packet was sent.
Returns:
See ReplicaReturnResult. Only REPLICA_PROCESSING_DONE is valid, and will send the destruction message. Anything else will not send any messages.

virtual ReplicaReturnResult Replica::SendScopeChange | ( | bool | inScope,
 |  | RakNet::BitStream * | outBitStream,
 |  | RakNetTime | currentTime,
 |  | SystemAddress | systemAddress,
 |  | bool * | includeTimestamp |
 | ) |  |  | [pure virtual]

Called when ReplicaManager::SetScope is called with a different value than what it currently has. It is up to you to write inScope to outBitStream. Not doing so, and returning true, means you want to cancel the scope change call. If inScope is true, you return true, and data is written to outBitStream, then Serialize will be called automatically This is a convenience feature, since there's almost no case where an object would go in scope but not be serialized

Parameters:
[in] | inScope | The new scope that will be sent to ReceiveScopeChange that originally came from SetScope
[out] | outBitStream | The data to send. If you do not write to outBitStream and return true, then no send will occur and the object will keep its existing scope
[in] | currentTime | The current time that would be returned by RakNet::GetTime(). That's a slow call I do already, so you can use the parameter instead of having to call it yourself.
[in] | systemAddress | The participant to send to.
[out] | includeTimestamp | Set to true to include a timestamp with the message. This will be reflected in the timestamp parameter of the callback. Defaults to false.
Returns:
See ReplicaReturnResult

virtual ReplicaReturnResult Replica::ReceiveScopeChange | ( | RakNet::BitStream * | inBitStream,
 |  | SystemAddress | systemAddress,
 |  | RakNetTime | timestamp |
 | ) |  |  | [pure virtual]

Called when when we get the SendScopeChange message. The new scope should have been encoded (by you) into inBitStream

Parameters:
[in] | inBitStream | What was sent in SendScopeChange::outBitStream
[in] | systemAddress | The participant that sent this message to us.
[in] | timestamp | if Serialize::SendScopeChange was set to true, the time the packet was sent.
Returns:
See ReplicaReturnResult

virtual ReplicaReturnResult Replica::Serialize | ( | bool * | sendTimestamp,
 |  | RakNet::BitStream * | outBitStream,
 |  | RakNetTime | lastSendTime,
 |  | PacketPriority * | priority,
 |  | PacketReliability * | reliability,
 |  | RakNetTime | currentTime,
 |  | SystemAddress | systemAddress,
 |  | unsigned int & | flags |
 | ) |  |  | [pure virtual]

Called when ReplicaManager::SignalSerializeNeeded is called with this object as the parameter. The system will ensure that Serialize only occurs for participants that have this object constructed and in scope The intent of this function is to serialize all your class member variables for remote transmission.

Parameters:
[out] | sendTimestamp | Set to true to include a timestamp with the message. This will be reflected in the timestamp parameter Deserialize. Defaults to false.
[out] | outBitStream | The data you want to write in the message. If you do not write to outBitStream and return true, then no send will occur for this participant.
[in] | lastSendTime | The last time Serialize returned true and outBitStream was written to. 0 if this is the first time the function has ever been called for this systemAddress
[in] | priority | Passed to RakPeer::Send for the send call.
[in] | reliability | Passed to RakPeer::Send for the send call.
[in] | currentTime | The current time that would be returned by RakNet::GetTime(). That's a slow call I do already, so you can use the parameter instead of having to call it yourself.
[in] | systemAddress | The participant we are sending to.
[in,out] | flags | Per-object per-system serialization flags modified by this function, ReplicaManager::SignalSerializationFlags, and ReplicaManager::AccessSerializationFlags. Useful for simple customization of what you serialize based on application events. This value is not automatically reset.
Returns:
See ReplicaReturnResult

virtual ReplicaReturnResult Replica::Deserialize | ( | RakNet::BitStream * | inBitStream,
 |  | RakNetTime | timestamp,
 |  | RakNetTime | lastDeserializeTime,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [pure virtual]

Called when another participant called Serialize with our system as the target

Parameters:
[in] | inBitStream | What was written to Serialize::outBitStream
[in] | timestamp | if Serialize::SendTimestamp was set to true, the time the packet was sent.
[in] | lastDeserializeTime | Last time you returned true from this function for this object, or 0 if never, regardless of systemAddress.
[in] | systemAddress | The participant that sent this message to us.

virtual int Replica::GetSortPriority ( void ) const [pure virtual]

Used to sort the order that commands (construct, serialize) take place in. Lower sort priority commands happen before higher sort priority commands. Same sort priority commands take place in random order. For example, if both players and player lists are replicas, you would want to create the players before the player lists if the player lists refer to the players. So you could specify the players as priority 0, and the lists as priority 1, and the players would be created and serialized first

Returns:
A higher value to process later, a lower value to process sooner, the same value to process in random order.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/Replica.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::Replica2 Class Reference

RakNet::Replica2

RakNet::Replica2 Class Reference
[ReplicaManager2]

Base class for game objects that use the ReplicaManager2 system All game objects that want to use the ReplicaManager2 functionality must inherit from Replica2. Generally you will want to implement at a minimum Serialize(), Deserialize(), and SerializeConstruction(). More...

#include <ReplicaManager2.h>

Inheritance diagram for RakNet::Replica2:

NetworkIDObject List of all members.

Public Member Functions

Replica2 ()
Constructor.
virtual | ~Replica2 ()
Destructor.
void | SetReplicaManager (ReplicaManager2 *rm)
ReplicaManager2 * | GetReplicaManager (void) const
virtual void | SendConstruction (SystemAddress recipientAddress, SerializationType serializationType=UNDEFINED_REASON)
virtual void | SendDestruction (SystemAddress recipientAddress, SerializationType serializationType=UNDEFINED_REASON)
virtual void | SendSerialize (SystemAddress recipientAddress, SerializationType serializationType=UNDEFINED_REASON)
virtual void | SendVisibility (SystemAddress recipientAddress, SerializationType serializationType=UNDEFINED_REASON)
virtual void | BroadcastConstruction (SerializationContext *serializationContext=0)
virtual void | BroadcastSerialize (SerializationContext *serializationContext=0)
virtual void | BroadcastDestruction (SerializationContext *serializationContext=0)
virtual void | BroadcastVisibility (bool isVisible, SerializationContext *serializationContext=0)
virtual bool | SerializeConstruction (RakNet::BitStream *bitStream, SerializationContext *serializationContext)=0
virtual bool | SerializeDestruction (RakNet::BitStream *bitStream, SerializationContext *serializationContext)
virtual bool | Serialize (RakNet::BitStream *bitStream, SerializationContext *serializationContext)
virtual bool | SerializeVisibility (RakNet::BitStream *bitStream, SerializationContext *serializationContext)
virtual void | DeserializeDestruction (RakNet::BitStream *bitStream, SerializationType serializationType, SystemAddress sender, RakNetTime timestamp)
virtual void | Deserialize (RakNet::BitStream *bitStream, SerializationType serializationType, SystemAddress sender, RakNetTime timestamp)
virtual void | DeserializeVisibility (RakNet::BitStream *bitStream, SerializationType serializationType, SystemAddress sender, RakNetTime timestamp)
virtual BooleanQueryResult | QueryConstruction (Connection_RM2 *connection)
virtual BooleanQueryResult | QueryVisibility (Connection_RM2 *connection)
virtual bool | QueryIsConstructionAuthority (void) const
virtual bool | QueryIsDestructionAuthority (void) const
virtual bool | QueryIsVisibilityAuthority (void) const
virtual bool | QueryIsSerializationAuthority (void) const
virtual bool | AllowRemoteConstruction (SystemAddress sender, RakNet::BitStream *replicaData, SerializationType type, RakNetTime timestamp)
virtual void | AddAutoSerializeTimer (RakNetTime interval, SerializationType serializationType=AUTOSERIALIZE_DEFAULT, RakNetTime countdown=(RakNetTime)-1)
virtual void | ElapseAutoSerializeTimers (RakNetTime timeElapsed, bool resynchOnly)
RakNetTime | GetTimeToNextAutoSerialize (SerializationType serializationType=AUTOSERIALIZE_DEFAULT)
virtual void | BroadcastAutoSerialize (SerializationContext *serializationContext, RakNet::BitStream *serializedObject)
virtual void | CancelAutoSerializeTimer (SerializationType serializationType=AUTOSERIALIZE_DEFAULT)
virtual void | ClearAutoSerializeTimers (void)
Remove and deallocate all previously added autoSerialize timers.
virtual void | OnAutoSerializeTimerElapsed (SerializationType serializationType, RakNet::BitStream *output, RakNet::BitStream *lastOutput, RakNetTime lastAutoSerializeCountdown, bool resynchOnly)
virtual void | ForceElapseAllAutoserializeTimers (bool resynchOnly)

Detailed Description

Base class for game objects that use the ReplicaManager2 system All game objects that want to use the ReplicaManager2 functionality must inherit from Replica2. Generally you will want to implement at a minimum Serialize(), Deserialize(), and SerializeConstruction().

Member Function Documentation

void Replica2::SetReplicaManager ( ReplicaManager2 * rm )

Sets the replica manager to use with this Replica. Will also set the NetworkIDManager associated with RakPeerInterface::SetNetworkIDManager() Call this before using any of the functions below!

Parameters:
[in] rm A pointer to your instance of ReplicaManager 2

ReplicaManager2 * Replica2::GetReplicaManager ( void ) const

Returns what was passed to SetReplicaManager(), or 0 if no value ever passed

Returns:
Registered instance of ReplicaManager2

void Replica2::SendConstruction | ( | SystemAddress | recipientAddress,
 |  | SerializationType | serializationType = UNDEFINED_REASON |
 | ) |  |  | [virtual]

Construct this object on other systems Triggers a call to SerializeConstruction()

Note:
If using peer-to-peer, don't forget to set NetworkID::peerToPeerMode=true and comment out NETWORK_ID_USE_PTR_TABLE in NetworkIDManager.h
Parameters:
[in] | recipientAddress | Which system to send to
[in] | serializationType | What type of command this is. Use UNDEFINED_REASON to have a type chosen automatically

void Replica2::SendDestruction | ( | SystemAddress | recipientAddress,
 |  | SerializationType | serializationType = UNDEFINED_REASON |
 | ) |  |  | [virtual]

Destroy this object on other systems Triggers a call to SerializeDestruction()

Parameters:
[in] | recipientAddress | Which system to send to
[in] | serializationType | What type of command this is. Use UNDEFINED_REASON to have a type chosen automatically

void Replica2::SendSerialize | ( | SystemAddress | recipientAddress,
 |  | SerializationType | serializationType = UNDEFINED_REASON |
 | ) |  |  | [virtual]

Serialize this object to another system Triggers a call to Serialize()

Parameters:
[in] | recipientAddress | Which system to send to
[in] | serializationType | What type of command this is. Use UNDEFINED_REASON to have a type chosen automatically

void Replica2::SendVisibility | ( | SystemAddress | recipientAddress,
 |  | SerializationType | serializationType = UNDEFINED_REASON |
 | ) |  |  | [virtual]

Update the visibility of this object on another system Triggers a call to SerializeVisibility()

Parameters:
[in] | recipientAddress | Which system to send to
[in] | serializationType | What type of command this is. Use UNDEFINED_REASON to have a type chosen automatically

void Replica2::BroadcastConstruction ( SerializationContext * serializationContext = 0 ) [virtual]

Construct this object on other systems

Parameters:
[in] serializationContext Which system to send to, an input timestamp, and the SerializationType. 0 to use defaults, no timestamp.

void Replica2::BroadcastSerialize ( SerializationContext * serializationContext = 0 ) [virtual]

Serialize this object to all current connections Triggers a call to SerializeConstruction() for each connection (you can serialize differently per connection).

Parameters:
[in] serializationContext Which system to send to, an input timestamp, and the SerializationType. 0 to use defaults, no timestamp.

void Replica2::BroadcastDestruction ( SerializationContext * serializationContext = 0 ) [virtual]

Destroy this object on all current connections Triggers a call to SerializeDestruction() for each connection (you can serialize differently per connection).

Parameters:
[in] serializationContext Which system to send to, an input timestamp, and the SerializationType. 0 to use defaults, no timestamp.

void Replica2::BroadcastVisibility | ( | bool | isVisible,
 |  | SerializationContext * | serializationContext = 0 |
 | ) |  |  | [virtual]

Update the visibility state of this object on all other systems Use SEND_VISIBILITY_TRUE_TO_SYSTEM or SEND_VISIBILITY_FALSE_TO_SYSTEM in serializationContext::serializationType Triggers a call to SerializeVisibility() for each connection (you can serialize differently per connection).

Parameters:
[in] serializationContext Which system to send to, an input timestamp, and the SerializationType. 0 to use defaults, no timestamp, true visibility

virtual bool RakNet::Replica2::SerializeConstruction | ( | RakNet::BitStream * | bitStream,
 |  | SerializationContext * | serializationContext |
 | ) |  |  | [pure virtual]

CALLBACK: Override in order to write to bitStream data identifying this class for the class factory. Will be received by Connection_RM2::Construct() to create an instance of this class.

Parameters:
[out] | bitStream | Data used to identify this class, along with any data you also want to send when constructing the class
[in] | serializationContext | serializationType passed to Replica2::SendConstruction(), along with destination system, and a timestamp you can write to.
Returns:
Return false to cancel the construction, true to process

bool Replica2::SerializeDestruction | ( | RakNet::BitStream * | bitStream,
 |  | SerializationContext * | serializationContext |
 | ) |  |  | [virtual]

CALLBACK: Override in order to write to bitStream data to send along with destruction requests. Will be received by DeserializeDestruction()

Parameters:
[out] | bitStream | Data to send
[in] | serializationContext | Describes which system we are sending to, and a timestamp as an out parameter
Returns:
Return false to cancel the operation, true to process

bool Replica2::Serialize | ( | RakNet::BitStream * | bitStream,
 |  | SerializationContext * | serializationContext |
 | ) |  |  | [virtual]

CALLBACK: Override in order to write to bitStream data to send as regular class serialization, for normal per-tick data. Will be received by Deserialize()

Parameters:
[out] | bitStream | Data to send
[in] | serializationContext | Describes which system we are sending to, and a timestamp as an out parameter
Returns:
Return false to cancel the operation, true to process

bool Replica2::SerializeVisibility | ( | RakNet::BitStream * | bitStream,
 |  | SerializationContext * | serializationContext |
 | ) |  |  | [virtual]

CALLBACK: Override in order to write to bitStream data to send along with visibility changes. Will be received by DeserializeVisibility()

Parameters:
[out] | bitStream | Data to send
[in] | serializationContext | Describes which system we are sending to, and a timestamp as an out parameter
Returns:
Return false to cancel the operation, true to process

void Replica2::DeserializeDestruction | ( | RakNet::BitStream * | bitStream,
 |  | SerializationType | serializationType,
 |  | SystemAddress | sender,
 |  | RakNetTime | timestamp |
 | ) |  |  | [virtual]

CALLBACK: Receives data written by SerializeDestruction()

Parameters:
[in] | bitStream | Data sent
[in] | serializationType | SerializationContext::serializationType
[in] | sender | Which system sent this message to us
[in] | timestamp | If a timestamp was written, will be whatever was written adjusted to the local system time. 0 if not used.

void Replica2::Deserialize | ( | RakNet::BitStream * | bitStream,
 |  | SerializationType | serializationType,
 |  | SystemAddress | sender,
 |  | RakNetTime | timestamp |
 | ) |  |  | [virtual]

CALLBACK: Receives data written by Serialize()

Parameters:
[in] | bitStream | Data sent
[in] | serializationType | SerializationContext::serializationType
[in] | sender | Which system sent this message to us
[in] | timestamp | If a timestamp was written, will be whatever was written adjusted to the local system time. 0 if not used.

void Replica2::DeserializeVisibility | ( | RakNet::BitStream * | bitStream,
 |  | SerializationType | serializationType,
 |  | SystemAddress | sender,
 |  | RakNetTime | timestamp |
 | ) |  |  | [virtual]

CALLBACK: Receives data written by SerializeVisibility()

Parameters:
[in] | bitStream | Data sent
[in] | serializationType | SerializationContext::serializationType
[in] | sender | Which system sent this message to us
[in] | timestamp | If a timestamp was written, will be whatever was written adjusted to the local system time. 0 if not used.

BooleanQueryResult Replica2::QueryConstruction ( Connection_RM2 * connection ) [virtual]

CALLBACK: For a given connection, should this object exist? Checked every Update cycle if ReplicaManager2::SetAutoUpdateScope() parameter construction is true Defaults to BQR_ALWAYS

Parameters:
[in] connection Which connection we are referring to. 0 means unknown, in which case the system is checking for BQR_ALWAYS or BQR_NEVER as an optimization.
Returns:
BQR_NO and the object will be destroyed. BQR_YES and the object will be created. BQR_ALWAYS is YES for all connections, and is optimized to only be checked once.

BooleanQueryResult Replica2::QueryVisibility ( Connection_RM2 * connection ) [virtual]

CALLBACK: For a given connection, should this object be visible (updatable?) Checked every Update cycle if ReplicaManager2::SetAutoUpdateScope() parameter serializationVisiblity is true Defaults to BQR_ALWAYS

Parameters:
[in] connection Which connection we are referring to. 0 means unknown, in which case the system is checking for BQR_ALWAYS or BQR_NEVER as an optimization.
Returns:
BQR_NO or BQR_YES and as this value changes per connection, you will get a call to DeserializeVisibility().

bool Replica2::QueryIsConstructionAuthority ( void ) const [virtual]

CALLBACK: Does this system have control over construction of this object? While not strictly required, it is best to have this consistently return true for only one system. Otherwise systems may fight and override each other. Defaults to NetworkIDManager::IsNetworkIDAuthority();

Returns:
True if an authority over this operation, for this object instance

bool Replica2::QueryIsDestructionAuthority ( void ) const [virtual]

CALLBACK: Does this system have control over deletion of this object? While not strictly required, it is best to have this consistently return true for only one system. Otherwise systems may fight and override each other. Defaults to NetworkIDManager::IsNetworkIDAuthority();

Returns:
True if an authority over this operation, for this object instance

bool Replica2::QueryIsVisibilityAuthority ( void ) const [virtual]

CALLBACK: Does this system have control over visibility of this object? While not strictly required, it is best to have this consistently return true for only one system. Otherwise systems may fight and override each other. Defaults to NetworkIDManager::IsNetworkIDAuthority();

Returns:
True if an authority over this operation, for this object instance

bool Replica2::QueryIsSerializationAuthority ( void ) const [virtual]

CALLBACK: Does this system have control over serialization of object members of this object? It is reasonable to have this be true for more than one system, but you would want to serialize different variables so those systems do not conflict. Defaults to NetworkIDManager::IsNetworkIDAuthority();

Returns:
True if an authority over this operation, for this object instance

bool Replica2::AllowRemoteConstruction | ( | SystemAddress | sender,
 |  | RakNet::BitStream * | replicaData,
 |  | SerializationType | type,
 |  | RakNetTime | timestamp |
 | ) |  |  | [virtual]

CALLBACK: If QueryIsConstructionAuthority() is false for a remote system, should that system be able to create this kind of object?

Parameters:
[in] | sender | Which system sent this message to us? Also happens to be the system that is requesting to create an object
[in] | replicaData | Construction data used to create this object
[in] | type | Which type of serialization operation was performed
[in] | timestamp | Written timestamp with the packet. 0 if not used.
Returns:
True to allow remote construction of this object. If true, we will reply with SEND_CONSTRUCTION_REPLY_ACCEPTED_TO_CLIENT and the network ID will be set on the requester.

void Replica2::AddAutoSerializeTimer | ( | RakNetTime | interval,
 |  | SerializationType | serializationType = AUTOSERIALIZE_DEFAULT,
 |  | RakNetTime | countdown = (RakNetTime)-1 |
 | ) |  |  | [virtual]

Adds a timer that will elapse every countdown milliseconds, calling Serialize with AUTOSERIALIZE_DEFAULT or whatever value was passed to serializationType Every time this timer elapses, the value returned from Serialize() will be compared to the last value returned by Serialize(). If different, SendSerialize() will be called automatically. It is possible to create your own AUTOSERIALIZE enumerations and thus control which parts of the object is serialized Use CancelAutoSerializeTimer() or ClearAutoSerializeTimers() to stop the timer. If this timer already exists, it will simply override the existing countdown This timer will automatically repeat every countdown milliseconds

Parameters:
[in] | interval | Time in milliseconds between autoserialize ticks. Use 0 to process immediately, and every tick
[in] | serializationType | User-defined identifier for what type of serialization operation to perform. Returned in Deserialize() as the serializationType parameter.
[in] | countdown | Amount of time before doing the next autoserialize. Defaults to interval

void Replica2::ElapseAutoSerializeTimers | ( | RakNetTime | timeElapsed,
 |  | bool | resynchOnly |
 | ) |  |  | [virtual]

Elapse time for all timers added with AddAutoSerializeTimer() Only necessary to call this if you call Replica2::SetDoReplicaAutoSerializeUpdate(false) (which defaults to true)

Parameters:
[in] | timeElapsed | How many milliseconds have elapsed since the last call
[in] | resynchOnly | True to only update what was considered the last send, without actually doing a send.

RakNetTime Replica2::GetTimeToNextAutoSerialize ( SerializationType serializationType = AUTOSERIALIZE_DEFAULT )

Returns how many milliseconds are remaining until the next autoserialize update

Parameters:
[in] serializationType User-defined identifier for what type of serialization operation to perform. Returned in Deserialize() as the serializationType parameter.
Returns:
How many milliseconds are remaining until the next autoserialize update. Returns -1 if no such autoserialization timer is in place.

void Replica2::BroadcastAutoSerialize | ( | SerializationContext * | serializationContext,
 |  | RakNet::BitStream * | serializedObject |
 | ) |  |  | [virtual]

Do the actual send call when needed to support autoSerialize If you want to do different types of send calls (UNRELIABLE for example) override this function.

Parameters:
[in] | serializationContext | Describes the recipient, sender. serializationContext::timestamp is an [out] parameter which if you write to, will be send along with the message
[in] | serializedObject | Data to pass to ReplicaManager2::SendSerialize()

void Replica2::CancelAutoSerializeTimer ( SerializationType serializationType = AUTOSERIALIZE_DEFAULT ) [virtual]

Stop calling an autoSerialize timer previously setup with AddAutoSerializeTimer()

Parameters:
[in] serializationType Corresponding value passed to serializationType

void Replica2::OnAutoSerializeTimerElapsed | ( | SerializationType | serializationType,
 |  | RakNet::BitStream * | output,
 |  | RakNet::BitStream * | lastOutput,
 |  | RakNetTime | lastAutoSerializeCountdown,
 |  | bool | resynchOnly |
 | ) |  |  | [virtual]

A timer has elapsed. Compare the last value sent to the current value, and if different, send the new value

void Replica2::ForceElapseAllAutoserializeTimers ( bool resynchOnly ) [virtual]

Immediately elapse all autoserialize timers Used internally when a Deserialize() event occurs, so that the deserialize does not trigger an autoserialize itself

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/ReplicaManager2.h
  • C:/RakNet/Source/ReplicaManager2.cpp
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ReplicaManager Class Reference

ReplicaManager Class Reference
[ReplicaManager]

A management system for your game objects and players to make serialization, scoping, and object creation and destruction easier. More...

#include <ReplicaManager.h>

Inheritance diagram for ReplicaManager:

PluginInterface List of all members.

Public Member Functions

ReplicaManager ()
Constructor.
virtual | ~ReplicaManager ()
Destructor.
void | AssertReplicatedObjectsClear (void)
void | AssertParticipantsClear (void)
void | SetAutoParticipateNewConnections (bool autoAdd)
bool | AddParticipant (SystemAddress systemAddress)
bool | RemoveParticipant (SystemAddress systemAddress)
void | Construct (Replica *replica, bool isCopy, SystemAddress systemAddress, bool broadcast)
void | Destruct (Replica *replica, SystemAddress systemAddress, bool broadcast)
void | ReferencePointer (Replica *replica)
void | DereferencePointer (Replica *replica)
void | SetScope (Replica *replica, bool inScope, SystemAddress systemAddress, bool broadcast)
void | SignalSerializeNeeded (Replica *replica, SystemAddress systemAddress, bool broadcast)
void | SetReceiveConstructionCB (ReceiveConstructionInterface *receiveConstructionInterface)
void | SetDownloadCompleteCB (SendDownloadCompleteInterface *sendDownloadComplete, ReceiveDownloadCompleteInterface *receiveDownloadComplete)
void | SetSendChannel (unsigned char channel)
void | SetAutoConstructToNewParticipants (bool autoConstruct)
void | SetDefaultScope (bool scope)
void | SetAutoSerializeInScope (bool autoSerialize)
void | Update (RakPeerInterface *peer)
void | EnableReplicaInterfaces (Replica *replica, unsigned char interfaceFlags)
void | DisableReplicaInterfaces (Replica *replica, unsigned char interfaceFlags)
bool | IsConstructed (Replica *replica, SystemAddress systemAddress)
bool | IsInScope (Replica *replica, SystemAddress systemAddress)
unsigned | GetReplicaCount (void) const
Replica * | GetReplicaAtIndex (unsigned index)
unsigned | GetParticipantCount (void) const
SystemAddress | GetParticipantAtIndex (unsigned index)
bool | HasParticipant (SystemAddress systemAddress)
void | SignalSerializationFlags (Replica *replica, SystemAddress systemAddress, bool broadcast, bool set, unsigned int flags)
unsigned int * | AccessSerializationFlags (Replica *replica, SystemAddress systemAddress)

Protected Member Functions

void | Clear (void)
Frees all memory.
void | OnAttach (RakPeerInterface *peer)
PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)
void | OnShutdown (RakPeerInterface *peer)

Protected Attributes

DataStructures::OrderedList<
Replica *, RegisteredReplica,
ReplicaManager::RegisteredReplicaComp > 		replicatedObjects
DataStructures::OrderedList<
SystemAddress, ParticipantStruct *,
ReplicaManager::ParticipantStructComp > 		participantList

Detailed Description

A management system for your game objects and players to make serialization, scoping, and object creation and destruction easier.

Deprecated:
Use RM2_ReplicaManager in ReplicaManager2.h ReplicaManager is a system manager for your game objects that performs the following tasks: 1. Tracks all locally registered game objects and players and only performs operations to and for those objects and players 2. Allows you to automatically turn off unneeded local and remote functions for your game objects, thus providing convenience and security against unauthorized sends. 3. Sends notifications of existing game objects to new connections, including a download complete message. 4. Sends notifications of new game objects to existing players. A. Serialize and scoping calls are not sent to objects that were not notified of that object. B. Notification calls can be canceled on a per-object basis. Object notification sends are tracked on a per-system per-object basis. 5. Configurable per-system per-object scoping. A. Scoping provides a mechanism to hide and unhide remote objects without destroying the whole object, used when when entities should not be destroyed but are currently not visible to systems. B. Serialize calls are not sent to hidden objects. C. Scoping calls can be canceled on a per-object basis. Scope is tracked on a per-system per-object basis. 6. Replicate, SetScope, SignalSerializeNeeded, and the corresponding Replica interfaces are processed in RakPeer::Receive, rather than immediately. A. This allows the ReplicaManager to reorganize function calls in order by dependency. This allows out of order calls, per-object call cancellation (which also cancels dependencies), and per-object call delays (which also delays dependencies) B. For example, although SetScope and SignalSerializeNeeded have a dependency on SetNetworkID(), you can still call them in the constructor and call SetNetworkID() later, as long as it happens before calling RakPeer::Receive() 7. The system is fast, uses little memory, and is intentionally hands off such that it can work with any game architecture and network topology
What the ReplicaManager system does NOT do for you 1. Actually create or destroy your game objects 2. Associate object destruction events with remote system disconnects. 3. Set networkIDs via SetNetworkID() on newly created objects. 4. Object sub-serialization. Serialize only granular on the level of entire objects. If you want to serialize part of the object, you need to set your own flags and indicate in the BitStream which parts were sent and which not.
Precondition:
You must call RakPeer::SetNetworkIDManager to use this plugin.

Member Function Documentation

void ReplicaManager::AssertReplicatedObjectsClear ( void )

If you think all objects should have been removed, call this to assert on any that were not. Useful for debugging shutdown or restarts

void ReplicaManager::AssertParticipantsClear ( void )

If you think all participants should have been removed, call this to assert on any that were not. Useful for debugging shutdown or restarts

void ReplicaManager::SetAutoParticipateNewConnections ( bool autoAdd )

Do or don't automatically call AddParticipant when new systems connect to us. Won't add automatically add connections that already exist before this was called Defaults to false

Parameters:
[in] autoAdd True or false, to add or not

bool ReplicaManager::AddParticipant ( SystemAddress systemAddress )

Adds a participant to the ReplicaManager system. Only these participants get packets and we only accept ReplicaManager packets from these participants. This way you can have connections that have nothing to do with your game - for example remote console logins

Parameters:
[in] systemAddress Which player you are referring to
Returns:
True on success, false on participant already exists

bool ReplicaManager::RemoveParticipant ( SystemAddress systemAddress )

Removes a participant from the data replicator system This is called automatically on ID_DISCONNECTION_NOTIFICATION and ID_CONNECTION_LOST messages, as well as CloseConnection() calls.

Parameters:
[in] systemAddress Which player you are referring to
Returns:
True on success, false on participant does not exist

void ReplicaManager::Construct | ( | Replica * | replica,
 |  | bool | isCopy,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast
 | ) |  |

Construct the specified object on the specified system Replica::SendConstruction will be called immediately, this is a change from before, because otherwise if you later send other packets that refer to this object, this object won't exist yet. The other system will get Replica::ReceiveConstruction If your system assigns NetworkIDs, do so before calling Replicate as the NetworkID is automatically included in the packet. Replicate packets that are sent to systems that already have this NetworkID are ignored.

Note:
Objects which are replicated get exactly one call to SendConstruction for every player / object permutation.

To perform scoping and serialize updates on an object already created by another system, call Construct with isCopy true.

Setting isCopy true will consider the object created on that system without actually trying to create it.

If you don't need to send updates to other systems for this object, it is more efficient to use ReferencePointer instead.

In a client / server environment, be sure to call Construct() with isCopy true to let the ReplicaManager know that the server has this object. Otherwise you won't be able to send Scope or Serialize changes to the server.

Parameters:
[in] | replica | A pointer to your object
[in] | isCopy | True means that this is a copy of an object that already exists on the systems specified by systemAddress and broadcast. If true, we will consider these systems as having the object without sending a datagram to them. SendConstruction will NOT be called for objects which isCopy is true.
[in] | systemAddress | The participant to send the command to, or the one to exclude if broadcast is true.
[in] | broadcast | True to send to all. If systemAddress!=UNASSIGNED_SYSTEM_ADDRESS then this means send to all but that participant

void ReplicaManager::Destruct | ( | Replica * | replica,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast
 | ) |  |

Call this with your game objects to have them send Replica::SendDestruction. This will be sent immediately to all participants that have this object. Those participants will get Replica::ReceiveDestruction All pending calls for this object, for this player, are canceled. Nothing is actually deleted - this just signals that the other system called this function. It is up to you to actually delete your object.

Precondition:
Call Replicate with this object first.

For the other system to get the network message, SetNetworkID on that object must have been called with the same value as GetNetworkID for this object.

Note:
Call Destruct before DereferencePointer if you plan on calling both, since Destruct will fail with no pointer reference.

Calling ( with systemAddress==UNASSIGNED_SYSTEM_ADDRESS and broadcast true is equivalent to calling DereferencePointer except that Destruct also sends the destruct packet.

It is important to call this before deleting your object. Otherwise this system will crash the next Update call.

Parameters:
[in] | replica | A pointer to your object
[in] | systemAddress | The participant to send the command to, or the one to exclude if broadcast is true.
[in] | broadcast | True to send to all systems that have the object. If systemAddress!=UNASSIGNED_SYSTEM_ADDRESS then this means send to all but that participant

void ReplicaManager::ReferencePointer ( Replica * replica )

This makes sure the object is tracked, so you can get calls on it. This will automatically happen if you call Construct, SetScope, or SignalSerializeNeeded with replica Otherwise you need to call this, or for security the system will ignore calls that reference this object, even if given a valid NetworkID Duplicate calls are safe and are simply ignored. Best place to put this is in the SetReceiveConstructionCB callback so that all your objects are registered.

Parameters:
[in] replica A pointer to your object

Try setting the network ID manager if the user forgot

void ReplicaManager::DereferencePointer ( Replica * replica )

Call this before you delete replica. This locally removes all references to this pointer. No messages are sent. Best place to put this is in the destructor of replica

Parameters:
[in] replica A pointer to your object

void ReplicaManager::SetScope | ( | Replica * | replica,
 |  | bool | inScope,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast
 | ) |  |

Sets the scope of your object in relation to another participant. Objects that are in-scope for that participant will send out Replica::Serialize calls. Otherwise Serialize calls are not sent. Scoping is useful when you want to disable sends to an object temporarily, without deleting that object. Calling this results in Replica::SendScopeChange being called on the local object and Replica::ReceiveScopeChange on the remote object if that object has been created on that remote system. Your game should ensure that objects not in scope are hidden, but not deallocated, on the remote system. Replica::SendScopeChange with inScope as true will automatically perform Replica::Serialize

Precondition:
Call Replicate with this object first.

For the other system to get the network message, that object must have an NetworkID (set by SetNetworkID()) the same as our object's NetworkID (returned from GetNetworkID()).

Note:
You can set the default scope with SetDefaultScope()

Individual objects can refuse to perform the SendScopeChange call by not writing to the output bitstream while returning true.

Parameters:
[in] | replica | An object previously registered with Replicate
[in] | inScope | in scope or not.
[in] | systemAddress | The participant to send the command to, or the one to exclude if broadcast is true.
[in] | broadcast | True to send to all. If systemAddress!=UNASSIGNED_SYSTEM_ADDRESS then this means send to all but that participant

void ReplicaManager::SignalSerializeNeeded | ( | Replica * | replica,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast
 | ) |  |

Signal that data has changed and we need to call Serialize() on the replica object. This will happen if the object has been registered, Replica::SendConstruction wrote to outBitStream and returned true, and the object is in scope for this player.

Precondition:
Call Replicate with this object first.

For the other system to get the network message, that object must have an NetworkID (set by SetNetworkID()) the same as our object's NetworkID (returned from GetNetworkID()).

Parameters:
[in] | replica | An object previously registered with Replicate
[in] | systemAddress | The participant to send the command to, or the one to exclude if broadcast is true.
[in] | broadcast | True to send to all. If systemAddress!=UNASSIGNED_SYSTEM_ADDRESS then this means send to all but that participant

void ReplicaManager::SetReceiveConstructionCB ( ReceiveConstructionInterface * receiveConstructionInterface )

Required callback Set your callback to parse requests to create new objects. Specifically, when Replica::SendConstruction is called and the networkID of the object is either unset or can't be found, this callback will get that call. How do you know what object to create? It's up to you, but I suggest in Replica::SendConstruction you encode the class name. The best way to do this is with the StringTable class.

Note:
If you return true from NetworkIDManager::IsNetworkIDAuthority, which you should do for a server or peer, I recommend also encoding the value returned by GetNetworkID() within Replica::SendConstruction into that bitstream and reading it here. Then set that value in a call to SetNetworkID. Dereplicate, SetScope, and SignalSerializeNeeded all rely on being able to call GET_OBJECT_FROM_ID which requires that SetNetworkID be called on that object.
Parameters:
[in] ReceiveConstructionInterface An instance of a class that implements ReceiveConstructionInterface

void ReplicaManager::SetDownloadCompleteCB | ( | SendDownloadCompleteInterface * | sendDownloadComplete,
 |  | ReceiveDownloadCompleteInterface * | receiveDownloadComplete
 | ) |  |

Set your callbacks to be called when, after connecting to another system, you get all objects that system is going to send to you when it is done with the first iteration through the object list. Optional if you want to send and receive the download complete notification

Parameters:
[in] | sendDownloadComplete | A class that implements the SendDownloadCompleteInterface interface.
[in] | receiveDownloadComplete | A class that implements the ReceiveDownloadCompleteInterface interface.
See also:
SendDownloadCompleteInterface , ReceiveDownloadCompleteInterface

void ReplicaManager::SetSendChannel ( unsigned char channel )

This channel will be used for all RakPeer::Send calls

Parameters:
[in] channel The channel to use for internal RakPeer::Send calls from this system. Defaults to 0.

void ReplicaManager::SetAutoConstructToNewParticipants ( bool autoConstruct )

This means automatically construct all known objects to all new participants Has no effect on existing participants Useful if your architecture always has all objects constructed on all systems all the time anyway, or if you want them to normally start constructed Defaults to false.

Parameters:
[in] autoConstruct true or false, as desired.

void ReplicaManager::SetDefaultScope ( bool scope )

Set the default scope for new objects to all players. Defaults to false, which means Serialize will not be called for new objects automatically. If you set this to true, then new players will get existing objects, and new objects will be sent to existing players This only applies to players that connect and objects that are replicated after this call. Existing object scopes are not affected. Useful to set to true if you don't use scope, or if all objects normally start in scope

Parameters:
[in] scope The default scope to use.

void ReplicaManager::SetAutoSerializeInScope ( bool autoSerialize )

When an object goes in scope for a system, you normally want to serialize that object to that system. Setting this flag to true will call Serialize for you automatically when SendScopeChange returns REPLICA_PROCESSING_DONE and the scopeTrue parameter is true Defaults to false

Parameters:
[in] autoSerialize True or false as needed.

void ReplicaManager::Update ( RakPeerInterface * peer ) [virtual]

Processes all pending commands and does sends as needed. This is called automatically when RakPeerInterface::Receive is called. Depending on where you call RakPeerInterface::Receive you may also wish to call this manually for better responsiveness. For example, if you call RakPeerInterface::Receive at the start of each game tick, this means you would have to wait a render cycle, causing

Parameters:
[in] peer Pointer to a valid instance of RakPeerInterface used to perform sends

Reimplemented from PluginInterface.

void ReplicaManager::EnableReplicaInterfaces | ( | Replica * | replica,
 |  | unsigned char | interfaceFlags
 | ) |  |

Lets you enable calling any or all of the interface functions in an instance of Replica This setting is the same for all participants for this object, so if you want per-participant permissions you will need to handle that inside your implementation All functions enabled by default.

Parameters:
[in] | replica | The object you are referring to
[in] | interfaceFlags | A bitwise-OR of REPLICA_SEND_CONSTRUCTION ... REPLICA_SET_ALL corresponding to the function of the same name

void ReplicaManager::DisableReplicaInterfaces | ( | Replica * | replica,
 |  | unsigned char | interfaceFlags
 | ) |  |

Lets you disable calling any or all of the interface functions in an instance of Replica This setting is the same for all participants for this object, so if you want per-participant permissions you will need to handle that inside your implementation All functions enabled by default.

Note:
Disabling functions is very useful for security.

For example, on the server you may wish to disable all receive functions so clients cannot change server objects.

Parameters:
[in] | replica | The object you are referring to
[in] | interfaceFlags | A bitwise-OR of REPLICA_SEND_CONSTRUCTION ... REPLICA_SET_ALL corresponding to the function of the same name

bool ReplicaManager::IsConstructed | ( | Replica * | replica,
 |  | SystemAddress | systemAddress
 | ) |  |

Tells us if a particular system got a SendConstruction() message from this object. e.g. does this object exist on this remote system? This is set by the user when calling Replicate and sending (any) data to outBitStream in Replica::SendConstruction

Parameters:
[in] | replica | The object we are checking
[in] | systemAddress | The system we are checking

bool ReplicaManager::IsInScope | ( | Replica * | replica,
 |  | SystemAddress | systemAddress
 | ) |  |

Tells us if a particular object is in scope for a particular system This is set by the user when calling SetScope and sending (any) data to outBitstream in Replica::SendScopeChange

Parameters:
[in] | replica | The object we are checking
[in] | systemAddress | The system we are checking

unsigned ReplicaManager::GetReplicaCount ( void ) const

Returns how many Replica instances are registered. This number goes up with each non-duplicate call to Replicate and down with each non-duplicate call to Dereplicate Used for GetReplicaAtIndex if you want to perform some object on all registered Replica objects.

Returns:
How many replica objects are in the list of replica objects

Replica * ReplicaManager::GetReplicaAtIndex ( unsigned index )

Returns a previously registered Replica *, from index 0 to GetReplicaCount()-1. The order that Replica * objects are returned in is arbitrary (it currently happens to be ordered by pointer address). Calling Dereplicate immediately deletes the Replica * passed to it, so if you call Dereplicate while using this function the array will be shifted over and the current index will now reference the next object in the array, if there was one.

Parameters:
[in] index An index, from 0 to GetReplicaCount()-1.
Returns:
A Replica * previously passed to Construct()

unsigned ReplicaManager::GetParticipantCount ( void ) const

Returns the number of unique participants added with AddParticipant As these systems disconnect, they are no longer participants, so this accurately returns how many participants are using the system

Returns:
The number of unique participants added with AddParticipant

SystemAddress ReplicaManager::GetParticipantAtIndex ( unsigned index )

Returns a SystemAddress previously added with AddParticipant

Parameters:
[in] index An index, from 0 to GetParticipantCount()-1.
Returns:
A SystemAddress

bool ReplicaManager::HasParticipant ( SystemAddress systemAddress )

Returns if a participant has been added

Returns:
If this participant has been added

void ReplicaManager::SignalSerializationFlags | ( | Replica * | replica,
 |  | SystemAddress | systemAddress,
 |  | bool | broadcast,
 |  | bool | set,
 |  | unsigned int | flags
 | ) |  |

Each participant has a per-remote object bitfield passed to the Replica::Serialize call. This function can set or unset these flags for one or more participants at the same time. Flags are NOT automatically cleared on serialize. You must clear them when you want to do so.

Parameters:
[in] | replica | An object previously registered with Replicate
[in] | systemAddress | The participant to set the flags for
[in] | broadcast | True to apply to all participants. If systemAddress!=UNASSIGNED_SYSTEM_ADDRESS then this means send to all but that participant
[in] | set | True set the bits set in flags with the per-object per-system serialization flags. False to unset these bits.
[in] | flags | Modifier to the Per-object per-system flags sent to Replica::Serialize. See the parameter /a set

unsigned int * ReplicaManager::AccessSerializationFlags | ( | Replica * | replica,
 |  | SystemAddress | systemAddress
 | ) |  |

Each participant has a per-remote object bitfield passed to the Replica::Serialize call. This function is used to read and change these flags directly for a single participant. It gives more control than SignalSerializationFlags but only works for a single participant at a time.

Parameters:
[in] | replica | An object previously registered with Replicate
[in] | systemAddress | The participant to read/write the flags for
Returns:
A pointer to the per-object per-system flags sent to Replica::Serialize. You can read or modify the flags directly with this function. This pointer is only valid until the next call to RakPeer::Receive

void ReplicaManager::OnAttach ( RakPeerInterface * peer ) [protected, virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult ReplicaManager::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [protected, virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void ReplicaManager::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [protected, virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

void ReplicaManager::OnShutdown ( RakPeerInterface * peer ) [protected, virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

Member Data Documentation

DataStructures::OrderedList<Replica *, RegisteredReplica, ReplicaManager::RegisteredReplicaComp> ReplicaManager::replicatedObjects [protected]

List of objects replicated in the Replicate function. Used to make sure queued actions happen on valid pointers, since objects are removed from the list in Dereplicate Sorted by raw pointer address using the default sort

DataStructures::OrderedList<SystemAddress, ParticipantStruct *, ReplicaManager::ParticipantStructComp> ReplicaManager::participantList [protected]

List of participants Each participant has several queues of pending commands Sorted by systemAddress The only complexity is that each participant also needs a list of objects that mirror the variable replicatedObjects so we know per-player if that object is in scope

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/ReplicaManager.h
  • C:/RakNet/Source/ReplicaManager.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::ReplicaManager2 Class Reference

RakNet::ReplicaManager2

RakNet::ReplicaManager2 Class Reference
[ReplicaManager2]

A management system for your game objects and players to make serialization, scoping, and object creation and destruction easier. More...

#include <ReplicaManager2.h>

Inheritance diagram for RakNet::ReplicaManager2:

PluginInterface List of all members.

Public Member Functions

ReplicaManager2 ()
Constructor.
virtual | ~ReplicaManager2 ()
Destructor.
void | SetConnectionFactory (Connection_RM2Factory *factory)
void | SetDefaultOrderingChannel (char def)
Parameters:
[in] Default ordering channel to use when passing -1 to a function that takes orderingChannel as a parameter

void | SetDefaultPacketPriority (PacketPriority def)
Parameters:
[in] Default packet priority to use when passing NUMBER_OF_PRIORITIES to a function that takes priority as a parameter

void | SetDefaultPacketReliability (PacketReliability def)
Parameters:
[in] Default packet reliability to use when passing NUMBER_OF_RELIABILITIES to a function that takes reliability as a parameter

void | SetAutoUpdateScope (bool construction, bool visibility)
void | SetAutoAddNewConnections (bool autoAdd)
bool | AddNewConnection (SystemAddress systemAddress)
bool | RemoveConnection (SystemAddress systemAddress)
bool | HasConnection (SystemAddress systemAddress)
void | SetDoReplicaAutoSerializeUpdate (bool autoUpdate)
void | SendConstruction (Replica2 *replica, BitStream *replicaData, SystemAddress recipient, RakNetTime timestamp, bool sendMessage, DataStructures::OrderedList< SystemAddress, SystemAddress > &exclusionList, unsigned char localClientId, SerializationType type=SEND_CONSTRUCTION_GENERIC_TO_SYSTEM, PacketPriority priority=NUMBER_OF_PRIORITIES, PacketReliability reliability=NUMBER_OF_RELIABILITIES, char orderingChannel=-1)
void | SendDestruction (Replica2 *replica, BitStream *replicaData, SystemAddress recipient, RakNetTime timestamp, bool sendMessage, DataStructures::OrderedList< SystemAddress, SystemAddress > &exclusionList, SerializationType type=SEND_DESTRUCTION_GENERIC_TO_SYSTEM, PacketPriority priority=NUMBER_OF_PRIORITIES, PacketReliability reliability=NUMBER_OF_RELIABILITIES, char orderingChannel=-1)
void | SendSerialize (Replica2 *replica, BitStream *replicaData, SystemAddress recipient, RakNetTime timestamp, DataStructures::OrderedList< SystemAddress, SystemAddress > &exclusionList, SerializationType type=SEND_SERIALIZATION_GENERIC_TO_SYSTEM, PacketPriority priority=NUMBER_OF_PRIORITIES, PacketReliability reliability=NUMBER_OF_RELIABILITIES, char orderingChannel=-1)
void | SendVisibility (Replica2 *replica, BitStream *replicaData, SystemAddress recipient, RakNetTime timestamp, DataStructures::OrderedList< SystemAddress, SystemAddress > &exclusionList, SerializationType type=SEND_VISIBILITY_TRUE_TO_SYSTEM, PacketPriority priority=NUMBER_OF_PRIORITIES, PacketReliability reliability=NUMBER_OF_RELIABILITIES, char orderingChannel=-1)
unsigned | GetReplicaCount (void) const
Replica2 * | GetReplicaAtIndex (unsigned index)
unsigned | GetConnectionCount (void) const
Connection_RM2 * | GetConnectionAtIndex (unsigned index) const
Connection_RM2 * | GetConnectionBySystemAddress (SystemAddress systemAddress) const
unsigned int | GetConnectionIndexBySystemAddress (SystemAddress systemAddress) const
void | RecalculateVisibility (Replica2 *replica)
void | GetConnectionsWithReplicaConstructed (Replica2 *replica, DataStructures::OrderedList< SystemAddress, Connection_RM2 *, ReplicaManager2::Connection_RM2CompBySystemAddress > &output)
void | GetConnectionsWithSerializeVisibility (Replica2 *replica, DataStructures::OrderedList< SystemAddress, Connection_RM2 *, ReplicaManager2::Connection_RM2CompBySystemAddress > &output)
RakPeerInterface * | GetRakPeer (void) const
void | Reference (Replica2 *replica, bool *newReference)
void | Dereference (Replica2 *replica)

Protected Member Functions

void | OnAttach (RakPeerInterface *peer)
PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)
void | OnShutdown (RakPeerInterface *peer)
void | Update (RakPeerInterface *peer)

Detailed Description

A management system for your game objects and players to make serialization, scoping, and object creation and destruction easier.

Quick start: 1. Create a class that derives from Connection_RM2, implementing the Construct() function. Construct() is a factory function that should return instances of your game objects, given a user-defined identifier. 2. Create a class that derives from Connection_RM2Factory, implementing AllocConnection() and DeallocConnection() to return instances of the class from step 1. 3. Attach ReplicaManager2 as a plugin 4. Call ReplicaManager2::SetConnectionFactory with an instance of the class from step 2. 5. For each of your game classes that use this system, derive from Replica2 and implement SerializeConstruction(), Serialize(), Deserialize(). The output of SerializeConstruction() is sent to Connection_RM2::Construct() 6. When these classes are allocated, call Replica2::SetReplicaManager() with the instance of ReplicaManager2 class created in step 3 (this could be done automatically in the constructor) 7. Creation: Use Replica2::SendConstruction() to create the object remotely, Replica2::SendDestruction() to delete the object remotely. 8. Scoping: Override Replica2::QueryVisibility() and Replica2::QueryConstruction() to return BQR_YES or BQR_NO if an object should be visible and in scope to a given connection. Defaults to BQR_ALWAYS 9. Automatic serialization: Call Replica2::AddAutoSerializeTimer() to automatically call Replica2::Serialize() at intervals, compare this to the last value, and broadcast out the object when the serialized variables change.

Precondition:
Call RakPeer::SetNetworkIDManager()

This system is a server or peer: Call NetworkIDManager::SetIsNetworkIDAuthority(true).

This system is a client: Call NetworkIDManager::SetIsNetworkIDAuthority(false).

If peer to peer, set NetworkID::peerToPeerMode=true, and comment out NETWORK_ID_USE_PTR_TABLE in NetworkIDManager.h

Member Function Documentation

void ReplicaManager2::SetConnectionFactory ( Connection_RM2Factory * factory )

Sets the factory class used to allocate connection objects

Parameters:
[in] factory A pointer to an instance of a class that derives from Connection_RM2Factory. This pointer it saved and not copied, so the object should remain in memory.

void ReplicaManager2::SetAutoUpdateScope | ( | bool | construction,
 |  | bool | visibility
 | ) |  |

Auto scope will track the prior construction and serialization visibility of each registered Replica2 class, for each connection. Per-tick, as the visibility or construction status of a replica changes, it will be constructed, destroyed, or the visibility will change as appropriate.

Parameters:
[in] | construction | If true, Connection_RM2::SetConstructionByReplicaQuery will be called once per PluginInterface::Update tick. This will call Replica2::QueryConstruction to return if an object should be exist on a particular connection
[in] | visibility | If true, Connection_RM2::SetConstructionSerializationByReplicaQuery will be called once per PluginInterface::Update tick. This will call Replica2::QuerySerialization to return if an object should be visible to a particular connection or not.

void ReplicaManager2::SetAutoAddNewConnections ( bool autoAdd )

Autoadd will cause a Connection_RM2 instance to be allocated for every connection. Defaults to true. Set this to false if you have connections which do not participate in the game (master server, etc).

Parameters:
[in] autoAdd If true, all incoming connections are added as ReplicaManager2 connections.

bool ReplicaManager2::AddNewConnection ( SystemAddress systemAddress )

If SetAutoAddNewConnections() is false, you need to add connections manually connections are also created implicitly if needed

Parameters:
[in] systemAddress The address of the new system
Returns:
false if the connection already exists

bool ReplicaManager2::RemoveConnection ( SystemAddress systemAddress )

Remove an existing connection. Also done automatically on ID_DISCONNECTION_NOTIFICATION and ID_CONNECTION_LOST

Parameters:
[in] systemAddress The address of the system to remove the connection for
Returns:
false if the connection does not exist

bool ReplicaManager2::HasConnection ( SystemAddress systemAddress )

Is this connection registered with the system?

Parameters:
[in] systemAddress The address of the system to check
Returns:
true if this address is registered, false otherwise

void ReplicaManager2::SetDoReplicaAutoSerializeUpdate ( bool autoUpdate )

If true, autoserialize timers added with Replica2::AddAutoSerializeTimer() will automatically decrement. If false, you must call Replica2::ElapseAutoSerializeTimers() manually. Defaults to true

Parameters:
[in] autoUpdate True to automatically call ElapseAutoSerializeTimers(). Set to false if you need to control these timers.

void ReplicaManager2::SendConstruction | ( | Replica2 * | replica,
 |  | BitStream * | replicaData,
 |  | SystemAddress | recipient,
 |  | RakNetTime | timestamp,
 |  | bool | sendMessage,
 |  | DataStructures::OrderedList< SystemAddress, SystemAddress > & | exclusionList,
 |  | unsigned char | localClientId,
 |  | SerializationType | type = SEND_CONSTRUCTION_GENERIC_TO_SYSTEM,
 |  | PacketPriority | priority = NUMBER_OF_PRIORITIES,
 |  | PacketReliability | reliability = NUMBER_OF_RELIABILITIES,
 |  | char | orderingChannel = -1
 | ) |  |

Sends a construction command to one or more systems, which will be relayed throughout the network. Recipient(s) will allocate the connection via Connection_RM2Factory::AllocConnection() if it does not already exist. Will trigger a call on the remote system(s) to Connection_RM2::Construct()

Note:
If using peer-to-peer, don't forget to set NetworkID::peerToPeerMode=true and comment out NETWORK_ID_USE_PTR_TABLE in NetworkIDManager.h.

This is a low level function. Beginners may wish to use Replica2::SendConstruction() or Replica2::BroadcastConstruction(). You can also override Replica2::QueryConstruction()

Parameters:
[in] | replica | The class to construct remotely
[in] | replicaData | User-defined serialized data representing how to construct the class. Could be the name of the class, a unique identifier, or other methods
[in] | recipient | Which system to send to. Use UNASSIGNED_SYSTEM_ADDRESS to send to all previously created connections. Connection_RM2Factory::AllocConnection will be called if this connection has not been previously used.
[in] | timestamp | Timestamp to send with the message. Use 0 to not send a timestamp if you don't need it.
[in] | sendMessage | True to actually send a network message. False to only register that the object exists on the remote system, useful for objects created outside ReplicaManager2, or objects that already existed in the world.
[in] | exclusionList | Which systems to not send to. This list is carried with the messsage, and appended to at each node in the connection graph. This is used to prevent infinite cyclical sends.
[in] | localClientId | If replica->QueryIsConstructionAuthority()==false, this number will be sent with SEND_CONSTRUCTION_REQUEST_TO_SERVER to the recipient. SEND_CONSTRUCTION_REPLY_ACCEPTED_TO_CLIENT or SEND_CONSTRUCTION_REPLY_DENIED_TO_CLIENT will be returned, and this number will be used to look up the local object in Replica2::clientPtrArray
[in] | type | What kind of serialization operation this is. Use one of the pre-defined types, or create your own. This will be returned in type in Connection_RM2::Construct()
[in] | priority | PacketPriority to send with. Use NUMBER_OF_PRIORITIES to use the default defined by SetDefaultPacketPriority().
[in] | reliability | PacketReliability to send with. Use NUMBER_OF_RELIABILITIES to use the default defined by SetDefaultPacketReliability();
[in] | orderingChannel | ordering channel to send on. Use -1 to use the default defined by SetDefaultOrderingChannel()
Precondition:
Call SetConnectionFactory() with a derived instance of Connection_RM2Factory.

void ReplicaManager2::SendDestruction | ( | Replica2 * | replica,
 |  | BitStream * | replicaData,
 |  | SystemAddress | recipient,
 |  | RakNetTime | timestamp,
 |  | bool | sendMessage,
 |  | DataStructures::OrderedList< SystemAddress, SystemAddress > & | exclusionList,
 |  | SerializationType | type = SEND_DESTRUCTION_GENERIC_TO_SYSTEM,
 |  | PacketPriority | priority = NUMBER_OF_PRIORITIES,
 |  | PacketReliability | reliability = NUMBER_OF_RELIABILITIES,
 |  | char | orderingChannel = -1
 | ) |  |

Sends a destruction command to one or more systems, which will be relayed throughout the network. Recipient(s) will allocate the connection via Connection_RM2Factory::AllocConnection() if it does not already exist. Will trigger a call on the remote system(s) to Replica2::ReceiveDestruction() which in turn calls Replica2::DeserializeDestruction() with the value passed in replicaData Note: This is a low level function. Beginners may wish to use Replica2::SendDestruction() or Replica2::BroadcastDestruction().

Parameters:
[in] | replica | The class to destroy remotely
[in] | replicaData | User-defined serialized data. Passed to Replica2::ReceiveDestruction()
[in] | recipient | Which system to send to. Use UNASSIGNED_SYSTEM_ADDRESS to send to all previously created connections. Connection_RM2Factory::AllocConnection will be called if this connection has not been previously used.
[in] | timestamp | Timestamp to send with the message. Use 0 to not send a timestamp if you don't need it.
[in] | sendMessage | True to actually send a network message. False to only register that the object no longer exists on the remote system.
[in] | exclusionList | Which systems to not send to. This list is carried with the messsage, and appended to at each node in the connection graph. This is used to prevent infinite cyclical sends.
[in] | type | What kind of serialization operation this is. Use one of the pre-defined types, or create your own. This will be returned in type in Connection_RM2::Construct()
[in] | priority | PacketPriority to send with. Use NUMBER_OF_PRIORITIES to use the default defined by SetDefaultPacketPriority().
[in] | reliability | PacketReliability to send with. Use NUMBER_OF_RELIABILITIES to use the default defined by SetDefaultPacketReliability();
[in] | orderingChannel | ordering channel to send on. Use -1 to use the default defined by SetDefaultOrderingChannel()
Precondition:
Replica::QueryIsDestructionAuthority() must return true

Call SetConnectionFactory() with a derived instance of Connection_RM2Factory.

void ReplicaManager2::SendSerialize | ( | Replica2 * | replica,
 |  | BitStream * | replicaData,
 |  | SystemAddress | recipient,
 |  | RakNetTime | timestamp,
 |  | DataStructures::OrderedList< SystemAddress, SystemAddress > & | exclusionList,
 |  | SerializationType | type = SEND_SERIALIZATION_GENERIC_TO_SYSTEM,
 |  | PacketPriority | priority = NUMBER_OF_PRIORITIES,
 |  | PacketReliability | reliability = NUMBER_OF_RELIABILITIES,
 |  | char | orderingChannel = -1
 | ) |  |

Sends a serialized object to one or more systems, which will be relayed throughout the network. Recipient(s) will allocate the connection via Connection_RM2Factory::AllocConnection() if it does not already exist. Will trigger a call on the remote system(s) to Replica2::ReceiveSerialization() which in turn calls Replica2::Deserialize() with the value passed in replicaData Note: This is a low level function. Beginners may wish to use Replica2::SendSerialize() or Replica2::BroadcastSerialize().

Parameters:
[in] | replica | The class to serialize
[in] | replicaData | User-defined serialized data. Passed to Replica2::ReceiveSerialization()
[in] | recipient | Which system to send to. Use UNASSIGNED_SYSTEM_ADDRESS to send to all previously created connections. Connection_RM2Factory::AllocConnection will be called if this connection has not been previously used.
[in] | timestamp | Timestamp to send with the message. Use 0 to not send a timestamp if you don't need it.
[in] | exclusionList | Which systems to not send to. This list is carried with the messsage, and appended to at each node in the connection graph. This is used to prevent infinite cyclical sends.
[in] | type | What kind of serialization operation this is. Use one of the pre-defined types, or create your own. This will be returned in type in Connection_RM2::Construct()
[in] | priority | PacketPriority to send with. Use NUMBER_OF_PRIORITIES to use the default defined by SetDefaultPacketPriority().
[in] | reliability | PacketReliability to send with. Use NUMBER_OF_RELIABILITIES to use the default defined by SetDefaultPacketReliability();
[in] | orderingChannel | ordering channel to send on. Use -1 to use the default defined by SetDefaultOrderingChannel()
Precondition:
Replica::QueryIsSerializationAuthority() must return true

Call SetConnectionFactory() with a derived instance of Connection_RM2Factory.

void ReplicaManager2::SendVisibility | ( | Replica2 * | replica,
 |  | BitStream * | replicaData,
 |  | SystemAddress | recipient,
 |  | RakNetTime | timestamp,
 |  | DataStructures::OrderedList< SystemAddress, SystemAddress > & | exclusionList,
 |  | SerializationType | type = SEND_VISIBILITY_TRUE_TO_SYSTEM,
 |  | PacketPriority | priority = NUMBER_OF_PRIORITIES,
 |  | PacketReliability | reliability = NUMBER_OF_RELIABILITIES,
 |  | char | orderingChannel = -1
 | ) |  |

Sets the visibility status of an object. which will be relayed throughout the network. Objects that are not visible should be hidden in the game world, and will not send AutoSerialize updates Recipient(s) will allocate the connection via Connection_RM2Factory::AllocConnection() if it does not already exist. Will trigger a call on the remote system(s) to Connection_RM2::ReceiveVisibility() Note: This is a low level function. Beginners may wish to use Connection_RM2::SendVisibility() or override Replica2::QueryVisibility()

Parameters:
[in] | objectList | The objects to send to the system.
[in] | replicaData | User-defined serialized data. Read in Connection_RM2::ReceiveVisibility()
[in] | recipient | Which system to send to. Use UNASSIGNED_SYSTEM_ADDRESS to send to all previously created connections. Connection_RM2Factory::AllocConnection will be called if this connection has not been previously used.
[in] | timestamp | Timestamp to send with the message. Use 0 to not send a timestamp if you don't need it.
[in] | sendMessage | True to actually send a network message. False to only register that the objects exist on the remote system
[in] | type | What kind of serialization operation this is. Use one of the pre-defined types, or create your own. This will be returned in type in Connection_RM2::Construct()
[in] | priority | PacketPriority to send with. Use NUMBER_OF_PRIORITIES to use the default defined by SetDefaultPacketPriority().
[in] | reliability | PacketReliability to send with. Use NUMBER_OF_RELIABILITIES to use the default defined by SetDefaultPacketReliability();
[in] | orderingChannel | ordering channel to send on. Use -1 to use the default defined by SetDefaultOrderingChannel()
Precondition:
Replica::QueryIsConstructionAuthority() must return true

Call SetConnectionFactory() with a derived instance of Connection_RM2Factory.

unsigned ReplicaManager2::GetReplicaCount ( void ) const

Returns how many Replica2 instances are registered. Replica2 instances are automatically registered when used, and unregistered when calling Deref (which is automatically done in the destructor). Used for GetReplicaAtIndex if you want to perform some object on all registered Replica objects.

Returns:
How many replica objects are in the list of replica objects

Replica2 * ReplicaManager2::GetReplicaAtIndex ( unsigned index )

Returns a previously registered Replica2 *, from index 0 to GetReplicaCount()-1. Replica2* objects are returned in the order they were registered.

Parameters:
[in] index An index, from 0 to GetReplicaCount()-1.
Returns:
A Replica2 pointer

unsigned ReplicaManager2::GetConnectionCount ( void ) const

Returns the number of registered connections. Connections are registered implicitly when used. Connections are unregistered on disconnect.

Returns:
The number of registered connections

Connection_RM2 * ReplicaManager2::GetConnectionAtIndex ( unsigned index ) const

Returns a connection pointer previously implicitly added.

Parameters:
[in] index An index, from 0 to GetConnectionCount()-1.
Returns:
A Connection_RM2 pointer

Connection_RM2 * ReplicaManager2::GetConnectionBySystemAddress ( SystemAddress systemAddress ) const

Returns a connection pointer previously implicitly added.

Parameters:
[in] systemAddress The system address of the connection to return
Returns:
A Connection_RM2 pointer

unsigned int ReplicaManager2::GetConnectionIndexBySystemAddress ( SystemAddress systemAddress ) const

Returns the index of a connection, by SystemAddress

Parameters:
[in] systemAddress The system address of the connection index to return
Returns:
The connection index, or -1 if no such connection

void ReplicaManager2::RecalculateVisibility ( Replica2 * replica )

Call this when Replica2::QueryVisibility() or Replica2::QueryConstructionVisibility() changes from BQR_ALWAYS or BQR_NEVER to BQR_YES or BQR_NO Otherwise these two conditions are assumed to never change

Parameters:
[in] Which replica to update

void ReplicaManager2::GetConnectionsWithReplicaConstructed | ( | Replica2 * | replica,
 |  | DataStructures::OrderedList< SystemAddress, Connection_RM2 *, ReplicaManager2::Connection_RM2CompBySystemAddress > & | output
 | ) |  |

Given a replica instance, return all connections that are believed to have this replica instantiated.

Parameters:
[in] | replica | Which replica is being refered to
[out] | output | List of connections, ordered by system address

void ReplicaManager2::GetConnectionsWithSerializeVisibility | ( | Replica2 * | replica,
 |  | DataStructures::OrderedList< SystemAddress, Connection_RM2 *, ReplicaManager2::Connection_RM2CompBySystemAddress > & | output
 | ) |  |

Given a replica instance, return all connections that are believed to have this replica visible

Parameters:
[in] | replica | Which replica is being refered to
[out] | output | List of connections, ordered by system address

RakPeerInterface * ReplicaManager2::GetRakPeer ( void ) const

Gets the instance of RakPeerInterface that this plugin was attached to

Returns:
The instance of RakPeerInterface that this plugin was attached to

void ReplicaManager2::Reference | ( | Replica2 * | replica,
 |  | bool * | newReference
 | ) |  |

Internally starts tracking this replica

void ReplicaManager2::Dereference ( Replica2 * replica )

Stops tracking this replica. Call before deleting the Replica. Done automatically in ~Replica()

void ReplicaManager2::OnAttach ( RakPeerInterface * peer ) [protected, virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult ReplicaManager2::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [protected, virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void ReplicaManager2::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [protected, virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

void ReplicaManager2::OnShutdown ( RakPeerInterface * peer ) [protected, virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void ReplicaManager2::Update ( RakPeerInterface * peer ) [protected, virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/ReplicaManager2.h
  • C:/RakNet/Source/ReplicaManager2.cpp
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Router Class Reference

Router Class Reference
[Router]

Used to route messages between peers. More...

#include <Router.h>

Inheritance diagram for Router:

PluginInterface RouterInterface List of all members.

Public Member Functions

void | SetRestrictRoutingByType (bool restrict__)
void | AddAllowedType (unsigned char messageId)
void | RemoveAllowedType (unsigned char messageId)
void | SetConnectionGraph (DataStructures::WeightedGraph< ConnectionGraph::SystemAddressAndGroupId, unsigned short, false > *connectionGraph)
bool | Send (char *data, BitSize_t bitLength, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddressList *recipients)
virtual void | OnAttach (RakPeerInterface *peer)
virtual void | OnDetach (RakPeerInterface *peer)
virtual void | OnShutdown (RakPeerInterface *peer)
virtual void | Update (RakPeerInterface *peer)
virtual PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
virtual void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)

Detailed Description

Used to route messages between peers.

Member Function Documentation

void Router::SetRestrictRoutingByType ( bool restrict__ )

We can restrict what kind of messages are routed by this plugin. This is useful for security, since you usually want to restrict what kind of messages you have to worry about from (as an example) other clients in a client / server system

Parameters:
[in] restrict True to restrict what messages will be routed. False to not do so (default).

void Router::AddAllowedType ( unsigned char messageId )

If types are restricted, this adds an allowed message type to be routed

Parameters:
[in] messageId The type to not allow routing of.

void Router::RemoveAllowedType ( unsigned char messageId )

Removes a restricted type previously added with AddRestrictedType

Parameters:
[in] messageId The type to no longer restrict routing of.

void Router::SetConnectionGraph ( DataStructures::WeightedGraph< ConnectionGraph::SystemAddressAndGroupId, unsigned short, false > * connectionGraph )

Set the connection graph, which is a weighted graph of the topology of the network. You can easily get this from the ConnectionGraph plugin. See the 'router' sample for usage. This is necessary if you want to send (not necessary just to route).

Parameters:
[in] connectionGraph A weighted graph representing the topology of the network.

bool Router::Send | ( | char * | data,
 |  | BitSize_t | bitLength,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | SystemAddressList * | recipients
 | ) |  |

Sends a bitstream to one or more systems. If multiple systems are specified, the message will be multicasted using a minimum spanning tree

Precondition:
You just have called SetConnectionGraph with a valid graph representing the network topology
Note:
Single target sends from RakPeer with this plugin installed will also be routed. Sends from other plugins will also be routed as long as this plugin is attached first.
Parameters:
[in] | data | The data to send
[in] | bitLength | How many bits long data is
[in] | priority | What priority level to send on.
[in] | reliability | How reliability to send this data
[in] | orderingChannel | When using ordered or sequenced packets, what channel to order these on.- Packets are only ordered relative to other packets on the same stream
[in] | recipients | A list of recipients to send to. To send to one recipient, just pass a SystemAddress
Returns:
True on success, false mostly if the connection graph cannot find the destination.

void Router::OnAttach ( RakPeerInterface * peer ) [virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void Router::OnDetach ( RakPeerInterface * peer ) [virtual]

Called when the interface is detached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void Router::OnShutdown ( RakPeerInterface * peer ) [virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

void Router::Update ( RakPeerInterface * peer ) [virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult Router::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void Router::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/Router.h
  • C:/RakNet/Source/Router.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RouterInterface Class Reference

RouterInterface Class Reference

On failed directed sends, RakNet can call an alternative send function to use. More...

#include <RouterInterface.h>

Inheritance diagram for RouterInterface:

Router List of all members.

Detailed Description

On failed directed sends, RakNet can call an alternative send function to use.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/RouterInterface.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::RPC3 Class Reference

RakNet::RPC3

RakNet::RPC3 Class Reference
[RPC3]

#include <RPC3.h>

Inheritance diagram for RakNet::RPC3:

PluginInterface List of all members.

Public Member Functions

RPC3 ()
Constructor.
virtual | ~RPC3 ()
Destructor.
void | SetNetworkIDManager (NetworkIDManager *idMan)
template<typename Function>
bool | RegisterFunction (const char *uniqueIdentifier, Function functionPtr)
bool | UnregisterFunction (const char *uniqueIdentifier)
bool | IsFunctionRegistered (const char *uniqueIdentifier)
void | SetTimestamp (RakNetTime timeStamp)
void | SetSendParams (PacketPriority priority, PacketReliability reliability, char orderingChannel)
void | SetRecipientAddress (SystemAddress systemAddress, bool broadcast)
void | SetRecipientObject (NetworkID networkID)
RakNetTime | GetLastSenderTimestamp (void) const
SystemAddress | GetLastSenderAddress (void) const
RakPeerInterface * | GetRakPeer (void) const
Returns the instance of RakPeer this plugin was attached to.
const char * | GetCurrentExecution (void) const
bool | Call (const char *uniqueIdentifier)
bool | CallExplicit (const char *uniqueIdentifier, const CallExplicitParameters *const callExplicitParameters)

Protected Member Functions

void | OnAttach (RakPeerInterface *peer)
virtual PluginReceiveResult | OnReceive (RakPeerInterface *peer, Packet *packet)
virtual void | OnCloseConnection (RakPeerInterface *peer, SystemAddress systemAddress)
virtual void | OnShutdown (RakPeerInterface *peer)

Detailed Description

The RPC3 plugin allows you to call remote functions as if they were local functions, using the standard function call syntax No serialization or deserialization is needed. Features: 1. Pointers to classes that derive from NetworkID are automatically looked up using NetworkIDManager 2. Types are written to BitStream, meaning built-in serialization operations are performed, including endian swapping 3. Types can customize autoserialization by providing an implementation of operator << and operator >> to and from BitStream

Member Function Documentation

void RPC3::SetNetworkIDManager ( NetworkIDManager * idMan )

Sets the network ID manager to use for object lookup Required to call C++ object member functions via SetRecipientObject()

Parameters:
[in] idMan Pointer to the network ID manager to use

template<typename Function>
bool RakNet::RPC3::RegisterFunction | ( | const char * | uniqueIdentifier,
 |  | Function | functionPtr |
 | ) |  |  | [inline]

Parameters:
[in] | uniqueIdentifier | String identifying the function. Recommended that this is the name of the function
[in] | functionPtr | Pointer to the function. For C, just pass the name of the function. For C++, use ARPC_REGISTER_CPP_FUNCTION
Returns:
True on success, false on uniqueIdentifier already used

bool RPC3::UnregisterFunction ( const char * uniqueIdentifier )

Unregisters a function pointer to be callable given an identifier for the pointer

Parameters:
[in] uniqueIdentifier String identifying the function.
Returns:
True on success, false on function was not previously or is not currently registered.

bool RPC3::IsFunctionRegistered ( const char * uniqueIdentifier )

Returns if a function identifier was previously registered with RegisterFunction(), and not unregistered with UnregisterFunction()

Parameters:
[in] uniqueIdentifier String identifying the function.
Returns:
True if the function was registered, false otherwise

void RPC3::SetTimestamp ( RakNetTime timeStamp )

Send or stop sending a timestamp with all following calls to Call() Use GetLastSenderTimestamp() to read the timestamp.

Parameters:
[in] timeStamp Non-zero to pass this timestamp using the ID_TIMESTAMP system. 0 to clear passing a timestamp.

void RPC3::SetSendParams | ( | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel
 | ) |  |

Set parameters to pass to RakPeer::Send() for all following calls to Call() Deafults to HIGH_PRIORITY, RELIABLE_ORDERED, ordering channel 0

Parameters:
[in] | priority | See RakPeer::Send()
[in] | reliability | See RakPeer::Send()
[in] | orderingChannel | See RakPeer::Send()

void RPC3::SetRecipientAddress | ( | SystemAddress | systemAddress,
 |  | bool | broadcast
 | ) |  |

Set system to send to for all following calls to Call() Defaults to UNASSIGNED_SYSTEM_ADDRESS, broadcast=true

Parameters:
[in] | systemAddress | See RakPeer::Send()
[in] | broadcast | See RakPeer::Send()

void RPC3::SetRecipientObject ( NetworkID networkID )

Set the NetworkID to pass for all following calls to Call() Defaults to UNASSIGNED_NETWORK_ID (none) If set, the remote function will be considered a C++ function, e.g. an object member function If set to UNASSIGNED_NETWORK_ID (none), the remote function will be considered a C function If this is set incorrectly, you will get back either RPC_ERROR_CALLING_C_AS_CPP or RPC_ERROR_CALLING_CPP_AS_C

See also:
NetworkIDManager
Parameters:
[in] networkID Returned from NetworkIDObject::GetNetworkID()

RakNetTime RPC3::GetLastSenderTimestamp ( void ) const

If the last received function call has a timestamp included, it is stored and can be retrieved with this function.

Returns:
0 if the last call did not have a timestamp, else non-zero

SystemAddress RPC3::GetLastSenderAddress ( void ) const

Returns the system address of the last system to send us a received function call Equivalent to the old system RPCParameters::sender

Returns:
Last system to send an RPC call using this system

const char * RPC3::GetCurrentExecution ( void ) const

Returns the currently running RPC call identifier, set from RegisterFunction::uniqueIdentifier Returns an empty string "" if none

Returns:
which RPC call is currently running

bool RakNet::RPC3::Call ( const char * uniqueIdentifier ) [inline]

Calls a remote function, using as send parameters whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() If you call a C++ class member function, don't forget to first call SetRecipientObject(). You can use CallExplicit() instead of Call() to force yourself not to forget.

Parameters passed to Call are processed as follows: 1. If the parameter is not a pointer 2. - And you overloaded RakNet::BitStream& operator<<(RakNet::BitStream& out, MyClass& in) then that will be used to do the serialization 3. - Otherwise, it will use bitStream.Write(myClass); BitStream already defines specializations for NetworkIDObject, SystemAddress, other BitStreams 4. If the parameter is a pointer 5. - And the pointer can be converted to NetworkIDObject, then it will write bitStream.Write(myClass->GetNetworkID()); To make it also dereference the pointer, use RakNet::_RPC3::Deref(myClass) 6. - And the pointer can not be converted to NetworkID, but it is a pointer to RakNet::RPC3, then it is skipped 7. Otherwise, the pointer is dereferenced and written as in step 2 and 3.

Note:
If you need endian swapping (Mac talking to PC for example), you pretty much need to define operator << and operator >> for all classes you want to serialize. Otherwise the member variables will not be endian swapped.

If the call fails on the remote system, you will get back ID_RPC_REMOTE_ERROR. packet->data[1] will contain one of the values of RPCErrorCodes. packet->data[2] and on will contain the name of the function.

Parameters:
[in] uniqueIdentifier parameter of the same name passed to RegisterFunction() on the remote system

bool RakNet::RPC3::CallExplicit | ( | const char * | uniqueIdentifier,
 |  | const CallExplicitParameters *const | callExplicitParameters |
 | ) |  |  | [inline]

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are serialized using operator << with RakNet::BitStream. If you provide an overload it will be used, otherwise the seriailzation is equivalent to memcpy except for native RakNet types (NetworkIDObject, SystemAddress, etc.) If the type is a pointer to a type deriving from NetworkIDObject, then only the NetworkID is sent, and the object looked up on the remote system. Otherwise, the pointer is dereferenced and the contents serialized as usual.

Note:
The this pointer, for this instance of RPC3, is pushed as the last parameter on the stack. See RPC3Sample.cpp for an example of this

If the call fails on the remote system, you will get back ID_RPC_REMOTE_ERROR. packet->data[1] will contain one of the values of RPCErrorCodes. packet->data[2] and on will contain the name of the function.

Parameters:
[in] | uniqueIdentifier | parameter of the same name passed to RegisterFunction() on the remote system
[in] | timeStamp | See SetTimestamp()
[in] | priority | See SetSendParams()
[in] | reliability | See SetSendParams()
[in] | orderingChannel | See SetSendParams()
[in] | systemAddress | See SetRecipientAddress()
[in] | broadcast | See SetRecipientAddress()
[in] | networkID | See SetRecipientObject()

void RPC3::OnAttach ( RakPeerInterface * peer ) [protected, virtual]

Called when the interface is attached

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

PluginReceiveResult RPC3::OnReceive | ( | RakPeerInterface * | peer,
 |  | Packet * | packet |
 | ) |  |  | [protected, virtual]

OnReceive is called for every packet.

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | packet | the packet that is being returned to the user
Returns:
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from PluginInterface.

void RPC3::OnCloseConnection | ( | RakPeerInterface * | peer,
 |  | SystemAddress | systemAddress |
 | ) |  |  | [protected, virtual]

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters:
[in] | peer | the instance of RakPeer that is calling Receive
[in] | systemAddress | The system whose connection was closed

Reimplemented from PluginInterface.

void RPC3::OnShutdown ( RakPeerInterface * peer ) [protected, virtual]

Called when RakPeer is shutdown

Parameters:
[in] peer the instance of RakPeer that is calling Receive

Reimplemented from PluginInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/RPC3/RPC3.h
  • C:/RakNet/DependentExtensions/RPC3/RPC3.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RPCParameters Struct Reference

RPCParameters Struct Reference

#include <RakNetTypes.h>

List of all members.

Public Attributes

unsigned char * | input
The data from the remote system.
BitSize_t | numberOfBitsOfData
How many bits long input is.
SystemAddress sender
Which system called this RPC.
RakPeerInterface * recipient
Which instance of RakPeer (or a derived RakPeer or RakPeer) got this call.
char * | functionName
The name of the function that was called.
RakNet::BitStream * replyToSender

Detailed Description

All RPC functions have the same parameter list - this structure. Use the AutoRPC plugin instead

Member Data Documentation

RakNet::BitStream* RPCParameters::replyToSender

You can return values from RPC calls by writing them to this BitStream. This is only sent back if the RPC call originally passed a BitStream to receive the reply. If you do so and your send is reliable, it will block until you get a reply or you get disconnected from the system you are sending to, whichever is first. If your send is not reliable, it will block for triple the ping time, or until you are disconnected, or you get a reply, whichever is first.

The documentation for this struct was generated from the following file:
  • C:/RakNet/Source/RakNetTypes.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SBDecState Struct Reference

SBDecState Struct Reference

#include <sb_celp.h>

List of all members.

Public Attributes

const SpeexMode * | mode
void * | st_low

Detailed Description

Structure representing the full state of the sub-band decoder

Member Data Documentation

const SpeexMode* SBDecState::mode

Pointer to the mode (containing for vtable info)

void* SBDecState::st_low

State of the low-band (narrowband) encoder

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/sb_celp.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SBEncState Struct Reference

SBEncState Struct Reference

#include <sb_celp.h>

List of all members.

Public Attributes

const SpeexMode * | mode
void * | st_low
int | full_frame_size
int | frame_size
int | subframeSize
int | nbSubframes
int | windowSize
int | lpcSize
int | bufSize
int | first
float | lag_factor
spx_word16_t | lpc_floor
spx_word16_t | gamma1
spx_word16_t | gamma2
char * | stack
spx_sig_t * | x1d
spx_sig_t * | high
spx_sig_t * | y1
spx_word32_t * | g1_mem
spx_sig_t * | excBuf
spx_sig_t * | exc
spx_sig_t * | res
spx_sig_t * | sw
spx_sig_t * | target
spx_word16_t * | window
spx_word16_t * | lagWindow
spx_word16_t * | autocorr
spx_coef_t * | lpc
spx_lsp_t * | lsp
spx_lsp_t * | qlsp
spx_lsp_t * | old_lsp
spx_lsp_t * | old_qlsp
spx_lsp_t * | interp_lsp
spx_lsp_t * | interp_qlsp
spx_coef_t * | interp_lpc
spx_coef_t * | interp_qlpc
spx_coef_t * | bw_lpc1
spx_coef_t * | bw_lpc2
spx_mem_t * | mem_sp
spx_mem_t * | mem_sw
float | vbr_quality
int | vbr_enabled
int | abr_enabled
int | vad_enabled

Detailed Description

Structure representing the full state of the sub-band encoder

Member Data Documentation

const SpeexMode* SBEncState::mode

Pointer to the mode (containing for vtable info)

void* SBEncState::st_low

State of the low-band (narrowband) encoder

int SBEncState::full_frame_size

Length of full-band frames

int SBEncState::frame_size

Length of high-band frames

int SBEncState::subframeSize

Length of high-band sub-frames

int SBEncState::nbSubframes

Number of high-band sub-frames

int SBEncState::windowSize

Length of high-band LPC window

int SBEncState::lpcSize

Order of high-band LPC analysis

int SBEncState::bufSize

Buffer size

int SBEncState::first

First frame?

float SBEncState::lag_factor

Lag-windowing control parameter

spx_word16_t SBEncState::lpc_floor

Controls LPC analysis noise floor

spx_word16_t SBEncState::gamma1

Perceptual weighting coef 1

spx_word16_t SBEncState::gamma2

Perceptual weighting coef 2

char* SBEncState::stack

Temporary allocation stack

spx_sig_t * SBEncState::x1d

QMF filter signals

spx_sig_t* SBEncState::high

High-band signal (buffer)

spx_sig_t * SBEncState::y1

QMF synthesis signals

spx_word32_t * SBEncState::g1_mem

QMF memories

spx_sig_t* SBEncState::excBuf

High-band excitation

spx_sig_t* SBEncState::exc

High-band excitation (for QMF only)

spx_sig_t* SBEncState::res

Zero-input response (ringing)

spx_sig_t* SBEncState::sw

Perceptually weighted signal

spx_sig_t* SBEncState::target

Weighted target signal (analysis by synthesis)

spx_word16_t* SBEncState::window

LPC analysis window

spx_word16_t* SBEncState::lagWindow

Auto-correlation window

spx_word16_t* SBEncState::autocorr

Auto-correlation (for LPC analysis)

spx_coef_t* SBEncState::lpc

LPC coefficients

spx_lsp_t* SBEncState::lsp

LSP coefficients

spx_lsp_t* SBEncState::qlsp

Quantized LSPs

spx_lsp_t* SBEncState::old_lsp

LSPs of previous frame

spx_lsp_t* SBEncState::old_qlsp

Quantized LSPs of previous frame

spx_lsp_t* SBEncState::interp_lsp

Interpolated LSPs for current sub-frame

spx_lsp_t* SBEncState::interp_qlsp

Interpolated quantized LSPs for current sub-frame

spx_coef_t* SBEncState::interp_lpc

Interpolated LPCs for current sub-frame

spx_coef_t* SBEncState::interp_qlpc

Interpolated quantized LPCs for current sub-frame

spx_coef_t* SBEncState::bw_lpc1

Bandwidth-expanded version of LPCs (#1)

spx_coef_t* SBEncState::bw_lpc2

Bandwidth-expanded version of LPCs (#2)

spx_mem_t* SBEncState::mem_sp

Synthesis signal memory

spx_mem_t* SBEncState::mem_sw

Perceptual signal memory

float SBEncState::vbr_quality

Quality setting for VBR encoding

int SBEncState::vbr_enabled

1 for enabling VBR, 0 otherwise

int SBEncState::abr_enabled

ABR setting (in bps), 0 if off

int SBEncState::vad_enabled

1 for enabling VAD, 0 otherwise

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/sb_celp.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SendDownloadCompleteInterface Class Reference

SendDownloadCompleteInterface Class Reference
[ReplicaManager]

#include <ReplicaManager.h>

List of all members.

Public Member Functions

virtual ReplicaReturnResult SendDownloadComplete (RakNet::BitStream *outBitStream, RakNetTime currentTime, SystemAddress senderId, ReplicaManager *caller)=0

Detailed Description

An interface for a class that handles the call to send the download complete notification See ReplicaManager::SetDownloadCompleteCB

Member Function Documentation

virtual ReplicaReturnResult SendDownloadCompleteInterface::SendDownloadComplete | ( | RakNet::BitStream * | outBitStream,
 |  | RakNetTime | currentTime,
 |  | SystemAddress | senderId,
 |  | ReplicaManager * | caller |
 | ) |  |  | [pure virtual]

Parameters:
[out] | outBitStream | Write whatever you want to this bitstream. It will arrive in the receiveDownloadCompleteCB callback.
[in] | currentTime | The current time that would be returned by RakNet::GetTime(). That's a slow call I do already, so you can use the parameter instead of having to call it yourself.
[in] | senderId | Who we are sending to
[in] | caller | Which instance of ReplicaManager is calling this interface
Returns:
See ReplicaReturnResult

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/ReplicaManager.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::SendEmail_Data Class Reference

LobbyDBSpec::SendEmail_Data

LobbyDBSpec::SendEmail_Data Class Reference

Adds an email to the emails table. Added once for the user with inbox=false, n times for n recipients with inbox=true. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::SendEmail_Data:

RefCountedObj List of all members.

Public Attributes

RowIdOrHandle | id
DataStructures::List< LobbyDBSpec::RowIdOrHandle > | to
[in] recipients, used for SendEmail
RakNet::RakString subject
[in] Email subject
RakNet::RakString body
[in] Email body
char * | attachment
[in] Binary data of your choosing. Set to 0, or attachmentLength to 0 to not use.
unsigned int | attachmentLength
[in] Length of the binary data
int | initialSenderStatus
[in] Use for your own status flags (marked, read, priority, etc). Update with UpdateEmailStatus
int | status
[out] Current status of the email, Used by GetEmails_Data
bool | wasOpened
long long | creationTime
[out] When this row was added to the database. Used by GetEmails_Data.
DatabaseKey | emailMessageID
[out] Email primary key. Used by GetEmails_Data.
bool | validParameters
[out] Are the parameters of this email valid?
RakNet::RakString failureMessage
[out] If validParameters==false, this is why

Detailed Description

Adds an email to the emails table. Added once for the user with inbox=false, n times for n recipients with inbox=true.

Member Data Documentation

RowIdOrHandle LobbyDBSpec::SendEmail_Data::id

[in] When sending, our own system [out] When calling GetEmails, the other system (the one that sent us the email, or the one we sent to)

bool LobbyDBSpec::SendEmail_Data::wasOpened

[in/out] For sending emails, initially mark this email as opened? For receiving mails, can be set by UpdateEmailStatus_Data Also returned by by GetEmails_Data

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.cpp
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::SerializationContext Struct Reference

RakNet::SerializationContext

RakNet::SerializationContext Struct Reference
[ReplicaManager2]

Contextual information about serialization, passed to some functions in Replica2. More...

#include <ReplicaManager2.h>

List of all members.

Static Public Member Functions

static bool | IsSerializationCommand (SerializationType r)
General category of serialization.
static bool | IsDownloadCommand (SerializationType r)
General category of serialization.
static bool | IsDestructionCommand (SerializationType r)
General category of serialization.
static bool | IsConstructionCommand (SerializationType r)
General category of serialization.
static bool | IsVisibilityCommand (SerializationType r)
General category of serialization.
static bool | IsVisible (SerializationType r)
General category of serialization.

Public Attributes

SystemAddress relaySourceAddress
The system that sent the message to us.
SystemAddress recipientAddress
The system that we are sending to.
RakNetTime | timestamp
Timestamp to send with the message. 0 means undefined. Set to non-zero to actually transmit using ID_TIMESTAMP.
SerializationType serializationType
What type of serialization was performed.

Detailed Description

Contextual information about serialization, passed to some functions in Replica2.

The documentation for this struct was generated from the following files:
  • C:/RakNet/Source/ReplicaManager2.h
  • C:/RakNet/Source/ReplicaManager2.cpp
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SimpleMutex Class Reference

SimpleMutex Class Reference

An easy to use mutex. More...

#include <SimpleMutex.h>

List of all members.

Public Member Functions

SimpleMutex ()
Constructor.

Detailed Description

An easy to use mutex.

I wrote this because the version that comes with Windows is too complicated and requires too much code to use.

Remarks:
Previously I used this everywhere, and in fact for a year or two RakNet was totally threadsafe. While doing profiling, I saw that this function was incredibly slow compared to the blazing performance of everything else, so switched to single producer / consumer everywhere. Now the user thread of RakNet is not threadsafe, but it's 100X faster than before.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/SimpleMutex.h
  • C:/RakNet/Source/SimpleMutex.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::SingleProducerConsumer< SingleProducerConsumerType > Class Template Reference

DataStructures::SingleProducerConsumer

DataStructures::SingleProducerConsumer< SingleProducerConsumerType > Class Template Reference

A single producer consumer implementation without critical sections. More...

#include <SingleProducerConsumer.h>

List of all members.

Public Member Functions

SingleProducerConsumer ()
Constructor.
~SingleProducerConsumer ()
Destructor.
SingleProducerConsumerType * | WriteLock (void)
void | CancelWriteLock (SingleProducerConsumerType *cancelToLocation)
void | WriteUnlock (void)
Call when you are done writing to a block of memory returned by WriteLock().
SingleProducerConsumerType * | ReadLock (void)
void | CancelReadLock (SingleProducerConsumerType *cancelToLocation)
param[in] Which ReadLock() to cancel.
void | ReadUnlock (void)
void | Clear (void)
Clear is not thread-safe and none of the lock or unlock functions should be called while it is running.
int | Size (void) const
bool | CheckReadUnlockOrder (const SingleProducerConsumerType *data) const
bool | ReadIsLocked (void) const

Detailed Description

template<class SingleProducerConsumerType>
class DataStructures::SingleProducerConsumer< SingleProducerConsumerType >

A single producer consumer implementation without critical sections.

Member Function Documentation

template<class SingleProducerConsumerType>
SingleProducerConsumerType * DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::WriteLock ( void )

WriteLock must be immediately followed by WriteUnlock. These two functions must be called in the same thread.

Returns:
A pointer to a block of data you can write to.

template<class SingleProducerConsumerType>
void DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::CancelWriteLock ( SingleProducerConsumerType * cancelToLocation )

Call if you don't want to write to a block of data from WriteLock() after all. Cancelling locks cancels all locks back up to the data passed. So if you lock twice and cancel using the first lock, the second lock is ignored

Parameters:
[in] cancelToLocation Which WriteLock() to cancel.

template<class SingleProducerConsumerType>
SingleProducerConsumerType * DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::ReadLock ( void )

ReadLock must be immediately followed by ReadUnlock. These two functions must be called in the same thread.

Return values:
0 | No data is availble to read
Non-zero | The data previously written to, in another thread, by WriteLock followed by WriteUnlock.

template<class SingleProducerConsumerType>
void DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::ReadUnlock ( void )

Signals that we are done reading the the data from the least recent call of ReadLock. At this point that pointer is no longer valid, and should no longer be read.

template<class SingleProducerConsumerType>
int DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::Size ( void ) const

This function will estimate how many elements are waiting to be read. It's threadsafe enough that the value returned is stable, but not threadsafe enough to give accurate results.

Returns:
An ESTIMATE of how many data elements are waiting to be read

template<class SingleProducerConsumerType>
bool DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::CheckReadUnlockOrder ( const SingleProducerConsumerType * data ) const

Make sure that the pointer we done reading for the call to ReadUnlock is the right pointer. param[in] A previous pointer returned by ReadLock()

template<class SingleProducerConsumerType>
bool DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::ReadIsLocked ( void ) const

Returns if ReadUnlock was called before ReadLock

Returns:
If the read is locked

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/SingleProducerConsumer.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SocketDescriptor Struct Reference

SocketDescriptor Struct Reference

Describes the local socket to use for RakPeer::Startup. More...

#include <RakNetTypes.h>

List of all members.

Public Attributes

unsigned short | port
The local port to bind to. Pass 0 to have the OS autoassign a port.
char | hostAddress [32]
The local network card address to bind to, such as "127.0.0.1". Pass an empty string to use INADDR_ANY.

Detailed Description

Describes the local socket to use for RakPeer::Startup.

The documentation for this struct was generated from the following files:
  • C:/RakNet/Source/RakNetTypes.h
  • C:/RakNet/Source/RakNetTypes.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SpeexBits Struct Reference

SpeexBits Struct Reference

#include <speex_bits.h>

List of all members.

Public Attributes

char * | chars
int | nbBits
int | charPtr
int | bitPtr
int | owner
int | overflow
int | buf_size
int | reserved1
void * | reserved2

Detailed Description

Bit-packing data structure representing (part of) a bit-stream.

Member Data Documentation

char* SpeexBits::chars

"raw" data

int SpeexBits::nbBits

Total number of bits stored in the stream

int SpeexBits::charPtr

Position of the byte "cursor"

int SpeexBits::bitPtr

Position of the bit "cursor" within the current char

int SpeexBits::owner

Does the struct "own" the "raw" buffer (member "chars")

int SpeexBits::overflow

Set to one if we try to read past the valid data

int SpeexBits::buf_size

Allocated size for buffer

int SpeexBits::reserved1

Reserved for future use

void* SpeexBits::reserved2

Reserved for future use

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_bits.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SpeexCallback Struct Reference

SpeexCallback Struct Reference

#include <speex_callbacks.h>

List of all members.

Public Attributes

int | callback_id
speex_callback_func func
void * | data
void * | reserved1
int | reserved2

Detailed Description

Callback information

Member Data Documentation

int SpeexCallback::callback_id

ID associated to the callback

speex_callback_func SpeexCallback::func

Callback handler function

void* SpeexCallback::data

Data that will be sent to the handler

void* SpeexCallback::reserved1

Reserved for future use

int SpeexCallback::reserved2

Reserved for future use

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_callbacks.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SpeexEchoState_ Struct Reference

SpeexEchoState_ Struct Reference

List of all members.

Public Attributes

int frame_size

Detailed Description

Speex echo cancellation state.

Member Data Documentation

int SpeexEchoState_::frame_size

Number of samples processed each time

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/mdf.c
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SpeexHeader Struct Reference

SpeexHeader Struct Reference

#include <speex_header.h>

List of all members.

Public Attributes

char | speex_string [SPEEX_HEADER_STRING_LENGTH]
char | speex_version [SPEEX_HEADER_VERSION_LENGTH]
spx_int32_t | speex_version_id
spx_int32_t | header_size
spx_int32_t | rate
spx_int32_t | mode
spx_int32_t | mode_bitstream_version
spx_int32_t | nb_channels
spx_int32_t | bitrate
spx_int32_t | frame_size
spx_int32_t | vbr
spx_int32_t | frames_per_packet
spx_int32_t | extra_headers
spx_int32_t | reserved1
spx_int32_t | reserved2

Detailed Description

Speex header info for file-based formats

Member Data Documentation

char SpeexHeader::speex_string[SPEEX_HEADER_STRING_LENGTH]

Identifies a Speex bit-stream, always set to "Speex "

char SpeexHeader::speex_version[SPEEX_HEADER_VERSION_LENGTH]

Speex version

spx_int32_t SpeexHeader::speex_version_id

Version for Speex (for checking compatibility)

spx_int32_t SpeexHeader::header_size

Total size of the header ( sizeof(SpeexHeader) )

spx_int32_t SpeexHeader::rate

Sampling rate used

spx_int32_t SpeexHeader::mode

Mode used (0 for narrowband, 1 for wideband)

spx_int32_t SpeexHeader::mode_bitstream_version

Version ID of the bit-stream

spx_int32_t SpeexHeader::nb_channels

Number of channels encoded

spx_int32_t SpeexHeader::bitrate

Bit-rate used

spx_int32_t SpeexHeader::frame_size

Size of frames

spx_int32_t SpeexHeader::vbr

1 for a VBR encoding, 0 otherwise

spx_int32_t SpeexHeader::frames_per_packet

Number of frames stored per Ogg packet

spx_int32_t SpeexHeader::extra_headers

Number of additional headers after the comments

spx_int32_t SpeexHeader::reserved1

Reserved for future use, must be zero

spx_int32_t SpeexHeader::reserved2

Reserved for future use, must be zero

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_header.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SpeexJitter Struct Reference

SpeexJitter Struct Reference

#include <speex_jitter.h>

List of all members.

Public Attributes

int | buffer_size
int | pointer_timestamp
SpeexBits current_packet
int | valid_bits
char | buf [SPEEX_JITTER_MAX_BUFFER_SIZE][SPEEX_JITTER_MAX_PACKET_SIZE]
int | timestamp [SPEEX_JITTER_MAX_BUFFER_SIZE]
int | len [SPEEX_JITTER_MAX_BUFFER_SIZE]
void * | dec
int | frame_size
int | frame_time
int | reset_state
int | lost_count
float | shortterm_margin [MAX_MARGIN]
float | longterm_margin [MAX_MARGIN]
float | loss_rate

Detailed Description

Speex jitter-buffer state.

Member Data Documentation

int SpeexJitter::buffer_size

Buffer size

int SpeexJitter::pointer_timestamp

Pointer timestamp

SpeexBits SpeexJitter::current_packet

Current Speex packet

int SpeexJitter::valid_bits

True if Speex bits are valid

char SpeexJitter::buf[SPEEX_JITTER_MAX_BUFFER_SIZE][SPEEX_JITTER_MAX_PACKET_SIZE]

Buffer of packets

int SpeexJitter::timestamp[SPEEX_JITTER_MAX_BUFFER_SIZE]

Timestamp of packet

int SpeexJitter::len[SPEEX_JITTER_MAX_BUFFER_SIZE]

Number of bytes in packet

void* SpeexJitter::dec

Pointer to Speex decoder

int SpeexJitter::frame_size

Frame size of Speex decoder

int SpeexJitter::frame_time

Frame time in [ms] of Speex decoder

int SpeexJitter::reset_state

True if Speex state was reset

int SpeexJitter::lost_count

Number of lost packets

float SpeexJitter::shortterm_margin[MAX_MARGIN]

Short term margins

float SpeexJitter::longterm_margin[MAX_MARGIN]

Long term margins

float SpeexJitter::loss_rate

Loss rate

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_jitter.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SpeexMode Struct Reference

SpeexMode Struct Reference

#include <speex.h>

List of all members.

Public Attributes

const void * | mode
mode_query_func query
const char * | modeName
int | modeID
int | bitstream_version
encoder_init_func enc_init
encoder_destroy_func enc_destroy
encode_func enc
decoder_init_func dec_init
decoder_destroy_func dec_destroy
decode_func dec
encoder_ctl_func enc_ctl
decoder_ctl_func dec_ctl

Detailed Description

Struct defining a Speex mode

Member Data Documentation

const void* SpeexMode::mode

Pointer to the low-level mode data

mode_query_func SpeexMode::query

Pointer to the mode query function

const char* SpeexMode::modeName

The name of the mode (you should not rely on this to identify the mode)

int SpeexMode::modeID

ID of the mode

int SpeexMode::bitstream_version

Version number of the bitstream (incremented every time we break bitstream compatibility

encoder_init_func SpeexMode::enc_init

Pointer to encoder initialization function

encoder_destroy_func SpeexMode::enc_destroy

Pointer to encoder destruction function

encode_func SpeexMode::enc

Pointer to frame encoding function

decoder_init_func SpeexMode::dec_init

Pointer to decoder initialization function

decoder_destroy_func SpeexMode::dec_destroy

Pointer to decoder destruction function

decode_func SpeexMode::dec

Pointer to frame decoding function

encoder_ctl_func SpeexMode::enc_ctl

ioctl-like requests for encoder

decoder_ctl_func SpeexMode::dec_ctl

ioctl-like requests for decoder

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SpeexNBMode Struct Reference

SpeexNBMode Struct Reference

#include <modes.h>

List of all members.

Public Attributes

int | frameSize
int | subframeSize
int | lpcSize
int | pitchStart
int | pitchEnd
spx_word16_t | gamma1
spx_word16_t | gamma2
float | lag_factor
spx_word16_t | lpc_floor
const SpeexSubmode * | submodes [NB_SUBMODES]
int | defaultSubmode
int | quality_map [11]

Detailed Description

Struct defining the encoding/decoding mode

Member Data Documentation

int SpeexNBMode::frameSize

Size of frames used for encoding

int SpeexNBMode::subframeSize

Size of sub-frames used for encoding

int SpeexNBMode::lpcSize

Order of LPC filter

int SpeexNBMode::pitchStart

Smallest pitch value allowed

int SpeexNBMode::pitchEnd

Largest pitch value allowed

spx_word16_t SpeexNBMode::gamma1

Perceptual filter parameter #1

spx_word16_t SpeexNBMode::gamma2

Perceptual filter parameter #2

float SpeexNBMode::lag_factor

Lag-windowing parameter

spx_word16_t SpeexNBMode::lpc_floor

Noise floor for LPC analysis

const SpeexSubmode* SpeexNBMode::submodes[NB_SUBMODES]

Sub-mode data for the mode

int SpeexNBMode::defaultSubmode

Default sub-mode to use when encoding

int SpeexNBMode::quality_map[11]

Mode corresponding to each quality setting

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/modes.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SpeexPreprocessState Struct Reference

SpeexPreprocessState Struct Reference

#include <speex_preprocess.h>

List of all members.

Public Attributes

int | frame_size
int | ps_size
int | sampling_rate
float * | frame
float * | ps
float * | gain2
float * | window
float * | noise
float * | reverb_estimate
float * | old_ps
float * | gain
float * | prior
float * | post
float * | S
float * | Smin
float * | Stmp
float * | update_prob
float * | zeta
float * | loudness_weight
float * | inbuf
float * | outbuf
float | loudness
float | loudness2
int | nb_adapt
int | nb_loudness_adapt
int | consec_noise
int | nb_preprocess
drft_lookup * fft_lookup

Detailed Description

Speex pre-processor state.

Member Data Documentation

int SpeexPreprocessState::frame_size

Number of samples processed each time

int SpeexPreprocessState::ps_size

Number of points in the power spectrum

int SpeexPreprocessState::sampling_rate

Sampling rate of the input/output

float* SpeexPreprocessState::frame

Processing frame (2*ps_size)

float* SpeexPreprocessState::ps

Current power spectrum

float* SpeexPreprocessState::gain2

Adjusted gains

float* SpeexPreprocessState::window

Analysis/Synthesis window

float* SpeexPreprocessState::noise

Noise estimate

float* SpeexPreprocessState::reverb_estimate

Estimate of reverb energy

float* SpeexPreprocessState::old_ps

Power spectrum for last frame

float* SpeexPreprocessState::gain

Ephraim Malah gain

float* SpeexPreprocessState::prior

A-priori SNR

float* SpeexPreprocessState::post

A-posteriori SNR

float* SpeexPreprocessState::S

Smoothed power spectrum

float* SpeexPreprocessState::Smin

See Cohen paper

float* SpeexPreprocessState::Stmp

See Cohen paper

float* SpeexPreprocessState::update_prob

Propability of speech presence for noise update

float* SpeexPreprocessState::zeta

Smoothed a priori SNR

float* SpeexPreprocessState::loudness_weight

Perceptual loudness curve

float* SpeexPreprocessState::inbuf

Input buffer (overlapped analysis)

float* SpeexPreprocessState::outbuf

Output buffer (for overlap and add)

float SpeexPreprocessState::loudness

loudness estimate

float SpeexPreprocessState::loudness2

loudness estimate

int SpeexPreprocessState::nb_adapt

Number of frames used for adaptation so far

int SpeexPreprocessState::nb_loudness_adapt

Number of frames used for loudness adaptation so far

int SpeexPreprocessState::consec_noise

Number of consecutive noise frames

int SpeexPreprocessState::nb_preprocess

Number of frames processed so far

struct drft_lookup* SpeexPreprocessState::fft_lookup

Lookup table for the FFT

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_preprocess.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SpeexSBMode Struct Reference

SpeexSBMode Struct Reference

#include <modes.h>

List of all members.

Public Attributes

const SpeexMode * | nb_mode
int | frameSize
int | subframeSize
int | lpcSize
int | bufSize
spx_word16_t | gamma1
spx_word16_t | gamma2
float | lag_factor
spx_word16_t | lpc_floor
const SpeexSubmode * | submodes [SB_SUBMODES]
int | defaultSubmode
int | low_quality_map [11]
int | quality_map [11]

Detailed Description

Struct defining the encoding/decoding mode for SB-CELP (wideband)

Member Data Documentation

const SpeexMode* SpeexSBMode::nb_mode

Embedded narrowband mode

int SpeexSBMode::frameSize

Size of frames used for encoding

int SpeexSBMode::subframeSize

Size of sub-frames used for encoding

int SpeexSBMode::lpcSize

Order of LPC filter

int SpeexSBMode::bufSize

Signal buffer size in encoder

spx_word16_t SpeexSBMode::gamma1

Perceptual filter parameter #1

spx_word16_t SpeexSBMode::gamma2

Perceptual filter parameter #1

float SpeexSBMode::lag_factor

Lag-windowing parameter

spx_word16_t SpeexSBMode::lpc_floor

Noise floor for LPC analysis

const SpeexSubmode* SpeexSBMode::submodes[SB_SUBMODES]

Sub-mode data for the mode

int SpeexSBMode::defaultSubmode

Default sub-mode to use when encoding

int SpeexSBMode::low_quality_map[11]

Mode corresponding to each quality setting

int SpeexSBMode::quality_map[11]

Mode corresponding to each quality setting

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/modes.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SpeexStereoState Struct Reference

SpeexStereoState Struct Reference

#include <speex_stereo.h>

List of all members.

Public Attributes

float | balance
float | e_ratio
float | smooth_left
float | smooth_right
float | reserved1
float | reserved2

Detailed Description

State used for decoding (intensity) stereo information

Member Data Documentation

float SpeexStereoState::balance

Left/right balance info

float SpeexStereoState::e_ratio

Ratio of energies: E(left+right)/[E(left)+E(right)]

float SpeexStereoState::smooth_left

Smoothed left channel gain

float SpeexStereoState::smooth_right

Smoothed right channel gain

float SpeexStereoState::reserved1

Reserved for future use

float SpeexStereoState::reserved2

Reserved for future use

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_stereo.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SpeexSubmode Struct Reference

SpeexSubmode Struct Reference

#include <modes.h>

List of all members.

Public Attributes

int | lbr_pitch
int | forced_pitch_gain
int | have_subframe_gain
int | double_codebook
lsp_quant_func lsp_quant
lsp_unquant_func lsp_unquant
ltp_quant_func ltp_quant
ltp_unquant_func ltp_unquant
const void * | ltp_params
innovation_quant_func innovation_quant
innovation_unquant_func innovation_unquant
const void * | innovation_params
spx_word16_t | lpc_enh_k1
spx_word16_t | lpc_enh_k2
spx_word16_t | lpc_enh_k3
spx_word16_t | comb_gain
int | bits_per_frame

Detailed Description

Description of a Speex sub-mode (wither narrowband or wideband

Member Data Documentation

int SpeexSubmode::lbr_pitch

Set to -1 for "normal" modes, otherwise encode pitch using a global pitch and allowing a +- lbr_pitch variation (for low not-rates)

int SpeexSubmode::forced_pitch_gain

Use the same (forced) pitch gain for all sub-frames

int SpeexSubmode::have_subframe_gain

Number of bits to use as sub-frame innovation gain

int SpeexSubmode::double_codebook

Apply innovation quantization twice for higher quality (and higher bit-rate)

lsp_quant_func SpeexSubmode::lsp_quant

LSP quantization function

lsp_unquant_func SpeexSubmode::lsp_unquant

LSP unquantization function

ltp_quant_func SpeexSubmode::ltp_quant

Long-term predictor (pitch) quantizer

ltp_unquant_func SpeexSubmode::ltp_unquant

Long-term predictor (pitch) un-quantizer

const void* SpeexSubmode::ltp_params

Pitch parameters (options)

innovation_quant_func SpeexSubmode::innovation_quant

Innovation quantization

innovation_unquant_func SpeexSubmode::innovation_unquant

Innovation un-quantization

const void* SpeexSubmode::innovation_params

Innovation quantization parameters

spx_word16_t SpeexSubmode::lpc_enh_k1

Enhancer constant

spx_word16_t SpeexSubmode::lpc_enh_k2

Enhancer constant

spx_word16_t SpeexSubmode::lpc_enh_k3

Enhancer constant

spx_word16_t SpeexSubmode::comb_gain

Gain of enhancer comb filter

int SpeexSubmode::bits_per_frame

Number of bits per frame after encoding

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/modes.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: split_cb_params Struct Reference

split_cb_params Struct Reference

#include <cb_search.h>

List of all members.

Detailed Description

Split codebook parameters.

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/cb_search.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: StrAndBool Struct Reference

StrAndBool Struct Reference

The string plus a bool telling us if this string was copied or not. More...

#include <StringTable.h>

List of all members.

Detailed Description

The string plus a bool telling us if this string was copied or not.

The documentation for this struct was generated from the following file:
  • C:/RakNet/Source/StringTable.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: StringCompressor Class Reference

StringCompressor Class Reference

Writes and reads strings to and from bitstreams. More...

#include <StringCompressor.h>

List of all members.

Public Member Functions

~StringCompressor ()
Destructor.
void | GenerateTreeFromStrings (unsigned char *input, unsigned inputLength, int languageID)
void | EncodeString (const char *input, int maxCharsToWrite, RakNet::BitStream *output, int languageID=0)
bool | DecodeString (char *output, int maxCharsToWrite, RakNet::BitStream *input, int languageID=0)

Static Public Member Functions

static StringCompressor * | Instance (void)
static void | AddReference (void)
Used so I can allocate and deallocate this singleton at runtime.
static void | RemoveReference (void)
Used so I can allocate and deallocate this singleton at runtime.

Detailed Description

Writes and reads strings to and from bitstreams.

Only works with ASCII strings. The default compression is for English. You can call GenerateTreeFromStrings to compress and decompress other languages efficiently as well.

Member Function Documentation

StringCompressor * StringCompressor::Instance ( void ) [static]

static function because only static functions can access static members The RakPeer constructor adds a reference to this class, so don't call this until an instance of RakPeer exists, or unless you call AddReference yourself.

Returns:
the unique instance of the StringCompressor

void StringCompressor::GenerateTreeFromStrings | ( | unsigned char * | input,
 |  | unsigned | inputLength,
 |  | int | languageID
 | ) |  |

Given an array of strings, such as a chat log, generate the optimal encoding tree for it. This function is optional and if it is not called a default tree will be used instead.

Parameters:
[in] | input | An array of bytes which should point to text.
[in] | inputLength | Length of input
[in] | languageID | An identifier for the language / string table to generate the tree for. English is automatically created with ID 0 in the constructor.

void StringCompressor::EncodeString | ( | const char * | input,
 |  | int | maxCharsToWrite,
 |  | RakNet::BitStream * | output,
 |  | int | languageID = 0
 | ) |  |

Writes input to output, compressed. Takes care of the null terminator for you.

Parameters:
[in] | input | Pointer to an ASCII string
[in] | maxCharsToWrite | The max number of bytes to write of input. Use 0 to mean no limit.
[out] | output | The bitstream to write the compressed string to
[in] | languageID | Which language to use

bool StringCompressor::DecodeString | ( | char * | output,
 |  | int | maxCharsToWrite,
 |  | RakNet::BitStream * | input,
 |  | int | languageID = 0
 | ) |  |

Writes input to output, uncompressed. Takes care of the null terminator for you.

Parameters:
[out] | output | A block of bytes to receive the output
[in] | maxCharsToWrite | Size, in bytes, of output . A NULL terminator will always be appended to the output string. If the maxCharsToWrite is not large enough, the string will be truncated.
[in] | input | The bitstream containing the compressed string
[in] | languageID | Which language to use

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/StringCompressor.h
  • C:/RakNet/Source/StringCompressor.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet::StringTable Class Reference

RakNet::StringTable

RakNet::StringTable Class Reference

Writes a string index, instead of the whole string. More...

#include <StringTable.h>

List of all members.

Public Member Functions

~StringTable ()
Destructor.
void | AddString (const char *str, bool copyString)
void | EncodeString (const char *input, int maxCharsToWrite, RakNet::BitStream *output)
bool | DecodeString (char *output, int maxCharsToWrite, RakNet::BitStream *input)

Static Public Member Functions

static StringTable * | Instance (void)
static void | AddReference (void)
Used so I can allocate and deallocate this singleton at runtime.
static void | RemoveReference (void)
Used so I can allocate and deallocate this singleton at runtime.

Protected Member Functions

void | LogStringNotFound (const char *strName)
StringTable ()
Private Constructor.

Static Protected Attributes

static StringTable * | instance
Singleton instance.

Detailed Description

Writes a string index, instead of the whole string.

This is an even more efficient alternative to StringCompressor in that it writes a single byte from a lookup table and only does compression if the string does not already exist in the table. All string tables must match on all systems - hence you must add all the strings in the same order on all systems. Furthermore, this must be done before sending packets that use this class, since the strings are ordered for fast lookup. Adding after that time would mess up all the indices so don't do it. Don't use this class to write strings which were not previously registered with AddString, since you just waste bandwidth then. Use StringCompressor instead.

Member Function Documentation

StringTable * StringTable::Instance ( void ) [static]

static function because only static functions can access static members The RakPeer constructor adds a reference to this class, so don't call this until an instance of RakPeer exists, or unless you call AddReference yourself.

Returns:
the unique instance of the StringTable

void StringTable::AddString | ( | const char * | str,
 |  | bool | copyString
 | ) |  |

Add a string to the string table.

Parameters:
[in] | str | The string to add to the string table
[in] | copyString | true to make a copy of the passed string (takes more memory), false to not do so (if your string is in static memory).

void StringTable::EncodeString | ( | const char * | input,
 |  | int | maxCharsToWrite,
 |  | RakNet::BitStream * | output
 | ) |  |

Writes input to output, compressed. Takes care of the null terminator for you. Relies on the StringCompressor class, which is automatically reference counted in the constructor and destructor in RakPeer. You can call the reference counting functions yourself if you wish too.

Parameters:
[in] | input | Pointer to an ASCII string
[in] | maxCharsToWrite | The size of input
[out] | output | The bitstream to write the compressed string to

bool StringTable::DecodeString | ( | char * | output,
 |  | int | maxCharsToWrite,
 |  | RakNet::BitStream * | input
 | ) |  |

Writes input to output, uncompressed. Takes care of the null terminator for you. Relies on the StringCompressor class, which is automatically reference counted in the constructor and destructor in RakPeer. You can call the reference counting functions yourself if you wish too.

Parameters:
[out] | output | A block of bytes to receive the output
[in] | maxCharsToWrite | Size, in bytes, of output . A NULL terminator will always be appended to the output string. If the maxCharsToWrite is not large enough, the string will be truncated.
[in] | input | The bitstream containing the compressed string

void StringTable::LogStringNotFound ( const char * strName ) [protected]

Called when you mess up and send a string using this class that was not registered with AddString

Parameters:
[in] maxCharsToWrite Size, in bytes, of output . A NULL terminator will always be appended to the output string. If the maxCharsToWrite is not large enough, the string will be truncated.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/StringTable.h
  • C:/RakNet/Source/StringTable.cpp
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RankingServerDBSpec::SubmitMatch_Data Class Reference

RankingServerDBSpec::SubmitMatch_Data

RankingServerDBSpec::SubmitMatch_Data Class Reference

#include <RankingServerDBSpec.h>

Inheritance diagram for RankingServerDBSpec::SubmitMatch_Data:

RefCountedObj SubmitMatch_PostgreSQLImpl List of all members.

Public Attributes

PairedKeyDbId participantADbId
[in] For playerId, an integer ID used as the primary key for the first player in the database. Pick whatever unique number you want. If this ID does not currently exist in the database it will be added. For rating, the new rating that the first player should get, based on the results of this match. Use CalculateNewEloRating with the score, the old ratings, and your kFactor to determine this
PairedKeyDbId participantBDbId
[in] For playerId, an integer ID used as the primary key for the second player in the database. Pick whatever unique number you want. If this ID does not currently exist in the database it will be added. For rating, the new rating that the second player should get, based on the results of this match. Use CalculateNewEloRating with the score, the old ratings, and your kFactor to determine this
float | participantAScore
[in] Whatever score the first player got. This is not used, but is written to the database for your own record keeping.
float | participantBScore
[in] Whatever score the second player got. This is not used, but is written to the database for your own record keeping.
float | participantAOldRating
[in] Old rating for participant A. Not used, but good for record keeping.
float | participantANewRating
[in] New rating for participant A.
float | participantBOldRating
[in] Old rating for participant B. Not used, but good for record keeping.
float | participantBNewRating
[in] New rating for participant B.
PairedKeyDbId gameDbId
[in] Identifies in the game in the database with a primary and secondary integer key. User defined.
RakNet::RakString matchNotes
[in] Any notes for this match (optional)
char * | matchBinaryData
[in] Binary data, if you want to upload it (optional, set to 0 to not use)
unsigned int | matchBinaryDataLength
[in] Length of the binary data to upload (optional, set to 0 to not use)
long long | matchTime
[out] Used by GetHistoryForParticipant_Data::matchHistoryList. Parse with _localtime64()

Detailed Description

Submit ratings, scores, for a particular game for two players Use CalculateNewEloRating in Elo.h to determine new ratings for the two players involved in the match. If you don't know the ratings for the two players involved beforehand to pass to CalculateNewEloRating, call GetRatingForParticipant() to look it up. No data is returned, but the callback is called so you know it completed

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SubmitMatch_PostgreSQLImpl Class Reference

SubmitMatch_PostgreSQLImpl Class Reference

#include <RankingServer_PostgreSQL.h>

Inheritance diagram for SubmitMatch_PostgreSQLImpl:

RankingServerDBSpec::SubmitMatch_Data RefCountedObj List of all members.

Public Member Functions

virtual void | Process (void *context)
Does SQL Processing.
virtual void | HandleResult (bool wasCancelled, void *context)

Static Public Member Functions

static SubmitMatch_PostgreSQLImpl * | Alloc (void)
Use these for allocation/deallocation if building to a DLL, so allocation and deallocation happen in the same DLL.

Detailed Description

Submit ratings, scores, for a particular game for two players Use CalculateNewEloRating in Elo.h to determine new ratings for the two players involved in the match. If you don't know the ratings for the two players involved beforehand to pass to CalculateNewEloRating, call GetRatingForParticipant() to look it up.

Member Function Documentation

void SubmitMatch_PostgreSQLImpl::HandleResult | ( | bool | wasCancelled,
 |  | void * | context |
 | ) |  |  | [virtual]

Calls the callback specified by RankingServerFunctor::callback (which you set) or RankingServer_PostgreSQL::AssignCallback() (which sets it for you) Default implementation also deallocates the structure.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.h
  • C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: SystemAddress Struct Reference

SystemAddress Struct Reference

Unique identifier for a system. Corresponds to a network address. More...

#include <RakNetTypes.h>

List of all members.

Public Attributes

unsigned int | binaryAddress
The peer address from inet_addr.
unsigned short | port
The port number.

Detailed Description

Unique identifier for a system. Corresponds to a network address.

The documentation for this struct was generated from the following files:
  • C:/RakNet/Source/RakNetTypes.h
  • C:/RakNet/Source/RakNetTypes.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::Table Class Reference

DataStructures::Table

DataStructures::Table Class Reference

Holds a set of columns, a set of rows, and rows times columns cells. The table data structure is useful if you want to store a set of structures and perform queries on those structures This is a relatively simple and fast implementation of the types of tables commonly used in databases See TableSerializer to serialize data members of the table See LightweightDatabaseClient and LightweightDatabaseServer to transmit the table over the network. More...

#include <DS_Table.h>

List of all members.

Public Types

enum | SortQueryType
Increasing or decreasing sort order.

Public Member Functions

Table ()
Constructor.
~Table ()
Destructor.
unsigned | AddColumn (const char columnName[_TABLE_MAX_COLUMN_NAME_LENGTH], ColumnType columnType)
Adds a column to the table.
void | RemoveColumn (unsigned columnIndex)
Removes a column by index.
unsigned | ColumnIndex (char columnName[_TABLE_MAX_COLUMN_NAME_LENGTH])
Gets the index of a column by name Column indices are stored in the order they are added.
char * | ColumnName (unsigned index)
Gives the string name of the column at a certain index.
ColumnType | GetColumnType (unsigned index)
Returns the type of a column, referenced by index.
unsigned | GetColumnCount (void) const
unsigned | GetRowCount (void) const
Table::Row * | AddRow (unsigned rowId)
Adds a row to the table New rows are added with empty values for all cells. However, if you specify initialCelLValues you can specify initial values It's up to you to ensure that the values in the specific cells match the type of data used by that row rowId can be considered the primary key for the row. It is much faster to lookup a row by its rowId than by searching keys. rowId must be unique Rows are stored in sorted order in the table, using rowId as the sort key.
void | RemoveRow (unsigned rowId)
void | RemoveRows (Table *tableContainingRowIDs)
bool | UpdateCell (unsigned rowId, unsigned columnIndex, int value)
void | GetCellValueByIndex (unsigned rowIndex, unsigned columnIndex, int *output)
Row * | GetRowByID (unsigned rowId) const
Row * | GetRowByIndex (unsigned rowIndex, unsigned *key) const
void | QueryTable (unsigned *columnIndicesSubset, unsigned numColumnSubset, FilterQuery *inclusionFilters, unsigned numInclusionFilters, unsigned *rowIds, unsigned numRowIDs, Table *result)
Queries the table, optionally returning only a subset of columns and rows.
void | SortTable (Table::SortQuery *sortQueries, unsigned numSortQueries, Table::Row **out)
Sorts the table by rows You can sort the table in ascending or descending order on one or more columns Columns have precedence in the order they appear in the sortQueries array If a row cell on column n has the same value as a a different row on column n, then the row will be compared on column n+1.
void | Clear (void)
Frees all memory in the table.
void | PrintColumnHeaders (char *out, int outLength, char columnDelineator) const
void | PrintRow (char *out, int outLength, char columnDelineator, bool printDelineatorForBinary, Table::Row *inputRow) const
DataStructures::List< ColumnDescriptor > & | GetColumns (void)
Direct access to make things easier.
DataStructures::BPlusTree<
unsigned, Row *, _TABLE_BPLUS_TREE_ORDER > & 		GetRows (void)
Direct access to make things easier.
DataStructures::Page< unsigned,
DataStructures::Table::Row *,
_TABLE_BPLUS_TREE_ORDER > * 		GetListHead (void)
Get the head of a linked list containing all the row data.
unsigned | GetAvailableRowId (void) const

Classes

struct | Cell
Holds the actual data in the table. More...
struct | ColumnDescriptor
struct | Row
Stores the list of cells for this row, and a special flag used for internal sorting. More...

Detailed Description

Holds a set of columns, a set of rows, and rows times columns cells. The table data structure is useful if you want to store a set of structures and perform queries on those structures This is a relatively simple and fast implementation of the types of tables commonly used in databases See TableSerializer to serialize data members of the table See LightweightDatabaseClient and LightweightDatabaseServer to transmit the table over the network.

Member Function Documentation

unsigned Table::AddColumn | ( | const char | columnName[_TABLE_MAX_COLUMN_NAME_LENGTH],
 |  | ColumnType | columnType
 | ) |  |

Adds a column to the table.

Parameters:
[in] | columnName | The name of the column
[in] | columnType | What type of data this column will hold
Returns:
The index of the new column

void Table::RemoveColumn ( unsigned columnIndex )

Removes a column by index.

Parameters:
[in] columnIndex The index of the column to remove

unsigned Table::ColumnIndex ( char columnName[_TABLE_MAX_COLUMN_NAME_LENGTH] )

Gets the index of a column by name Column indices are stored in the order they are added.

Parameters:
[in] columnName The name of the column
Returns:
The index of the column, or (unsigned)-1 if no such column

char * Table::ColumnName ( unsigned index )

Gives the string name of the column at a certain index.

Parameters:
[in] index The index of the column
Returns:
The name of the column, or 0 if an invalid index

Table::ColumnType Table::GetColumnType ( unsigned index )

Returns the type of a column, referenced by index.

Parameters:
[in] index The index of the column
Returns:
The type of the column

unsigned Table::GetColumnCount ( void ) const

Returns the number of columns

Returns:
The number of columns in the table

unsigned Table::GetRowCount ( void ) const

Returns the number of rows

Returns:
The number of rows in the table

Table::Row * Table::AddRow ( unsigned rowId )

Adds a row to the table New rows are added with empty values for all cells. However, if you specify initialCelLValues you can specify initial values It's up to you to ensure that the values in the specific cells match the type of data used by that row rowId can be considered the primary key for the row. It is much faster to lookup a row by its rowId than by searching keys. rowId must be unique Rows are stored in sorted order in the table, using rowId as the sort key.

Parameters:
[in] | rowId | The UNIQUE primary key for the row. This can never be changed.
[in] | initialCellValues | Initial values to give the row (optional)
Returns:
The newly added row

void Table::RemoveRow ( unsigned rowId )

Removes a row specified by rowId

Parameters:
[in] rowId The ID of the row

void Table::RemoveRows ( Table * tableContainingRowIDs )

Removes all the rows with IDs that the specified table also has

Parameters:
[in] tableContainingRowIDs The IDs of the rows

bool Table::UpdateCell | ( | unsigned | rowId,
 |  | unsigned | columnIndex,
 |  | int | value
 | ) |  |

Parameters:
[in] | columnIndex | The column of the cell
[in] | value | The data to set

void Table::GetCellValueByIndex | ( | unsigned | rowIndex,
 |  | unsigned | columnIndex,
 |  | int * | output
 | ) |  |

Note this is much less efficient to call than GetRow, then working with the cells directly Numeric, string, binary

Table::Row * Table::GetRowByID ( unsigned rowId ) const

Gets a row. More efficient to do this and access Row::cells than to repeatedly call GetCell. You can also update cells in rows from this function.

Parameters:
[in] rowId The ID of the row
Returns:
The desired row, or 0 if no such row.

Table::Row * Table::GetRowByIndex | ( | unsigned | rowIndex,
 |  | unsigned * | key |
 | ) |  |  | const

Gets a row at a specific index rowIndex should be less than GetRowCount()

Parameters:
[in] | rowIndex | The index of the row
[out] | key | The ID of the row returned
Returns:
The desired row, or 0 if no such row.

void Table::QueryTable | ( | unsigned * | columnIndicesSubset,
 |  | unsigned | numColumnSubset,
 |  | FilterQuery * | inclusionFilters,
 |  | unsigned | numInclusionFilters,
 |  | unsigned * | rowIds,
 |  | unsigned | numRowIDs,
 |  | Table * | result
 | ) |  |

Queries the table, optionally returning only a subset of columns and rows.

Parameters:
[in] | columnSubset | An array of column indices. Only columns in this array are returned. Pass 0 for all columns
[in] | numColumnSubset | The number of elements in columnSubset
[in] | inclusionFilters | An array of FilterQuery. All filters must pass for the row to be returned.
[in] | numInclusionFilters | The number of elements in inclusionFilters
[in] | rowIds | An arrow of row IDs. Only these rows with these IDs are returned. Pass 0 for all rows.
[in] | numRowIDs | The number of elements in rowIds
[out] | result | The result of the query. If no rows are returned, the table will only have columns.

void Table::SortTable | ( | Table::SortQuery * | sortQueries,
 |  | unsigned | numSortQueries,
 |  | Table::Row ** | out
 | ) |  |

Sorts the table by rows You can sort the table in ascending or descending order on one or more columns Columns have precedence in the order they appear in the sortQueries array If a row cell on column n has the same value as a a different row on column n, then the row will be compared on column n+1.

Parameters:
[in] | sortQueries | A list of SortQuery structures, defining the sorts to perform on the table
[in] | numColumnSubset | The number of elements in numSortQueries
[out] | out | The address of an array of Rows, which will receive the sorted output. The array must be long enough to contain all returned rows, up to GetRowCount()

void Table::PrintColumnHeaders | ( | char * | out,
 |  | int | outLength,
 |  | char | columnDelineator |
 | ) |  |  | const

Prints out the names of all the columns

Parameters:
[out] | out | A pointer to an array of bytes which will hold the output.
[in] | outLength | The size of the out array
[in] | columnDelineator | What character to print to delineate columns

void Table::PrintRow | ( | char * | out,
 |  | int | outLength,
 |  | char | columnDelineator,
 |  | bool | printDelineatorForBinary,
 |  | Table::Row * | inputRow |
 | ) |  |  | const

Writes a text representation of the row to out

Parameters:
[out] | out | A pointer to an array of bytes which will hold the output.
[in] | outLength | The size of the out array
[in] | columnDelineator | What character to print to delineate columns
[in] | printDelineatorForBinary | Binary output is not printed. True to still print the delineator.
[in] | inputRow | The row to print

unsigned Table::GetAvailableRowId ( void ) const

Get the first free row id. This could be made more efficient.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/DS_Table.h
  • C:/RakNet/Source/DS_Table.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::Table::Cell Struct Reference

DataStructures::Table::Cell

DataStructures::Table::Cell Struct Reference

Holds the actual data in the table. More...

#include <DS_Table.h>

List of all members.

Public Member Functions

void | Set (int input)
Numeric.
void | Set (const char *input)
String.
void | Set (const char *input, int inputLength)
Binary.
void | SetPtr (void *p)
Pointer.
void | Get (int *output)
Numeric.
void | Get (char *output)
String.
void | Get (char *output, int *outputLength)
Binary.

Detailed Description

Holds the actual data in the table.

The documentation for this struct was generated from the following files:
  • C:/RakNet/Source/DS_Table.h
  • C:/RakNet/Source/DS_Table.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::Table::ColumnDescriptor Struct Reference

DataStructures::Table::ColumnDescriptor

DataStructures::Table::ColumnDescriptor Struct Reference

#include <DS_Table.h>

List of all members.

Detailed Description

Stores the name and type of the column

The documentation for this struct was generated from the following files:
  • C:/RakNet/Source/DS_Table.h
  • C:/RakNet/Source/DS_Table.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures::Table::Row Struct Reference

DataStructures::Table::Row

DataStructures::Table::Row Struct Reference

Stores the list of cells for this row, and a special flag used for internal sorting. More...

#include <DS_Table.h>

List of all members.

Public Member Functions

void | UpdateCell (unsigned columnIndex, int value)
Numeric.
void | UpdateCell (unsigned columnIndex, const char *str)
String.
void | UpdateCell (unsigned columnIndex, int byteLength, const char *data)
Binary.

Detailed Description

Stores the list of cells for this row, and a special flag used for internal sorting.

The documentation for this struct was generated from the following files:
  • C:/RakNet/Source/DS_Table.h
  • C:/RakNet/Source/DS_Table.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: TelnetTransport Class Reference

TelnetTransport Class Reference

Use TelnetTransport to easily allow windows telnet to connect to your ConsoleServer To run Windows telnet, go to your start menu, click run, and in the edit box type "telnet <IP>" where <IP> is the ip address of your ConsoleServer (most likely the same IP as your game). This implementation always echos commands. More...

#include <TelnetTransport.h>

Inheritance diagram for TelnetTransport:

TransportInterface List of all members.

Public Member Functions

bool | Start (unsigned short port, bool serverMode)
void | Stop (void)
Stop the transport provider. You can clear memory and shutdown threads here.
void | Send (SystemAddress systemAddress, const char *data,...)
void | CloseConnection (SystemAddress systemAddress)
Packet * | Receive (void)
void | DeallocatePacket (Packet *packet)
SystemAddress | HasNewConnection (void)
SystemAddress | HasLostConnection (void)
CommandParserInterface * | GetCommandParser (void)

Detailed Description

Use TelnetTransport to easily allow windows telnet to connect to your ConsoleServer To run Windows telnet, go to your start menu, click run, and in the edit box type "telnet <IP>" where <IP> is the ip address of your ConsoleServer (most likely the same IP as your game). This implementation always echos commands.

Member Function Documentation

bool TelnetTransport::Start | ( | unsigned short | port,
 |  | bool | serverMode |
 | ) |  |  | [virtual]

Start the transport provider on the indicated port.

Parameters:
[in] | port | The port to start the transport provider on
[in] | serverMode | If true, you should allow incoming connections (I don't actually use this anywhere)
Returns:
Return true on success, false on failure.

Implements TransportInterface.

void TelnetTransport::Send | ( | SystemAddress | systemAddress,
 |  | const char * | data,
 |  |  | ... |
 | ) |  |  | [virtual]

Send a null-terminated string to systemAddress If your transport method requires particular formatting of the outgoing data (e.g. you don't just send strings) you can do it here and parse it out in Receive().

Parameters:
[in] | systemAddress | The player to send the string to
[in] | data | format specifier - same as printf
[in] ... format specification arguments - same as printf

Implements TransportInterface.

void TelnetTransport::CloseConnection ( SystemAddress systemAddress ) [virtual]

Disconnect systemAddress . The binary address and port defines the SystemAddress structure.

Parameters:
[in] systemAddress The player/address to disconnect

Implements TransportInterface.

Packet * TelnetTransport::Receive ( void ) [virtual]

Return a string. The string should be allocated and written to Packet::data . The byte length should be written to Packet::length . The player/address should be written to Packet::systemAddress If your transport protocol adds special formatting to the data stream you should parse it out before returning it in the packet and thus only return a string in Packet::data

Returns:
The packet structure containing the result of Receive, or 0 if no data is available

Implements TransportInterface.

void TelnetTransport::DeallocatePacket ( Packet * packet ) [virtual]

Deallocate the Packet structure returned by Receive

Parameters:
[in] The packet to deallocate

Implements TransportInterface.

SystemAddress TelnetTransport::HasNewConnection ( void ) [virtual]

If a new system connects to you, you should queue that event and return the systemAddress/address of that player in this function.

Returns:
The SystemAddress/address of the system

Implements TransportInterface.

SystemAddress TelnetTransport::HasLostConnection ( void ) [virtual]

If a system loses the connection, you should queue that event and return the systemAddress/address of that player in this function.

Returns:
The SystemAddress/address of the system

Implements TransportInterface.

CommandParserInterface * TelnetTransport::GetCommandParser ( void ) [virtual]

Your transport provider can itself have command parsers if the transport layer has user-modifiable features For example, your transport layer may have a password which you want remote users to be able to set or you may want to allow remote users to turn on or off command echo

Returns:
0 if you do not need a command parser - otherwise the desired derivation of CommandParserInterface

Implements TransportInterface.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/TelnetTransport.h
  • C:/RakNet/Source/TelnetTransport.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ThreadPool< InputType, OutputType > Struct Template Reference

ThreadPool< InputType, OutputType > Struct Template Reference

#include <ThreadPool.h>

List of all members.

Public Member Functions

bool | StartThreads (int numThreads, int stackSize, void *(*_perThreadDataFactory)()=0, void(*_perThreadDataDestructor)(void *)=0)
void | StopThreads (void)
Stops all threads.
void | AddInput (OutputType(*workerThreadCallback)(InputType, bool *returnOutput, void *perThreadData), InputType inputData)
bool | HasOutput (void)
bool | HasOutputFast (void)
bool | HasInput (void)
bool | HasInputFast (void)
OutputType | GetOutput (void)
void | Clear (void)
Clears internal buffers.
void | LockInput (void)
void | UnlockInput (void)
Unlock the input buffer after you are done with the functions InputSize, GetInputAtIndex, and RemoveInputAtIndex.
unsigned | InputSize (void)
Length of the input queue.
InputType | GetInputAtIndex (unsigned index)
Get the input at a specified index.
void | RemoveInputAtIndex (unsigned index)
Remove input from a specific index. This does NOT do memory deallocation - it only removes the item from the queue.
void | LockOutput (void)
void | UnlockOutput (void)
Unlock the output buffer after you are done with the functions OutputSize, GetOutputAtIndex, and RemoveOutputAtIndex.
unsigned | OutputSize (void)
Length of the output queue.
OutputType | GetOutputAtIndex (unsigned index)
Get the output at a specified index.
void | RemoveOutputAtIndex (unsigned index)
Remove output from a specific index. This does NOT do memory deallocation - it only removes the item from the queue.
void | ClearInput (void)
Removes all items from the input queue.
void | ClearOutput (void)
Removes all items from the output queue.
bool | IsWorking (void)
Are any of the threads working, or is input or output available?
int | NumThreadsWorking (void)
The number of currently active threads.
bool | WasStopped (void) const
Have the threads been signaled to be stopped?

Detailed Description

template<class InputType, class OutputType>
struct ThreadPool< InputType, OutputType >

A simple class to create worker threads that processes a queue of functions with data. This class does not allocate or deallocate memory. It is up to the user to handle memory management. InputType and OutputType are stored directly in a queue. For large structures, if you plan to delete from the middle of the queue, you might wish to store pointers rather than the structures themselves so the array can shift efficiently.

Member Function Documentation

template<class InputType, class OutputType>
bool ThreadPool< InputType, OutputType >::StartThreads | ( | int | numThreads,
 |  | int | stackSize,
 |  | void *(*)() | _perThreadDataFactory = 0,
 |  | void(*)(void *) | _perThreadDataDestructor = 0
 | ) |  |

Start the specified number of threads.

Parameters:
[in] | numThreads | The number of threads to start
[in] | stackSize | 0 for default (except on consoles).
[in] | _perThreadDataFactory | User callback to return data stored per thread. Pass 0 if not needed.
[in] | _perThreadDataDestructor | User callback to destroy data stored per thread, created by _perThreadDataFactory. Pass 0 if not needed.
Returns:
True on success, false on failure.

template<class InputType, class OutputType>
void ThreadPool< InputType, OutputType >::AddInput | ( | OutputType(*)(InputType, bool *returnOutput, void *perThreadData) | workerThreadCallback,
 |  | InputType | inputData
 | ) |  |

Adds a function to a queue with data to pass to that function. This function will be called from the thread Memory management is your responsibility! This class does not allocate or deallocate memory. The best way to deallocate inputData is in userCallback. If you call EndThreads such that callbacks were not called, you can iterate through the inputQueue and deallocate all pending input data there The best way to deallocate output is as it is returned to you from GetOutput. Similarly, if you end the threads such that not all output was returned, you can iterate through outputQueue and deallocate it there.

Parameters:
[in] | workerThreadCallback | The function to call from the thread
[in] | inputData | The parameter to pass to userCallback

template<class InputType, class OutputType>
bool ThreadPool< InputType, OutputType >::HasOutput ( void )

Returns true if output from GetOutput is waiting.

Returns:
true if output is waiting, false otherwise

template<class InputType, class OutputType>
bool ThreadPool< InputType, OutputType >::HasOutputFast ( void )

Inaccurate but fast version of HasOutput. If this returns true, you should still check HasOutput for the real value.

Returns:
true if output is probably waiting, false otherwise

template<class InputType, class OutputType>
bool ThreadPool< InputType, OutputType >::HasInput ( void )

Returns true if input from GetInput is waiting.

Returns:
true if input is waiting, false otherwise

template<class InputType, class OutputType>
bool ThreadPool< InputType, OutputType >::HasInputFast ( void )

Inaccurate but fast version of HasInput. If this returns true, you should still check HasInput for the real value.

Returns:
true if input is probably waiting, false otherwise

template<class InputType, class OutputType>
OutputType ThreadPool< InputType, OutputType >::GetOutput ( void )

Gets the output of a call to userCallback HasOutput must return true before you call this function. Otherwise it will assert.

Returns:
The output of userCallback. If you have different output signatures, it is up to you to encode the data to indicate this

template<class InputType, class OutputType>
void ThreadPool< InputType, OutputType >::LockInput ( void )

Lock the input buffer before calling the functions InputSize, InputAtIndex, and RemoveInputAtIndex It is only necessary to lock the input or output while the threads are running

template<class InputType, class OutputType>
void ThreadPool< InputType, OutputType >::LockOutput ( void )

Lock the output buffer before calling the functions OutputSize, OutputAtIndex, and RemoveOutputAtIndex It is only necessary to lock the input or output while the threads are running

The documentation for this struct was generated from the following file:
  • C:/RakNet/Source/ThreadPool.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: ThreadsafePacketLogger Class Reference

ThreadsafePacketLogger Class Reference
[PacketLogger]

Same as PacketLogger, but writes output in the user thread. More...

#include <ThreadsafePacketLogger.h>

Inheritance diagram for ThreadsafePacketLogger:

PacketLogger PluginInterface List of all members.

Public Member Functions

virtual void Update (RakPeerInterface *peer)

Detailed Description

Same as PacketLogger, but writes output in the user thread.

Member Function Documentation

void ThreadsafePacketLogger::Update ( RakPeerInterface * peer ) [virtual]

Update is called every time a packet is checked for .

Parameters:
[in] peer - the instance of RakPeer that is calling Receive

Reimplemented from PacketLogger.

The documentation for this class was generated from the following files:
  • C:/RakNet/Source/ThreadsafePacketLogger.h
  • C:/RakNet/Source/ThreadsafePacketLogger.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: TitleValidation_PostgreSQL Class Reference

TitleValidation_PostgreSQL Class Reference

#include <TitleValidationDB_PostgreSQL.h>

List of all members.

Public Member Functions

bool | CreateTitleValidationTables (void)
bool | DestroyTitleValidationTables (void)
virtual void | PushFunctor (TitleValidationFunctor *functor, void *context=0)
void | AssignCallback (TitleValidationDBCBInterface *cb)

Detailed Description

Provides a central class for all TitleValidation functionality using the PostgreSQL interface If you are using more than one class that uses functionThreads, you should maintain this separately and call AssignFunctionThread() to avoid unnecessary threads.

Member Function Documentation

bool TitleValidation_PostgreSQL::CreateTitleValidationTables ( void )

Create the tables used by the ranking server, for all applications. Call this first. I recommend using UTF8 for the database encoding within PostgreSQL if you are going to store binary data

Returns:
True on success, false on failure.

bool TitleValidation_PostgreSQL::DestroyTitleValidationTables ( void )

Destroy the tables used by the ranking server. Don't call this unless you don't want to use the ranking server anymore, or are testing.

Returns:
True on success, false on failure.

void TitleValidation_PostgreSQL::PushFunctor | ( | TitleValidationFunctor * | functor,
 |  | void * | context = 0 |
 | ) |  |  | [virtual]

Push one of the above *_PostgreSQLImpl functors to run.

Parameters:
functor A structure allocated on the HEAP (using new) with the input parameters filled in.

void TitleValidation_PostgreSQL::AssignCallback ( TitleValidationDBCBInterface * cb )

Assigns a callback to get the results of processing.

Parameters:
[in] A structure allocated on the HEAP (using new) with the input parameters filled in.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/TitleValidationDB_PostgreRepository/TitleValidationDB_PostgreSQL.h
  • C:/RakNet/DependentExtensions/Lobby/TitleValidationDB_PostgreRepository/TitleValidationDB_PostgreSQL.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: TitleValidationDBCBInterface Class Reference

TitleValidationDBCBInterface Class Reference

If you want to forward Functor::HandleResult() the output to a callback (which is what it does by default), you can use this. More...

#include <TitleValidationDB_PostgreSQL.h>

Inheritance diagram for TitleValidationDBCBInterface:

RakNet::LobbyServerPostgreSQL List of all members.

Detailed Description

If you want to forward Functor::HandleResult() the output to a callback (which is what it does by default), you can use this.

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/TitleValidationDB_PostgreRepository/TitleValidationDB_PostgreSQL.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: TransportInterface Class Reference

TransportInterface Class Reference

Defines an interface that is used to send and receive null-terminated strings. In practice this is only used by the CommandParser system for for servers. More...

#include <TransportInterface.h>

Inheritance diagram for TransportInterface:

RakNetTransport TelnetTransport List of all members.

Public Member Functions

virtual bool | Start (unsigned short port, bool serverMode)=0
virtual void | Stop (void)=0
Stop the transport provider. You can clear memory and shutdown threads here.
virtual void | Send (SystemAddress systemAddress, const char *data,...)=0
virtual void | CloseConnection (SystemAddress systemAddress)=0
virtual Packet * | Receive (void)=0
virtual void | DeallocatePacket (Packet *packet)=0
virtual SystemAddress | HasNewConnection (void)=0
virtual SystemAddress | HasLostConnection (void)=0
virtual CommandParserInterface * | GetCommandParser (void)=0

Detailed Description

Defines an interface that is used to send and receive null-terminated strings. In practice this is only used by the CommandParser system for for servers.

Member Function Documentation

virtual bool TransportInterface::Start | ( | unsigned short | port,
 |  | bool | serverMode |
 | ) |  |  | [pure virtual]

Start the transport provider on the indicated port.

Parameters:
[in] | port | The port to start the transport provider on
[in] | serverMode | If true, you should allow incoming connections (I don't actually use this anywhere)
Returns:
Return true on success, false on failure.

Implemented in RakNetTransport, and TelnetTransport.

virtual void TransportInterface::Send | ( | SystemAddress | systemAddress,
 |  | const char * | data,
 |  |  | ... |
 | ) |  |  | [pure virtual]

Send a null-terminated string to systemAddress If your transport method requires particular formatting of the outgoing data (e.g. you don't just send strings) you can do it here and parse it out in Receive().

Parameters:
[in] | systemAddress | The player to send the string to
[in] | data | format specifier - same as printf
[in] ... format specification arguments - same as printf

Implemented in RakNetTransport, and TelnetTransport.

virtual void TransportInterface::CloseConnection ( SystemAddress systemAddress ) [pure virtual]

Disconnect systemAddress . The binary address and port defines the SystemAddress structure.

Parameters:
[in] systemAddress The player/address to disconnect

Implemented in RakNetTransport, and TelnetTransport.

virtual Packet* TransportInterface::Receive ( void ) [pure virtual]

Return a string. The string should be allocated and written to Packet::data . The byte length should be written to Packet::length . The player/address should be written to Packet::systemAddress If your transport protocol adds special formatting to the data stream you should parse it out before returning it in the packet and thus only return a string in Packet::data

Returns:
The packet structure containing the result of Receive, or 0 if no data is available

Implemented in RakNetTransport, and TelnetTransport.

virtual void TransportInterface::DeallocatePacket ( Packet * packet ) [pure virtual]

Deallocate the Packet structure returned by Receive

Parameters:
[in] The packet to deallocate

Implemented in RakNetTransport, and TelnetTransport.

virtual SystemAddress TransportInterface::HasNewConnection ( void ) [pure virtual]

If a new system connects to you, you should queue that event and return the systemAddress/address of that player in this function.

Returns:
The SystemAddress/address of the system

Implemented in RakNetTransport, and TelnetTransport.

virtual SystemAddress TransportInterface::HasLostConnection ( void ) [pure virtual]

If a system loses the connection, you should queue that event and return the systemAddress/address of that player in this function.

Returns:
The SystemAddress/address of the system

Implemented in RakNetTransport, and TelnetTransport.

virtual CommandParserInterface* TransportInterface::GetCommandParser ( void ) [pure virtual]

Your transport provider can itself have command parsers if the transport layer has user-modifiable features For example, your transport layer may have a password which you want remote users to be able to set or you may want to allow remote users to turn on or off command echo

Returns:
0 if you do not need a command parser - otherwise the desired derivation of CommandParserInterface

Implemented in RakNetTransport, and TelnetTransport.

The documentation for this class was generated from the following file:
  • C:/RakNet/Source/TransportInterface.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::UpdateEmailStatus_Data Class Reference

LobbyDBSpec::UpdateEmailStatus_Data

LobbyDBSpec::UpdateEmailStatus_Data Class Reference

Updates the mark flags on an email. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::UpdateEmailStatus_Data:

RefCountedObj List of all members.

Public Attributes

int | status
[in] Status flags, define as you wish
bool | wasOpened
[in] Update the opened status flag on the email
DatabaseKey | emailMessageID
[in] Refers to what email to mark as read.

Detailed Description

Updates the mark flags on an email.

The documentation for this class was generated from the following file:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: LobbyDBSpec::UpdateUser_Data Class Reference

LobbyDBSpec::UpdateUser_Data

LobbyDBSpec::UpdateUser_Data Class Reference

Overwrites an existing user in the users table. More...

#include <LobbyDBSpec.h>

Inheritance diagram for LobbyDBSpec::UpdateUser_Data:

RefCountedObj List of all members.

Public Attributes

bool | updateCCInfo
[in] Get credit card info?
bool | updateBinaryData
[in] Get binary data?
bool | updatePersonalInfo
[in] Get personal information (Name, address)
bool | updateEmailAddr
[in] Get email address?
bool | updatePassword
[in] Get password, recovery question, and recovery answer?
RowIdOrHandle | id
[in] Which user
CreateUser_Data input

Detailed Description

Overwrites an existing user in the users table.

Member Data Documentation

CreateUser_Data LobbyDBSpec::UpdateUser_Data::input

[in] Will overwrite what is there already, based on the update booleans in this structure. Will fail if the new handle is different and already in use.

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.cpp
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: TitleValidationDBSpec::UpdateUserKey_Data Class Reference

TitleValidationDBSpec::UpdateUserKey_Data

TitleValidationDBSpec::UpdateUserKey_Data Class Reference

#include <TitleValidationDBSpec.h>

Inheritance diagram for TitleValidationDBSpec::UpdateUserKey_Data:

RefCountedObj List of all members.

Public Attributes

DatabaseKey | userKeyId
[in/out] integer identifier of this key. If this is a new key and you do not yet have a userKeyId, set userKeyIsSet to false. Otherwise, this will overwrite the existing key.
bool | userKeyIsSet
[in] True to overwrite an existing row specified by userKeyId. False to add a new row, and fill out userKeyId
DatabaseKey | titleId
[in] Which title this key should be associated with
char * | keyPassword
[in] Password to the key. Binary data.
int | keyPasswordLength
[in] length of keyPassword
DatabaseKey | userId
[in] Which user this key has been assigned to. You do not necessarily have to use this if your keys are not assigned to users.
RakNet::RakString userIP
[ip] IP address of the system this key was assigned to. (Optional)
int | numRegistrations
[in] If you want to track the number of times a key has been registered, you can store it here. Useful to see if a key has been pirated
bool | invalidKey
[in] If you want to mark a key as invalid, you can store it here.
RakNet::RakString invalidKeyReason
[in] Reason why a key was invalid.
char * | binaryData
[in] Any other data you wish to store.
int | binaryDataLength
[in] Length of binaryDataLength
long long | creationDate
[out] Added automatically by the database on row entry. Parse with _localtime64()

Detailed Description

User keys are a more general form of CD Keys This database can maintain records of what keys have been used, and additional data per-key if required

The documentation for this class was generated from the following files:
  • C:/RakNet/DependentExtensions/Lobby/TitleValidationDBSpec.h
  • C:/RakNet/DependentExtensions/Lobby/TitleValidationDBSpec.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: VBRState Struct Reference

VBRState Struct Reference

#include <vbr.h>

List of all members.

Detailed Description

VBR state.

The documentation for this struct was generated from the following file:
  • C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/vbr.h
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Hierarchical Index

RakNet Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • AutopatcherRepositoryInterface
    • AutopatcherMySQLRepository
    • AutopatcherPostgreRepository
  • DataStructures::BinarySearchTree< BinarySearchTreeType >
    • DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType >
  • RakNet::BitStream
  • DataStructures::BPlusTree< KeyType, DataType, order >
  • CheckSum
  • DataStructures::CircularLinkedList< CircularLinkedListType >
  • DataStructures::CircularLinkedList< LinkedListType >
  • RakNet::ClanJoinInvitation_Notification
  • RakNet::ClanJoinInvitationAccepted_Notification
  • RakNet::ClanJoinInvitationRejected_Notification
  • RakNet::ClanJoinInvitationWithdrawn_Notification
  • RakNet::ClanMemberJoinRequest_Notification
  • RakNet::ClanMemberJoinRequestAccepted_Notification
  • RakNet::ClanMemberJoinRequestRejected_Notification
  • RakNet::ClanMemberJoinRequestWithdrawn_Notification
  • CombFilterMem
  • CommandParserInterface
    • LogCommandParser
    • RakNetCommandParser
    • RakNetTransportCommandParser
  • RakNet::Connection_RM2
  • RakNet::Connection_RM2Factory
  • ConnectionGraph::SystemAddressAndGroupId
  • ConsoleServer
  • DatabaseCellUpdate
  • DataBlockEncryptor
  • DataCompressor
  • DecState
  • drft_lookup
  • EmailSender
  • EncState
  • FileListNode
  • FileListProgress
    • FLP_Printf
  • FileListTransferCBInterface
  • RakNet::FunctionThread
  • RakNet::Functor
    • InlineFunctor
  • HTTPConnection
  • HTTPConnection::BadResponse
  • HuffmanEncodingTree
  • HuffmanEncodingTreeFactory
  • InlineFunctorProcessor
  • InternalPacket
  • RakNet::LeaveClan_Notification
  • DataStructures::List< list_type >
  • RakNet::Lobby2::LobbyClient
    • RakNet::Lobby2::LobbyClientPC
  • RakNet::LobbyClientInterface
    • RakNet::LobbyClientPC
  • LobbyDB_PostgreSQL
  • LobbyDBCBInterface
    • RakNet::LobbyServerPostgreSQL
  • LogCommandParser::SystemAddressAndChannel
  • ltp_params
  • DataStructures::Map< key_type, data_type, key_comparison_func >
  • MemoryCompressor
  • DataStructures::MemoryPool< MemoryBlockType >
  • NatPunchthroughLogger
  • NetworkIDManager
  • NetworkIDObject
    • RakNet::Replica2
    • Replica
  • DataStructures::OrderedList< key_type, data_type, default_comparison_function >
  • Packet
  • DataStructures::Page< KeyType, DataType, order >
  • RankingServerDBSpec::PairedKeyDbId
  • PluginInterface
    • ConnectionGraph
    • DirectoryDeltaTransfer
    • FileListTransfer
    • FullyConnectedMesh
    • LightweightDatabaseClient
    • LightweightDatabaseServer
    • MessageFilter
    • NatPunchthrough
    • PacketLogger
      • PacketConsoleLogger
      • PacketFileLogger
      • ThreadsafePacketLogger
    • RakNet::AutoRPC
    • RakNet::Lobby2::LobbyClientPC
    • RakNet::LobbyClientPC
    • RakNet::LobbyServer
      • RakNet::LobbyServerPostgreSQL
    • RakNet::ReplicaManager2
    • RakNet::RPC3
    • ReadyEvent
    • ReplicaManager
    • Router
  • DataStructures::Queue< queue_type >
  • DataStructures::QueueLinkedList< QueueType >
  • RakNetStatistics
  • RakPeer::MemoryBlock
  • RakPeerInterface
    • RakPeer
  • RakNet::RakString
  • RankingServer_PostgreSQL
  • RankingServerCBInterface
    • RakNet::LobbyServerPostgreSQL
  • ReceiveConstructionInterface
  • ReceiveDownloadCompleteInterface
  • RefCountedObj
    • LobbyDBSpec::AddAccountNote_Data
    • LobbyDBSpec::AddFriend_Data
    • LobbyDBSpec::AddToIgnoreList_Data
    • LobbyDBSpec::CreateUser_Data
    • LobbyDBSpec::DeleteEmail_Data
    • LobbyDBSpec::GetAccountNotes_Data
    • LobbyDBSpec::GetEmails_Data
    • LobbyDBSpec::GetFriends_Data
    • LobbyDBSpec::GetIgnoreList_Data
    • LobbyDBSpec::GetUser_Data
    • LobbyDBSpec::RemoveFriend_Data
    • LobbyDBSpec::RemoveFromIgnoreList_Data
    • LobbyDBSpec::SendEmail_Data
    • LobbyDBSpec::UpdateEmailStatus_Data
    • LobbyDBSpec::UpdateUser_Data
    • RankingServerDBSpec::GetHistoryForParticipant_Data
      • GetHistoryForParticipant_PostgreSQLImpl
    • RankingServerDBSpec::GetRatingForParticipant_Data
      • GetRatingForParticipant_PostgreSQLImpl
    • RankingServerDBSpec::GetRatingForParticipants_Data
      • GetRatingForParticipants_PostgreSQLImpl
    • RankingServerDBSpec::GetTrustedIPList_Data
    • RankingServerDBSpec::ModifyTrustedIPList_Data
      • ModifyTrustedIPList_PostgreSQLImpl
    • RankingServerDBSpec::SubmitMatch_Data
      • SubmitMatch_PostgreSQLImpl
    • TitleValidationDBSpec::AddTitle_Data
    • TitleValidationDBSpec::GetTitles_Data
    • TitleValidationDBSpec::UpdateUserKey_Data
  • ReliabilityLayer
  • RemoteClient
  • RouterInterface
    • Router
  • RPCParameters
  • SBDecState
  • SBEncState
  • SendDownloadCompleteInterface
  • RakNet::SerializationContext
  • SimpleMutex
  • DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • SocketDescriptor
  • SpeexBits
  • SpeexCallback
  • SpeexEchoState_
  • SpeexHeader
  • SpeexJitter
  • SpeexMode
  • SpeexNBMode
  • SpeexPreprocessState
  • SpeexSBMode
  • SpeexStereoState
  • SpeexSubmode
  • split_cb_params
  • StrAndBool
  • StringCompressor
  • RakNet::StringTable
  • SystemAddress
  • DataStructures::Table
  • DataStructures::Table::Cell
  • DataStructures::Table::ColumnDescriptor
  • DataStructures::Table::Row
  • ThreadPool< InputType, OutputType >
  • TitleValidation_PostgreSQL
  • TitleValidationDBCBInterface
    • RakNet::LobbyServerPostgreSQL
  • TransportInterface
    • RakNetTransport
    • TelnetTransport
  • VBRState
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • abr_enabled : EncState , SBEncState
  • AcceptAddFriendInvite() : RakNet::LobbyClientPC
  • AccessSerializationFlags() : ReplicaManager
  • accountBalance : LobbyDBSpec::CreateUser_Data
  • accountNumber : LobbyDBSpec::CreateUser_Data
  • acknowlegementBitsSent : RakNetStatistics
  • acknowlegementsPending : RakNetStatistics
  • acknowlegementsReceived : RakNetStatistics
  • acknowlegementsSent : RakNetStatistics
  • AckTimeout() : ReliabilityLayer
  • actions : LobbyDBSpec::AddToIgnoreList_Data
  • AddAllowedType() : Router
  • AddApplication() : AutopatcherMySQLRepository , AutopatcherPostgreRepository
  • AddAutoSerializeTimer() : RakNet::Replica2
  • AddBitsAndReallocate() : RakNet::BitStream
  • AddChannel() : LogCommandParser
  • AddColumn() : DataStructures::Table
  • AddCommandParser() : ConsoleServer
  • AddInput() : ThreadPool< InputType, OutputType >
  • AddNewConnection() : ConnectionGraph , RakNet::ReplicaManager2
  • AddParticipant() : ReplicaManager
  • AddReference() : StringCompressor , RakNet::StringTable
  • AddRow() : DataStructures::Table
  • AddString() : RakNet::StringTable
  • AddTable() : LightweightDatabaseServer
  • AddToActionHistory() : RakNet::LobbyClientPC
  • AddToBanList() : RakPeer , RakPeerInterface
  • AddToFrequencyTable() : HuffmanEncodingTreeFactory
  • addToList : RankingServerDBSpec::ModifyTrustedIPList_Data
  • AddToOrUpdateIgnoreList() : RakNet::LobbyClientPC
  • AddToSecurityExceptionList() : RakPeer , RakPeerInterface
  • AddToWaitList() : ReadyEvent
  • AddUploadsFromSubdirectory() : DirectoryDeltaTransfer
  • adminLevel : LobbyDBSpec::CreateUser_Data
  • AdvertiseSystem() : RakPeer , RakPeerInterface
  • AlignReadToByteBoundary() : RakNet::BitStream
  • AlignWriteToByteBoundary() : RakNet::BitStream
  • Alloc() : GetHistoryForParticipant_PostgreSQLImpl , ModifyTrustedIPList_PostgreSQLImpl , GetRatingForParticipants_PostgreSQLImpl , SubmitMatch_PostgreSQLImpl , GetRatingForParticipant_PostgreSQLImpl
  • AllocatePacket() : RakPeer , RakPeerInterface
  • allowClientAccountCreation : TitleValidationDBSpec::AddTitle_Data
  • AllowConnectionResponseIPMigration() : RakPeerInterface
  • allowConnectionResponseIPMigration : RakPeer
  • AllowConnectionResponseIPMigration() : RakPeer
  • AllowRemoteConstruction() : RakNet::Replica2
  • ApplyNetworkSimulator() : RakPeerInterface , RakPeer
  • ascendingSort
: LobbyDBSpec::GetIgnoreList_Data
, LobbyDBSpec::GetFriends_Data
, LobbyDBSpec::GetEmails_Data
, LobbyDBSpec::GetAccountNotes_Data
  • AssertCopyData() : RakNet::BitStream
  • AssertParticipantsClear() : ReplicaManager
  • AssertReplicatedObjectsClear() : ReplicaManager
  • AssertStreamEmpty() : RakNet::BitStream
  • AssignCallback() : LobbyDB_PostgreSQL , RankingServer_PostgreSQL , TitleValidation_PostgreSQL
  • AssignSystemAddressToRemoteSystemList() : RakPeer
  • attachment : LobbyDBSpec::SendEmail_Data
  • attachmentLength : LobbyDBSpec::SendEmail_Data
  • AttachPlugin() : RakPeerInterface , RakPeer
  • autocorr : SBEncState , EncState
  • AutoRPC() : RakNet::AutoRPC
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Namespace Index

  • Namespace List
  • Namespace Members

RakNet Namespace List

Here is a list of all documented namespaces with brief descriptions:
cat | Compatibility and Fundamental Tools and Types. This namespace contains compatibility tools and types and also fundamental class
DataStructures |
RakNet | Forward declaration
Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: cat Namespace Reference

  • Namespace List
  • Namespace Members

cat Namespace Reference

Compatibility and Fundamental Tools and Types. This namespace contains compatibility tools and types and also fundamental class. More...

Typedefs

typedef unsigned char | u8
typedef signed char | s8
typedef unsigned short | u16
typedef signed short | s16
typedef unsigned int | u32
typedef signed int | s32
typedef float | f32
typedef double | f64
typedef s32 | sfp22_10
typedef u32 | ufp22_10
typedef s32 | sfp16_16
typedef u32 | ufp16_16

Detailed Description

Compatibility and Fundamental Tools and Types. This namespace contains compatibility tools and types and also fundamental class.

Compiler detection

Things to consider for each compiler:

  • BIG_ENDIAN / LITTLE_ENDIAN
  • MULTITHREADED
  • DEBUG
  • HASINT64
  • Basic types {u8-u64, s8-s64, f32, f64}
  • WIN32
  • ASSEMBLY_INTEL_SYNTAX / ASSEMBLY_ATT_SYNTAX, ASSEMBLY_BLOCK
  • INLINE
  • NO_TEMPLATE_INLINE_ASSEMBLY
  • Fixes

Set depending which compiler is being used:

  • COMPILER_MSVC
  • COMPILER_GCC
  • COMPILER_BORLANDC

Typedef Documentation

typedef float cat::f32

Typename for 32 bits floatting point number

typedef double cat::f64

Typename for 64 bits floatting point number

typedef signed short cat::s16

Typename for 16 bits signed integer

typedef signed int cat::s32

Typename for 32 bits signed integer

typedef signed char cat::s8

Typename for 8 bits signed integer

typedef s32 cat::sfp16_16

Fixed point types hi-Siiiiiiiiiiiiiii-lo | hi-ffffffffffffffff-lo

typedef s32 cat::sfp22_10

Fixed-point types hi-Siiiiiiiiiiiiiiiiiiiii-lo | hi-ffffffffff-lo

typedef unsigned short cat::u16

Typename for 16 bits unsigned integer

typedef unsigned int cat::u32

Typename for 32 bits unsigned integer

typedef unsigned char cat::u8

Typename for 8 bits unsigned integer

typedef u32 cat::ufp16_16

Fixed point types hi-iiiiiiiiiiiiiiii-lo | hi-ffffffffffffffff-lo

typedef u32 cat::ufp22_10

Fixed-point types hi-iiiiiiiiiiiiiiiiiiiiii-lo | hi-ffffffffff-lo

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: DataStructures Namespace Reference

  • Namespace List
  • Namespace Members

DataStructures Namespace Reference

Classes

class | BinarySearchTree
A binary search tree and an AVL balanced binary search tree. More...
class | AVLBalancedBinarySearchTree
An AVLBalancedBinarySearchTree is a binary tree that is always balanced. More...
struct | Page
class | BPlusTree
class | CircularLinkedList
(Circular) Linked List ADT (Doubly Linked Pointer to Node Style) - More...
class | List
Array based implementation of a list. More...
class | Map
Note:
IMPORTANT! If you use defaultMapKeyComparison then call IMPLEMENT_DEFAULT_COMPARISON or you will get an unresolved external linker error.
More...
class | MemoryPool
class | OrderedList
Note:
IMPORTANT! If you use defaultOrderedListComparison then call IMPLEMENT_DEFAULT_COMPARISON or you will get an unresolved external linker error.
More...
class | Queue
A queue implemented as an array with a read and write index. More...
class | QueueLinkedList
A queue implemented using a linked list. Rarely used. More...
class | Table
Holds a set of columns, a set of rows, and rows times columns cells. The table data structure is useful if you want to store a set of structures and perform queries on those structures This is a relatively simple and fast implementation of the types of tables commonly used in databases See TableSerializer to serialize data members of the table See LightweightDatabaseClient and LightweightDatabaseServer to transmit the table over the network. More...
class | SingleProducerConsumer
A single producer consumer implementation without critical sections. More...

Functions

template<class key_type>
int | defaultMapKeyComparison (const key_type &a, const key_type &b)

Detailed Description

The namespace DataStructures was only added to avoid compiler errors for commonly named data structures As these data structures are stand-alone, you can use them outside of RakNet for your own projects if you wish.

Function Documentation

template<class key_type>
int DataStructures::defaultMapKeyComparison | ( | const key_type & | a,
 |  | const key_type & | b
 | ) |  |

The default comparison has to be first so it can be called as a default parameter. It then is followed by MapNode, followed by NodeComparisonFunc

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: RakNet Namespace Reference

  • Namespace List
  • Namespace Members

RakNet Namespace Reference

Forward declaration. More...

Classes

class | AutoRPC
class | BitStream
class | FunctionThread
class | Functor
class | RakString
String class Has the following improvements over std::string Reference counting: Suitable to store in lists Varidic assignment operator Doesn't cause linker errors. More...
class | ReplicaManager2
A management system for your game objects and players to make serialization, scoping, and object creation and destruction easier. More...
struct | SerializationContext
Contextual information about serialization, passed to some functions in Replica2. More...
class | Replica2
Base class for game objects that use the ReplicaManager2 system All game objects that want to use the ReplicaManager2 functionality must inherit from Replica2. Generally you will want to implement at a minimum Serialize(), Deserialize(), and SerializeConstruction(). More...
class | Connection_RM2Factory
Implement this factory class to return instances of your Connection_RM2 derived object. This is used as a class factory and exposes functionality related to the connection and the system. More...
class | Connection_RM2
This class represents a connection between two instances of ReplicaManager2 Represents a connection. Allocated by user supplied factory interface Connection_RM2Factory Implicitly created as needed Generally you will want to implement at a minimum the Construct() function, used as a factory function to create your game objects. More...
class | StringTable
Writes a string index, instead of the whole string. More...
class | LobbyClientInterface
The client-side interface to the lobby system The Lobby client implements functionality commonly found in game lobbies. It is the counterpart to the LobbyServer class. This interface is system independent, but for PC functionality see LobbyClientPC For full documentation on the PC version, see LobbyClientPC.h. More...
struct | LeaveClan_Notification
Someone has left this clan. More...
struct | ClanJoinInvitationWithdrawn_Notification
You were invited to a clan, but this invitation has been revoked. More...
struct | ClanJoinInvitationRejected_Notification
struct | ClanJoinInvitationAccepted_Notification
struct | ClanJoinInvitation_Notification
A leader or subleader in a clan has invited you to join that clan. More...
struct | ClanMemberJoinRequestWithdrawn_Notification
Someone has petitioned to join your clan, but changed their mind and have withdrawn that petition. More...
struct | ClanMemberJoinRequestRejected_Notification
struct | ClanMemberJoinRequestAccepted_Notification
struct | ClanMemberJoinRequest_Notification
Someone has asked to join your clan. More...
class | LobbyClientPC
PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality. More...
class | LobbyServer
class | LobbyServerPostgreSQL
class | RPC3

Enumerations

enum RPCErrorCodes {
RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RPC_ERROR_OBJECT_DOES_NOT_EXIST, RPC_ERROR_OBJECT_DOES_NOT_EXIST,
RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RPC_ERROR_FUNCTION_NOT_REGISTERED, RPC_ERROR_FUNCTION_NOT_REGISTERED,
RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RPC_ERROR_CALLING_CPP_AS_C, RPC_ERROR_CALLING_CPP_AS_C,
RPC_ERROR_CALLING_C_AS_CPP, RPC_ERROR_CALLING_C_AS_CPP, RPC_ERROR_STACK_TOO_SMALL, RPC_ERROR_STACK_DESERIALIZATION_FAILED,
RPC_ERROR_INCORRECT_NUMBER_OF_PARAMETERS, RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RPC_ERROR_OBJECT_DOES_NOT_EXIST,
RPC_ERROR_OBJECT_DOES_NOT_EXIST, RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RPC_ERROR_FUNCTION_NOT_REGISTERED,
RPC_ERROR_FUNCTION_NOT_REGISTERED, RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RPC_ERROR_CALLING_CPP_AS_C,
RPC_ERROR_CALLING_CPP_AS_C, RPC_ERROR_CALLING_C_AS_CPP, RPC_ERROR_CALLING_C_AS_CPP
}
enum SerializationType {
SEND_SERIALIZATION_GENERIC_TO_SYSTEM, BROADCAST_SERIALIZATION_GENERIC_TO_SYSTEM, SEND_SERIALIZATION_CONSTRUCTION_TO_SYSTEM, BROADCAST_SERIALIZATION_CONSTRUCTION_TO_SYSTEM,
SEND_AUTO_SERIALIZE_TO_SYSTEM, BROADCAST_AUTO_SERIALIZE_TO_SYSTEM, RELAY_SERIALIZATION_TO_SYSTEMS, SEND_CONSTRUCTION_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM ,
SEND_DATA_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM, SEND_DESTRUCTION_GENERIC_TO_SYSTEM, SEND_DESTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM, BROADCAST_DESTRUCTION_GENERIC_TO_SYSTEM,
RELAY_DESTRUCTION_TO_SYSTEMS, SEND_CONSTRUCTION_GENERIC_TO_SYSTEM, SEND_CONSTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM, BROADCAST_CONSTRUCTION_GENERIC_TO_SYSTEM,
SEND_CONSTRUCTION_REQUEST_TO_SERVER, BROADCAST_CONSTRUCTION_REQUEST_ACCEPTED_TO_SYSTEM, SEND_CONSTRUCTION_REPLY_ACCEPTED_TO_CLIENT, SEND_CONSTRUCTION_REPLY_DENIED_TO_CLIENT,
SEND_VISIBILITY_TRUE_TO_SYSTEM, BROADCAST_VISIBILITY_TRUE_TO_SYSTEM, SEND_VISIBILITY_FALSE_TO_SYSTEM, BROADCAST_VISIBILITY_FALSE_TO_SYSTEM,
RELAY_VISIBILITY_TRUE_TO_SYSTEMS, RELAY_VISIBILITY_FALSE_TO_SYSTEMS, AUTOSERIALIZE_RESYNCH_ONLY, AUTOSERIALIZE_DEFAULT,
UNDEFINED_REASON
}
These are the types of events that can cause network data to be transmitted. More...
enum RPCErrorCodes {
RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RPC_ERROR_OBJECT_DOES_NOT_EXIST, RPC_ERROR_OBJECT_DOES_NOT_EXIST,
RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RPC_ERROR_FUNCTION_NOT_REGISTERED, RPC_ERROR_FUNCTION_NOT_REGISTERED,
RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RPC_ERROR_CALLING_CPP_AS_C, RPC_ERROR_CALLING_CPP_AS_C,
RPC_ERROR_CALLING_C_AS_CPP, RPC_ERROR_CALLING_C_AS_CPP, RPC_ERROR_STACK_TOO_SMALL, RPC_ERROR_STACK_DESERIALIZATION_FAILED,
RPC_ERROR_INCORRECT_NUMBER_OF_PARAMETERS, RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RPC_ERROR_OBJECT_DOES_NOT_EXIST,
RPC_ERROR_OBJECT_DOES_NOT_EXIST, RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RPC_ERROR_FUNCTION_NOT_REGISTERED,
RPC_ERROR_FUNCTION_NOT_REGISTERED, RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RPC_ERROR_CALLING_CPP_AS_C,
RPC_ERROR_CALLING_CPP_AS_C, RPC_ERROR_CALLING_C_AS_CPP, RPC_ERROR_CALLING_C_AS_CPP
}

Functions

RakNetTime | GetTime (void)
Returns the value from QueryPerformanceCounter. This is the function RakNet uses to represent time.

Detailed Description

Forward declaration.

The namespace RakNet is not consistently used. It's only purpose is to avoid compiler errors for classes whose names are very common. For the most part I've tried to avoid this simply by using names very likely to be unique for my classes.

Enumeration Type Documentation

enum RakNet::RPCErrorCodes

Error codes returned by a remote system as to why an RPC function call cannot execute Follows packet ID ID_RPC_REMOTE_ERROR Name of the function will be appended, if available. Read as follows: char outputBuff[256]; stringCompressor->DecodeString(outputBuff,256,&RakNet::BitStream(p->data+sizeof(MessageID)+1,p->length-sizeof(MessageID)-1,false),0); printf("Function: %s\n", outputBuff);

Enumerator:
RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE | AutoRPC::SetNetworkIDManager() was not called, and it must be called to call a C++ object member.
RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE | RPC3::SetNetworkIDManager() was not called, and it must be called to call a C++ object member.
RPC_ERROR_OBJECT_DOES_NOT_EXIST | Cannot execute C++ object member call because the object specified by SetRecipientObject() does not exist on this system.
RPC_ERROR_OBJECT_DOES_NOT_EXIST | Cannot execute C++ object member call because the object specified by SetRecipientObject() does not exist on this system.
RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE | Internal error, index optimization for function lookup does not exist.
RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE | Internal error, index optimization for function lookup does not exist.
RPC_ERROR_FUNCTION_NOT_REGISTERED | Named function was not registered with RegisterFunction(). Check your spelling.
RPC_ERROR_FUNCTION_NOT_REGISTERED | Named function was not registered with RegisterFunction(). Check your spelling.
RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED | Named function was registered, but later unregistered with UnregisterFunction() and can no longer be called.
RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED | Named function was registered, but later unregistered with UnregisterFunction() and can no longer be called.
RPC_ERROR_CALLING_CPP_AS_C | SetRecipientObject() was not called before Call(), but RegisterFunction() was called with isObjectMember=true If you intended to call a CPP function, call SetRecipientObject() with a valid object first.
RPC_ERROR_CALLING_CPP_AS_C | SetRecipientObject() was not called before Call(), but the registered pointer is a class member If you intended to call a class member function, call SetRecipientObject() with a valid object first.
RPC_ERROR_CALLING_C_AS_CPP | SetRecipientObject() was called before Call(), but RegisterFunction() was called with isObjectMember=false If you intended to call a C function, call SetRecipientObject(UNASSIGNED_NETWORK_ID) first.
RPC_ERROR_CALLING_C_AS_CPP | SetRecipientObject() was called before Call(), but RegisterFunction() was called with isObjectMember=false If you intended to call a C function, call SetRecipientObject(UNASSIGNED_NETWORK_ID) first.
RPC_ERROR_STACK_TOO_SMALL | Internal error, passed stack is bigger than current stack. Check that the version is the same on both systems.
RPC_ERROR_STACK_DESERIALIZATION_FAILED | Internal error, formatting error with how the stack was serialized.
RPC_ERROR_INCORRECT_NUMBER_OF_PARAMETERS | The parameterCount parameter passed to RegisterFunction() on this system does not match the parameterCount parameter passed to SendCall() on the remote system.
RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE | AutoRPC::SetNetworkIDManager() was not called, and it must be called to call a C++ object member.
RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE | RPC3::SetNetworkIDManager() was not called, and it must be called to call a C++ object member.
RPC_ERROR_OBJECT_DOES_NOT_EXIST | Cannot execute C++ object member call because the object specified by SetRecipientObject() does not exist on this system.
RPC_ERROR_OBJECT_DOES_NOT_EXIST | Cannot execute C++ object member call because the object specified by SetRecipientObject() does not exist on this system.
RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE | Internal error, index optimization for function lookup does not exist.
RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE | Internal error, index optimization for function lookup does not exist.
RPC_ERROR_FUNCTION_NOT_REGISTERED | Named function was not registered with RegisterFunction(). Check your spelling.
RPC_ERROR_FUNCTION_NOT_REGISTERED | Named function was not registered with RegisterFunction(). Check your spelling.
RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED | Named function was registered, but later unregistered with UnregisterFunction() and can no longer be called.
RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED | Named function was registered, but later unregistered with UnregisterFunction() and can no longer be called.
RPC_ERROR_CALLING_CPP_AS_C | SetRecipientObject() was not called before Call(), but RegisterFunction() was called with isObjectMember=true If you intended to call a CPP function, call SetRecipientObject() with a valid object first.
RPC_ERROR_CALLING_CPP_AS_C | SetRecipientObject() was not called before Call(), but the registered pointer is a class member If you intended to call a class member function, call SetRecipientObject() with a valid object first.
RPC_ERROR_CALLING_C_AS_CPP | SetRecipientObject() was called before Call(), but RegisterFunction() was called with isObjectMember=false If you intended to call a C function, call SetRecipientObject(UNASSIGNED_NETWORK_ID) first.
RPC_ERROR_CALLING_C_AS_CPP | SetRecipientObject() was called before Call(), but RegisterFunction() was called with isObjectMember=false If you intended to call a C function, call SetRecipientObject(UNASSIGNED_NETWORK_ID) first.

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerator
  • a
  • b
  • d
  • f
  • r
  • s
  • u

Here is a list of all documented namespace members with links to the namespaces they belong to:

- a -

  • AUTOSERIALIZE_DEFAULT : RakNet
  • AUTOSERIALIZE_RESYNCH_ONLY : RakNet

- b -

  • BROADCAST_AUTO_SERIALIZE_TO_SYSTEM : RakNet
  • BROADCAST_CONSTRUCTION_GENERIC_TO_SYSTEM : RakNet
  • BROADCAST_CONSTRUCTION_REQUEST_ACCEPTED_TO_SYSTEM : RakNet
  • BROADCAST_DESTRUCTION_GENERIC_TO_SYSTEM : RakNet
  • BROADCAST_SERIALIZATION_CONSTRUCTION_TO_SYSTEM : RakNet
  • BROADCAST_SERIALIZATION_GENERIC_TO_SYSTEM : RakNet
  • BROADCAST_VISIBILITY_FALSE_TO_SYSTEM : RakNet
  • BROADCAST_VISIBILITY_TRUE_TO_SYSTEM : RakNet

- d -

  • defaultMapKeyComparison() : DataStructures

- f -

  • f32 : cat
  • f64 : cat

- r -

  • RELAY_DESTRUCTION_TO_SYSTEMS : RakNet
  • RELAY_SERIALIZATION_TO_SYSTEMS : RakNet
  • RELAY_VISIBILITY_FALSE_TO_SYSTEMS : RakNet
  • RELAY_VISIBILITY_TRUE_TO_SYSTEMS : RakNet
  • RPC_ERROR_CALLING_C_AS_CPP : RakNet
  • RPC_ERROR_CALLING_CPP_AS_C : RakNet
  • RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE : RakNet
  • RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED : RakNet
  • RPC_ERROR_FUNCTION_NOT_REGISTERED : RakNet
  • RPC_ERROR_INCORRECT_NUMBER_OF_PARAMETERS : RakNet
  • RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE : RakNet
  • RPC_ERROR_OBJECT_DOES_NOT_EXIST : RakNet
  • RPC_ERROR_STACK_DESERIALIZATION_FAILED : RakNet
  • RPC_ERROR_STACK_TOO_SMALL : RakNet

- s -

  • s16 : cat
  • s32 : cat
  • s8 : cat
  • SEND_AUTO_SERIALIZE_TO_SYSTEM : RakNet
  • SEND_CONSTRUCTION_GENERIC_TO_SYSTEM : RakNet
  • SEND_CONSTRUCTION_REPLY_ACCEPTED_TO_CLIENT : RakNet
  • SEND_CONSTRUCTION_REPLY_DENIED_TO_CLIENT : RakNet
  • SEND_CONSTRUCTION_REQUEST_TO_SERVER : RakNet
  • SEND_CONSTRUCTION_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM : RakNet
  • SEND_CONSTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM : RakNet
  • SEND_DATA_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM : RakNet
  • SEND_DESTRUCTION_GENERIC_TO_SYSTEM : RakNet
  • SEND_DESTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM : RakNet
  • SEND_SERIALIZATION_CONSTRUCTION_TO_SYSTEM : RakNet
  • SEND_SERIALIZATION_GENERIC_TO_SYSTEM : RakNet
  • SEND_VISIBILITY_FALSE_TO_SYSTEM : RakNet
  • SEND_VISIBILITY_TRUE_TO_SYSTEM : RakNet
  • sfp16_16 : cat
  • sfp22_10 : cat

- u -

  • u16 : cat
  • u32 : cat
  • u8 : cat
  • ufp16_16 : cat
  • ufp22_10 : cat
  • UNDEFINED_REASON : RakNet
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: File Index

  • File List
  • File Members

RakNet File List

Here is a list of all documented files with brief descriptions:
C:/RakNet/DependentExtensions/AutopatcherClient.h | Client plugin for the autopatcher
C:/RakNet/DependentExtensions/AutopatcherServer.cpp | The server plugin for the autopatcher. Must be running for the client to get patches
C:/RakNet/DependentExtensions/AutopatcherServer.h | The server plugin for the autopatcher. Must be running for the client to get patches
C:/RakNet/DependentExtensions/RakVoice.h | Voice compression and transmission interface
C:/RakNet/DependentExtensions/AutopatcherMySQLRepository/AutopatcherMySQLRepository.h | An implementation of the AutopatcherRepositoryInterface to use MySQL to store the relevant data
C:/RakNet/DependentExtensions/AutopatcherPostgreRepository/AutopatcherPostgreRepository.cpp | An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data
C:/RakNet/DependentExtensions/AutopatcherPostgreRepository/AutopatcherPostgreRepository.h | An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data
C:/RakNet/DependentExtensions/Lobby/LobbyClientInterface.h | Interface to the lobby client. Not platform specific
C:/RakNet/DependentExtensions/Lobby/LobbyClientPC.h | Interface to the lobby client for the PC
C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h | Not code so much as a specification for the structures and classes that an implementation of the lobby server can use
C:/RakNet/DependentExtensions/Lobby/LobbyPCCommon.h | Common source between the lobby client and the lobby server for the PC
C:/RakNet/DependentExtensions/Lobby/LobbyServer.h | Base class that implements the networking for the lobby server. Database specific functionality is implemented in a derived class
C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.h | Not code so much as a specification for the structures and classes that an implementation of the ranking server can use
C:/RakNet/DependentExtensions/Lobby/TitleValidationDBSpec.h | Not code so much as a specification for the structures and classes that an implementation of a title validation system (CD Keys and game server logins)
C:/RakNet/DependentExtensions/Lobby/LobbyDB_PostgreRepository/LobbyDB_PostgreSQL.cpp | An implementation of the LobbyServer database to use PostgreSQL to store the relevant data
C:/RakNet/DependentExtensions/Lobby/LobbyDB_PostgreRepository/LobbyDB_PostgreSQL.h | An implementation of the LobbyServer database to use PostgreSQL to store the relevant data
C:/RakNet/DependentExtensions/Lobby/LobbyServer_PostgreSQL/LobbyServer_PostgreSQL.h | Base class that implements the networking for the lobby server. Database specific functionality is implemented in a derived class
C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.cpp | An implementation of the RankingRepositoryInterface to use PostgreSQL to store the relevant data
C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.h | An implementation of the RankingServerPostgreRepository to use PostgreSQL to store ranking info for users
C:/RakNet/DependentExtensions/Lobby/TitleValidationDB_PostgreRepository/TitleValidationDB_PostgreSQL.cpp | An implementation of TitleValidationDBSpec.h to use PostgreSQL. Title validation is useful for checking server logins and cd keys
C:/RakNet/DependentExtensions/Lobby/TitleValidationDB_PostgreRepository/TitleValidationDB_PostgreSQL.h | An implementation of TitleValidationDBSpec.h to use PostgreSQL. Title validation is useful for checking server logins and cd keys
C:/RakNet/DependentExtensions/RPC3/RPC3.h | Automatically serializing and deserializing RPC system. Third generation of RPC
C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/pcm_wrapper.h | PCM encoding wrapped as a Speex mode
C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex.h | Describes the different modes of the codec
C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_bits.h | Handles bit packing/unpacking
C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_callbacks.h | Describes callback handling and in-band signalling
C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_echo.h | Echo cancellation
C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_header.h | Describes the Speex header
C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_jitter.h | Adaptive jitter buffer for Speex
C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_preprocess.h | Speex preprocessor
C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_stereo.h | Describes the handling for intensity stereo
C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_types.h | Speex types
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/arch.h | Various architecture definitions Speex
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/cb_search.h | Overlapped codebook search
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/cb_search_arm4.h | Fixed codebook functions (ARM4 version)
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/cb_search_bfin.h | Fixed codebook functions (Blackfin version)
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/cb_search_sse.h | Fixed codebook functions (SSE version)
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/filters.h | Various analysis/synthesis filters
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/filters_arm4.h | Various analysis/synthesis filters (ARM4 version)
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/filters_bfin.h | Various analysis/synthesis filters (Blackfin version)
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/filters_sse.h | Various analysis/synthesis filters (SSE version)
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/fixed_arm4.h | ARM4 fixed-point operations
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/fixed_arm5e.h | ARM-tuned fixed-point operations
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/fixed_bfin.h | Blackfin fixed-point operations
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/fixed_debug.h | Fixed-point operations with debugging
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/fixed_generic.h | Generic fixed-point operations
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/lpc.h | Functions for LPC (Linear Prediction Coefficients) analysis
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/lpc_bfin.h | Functions for LPC (Linear Prediction Coefficients) analysis (Blackfin version)
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/lsp.h | Line Spectral Pair (LSP) functions
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/ltp.h | Long-Term Prediction functions
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/ltp_arm4.h | Long-Term Prediction functions (ARM4 version)
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/ltp_bfin.h | Long-Term Prediction functions (Blackfin version)
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/ltp_sse.h | Long-Term Prediction functions (SSE version)
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/math_approx.h | Various math approximation functions for Speex
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/misc.h | Various compatibility routines for Speex
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/misc_bfin.h | Various compatibility routines for Speex (Blackfin version)
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/modes.h | Describes the different modes of the codec
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/nb_celp.h | Narrowband CELP encoder/decoder
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/pcm_wrapper.c | PCM encoding wrapped as a Speex mode
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/pseudofloat.h | Pseudo-floating point
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/quant_lsp.h | LSP vector quantization
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/sb_celp.h | Sub-band CELP mode used for wideband encoding
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/smallft.h | Discrete Rotational Fourier Transform (DRFT)
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/stack_alloc.h | Temporary memory allocation on stack
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/vbr.h | Variable Bit-Rate (VBR) related routines
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/vq.h | Vector quantization
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/vq_arm4.h | ARM4-optimized vq routine
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/vq_bfin.h | Blackfin-optimized vq routine
C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/vq_sse.h | SSE-optimized vq routine
C:/RakNet/Source/AsynchronousFileIO.cpp |
C:/RakNet/Source/AsynchronousFileIO.h | [Internal] Depreciated, used for windows back when I supported IO completion ports
C:/RakNet/Source/AutopatcherRepositoryInterface.h | An interface used by AutopatcherServer to get the data necessary to run an autopatcher
C:/RakNet/Source/AutoRPC.h | Automatically serializing and deserializing RPC system. More advanced RPC, but possibly not cross-platform
C:/RakNet/Source/BigTypes.h | [Internal] Used for RSA generation
C:/RakNet/Source/BitStream.cpp |
C:/RakNet/Source/BitStream.h | This class allows you to write and read native types as a string of bits. BitStream is used extensively throughout RakNet and is designed to be used by users as well
C:/RakNet/Source/BitStream_NoTemplate.cpp |
C:/RakNet/Source/BitStream_NoTemplate.h | This class allows you to write and read native types as a string of bits. BitStream is used extensively throughout RakNet and is designed to be used by users as well
C:/RakNet/Source/CheckSum.cpp | CheckSum implementation from http://www.flounder.com/checksum.htm
C:/RakNet/Source/CheckSum.h | [Internal] Generates and validates checksums
C:/RakNet/Source/ClientContextStruct.h | [Internal] Depreciated, back from when I supported IO Completion ports
C:/RakNet/Source/CommandParserInterface.h | Contains CommandParserInterface , from which you derive custom command parsers
C:/RakNet/Source/ConnectionGraph.cpp |
C:/RakNet/Source/ConnectionGraph.h | Connection graph plugin. This maintains a graph of connections for the entire network, so every peer knows about every other peer
C:/RakNet/Source/ConsoleServer.h | Contains ConsoleServer , used to plugin to your game to accept remote console-based connections
C:/RakNet/Source/DataBlockEncryptor.cpp |
C:/RakNet/Source/DataBlockEncryptor.h | [Internal] Encrypts and decrypts data blocks. Used as part of secure connections
C:/RakNet/Source/DataCompressor.h | DataCompressor does compression on a block of data. Not very good compression, but it's small and fast so is something you can use per-message at runtime
C:/RakNet/Source/DirectoryDeltaTransfer.h | Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc
C:/RakNet/Source/DS_BinarySearchTree.h | [Internal] A binary search tree, and an AVL balanced BST derivation
C:/RakNet/Source/DS_ByteQueue.h | [Internal] Byte queue
C:/RakNet/Source/DS_Heap.h | [Internal] Heap (Also serves as a priority queue)
C:/RakNet/Source/DS_HuffmanEncodingTree.cpp |
C:/RakNet/Source/DS_HuffmanEncodingTree.h | [Internal] Generates a huffman encoding tree, used for string and global compression
C:/RakNet/Source/DS_HuffmanEncodingTreeFactory.h | [Internal] Creates instances of the class HuffmanEncodingTree
C:/RakNet/Source/DS_HuffmanEncodingTreeNode.h | [Internal] A single node in the Huffman Encoding Tree
C:/RakNet/Source/DS_LinkedList.h | [Internal] Straightforward linked list data structure
C:/RakNet/Source/DS_List.h | [Internal] Array based list. Usually the Queue class is used instead, since it has all the same functionality and is only worse at random access
C:/RakNet/Source/DS_Map.h | [Internal] Map
C:/RakNet/Source/DS_OrderedChannelHeap.h | [Internal] Ordered Channel Heap . This is a heap where you add to it on multiple ordered channels, with each channel having a different weight
C:/RakNet/Source/DS_OrderedList.h | [Internal] Quicksort ordered list
C:/RakNet/Source/DS_Queue.h | [Internal] A queue used by RakNet
C:/RakNet/Source/DS_QueueLinkedList.h | [Internal] A queue implemented as a linked list
C:/RakNet/Source/DS_Tree.h | [Internal] Just a regular tree
C:/RakNet/Source/DS_WeightedGraph.h | [Internal] Weighted graph. I'm assuming the indices are complex map types, rather than sequential numbers (which could be implemented much more efficiently)
C:/RakNet/Source/EmailSender.h | Rudimentary class to send email from code. Don't expect anything fancy
C:/RakNet/Source/ExtendedOverlappedPool.cpp |
C:/RakNet/Source/ExtendedOverlappedPool.h | [Depreciated] This was used for IO completion ports
C:/RakNet/Source/FileListTransfer.h | A plugin to provide a simple way to compress and incrementally send the files in the FileList structure
C:/RakNet/Source/FullyConnectedMesh.cpp |
C:/RakNet/Source/FullyConnectedMesh.h | Fully connected mesh plugin. This will connect RakPeer to all connecting peers, and all peers the connecting peer knows about
C:/RakNet/Source/FunctionThread.h | A set of classes to make it easier to perform asynchronous function processing
C:/RakNet/Source/GetTime.cpp |
C:/RakNet/Source/GetTime.h | Returns the value from QueryPerformanceCounter. This is the function RakNet uses to represent time
C:/RakNet/Source/HTTPConnection.cpp | Contains HTTPConnection, used to communicate with web servers
C:/RakNet/Source/HTTPConnection.h | Contains HTTPConnection, used to communicate with web servers
C:/RakNet/Source/InternalPacket.h | [Internal] A class which stores a user message, and all information associated with sending and receiving that message
C:/RakNet/Source/LightweightDatabaseClient.h | Contains the client interface to the simple database included with RakNet, useful for a server browser or a lobby server
C:/RakNet/Source/LightweightDatabaseServer.h | A simple flat database included with RakNet, useful for a server browser or a lobby server
C:/RakNet/Source/LogCommandParser.h | Contains LogCommandParser , Used to send logs to connected consoles
C:/RakNet/Source/MessageFilter.h | Message filter plugin. Assigns systems to FilterSets. Each FilterSet limits what messages are allowed. This is a security related plugin
C:/RakNet/Source/MessageIdentifiers.h | All the message identifiers used by RakNet. Message identifiers comprise the first byte of any message
C:/RakNet/Source/MTUSize.h | [Internal] Defines the default maximum transfer unit
C:/RakNet/Source/NatPunchthrough.h | Contains the NAT-punchthrough plugin
C:/RakNet/Source/NetworkIDManager.cpp |
C:/RakNet/Source/NetworkIDManager.h |
C:/RakNet/Source/NetworkIDObject.cpp |
C:/RakNet/Source/NetworkIDObject.h | A class you can derive from to make it easier to represent every networked object with an integer. This way you can refer to objects over the network
C:/RakNet/Source/PacketConsoleLogger.h | This will write all incoming and outgoing network messages to the log command parser, which can be accessed through Telnet
C:/RakNet/Source/PacketFileLogger.h | This will write all incoming and outgoing network messages to a file
C:/RakNet/Source/PacketLogger.cpp |
C:/RakNet/Source/PacketLogger.h | This will write all incoming and outgoing network messages to the local console screen. See derived functions for other outputs
C:/RakNet/Source/PacketPriority.h | This file contains enumerations for packet priority and reliability enumerations
C:/RakNet/Source/PluginInterface.cpp |
C:/RakNet/Source/PluginInterface.h | RakNet's plugin functionality system. You can derive from this to create your own plugins
C:/RakNet/Source/RakNetCommandParser.h | Contains RakNetCommandParser , used to send commands to an instance of RakPeer
C:/RakNet/Source/RakNetStatistics.cpp |
C:/RakNet/Source/RakNetStatistics.h | A structure that holds all statistical data returned by RakNet
C:/RakNet/Source/RakNetTransport.h | Contains RakNetTransportCommandParser and RakNetTransport used to provide a secure console connection
C:/RakNet/Source/RakNetTypes.cpp |
C:/RakNet/Source/RakNetTypes.h | Types used by RakNet, most of which involve user code
C:/RakNet/Source/RakNetworkFactory.cpp |
C:/RakNet/Source/RakNetworkFactory.h | Factory class for RakNet objects
C:/RakNet/Source/RakPeer.cpp |
C:/RakNet/Source/RakPeer.h | The main class used for data transmission and most of RakNet's functionality
C:/RakNet/Source/RakPeerInterface.h | An interface for RakPeer. Simply contains all user functions as pure virtuals
C:/RakNet/Source/Rand.h | [Internal] Random number generator
C:/RakNet/Source/ReadyEvent.h | Ready event plugin. This enables a set of systems to create a signal event, set this signal as ready or unready, and to trigger the event when all systems are ready
C:/RakNet/Source/RefCountedObj.h | Reference counted object. Very simple class for quick and dirty uses
C:/RakNet/Source/ReliabilityLayer.cpp |
C:/RakNet/Source/ReliabilityLayer.h | [Internal] Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence
C:/RakNet/Source/Replica.h | Contains interface Replica used by the ReplicaManager
C:/RakNet/Source/ReplicaEnums.h | Contains enumerations used by the ReplicaManager system. This file is a lightweight header, so you can include it without worrying about linking in lots of other crap
C:/RakNet/Source/ReplicaManager.h | Contains class ReplicaManager. This system provides management for your game objects and players to make serialization, scoping, and object creation and destruction easier
C:/RakNet/Source/ReplicaManager2.h | Contains the second iteration of the ReplicaManager class. This system automatically creates and destroys objects, downloads the world to new players, manages players, and automatically serializes as needed
C:/RakNet/Source/Rijndael.h | [Internal] AES encoding / decoding rijndael-alg-fst.h v2.0 August '99 Optimised ANSI C code taken from the 'aescrypt' project: www.sf.net/projects/aescrypt See LICENSE-EST for the license applicable to this file
C:/RakNet/Source/Router.h | Router plugin. Allows you to send to systems you are not directly connected to, and to route those messages
C:/RakNet/Source/RPCMap.cpp |
C:/RakNet/Source/RPCMap.h | [Internal] A container class for a list of RPCNodes
C:/RakNet/Source/RPCNode.h | [Internal] Holds information related to a RPC
C:/RakNet/Source/SimpleMutex.cpp |
C:/RakNet/Source/SimpleMutex.h | [Internal] Encapsulates a mutex
C:/RakNet/Source/SingleProducerConsumer.h | [Internal] Passes queued data between threads using a circular buffer with read and write pointers
C:/RakNet/Source/SocketLayer.cpp | SocketLayer class implementation
C:/RakNet/Source/SocketLayer.h | SocketLayer class implementation
C:/RakNet/Source/StringCompressor.cpp |
C:/RakNet/Source/StringCompressor.h | Compresses/Decompresses ASCII strings and writes/reads them to BitStream class instances. You can use this to easily serialize and deserialize your own strings
C:/RakNet/Source/StringTable.h | A simple class to encode and decode known strings based on a lookup table. Similar to the StringCompressor class
C:/RakNet/Source/SystemAddressList.h | Just a class to hold a list of systems
C:/RakNet/Source/TCPInterface.cpp | A simple TCP based server allowing sends and receives. Can be connected to by a telnet client
C:/RakNet/Source/TCPInterface.h | A simple TCP based server allowing sends and receives. Can be connected by any TCP client, including telnet
C:/RakNet/Source/TelnetTransport.h | Contains TelnetTransport , used to supports the telnet transport protocol. Insecure
C:/RakNet/Source/ThreadsafePacketLogger.h | Derivation of the packet logger to defer the call to WriteLog until the user thread
C:/RakNet/Source/TransportInterface.h | Contains TransportInterface from which you can derive custom transport providers for ConsoleServer
C:/RakNet/Source/Types.h | Used for types used by RSA
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/AutopatcherClient.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions

AutopatcherClient.h File Reference

Client plugin for the autopatcher. More...

#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface.h"
#include "PacketPriority.h"
#include "FileList.h"

Detailed Description

Client plugin for the autopatcher.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/AutopatcherServer.cpp File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions

AutopatcherServer.cpp File Reference

The server plugin for the autopatcher. Must be running for the client to get patches. More...

#include "AutopatcherServer.h"
#include "DirectoryDeltaTransfer.h"
#include "FileList.h"
#include "StringCompressor.h"
#include "RakPeerInterface.h"
#include "FileListTransfer.h"
#include "FileListTransferCBInterface.h"
#include "BitStream.h"
#include "MessageIdentifiers.h"
#include "AutopatcherRepositoryInterface.h"
#include "RakAssert.h"

Detailed Description

The server plugin for the autopatcher. Must be running for the client to get patches.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/AutopatcherServer.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions

AutopatcherServer.h File Reference

The server plugin for the autopatcher. Must be running for the client to get patches. More...

#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface.h"
#include "PacketPriority.h"
#include "ThreadPool.h"
#include "BitStream.h"

Detailed Description

The server plugin for the autopatcher. Must be running for the client to get patches.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/RakVoice.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions

RakVoice.h File Reference

Voice compression and transmission interface. More...

#include "RakNetTypes.h"
#include "PluginInterface.h"
#include "DS_OrderedList.h"

Detailed Description

Voice compression and transmission interface.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/AutopatcherMySQLRepository/AutopatcherMySQLRepository.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » AutopatcherMySQLRepository

AutopatcherMySQLRepository.h File Reference

An implementation of the AutopatcherRepositoryInterface to use MySQL to store the relevant data. More...

#include "AutopatcherRepositoryInterface.h"
#include "MySQLInterface.h"
#include "Export.h"

Classes

class AutopatcherMySQLRepository

Detailed Description

An implementation of the AutopatcherRepositoryInterface to use MySQL to store the relevant data.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/AutopatcherPostgreRepository/AutopatcherPostgreRepository.cpp File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » AutopatcherPostgreRepository

AutopatcherPostgreRepository.cpp File Reference

An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data. More...

#include "AutopatcherPostgreRepository.h"
#include "AutopatcherPatchContext.h"
#include "FileList.h"
#include "libpq-fe.h"
#include "CreatePatch.h"
#include <stdlib.h>
#include "LinuxStrings.h"
#include <netinet/in.h>

Detailed Description

An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/AutopatcherPostgreRepository/AutopatcherPostgreRepository.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » AutopatcherPostgreRepository

AutopatcherPostgreRepository.h File Reference

An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data. More...

#include "AutopatcherRepositoryInterface.h"
#include "PostgreSQLInterface.h"
#include "Export.h"

Classes

class AutopatcherPostgreRepository

Detailed Description

An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/LobbyClientInterface.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby

LobbyClientInterface.h File Reference

Interface to the lobby client. Not platform specific. More...

#include "LobbyPCTypes.h"
#include "LobbyTypes.h"
#include "RankingServerDBSpec.h"
#include "LobbyDBSpec.h"
#include "DS_Table.h"
#include "DS_List.h"
#include "RakNetTypes.h"

Namespaces

namespace | RakNet

Classes

class | RakNet::LobbyClientInterface
The client-side interface to the lobby system The Lobby client implements functionality commonly found in game lobbies. It is the counterpart to the LobbyServer class. This interface is system independent, but for PC functionality see LobbyClientPC For full documentation on the PC version, see LobbyClientPC.h. More...
struct | RakNet::LeaveClan_Notification
Someone has left this clan. More...
struct | RakNet::ClanJoinInvitationWithdrawn_Notification
You were invited to a clan, but this invitation has been revoked. More...
struct | RakNet::ClanJoinInvitationRejected_Notification
struct | RakNet::ClanJoinInvitationAccepted_Notification
struct | RakNet::ClanJoinInvitation_Notification
A leader or subleader in a clan has invited you to join that clan. More...
struct | RakNet::ClanMemberJoinRequestWithdrawn_Notification
Someone has petitioned to join your clan, but changed their mind and have withdrawn that petition. More...
struct | RakNet::ClanMemberJoinRequestRejected_Notification
struct | RakNet::ClanMemberJoinRequestAccepted_Notification
struct | RakNet::ClanMemberJoinRequest_Notification
Someone has asked to join your clan. More...

Detailed Description

Interface to the lobby client. Not platform specific.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/LobbyClientPC.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby

LobbyClientPC.h File Reference

Interface to the lobby client for the PC. More...

#include "PluginInterface.h"
#include "LobbyClientInterface.h"
#include "PacketPriority.h"
#include "LobbyPCCommon.h"

Namespaces

namespace | RakNet

Classes

class | RakNet::LobbyClientPC
PC specific client side code to the lobby system Attach class as a plugin to RakNet as usual. Connect to the lobby server (as usual). Then use provided functions for specific functionality. More...

Detailed Description

Interface to the lobby client for the PC.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/LobbyDBSpec.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby

LobbyDBSpec.h File Reference

Not code so much as a specification for the structures and classes that an implementation of the lobby server can use. More...

#include "Export.h"
#include "DS_List.h"
#include "RakString.h"
#include "RefCountedObj.h"

Namespaces

namespace | RakNet
namespace | LobbyDBSpec

Classes

class | LobbyDBSpec::CreateUser_Data
Adds a user to the users table. More...
class | LobbyDBSpec::GetUser_Data
Get a user from the users table, using userId or userHandle for the lookup. More...
class | LobbyDBSpec::UpdateUser_Data
Overwrites an existing user in the users table. More...
class | LobbyDBSpec::AddAccountNote_Data
Adds an entry to the accountNotes table for an existing user. More...
class | LobbyDBSpec::GetAccountNotes_Data
Gets all account notes for an existing user. More...
class | LobbyDBSpec::AddFriend_Data
Adds a userId / friendId to the friends table. More...
class | LobbyDBSpec::RemoveFriend_Data
Removes a userId / friendId from the friends table. More...
class | LobbyDBSpec::GetFriends_Data
Gets the friends table for a userId or userHandle. More...
class | LobbyDBSpec::AddToIgnoreList_Data
Adds to the ignoreList table for a particular userId / userHandle. More...
class | LobbyDBSpec::RemoveFromIgnoreList_Data
Removes from the ignoreList table for a particular userId / userHandle. More...
class | LobbyDBSpec::GetIgnoreList_Data
Gets the ignoreList table for a particular userId / userHandle. More...
class | LobbyDBSpec::SendEmail_Data
Adds an email to the emails table. Added once for the user with inbox=false, n times for n recipients with inbox=true. More...
class | LobbyDBSpec::GetEmails_Data
Gets all emails in the emails table for a particular user. More...
class | LobbyDBSpec::DeleteEmail_Data
Deletes an email from either the incomingEmails or sentEmails table. More...
class | LobbyDBSpec::UpdateEmailStatus_Data
Updates the mark flags on an email. More...

Typedefs

typedef unsigned | LobbyDBSpec::DatabaseKey
Type of the primary keys in the database.

Detailed Description

Not code so much as a specification for the structures and classes that an implementation of the lobby server can use.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/LobbyPCCommon.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby

LobbyPCCommon.h File Reference

Common source between the lobby client and the lobby server for the PC. More...

#include "LobbyClientInterface.h"
#include "LobbyDBSpec.h"
#include "TitleValidationDBSpec.h"
#include "DS_List.h"
#include "DS_Table.h"

Namespaces

namespace RakNet

Detailed Description

Common source between the lobby client and the lobby server for the PC.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/LobbyServer.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby

LobbyServer.h File Reference

Base class that implements the networking for the lobby server. Database specific functionality is implemented in a derived class. More...

#include "LobbyPCTypes.h"
#include "PluginInterface.h"
#include "DS_OrderedList.h"
#include "LobbyDBSpec.h"
#include "RakNetTypes.h"
#include "LobbyTypes.h"
#include "PacketPriority.h"
#include "TitleValidationDBSpec.h"
#include "DS_Table.h"
#include "LobbyPCCommon.h"

Namespaces

namespace | RakNet

Classes

class | RakNet::LobbyServer

Detailed Description

Base class that implements the networking for the lobby server. Database specific functionality is implemented in a derived class.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/RankingServerDBSpec.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby

RankingServerDBSpec.h File Reference

Not code so much as a specification for the structures and classes that an implementation of the ranking server can use. More...

#include "Export.h"
#include "DS_List.h"
#include "RakNetTypes.h"
#include "RakString.h"
#include "RefCountedObj.h"

Namespaces

namespace | RakNet
namespace | RankingServerDBSpec

Classes

struct | RankingServerDBSpec::PairedKeyDbId
class | RankingServerDBSpec::SubmitMatch_Data
class | RankingServerDBSpec::ModifyTrustedIPList_Data
class | RankingServerDBSpec::GetTrustedIPList_Data
class | RankingServerDBSpec::GetRatingForParticipant_Data
Given a particular player and game, get that player's rating from the database. More...
class | RankingServerDBSpec::GetRatingForParticipants_Data
Given a particular game, get ratings for all players. More...
class | RankingServerDBSpec::GetHistoryForParticipant_Data
Given a particular player and game, get a match history. More...

Typedefs

typedef unsigned | RankingServerDBSpec::DatabaseKey
Type of the primary keys in the database.

Detailed Description

Not code so much as a specification for the structures and classes that an implementation of the ranking server can use.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/TitleValidationDBSpec.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby

TitleValidationDBSpec.h File Reference

Not code so much as a specification for the structures and classes that an implementation of a title validation system (CD Keys and game server logins). More...

#include "Export.h"
#include "DS_List.h"
#include "RefCountedObj.h"
#include "RakString.h"

Namespaces

namespace | TitleValidationDBSpec

Classes

class | TitleValidationDBSpec::AddTitle_Data
Adds a title to the database of titles. This can be used to look up titleIds given a title password. More...
class | TitleValidationDBSpec::GetTitles_Data
Download all titles added with AddTitle_Data. More...
class | TitleValidationDBSpec::UpdateUserKey_Data

Typedefs

typedef unsigned | TitleValidationDBSpec::DatabaseKey
Type of the primary keys in the database.

Detailed Description

Not code so much as a specification for the structures and classes that an implementation of a title validation system (CD Keys and game server logins).

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/LobbyDB_PostgreRepository/LobbyDB_PostgreSQL.cpp File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby » LobbyDB_PostgreRepository

LobbyDB_PostgreSQL.cpp File Reference

An implementation of the LobbyServer database to use PostgreSQL to store the relevant data. More...

#include "LobbyDB_PostgreSQL.h"
#include "libpq-fe.h"
#include <RakAssert.h>
#include "FormatString.h"

Detailed Description

An implementation of the LobbyServer database to use PostgreSQL to store the relevant data.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/LobbyDB_PostgreRepository/LobbyDB_PostgreSQL.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby » LobbyDB_PostgreRepository

LobbyDB_PostgreSQL.h File Reference

An implementation of the LobbyServer database to use PostgreSQL to store the relevant data. More...

#include "LobbyDBSpec.h"
#include "PostgreSQLInterface.h"
#include "FunctionThread.h"

Classes

class | LobbyDBCBInterface
If you want to forward Functor::HandleResult() the output to a callback (which is what it does by default), you can use this. More...
class | LobbyDB_PostgreSQL

Detailed Description

An implementation of the LobbyServer database to use PostgreSQL to store the relevant data.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/LobbyServer_PostgreSQL/LobbyServer_PostgreSQL.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby » LobbyServer_PostgreSQL

LobbyServer_PostgreSQL.h File Reference

Base class that implements the networking for the lobby server. Database specific functionality is implemented in a derived class. More...

#include "LobbyServer.h"
#include "FunctionThread.h"
#include "TitleValidationDB_PostgreSQL.h"
#include "RankingServer_PostgreSQL.h"
#include "LobbyDB_PostgreSQL.h"

Namespaces

namespace | RakNet

Classes

class | RakNet::LobbyServerPostgreSQL

Detailed Description

Base class that implements the networking for the lobby server. Database specific functionality is implemented in a derived class.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.cpp File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby » RankingServerDB_PostgreRepository

RankingServer_PostgreSQL.cpp File Reference

An implementation of the RankingRepositoryInterface to use PostgreSQL to store the relevant data. More...

#include "RankingServer_PostgreSQL.h"
#include "libpq-fe.h"
#include <RakAssert.h>
#include "FormatString.h"

Detailed Description

An implementation of the RankingRepositoryInterface to use PostgreSQL to store the relevant data.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/RankingServer_PostgreSQL.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby » RankingServerDB_PostgreRepository

RankingServer_PostgreSQL.h File Reference

An implementation of the RankingServerPostgreRepository to use PostgreSQL to store ranking info for users. More...

#include "RankingServerDBSpec.h"
#include "PostgreSQLInterface.h"
#include "FunctionThread.h"

Classes

class | SubmitMatch_PostgreSQLImpl
class | ModifyTrustedIPList_PostgreSQLImpl
Modify the list of IPs allowed to submit matches. More...
class | GetRatingForParticipant_PostgreSQLImpl
Given a particular player and game, get that player's rating from the database. More...
class | GetRatingForParticipants_PostgreSQLImpl
Given a particular game, get ratings for all players. More...
class | GetHistoryForParticipant_PostgreSQLImpl
Given a particular player and game, get a match history. More...
class | RankingServerCBInterface
If you want to forward Functor::HandleResult() the output to a callback (which is what it does by default), you can use this. More...
class | RankingServer_PostgreSQL

Detailed Description

An implementation of the RankingServerPostgreRepository to use PostgreSQL to store ranking info for users.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/TitleValidationDB_PostgreRepository/TitleValidationDB_PostgreSQL.cpp File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby » TitleValidationDB_PostgreRepository

TitleValidationDB_PostgreSQL.cpp File Reference

An implementation of TitleValidationDBSpec.h to use PostgreSQL. Title validation is useful for checking server logins and cd keys. More...

#include "TitleValidationDB_PostgreSQL.h"
#include "libpq-fe.h"
#include <RakAssert.h>
#include "FormatString.h"

Detailed Description

An implementation of TitleValidationDBSpec.h to use PostgreSQL. Title validation is useful for checking server logins and cd keys.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/TitleValidationDB_PostgreRepository/TitleValidationDB_PostgreSQL.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » Lobby » TitleValidationDB_PostgreRepository

TitleValidationDB_PostgreSQL.h File Reference

An implementation of TitleValidationDBSpec.h to use PostgreSQL. Title validation is useful for checking server logins and cd keys. More...

#include "TitleValidationDBSpec.h"
#include "PostgreSQLInterface.h"
#include "FunctionThread.h"

Classes

class | TitleValidationDBCBInterface
If you want to forward Functor::HandleResult() the output to a callback (which is what it does by default), you can use this. More...
class | TitleValidation_PostgreSQL

Detailed Description

An implementation of TitleValidationDBSpec.h to use PostgreSQL. Title validation is useful for checking server logins and cd keys.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/RPC3/RPC3.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » RPC3

RPC3.h File Reference

Automatically serializing and deserializing RPC system. Third generation of RPC. More...

#include "RPC3_Boost.h"
#include "PluginInterface.h"
#include "DS_Map.h"
#include "PacketPriority.h"
#include "RakNetTypes.h"
#include "BitStream.h"
#include "RakString.h"

Namespaces

namespace | RakNet

Classes

class | RakNet::RPC3

Enumerations

enum RakNet::RPCErrorCodes {
RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST, RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST,
RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED,
RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_CALLING_CPP_AS_C, RakNet::RPC_ERROR_CALLING_CPP_AS_C,
RakNet::RPC_ERROR_CALLING_C_AS_CPP, RakNet::RPC_ERROR_CALLING_C_AS_CPP, RakNet::RPC_ERROR_STACK_TOO_SMALL, RakNet::RPC_ERROR_STACK_DESERIALIZATION_FAILED,
RakNet::RPC_ERROR_INCORRECT_NUMBER_OF_PARAMETERS, RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST,
RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST, RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED,
RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_CALLING_CPP_AS_C,
RakNet::RPC_ERROR_CALLING_CPP_AS_C, RakNet::RPC_ERROR_CALLING_C_AS_CPP, RakNet::RPC_ERROR_CALLING_C_AS_CPP
}

Detailed Description

Automatically serializing and deserializing RPC system. Third generation of RPC.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/pcm_wrapper.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » include » speex

pcm_wrapper.h File Reference

PCM encoding wrapped as a Speex mode. More...

#include "speex.h"

Variables

const SpeexMode * speex_pcm_wrapper

Detailed Description

PCM encoding wrapped as a Speex mode.

Variable Documentation

const SpeexMode* speex_pcm_wrapper

PCM wrapper mode

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » include » speex

speex.h File Reference

Describes the different modes of the codec. More...

#include "speex/speex_bits.h"
#include "speex/speex_types.h"

Classes

struct | SpeexMode

Defines

#define | SPEEX_SET_ENH 0
#define | SPEEX_GET_ENH 1
#define | SPEEX_GET_FRAME_SIZE 3
#define | SPEEX_SET_QUALITY 4
#define | SPEEX_SET_MODE 6
#define | SPEEX_GET_MODE 7
#define | SPEEX_SET_LOW_MODE 8
#define | SPEEX_GET_LOW_MODE 9
#define | SPEEX_SET_HIGH_MODE 10
#define | SPEEX_GET_HIGH_MODE 11
#define | SPEEX_SET_VBR 12
#define | SPEEX_GET_VBR 13
#define | SPEEX_SET_VBR_QUALITY 14
#define | SPEEX_GET_VBR_QUALITY 15
#define | SPEEX_SET_COMPLEXITY 16
#define | SPEEX_GET_COMPLEXITY 17
#define | SPEEX_SET_BITRATE 18
#define | SPEEX_GET_BITRATE 19
#define | SPEEX_SET_HANDLER 20
#define | SPEEX_SET_USER_HANDLER 22
#define | SPEEX_SET_SAMPLING_RATE 24
#define | SPEEX_GET_SAMPLING_RATE 25
#define | SPEEX_RESET_STATE 26
#define | SPEEX_GET_RELATIVE_QUALITY 29
#define | SPEEX_SET_VAD 30
#define | SPEEX_GET_VAD 31
#define | SPEEX_SET_ABR 32
#define | SPEEX_GET_ABR 33
#define | SPEEX_SET_DTX 34
#define | SPEEX_GET_DTX 35
#define | SPEEX_SET_SUBMODE_ENCODING 36
#define | SPEEX_GET_SUBMODE_ENCODING 37
#define | SPEEX_GET_LOOKAHEAD 39
#define | SPEEX_SET_PLC_TUNING 40
#define | SPEEX_GET_PLC_TUNING 41
#define | SPEEX_GET_PI_GAIN 100
#define | SPEEX_GET_EXC 101
#define | SPEEX_GET_INNOV 102
#define | SPEEX_GET_DTX_STATUS 103
#define | SPEEX_SET_PF 0
#define | SPEEX_GET_PF 1
#define | SPEEX_MODE_FRAME_SIZE 0
#define | SPEEX_SUBMODE_BITS_PER_FRAME 1
#define | SPEEX_LIB_GET_MAJOR_VERSION 1
#define | SPEEX_LIB_GET_MINOR_VERSION 3
#define | SPEEX_LIB_GET_MICRO_VERSION 5
#define | SPEEX_LIB_GET_EXTRA_VERSION 7
#define | SPEEX_LIB_GET_VERSION_STRING 9
#define | SPEEX_NB_MODES 3
#define | SPEEX_MODEID_NB 0
#define | SPEEX_MODEID_WB 1
#define | SPEEX_MODEID_UWB 2

Typedefs

typedef void *(*) | encoder_init_func (const struct SpeexMode *mode)
typedef void(*) | encoder_destroy_func (void *st)
typedef int(*) | encode_func (void *state, void *in, SpeexBits *bits)
typedef int(*) | encoder_ctl_func (void *state, int request, void *ptr)
typedef void *(*) | decoder_init_func (const struct SpeexMode *mode)
typedef void(*) | decoder_destroy_func (void *st)
typedef int(*) | decode_func (void *state, SpeexBits *bits, void *out)
typedef int(*) | decoder_ctl_func (void *state, int request, void *ptr)
typedef int(*) | mode_query_func (const void *mode, int request, void *ptr)

Functions

void * | speex_encoder_init (const SpeexMode *mode)
void | speex_encoder_destroy (void *state)
int | speex_encode (void *state, float *in, SpeexBits *bits)
int | speex_encode_int (void *state, spx_int16_t *in, SpeexBits *bits)
int | speex_encoder_ctl (void *state, int request, void *ptr)
void * | speex_decoder_init (const SpeexMode *mode)
void | speex_decoder_destroy (void *state)
int | speex_decode (void *state, SpeexBits *bits, float *out)
int | speex_decode_int (void *state, SpeexBits *bits, spx_int16_t *out)
int | speex_decoder_ctl (void *state, int request, void *ptr)
int | speex_mode_query (const SpeexMode *mode, int request, void *ptr)
int | speex_lib_ctl (int request, void *ptr)
const SpeexMode * | speex_lib_get_mode (int mode)

Variables

const SpeexMode | speex_nb_mode
const SpeexMode | speex_wb_mode
const SpeexMode | speex_uwb_mode
const SpeexMode *const | speex_mode_list [SPEEX_NB_MODES]

Detailed Description

Describes the different modes of the codec.

Define Documentation

#define SPEEX_GET_ABR 33

Get Average Bit-Rate (ABR) setting (in bps)

#define SPEEX_GET_BITRATE 19

Get current bit-rate used by the encoder or decoder

#define SPEEX_GET_COMPLEXITY 17

Get current complexity of the encoder (0-10)

#define SPEEX_GET_DTX 35

Get DTX status (1 for on, 0 for off)

#define SPEEX_GET_DTX_STATUS 103

Used internally

#define SPEEX_GET_ENH 1

Get enhancement state (decoder only)

#define SPEEX_GET_EXC 101

Used internally

#define SPEEX_GET_FRAME_SIZE 3

Obtain frame size used by encoder/decoder

#define SPEEX_GET_HIGH_MODE 11

Get current high-band mode in use (wideband only)

#define SPEEX_GET_INNOV 102

Used internally

#define SPEEX_GET_LOOKAHEAD 39

Returns the lookahead used by Speex

#define SPEEX_GET_LOW_MODE 9

Get current low-band mode in use (wideband only)

#define SPEEX_GET_MODE 7

Get current sub-mode in use

#define SPEEX_GET_PF 1

Equivalent to SPEEX_GET_ENH

#define SPEEX_GET_PI_GAIN 100

Used internally

#define SPEEX_GET_PLC_TUNING 41

Gets tuning for PLC

#define SPEEX_GET_RELATIVE_QUALITY 29

Get VBR info (mostly used internally)

#define SPEEX_GET_SAMPLING_RATE 25

Get sampling rate used in bit-rate computation

#define SPEEX_GET_SUBMODE_ENCODING 37

Get submode encoding in each frame

#define SPEEX_GET_VAD 31

Get VAD status (1 for on, 0 for off)

#define SPEEX_GET_VBR 13

Get VBR status (1 for on, 0 for off)

#define SPEEX_GET_VBR_QUALITY 15

Get current quality value for VBR encoding (0-10)

#define SPEEX_LIB_GET_EXTRA_VERSION 7

Get extra Speex version

#define SPEEX_LIB_GET_MAJOR_VERSION 1

Get major Speex version

#define SPEEX_LIB_GET_MICRO_VERSION 5

Get micro Speex version

#define SPEEX_LIB_GET_MINOR_VERSION 3

Get minor Speex version

#define SPEEX_LIB_GET_VERSION_STRING 9

Get Speex version string

#define SPEEX_MODE_FRAME_SIZE 0

Query the frame size of a mode

#define SPEEX_MODEID_NB 0

modeID for the defined narrowband mode

#define SPEEX_MODEID_UWB 2

modeID for the defined ultra-wideband mode

#define SPEEX_MODEID_WB 1

modeID for the defined wideband mode

#define SPEEX_NB_MODES 3

Number of defined modes in Speex

#define SPEEX_RESET_STATE 26

Reset the encoder/decoder memories to zero

#define SPEEX_SET_ABR 32

Set Average Bit-Rate (ABR) to n bits per seconds

#define SPEEX_SET_BITRATE 18

Set bit-rate used by the encoder (or lower)

#define SPEEX_SET_COMPLEXITY 16

Set complexity of the encoder (0-10)

#define SPEEX_SET_DTX 34

Set DTX status (1 for on, 0 for off)

#define SPEEX_SET_ENH 0

Set enhancement on/off (decoder only)

#define SPEEX_SET_HANDLER 20

Define a handler function for in-band Speex request

#define SPEEX_SET_HIGH_MODE 10

Set high-band sub-mode to use (wideband only)

#define SPEEX_SET_LOW_MODE 8

Set low-band sub-mode to use (wideband only)

#define SPEEX_SET_MODE 6

Set sub-mode to use

#define SPEEX_SET_PF 0

Equivalent to SPEEX_SET_ENH

#define SPEEX_SET_PLC_TUNING 40

Sets tuning for packet-loss concealment (expected loss rate)

#define SPEEX_SET_QUALITY 4

Set quality value

#define SPEEX_SET_SAMPLING_RATE 24

Set sampling rate used in bit-rate computation

#define SPEEX_SET_SUBMODE_ENCODING 36

Set submode encoding in each frame (1 for yes, 0 for no, setting to no breaks the standard)

#define SPEEX_SET_USER_HANDLER 22

Define a handler function for in-band user-defined request

#define SPEEX_SET_VAD 30

Set VAD status (1 for on, 0 for off)

#define SPEEX_SET_VBR 12

Set VBR on (1) or off (0)

#define SPEEX_SET_VBR_QUALITY 14

Set quality value for VBR encoding (0-10)

#define SPEEX_SUBMODE_BITS_PER_FRAME 1

Query the size of an encoded frame for a particular sub-mode

Typedef Documentation

typedef int(*) decode_func(void *state, SpeexBits *bits, void *out)

Main decoding function

typedef int(*) decoder_ctl_func(void *state, int request, void *ptr)

Function for controlling the decoder options

typedef void(*) decoder_destroy_func(void *st)

Decoder state destruction function

typedef void*(*) decoder_init_func(const struct SpeexMode *mode)

Decoder state initialization function

typedef int(*) encode_func(void *state, void *in, SpeexBits *bits)

Main encoding function

typedef int(*) encoder_ctl_func(void *state, int request, void *ptr)

Function for controlling the encoder options

typedef void(*) encoder_destroy_func(void *st)

Encoder state destruction function

typedef void*(*) encoder_init_func(const struct SpeexMode *mode)

Encoder state initialization function

typedef int(*) mode_query_func(const void *mode, int request, void *ptr)

Query function for a mode

Function Documentation

int speex_decode | ( | void * | state,
 |  | SpeexBits * | bits,
 |  | float * | out
 | ) |  |

Uses an existing decoder state to decode one frame of speech from bit-stream bits. The output speech is saved written to out.

Parameters:
state | Decoder state
bits | Bit-stream from which to decode the frame (NULL if the packet was lost)
out | Where to write the decoded frame
Returns:
return status (0 for no error, -1 for end of stream, -2 corrupt stream)

int speex_decode_int | ( | void * | state,
 |  | SpeexBits * | bits,
 |  | spx_int16_t * | out
 | ) |  |

Uses an existing decoder state to decode one frame of speech from bit-stream bits. The output speech is saved written to out.

Parameters:
state | Decoder state
bits | Bit-stream from which to decode the frame (NULL if the packet was lost)
out | Where to write the decoded frame
Returns:
return status (0 for no error, -1 for end of stream, -2 corrupt stream)

int speex_decoder_ctl | ( | void * | state,
 |  | int | request,
 |  | void * | ptr
 | ) |  |

Used like the ioctl function to control the encoder parameters

Parameters:
state | Decoder state
request | ioctl-type request (one of the SPEEX_* macros)
ptr | Data exchanged to-from function
Returns:
0 if no error, -1 if request in unknown

void speex_decoder_destroy ( void * state )

Frees all resources associated to an existing decoder state.

Parameters:
state State to be destroyed

void* speex_decoder_init ( const SpeexMode * mode )

Returns a handle to a newly created decoder state structure. For now, the mode argument can be &nb_mode or &wb_mode . In the future, more modes may be added. Note that for now if you have more than one channels to decode, you need one state per channel.

Parameters:
mode Speex mode (one of speex_nb_mode or speex_wb_mode)
Returns:
A newly created decoder state

int speex_encode | ( | void * | state,
 |  | float * | in,
 |  | SpeexBits * | bits
 | ) |  |

Uses an existing encoder state to encode one frame of speech pointed to by "in". The encoded bit-stream is saved in "bits".

Parameters:
state | Encoder state
in | Frame that will be encoded with a +-2^15 range
bits | Bit-stream where the data will be written
Returns:
0 if frame needs not be transmitted (DTX only), 1 otherwise

int speex_encode_int | ( | void * | state,
 |  | spx_int16_t * | in,
 |  | SpeexBits * | bits
 | ) |  |

Uses an existing encoder state to encode one frame of speech pointed to by "in". The encoded bit-stream is saved in "bits".

Parameters:
state | Encoder state
in | Frame that will be encoded with a +-2^15 range
bits | Bit-stream where the data will be written
Returns:
0 if frame needs not be transmitted (DTX only), 1 otherwise

int speex_encoder_ctl | ( | void * | state,
 |  | int | request,
 |  | void * | ptr
 | ) |  |

Used like the ioctl function to control the encoder parameters

Parameters:
state | Encoder state
request | ioctl-type request (one of the SPEEX_* macros)
ptr | Data exchanged to-from function
Returns:
0 if no error, -1 if request in unknown

void speex_encoder_destroy ( void * state )

Frees all resources associated to an existing Speex encoder state.

Parameters:
state Encoder state to be destroyed

void* speex_encoder_init ( const SpeexMode * mode )

Returns a handle to a newly created Speex encoder state structure. For now, the "mode" argument can be &nb_mode or &wb_mode . In the future, more modes may be added. Note that for now if you have more than one channels to encode, you need one state per channel.

Parameters:
mode The mode to use (either speex_nb_mode or speex_wb.mode)
Returns:
A newly created encoder

int speex_lib_ctl | ( | int | request,
 |  | void * | ptr
 | ) |  |

Functions for controlling the behavior of libspeex

Parameters:
request | ioctl-type request (one of the SPEEX_LIB_* macros)
ptr | Data exchanged to-from function

const SpeexMode* speex_lib_get_mode ( int mode )

Obtain one of the modes available

int speex_mode_query | ( | const SpeexMode * | mode,
 |  | int | request,
 |  | void * | ptr
 | ) |  |

Query function for mode information

Parameters:
mode | Speex mode
request | ioctl-type request (one of the SPEEX_* macros)
ptr | Data exchanged to-from function

Variable Documentation

const SpeexMode* const speex_mode_list[SPEEX_NB_MODES]

List of all modes available

const SpeexMode speex_nb_mode

Default narrowband mode

const SpeexMode speex_uwb_mode

Default "ultra-wideband" mode

const SpeexMode speex_wb_mode

Default wideband mode

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_bits.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » include » speex

speex_bits.h File Reference

Handles bit packing/unpacking. More...

Classes

struct | SpeexBits

Functions

void | speex_bits_init (SpeexBits *bits)
void | speex_bits_init_buffer (SpeexBits *bits, void *buff, int buf_size)
void | speex_bits_destroy (SpeexBits *bits)
void | speex_bits_reset (SpeexBits *bits)
void | speex_bits_rewind (SpeexBits *bits)
void | speex_bits_read_from (SpeexBits *bits, char *bytes, int len)
void | speex_bits_read_whole_bytes (SpeexBits *bits, char *bytes, int len)
int | speex_bits_write (SpeexBits *bits, char *bytes, int max_len)
int | speex_bits_write_whole_bytes (SpeexBits *bits, char *bytes, int max_len)
void | speex_bits_pack (SpeexBits *bits, int data, int nbBits)
int | speex_bits_unpack_signed (SpeexBits *bits, int nbBits)
unsigned int | speex_bits_unpack_unsigned (SpeexBits *bits, int nbBits)
int | speex_bits_nbytes (SpeexBits *bits)
unsigned int | speex_bits_peek_unsigned (SpeexBits *bits, int nbBits)
int | speex_bits_peek (SpeexBits *bits)
void | speex_bits_advance (SpeexBits *bits, int n)
int | speex_bits_remaining (SpeexBits *bits)
void | speex_bits_insert_terminator (SpeexBits *bits)

Detailed Description

Handles bit packing/unpacking.

Function Documentation

void speex_bits_advance | ( | SpeexBits * | bits,
 |  | int | n
 | ) |  |

Advances the position of the "bit cursor" in the stream

Parameters:
bits | Bit-stream to operate on
n | Number of bits to advance

void speex_bits_destroy ( SpeexBits * bits )

Frees all resources associated to a SpeexBits struct. Right now this does nothing since no resources are allocated, but this could change in the future.

void speex_bits_init ( SpeexBits * bits )

Initializes and allocates resources for a SpeexBits struct

void speex_bits_init_buffer | ( | SpeexBits * | bits,
 |  | void * | buff,
 |  | int | buf_size
 | ) |  |

Initializes SpeexBits struct using a pre-allocated buffer

void speex_bits_insert_terminator ( SpeexBits * bits )

Insert a terminator so that the data can be sent as a packet while auto-detecting the number of frames in each packet

Parameters:
bits Bit-stream to operate on

int speex_bits_nbytes ( SpeexBits * bits )

Returns the number of bytes in the bit-stream, including the last one even if it is not "full"

Parameters:
bits Bit-stream to operate on
Returns:
Number of bytes in the stream

void speex_bits_pack | ( | SpeexBits * | bits,
 |  | int | data,
 |  | int | nbBits
 | ) |  |

Append bits to the bit-stream

Parameters:
bits | Bit-stream to operate on
data | Value to append as integer
nbBits | number of bits to consider in "data"

int speex_bits_peek ( SpeexBits * bits )

Get the value of the next bit in the stream, without modifying the "cursor" position

Parameters:
bits Bit-stream to operate on

unsigned int speex_bits_peek_unsigned | ( | SpeexBits * | bits,
 |  | int | nbBits
 | ) |  |

Same as speex_bits_unpack_unsigned, but without modifying the cursor position

void speex_bits_read_from | ( | SpeexBits * | bits,
 |  | char * | bytes,
 |  | int | len
 | ) |  |

Initializes the bit-stream from the data in an area of memory

void speex_bits_read_whole_bytes | ( | SpeexBits * | bits,
 |  | char * | bytes,
 |  | int | len
 | ) |  |

Append bytes to the bit-stream

Parameters:
bits | Bit-stream to operate on
bytes | pointer to the bytes what will be appended
len | Number of bytes of append

int speex_bits_remaining ( SpeexBits * bits )

Returns the number of bits remaining to be read in a stream

Parameters:
bits Bit-stream to operate on

void speex_bits_reset ( SpeexBits * bits )

Resets bits to initial value (just after initialization, erasing content)

void speex_bits_rewind ( SpeexBits * bits )

Rewind the bit-stream to the beginning (ready for read) without erasing the content

int speex_bits_unpack_signed | ( | SpeexBits * | bits,
 |  | int | nbBits
 | ) |  |

Interpret the next bits in the bit-stream as a signed integer

Parameters:
bits | Bit-stream to operate on
nbBits | Number of bits to interpret
Returns:
A signed integer represented by the bits read

unsigned int speex_bits_unpack_unsigned | ( | SpeexBits * | bits,
 |  | int | nbBits
 | ) |  |

Interpret the next bits in the bit-stream as an unsigned integer

Parameters:
bits | Bit-stream to operate on
nbBits | Number of bits to interpret
Returns:
An unsigned integer represented by the bits read

int speex_bits_write | ( | SpeexBits * | bits,
 |  | char * | bytes,
 |  | int | max_len
 | ) |  |

Write the content of a bit-stream to an area of memory

int speex_bits_write_whole_bytes | ( | SpeexBits * | bits,
 |  | char * | bytes,
 |  | int | max_len
 | ) |  |

Like speex_bits_write, but writes only the complete bytes in the stream. Also removes the written bytes from the stream

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_callbacks.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » include » speex

speex_callbacks.h File Reference

Describes callback handling and in-band signalling. More...

#include "speex.h"

Classes

struct | SpeexCallback

Defines

#define | SPEEX_MAX_CALLBACKS 16
#define | SPEEX_INBAND_ENH_REQUEST 0
#define | SPEEX_INBAND_RESERVED1 1
#define | SPEEX_INBAND_MODE_REQUEST 2
#define | SPEEX_INBAND_LOW_MODE_REQUEST 3
#define | SPEEX_INBAND_HIGH_MODE_REQUEST 4
#define | SPEEX_INBAND_VBR_QUALITY_REQUEST 5
#define | SPEEX_INBAND_ACKNOWLEDGE_REQUEST 6
#define | SPEEX_INBAND_VBR_REQUEST 7
#define | SPEEX_INBAND_CHAR 8
#define | SPEEX_INBAND_STEREO 9
#define | SPEEX_INBAND_MAX_BITRATE 10
#define | SPEEX_INBAND_ACKNOWLEDGE 12

Typedefs

typedef int(*) | speex_callback_func (SpeexBits *bits, void *state, void *data)

Functions

int | speex_inband_handler (SpeexBits *bits, SpeexCallback *callback_list, void *state)
int | speex_std_mode_request_handler (SpeexBits *bits, void *state, void *data)
int | speex_std_high_mode_request_handler (SpeexBits *bits, void *state, void *data)
int | speex_std_char_handler (SpeexBits *bits, void *state, void *data)
int | speex_default_user_handler (SpeexBits *bits, void *state, void *data)

Detailed Description

Describes callback handling and in-band signalling.

Define Documentation

#define SPEEX_INBAND_ACKNOWLEDGE 12

Acknowledge packet reception

#define SPEEX_INBAND_ACKNOWLEDGE_REQUEST 6

Request to be sent acknowledge

#define SPEEX_INBAND_CHAR 8

Send a character in-band

#define SPEEX_INBAND_ENH_REQUEST 0

Request for perceptual enhancement (1 for on, 0 for off)

#define SPEEX_INBAND_HIGH_MODE_REQUEST 4

Request for a high mode change

#define SPEEX_INBAND_LOW_MODE_REQUEST 3

Request for a low mode change

#define SPEEX_INBAND_MAX_BITRATE 10

Transmit max bit-rate allowed

#define SPEEX_INBAND_MODE_REQUEST 2

Request for a mode change

#define SPEEX_INBAND_RESERVED1 1

Reserved

#define SPEEX_INBAND_STEREO 9

Intensity stereo information

#define SPEEX_INBAND_VBR_QUALITY_REQUEST 5

Request for VBR (1 on, 0 off)

#define SPEEX_INBAND_VBR_REQUEST 7

Request for VBR (1 for on, 0 for off)

#define SPEEX_MAX_CALLBACKS 16

Total number of callbacks

Typedef Documentation

typedef int(*) speex_callback_func(SpeexBits *bits, void *state, void *data)

Callback function type

Function Documentation

int speex_default_user_handler | ( | SpeexBits * | bits,
 |  | void * | state,
 |  | void * | data
 | ) |  |

Default handler for user-defined requests: in this case, just ignore

int speex_inband_handler | ( | SpeexBits * | bits,
 |  | SpeexCallback * | callback_list,
 |  | void * | state
 | ) |  |

Handle in-band request

int speex_std_char_handler | ( | SpeexBits * | bits,
 |  | void * | state,
 |  | void * | data
 | ) |  |

Standard handler for in-band characters (write to stderr)

int speex_std_high_mode_request_handler | ( | SpeexBits * | bits,
 |  | void * | state,
 |  | void * | data
 | ) |  |

Standard handler for high mode request (change high mode, no questions asked)

int speex_std_mode_request_handler | ( | SpeexBits * | bits,
 |  | void * | state,
 |  | void * | data
 | ) |  |

Standard handler for mode request (change mode, no questions asked)

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_echo.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » include » speex

speex_echo.h File Reference

Echo cancellation. More...

#include "speex/speex_types.h"

Defines

#define | SPEEX_ECHO_GET_FRAME_SIZE 3
#define | SPEEX_ECHO_SET_SAMPLING_RATE 24
#define | SPEEX_ECHO_GET_SAMPLING_RATE 25

Functions

SpeexEchoState * | speex_echo_state_init (int frame_size, int filter_length)
void | speex_echo_state_destroy (SpeexEchoState *st)
void | speex_echo_cancel (SpeexEchoState *st, short *ref, short *echo, short *out, spx_int32_t *Y)
void | speex_echo_state_reset (SpeexEchoState *st)
int | speex_echo_ctl (SpeexEchoState *st, int request, void *ptr)

Detailed Description

Echo cancellation.

Define Documentation

#define SPEEX_ECHO_GET_FRAME_SIZE 3

Obtain frame size used by the AEC

#define SPEEX_ECHO_GET_SAMPLING_RATE 25

Get sampling rate

#define SPEEX_ECHO_SET_SAMPLING_RATE 24

Set sampling rate

Function Documentation

void speex_echo_cancel | ( | SpeexEchoState * | st,
 |  | short * | ref,
 |  | short * | echo,
 |  | short * | out,
 |  | spx_int32_t * | Yout
 | ) |  |

Performs echo cancellation on a frame

int speex_echo_ctl | ( | SpeexEchoState * | st,
 |  | int | request,
 |  | void * | ptr
 | ) |  |

Used like the ioctl function to control the echo canceller parameters

Parameters:
state | Encoder state
request | ioctl-type request (one of the SPEEX_ECHO_* macros)
ptr | Data exchanged to-from function
Returns:
0 if no error, -1 if request in unknown

void speex_echo_state_destroy ( SpeexEchoState * st )

Destroys an echo canceller state

SpeexEchoState* speex_echo_state_init | ( | int | frame_size,
 |  | int | filter_length
 | ) |  |

Creates a new echo canceller state

void speex_echo_state_reset ( SpeexEchoState * st )

Resets echo canceller state

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_header.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » include » speex

speex_header.h File Reference

Describes the Speex header. More...

#include "speex/speex_types.h"

Classes

struct | SpeexHeader

Defines

#define | SPEEX_HEADER_VERSION_LENGTH 20

Functions

void | speex_init_header (SpeexHeader *header, int rate, int nb_channels, const struct SpeexMode *m)
char * | speex_header_to_packet (SpeexHeader *header, int *size)
SpeexHeader * | speex_packet_to_header (char *packet, int size)

Detailed Description

Describes the Speex header.

Define Documentation

#define SPEEX_HEADER_VERSION_LENGTH 20

Maximum number of characters for encoding the Speex version number in the header

Function Documentation

char* speex_header_to_packet | ( | SpeexHeader * | header,
 |  | int * | size
 | ) |  |

Creates the header packet from the header itself (mostly involves endianness conversion)

void speex_init_header | ( | SpeexHeader * | header,
 |  | int | rate,
 |  | int | nb_channels,
 |  | const struct SpeexMode * | m
 | ) |  |

Initializes a SpeexHeader using basic information

SpeexHeader* speex_packet_to_header | ( | char * | packet,
 |  | int | size
 | ) |  |

Creates a SpeexHeader from a packet

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_jitter.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » include » speex

speex_jitter.h File Reference

Adaptive jitter buffer for Speex. More...

#include "speex.h"
#include "speex_bits.h"

Classes

struct | SpeexJitter

Defines

#define | SPEEX_JITTER_MAX_PACKET_SIZE 1500
#define | SPEEX_JITTER_MAX_BUFFER_SIZE 20
#define | MAX_MARGIN 12

Functions

void | speex_jitter_init (SpeexJitter *jitter, void *decoder, int sampling_rate)
void | speex_jitter_destroy (SpeexJitter *jitter)
void | speex_jitter_put (SpeexJitter *jitter, char *packet, int len, int timestamp)
void | speex_jitter_get (SpeexJitter *jitter, short *out, int *current_timestamp)
int | speex_jitter_get_pointer_timestamp (SpeexJitter *jitter)

Detailed Description

Adaptive jitter buffer for Speex.

Define Documentation

#define MAX_MARGIN 12

Number of bins in margin histogram

#define SPEEX_JITTER_MAX_BUFFER_SIZE 20

Maximum number of packets in jitter buffer

#define SPEEX_JITTER_MAX_PACKET_SIZE 1500

Maximum number of bytes per packet

Function Documentation

void speex_jitter_destroy ( SpeexJitter * jitter )

Destroy jitter buffer

void speex_jitter_get | ( | SpeexJitter * | jitter,
 |  | short * | out,
 |  | int * | current_timestamp
 | ) |  |

Get one packet from the jitter buffer

int speex_jitter_get_pointer_timestamp ( SpeexJitter * jitter )

Get pointer timestamp of jitter buffer

void speex_jitter_init | ( | SpeexJitter * | jitter,
 |  | void * | decoder,
 |  | int | sampling_rate
 | ) |  |

Initialise jitter buffer

void speex_jitter_put | ( | SpeexJitter * | jitter,
 |  | char * | packet,
 |  | int | len,
 |  | int | timestamp
 | ) |  |

Put one packet into the jitter buffer

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_preprocess.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » include » speex

speex_preprocess.h File Reference

Speex preprocessor. More...

#include "speex/speex_types.h"

Classes

struct | SpeexPreprocessState

Defines

#define | SPEEX_PREPROCESS_SET_DENOISE 0
#define | SPEEX_PREPROCESS_GET_DENOISE 1
#define | SPEEX_PREPROCESS_SET_AGC 2
#define | SPEEX_PREPROCESS_GET_AGC 3
#define | SPEEX_PREPROCESS_SET_VAD 4
#define | SPEEX_PREPROCESS_GET_VAD 5
#define | SPEEX_PREPROCESS_SET_AGC_LEVEL 6
#define | SPEEX_PREPROCESS_GET_AGC_LEVEL 7
#define | SPEEX_PREPROCESS_SET_DEREVERB 8
#define | SPEEX_PREPROCESS_GET_DEREVERB 9
#define | SPEEX_PREPROCESS_SET_DEREVERB_LEVEL 10
#define | SPEEX_PREPROCESS_GET_DEREVERB_LEVEL 11
#define | SPEEX_PREPROCESS_SET_DEREVERB_DECAY 12
#define | SPEEX_PREPROCESS_GET_DEREVERB_DECAY 13

Functions

SpeexPreprocessState * | speex_preprocess_state_init (int frame_size, int sampling_rate)
void | speex_preprocess_state_destroy (SpeexPreprocessState *st)
int | speex_preprocess (SpeexPreprocessState *st, spx_int16_t *x, spx_int32_t *echo)
void | speex_preprocess_estimate_update (SpeexPreprocessState *st, spx_int16_t *x, spx_int32_t *echo)
int | speex_preprocess_ctl (SpeexPreprocessState *st, int request, void *ptr)

Detailed Description

Speex preprocessor.

Define Documentation

#define SPEEX_PREPROCESS_GET_AGC 3

Get preprocessor Automatic Gain Control state

#define SPEEX_PREPROCESS_GET_AGC_LEVEL 7

Get preprocessor Automatic Gain Control level

#define SPEEX_PREPROCESS_GET_DENOISE 1

Get preprocessor denoiser state

#define SPEEX_PREPROCESS_GET_DEREVERB 9

Get preprocessor dereverb state

#define SPEEX_PREPROCESS_GET_DEREVERB_DECAY 13

Get preprocessor dereverb decay

#define SPEEX_PREPROCESS_GET_DEREVERB_LEVEL 11

Get preprocessor dereverb level

#define SPEEX_PREPROCESS_GET_VAD 5

Get preprocessor Voice Activity Detection state

#define SPEEX_PREPROCESS_SET_AGC 2

Set preprocessor Automatic Gain Control state

#define SPEEX_PREPROCESS_SET_AGC_LEVEL 6

Set preprocessor Automatic Gain Control level

#define SPEEX_PREPROCESS_SET_DENOISE 0

Set preprocessor denoiser state

#define SPEEX_PREPROCESS_SET_DEREVERB 8

Set preprocessor dereverb state

#define SPEEX_PREPROCESS_SET_DEREVERB_DECAY 12

Set preprocessor dereverb decay

#define SPEEX_PREPROCESS_SET_DEREVERB_LEVEL 10

Set preprocessor dereverb level

#define SPEEX_PREPROCESS_SET_VAD 4

Set preprocessor Voice Activity Detection state

Function Documentation

int speex_preprocess | ( | SpeexPreprocessState * | st,
 |  | spx_int16_t * | x,
 |  | spx_int32_t * | echo
 | ) |  |

Preprocess a frame

int speex_preprocess_ctl | ( | SpeexPreprocessState * | st,
 |  | int | request,
 |  | void * | ptr
 | ) |  |

Used like the ioctl function to control the preprocessor parameters

void speex_preprocess_estimate_update | ( | SpeexPreprocessState * | st,
 |  | spx_int16_t * | x,
 |  | spx_int32_t * | echo
 | ) |  |

Preprocess a frame

void speex_preprocess_state_destroy ( SpeexPreprocessState * st )

Destroys a denoising state

SpeexPreprocessState* speex_preprocess_state_init | ( | int | frame_size,
 |  | int | sampling_rate
 | ) |  |

Creates a new preprocessing state

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_stereo.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » include » speex

speex_stereo.h File Reference

Describes the handling for intensity stereo. More...

#include "speex/speex_types.h"
#include "speex/speex_bits.h"

Classes

struct | SpeexStereoState

Defines

#define | SPEEX_STEREO_STATE_INIT {1,.5,1,1}

Functions

void | speex_encode_stereo (float *data, int frame_size, SpeexBits *bits)
void | speex_encode_stereo_int (spx_int16_t *data, int frame_size, SpeexBits *bits)
void | speex_decode_stereo (float *data, int frame_size, SpeexStereoState *stereo)
void | speex_decode_stereo_int (spx_int16_t *data, int frame_size, SpeexStereoState *stereo)
int | speex_std_stereo_request_handler (SpeexBits *bits, void *state, void *data)

Detailed Description

Describes the handling for intensity stereo.

Define Documentation

#define SPEEX_STEREO_STATE_INIT {1,.5,1,1}

Initialization value for a stereo state

Function Documentation

void speex_decode_stereo | ( | float * | data,
 |  | int | frame_size,
 |  | SpeexStereoState * | stereo
 | ) |  |

Transforms a mono frame into a stereo frame using intensity stereo info

void speex_decode_stereo_int | ( | spx_int16_t * | data,
 |  | int | frame_size,
 |  | SpeexStereoState * | stereo
 | ) |  |

Transforms a mono frame into a stereo frame using intensity stereo info

void speex_encode_stereo | ( | float * | data,
 |  | int | frame_size,
 |  | SpeexBits * | bits
 | ) |  |

Transforms a stereo frame into a mono frame and stores intensity stereo info in 'bits'

void speex_encode_stereo_int | ( | spx_int16_t * | data,
 |  | int | frame_size,
 |  | SpeexBits * | bits
 | ) |  |

Transforms a stereo frame into a mono frame and stores intensity stereo info in 'bits'

int speex_std_stereo_request_handler | ( | SpeexBits * | bits,
 |  | void * | state,
 |  | void * | data
 | ) |  |

Callback handler for intensity stereo info

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/speex_types.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » include » speex

speex_types.h File Reference

Speex types. More...

Detailed Description

Speex types.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/arch.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

arch.h File Reference

Various architecture definitions Speex. More...

#include "speex/speex_types.h"

Defines

#define | ABS(x) ((x) < 0 ? (-(x)) : (x))
#define | ABS16(x) ((x) < 0 ? (-(x)) : (x))
#define | MAX16(a, b) ((a) > (b) ? (a) : (b))
#define | ABS32(x) ((x) < 0 ? (-(x)) : (x))

Detailed Description

Various architecture definitions Speex.

Define Documentation

#define ABS ( x ) ((x) < 0 ? (-(x)) : (x))

Absolute integer value.

#define ABS16 ( x ) ((x) < 0 ? (-(x)) : (x))

Absolute 16-bit value.

#define ABS32 ( x ) ((x) < 0 ? (-(x)) : (x))

Absolute 32-bit value.

#define MAX16 | ( | a,
 |  | b | ) | ((a) > (b) ? (a) : (b))

Maximum 16-bit value.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/cb_search.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

cb_search.h File Reference

Overlapped codebook search. More...

#include <speex/speex_bits.h>
#include "misc.h"

Classes

struct split_cb_params

Detailed Description

Overlapped codebook search.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/cb_search_arm4.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

cb_search_arm4.h File Reference

Fixed codebook functions (ARM4 version). More...

Detailed Description

Fixed codebook functions (ARM4 version).

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/cb_search_bfin.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

cb_search_bfin.h File Reference

Fixed codebook functions (Blackfin version). More...

Detailed Description

Fixed codebook functions (Blackfin version).

Author:
Jean-Marc Valin
Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/cb_search_sse.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

cb_search_sse.h File Reference

Fixed codebook functions (SSE version). More...

#include <xmmintrin.h>

Detailed Description

Fixed codebook functions (SSE version).

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/filters.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

filters.h File Reference

Various analysis/synthesis filters. More...

#include "misc.h"

Classes

struct CombFilterMem

Detailed Description

Various analysis/synthesis filters.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/filters_arm4.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

filters_arm4.h File Reference

Various analysis/synthesis filters (ARM4 version). More...

Detailed Description

Various analysis/synthesis filters (ARM4 version).

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/filters_bfin.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

filters_bfin.h File Reference

Various analysis/synthesis filters (Blackfin version). More...

#include <stdio.h>

Detailed Description

Various analysis/synthesis filters (Blackfin version).

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/filters_sse.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

filters_sse.h File Reference

Various analysis/synthesis filters (SSE version). More...

#include <xmmintrin.h>

Detailed Description

Various analysis/synthesis filters (SSE version).

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/fixed_arm4.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

fixed_arm4.h File Reference

ARM4 fixed-point operations. More...

Detailed Description

ARM4 fixed-point operations.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/fixed_arm5e.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

fixed_arm5e.h File Reference

ARM-tuned fixed-point operations. More...

Detailed Description

ARM-tuned fixed-point operations.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/fixed_bfin.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

fixed_bfin.h File Reference

Blackfin fixed-point operations. More...

Detailed Description

Blackfin fixed-point operations.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/fixed_debug.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

fixed_debug.h File Reference

Fixed-point operations with debugging. More...

#include <stdio.h>

Detailed Description

Fixed-point operations with debugging.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/fixed_generic.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

fixed_generic.h File Reference

Generic fixed-point operations. More...

Detailed Description

Generic fixed-point operations.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/lpc.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

lpc.h File Reference

Functions for LPC (Linear Prediction Coefficients) analysis. More...

#include "misc.h"

Detailed Description

Functions for LPC (Linear Prediction Coefficients) analysis.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/lpc_bfin.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

lpc_bfin.h File Reference

Functions for LPC (Linear Prediction Coefficients) analysis (Blackfin version). More...

Detailed Description

Functions for LPC (Linear Prediction Coefficients) analysis (Blackfin version).

Author:
Jean-Marc Valin
Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/lsp.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

lsp.h File Reference

Line Spectral Pair (LSP) functions. More...

#include "misc.h"

Detailed Description

Line Spectral Pair (LSP) functions.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/ltp.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

ltp.h File Reference

Long-Term Prediction functions. More...

#include <speex/speex_bits.h>
#include "misc.h"

Classes

struct | ltp_params

Functions

int | pitch_search_3tap (spx_sig_t target[], spx_sig_t *sw, spx_coef_t ak[], spx_coef_t awk1[], spx_coef_t awk2[], spx_sig_t exc[], const void *par, int start, int end, spx_word16_t pitch_coef, int p, int nsf, SpeexBits *bits, char *stack, spx_sig_t *exc2, spx_word16_t *r, int complexity, int cdbk_offset, int plc_tuning)
int | forced_pitch_quant (spx_sig_t target[], spx_sig_t *sw, spx_coef_t ak[], spx_coef_t awk1[], spx_coef_t awk2[], spx_sig_t exc[], const void *par, int start, int end, spx_word16_t pitch_coef, int p, int nsf, SpeexBits *bits, char *stack, spx_sig_t *exc2, spx_word16_t *r, int complexity, int cdbk_offset, int plc_tuning)
void | forced_pitch_unquant (spx_sig_t exc[], int start, int end, spx_word16_t pitch_coef, const void *par, int nsf, int *pitch_val, spx_word16_t *gain_val, SpeexBits *bits, char *stack, int lost, int subframe_offset, spx_word16_t last_pitch_gain, int cdbk_offset)

Detailed Description

Long-Term Prediction functions.

Function Documentation

int forced_pitch_quant | ( | spx_sig_t | target[],
 |  | spx_sig_t * | sw,
 |  | spx_coef_t | ak[],
 |  | spx_coef_t | awk1[],
 |  | spx_coef_t | awk2[],
 |  | spx_sig_t | exc[],
 |  | const void * | par,
 |  | int | start,
 |  | int | end,
 |  | spx_word16_t | pitch_coef,
 |  | int | p,
 |  | int | nsf,
 |  | SpeexBits * | bits,
 |  | char * | stack,
 |  | spx_sig_t * | exc2,
 |  | spx_word16_t * | r,
 |  | int | complexity,
 |  | int | cdbk_offset,
 |  | int | plc_tuning
 | ) |  |

Forced pitch delay and gain

void forced_pitch_unquant | ( | spx_sig_t | exc[],
 |  | int | start,
 |  | int | end,
 |  | spx_word16_t | pitch_coef,
 |  | const void * | par,
 |  | int | nsf,
 |  | int * | pitch_val,
 |  | spx_word16_t * | gain_val,
 |  | SpeexBits * | bits,
 |  | char * | stack,
 |  | int | count_lost,
 |  | int | subframe_offset,
 |  | spx_word16_t | last_pitch_gain,
 |  | int | cdbk_offset
 | ) |  |

Unquantize forced pitch delay and gain

int pitch_search_3tap | ( | spx_sig_t | target[],
 |  | spx_sig_t * | sw,
 |  | spx_coef_t | ak[],
 |  | spx_coef_t | awk1[],
 |  | spx_coef_t | awk2[],
 |  | spx_sig_t | exc[],
 |  | const void * | par,
 |  | int | start,
 |  | int | end,
 |  | spx_word16_t | pitch_coef,
 |  | int | p,
 |  | int | nsf,
 |  | SpeexBits * | bits,
 |  | char * | stack,
 |  | spx_sig_t * | exc2,
 |  | spx_word16_t * | r,
 |  | int | complexity,
 |  | int | cdbk_offset,
 |  | int | plc_tuning
 | ) |  |

Finds the best quantized 3-tap pitch predictor by analysis by synthesis

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/ltp_arm4.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

ltp_arm4.h File Reference

Long-Term Prediction functions (ARM4 version). More...

Detailed Description

Long-Term Prediction functions (ARM4 version).

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/ltp_bfin.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

ltp_bfin.h File Reference

Long-Term Prediction functions (Blackfin version). More...

Detailed Description

Long-Term Prediction functions (Blackfin version).

Author:
Jean-Marc Valin
Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/ltp_sse.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

ltp_sse.h File Reference

Long-Term Prediction functions (SSE version). More...

#include <xmmintrin.h>

Detailed Description

Long-Term Prediction functions (SSE version).

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/math_approx.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

math_approx.h File Reference

Various math approximation functions for Speex. More...

#include "misc.h"

Detailed Description

Various math approximation functions for Speex.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/misc.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

misc.h File Reference

Various compatibility routines for Speex. More...

#include "arch.h"

Defines

#define | SPEEX_MAJOR_VERSION 1
#define | SPEEX_MINOR_VERSION 1
#define | SPEEX_MICRO_VERSION 12
#define | SPEEX_EXTRA_VERSION ""
#define | SPEEX_VERSION "speex-1.1.12"

Functions

void | print_vec (float *vec, int len, char *name)
spx_uint32_t | be_int (spx_uint32_t i)
spx_uint32_t | le_int (spx_uint32_t i)
void * | speex_alloc (int size)
void * | speex_alloc_scratch (int size)
void * | speex_realloc (void *ptr, int size)
void | speex_free (void *ptr)
void | speex_free_scratch (void *ptr)
void * | speex_move (void *dest, void *src, int n)
void | speex_memcpy_bytes (char *dst, char *src, int nbytes)
void | speex_memset_bytes (char *dst, char src, int nbytes)
void | speex_error (const char *str)
void | speex_warning (const char *str)
void | speex_warning_int (const char *str, int val)
void | speex_rand_vec (float std, spx_sig_t *data, int len)
spx_word32_t | speex_rand (spx_word16_t std, spx_int32_t *seed)
void | _speex_putc (int ch, void *file)

Detailed Description

Various compatibility routines for Speex.

Define Documentation

#define SPEEX_EXTRA_VERSION ""

Extra Speex version.

#define SPEEX_MAJOR_VERSION 1

Major Speex version.

#define SPEEX_MICRO_VERSION 12

Micro Speex version.

#define SPEEX_MINOR_VERSION 1

Minor Speex version.

#define SPEEX_VERSION "speex-1.1.12"

Speex version string.

Function Documentation

void _speex_putc | ( | int | ch,
 |  | void * | file
 | ) |  |

Speex wrapper for putc

spx_uint32_t be_int ( spx_uint32_t i )

Convert big endian

spx_uint32_t le_int ( spx_uint32_t i )

Convert little endian

void print_vec | ( | float * | vec,
 |  | int | len,
 |  | char * | name
 | ) |  |

Print a named vector to stdout

void* speex_alloc ( int size )

Speex wrapper for calloc. To do your own dynamic allocation, all you need to do is replace this function, speex_realloc and speex_free

void* speex_alloc_scratch ( int size )

Same as speex_alloc, except that the area is only needed inside a Speex call (might cause problem with wideband though)

void speex_error ( const char * str )

Print error message to stderr

void speex_free ( void * ptr )

Speex wrapper for calloc. To do your own dynamic allocation, all you need to do is replace this function, speex_realloc and speex_alloc

void speex_free_scratch ( void * ptr )

Same as speex_alloc, except that the area is only needed inside a Speex call (might cause problem with wideband though)

void speex_memcpy_bytes | ( | char * | dst,
 |  | char * | src,
 |  | int | nbytes
 | ) |  |

Speex wrapper for memcpy

void speex_memset_bytes | ( | char * | dst,
 |  | char | src,
 |  | int | nbytes
 | ) |  |

Speex wrapper for memset

void* speex_move | ( | void * | dest,
 |  | void * | src,
 |  | int | n
 | ) |  |

Speex wrapper for mem_move

spx_word32_t speex_rand | ( | spx_word16_t | std,
 |  | spx_int32_t * | seed
 | ) |  |

Generate a random number

void speex_rand_vec | ( | float | std,
 |  | spx_sig_t * | data,
 |  | int | len
 | ) |  |

Generate a vector of random numbers

void* speex_realloc | ( | void * | ptr,
 |  | int | size
 | ) |  |

Speex wrapper for realloc. To do your own dynamic allocation, all you need to do is replace this function, speex_alloc and speex_free

void speex_warning ( const char * str )

Print warning message to stderr

void speex_warning_int | ( | const char * | str,
 |  | int | val
 | ) |  |

Print warning message with integer argument to stderr

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/misc_bfin.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

misc_bfin.h File Reference

Various compatibility routines for Speex (Blackfin version). More...

Functions

void * speex_move (void *dest, void *src, int n)

Detailed Description

Various compatibility routines for Speex (Blackfin version).

Author:
Jean-Marc Valin

Function Documentation

void* speex_move | ( | void * | dest,
 |  | void * | src,
 |  | int | n
 | ) |  |

Speex wrapper for mem_move

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/modes.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

modes.h File Reference

Describes the different modes of the codec. More...

#include <speex/speex.h>
#include <speex/speex_bits.h>
#include "misc.h"

Classes

struct | SpeexSubmode
struct | SpeexNBMode
struct | SpeexSBMode

Typedefs

typedef void(*) | lsp_quant_func (spx_lsp_t *, spx_lsp_t *, int, SpeexBits *)
typedef void(*) | lsp_unquant_func (spx_lsp_t *, int, SpeexBits *)
typedef int(*) | ltp_quant_func (spx_sig_t *, spx_sig_t *, spx_coef_t *, spx_coef_t *, spx_coef_t *, spx_sig_t *, const void *, int, int, spx_word16_t, int, int, SpeexBits *, char *, spx_sig_t *, spx_word16_t *, int, int, int)
typedef void(*) | ltp_unquant_func (spx_sig_t *, int, int, spx_word16_t, const void *, int, int *, spx_word16_t *, SpeexBits *, char *, int, int, spx_word16_t, int)
typedef void(*) | innovation_quant_func (spx_sig_t *, spx_coef_t *, spx_coef_t *, spx_coef_t *, const void *, int, int, spx_sig_t *, spx_word16_t *, SpeexBits *, char *, int, int)
typedef void(*) | innovation_unquant_func (spx_sig_t *, const void *, int, SpeexBits *, char *)

Detailed Description

Describes the different modes of the codec.

Typedef Documentation

typedef void(*) innovation_quant_func(spx_sig_t *, spx_coef_t *, spx_coef_t *, spx_coef_t *, const void *, int, int, spx_sig_t *, spx_word16_t *, SpeexBits *, char *, int, int)

Innovation quantization function

typedef void(*) innovation_unquant_func(spx_sig_t *, const void *, int, SpeexBits *, char *)

Innovation unquantization function

typedef void(*) lsp_quant_func(spx_lsp_t *, spx_lsp_t *, int, SpeexBits *)

Quantizes LSPs

typedef void(*) lsp_unquant_func(spx_lsp_t *, int, SpeexBits *)

Decodes quantized LSPs

typedef int(*) ltp_quant_func(spx_sig_t *, spx_sig_t *, spx_coef_t *, spx_coef_t *, spx_coef_t *, spx_sig_t *, const void *, int, int, spx_word16_t, int, int, SpeexBits *, char *, spx_sig_t *, spx_word16_t *, int, int, int)

Long-term predictor quantization

typedef void(*) ltp_unquant_func(spx_sig_t *, int, int, spx_word16_t, const void *, int, int *, spx_word16_t *, SpeexBits *, char *, int, int, spx_word16_t, int)

Long-term un-quantize

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/nb_celp.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

nb_celp.h File Reference

Narrowband CELP encoder/decoder. More...

#include "modes.h"
#include <speex/speex_bits.h>
#include <speex/speex_callbacks.h>
#include "vbr.h"
#include "filters.h"

Classes

struct | EncState
struct | DecState

Functions

void * | nb_encoder_init (const SpeexMode *m)
void | nb_encoder_destroy (void *state)
int | nb_encode (void *state, void *in, SpeexBits *bits)
void * | nb_decoder_init (const SpeexMode *m)
void | nb_decoder_destroy (void *state)
int | nb_decode (void *state, SpeexBits *bits, void *out)
int | nb_encoder_ctl (void *state, int request, void *ptr)
int | nb_decoder_ctl (void *state, int request, void *ptr)

Detailed Description

Narrowband CELP encoder/decoder.

Function Documentation

int nb_decode | ( | void * | state,
 |  | SpeexBits * | bits,
 |  | void * | out
 | ) |  |

Decodes one frame

int nb_decoder_ctl | ( | void * | state,
 |  | int | request,
 |  | void * | ptr
 | ) |  |

ioctl-like function for controlling a narrowband decoder

void nb_decoder_destroy ( void * state )

De-allocates decoder state resources

void* nb_decoder_init ( const SpeexMode * m )

Initializes decoder state

int nb_encode | ( | void * | state,
 |  | void * | in,
 |  | SpeexBits * | bits
 | ) |  |

Encodes one frame

int nb_encoder_ctl | ( | void * | state,
 |  | int | request,
 |  | void * | ptr
 | ) |  |

ioctl-like function for controlling a narrowband encoder

void nb_encoder_destroy ( void * state )

De-allocates encoder state resources

void* nb_encoder_init ( const SpeexMode * m )

Initializes encoder state

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/pcm_wrapper.c File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

pcm_wrapper.c File Reference

PCM encoding wrapped as a Speex mode. More...

#include "speex/pcm_wrapper.h"
#include "misc.h"

Variables

const SpeexMode * speex_pcm_wrapper = &pcm_wrapper_mode

Detailed Description

PCM encoding wrapped as a Speex mode.

Variable Documentation

const SpeexMode* speex_pcm_wrapper = &pcm_wrapper_mode

PCM wrapper mode

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/pseudofloat.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

pseudofloat.h File Reference

Pseudo-floating point. More...

#include "misc.h"
#include <math.h>

Detailed Description

Pseudo-floating point.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/quant_lsp.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

quant_lsp.h File Reference

LSP vector quantization. More...

#include <speex/speex_bits.h>
#include "misc.h"

Detailed Description

LSP vector quantization.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/sb_celp.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

sb_celp.h File Reference

Sub-band CELP mode used for wideband encoding. More...

#include "modes.h"
#include <speex/speex_bits.h>
#include "nb_celp.h"

Classes

struct | SBEncState
struct | SBDecState

Functions

void * | sb_encoder_init (const SpeexMode *m)
void | sb_encoder_destroy (void *state)
int | sb_encode (void *state, void *in, SpeexBits *bits)
void * | sb_decoder_init (const SpeexMode *m)
void | sb_decoder_destroy (void *state)
int | sb_decode (void *state, SpeexBits *bits, void *out)

Detailed Description

Sub-band CELP mode used for wideband encoding.

Function Documentation

int sb_decode | ( | void * | state,
 |  | SpeexBits * | bits,
 |  | void * | out
 | ) |  |

Decodes one frame

void sb_decoder_destroy ( void * state )

De-allocates decoder state resources

void* sb_decoder_init ( const SpeexMode * m )

Initializes decoder state

int sb_encode | ( | void * | state,
 |  | void * | in,
 |  | SpeexBits * | bits
 | ) |  |

Encodes one frame

void sb_encoder_destroy ( void * state )

De-allocates encoder state resources

void* sb_encoder_init ( const SpeexMode * m )

Initializes encoder state

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/smallft.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

smallft.h File Reference

Discrete Rotational Fourier Transform (DRFT). More...

Classes

struct drft_lookup

Detailed Description

Discrete Rotational Fourier Transform (DRFT).

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/stack_alloc.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

stack_alloc.h File Reference

Temporary memory allocation on stack. More...

Defines

#define | ALIGN(stack, size) ((stack) += ((size) - (long)(stack)) & ((size) - 1))
#define | PUSH(stack, size, type) (ALIGN((stack),sizeof(type)),(stack)+=((size)*sizeof(type)),(type*)((stack)-((size)*sizeof(type))))
#define | PUSHS(stack, type) (ALIGN((stack),sizeof(long)),(stack)+=(sizeof(type)),(type*)((stack)-(sizeof(type))))
#define | VARDECL(var) var
#define | ALLOC(var, size, type) var = PUSH(stack, size, type)

Detailed Description

Temporary memory allocation on stack.

Define Documentation

#define ALIGN | ( | stack,
 |  | size | ) | ((stack) += ((size) - (long)(stack)) & ((size) - 1))

Aligns the stack to a 'size' boundary

Parameters:
stack | Stack
size | New size boundary

#define ALLOC | ( | var,
 |  | size,
 |  | type | ) | var = PUSH(stack, size, type)

Allocate 'size' elements of 'type' on stack

Parameters:
var | Name of variable to allocate
size | Number of elements
type | Type of element

#define PUSH | ( | stack,
 |  | size,
 |  | type | ) | (ALIGN((stack),sizeof(type)),(stack)+=((size)*sizeof(type)),(type*)((stack)-((size)*sizeof(type))))

Allocates 'size' elements of type 'type' on the stack

Parameters:
stack | Stack
size | Number of elements
type | Type of element

#define PUSHS | ( | stack,
 |  | type | ) | (ALIGN((stack),sizeof(long)),(stack)+=(sizeof(type)),(type*)((stack)-(sizeof(type))))

Allocates a struct stack

Parameters:
stack | Stack
type | Struct type

#define VARDECL ( var ) var

Declare variable on stack

Parameters:
var Variable to declare

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/vbr.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

vbr.h File Reference

Variable Bit-Rate (VBR) related routines. More...

#include "misc.h"

Classes

struct VBRState

Detailed Description

Variable Bit-Rate (VBR) related routines.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/vq.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

vq.h File Reference

Vector quantization. More...

#include "misc.h"

Detailed Description

Vector quantization.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/vq_arm4.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

vq_arm4.h File Reference

ARM4-optimized vq routine. More...

Detailed Description

ARM4-optimized vq routine.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/vq_bfin.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

vq_bfin.h File Reference

Blackfin-optimized vq routine. More...

Detailed Description

Blackfin-optimized vq routine.

Author:
Jean-Marc Valin
Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/vq_sse.h File Reference

  • File List
  • File Members
C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

vq_sse.h File Reference

SSE-optimized vq routine. More...

Detailed Description

SSE-optimized vq routine.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/AsynchronousFileIO.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

AsynchronousFileIO.cpp File Reference

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/AsynchronousFileIO.h File Reference

  • File List
  • File Members
C: » RakNet » Source

AsynchronousFileIO.h File Reference

[Internal] Depreciated, used for windows back when I supported IO completion ports. More...

Detailed Description

[Internal] Depreciated, used for windows back when I supported IO completion ports.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/AutopatcherRepositoryInterface.h File Reference

  • File List
  • File Members
C: » RakNet » Source

AutopatcherRepositoryInterface.h File Reference

An interface used by AutopatcherServer to get the data necessary to run an autopatcher. More...

Namespaces

namespace | RakNet

Classes

class | AutopatcherRepositoryInterface
An interface used by AutopatcherServer to get the data necessary to run an autopatcher. This is up to you to implement for custom repository solutions. More...

Detailed Description

An interface used by AutopatcherServer to get the data necessary to run an autopatcher.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/AutoRPC.h File Reference

  • File List
  • File Members
C: » RakNet » Source

AutoRPC.h File Reference

Automatically serializing and deserializing RPC system. More advanced RPC, but possibly not cross-platform. More...

#include "PluginInterface.h"
#include "DS_Map.h"
#include "PacketPriority.h"
#include "RakNetTypes.h"
#include "BitStream.h"
#include "Gen_RPC8.h"
#include "RakString.h"
#include "NetworkIDObject.h"

Namespaces

namespace | RakNet

Classes

class | RakNet::AutoRPC

Defines

#define | ARPC_MAX_STACK_SIZE 65536
Maximum amount of data that can be passed on the stack in a function call.
#define | ARPC_REGISTER_CPP_FUNCTION(autoRPCInstance, _IDENTIFIER_, _RETURN_, _CLASS_, _FUNCTION_, _PARAMS_) (autoRPCInstance)->RegisterFunction( (_IDENTIFIER_), GenRPC::PMFWrapper<_CLASS_, _RETURN_(AUTO_RPC_CALLSPEC _CLASS_::*) _PARAMS_ >( &_CLASS_::_FUNCTION_), true, -1 )
#define | ARPC_REGISTER_CPP_FUNCTIONX(autoRPCInstance, _IDENTIFIER_, _RETURN_, _CLASS_, _FUNCTION_, _PARAMS_, _PARAM_COUNT_) (autoRPCInstance)->RegisterFunction( (_IDENTIFIER_), GenRPC::PMFWrapper<_CLASS_, _RETURN_(AUTO_RPC_CALLSPEC _CLASS_::*) _PARAMS_>( &_CLASS_::_FUNCTION_), true, _PARAM_COUNT_ )
#define | ARPC_REGISTER_CPP_FUNCTION_N(autoRPCInstance, _IDENTIFIER_, _RETURN_, _CLASS_, _FUNCTION_,...) (autoRPCInstance)->RegisterFunction( (_IDENTIFIER_), GenRPC::PMFWrapper<_CLASS_, _RETURN_(AUTO_RPC_CALLSPEC _CLASS_::*)(__VA_ARGS__)>( &_CLASS_::_FUNCTION_), true, GenRPC::countFuncArgs( &_CLASS_::_FUNCTION_ ) - 1 )

Enumerations

enum RakNet::RPCErrorCodes {
RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST, RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST,
RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED,
RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_CALLING_CPP_AS_C, RakNet::RPC_ERROR_CALLING_CPP_AS_C,
RakNet::RPC_ERROR_CALLING_C_AS_CPP, RakNet::RPC_ERROR_CALLING_C_AS_CPP, RakNet::RPC_ERROR_STACK_TOO_SMALL, RakNet::RPC_ERROR_STACK_DESERIALIZATION_FAILED,
RakNet::RPC_ERROR_INCORRECT_NUMBER_OF_PARAMETERS, RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST,
RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST, RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE, RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED,
RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_CALLING_CPP_AS_C,
RakNet::RPC_ERROR_CALLING_CPP_AS_C, RakNet::RPC_ERROR_CALLING_C_AS_CPP, RakNet::RPC_ERROR_CALLING_C_AS_CPP
}

Detailed Description

Automatically serializing and deserializing RPC system. More advanced RPC, but possibly not cross-platform.

Note:
Semi-depreciated. RPC3 found at DependentExtensions/RPC3 has more features and is easier to use. But if you do not want to link with Boost this version still works.
This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Define Documentation

#define ARPC_REGISTER_CPP_FUNCTION | ( | autoRPCInstance,
 |  | _IDENTIFIER_,
 |  | _RETURN_,
 |  | _CLASS_,
 |  | _FUNCTION_,
 |  | _PARAMS_ | ) | (autoRPCInstance)->RegisterFunction( (_IDENTIFIER_), GenRPC::PMFWrapper<_CLASS_, _RETURN_(AUTO_RPC_CALLSPEC _CLASS_::*) _PARAMS_ >( &_CLASS_::_FUNCTION_), true, -1 )

Get a pointer to a function member of a C++ class.

Note:
Recommended you use ARPC_REGISTER_CPP_FUNCTION0 to ARPC_REGISTER_CPP_FUNCTION9 (below)

Cannot validate the number of parameters is correctly passed.

You must use one of these macros, or the code will be broken.

Parameters:
[in] | autoRPCInstance | A pointer to an instance of AutoRPC
[in] | _IDENTIFIER_ | C string identifier to use on the remote system to call the function
[in] | _RETURN_ | Return value of the function
[in] | _CLASS_ | Base-most class of the containing class that contains your function
[in] | _FUNCTION_ | Name of the function
[in] | _PARAMS_ | Parameter list, include parenthesis

#define ARPC_REGISTER_CPP_FUNCTION_N | ( | autoRPCInstance,
 |  | _IDENTIFIER_,
 |  | _RETURN_,
 |  | _CLASS_,
 |  | _FUNCTION_,
 |  | ... | ) | (autoRPCInstance)->RegisterFunction( (_IDENTIFIER_), GenRPC::PMFWrapper<_CLASS_, _RETURN_(AUTO_RPC_CALLSPEC _CLASS_::*)(__VA_ARGS__)>( &_CLASS_::_FUNCTION_), true, GenRPC::countFuncArgs( &_CLASS_::_FUNCTION_ ) - 1 )

Get a pointer to a function member of a C++ class

Parameters:
[in] | autoRPCInstance | A pointer to an instance of AutoRPC
[in] | _IDENTIFIER_ | C string identifier to use on the remote system to call the function
[in] | _RETURN_ | Return value of the function
[in] | _CLASS_ | Base-most class of the containing class that contains your function
[in] | _FUNCTION_ | Name of the function

#define ARPC_REGISTER_CPP_FUNCTIONX | ( | autoRPCInstance,
 |  | _IDENTIFIER_,
 |  | _RETURN_,
 |  | _CLASS_,
 |  | _FUNCTION_,
 |  | _PARAMS_,
 |  | _PARAM_COUNT_ | ) | (autoRPCInstance)->RegisterFunction( (_IDENTIFIER_), GenRPC::PMFWrapper<_CLASS_, _RETURN_(AUTO_RPC_CALLSPEC _CLASS_::*) _PARAMS_>( &_CLASS_::_FUNCTION_), true, _PARAM_COUNT_ )

Get a pointer to a function member of a C++ class.

Note:
Recommended you use ARPC_REGISTER_CPP_FUNCTION0 to ARPC_REGISTER_CPP_FUNCTION9 (below)

Cannot validate the number of parameters is correctly passed.

You must use one of these macros, or the code will be broken.

Parameters:
[in] | autoRPCInstance | A pointer to an instance of AutoRPC
[in] | _IDENTIFIER_ | C string identifier to use on the remote system to call the function
[in] | _RETURN_ | Return value of the function
[in] | _CLASS_ | Base-most class of the containing class that contains your function
[in] | _FUNCTION_ | Name of the function
[in] | _PARAMS_ | Parameter list, include parenthesis
[in] | _PARAM_COUNT_ | Number of parameters.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/BigTypes.h File Reference

  • File List
  • File Members
C: » RakNet » Source

BigTypes.h File Reference

[Internal] Used for RSA generation. More...

#include "Types.h"

Namespaces

namespace big

Detailed Description

[Internal] Used for RSA generation.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

(128)2^7-bit to (32768)2^14-bit signed 2's complement & unsigned extended arithmetic

catid(cat02e@fsu.edu)

7/30/2004 Fixed VS6 compat 7/28/2004 Fixed macros so they can be used outside of the big namespace Now using pre-processor definitions from types.h for inline assembly 7/26/2004 Removed a lot of assembly, made add/sub assembly optional 7/25/2004 Merged the wrapper class Int<T> from older code 7/24/2004 Replaced trivial assembly code with std:: functions Refined some assembly code with Art of Assembly chapter 9 Added binary ops 7/23/2004 Finished assembly coding Removed Int<T> class, for now Added old C++ code back in with USEASSEMBLY 7/22/2004 Signed arithmetic (needed for ext. Euclidean algo) Cleaned up coding style Began rewriting parts in assembly 7/21/2004 Began writing

Tabs: 4 spaces Dist: public

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/BitStream.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

BitStream.cpp File Reference

#include "BitStream.h"
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <arpa/inet.h>
#include <memory.h>
#include <cmath>
#include <float.h>

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/BitStream.h File Reference

  • File List
  • File Members
C: » RakNet » Source

BitStream.h File Reference

This class allows you to write and read native types as a string of bits. BitStream is used extensively throughout RakNet and is designed to be used by users as well. More...

#include "RakMemoryOverride.h"
#include "RakNetDefines.h"
#include "Export.h"
#include "RakNetTypes.h"
#include "RakString.h"
#include <assert.h>
#include <math.h>
#include <float.h>

Namespaces

namespace | RakNet

Classes

class | RakNet::BitStream

Detailed Description

This class allows you to write and read native types as a string of bits. BitStream is used extensively throughout RakNet and is designed to be used by users as well.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/BitStream_NoTemplate.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

BitStream_NoTemplate.cpp File Reference

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/BitStream_NoTemplate.h File Reference

  • File List
  • File Members
C: » RakNet » Source

BitStream_NoTemplate.h File Reference

This class allows you to write and read native types as a string of bits. BitStream is used extensively throughout RakNet and is designed to be used by users as well. More...

Detailed Description

This class allows you to write and read native types as a string of bits. BitStream is used extensively throughout RakNet and is designed to be used by users as well.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/CheckSum.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

CheckSum.cpp File Reference

CheckSum implementation from http://www.flounder.com/checksum.htm. More...

#include "CheckSum.h"

Detailed Description

CheckSum implementation from http://www.flounder.com/checksum.htm.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/CheckSum.h File Reference

  • File List
  • File Members
C: » RakNet » Source

CheckSum.h File Reference

[Internal] Generates and validates checksums More...

#include "RakMemoryOverride.h"

Classes

class CheckSum
Generates and validates checksums. More...

Detailed Description

[Internal] Generates and validates checksums

Note:
I didn't write this, but took it from http://www.flounder.com/checksum.htm
Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ClientContextStruct.h File Reference

  • File List
  • File Members
C: » RakNet » Source

ClientContextStruct.h File Reference

[Internal] Depreciated, back from when I supported IO Completion ports. More...

#include "RakNetTypes.h"
#include "MTUSize.h"

Detailed Description

[Internal] Depreciated, back from when I supported IO Completion ports.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/CommandParserInterface.h File Reference

  • File List
  • File Members
C: » RakNet » Source

CommandParserInterface.h File Reference

Contains CommandParserInterface , from which you derive custom command parsers. More...

#include "RakMemoryOverride.h"
#include "RakNetTypes.h"
#include "DS_OrderedList.h"
#include "Export.h"

Classes

class | CommandParserInterface
The interface used by command parsers. More...

Functions

int RAK_DLL_EXPORT | RegisteredCommandComp (const char *const &key, const RegisteredCommand &data)
List of commands registered with RegisterCommand().

Detailed Description

Contains CommandParserInterface , from which you derive custom command parsers.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ConnectionGraph.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

ConnectionGraph.cpp File Reference

#include "ConnectionGraph.h"
#include "RakPeerInterface.h"
#include "MessageIdentifiers.h"
#include "BitStream.h"
#include "StringCompressor.h"
#include "GetTime.h"
#include <string.h>
#include "RakAssert.h"
#include "SHA1.h"

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ConnectionGraph.h File Reference

  • File List
  • File Members
C: » RakNet » Source

ConnectionGraph.h File Reference

Connection graph plugin. This maintains a graph of connections for the entire network, so every peer knows about every other peer. More...

#include "RakMemoryOverride.h"
#include "RakNetTypes.h"
#include "PluginInterface.h"
#include "DS_List.h"
#include "DS_WeightedGraph.h"
#include "GetTime.h"
#include "Export.h"

Classes

class | ConnectionGraph
A connection graph. Each peer will know about all other peers. More...
struct | ConnectionGraph::SystemAddressAndGroupId
A node in the connection graph. More...

Detailed Description

Connection graph plugin. This maintains a graph of connections for the entire network, so every peer knows about every other peer.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ConsoleServer.h File Reference

  • File List
  • File Members
C: » RakNet » Source

ConsoleServer.h File Reference

Contains ConsoleServer , used to plugin to your game to accept remote console-based connections. More...

#include "RakMemoryOverride.h"
#include "DS_List.h"
#include "RakNetTypes.h"
#include "Export.h"

Classes

class ConsoleServer
The main entry point for the server portion of your remote console application support. ConsoleServer takes one TransportInterface and one or more CommandParserInterface (s) The TransportInterface will be used to send data between the server and the client. The connecting client must support the protocol used by your derivation of TransportInterface . TelnetTransport and RakNetTransport are two such derivations . When a command is sent by a remote console, it will be processed by your implementations of CommandParserInterface. More...

Detailed Description

Contains ConsoleServer , used to plugin to your game to accept remote console-based connections.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DataBlockEncryptor.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

DataBlockEncryptor.cpp File Reference

#include "DataBlockEncryptor.h"
#include "CheckSum.h"
#include "GetTime.h"
#include "Rand.h"
#include <assert.h>
#include <string.h>
#include "Rijndael.h"
#include "Types.h"

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DataBlockEncryptor.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DataBlockEncryptor.h File Reference

[Internal] Encrypts and decrypts data blocks. Used as part of secure connections. More...

#include "Rijndael.h"
#include "RakMemoryOverride.h"

Classes

class DataBlockEncryptor
Encrypts and decrypts data blocks. More...

Detailed Description

[Internal] Encrypts and decrypts data blocks. Used as part of secure connections.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DataCompressor.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DataCompressor.h File Reference

DataCompressor does compression on a block of data. Not very good compression, but it's small and fast so is something you can use per-message at runtime. More...

#include "RakMemoryOverride.h"
#include "DS_HuffmanEncodingTree.h"
#include "Export.h"

Classes

class DataCompressor
Does compression on a block of data. Not very good compression, but it's small and fast so is something you can compute at runtime. More...

Detailed Description

DataCompressor does compression on a block of data. Not very good compression, but it's small and fast so is something you can use per-message at runtime.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DirectoryDeltaTransfer.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DirectoryDeltaTransfer.h File Reference

Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc. More...

#include "RakMemoryOverride.h"
#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface.h"
#include "DS_Map.h"
#include "PacketPriority.h"

Classes

class DirectoryDeltaTransfer
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc. More...

Detailed Description

Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_BinarySearchTree.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_BinarySearchTree.h File Reference

[Internal] A binary search tree, and an AVL balanced BST derivation. More...

#include "DS_QueueLinkedList.h"
#include "RakMemoryOverride.h"
#include "Export.h"

Namespaces

namespace | DataStructures

Classes

class | DataStructures::BinarySearchTree< BinarySearchTreeType >
A binary search tree and an AVL balanced binary search tree. More...
class | DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType >
An AVLBalancedBinarySearchTree is a binary tree that is always balanced. More...

Detailed Description

[Internal] A binary search tree, and an AVL balanced BST derivation.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_ByteQueue.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_ByteQueue.h File Reference

[Internal] Byte queue More...

#include "RakMemoryOverride.h"
#include "Export.h"

Namespaces

namespace DataStructures

Detailed Description

[Internal] Byte queue

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_Heap.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_Heap.h File Reference

[Internal] Heap (Also serves as a priority queue) More...

#include "RakMemoryOverride.h"
#include "DS_List.h"
#include "Export.h"
#include <assert.h>

Namespaces

namespace DataStructures

Detailed Description

[Internal] Heap (Also serves as a priority queue)

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_HuffmanEncodingTree.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_HuffmanEncodingTree.cpp File Reference

#include "DS_HuffmanEncodingTree.h"
#include "DS_Queue.h"
#include "BitStream.h"
#include <assert.h>

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_HuffmanEncodingTree.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_HuffmanEncodingTree.h File Reference

[Internal] Generates a huffman encoding tree, used for string and global compression. More...

#include "RakMemoryOverride.h"
#include "DS_HuffmanEncodingTreeNode.h"
#include "BitStream.h"
#include "Export.h"
#include "DS_LinkedList.h"

Classes

class HuffmanEncodingTree
This generates special cases of the huffman encoding tree using 8 bit keys with the additional condition that unused combinations of 8 bits are treated as a frequency of 1. More...

Detailed Description

[Internal] Generates a huffman encoding tree, used for string and global compression.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_HuffmanEncodingTreeFactory.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_HuffmanEncodingTreeFactory.h File Reference

[Internal] Creates instances of the class HuffmanEncodingTree More...

#include "RakMemoryOverride.h"

Classes

class HuffmanEncodingTreeFactory
Creates instances of the class HuffmanEncodingTree. More...

Detailed Description

[Internal] Creates instances of the class HuffmanEncodingTree

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_HuffmanEncodingTreeNode.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_HuffmanEncodingTreeNode.h File Reference

[Internal] A single node in the Huffman Encoding Tree. More...

Detailed Description

[Internal] A single node in the Huffman Encoding Tree.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_LinkedList.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_LinkedList.h File Reference

[Internal] Straightforward linked list data structure. More...

#include "Export.h"
#include "RakMemoryOverride.h"

Namespaces

namespace | DataStructures

Classes

class | DataStructures::CircularLinkedList< CircularLinkedListType >
(Circular) Linked List ADT (Doubly Linked Pointer to Node Style) - More...

Detailed Description

[Internal] Straightforward linked list data structure.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_List.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_List.h File Reference

[Internal] Array based list. Usually the Queue class is used instead, since it has all the same functionality and is only worse at random access. More...

#include <assert.h>
#include <string.h>
#include "Export.h"

Namespaces

namespace | DataStructures

Classes

class | DataStructures::List< list_type >
Array based implementation of a list. More...

Detailed Description

[Internal] Array based list. Usually the Queue class is used instead, since it has all the same functionality and is only worse at random access.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_Map.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_Map.h File Reference

[Internal] Map More...

#include "DS_OrderedList.h"
#include "Export.h"

Namespaces

namespace | DataStructures

Classes

class | DataStructures::Map< key_type, data_type, key_comparison_func >
Note:
IMPORTANT! If you use defaultMapKeyComparison then call IMPLEMENT_DEFAULT_COMPARISON or you will get an unresolved external linker error.
More...

Functions

template<class key_type>
int | DataStructures::defaultMapKeyComparison (const key_type &a, const key_type &b)

Detailed Description

[Internal] Map

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_OrderedChannelHeap.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_OrderedChannelHeap.h File Reference

[Internal] Ordered Channel Heap . This is a heap where you add to it on multiple ordered channels, with each channel having a different weight. More...

#include "DS_Heap.h"
#include "DS_Map.h"
#include "DS_Queue.h"
#include "Export.h"
#include <assert.h>
#include "Rand.h"

Namespaces

namespace DataStructures

Detailed Description

[Internal] Ordered Channel Heap . This is a heap where you add to it on multiple ordered channels, with each channel having a different weight.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_OrderedList.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_OrderedList.h File Reference

[Internal] Quicksort ordered list. More...

#include "DS_List.h"
#include "RakMemoryOverride.h"
#include "Export.h"

Namespaces

namespace | DataStructures

Classes

class | DataStructures::OrderedList< key_type, data_type, default_comparison_function >
Note:
IMPORTANT! If you use defaultOrderedListComparison then call IMPLEMENT_DEFAULT_COMPARISON or you will get an unresolved external linker error.
More...

Detailed Description

[Internal] Quicksort ordered list.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_Queue.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_Queue.h File Reference

[Internal] A queue used by RakNet. More...

#include <assert.h>
#include "Export.h"

Namespaces

namespace | DataStructures

Classes

class | DataStructures::Queue< queue_type >
A queue implemented as an array with a read and write index. More...

Detailed Description

[Internal] A queue used by RakNet.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_QueueLinkedList.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_QueueLinkedList.h File Reference

[Internal] A queue implemented as a linked list. More...

#include "DS_LinkedList.h"
#include "Export.h"
#include "RakMemoryOverride.h"

Namespaces

namespace | DataStructures

Classes

class | DataStructures::QueueLinkedList< QueueType >
A queue implemented using a linked list. Rarely used. More...

Detailed Description

[Internal] A queue implemented as a linked list.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_Tree.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_Tree.h File Reference

[Internal] Just a regular tree More...

#include "Export.h"
#include "DS_List.h"
#include "DS_Queue.h"
#include "RakMemoryOverride.h"

Namespaces

namespace DataStructures

Detailed Description

[Internal] Just a regular tree

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/DS_WeightedGraph.h File Reference

  • File List
  • File Members
C: » RakNet » Source

DS_WeightedGraph.h File Reference

[Internal] Weighted graph. I'm assuming the indices are complex map types, rather than sequential numbers (which could be implemented much more efficiently). More...

#include "DS_OrderedList.h"
#include "DS_Map.h"
#include "DS_Heap.h"
#include "DS_Queue.h"
#include "DS_Tree.h"
#include <assert.h>
#include "RakMemoryOverride.h"

Namespaces

namespace DataStructures

Detailed Description

[Internal] Weighted graph. I'm assuming the indices are complex map types, rather than sequential numbers (which could be implemented much more efficiently).

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/EmailSender.h File Reference

  • File List
  • File Members
C: » RakNet » Source

EmailSender.h File Reference

Rudimentary class to send email from code. Don't expect anything fancy. More...

#include "RakNetTypes.h"
#include "RakMemoryOverride.h"

Classes

class EmailSender
Rudimentary class to send email from code. More...

Detailed Description

Rudimentary class to send email from code. Don't expect anything fancy.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ExtendedOverlappedPool.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

ExtendedOverlappedPool.cpp File Reference

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ExtendedOverlappedPool.h File Reference

  • File List
  • File Members
C: » RakNet » Source

ExtendedOverlappedPool.h File Reference

[Depreciated] This was used for IO completion ports. More...

Detailed Description

[Depreciated] This was used for IO completion ports.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/FileListTransfer.h File Reference

  • File List
  • File Members
C: » RakNet » Source

FileListTransfer.h File Reference

A plugin to provide a simple way to compress and incrementally send the files in the FileList structure. More...

#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface.h"
#include "DS_Map.h"
#include "PacketPriority.h"
#include "RakMemoryOverride.h"

Classes

class FileListTransfer
A plugin to provide a simple way to compress and incrementally send the files in the FileList structure. Similar to the DirectoryDeltaTransfer plugin, except that it doesn't send deltas based on pre-existing files or actually write the files to disk. More...

Detailed Description

A plugin to provide a simple way to compress and incrementally send the files in the FileList structure.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/FullyConnectedMesh.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

FullyConnectedMesh.cpp File Reference

#include "FullyConnectedMesh.h"
#include "RakPeerInterface.h"
#include "MessageIdentifiers.h"
#include "BitStream.h"
#include "ConnectionGraph.h"
#include "NatPunchthrough.h"
#include <string.h>
#include <assert.h>

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/FullyConnectedMesh.h File Reference

  • File List
  • File Members
C: » RakNet » Source

FullyConnectedMesh.h File Reference

Fully connected mesh plugin. This will connect RakPeer to all connecting peers, and all peers the connecting peer knows about. More...

#include "PluginInterface.h"
#include "RakMemoryOverride.h"

Classes

class FullyConnectedMesh

Detailed Description

Fully connected mesh plugin. This will connect RakPeer to all connecting peers, and all peers the connecting peer knows about.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/FunctionThread.h File Reference

  • File List
  • File Members
C: » RakNet » Source

FunctionThread.h File Reference

A set of classes to make it easier to perform asynchronous function processing. More...

#include "SingleProducerConsumer.h"
#include "ThreadPool.h"
#include "RakMemoryOverride.h"
#include "Export.h"

Namespaces

namespace | RakNet

Classes

class | RakNet::FunctionThread
class | RakNet::Functor

Detailed Description

A set of classes to make it easier to perform asynchronous function processing.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/GetTime.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

GetTime.cpp File Reference

#include "GetTime.h"
#include <sys/time.h>
#include <unistd.h>

Functions

RakNetTime RakNet::GetTime (void)
Returns the value from QueryPerformanceCounter. This is the function RakNet uses to represent time.

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/GetTime.h File Reference

  • File List
  • File Members
C: » RakNet » Source

GetTime.h File Reference

Returns the value from QueryPerformanceCounter. This is the function RakNet uses to represent time. More...

#include "Export.h"
#include "RakNetTypes.h"

Namespaces

namespace | RakNet

Functions

RakNetTime | RakNet::GetTime (void)
Returns the value from QueryPerformanceCounter. This is the function RakNet uses to represent time.

Detailed Description

Returns the value from QueryPerformanceCounter. This is the function RakNet uses to represent time.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/HTTPConnection.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

HTTPConnection.cpp File Reference

Contains HTTPConnection, used to communicate with web servers. More...

#include "TCPInterface.h"
#include "HTTPConnection.h"
#include "RakSleep.h"
#include "RakString.h"
#include "RakAssert.h"
#include <string.h>
#include <stdlib.h>
#include <stdio.h>

Detailed Description

Contains HTTPConnection, used to communicate with web servers.

This file is part of RakNet Copyright 2008 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/HTTPConnection.h File Reference

  • File List
  • File Members
C: » RakNet » Source

HTTPConnection.h File Reference

Contains HTTPConnection, used to communicate with web servers. More...

#include "Export.h"
#include "RakString.h"
#include "RakMemoryOverride.h"
#include "RakNetTypes.h"
#include "DS_Queue.h"

Classes

class | HTTPConnection
Use HTTPConnection to communicate with a web server. Start an instance of TCPInterface via the Start() command. Instantiate a new instance of HTTPConnection, and associate TCPInterface with the class in the constructor. Use Post() to send commands to the web server, and ProcessDataPacket() to update the connection with packets returned from TCPInterface that have the system address of the web server This class will handle connecting and reconnecting as necessary. More...
struct | HTTPConnection::BadResponse
Encapsulates a raw HTTP response and response code. More...

Detailed Description

Contains HTTPConnection, used to communicate with web servers.

This file is part of RakNet Copyright 2008 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/InternalPacket.h File Reference

  • File List
  • File Members
C: » RakNet » Source

InternalPacket.h File Reference

[Internal] A class which stores a user message, and all information associated with sending and receiving that message. More...

#include "PacketPriority.h"
#include "RakNetTypes.h"
#include "RakMemoryOverride.h"

Classes

struct | InternalPacket

Typedefs

typedef unsigned int | MessageNumberType
typedef MessageNumberType | OrderingIndexType

Detailed Description

[Internal] A class which stores a user message, and all information associated with sending and receiving that message.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Typedef Documentation

typedef unsigned int MessageNumberType

This is the counter used for holding packet numbers, so we can detect duplicate packets. It should be large enough that if the variables were to wrap, the newly wrapped values would no longer be in use. Warning: Too large of a value wastes bandwidth! Use the smallest possible value, such that you send no more than rangeof(MessageNumberType) / GetTimeoutTime() packets per second For the default value of 10 seconds, this is unsigned char - 25.5 packets per second unsigned short - 6553.5 packets per second unsigned int - You'll run out of memory first.

typedef MessageNumberType OrderingIndexType

This is the counter used for holding ordered packet numbers, so we can detect out-of-order packets. It should be large enough that if the variables were to wrap, the newly wrapped values would no longer be in use. Warning: Too large of a value wastes bandwidth!

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/LightweightDatabaseClient.h File Reference

  • File List
  • File Members
C: » RakNet » Source

LightweightDatabaseClient.h File Reference

Contains the client interface to the simple database included with RakNet, useful for a server browser or a lobby server. More...

#include "Export.h"
#include "PluginInterface.h"
#include "LightweightDatabaseCommon.h"

Classes

class LightweightDatabaseClient
The client interface to the simple database included with RakNet, useful for a server browser or a lobby server. More...

Detailed Description

Contains the client interface to the simple database included with RakNet, useful for a server browser or a lobby server.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/LightweightDatabaseServer.h File Reference

  • File List
  • File Members
C: » RakNet » Source

LightweightDatabaseServer.h File Reference

A simple flat database included with RakNet, useful for a server browser or a lobby server. More...

#include "Export.h"
#include "PluginInterface.h"
#include "LightweightDatabaseCommon.h"
#include "DS_Map.h"

Classes

class LightweightDatabaseServer
A simple flat database included with RakNet, useful for a server browser or a lobby server. A flat database interface. Adds the ability to track IPs of row updaters and passwords for table read and write operations, Best used for data in which queries which do not need to be updated in real-time. More...

Detailed Description

A simple flat database included with RakNet, useful for a server browser or a lobby server.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/LogCommandParser.h File Reference

  • File List
  • File Members
C: » RakNet » Source

LogCommandParser.h File Reference

Contains LogCommandParser , Used to send logs to connected consoles. More...

#include "CommandParserInterface.h"
#include "Export.h"

Classes

class | LogCommandParser
Adds the ability to send logging output to a remote console. More...
struct | LogCommandParser::SystemAddressAndChannel
One of these structures is created per player. More...

Detailed Description

Contains LogCommandParser , Used to send logs to connected consoles.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/MessageFilter.h File Reference

  • File List
  • File Members
C: » RakNet » Source

MessageFilter.h File Reference

Message filter plugin. Assigns systems to FilterSets. Each FilterSet limits what messages are allowed. This is a security related plugin. More...

#include "RakNetTypes.h"
#include "PluginInterface.h"
#include "DS_OrderedList.h"
#include "Export.h"

Classes

class | MessageFilter
Assigns systems to FilterSets. Each FilterSet limits what kinds of messages are allowed. The MessageFilter plugin is used for security where you limit what systems can send what kind of messages. You implicitly define FilterSets, and add allowed message IDs and RPC calls to these FilterSets. You then add systems to these filters, such that those systems are limited to sending what the filters allows. You can automatically assign systems to a filter. You can automatically kick and possibly ban users that stay in a filter too long, or send the wrong message. Each system is a member of either zero or one filters. Add this plugin before any plugin you wish to filter (most likely just add this plugin before any other). More...

Defines

#define | MESSAGE_FILTER_MAX_MESSAGE_ID 256
MessageIdentifier (ID_*) values shoudln't go higher than this. Change it if you do.

Detailed Description

Message filter plugin. Assigns systems to FilterSets. Each FilterSet limits what messages are allowed. This is a security related plugin.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/MessageIdentifiers.h File Reference

  • File List
  • File Members
C: » RakNet » Source

MessageIdentifiers.h File Reference

All the message identifiers used by RakNet. Message identifiers comprise the first byte of any message. More...

Enumerations

enum DefaultMessageIDTypes {
ID_INTERNAL_PING, ID_PING, ID_PING_OPEN_CONNECTIONS, ID_CONNECTED_PONG,
ID_CONNECTION_REQUEST, ID_SECURED_CONNECTION_RESPONSE, ID_SECURED_CONNECTION_CONFIRMATION, ID_RPC_MAPPING,
ID_DETECT_LOST_CONNECTIONS, ID_OPEN_CONNECTION_REQUEST, ID_OPEN_CONNECTION_REPLY, ID_RPC,
ID_RPC_REPLY, ID_OUT_OF_BAND_INTERNAL, ID_CONNECTION_REQUEST_ACCEPTED, ID_CONNECTION_ATTEMPT_FAILED,
ID_ALREADY_CONNECTED, ID_NEW_INCOMING_CONNECTION, ID_NO_FREE_INCOMING_CONNECTIONS, ID_DISCONNECTION_NOTIFICATION,
ID_CONNECTION_LOST, ID_RSA_PUBLIC_KEY_MISMATCH, ID_CONNECTION_BANNED, ID_INVALID_PASSWORD,
ID_MODIFIED_PACKET, ID_TIMESTAMP, ID_PONG, ID_ADVERTISE_SYSTEM,
ID_REMOTE_DISCONNECTION_NOTIFICATION, ID_REMOTE_CONNECTION_LOST, ID_REMOTE_NEW_INCOMING_CONNECTION , ID_FILE_LIST_TRANSFER_HEADER,
ID_FILE_LIST_TRANSFER_FILE, ID_DDT_DOWNLOAD_REQUEST, ID_TRANSPORT_STRING, ID_REPLICA_MANAGER_CONSTRUCTION,
ID_REPLICA_MANAGER_DESTRUCTION, ID_REPLICA_MANAGER_SCOPE_CHANGE, ID_REPLICA_MANAGER_SERIALIZE, ID_REPLICA_MANAGER_DOWNLOAD_STARTED,
ID_REPLICA_MANAGER_DOWNLOAD_COMPLETE, ID_CONNECTION_GRAPH_REQUEST, ID_CONNECTION_GRAPH_REPLY, ID_CONNECTION_GRAPH_UPDATE,
ID_CONNECTION_GRAPH_NEW_CONNECTION, ID_CONNECTION_GRAPH_CONNECTION_LOST, ID_CONNECTION_GRAPH_DISCONNECTION_NOTIFICATION, ID_ROUTE_AND_MULTICAST,
ID_RAKVOICE_OPEN_CHANNEL_REQUEST, ID_RAKVOICE_OPEN_CHANNEL_REPLY, ID_RAKVOICE_CLOSE_CHANNEL, ID_RAKVOICE_DATA,
ID_AUTOPATCHER_GET_CHANGELIST_SINCE_DATE, ID_AUTOPATCHER_CREATION_LIST, ID_AUTOPATCHER_DELETION_LIST, ID_AUTOPATCHER_GET_PATCH,
ID_AUTOPATCHER_PATCH_LIST, ID_AUTOPATCHER_REPOSITORY_FATAL_ERROR, ID_AUTOPATCHER_FINISHED_INTERNAL , ID_AUTOPATCHER_RESTART_APPLICATION,
ID_NAT_PUNCHTHROUGH_REQUEST, ID_NAT_TARGET_NOT_CONNECTED, ID_NAT_TARGET_CONNECTION_LOST, ID_NAT_CONNECT_AT_TIME,
ID_NAT_SEND_OFFLINE_MESSAGE_AT_TIME, ID_NAT_IN_PROGRESS, ID_DATABASE_QUERY_REQUEST, ID_DATABASE_UPDATE_ROW,
ID_DATABASE_REMOVE_ROW, ID_DATABASE_QUERY_REPLY, ID_DATABASE_UNKNOWN_TABLE, ID_DATABASE_INCORRECT_PASSWORD,
ID_READY_EVENT_SET, ID_READY_EVENT_UNSET, ID_READY_EVENT_ALL_SET, ID_READY_EVENT_QUERY,
ID_LOBBY_GENERAL, ID_AUTO_RPC_CALL, ID_AUTO_RPC_REMOTE_INDEX, ID_AUTO_RPC_UNKNOWN_REMOTE_INDEX,
ID_RPC_REMOTE_ERROR
}

Detailed Description

All the message identifiers used by RakNet. Message identifiers comprise the first byte of any message.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Enumeration Type Documentation

enum DefaultMessageIDTypes

You should not edit the file MessageIdentifiers.h as it is a part of RakNet static library To define your own message id, define an enum following the code example that follows.

 enum {
   ID_MYPROJECT_MSG_1 = ID_USER_PACKET_ENUM,
   ID_MYPROJECT_MSG_2,
    ...
 };

Note:
All these enumerations should be casted to (unsigned char) before writing them to RakNet::BitStream
Enumerator:
ID_INTERNAL_PING | These types are never returned to the user. Ping from a connected system. Update timestamps (internal use only)
ID_PING | Ping from an unconnected system. Reply but do not update timestamps. (internal use only).
ID_PING_OPEN_CONNECTIONS | Ping from an unconnected system. Only reply if we have open connections. Do not update timestamps. (internal use only).
ID_CONNECTED_PONG | Pong from a connected system. Update timestamps (internal use only).
ID_CONNECTION_REQUEST | Asking for a new connection (internal use only).
ID_SECURED_CONNECTION_RESPONSE | Connecting to a secured server/peer (internal use only).
ID_SECURED_CONNECTION_CONFIRMATION | Connecting to a secured server/peer (internal use only).
ID_RPC_MAPPING | Packet that tells us the packet contains an integer ID to name mapping for the remote system (internal use only).
ID_DETECT_LOST_CONNECTIONS | A reliable packet to detect lost connections (internal use only).
ID_OPEN_CONNECTION_REQUEST | Offline message so we know when to reset and start a new connection (internal use only).
ID_OPEN_CONNECTION_REPLY | Offline message response so we know when to reset and start a new connection (internal use only).
ID_RPC | Remote procedure call (internal use only).
ID_RPC_REPLY | Remote procedure call reply, for RPCs that return data (internal use only).
ID_OUT_OF_BAND_INTERNAL | RakPeer - Same as ID_ADVERTISE_SYSTEM, but intended for internal use rather than being passed to the user. Second byte indicates type. Used currently for NAT punchthrough for receiver port advertisement. See ID_NAT_ADVERTISE_RECIPIENT_PORT.
ID_CONNECTION_REQUEST_ACCEPTED | RakPeer - In a client/server environment, our connection request to the server has been accepted.
ID_CONNECTION_ATTEMPT_FAILED | RakPeer - Sent to the player when a connection request cannot be completed due to inability to connect.
ID_ALREADY_CONNECTED | RakPeer - Sent a connect request to a system we are currently connected to.
ID_NEW_INCOMING_CONNECTION | RakPeer - A remote system has successfully connected.
ID_NO_FREE_INCOMING_CONNECTIONS | RakPeer - The system we attempted to connect to is not accepting new connections.
ID_DISCONNECTION_NOTIFICATION | RakPeer - The system specified in Packet::systemAddress has disconnected from us. For the client, this would mean the server has shutdown.
ID_CONNECTION_LOST | RakPeer - Reliable packets cannot be delivered to the system specified in Packet::systemAddress. The connection to that system has been closed.
ID_RSA_PUBLIC_KEY_MISMATCH | RakPeer - We preset an RSA public key which does not match what the system we connected to is using.
ID_CONNECTION_BANNED | RakPeer - We are banned from the system we attempted to connect to.
ID_INVALID_PASSWORD | RakPeer - The remote system is using a password and has refused our connection because we did not set the correct password.
ID_MODIFIED_PACKET | RakPeer - A packet has been tampered with in transit. The sender is contained in Packet::systemAddress.
ID_TIMESTAMP | RakPeer - The four bytes following this byte represent an unsigned int which is automatically modified by the difference in system times between the sender and the recipient. Requires that you call SetOccasionalPing.
ID_PONG | RakPeer - Pong from an unconnected system. First byte is ID_PONG, second sizeof(RakNetTime) bytes is the ping, following bytes is system specific enumeration data.
ID_ADVERTISE_SYSTEM | RakPeer - Inform a remote system of our IP/Port, plus some offline data.
ID_REMOTE_DISCONNECTION_NOTIFICATION | ConnectionGraph plugin - In a client/server environment, a client other than ourselves has disconnected gracefully. Packet::systemAddress is modified to reflect the systemAddress of this client.
ID_REMOTE_CONNECTION_LOST | ConnectionGraph plugin - In a client/server environment, a client other than ourselves has been forcefully dropped. Packet::systemAddress is modified to reflect the systemAddress of this client.
ID_REMOTE_NEW_INCOMING_CONNECTION | ConnectionGraph plugin - In a client/server environment, a client other than ourselves has connected. Packet::systemAddress is modified to reflect the systemAddress of the client that is not connected directly to us. The packet encoding is SystemAddress 1, ConnectionGraphGroupID 1, SystemAddress 2, ConnectionGraphGroupID 2.
ID_FILE_LIST_TRANSFER_HEADER | FileListTransfer plugin - Setup data.
ID_FILE_LIST_TRANSFER_FILE | FileListTransfer plugin - A file.
ID_DDT_DOWNLOAD_REQUEST | DirectoryDeltaTransfer plugin - Request from a remote system for a download of a directory.
ID_TRANSPORT_STRING | RakNetTransport plugin - Transport provider message, used for remote console.
ID_REPLICA_MANAGER_CONSTRUCTION | ReplicaManager plugin - Create an object.
ID_REPLICA_MANAGER_DESTRUCTION | ReplicaManager plugin - Destroy an object.
ID_REPLICA_MANAGER_SCOPE_CHANGE | ReplicaManager plugin - Changed scope of an object.
ID_REPLICA_MANAGER_SERIALIZE | ReplicaManager plugin - Serialized data of an object.
ID_REPLICA_MANAGER_DOWNLOAD_STARTED | ReplicaManager plugin - New connection, about to send all world objects.
ID_REPLICA_MANAGER_DOWNLOAD_COMPLETE | ReplicaManager plugin - Finished downloading all serialized objects.
ID_CONNECTION_GRAPH_REQUEST | ConnectionGraph plugin - Request the connection graph from another system.
ID_CONNECTION_GRAPH_REPLY | ConnectionGraph plugin - Reply to a connection graph download request.
ID_CONNECTION_GRAPH_UPDATE | ConnectionGraph plugin - Update edges / nodes for a system with a connection graph.
ID_CONNECTION_GRAPH_NEW_CONNECTION | ConnectionGraph plugin - Add a new connection to a connection graph.
ID_CONNECTION_GRAPH_CONNECTION_LOST | ConnectionGraph plugin - Remove a connection from a connection graph - connection was abruptly lost.
ID_CONNECTION_GRAPH_DISCONNECTION_NOTIFICATION | ConnectionGraph plugin - Remove a connection from a connection graph - connection was gracefully lost.
ID_ROUTE_AND_MULTICAST | Router plugin - route a message through another system.
ID_RAKVOICE_OPEN_CHANNEL_REQUEST | RakVoice plugin - Open a communication channel.
ID_RAKVOICE_OPEN_CHANNEL_REPLY | RakVoice plugin - Communication channel accepted.
ID_RAKVOICE_CLOSE_CHANNEL | RakVoice plugin - Close a communication channel.
ID_RAKVOICE_DATA | RakVoice plugin - Voice data.
ID_AUTOPATCHER_GET_CHANGELIST_SINCE_DATE | Autopatcher plugin - Get a list of files that have changed since a certain date.
ID_AUTOPATCHER_CREATION_LIST | Autopatcher plugin - A list of files to create.
ID_AUTOPATCHER_DELETION_LIST | Autopatcher plugin - A list of files to delete.
ID_AUTOPATCHER_GET_PATCH | Autopatcher plugin - A list of files to get patches for.
ID_AUTOPATCHER_PATCH_LIST | Autopatcher plugin - A list of patches for a list of files.
ID_AUTOPATCHER_REPOSITORY_FATAL_ERROR | Autopatcher plugin - Returned to the user: An error from the database repository for the autopatcher.
ID_AUTOPATCHER_FINISHED_INTERNAL | Autopatcher plugin - Finished getting all files from the autopatcher.
ID_AUTOPATCHER_RESTART_APPLICATION | Autopatcher plugin - Returned to the user: You must restart the application to finish patching.
ID_NAT_PUNCHTHROUGH_REQUEST | NATPunchthrough plugin - Intermediary got a request to help punch through a nat.
ID_NAT_TARGET_NOT_CONNECTED | NATPunchthrough plugin - Intermediary cannot complete the request because the target system is not connected.
ID_NAT_TARGET_CONNECTION_LOST | NATPunchthrough plugin - While attempting to connect, we lost the connection to the target system.
ID_NAT_CONNECT_AT_TIME | NATPunchthrough plugin - Internal message to connect at a certain time.
ID_NAT_SEND_OFFLINE_MESSAGE_AT_TIME | NATPunchthrough plugin - Internal message to send a message (to punch through the nat) at a certain time.
ID_NAT_IN_PROGRESS | NATPunchthrough plugin - The facilitator is already attempting this connection.
ID_DATABASE_QUERY_REQUEST | LightweightDatabase plugin - Query.
ID_DATABASE_UPDATE_ROW | LightweightDatabase plugin - Update.
ID_DATABASE_REMOVE_ROW | LightweightDatabase plugin - Remove.
ID_DATABASE_QUERY_REPLY | LightweightDatabase plugin - A serialized table. Bytes 1+ contain the table. Pass to TableSerializer::DeserializeTable.
ID_DATABASE_UNKNOWN_TABLE | LightweightDatabase plugin - Specified table not found.
ID_DATABASE_INCORRECT_PASSWORD | LightweightDatabase plugin - Incorrect password.
ID_READY_EVENT_SET | ReadyEvent plugin - Set the ready state for a particular system.
ID_READY_EVENT_UNSET | ReadyEvent plugin - Unset the ready state for a particular system.
ID_READY_EVENT_ALL_SET | All systems are in state ID_READY_EVENT_SET.
ID_READY_EVENT_QUERY | ReadyEvent plugin - Request of ready event state - used for pulling data when newly connecting.
ID_LOBBY_GENERAL | Lobby packets. Second byte indicates type.
ID_AUTO_RPC_CALL | Auto RPC procedure call.
ID_AUTO_RPC_REMOTE_INDEX | Auto RPC functionName to index mapping.
ID_AUTO_RPC_UNKNOWN_REMOTE_INDEX | Auto RPC functionName to index mapping, lookup failed. Will try to auto recover.
ID_RPC_REMOTE_ERROR | Auto RPC error code See AutoRPC.h for codes, stored in packet->data[1]

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/MTUSize.h File Reference

  • File List
  • File Members
C: » RakNet » Source

MTUSize.h File Reference

[Internal] Defines the default maximum transfer unit. More...

Defines

#define | DEFAULT_MTU_SIZE 1492
#define | MAXIMUM_MTU_SIZE 1492

Detailed Description

[Internal] Defines the default maximum transfer unit.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Define Documentation

#define DEFAULT_MTU_SIZE 1492

The MTU size to use if RakPeer::SetMTUSize() is not called.

Remarks:
I think many people forget to call RakPeer::SetMTUSize() so I'm setting this to 1500 by default for efficiency.
  • 17914 16 Mbit/Sec Token Ring
  • 4464 4 Mbits/Sec Token Ring
  • 4352 FDDI
  • 1500. The largest Ethernet packet size recommended. This is the typical setting for non-PPPoE, non-VPN connections. The default value for NETGEAR routers, adapters and switches.
  • 1492. The size PPPoE prefers.
  • 1472. Maximum size to use for pinging. (Bigger packets are fragmented.)
  • 1468. The size DHCP prefers.
  • 1460. Usable by AOL if you don't have large email attachments, etc.
  • 1430. The size VPN and PPTP prefer.
  • 1400. Maximum size for AOL DSL.
  • 576. Typical value to connect to dial-up ISPs.

#define MAXIMUM_MTU_SIZE 1492

The largest value for an UDP datagram

See also:
RakPeer::SetMTUSize()

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/NatPunchthrough.h File Reference

  • File List
  • File Members
C: » RakNet » Source

NatPunchthrough.h File Reference

Contains the NAT-punchthrough plugin. More...

#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface.h"
#include "PacketPriority.h"
#include "DS_List.h"

Classes

class | NatPunchthroughLogger
Prints logging output for NatPunchthrough. More...
class | NatPunchthrough
The NatPunchthrough class implements the NAT punch through technique, allowing two systems to connect to each other that are both behind NATs. More...

Detailed Description

Contains the NAT-punchthrough plugin.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/NetworkIDManager.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

NetworkIDManager.cpp File Reference

#include "NetworkIDManager.h"
#include "NetworkIDObject.h"
#include "RakAssert.h"
#include <string.h>

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/NetworkIDManager.h File Reference

  • File List
  • File Members
C: » RakNet » Source

NetworkIDManager.h File Reference

#include "DS_BinarySearchTree.h"
#include "RakNetTypes.h"
#include "Export.h"
#include "RakMemoryOverride.h"
#include "NetworkIDObject.h"

Classes

class NetworkIDManager

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/NetworkIDObject.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

NetworkIDObject.cpp File Reference

#include "NetworkIDObject.h"
#include "NetworkIDManager.h"
#include "RakAssert.h"
#include <alloca.h>

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/NetworkIDObject.h File Reference

  • File List
  • File Members
C: » RakNet » Source

NetworkIDObject.h File Reference

A class you can derive from to make it easier to represent every networked object with an integer. This way you can refer to objects over the network. More...

#include "RakNetTypes.h"
#include "RakMemoryOverride.h"
#include "Export.h"

Classes

class NetworkIDObject
Unique shared ids for each object instance. More...

Detailed Description

A class you can derive from to make it easier to represent every networked object with an integer. This way you can refer to objects over the network.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/PacketConsoleLogger.h File Reference

  • File List
  • File Members
C: » RakNet » Source

PacketConsoleLogger.h File Reference

This will write all incoming and outgoing network messages to the log command parser, which can be accessed through Telnet. More...

#include "PacketLogger.h"

Classes

class PacketConsoleLogger
Packetlogger that logs to a remote command console. More...

Detailed Description

This will write all incoming and outgoing network messages to the log command parser, which can be accessed through Telnet.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/PacketFileLogger.h File Reference

  • File List
  • File Members
C: » RakNet » Source

PacketFileLogger.h File Reference

This will write all incoming and outgoing network messages to a file. More...

#include "PacketLogger.h"
#include <stdio.h>

Classes

class PacketFileLogger
Packetlogger that outputs to a file. More...

Detailed Description

This will write all incoming and outgoing network messages to a file.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/PacketLogger.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

PacketLogger.cpp File Reference

#include "PacketLogger.h"
#include "BitStream.h"
#include "DS_List.h"
#include "InternalPacket.h"
#include "RakPeerInterface.h"
#include "MessageIdentifiers.h"
#include "StringCompressor.h"
#include "RPCMap.h"
#include "GetTime.h"
#include <stdio.h>
#include <string.h>

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/PacketLogger.h File Reference

  • File List
  • File Members
C: » RakNet » Source

PacketLogger.h File Reference

This will write all incoming and outgoing network messages to the local console screen. See derived functions for other outputs. More...

#include "RakNetTypes.h"
#include "PluginInterface.h"
#include "Export.h"

Classes

class PacketLogger
Writes incoming and outgoing messages to the screen. This will write all incoming and outgoing messages to the console window, or to a file if you override it and give it this functionality. More...

Detailed Description

This will write all incoming and outgoing network messages to the local console screen. See derived functions for other outputs.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/PacketPriority.h File Reference

  • File List
  • File Members
C: » RakNet » Source

PacketPriority.h File Reference

This file contains enumerations for packet priority and reliability enumerations. More...

Enumerations

enum PacketPriority { , HIGH_PRIORITY, MEDIUM_PRIORITY, LOW_PRIORITY }
These enumerations are used to describe when packets are delivered. More...
enum PacketReliability {
UNRELIABLE, UNRELIABLE_SEQUENCED, RELIABLE, RELIABLE_ORDERED,
RELIABLE_SEQUENCED
}

Detailed Description

This file contains enumerations for packet priority and reliability enumerations.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Enumeration Type Documentation

enum PacketPriority

These enumerations are used to describe when packets are delivered.

Enumerator:
HIGH_PRIORITY | High priority messages are send before medium priority messages.
MEDIUM_PRIORITY | Medium priority messages are send before low priority messages.
LOW_PRIORITY | Low priority messages are only sent when no other messages are waiting.

enum PacketReliability

These enumerations are used to describe how packets are delivered.

Note:
Note to self: I write this with 3 bits in the stream. If I add more remember to change that
Enumerator:
UNRELIABLE | Same as regular UDP, except that it will also discard duplicate datagrams. RakNet adds (6 to 17) + 21 bits of overhead, 16 of which is used to detect duplicate packets and 6 to 17 of which is used for message length.
UNRELIABLE_SEQUENCED | Regular UDP with a sequence counter. Out of order messages will be discarded. This adds an additional 13 bits on top what is used for UNRELIABLE.
RELIABLE | The message is sent reliably, but not necessarily in any order. Same overhead as UNRELIABLE.
RELIABLE_ORDERED | This message is reliable and will arrive in the order you sent it. Messages will be delayed while waiting for out of order messages. Same overhead as UNRELIABLE_SEQUENCED.
RELIABLE_SEQUENCED | This message is reliable and will arrive in the sequence you sent it. Out or order messages will be dropped. Same overhead as UNRELIABLE_SEQUENCED.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/PluginInterface.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

PluginInterface.cpp File Reference

#include "PluginInterface.h"

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/PluginInterface.h File Reference

  • File List
  • File Members
C: » RakNet » Source

PluginInterface.h File Reference

RakNet's plugin functionality system. You can derive from this to create your own plugins. More...

#include "RakNetTypes.h"
#include "Export.h"
#include "RakMemoryOverride.h"

Classes

class PluginInterface
PluginInterface provides a mechanism to add functionality in a modular way. MessageHandlers should derive from PluginInterface and be attached to RakPeer using the function AttachPlugin On a user call to Receive, OnReceive is called for every PluginInterface, which can then take action based on the message passed to it. This is used to transparently add game-independent functional modules, similar to browser plugins. More...

Detailed Description

RakNet's plugin functionality system. You can derive from this to create your own plugins.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RakNetCommandParser.h File Reference

  • File List
  • File Members
C: » RakNet » Source

RakNetCommandParser.h File Reference

Contains RakNetCommandParser , used to send commands to an instance of RakPeer. More...

#include "CommandParserInterface.h"
#include "Export.h"

Classes

class RakNetCommandParser
This allows a console client to call most of the functions in RakPeer. More...

Detailed Description

Contains RakNetCommandParser , used to send commands to an instance of RakPeer.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RakNetStatistics.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

RakNetStatistics.cpp File Reference

#include "RakNetStatistics.h"
#include <stdio.h>
#include "BitStream.h"
#include "GetTime.h"
#include "RakString.h"

Functions

void RAK_DLL_EXPORT StatisticsToString (RakNetStatistics *s, char *buffer, int verbosityLevel)

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Function Documentation

void RAK_DLL_EXPORT StatisticsToString | ( | RakNetStatistics * | s,
 |  | char * | buffer,
 |  | int | verbosityLevel
 | ) |  |

Verbosity level currently supports 0 (low), 1 (medium), 2 (high)

Parameters:
[in] | s | The Statistical information to format out
[in] | buffer | The buffer containing a formated report
[in] | verbosityLevel | 0 low 1 medium 2 high

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RakNetStatistics.h File Reference

  • File List
  • File Members
C: » RakNet » Source

RakNetStatistics.h File Reference

A structure that holds all statistical data returned by RakNet. More...

#include "PacketPriority.h"
#include "Export.h"
#include "RakNetTypes.h"

Classes

struct | RakNetStatistics
Network Statisics Usage. More...

Functions

void RAK_DLL_EXPORT | StatisticsToString (RakNetStatistics *s, char *buffer, int verbosityLevel)

Detailed Description

A structure that holds all statistical data returned by RakNet.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Function Documentation

void RAK_DLL_EXPORT StatisticsToString | ( | RakNetStatistics * | s,
 |  | char * | buffer,
 |  | int | verbosityLevel
 | ) |  |

Verbosity level currently supports 0 (low), 1 (medium), 2 (high)

Parameters:
[in] | s | The Statistical information to format out
[in] | buffer | The buffer containing a formated report
[in] | verbosityLevel | 0 low 1 medium 2 high

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RakNetTransport.h File Reference

  • File List
  • File Members
C: » RakNet » Source

RakNetTransport.h File Reference

Contains RakNetTransportCommandParser and RakNetTransport used to provide a secure console connection. More...

#include "TransportInterface.h"
#include "DS_Queue.h"
#include "CommandParserInterface.h"
#include "Export.h"

Namespaces

namespace | RakNet

Classes

class | RakNetTransportCommandParser
RakNetTransport has its own command parser to enable remote users to change the command console's password. More...
class | RakNetTransport
Use RakNetTransport if you need a secure connection between the client and the console server. RakNetTransport automatically initializes security for the system. Use the project CommandConsoleClient to connect To the ConsoleServer if you use RakNetTransport. More...

Detailed Description

Contains RakNetTransportCommandParser and RakNetTransport used to provide a secure console connection.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RakNetTypes.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

RakNetTypes.cpp File Reference

#include "RakNetTypes.h"
#include <string.h>
#include <stdio.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>
#include "Itoa.h"
#include "SocketLayer.h"
#include <stdlib.h>

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RakNetTypes.h File Reference

  • File List
  • File Members
C: » RakNet » Source

RakNetTypes.h File Reference

Types used by RakNet, most of which involve user code. More...

#include "RakNetDefines.h"
#include "RakNetTypes.h"
#include "Export.h"

Namespaces

namespace | RakNet

Classes

struct | SocketDescriptor
Describes the local socket to use for RakPeer::Startup. More...
struct | SystemAddress
Unique identifier for a system. Corresponds to a network address. More...
struct | Packet
This represents a user message from another system. More...
struct | RPCParameters

Defines

#define | BITS_TO_BYTES(x) (((x)+7)>>3)
Given a number of bits, return how many bytes are needed to represent that.
#define | SystemAddress_Size 6
Size of SystemAddress data.
#define | REGISTER_STATIC_RPC(networkObject, functionName) (networkObject)->RegisterAsRemoteProcedureCall((#functionName),(functionName))
RPC Function Implementation.
#define | CLASS_MEMBER_ID(className, functionName) #className "_" #functionName
Concatenate two strings.
#define | REGISTER_CLASS_MEMBER_RPC(networkObject, className, functionName) {union {void (__cdecl className::*cFunc)( RPCParameters *rpcParms ); void* voidFunc;}; cFunc=&className::functionName; networkObject->RegisterClassMemberRPC(CLASS_MEMBER_ID(className, functionName),voidFunc);}
Register a member function of an instantiated object as a Remote procedure call. RPC member Functions MUST be marked __cdecl!
#define | UNREGISTER_STATIC_RPC(networkObject, functionName) (networkObject)->UnregisterAsRemoteProcedureCall((#functionName))

Typedefs

typedef unsigned char | UniqueIDType
See also:
NetworkIDObject.h

typedef unsigned char | MessageID
First byte of a network message.

Variables

const SystemIndex | UNASSIGNED_PLAYER_INDEX = 65535
Index of an unassigned player.
const SystemAddress | UNASSIGNED_SYSTEM_ADDRESS
Index of an invalid SystemAddress.
const NetworkID | UNASSIGNED_NETWORK_ID
Unassigned object ID.

Detailed Description

Types used by RakNet, most of which involve user code.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RakNetworkFactory.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

RakNetworkFactory.cpp File Reference

#include "LogCommandParser.h"
#include "RakNetworkFactory.h"
#include "RakPeerInterface.h"
#include "RakPeer.h"
#include "ConsoleServer.h"
#include "PacketLogger.h"
#include "RakNetCommandParser.h"
#include "ReplicaManager.h"
#include "RakNetTransport.h"
#include "TelnetTransport.h"
#include "PacketConsoleLogger.h"
#include "PacketFileLogger.h"
#include "Router.h"
#include "ConnectionGraph.h"

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RakNetworkFactory.h File Reference

  • File List
  • File Members
C: » RakNet » Source

RakNetworkFactory.h File Reference

Factory class for RakNet objects. More...

#include "Export.h"

Detailed Description

Factory class for RakNet objects.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RakPeer.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

RakPeer.cpp File Reference

#include "RakNetDefines.h"
#include "RakPeer.h"
#include "RakNetTypes.h"
#include <unistd.h>
#include <ctype.h>
#include <string.h>
#include "GetTime.h"
#include "MessageIdentifiers.h"
#include "DS_HuffmanEncodingTree.h"
#include "Rand.h"
#include "PluginInterface.h"
#include "StringCompressor.h"
#include "StringTable.h"
#include "NetworkIDObject.h"
#include "SHA1.h"
#include "RakSleep.h"
#include "RouterInterface.h"
#include "RakAssert.h"
#include "NetworkIDManager.h"
#include "DataBlockEncryptor.h"
#include <stdlib.h>

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RakPeer.h File Reference

  • File List
  • File Members
C: » RakNet » Source

RakPeer.h File Reference

The main class used for data transmission and most of RakNet's functionality. More...

#include "ReliabilityLayer.h"
#include "RakPeerInterface.h"
#include "RPCNode.h"
#include "RSACrypt.h"
#include "BitStream.h"
#include "SingleProducerConsumer.h"
#include "RPCMap.h"
#include "SimpleMutex.h"
#include "DS_OrderedList.h"
#include "Export.h"
#include "RakString.h"
#include "RakThread.h"

Classes

class | RakPeer
The main interface for network communications. More...
struct | RakPeer::MemoryBlock
Automatic Variable Synchronization Mechanism automatic variable synchronization takes a primary and secondary identifier The unique primary identifier is the index into the automaticVariableSynchronizationList The unique secondary identifier (UNASSIGNED_NETWORK_ID for none) is in an unsorted list of memory blocks. More...

Detailed Description

The main class used for data transmission and most of RakNet's functionality.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RakPeerInterface.h File Reference

  • File List
  • File Members
C: » RakNet » Source

RakPeerInterface.h File Reference

An interface for RakPeer. Simply contains all user functions as pure virtuals. More...

#include "PacketPriority.h"
#include "RakNetTypes.h"
#include "RakMemoryOverride.h"
#include "Export.h"

Namespaces

namespace | RakNet

Classes

class | RakPeerInterface
The main interface for network communications. More...

Detailed Description

An interface for RakPeer. Simply contains all user functions as pure virtuals.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/Rand.h File Reference

  • File List
  • File Members
C: » RakNet » Source

Rand.h File Reference

[Internal] Random number generator More...

#include "Export.h"

Functions

void RAK_DLL_EXPORT | seedMT (unsigned int seed)
unsigned int RAK_DLL_EXPORT | randomMT (void)
float RAK_DLL_EXPORT | frandomMT (void)

Detailed Description

[Internal] Random number generator

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Function Documentation

float RAK_DLL_EXPORT frandomMT ( void )

Gets a random float

Returns:
0 to 1.0f, inclusive

unsigned int RAK_DLL_EXPORT randomMT ( void )

Gets a random unsigned int

Returns:
an integer random value.

void RAK_DLL_EXPORT seedMT ( unsigned int seed )

Initialise seed for Random Generator

Parameters:
[in] seed The seed value for the random number generator.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ReadyEvent.h File Reference

  • File List
  • File Members
C: » RakNet » Source

ReadyEvent.h File Reference

Ready event plugin. This enables a set of systems to create a signal event, set this signal as ready or unready, and to trigger the event when all systems are ready. More...

#include "PluginInterface.h"
#include "DS_OrderedList.h"

Classes

class ReadyEvent

Enumerations

enum ReadyEventSystemStatus {
RES_NOT_WAITING, RES_WAITING, RES_READY, RES_ALL_READY,
RES_UNKNOWN_EVENT
}

Detailed Description

Ready event plugin. This enables a set of systems to create a signal event, set this signal as ready or unready, and to trigger the event when all systems are ready.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RefCountedObj.h File Reference

  • File List
  • File Members
C: » RakNet » Source

RefCountedObj.h File Reference

Reference counted object. Very simple class for quick and dirty uses. More...

#include "RakMemoryOverride.h"

Classes

class RefCountedObj
World's simplest class :). More...

Detailed Description

Reference counted object. Very simple class for quick and dirty uses.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ReliabilityLayer.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

ReliabilityLayer.cpp File Reference

#include "ReliabilityLayer.h"
#include "GetTime.h"
#include "SocketLayer.h"
#include "PluginInterface.h"
#include "RakAssert.h"
#include "Rand.h"
#include "MessageIdentifiers.h"
#include <math.h>

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ReliabilityLayer.h File Reference

  • File List
  • File Members
C: » RakNet » Source

ReliabilityLayer.h File Reference

[Internal] Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence. More...

#include "RakMemoryOverride.h"
#include "MTUSize.h"
#include "DS_LinkedList.h"
#include "DS_List.h"
#include "SocketLayer.h"
#include "PacketPriority.h"
#include "DS_Queue.h"
#include "BitStream.h"
#include "InternalPacket.h"
#include "DataBlockEncryptor.h"
#include "RakNetStatistics.h"
#include "SHA1.h"
#include "DS_OrderedList.h"
#include "DS_RangeList.h"
#include "DS_BPlusTree.h"
#include "DS_MemoryPool.h"

Classes

class | ReliabilityLayer
Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence. More...

Defines

#define | UDP_HEADER_SIZE 28
Sizeof an UDP header in byte.
#define | NUMBER_OF_ORDERED_STREAMS 32
Number of ordered streams available. You can use up to 32 ordered streams.

Detailed Description

[Internal] Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/Replica.h File Reference

  • File List
  • File Members
C: » RakNet » Source

Replica.h File Reference

Contains interface Replica used by the ReplicaManager. More...

#include "NetworkIDObject.h"
#include "PacketPriority.h"
#include "ReplicaEnums.h"

Classes

class Replica
The interface to derive your game's networked classes from. More...

Detailed Description

Contains interface Replica used by the ReplicaManager.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ReplicaEnums.h File Reference

  • File List
  • File Members
C: » RakNet » Source

ReplicaEnums.h File Reference

Contains enumerations used by the ReplicaManager system. This file is a lightweight header, so you can include it without worrying about linking in lots of other crap. More...

Enumerations

enum
enum ReplicaReturnResult {
REPLICA_PROCESS_LATER, REPLICA_PROCESSING_DONE, REPLICA_CANCEL_PROCESS, REPLICA_PROCESS_AGAIN,
REPLICA_PROCESS_IMPLICIT
}

Detailed Description

Contains enumerations used by the ReplicaManager system. This file is a lightweight header, so you can include it without worrying about linking in lots of other crap.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Enumeration Type Documentation

anonymous enum

Replica interface flags, used to enable and disable function calls on the Replica object Passed to ReplicaManager::EnableReplicaInterfaces and ReplicaManager::DisableReplicaInterfaces

enum ReplicaReturnResult

Enumerator:
REPLICA_PROCESS_LATER | This means call the function again later, with the same parameters.
REPLICA_PROCESSING_DONE | This means we are done processing (the normal result to return).
REPLICA_CANCEL_PROCESS | This means cancel the processing - don't send any network messages and don't change the current state.
REPLICA_PROCESS_AGAIN | Same as REPLICA_PROCESSING_DONE, where a message is sent, but does not clear the send bit. Useful for multi-part sends with different reliability levels. Only currently used by Replica::Serialize
REPLICA_PROCESS_IMPLICIT | Only returned from the Replica::SendConstruction interface, means act as if the other system had this object but don't actually Send a construction packet. This way you will still send scope and serialize packets to that system

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ReplicaManager.h File Reference

  • File List
  • File Members
C: » RakNet » Source

ReplicaManager.h File Reference

Contains class ReplicaManager. This system provides management for your game objects and players to make serialization, scoping, and object creation and destruction easier. More...

#include "Export.h"
#include "RakNetTypes.h"
#include "DS_OrderedList.h"
#include "PluginInterface.h"
#include "NetworkIDObject.h"
#include "DS_Queue.h"
#include "ReplicaEnums.h"

Namespaces

namespace | RakNet

Classes

class | ReceiveConstructionInterface
class | SendDownloadCompleteInterface
class | ReceiveDownloadCompleteInterface
class | ReplicaManager
A management system for your game objects and players to make serialization, scoping, and object creation and destruction easier. More...

Detailed Description

Contains class ReplicaManager. This system provides management for your game objects and players to make serialization, scoping, and object creation and destruction easier.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ReplicaManager2.h File Reference

  • File List
  • File Members
C: » RakNet » Source

ReplicaManager2.h File Reference

Contains the second iteration of the ReplicaManager class. This system automatically creates and destroys objects, downloads the world to new players, manages players, and automatically serializes as needed. More...

#include "Export.h"
#include "RakNetTypes.h"
#include "DS_Map.h"
#include "PluginInterface.h"
#include "NetworkIDObject.h"
#include "PacketPriority.h"
#include "GetTime.h"
#include "BitStream.h"
#include "DS_Queue.h"

Namespaces

namespace | RakNet

Classes

class | RakNet::ReplicaManager2
A management system for your game objects and players to make serialization, scoping, and object creation and destruction easier. More...
struct | RakNet::SerializationContext
Contextual information about serialization, passed to some functions in Replica2. More...
class | RakNet::Replica2
Base class for game objects that use the ReplicaManager2 system All game objects that want to use the ReplicaManager2 functionality must inherit from Replica2. Generally you will want to implement at a minimum Serialize(), Deserialize(), and SerializeConstruction(). More...
class | RakNet::Connection_RM2Factory
Implement this factory class to return instances of your Connection_RM2 derived object. This is used as a class factory and exposes functionality related to the connection and the system. More...
class | RakNet::Connection_RM2
This class represents a connection between two instances of ReplicaManager2 Represents a connection. Allocated by user supplied factory interface Connection_RM2Factory Implicitly created as needed Generally you will want to implement at a minimum the Construct() function, used as a factory function to create your game objects. More...

Enumerations

enum RakNet::SerializationType {
RakNet::SEND_SERIALIZATION_GENERIC_TO_SYSTEM, RakNet::BROADCAST_SERIALIZATION_GENERIC_TO_SYSTEM, RakNet::SEND_SERIALIZATION_CONSTRUCTION_TO_SYSTEM, RakNet::BROADCAST_SERIALIZATION_CONSTRUCTION_TO_SYSTEM,
RakNet::SEND_AUTO_SERIALIZE_TO_SYSTEM, RakNet::BROADCAST_AUTO_SERIALIZE_TO_SYSTEM, RakNet::RELAY_SERIALIZATION_TO_SYSTEMS, RakNet::SEND_CONSTRUCTION_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM ,
RakNet::SEND_DATA_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM, RakNet::SEND_DESTRUCTION_GENERIC_TO_SYSTEM, RakNet::SEND_DESTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM, RakNet::BROADCAST_DESTRUCTION_GENERIC_TO_SYSTEM,
RakNet::RELAY_DESTRUCTION_TO_SYSTEMS, RakNet::SEND_CONSTRUCTION_GENERIC_TO_SYSTEM, RakNet::SEND_CONSTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM, RakNet::BROADCAST_CONSTRUCTION_GENERIC_TO_SYSTEM,
RakNet::SEND_CONSTRUCTION_REQUEST_TO_SERVER, RakNet::BROADCAST_CONSTRUCTION_REQUEST_ACCEPTED_TO_SYSTEM, RakNet::SEND_CONSTRUCTION_REPLY_ACCEPTED_TO_CLIENT, RakNet::SEND_CONSTRUCTION_REPLY_DENIED_TO_CLIENT,
RakNet::SEND_VISIBILITY_TRUE_TO_SYSTEM, RakNet::BROADCAST_VISIBILITY_TRUE_TO_SYSTEM, RakNet::SEND_VISIBILITY_FALSE_TO_SYSTEM, RakNet::BROADCAST_VISIBILITY_FALSE_TO_SYSTEM,
RakNet::RELAY_VISIBILITY_TRUE_TO_SYSTEMS, RakNet::RELAY_VISIBILITY_FALSE_TO_SYSTEMS, RakNet::AUTOSERIALIZE_RESYNCH_ONLY, RakNet::AUTOSERIALIZE_DEFAULT,
RakNet::UNDEFINED_REASON
}
These are the types of events that can cause network data to be transmitted. More...

Variables

BQR_ALWAYS
The query is always true, for all systems. Certain optimizations are performed here, but you should not later return any other value without first calling ReplicaManager2::RecalculateVisibility.
BQR_YES
True.
BQR_NO
False.

Detailed Description

Contains the second iteration of the ReplicaManager class. This system automatically creates and destroys objects, downloads the world to new players, manages players, and automatically serializes as needed.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/Rijndael.h File Reference

  • File List
  • File Members
C: » RakNet » Source

Rijndael.h File Reference

[Internal] AES encoding / decoding rijndael-alg-fst.h v2.0 August '99 Optimised ANSI C code taken from the 'aescrypt' project: www.sf.net/projects/aescrypt See LICENSE-EST for the license applicable to this file More...

#include <stdio.h>

Defines

#define | MAXKC (256/32)

Functions

int | cipherUpdateRounds (cipherInstance *cipher, keyInstance *key, BYTE *input, int inputLen, BYTE *outBuffer, int Rounds)

Detailed Description

[Internal] AES encoding / decoding rijndael-alg-fst.h v2.0 August '99 Optimised ANSI C code taken from the 'aescrypt' project: www.sf.net/projects/aescrypt See LICENSE-EST for the license applicable to this file

Define Documentation

#define MAXKC (256/32)

Note:
Although the routines claim to support 192 and 256 bit blocks, don't take your chances - stick to the 128 bit (16 byte) blocks unless you've run tests to prove that 192 and 256 are correctly supported.
  • Cirilo

Function Documentation

int cipherUpdateRounds | ( | cipherInstance * | cipher,
 |  | keyInstance * | key,
 |  | BYTE * | input,
 |  | int inputLen | __UNUS,
 |  | BYTE * | outBuffer,
 |  | int | rounds
 | ) |  |

cipherUpdateRounds:

Encrypts/Decrypts exactly one full block a specified number of rounds. Only used in the Intermediate Value Known Answer Test.

Returns: TRUE - on success BAD_CIPHER_STATE - cipher in bad state (e.g., not initialized)

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/Router.h File Reference

  • File List
  • File Members
C: » RakNet » Source

Router.h File Reference

Router plugin. Allows you to send to systems you are not directly connected to, and to route those messages. More...

#include "RakNetTypes.h"
#include "PluginInterface.h"
#include "DS_OrderedList.h"
#include "DS_WeightedGraph.h"
#include "PacketPriority.h"
#include "SystemAddressList.h"
#include "RouterInterface.h"
#include "Export.h"
#include "ConnectionGraph.h"

Classes

class Router
Used to route messages between peers. More...

Detailed Description

Router plugin. Allows you to send to systems you are not directly connected to, and to route those messages.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RPCMap.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

RPCMap.cpp File Reference

#include "RPCMap.h"
#include <string.h>

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RPCMap.h File Reference

  • File List
  • File Members
C: » RakNet » Source

RPCMap.h File Reference

[Internal] A container class for a list of RPCNodes More...

#include "RakMemoryOverride.h"
#include "RPCNode.h"
#include "DS_List.h"
#include "RakNetTypes.h"
#include "Export.h"

Detailed Description

[Internal] A container class for a list of RPCNodes

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/RPCNode.h File Reference

  • File List
  • File Members
C: » RakNet » Source

RPCNode.h File Reference

[Internal] Holds information related to a RPC More...

#include "RakNetTypes.h"
#include "Export.h"

Detailed Description

[Internal] Holds information related to a RPC

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/SimpleMutex.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

SimpleMutex.cpp File Reference

#include "SimpleMutex.h"
#include <assert.h>

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/SimpleMutex.h File Reference

  • File List
  • File Members
C: » RakNet » Source

SimpleMutex.h File Reference

[Internal] Encapsulates a mutex More...

#include "RakMemoryOverride.h"
#include <pthread.h>
#include <sys/types.h>
#include "Export.h"

Classes

class SimpleMutex
An easy to use mutex. More...

Detailed Description

[Internal] Encapsulates a mutex

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/SingleProducerConsumer.h File Reference

  • File List
  • File Members
C: » RakNet » Source

SingleProducerConsumer.h File Reference

[Internal] Passes queued data between threads using a circular buffer with read and write pointers More...

#include <assert.h>
#include "RakMemoryOverride.h"
#include "Export.h"

Namespaces

namespace | DataStructures

Classes

class | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
A single producer consumer implementation without critical sections. More...

Detailed Description

[Internal] Passes queued data between threads using a circular buffer with read and write pointers

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/SocketLayer.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

SocketLayer.cpp File Reference

SocketLayer class implementation. More...

#include "SocketLayer.h"
#include <assert.h>
#include "MTUSize.h"
#include <string.h>
#include <unistd.h>
#include <fcntl.h>
#include <arpa/inet.h>
#include <errno.h>
#include <stdio.h>
#include "ExtendedOverlappedPool.h"

Detailed Description

SocketLayer class implementation.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/SocketLayer.h File Reference

  • File List
  • File Members
C: » RakNet » Source

SocketLayer.h File Reference

SocketLayer class implementation. More...

#include "RakMemoryOverride.h"
#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>
#include <netdb.h>
#include <unistd.h>

Typedefs

typedef int SOCKET
Unix/Linux uses ints for sockets.

Detailed Description

SocketLayer class implementation.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/StringCompressor.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

StringCompressor.cpp File Reference

#include "StringCompressor.h"
#include "DS_HuffmanEncodingTree.h"
#include "BitStream.h"
#include "RakString.h"
#include <assert.h>
#include <string.h>
#include <memory.h>

Detailed Description

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/StringCompressor.h File Reference

  • File List
  • File Members
C: » RakNet » Source

StringCompressor.h File Reference

Compresses/Decompresses ASCII strings and writes/reads them to BitStream class instances. You can use this to easily serialize and deserialize your own strings. More...

#include "Export.h"
#include "DS_Map.h"
#include "RakMemoryOverride.h"

Namespaces

namespace | RakNet

Classes

class | StringCompressor
Writes and reads strings to and from bitstreams. More...

Defines

#define | stringCompressor StringCompressor::Instance()

Detailed Description

Compresses/Decompresses ASCII strings and writes/reads them to BitStream class instances. You can use this to easily serialize and deserialize your own strings.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Define Documentation

#define stringCompressor StringCompressor::Instance()

Define to more easily reference the string compressor instance. The RakPeer constructor adds a reference to this class, so don't call this until an instance of RakPeer exists, or unless you call AddReference yourself.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/StringTable.h File Reference

  • File List
  • File Members
C: » RakNet » Source

StringTable.h File Reference

A simple class to encode and decode known strings based on a lookup table. Similar to the StringCompressor class. More...

#include "DS_OrderedList.h"
#include "Export.h"
#include "RakMemoryOverride.h"

Namespaces

namespace | RakNet

Classes

struct | StrAndBool
The string plus a bool telling us if this string was copied or not. More...
class | RakNet::StringTable
Writes a string index, instead of the whole string. More...

Typedefs

typedef unsigned char | StringTableType
StringTableType should be the smallest type possible, or else it defeats the purpose of the StringTable class, which is to save bandwidth.

Detailed Description

A simple class to encode and decode known strings based on a lookup table. Similar to the StringCompressor class.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/SystemAddressList.h File Reference

  • File List
  • File Members
C: » RakNet » Source

SystemAddressList.h File Reference

Just a class to hold a list of systems. More...

#include "RakNetTypes.h"
#include "DS_OrderedList.h"

Detailed Description

Just a class to hold a list of systems.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/TCPInterface.cpp File Reference

  • File List
  • File Members
C: » RakNet » Source

TCPInterface.cpp File Reference

A simple TCP based server allowing sends and receives. Can be connected to by a telnet client. More...

#include "TCPInterface.h"
#include <sys/time.h>
#include <unistd.h>
#include <pthread.h>
#include <string.h>
#include <assert.h>
#include <stdio.h>
#include "RakAssert.h"
#include "RakSleep.h"

Detailed Description

A simple TCP based server allowing sends and receives. Can be connected to by a telnet client.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/TCPInterface.h File Reference

  • File List
  • File Members
C: » RakNet » Source

TCPInterface.h File Reference

A simple TCP based server allowing sends and receives. Can be connected by any TCP client, including telnet. More...

#include <sys/types.h>
#include <sys/socket.h>
#include <sys/select.h>
#include <netinet/in.h>
#include <arpa/inet.h>
#include <netdb.h>
#include <unistd.h>
#include <pthread.h>
#include "RakMemoryOverride.h"
#include "DS_List.h"
#include "RakNetTypes.h"
#include "SingleProducerConsumer.h"
#include "Export.h"
#include "RakThread.h"
#include "DS_Queue.h"
#include "SimpleMutex.h"
#include "RakNetDefines.h"

Classes

struct | RemoteClient
Stores information about a remote client. More...

Typedefs

typedef unsigned int | SOCKET
Unix/Linux uses ints for sockets.

Detailed Description

A simple TCP based server allowing sends and receives. Can be connected by any TCP client, including telnet.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/TelnetTransport.h File Reference

  • File List
  • File Members
C: » RakNet » Source

TelnetTransport.h File Reference

Contains TelnetTransport , used to supports the telnet transport protocol. Insecure. More...

#include "TransportInterface.h"
#include "DS_List.h"
#include "Export.h"

Classes

class TelnetTransport
Use TelnetTransport to easily allow windows telnet to connect to your ConsoleServer To run Windows telnet, go to your start menu, click run, and in the edit box type "telnet <IP>" where <IP> is the ip address of your ConsoleServer (most likely the same IP as your game). This implementation always echos commands. More...

Detailed Description

Contains TelnetTransport , used to supports the telnet transport protocol. Insecure.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ThreadsafePacketLogger.h File Reference

  • File List
  • File Members
C: » RakNet » Source

ThreadsafePacketLogger.h File Reference

Derivation of the packet logger to defer the call to WriteLog until the user thread. More...

#include "PacketLogger.h"
#include "SingleProducerConsumer.h"

Classes

class ThreadsafePacketLogger
Same as PacketLogger, but writes output in the user thread. More...

Detailed Description

Derivation of the packet logger to defer the call to WriteLog until the user thread.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/TransportInterface.h File Reference

  • File List
  • File Members
C: » RakNet » Source

TransportInterface.h File Reference

Contains TransportInterface from which you can derive custom transport providers for ConsoleServer. More...

#include "RakNetTypes.h"
#include "Export.h"
#include "RakMemoryOverride.h"

Classes

class TransportInterface
Defines an interface that is used to send and receive null-terminated strings. In practice this is only used by the CommandParser system for for servers. More...

Detailed Description

Contains TransportInterface from which you can derive custom transport providers for ConsoleServer.

This file is part of RakNet Copyright 2003 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/Types.h File Reference

  • File List
  • File Members
C: » RakNet » Source

Types.h File Reference

Used for types used by RSA. More...

Namespaces

namespace | cat

Defines

#define | FALSE false
#define | TRUE true
#define | STRNCPY(dest, src, size)

Typedefs

typedef unsigned char | cat::u8
typedef signed char | cat::s8
typedef unsigned short | cat::u16
typedef signed short | cat::s16
typedef unsigned int | cat::u32
typedef signed int | cat::s32
typedef float | cat::f32
typedef double | cat::f64
typedef s32 | cat::sfp22_10
typedef u32 | cat::ufp22_10
typedef s32 | cat::sfp16_16
typedef u32 | cat::ufp16_16

Detailed Description

Used for types used by RSA.

/// Fundamental tools & types
///
/// Catid(cat02e@fsu.edu)
///
/// 8/9/2004 Added SINGLE/ARRAY_RELEASE
/// 8/5/2004 Added COMPILER_ preprocessors
///    class NoCopies
/// 8/1/2004 Removed mask stuff
/// 7/29/2004 Added swapLE, swapBE, getLE, getBE
/// 7/28/2004 Automatic and AutoArray now compile in dev-c++
///    Added pre-processor conditions to support
///    other compilers
///    Removed GETWORD and GETDWORD
/// 7/15/2004 Now using COM_RELEASE throughout CatGL3
/// 6/22/2004 Removed triple and pair
/// 6/12/2004 AutoDeallocate -> Automatic, AutoArray
/// 6/9/2004 OBJCLR
/// 5/2/2004 class AutoDeallocate
/// 5/1/2004 IS_POWER_OF_2, next_highest_power_of_2
/// 4/30/2004 Merged character manip macros
/// 2/23/2004 CEIL*
///    Removed MEMCOPY32 and MEMCLEAR32,
///    memcpy and memset are now faster
///    MAKE_MASK
/// 2/10/2004 LITTLE_ENDIAN
///    COUNT1BITS32
///    AT_LEAST_2_BITS
///    LEAST_SIGNIFICANT_BIT
/// X-mas/2003 [u/s]int?? -> [u/s]??
/// 7/3/2003 Added template triple, point->pair
/// 6/15/2003 Added template rect, point
/// 3/30/2003 Added RO?8, RO?16 and ?int64
///    Added MEMCOPY32 and MEMCLEAR32
/// 3/12/2003 Added GETWORD and GETDWORD
/// 1/16/2003 Formalized this library.
///
/// Tabs: 4 spaces
/// Dist: public
///

Define Documentation

#define FALSE false

Define an alias between FALSE and false

#define STRNCPY | ( | dest,
 |  | src,
 |  | size | )

Value:

{ \
        strncpy(dest, src, size); \
        dest[size-1] = 0; \
}
Safe null-terminated string -> char buffer copy
Parameters:
dest | the resulting string
src | the string to copy
size | the number of char to copy

#define TRUE true

Define an alias between TRUE and true

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Directory Hierarchy

RakNet Directories

This directory hierarchy is sorted roughly, but not completely, alphabetically:
  • C:
    • RakNet
      • DependentExtensions
        • AutopatcherMySQLRepository
        • AutopatcherPostgreRepository
        • bzip2-1.0.3
        • Lobby
          • LobbyDB_PostgreRepository
          • LobbyServer_PostgreSQL
          • RankingServerDB_PostgreRepository
          • TitleValidationDB_PostgreRepository
        • Lobby2
        • MySQLInterface
        • Ogre3DInterpDemo
        • openssl-0.9.8g
          • openssl
        • PatchTest
        • portaudio_v18_1
          • pa_asio
          • pa_beos
          • pa_common
          • pa_dll_switch
          • pa_mac
          • pa_mac_core
          • pa_sgi
          • pa_tests
          • pa_unix_oss
          • pa_win_ds
          • pa_win_wmme
          • pablio
        • PostgreSQLInterface
        • RPC3
        • speex-1.1.12
          • include
            • speex
          • libspeex
          • src
          • symbian
          • ti
          • win32
      • Source
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/ Directory Reference

C:

C: Directory Reference

Directories

directory RakNet
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/ Directory Reference

C: » RakNet

RakNet Directory Reference

Directories

directory | DependentExtensions
directory | Source
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/ Directory Reference

C: » RakNet » DependentExtensions

DependentExtensions Directory Reference

Directories

directory | AutopatcherMySQLRepository
directory | AutopatcherPostgreRepository
directory | bzip2-1.0.3
directory | Lobby
directory | Lobby2
directory | MySQLInterface
directory | Ogre3DInterpDemo
directory | openssl-0.9.8g
directory | PatchTest
directory | portaudio_v18_1
directory | PostgreSQLInterface
directory | RPC3
directory | speex-1.1.12

Files

file | ApplyPatch.cpp
file | ApplyPatch.h
file | AutopatcherClient.cpp
file | AutopatcherClient.h
Client plugin for the autopatcher.
file | AutopatcherServer.cpp
The server plugin for the autopatcher. Must be running for the client to get patches.
file | AutopatcherServer.h
The server plugin for the autopatcher. Must be running for the client to get patches.
file | CreatePatch.cpp
file | CreatePatch.h
file | MemoryCompressor.cpp
file | MemoryCompressor.h
file | RakVoice.cpp
file | RakVoice.h
Voice compression and transmission interface.
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/AutopatcherMySQLRepository/ Directory Reference

C: » RakNet » DependentExtensions » AutopatcherMySQLRepository

AutopatcherMySQLRepository Directory Reference

Files

file | AutopatcherMySQLRepository.cpp
file | AutopatcherMySQLRepository.h
An implementation of the AutopatcherRepositoryInterface to use MySQL to store the relevant data.
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/AutopatcherPostgreRepository/ Directory Reference

C: » RakNet » DependentExtensions » AutopatcherPostgreRepository

AutopatcherPostgreRepository Directory Reference

Files

file | AutopatcherPostgreRepository.cpp
An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data.
file | AutopatcherPostgreRepository.h
An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data.
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/bzip2-1.0.3/ Directory Reference

C: » RakNet » DependentExtensions » bzip2-1.0.3

bzip2-1.0.3 Directory Reference

Files

file | blocksort.c
file | bzip2.c
file | bzip2recover.c
file | bzlib.c
file | bzlib.h
file | bzlib_private.h
file | compress.c
file | crctable.c
file | decompress.c
file | dlltest.c
file | huffman.c
file | mk251.c
file | randtable.c
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/ Directory Reference

C: » RakNet » DependentExtensions » Lobby

Lobby Directory Reference

Directories

directory | LobbyDB_PostgreRepository
directory | LobbyServer_PostgreSQL
directory | RankingServerDB_PostgreRepository
directory | TitleValidationDB_PostgreRepository

Files

file | LobbyClientInterface.cpp
file | LobbyClientInterface.h
Interface to the lobby client. Not platform specific.
file | LobbyClientPC.cpp
file | LobbyClientPC.h
Interface to the lobby client for the PC.
file | LobbyDBSpec.cpp
file | LobbyDBSpec.h
Not code so much as a specification for the structures and classes that an implementation of the lobby server can use.
file | LobbyPCCommon.cpp
file | LobbyPCCommon.h
Common source between the lobby client and the lobby server for the PC.
file | LobbyPCTypes.h
file | LobbyServer.cpp
file | LobbyServer.h
Base class that implements the networking for the lobby server. Database specific functionality is implemented in a derived class.
file | LobbyTypes.cpp
file | LobbyTypes.h
file | RankingServerDBSpec.cpp
file | RankingServerDBSpec.h
Not code so much as a specification for the structures and classes that an implementation of the ranking server can use.
file | STDStringCompressor.cpp
file | STDStringCompressor.h
file | TitleValidationDBSpec.cpp
file | TitleValidationDBSpec.h
Not code so much as a specification for the structures and classes that an implementation of a title validation system (CD Keys and game server logins).
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/LobbyDB_PostgreRepository/ Directory Reference

C: » RakNet » DependentExtensions » Lobby » LobbyDB_PostgreRepository

LobbyDB_PostgreRepository Directory Reference

Files

file | LobbyDB_PostgreSQL.cpp
An implementation of the LobbyServer database to use PostgreSQL to store the relevant data.
file | LobbyDB_PostgreSQL.h
An implementation of the LobbyServer database to use PostgreSQL to store the relevant data.
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/LobbyServer_PostgreSQL/ Directory Reference

C: » RakNet » DependentExtensions » Lobby » LobbyServer_PostgreSQL

LobbyServer_PostgreSQL Directory Reference

Files

file | LobbyServer_PostgreSQL.cpp
file | LobbyServer_PostgreSQL.h
Base class that implements the networking for the lobby server. Database specific functionality is implemented in a derived class.
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/RankingServerDB_PostgreRepository/ Directory Reference

C: » RakNet » DependentExtensions » Lobby » RankingServerDB_PostgreRepository

RankingServerDB_PostgreRepository Directory Reference

Files

file | Elo.cpp
file | Elo.h
file | RankingServer_PostgreSQL.cpp
An implementation of the RankingRepositoryInterface to use PostgreSQL to store the relevant data.
file | RankingServer_PostgreSQL.h
An implementation of the RankingServerPostgreRepository to use PostgreSQL to store ranking info for users.
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby/TitleValidationDB_PostgreRepository/ Directory Reference

C: » RakNet » DependentExtensions » Lobby » TitleValidationDB_PostgreRepository

TitleValidationDB_PostgreRepository Directory Reference

Files

file | TitleValidationDB_PostgreSQL.cpp
An implementation of TitleValidationDBSpec.h to use PostgreSQL. Title validation is useful for checking server logins and cd keys.
file | TitleValidationDB_PostgreSQL.h
An implementation of TitleValidationDBSpec.h to use PostgreSQL. Title validation is useful for checking server logins and cd keys.
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Lobby2/ Directory Reference

C: » RakNet » DependentExtensions » Lobby2

Lobby2 Directory Reference

Files

file | LobbyClient.cpp
file | LobbyClient.h
file | LobbyClientPC.cpp
file | LobbyClientPC.h
file | LobbyErrorCodes.cpp
file | LobbyErrorCodes.h
file | LobbyProcedures.cpp
file | LobbyProcedures.h
file | LobbyProcedures_Factory.h
file | LobbyProcedures_Factory_PGSQL.cpp
file | LobbyProcedures_Factory_PGSQL.h
file | LobbyProcedures_PGSQL.cpp
file | LobbyProcedures_PGSQL.h
file | LobbyRooms.cpp
file | LobbyRooms.h
file | LobbyServer.cpp
file | LobbyServer.h
file | LobbyTypes.cpp
file | LobbyTypes.h
file | LobbyTypesPC.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/MySQLInterface/ Directory Reference

C: » RakNet » DependentExtensions » MySQLInterface

MySQLInterface Directory Reference

Files

file | MySQLInterface.cpp
file | MySQLInterface.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/Ogre3DInterpDemo/ Directory Reference

C: » RakNet » DependentExtensions » Ogre3DInterpDemo

Ogre3DInterpDemo Directory Reference

Files

file | App3D.cpp
file | App3D.h
file | AppInterface.cpp
file | AppInterface.h
file | AppTypes.h
file | FSM.cpp
file | FSM.h
file | OverlayHelper.cpp
file | OverlayHelper.h
file | RunnableState.cpp
file | RunnableState.h
file | State.cpp
file | State.h
file | TransformationHistory.cpp
file | TransformationHistory.h
file | WinMain.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/openssl-0.9.8g/ Directory Reference

C: » RakNet » DependentExtensions » openssl-0.9.8g

openssl-0.9.8g Directory Reference

Directories

directory openssl
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/openssl-0.9.8g/openssl/ Directory Reference

C: » RakNet » DependentExtensions » openssl-0.9.8g » openssl

openssl Directory Reference

Files

file | aes.h
file | applink.c
file | asn1.h
file | asn1_mac.h
file | asn1t.h
file | bio.h
file | blowfish.h
file | bn.h
file | buffer.h
file | cast.h
file | comp.h
file | conf.h
file | conf_api.h
file | crypto.h
file | des.h
file | des_old.h
file | dh.h
file | dsa.h
file | dso.h
file | dtls1.h
file | e_os2.h
file | ebcdic.h
file | ec.h
file | ecdh.h
file | ecdsa.h
file | engine.h
file | err.h
file | evp.h
file | hmac.h
file | idea.h
file | krb5_asn.h
file | kssl.h
file | lhash.h
file | md2.h
file | md4.h
file | md5.h
file | obj_mac.h
file | objects.h
file | ocsp.h
file | opensslconf.h
file | opensslv.h
file | ossl_typ.h
file | pem.h
file | pem2.h
file | pkcs12.h
file | pkcs7.h
file | pq_compat.h
file | pqueue.h
file | rand.h
file | rc2.h
file | rc4.h
file | ripemd.h
file | rsa.h
file | safestack.h
file | sha.h
file | ssl.h
file | ssl2.h
file | ssl23.h
file | ssl3.h
file | stack.h
file | store.h
file | symhacks.h
file | tls1.h
file | tmdiff.h
file | txt_db.h
file | ui.h
file | ui_compat.h
file | x509.h
file | x509_vfy.h
file | x509v3.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/PatchTest/ Directory Reference

C: » RakNet » DependentExtensions » PatchTest

PatchTest Directory Reference

Files

file main.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/portaudio_v18_1/ Directory Reference

C: » RakNet » DependentExtensions » portaudio_v18_1

portaudio_v18_1 Directory Reference

Directories

directory | pa_asio
directory | pa_beos
directory | pa_common
directory | pa_dll_switch
directory | pa_mac
directory | pa_mac_core
directory | pa_sgi
directory | pa_tests
directory | pa_unix_oss
directory | pa_win_ds
directory | pa_win_wmme
directory | pablio
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/portaudio_v18_1/pa_asio/ Directory Reference

C: » RakNet » DependentExtensions » portaudio_v18_1 » pa_asio

pa_asio Directory Reference

Files

file pa_asio.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/portaudio_v18_1/pa_beos/ Directory Reference

C: » RakNet » DependentExtensions » portaudio_v18_1 » pa_beos

pa_beos Directory Reference

Files

file | pa_beos_mk.cc
file | playbacknode.cc
file | PlaybackNode.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/portaudio_v18_1/pa_common/ Directory Reference

C: » RakNet » DependentExtensions » portaudio_v18_1 » pa_common

pa_common Directory Reference

Files

file | pa_convert.c
file | pa_host.h
file | pa_lib.c
file | pa_trace.c
file | pa_trace.h
file | portaudio.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/portaudio_v18_1/pa_dll_switch/ Directory Reference

C: » RakNet » DependentExtensions » portaudio_v18_1 » pa_dll_switch

pa_dll_switch Directory Reference

Files

file | loadPA_DLL.cpp
file | pa_lib.c
file | PaDllEntry.h
file | portaudio.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/portaudio_v18_1/pa_mac/ Directory Reference

C: » RakNet » DependentExtensions » portaudio_v18_1 » pa_mac

pa_mac Directory Reference

Files

file pa_mac.c
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/portaudio_v18_1/pa_mac_core/ Directory Reference

C: » RakNet » DependentExtensions » portaudio_v18_1 » pa_mac_core

pa_mac_core Directory Reference

Files

file pa_mac_core.c
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/portaudio_v18_1/pa_sgi/ Directory Reference

C: » RakNet » DependentExtensions » portaudio_v18_1 » pa_sgi

pa_sgi Directory Reference

Files

file | pa_sgi.c
file | pthread-pa_sgi.c
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/portaudio_v18_1/pa_tests/ Directory Reference

C: » RakNet » DependentExtensions » portaudio_v18_1 » pa_tests

pa_tests Directory Reference

Files

file | debug_convert.c
file | debug_dither_calc.c
file | debug_dual.c
file | debug_multi_in.c
file | debug_multi_out.c
file | debug_record.c
file | debug_record_reuse.c
file | debug_sine.c
file | debug_sine_amp.c
file | debug_sine_formats.c
file | debug_sine_getchar.c
file | debug_srate.c
file | debug_test1.c
file | pa_devs.c
file | pa_fuzz.c
file | pa_minlat.c
file | paqa_devs.c
file | paqa_errs.c
file | patest1.c
file | patest_buffer.c
file | patest_clip.c
file | patest_dither.c
file | patest_hang.c
file | patest_latency.c
file | patest_leftright.c
file | patest_longsine.c
file | patest_many.c
file | patest_maxsines.c
file | patest_mono.c
file | patest_multi_sine.c
file | patest_pink.c
file | patest_record.c
file | patest_ringmix.c
file | patest_saw.c
file | patest_sine.c
file | patest_sine8.c
file | patest_sine_formats.c
file | patest_sine_time.c
file | patest_stop.c
file | patest_sync.c
file | patest_toomanysines.c
file | patest_two_rates.c
file | patest_underflow.c
file | patest_wire.c
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/portaudio_v18_1/pa_unix_oss/ Directory Reference

C: » RakNet » DependentExtensions » portaudio_v18_1 » pa_unix_oss

pa_unix_oss Directory Reference

Files

file | pa_unix.c
file | pa_unix.h
file | pa_unix_oss.c
file | pa_unix_solaris.c
file | recplay.c
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/portaudio_v18_1/pa_win_ds/ Directory Reference

C: » RakNet » DependentExtensions » portaudio_v18_1 » pa_win_ds

pa_win_ds Directory Reference

Files

file | dsound_wrapper.c
file | dsound_wrapper.h
file | pa_dsound.c
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/portaudio_v18_1/pa_win_wmme/ Directory Reference

C: » RakNet » DependentExtensions » portaudio_v18_1 » pa_win_wmme

pa_win_wmme Directory Reference

Files

file pa_win_wmme.c
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/portaudio_v18_1/pablio/ Directory Reference

C: » RakNet » DependentExtensions » portaudio_v18_1 » pablio

pablio Directory Reference

Files

file | pablio.c
file | pablio.h
file | ringbuffer.c
file | ringbuffer.h
file | test_rw.c
file | test_rw_echo.c
file | test_w_saw.c
file | test_w_saw8.c
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/PostgreSQLInterface/ Directory Reference

C: » RakNet » DependentExtensions » PostgreSQLInterface

PostgreSQLInterface Directory Reference

Files

file | PostgreSQLInterface.cpp
file | PostgreSQLInterface.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/RPC3/ Directory Reference

C: » RakNet » DependentExtensions » RPC3

RPC3 Directory Reference

Files

file | RPC3.cpp
file | RPC3.h
Automatically serializing and deserializing RPC system. Third generation of RPC.
file | RPC3_Boost.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/ Directory Reference

C: » RakNet » DependentExtensions » speex-1.1.12

speex-1.1.12 Directory Reference

Directories

directory | include
directory | libspeex
directory | src
directory | symbian
directory | ti
directory | win32
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/include/ Directory Reference

C: » RakNet » DependentExtensions » speex-1.1.12 » include

include Directory Reference

Directories

directory speex
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/include/speex/ Directory Reference

C: » RakNet » DependentExtensions » speex-1.1.12 » include » speex

speex Directory Reference

Files

file | pcm_wrapper.h
PCM encoding wrapped as a Speex mode.
file | speex.h
Describes the different modes of the codec.
file | speex_bits.h
Handles bit packing/unpacking.
file | speex_callbacks.h
Describes callback handling and in-band signalling.
file | speex_echo.h
Echo cancellation.
file | speex_header.h
Describes the Speex header.
file | speex_jitter.h
Adaptive jitter buffer for Speex.
file | speex_preprocess.h
Speex preprocessor.
file | speex_stereo.h
Describes the handling for intensity stereo.
file | speex_types.h
Speex types.
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/libspeex/ Directory Reference

C: » RakNet » DependentExtensions » speex-1.1.12 » libspeex

libspeex Directory Reference

Files

file | _kiss_fft_guts.h
file | arch.h
Various architecture definitions Speex.
file | bits.c
file | cb_search.c
file | cb_search.h
Overlapped codebook search.
file | cb_search_arm4.h
Fixed codebook functions (ARM4 version).
file | cb_search_bfin.h
Fixed codebook functions (Blackfin version).
file | cb_search_sse.h
Fixed codebook functions (SSE version).
file | exc_10_16_table.c
file | exc_10_32_table.c
file | exc_20_32_table.c
file | exc_5_256_table.c
file | exc_5_64_table.c
file | exc_8_128_table.c
file | fftwrap.c
file | fftwrap.h
file | filters.c
file | filters.h
Various analysis/synthesis filters.
file | filters_arm4.h
Various analysis/synthesis filters (ARM4 version).
file | filters_bfin.h
Various analysis/synthesis filters (Blackfin version).
file | filters_sse.h
Various analysis/synthesis filters (SSE version).
file | fixed_arm4.h
ARM4 fixed-point operations.
file | fixed_arm5e.h
ARM-tuned fixed-point operations.
file | fixed_bfin.h
Blackfin fixed-point operations.
file | fixed_debug.h
Fixed-point operations with debugging.
file | fixed_generic.h
Generic fixed-point operations.
file | gain_table.c
file | gain_table_lbr.c
file | hexc_10_32_table.c
file | hexc_table.c
file | high_lsp_tables.c
file | jitter.c
file | kiss_fft.c
file | kiss_fft.h
file | kiss_fftr.c
file | kiss_fftr.h
file | lbr_48k_tables.c
file | lpc.c
file | lpc.h
Functions for LPC (Linear Prediction Coefficients) analysis.
file | lpc_bfin.h
Functions for LPC (Linear Prediction Coefficients) analysis (Blackfin version).
file | lsp.c
file | lsp.h
Line Spectral Pair (LSP) functions.
file | lsp_tables_nb.c
file | ltp.c
file | ltp.h
Long-Term Prediction functions.
file | ltp_arm4.h
Long-Term Prediction functions (ARM4 version).
file | ltp_bfin.h
Long-Term Prediction functions (Blackfin version).
file | ltp_sse.h
Long-Term Prediction functions (SSE version).
file | math_approx.c
file | math_approx.h
Various math approximation functions for Speex.
file | mdf.c
file | misc.c
file | misc.h
Various compatibility routines for Speex.
file | misc_bfin.h
Various compatibility routines for Speex (Blackfin version).
file | modes.c
file | modes.h
Describes the different modes of the codec.
file | nb_celp.c
file | nb_celp.h
Narrowband CELP encoder/decoder.
file | pcm_wrapper.c
PCM encoding wrapped as a Speex mode.
file | preprocess.c
file | pseudofloat.h
Pseudo-floating point.
file | quant_lsp.c
file | quant_lsp.h
LSP vector quantization.
file | sb_celp.c
file | sb_celp.h
Sub-band CELP mode used for wideband encoding.
file | smallft.c
file | smallft.h
Discrete Rotational Fourier Transform (DRFT).
file | speex.c
file | speex_callbacks.c
file | speex_header.c
file | stack_alloc.h
Temporary memory allocation on stack.
file | stereo.c
file | vbr.c
file | vbr.h
Variable Bit-Rate (VBR) related routines.
file | vorbis_psy.c
file | vorbis_psy.h
file | vq.c
file | vq.h
Vector quantization.
file | vq_arm4.h
ARM4-optimized vq routine.
file | vq_bfin.h
Blackfin-optimized vq routine.
file | vq_sse.h
SSE-optimized vq routine.
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/src/ Directory Reference

C: » RakNet » DependentExtensions » speex-1.1.12 » src

src Directory Reference

Files

file | getopt.c
file | getopt1.c
file | getopt_win.h
file | speexdec.c
file | speexenc.c
file | wav_io.c
file | wav_io.h
file | wave_out.c
file | wave_out.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/symbian/ Directory Reference

C: » RakNet » DependentExtensions » speex-1.1.12 » symbian

symbian Directory Reference

Files

file config.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/ti/ Directory Reference

C: » RakNet » DependentExtensions » speex-1.1.12 » ti

ti Directory Reference

Files

file | config.h
file | testenc-TI-C5x.c
file | testenc-TI-C64x.c
file | user_misc.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/DependentExtensions/speex-1.1.12/win32/ Directory Reference

C: » RakNet » DependentExtensions » speex-1.1.12 » win32

win32 Directory Reference

Files

file config.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: C:/RakNet/Source/ Directory Reference

C: » RakNet » Source

Source Directory Reference

Files

file | _FindFirst.cpp
file | _FindFirst.h
file | AsynchronousFileIO.cpp
file | AsynchronousFileIO.h
[Internal] Depreciated, used for windows back when I supported IO completion ports.
file | AutopatcherPatchContext.h
file | AutopatcherRepositoryInterface.h
An interface used by AutopatcherServer to get the data necessary to run an autopatcher.
file | AutoRPC.cpp
file | AutoRPC.h
Automatically serializing and deserializing RPC system. More advanced RPC, but possibly not cross-platform.
file | BigTypes.h
[Internal] Used for RSA generation.
file | BitStream.cpp
file | BitStream.h
This class allows you to write and read native types as a string of bits. BitStream is used extensively throughout RakNet and is designed to be used by users as well.
file | BitStream_NoTemplate.cpp
file | BitStream_NoTemplate.h
This class allows you to write and read native types as a string of bits. BitStream is used extensively throughout RakNet and is designed to be used by users as well.
file | CheckSum.cpp
CheckSum implementation from http://www.flounder.com/checksum.htm.
file | CheckSum.h
[Internal] Generates and validates checksums
file | ClientContextStruct.h
[Internal] Depreciated, back from when I supported IO Completion ports.
file | CommandParserInterface.cpp
file | CommandParserInterface.h
Contains CommandParserInterface , from which you derive custom command parsers.
file | ConnectionGraph.cpp
file | ConnectionGraph.h
Connection graph plugin. This maintains a graph of connections for the entire network, so every peer knows about every other peer.
file | ConsoleServer.cpp
file | ConsoleServer.h
Contains ConsoleServer , used to plugin to your game to accept remote console-based connections.
file | DataBlockEncryptor.cpp
file | DataBlockEncryptor.h
[Internal] Encrypts and decrypts data blocks. Used as part of secure connections.
file | DataCompressor.cpp
file | DataCompressor.h
DataCompressor does compression on a block of data. Not very good compression, but it's small and fast so is something you can use per-message at runtime.
file | DirectoryDeltaTransfer.cpp
file | DirectoryDeltaTransfer.h
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.
file | DS_BinarySearchTree.h
[Internal] A binary search tree, and an AVL balanced BST derivation.
file | DS_BPlusTree.h
file | DS_BytePool.cpp
file | DS_BytePool.h
file | DS_ByteQueue.cpp
file | DS_ByteQueue.h
[Internal] Byte queue
file | DS_Heap.h
[Internal] Heap (Also serves as a priority queue)
file | DS_HuffmanEncodingTree.cpp
file | DS_HuffmanEncodingTree.h
[Internal] Generates a huffman encoding tree, used for string and global compression.
file | DS_HuffmanEncodingTreeFactory.h
[Internal] Creates instances of the class HuffmanEncodingTree
file | DS_HuffmanEncodingTreeNode.h
[Internal] A single node in the Huffman Encoding Tree.
file | DS_LinkedList.h
[Internal] Straightforward linked list data structure.
file | DS_List.h
[Internal] Array based list. Usually the Queue class is used instead, since it has all the same functionality and is only worse at random access.
file | DS_Map.h
[Internal] Map
file | DS_MemoryPool.h
file | DS_OrderedChannelHeap.h
[Internal] Ordered Channel Heap . This is a heap where you add to it on multiple ordered channels, with each channel having a different weight.
file | DS_OrderedList.h
[Internal] Quicksort ordered list.
file | DS_Queue.h
[Internal] A queue used by RakNet.
file | DS_QueueLinkedList.h
[Internal] A queue implemented as a linked list.
file | DS_RangeList.h
file | DS_Table.cpp
file | DS_Table.h
file | DS_Tree.h
[Internal] Just a regular tree
file | DS_WeightedGraph.h
[Internal] Weighted graph. I'm assuming the indices are complex map types, rather than sequential numbers (which could be implemented much more efficiently).
file | EmailSender.cpp
file | EmailSender.h
Rudimentary class to send email from code. Don't expect anything fancy.
file | EncodeClassName.cpp
file | EpochTimeToString.cpp
file | EpochTimeToString.h
file | Export.h
file | ExtendedOverlappedPool.cpp
file | ExtendedOverlappedPool.h
[Depreciated] This was used for IO completion ports.
file | FileList.cpp
file | FileList.h
file | FileListTransfer.cpp
file | FileListTransfer.h
A plugin to provide a simple way to compress and incrementally send the files in the FileList structure.
file | FileListTransferCBInterface.h
file | FileOperations.cpp
file | FileOperations.h
file | FormatString.cpp
file | FormatString.h
file | FullyConnectedMesh.cpp
file | FullyConnectedMesh.h
Fully connected mesh plugin. This will connect RakPeer to all connecting peers, and all peers the connecting peer knows about.
file | FunctionThread.cpp
file | FunctionThread.h
A set of classes to make it easier to perform asynchronous function processing.
file | Gen_RPC8.cpp
file | Gen_RPC8.h
file | GetTime.cpp
file | GetTime.h
Returns the value from QueryPerformanceCounter. This is the function RakNet uses to represent time.
file | GridSectorizer.cpp
file | GridSectorizer.h
file | HTTPConnection.cpp
Contains HTTPConnection, used to communicate with web servers.
file | HTTPConnection.h
Contains HTTPConnection, used to communicate with web servers.
file | InlineFunctor.cpp
file | InlineFunctor.h
file | InternalPacket.h
[Internal] A class which stores a user message, and all information associated with sending and receiving that message.
file | Itoa.cpp
file | Itoa.h
file | Kbhit.h
file | LightweightDatabaseClient.cpp
file | LightweightDatabaseClient.h
Contains the client interface to the simple database included with RakNet, useful for a server browser or a lobby server.
file | LightweightDatabaseCommon.cpp
file | LightweightDatabaseCommon.h
file | LightweightDatabaseServer.cpp
file | LightweightDatabaseServer.h
A simple flat database included with RakNet, useful for a server browser or a lobby server.
file | LinuxStrings.cpp
file | LinuxStrings.h
file | LogCommandParser.cpp
file | LogCommandParser.h
Contains LogCommandParser , Used to send logs to connected consoles.
file | MessageFilter.cpp
file | MessageFilter.h
Message filter plugin. Assigns systems to FilterSets. Each FilterSet limits what messages are allowed. This is a security related plugin.
file | MessageIdentifiers.h
All the message identifiers used by RakNet. Message identifiers comprise the first byte of any message.
file | MTUSize.h
[Internal] Defines the default maximum transfer unit.
file | NatPunchthrough.cpp
file | NatPunchthrough.h
Contains the NAT-punchthrough plugin.
file | NetworkIDManager.cpp
file | NetworkIDManager.h
file | NetworkIDObject.cpp
file | NetworkIDObject.h
A class you can derive from to make it easier to represent every networked object with an integer. This way you can refer to objects over the network.
file | PacketConsoleLogger.cpp
file | PacketConsoleLogger.h
This will write all incoming and outgoing network messages to the log command parser, which can be accessed through Telnet.
file | PacketFileLogger.cpp
file | PacketFileLogger.h
This will write all incoming and outgoing network messages to a file.
file | PacketLogger.cpp
file | PacketLogger.h
This will write all incoming and outgoing network messages to the local console screen. See derived functions for other outputs.
file | PacketPool.h
file | PacketPriority.h
This file contains enumerations for packet priority and reliability enumerations.
file | PluginInterface.cpp
file | PluginInterface.h
RakNet's plugin functionality system. You can derive from this to create your own plugins.
file | RakAssert.h
file | RakMemoryOverride.cpp
file | RakMemoryOverride.h
file | RakNetCommandParser.cpp
file | RakNetCommandParser.h
Contains RakNetCommandParser , used to send commands to an instance of RakPeer.
file | RakNetDefines.h
file | RakNetStatistics.cpp
file | RakNetStatistics.h
A structure that holds all statistical data returned by RakNet.
file | RakNetTransport.cpp
file | RakNetTransport.h
Contains RakNetTransportCommandParser and RakNetTransport used to provide a secure console connection.
file | RakNetTypes.cpp
file | RakNetTypes.h
Types used by RakNet, most of which involve user code.
file | RakNetVersion.h
file | RakNetworkFactory.cpp
file | RakNetworkFactory.h
Factory class for RakNet objects.
file | RakPeer.cpp
file | RakPeer.h
The main class used for data transmission and most of RakNet's functionality.
file | RakPeerInterface.h
An interface for RakPeer. Simply contains all user functions as pure virtuals.
file | RakSleep.cpp
file | RakSleep.h
file | RakString.cpp
file | RakString.h
file | RakThread.cpp
file | RakThread.h
file | Rand.cpp
file | Rand.h
[Internal] Random number generator
file | ReadyEvent.cpp
file | ReadyEvent.h
Ready event plugin. This enables a set of systems to create a signal event, set this signal as ready or unready, and to trigger the event when all systems are ready.
file | RefCountedObj.h
Reference counted object. Very simple class for quick and dirty uses.
file | ReliabilityLayer.cpp
file | ReliabilityLayer.h
[Internal] Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence.
file | Replica.h
Contains interface Replica used by the ReplicaManager.
file | ReplicaEnums.h
Contains enumerations used by the ReplicaManager system. This file is a lightweight header, so you can include it without worrying about linking in lots of other crap.
file | ReplicaManager.cpp
file | ReplicaManager.h
Contains class ReplicaManager. This system provides management for your game objects and players to make serialization, scoping, and object creation and destruction easier.
file | ReplicaManager2.cpp
file | ReplicaManager2.h
Contains the second iteration of the ReplicaManager class. This system automatically creates and destroys objects, downloads the world to new players, manages players, and automatically serializes as needed.
file | Rijndael-Boxes.h
file | rijndael.cpp
file | Rijndael.h
[Internal] AES encoding / decoding rijndael-alg-fst.h v2.0 August '99 Optimised ANSI C code taken from the 'aescrypt' project: www.sf.net/projects/aescrypt See LICENSE-EST for the license applicable to this file
file | Router.cpp
file | Router.h
Router plugin. Allows you to send to systems you are not directly connected to, and to route those messages.
file | RouterInterface.h
file | RPCMap.cpp
file | RPCMap.h
[Internal] A container class for a list of RPCNodes
file | RPCNode.h
[Internal] Holds information related to a RPC
file | RSACrypt.h
file | SHA1.cpp
file | SHA1.h
file | SimpleMutex.cpp
file | SimpleMutex.h
[Internal] Encapsulates a mutex
file | SimpleTCPServer.h
file | SingleProducerConsumer.h
[Internal] Passes queued data between threads using a circular buffer with read and write pointers
file | SocketLayer.cpp
SocketLayer class implementation.
file | SocketLayer.h
SocketLayer class implementation.
file | StringCompressor.cpp
file | StringCompressor.h
Compresses/Decompresses ASCII strings and writes/reads them to BitStream class instances. You can use this to easily serialize and deserialize your own strings.
file | StringTable.cpp
file | StringTable.h
A simple class to encode and decode known strings based on a lookup table. Similar to the StringCompressor class.
file | SuperFastHash.cpp
file | SuperFastHash.h
file | SystemAddressList.cpp
file | SystemAddressList.h
Just a class to hold a list of systems.
file | TableSerializer.cpp
file | TableSerializer.h
file | TCPInterface.cpp
A simple TCP based server allowing sends and receives. Can be connected to by a telnet client.
file | TCPInterface.h
A simple TCP based server allowing sends and receives. Can be connected by any TCP client, including telnet.
file | TelnetTransport.cpp
file | TelnetTransport.h
Contains TelnetTransport , used to supports the telnet transport protocol. Insecure.
file | ThreadPool.h
file | ThreadsafePacketLogger.cpp
file | ThreadsafePacketLogger.h
Derivation of the packet logger to defer the call to WriteLog until the user thread.
file | TransportInterface.h
Contains TransportInterface from which you can derive custom transport providers for ConsoleServer.
file | Types.h
Used for types used by RSA.
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- _ -

  • _speex_putc() : misc.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Page Index

RakNet Related Pages

Here is a list of all related documentation pages:
  • Todo List
  • Deprecated List
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Todo List

Todo List

Member RakNet::LobbyClientPC::QuickMatch (int requiredPlayers, int timeoutInSeconds)
This feature is currently hacked in and will start games but does not honor the requiredPlayers. In the near future I will have it working properly
Precondition:
You must be in the lobby to start this function
See also:
LobbyClientInterfaceCB::QuickMatch_Result()

LobbyClientInterfaceCB::StartGame_Notify()

LobbyClientInterfaceCB::QuickMatchTimeout_Notify()

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Deprecated List

Deprecated List

Member Packet::length
You should use bitSize.

Class ReplicaManager
Use RM2_ReplicaManager in ReplicaManager2.h ReplicaManager is a system manager for your game objects that performs the following tasks: 1. Tracks all locally registered game objects and players and only performs operations to and for those objects and players 2. Allows you to automatically turn off unneeded local and remote functions for your game objects, thus providing convenience and security against unauthorized sends. 3. Sends notifications of existing game objects to new connections, including a download complete message. 4. Sends notifications of new game objects to existing players. A. Serialize and scoping calls are not sent to objects that were not notified of that object. B. Notification calls can be canceled on a per-object basis. Object notification sends are tracked on a per-system per-object basis. 5. Configurable per-system per-object scoping. A. Scoping provides a mechanism to hide and unhide remote objects without destroying the whole object, used when when entities should not be destroyed but are currently not visible to systems. B. Serialize calls are not sent to hidden objects. C. Scoping calls can be canceled on a per-object basis. Scope is tracked on a per-system per-object basis. 6. Replicate, SetScope, SignalSerializeNeeded, and the corresponding Replica interfaces are processed in RakPeer::Receive, rather than immediately. A. This allows the ReplicaManager to reorganize function calls in order by dependency. This allows out of order calls, per-object call cancellation (which also cancels dependencies), and per-object call delays (which also delays dependencies) B. For example, although SetScope and SignalSerializeNeeded have a dependency on SetNetworkID(), you can still call them in the constructor and call SetNetworkID() later, as long as it happens before calling RakPeer::Receive() 7. The system is fast, uses little memory, and is intentionally hands off such that it can work with any game architecture and network topology

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

AutopatcherMySQLRepository Member List

This is the complete list of members for AutopatcherMySQLRepository, including all inherited members.

AddApplication(const char *applicationName, const char *userName) | AutopatcherMySQLRepository |
CreateAutopatcherTables(void) | AutopatcherMySQLRepository |
DestroyAutopatcherTables(void) | AutopatcherMySQLRepository |
GetChangelistSinceDate(const char *applicationName, FileList *addedFiles, FileList *deletedFiles, const char *sinceDate, char currentDate[64]) | AutopatcherMySQLRepository | [virtual]
GetLastError(void) const | AutopatcherMySQLRepository | [virtual]
GetPatches(const char *applicationName, FileList *input, FileList *patchList, char currentDate[64]) | AutopatcherMySQLRepository | [virtual]
RemoveApplication(const char *applicationName) | AutopatcherMySQLRepository |
UpdateApplicationFiles(const char *applicationName, const char *applicationDirectory, const char *userName, FileListProgress *cb) | AutopatcherMySQLRepository |

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

AutopatcherPostgreRepository Member List

This is the complete list of members for AutopatcherPostgreRepository, including all inherited members.

AddApplication(const char *applicationName, const char *userName) | AutopatcherPostgreRepository |
CreateAutopatcherTables(void) | AutopatcherPostgreRepository |
DestroyAutopatcherTables(void) | AutopatcherPostgreRepository |
GetChangelistSinceDate(const char *applicationName, FileList *addedFiles, FileList *deletedFiles, const char *sinceDate, char currentDate[64]) | AutopatcherPostgreRepository | [virtual]
GetLastError(void) const | AutopatcherPostgreRepository | [virtual]
GetPatches(const char *applicationName, FileList *input, FileList *patchList, char currentDate[64]) | AutopatcherPostgreRepository | [virtual]
RemoveApplication(const char *applicationName) | AutopatcherPostgreRepository |
UpdateApplicationFiles(const char *applicationName, const char *applicationDirectory, const char *userName, FileListProgress *cb) | AutopatcherPostgreRepository |

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

AutopatcherRepositoryInterface Member List

This is the complete list of members for AutopatcherRepositoryInterface, including all inherited members.

GetChangelistSinceDate(const char *applicationName, FileList *addedFiles, FileList *deletedFiles, const char *sinceDate, char currentDate[64])=0 | AutopatcherRepositoryInterface | [pure virtual]
GetLastError(void) const =0 | AutopatcherRepositoryInterface | [pure virtual]
GetPatches(const char *applicationName, FileList *input, FileList *patchList, char currentDate[64])=0 | AutopatcherRepositoryInterface | [pure virtual]

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

CheckSum Member List

This is the complete list of members for CheckSum, including all inherited members.

CheckSum() CheckSum [inline]

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

CommandParserInterface Member List

This is the complete list of members for CommandParserInterface, including all inherited members.

GetName(void) const =0 | CommandParserInterface | [pure virtual]
IntegersToSystemAddress(int binaryAddress, int port) | CommandParserInterface | [protected]
OnCommand(const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, SystemAddress systemAddress, const char *originalString)=0 | CommandParserInterface | [pure virtual]
OnConnectionLost(SystemAddress systemAddress, TransportInterface *transport) | CommandParserInterface | [virtual]
OnNewIncomingConnection(SystemAddress systemAddress, TransportInterface *transport) | CommandParserInterface | [virtual]
OnTransportChange(TransportInterface *transport) | CommandParserInterface | [virtual]
RegisterCommand(unsigned char parameterCount, const char *command, const char *commandHelp) | CommandParserInterface | [protected, virtual]
ReturnResult(bool res, const char *command, TransportInterface *transport, SystemAddress systemAddress) | CommandParserInterface | [protected, virtual]
ReturnResult(const char *command, TransportInterface *transport, SystemAddress systemAddress) | CommandParserInterface | [protected, virtual]
SendHelp(TransportInterface *transport, SystemAddress systemAddress)=0 | CommandParserInterface | [pure virtual]

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

ConnectionGraph Member List

This is the complete list of members for ConnectionGraph, including all inherited members.

AddNewConnection(RakPeerInterface *peer, SystemAddress systemAddress, ConnectionGraphGroupID groupId) | ConnectionGraph |
GetGraph(void) | ConnectionGraph |
OnAttach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | ConnectionGraph | [virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | ConnectionGraph | [virtual]
OnShutdown(RakPeerInterface *peer) | ConnectionGraph | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
RequestConnectionGraph(RakPeerInterface *peer, SystemAddress systemAddress) | ConnectionGraph |
SetAutoAddNewConnections(bool autoAdd) | ConnectionGraph |
SetGroupId(ConnectionGraphGroupID groupId) | ConnectionGraph |
SetPassword(const char *password) | ConnectionGraph |
SubscribeToGroup(ConnectionGraphGroupID groupId) | ConnectionGraph |
UnsubscribeFromGroup(ConnectionGraphGroupID groupId) | ConnectionGraph |
Update(RakPeerInterface *peer) | ConnectionGraph | [virtual]

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

ConsoleServer Member List

This is the complete list of members for ConsoleServer, including all inherited members.

AddCommandParser(CommandParserInterface *commandParserInterface) | ConsoleServer
RemoveCommandParser(CommandParserInterface *commandParserInterface) | ConsoleServer
SetTransportProvider(TransportInterface *transportInterface, unsigned short port) | ConsoleServer
Update(void) | ConsoleServer

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataBlockEncryptor Member List

This is the complete list of members for DataBlockEncryptor, including all inherited members.

DataBlockEncryptor() | DataBlockEncryptor
Decrypt(unsigned char *input, unsigned int inputLength, unsigned char *output, unsigned int *outputLength) | DataBlockEncryptor
Encrypt(unsigned char *input, unsigned int inputLength, unsigned char *output, unsigned int *outputLength) | DataBlockEncryptor
IsKeySet(void) const | DataBlockEncryptor
SetKey(const unsigned char key[16]) | DataBlockEncryptor
UnsetKey(void) | DataBlockEncryptor
~DataBlockEncryptor() | DataBlockEncryptor

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataCompressor Member List

This is the complete list of members for DataCompressor, including all inherited members.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType > Member List

This is the complete list of members for DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType >, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::BinarySearchTree< BinarySearchTreeType > Member List

This is the complete list of members for DataStructures::BinarySearchTree< BinarySearchTreeType >, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::BPlusTree< KeyType, DataType, order > Member List

This is the complete list of members for DataStructures::BPlusTree< KeyType, DataType, order >, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::CircularLinkedList< CircularLinkedListType > Member List

This is the complete list of members for DataStructures::CircularLinkedList< CircularLinkedListType >, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::List< list_type > Member List

This is the complete list of members for DataStructures::List< list_type >, including all inherited members.

Clear(bool doNotDeallocateSmallBlocks=false) | DataStructures::List< list_type > |
Compress(void) | DataStructures::List< list_type > |
GetIndexOf(const list_type input) const | DataStructures::List< list_type > |
Insert(const list_type input, const unsigned int position) | DataStructures::List< list_type > |
Insert(const list_type input) | DataStructures::List< list_type > |
List() | DataStructures::List< list_type > |
List(const List &original_copy) | DataStructures::List< list_type > |
operator=(const List &original_copy) | DataStructures::List< list_type > |
operator[](const unsigned int position) const | DataStructures::List< list_type > | [inline]
Pop(void) | DataStructures::List< list_type > | [inline]
Push(const list_type input) | DataStructures::List< list_type > |
RemoveAtIndex(const unsigned int position) | DataStructures::List< list_type > |
RemoveAtIndexFast(const unsigned int position) | DataStructures::List< list_type > |
RemoveFromEnd(const unsigned num=1) | DataStructures::List< list_type > | [inline]
Replace(const list_type input, const list_type filler, const unsigned int position) | DataStructures::List< list_type > | [inline]
Replace(const list_type input) | DataStructures::List< list_type > | [inline]
Size(void) const | DataStructures::List< list_type > | [inline]
~List() | DataStructures::List< list_type > |

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::Map< key_type, data_type, key_comparison_func > Member List

This is the complete list of members for DataStructures::Map< key_type, data_type, key_comparison_func >, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::MemoryPool< MemoryBlockType > Member List

This is the complete list of members for DataStructures::MemoryPool< MemoryBlockType >, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::OrderedList< key_type, data_type, default_comparison_function > Member List

This is the complete list of members for DataStructures::OrderedList< key_type, data_type, default_comparison_function >, including all inherited members.

HasData(const key_type &key, int(*cf)(const key_type &, const data_type &)=default_comparison_function) const DataStructures::OrderedList< key_type, data_type, default_comparison_function >

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::Queue< queue_type > Member List

This is the complete list of members for DataStructures::Queue< queue_type >, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::QueueLinkedList< QueueType > Member List

This is the complete list of members for DataStructures::QueueLinkedList< QueueType >, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::SingleProducerConsumer< SingleProducerConsumerType > Member List

This is the complete list of members for DataStructures::SingleProducerConsumer< SingleProducerConsumerType >, including all inherited members.

CancelReadLock(SingleProducerConsumerType *cancelToLocation) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
CancelWriteLock(SingleProducerConsumerType *cancelToLocation) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
CheckReadUnlockOrder(const SingleProducerConsumerType *data) const | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
Clear(void) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
ReadIsLocked(void) const | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
ReadLock(void) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
ReadUnlock(void) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
SingleProducerConsumer() | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
Size(void) const | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
WriteLock(void) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
WriteUnlock(void) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
~SingleProducerConsumer() | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::Table Member List

This is the complete list of members for DataStructures::Table, including all inherited members.

AddColumn(const char columnName[_TABLE_MAX_COLUMN_NAME_LENGTH], ColumnType columnType) | DataStructures::Table
AddRow(unsigned rowId) | DataStructures::Table
Clear(void) | DataStructures::Table
ColumnIndex(char columnName[_TABLE_MAX_COLUMN_NAME_LENGTH]) | DataStructures::Table
ColumnName(unsigned index) | DataStructures::Table
GetAvailableRowId(void) const | DataStructures::Table
GetCellValueByIndex(unsigned rowIndex, unsigned columnIndex, int *output) | DataStructures::Table
GetColumnCount(void) const | DataStructures::Table
GetColumns(void) | DataStructures::Table
GetColumnType(unsigned index) | DataStructures::Table
GetListHead(void) | DataStructures::Table
GetRowByID(unsigned rowId) const | DataStructures::Table
GetRowByIndex(unsigned rowIndex, unsigned *key) const | DataStructures::Table
GetRowCount(void) const | DataStructures::Table
GetRows(void) | DataStructures::Table
PrintColumnHeaders(char *out, int outLength, char columnDelineator) const | DataStructures::Table
PrintRow(char *out, int outLength, char columnDelineator, bool printDelineatorForBinary, Table::Row *inputRow) const | DataStructures::Table
QueryTable(unsigned *columnIndicesSubset, unsigned numColumnSubset, FilterQuery *inclusionFilters, unsigned numInclusionFilters, unsigned *rowIds, unsigned numRowIDs, Table *result) | DataStructures::Table
RemoveColumn(unsigned columnIndex) | DataStructures::Table
RemoveRow(unsigned rowId) | DataStructures::Table
RemoveRows(Table *tableContainingRowIDs) | DataStructures::Table
SortQueryType enum name | DataStructures::Table
SortTable(Table::SortQuery *sortQueries, unsigned numSortQueries, Table::Row **out) | DataStructures::Table
Table() | DataStructures::Table
UpdateCell(unsigned rowId, unsigned columnIndex, int value) | DataStructures::Table
~Table() | DataStructures::Table

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DirectoryDeltaTransfer Member List

This is the complete list of members for DirectoryDeltaTransfer, including all inherited members.

AddUploadsFromSubdirectory(const char *subdir) | DirectoryDeltaTransfer |
ClearUploads(void) | DirectoryDeltaTransfer |
DirectoryDeltaTransfer() | DirectoryDeltaTransfer |
DownloadFromSubdirectory(const char *subdir, const char *outputSubdir, bool prependAppDirToOutputSubdir, SystemAddress host, FileListTransferCBInterface *onFileCallback, PacketPriority _priority, char _orderingChannel, FileListProgress *cb) | DirectoryDeltaTransfer |
GetNumberOfFilesForUpload(void) const | DirectoryDeltaTransfer |
OnAttach(RakPeerInterface *peer) | DirectoryDeltaTransfer | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | PluginInterface | [virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | DirectoryDeltaTransfer | [virtual]
OnShutdown(RakPeerInterface *peer) | DirectoryDeltaTransfer | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
SetApplicationDirectory(const char *pathToApplication) | DirectoryDeltaTransfer |
SetCompressOutgoingSends(bool compress) | DirectoryDeltaTransfer |
SetFileListTransferPlugin(FileListTransfer *flt) | DirectoryDeltaTransfer |
SetUploadSendParameters(PacketPriority _priority, char _orderingChannel) | DirectoryDeltaTransfer |
Update(RakPeerInterface *peer) | DirectoryDeltaTransfer | [virtual]
~DirectoryDeltaTransfer() | DirectoryDeltaTransfer | [virtual]

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

EmailSender Member List

This is the complete list of members for EmailSender, including all inherited members.

Send(const char *hostAddress, unsigned short hostPort, const char *sender, const char *recipient, const char *senderName, const char *recipientName, const char *subject, const char *body, FileList *attachedFiles, bool doPrintf, const char *password) EmailSender

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Alphabetical List

RakNet Class Index

A | B | C | D | E | F | G | H | I | L | M | N | O | P | Q | R | S | T | U | V

A
DeleteEmail_Data (LobbyDBSpec)
L
Q
SingleProducerConsumer (DataStructures)
AddAccountNote_Data (LobbyDBSpec) | DirectoryDeltaTransfer | LeaveClan_Notification (RakNet) | Queue (DataStructures) | SocketDescriptor
AddFriend_Data (LobbyDBSpec) | drft_lookup | LightweightDatabaseClient | QueueLinkedList (DataStructures) | SpeexBits
AddTitle_Data (TitleValidationDBSpec)
E
LightweightDatabaseServer
R
SpeexCallback
AddToIgnoreList_Data (LobbyDBSpec) | EmailSender | List (DataStructures) | RakNetCommandParser | SpeexEchoState_
AutopatcherMySQLRepository | EncState | LobbyClient (RakNet::Lobby2) | RakNetStatistics | SpeexHeader
AutopatcherPostgreRepository
F
LobbyClientInterface (RakNet) RakNetTransport SpeexJitter
AutopatcherRepositoryInterface FileListNode LobbyClientPC (RakNet) RakNetTransportCommandParser SpeexMode
AutoRPC (RakNet) | FileListProgress | LobbyClientPC (RakNet::Lobby2) | RakPeer | SpeexNBMode
AVLBalancedBinarySearchTree (DataStructures) FileListTransfer LobbyDB_PostgreSQL RakPeer::MemoryBlock SpeexPreprocessState
B
FileListTransferCBInterface LobbyDBCBInterface RakPeerInterface SpeexSBMode
BinarySearchTree (DataStructures) FLP_Printf LobbyServer (RakNet) RakString (RakNet) SpeexStereoState
BitStream (RakNet) FullyConnectedMesh LobbyServerPostgreSQL (RakNet) RankingServer_PostgreSQL SpeexSubmode
BPlusTree (DataStructures) FunctionThread (RakNet) LogCommandParser RankingServerCBInterface split_cb_params
C
Functor (RakNet) LogCommandParser::SystemAddressAndChannel ReadyEvent StrAndBool
CheckSum
G
ltp_params ReceiveConstructionInterface StringCompressor
CircularLinkedList (DataStructures) GetAccountNotes_Data (LobbyDBSpec)
M
ReceiveDownloadCompleteInterface StringTable (RakNet)
ClanJoinInvitation_Notification (RakNet) | GetEmails_Data (LobbyDBSpec) | Map (DataStructures) | RefCountedObj | SubmitMatch_Data (RankingServerDBSpec)
ClanJoinInvitationAccepted_Notification (RakNet) | GetFriends_Data (LobbyDBSpec) | MemoryCompressor | ReliabilityLayer | SubmitMatch_PostgreSQLImpl
ClanJoinInvitationRejected_Notification (RakNet) | GetHistoryForParticipant_Data (RankingServerDBSpec) | MemoryPool (DataStructures) | RemoteClient | SystemAddress
ClanJoinInvitationWithdrawn_Notification (RakNet) GetHistoryForParticipant_PostgreSQLImpl MessageFilter RemoveFriend_Data (LobbyDBSpec)
T
ClanMemberJoinRequest_Notification (RakNet) | GetIgnoreList_Data (LobbyDBSpec) | ModifyTrustedIPList_Data (RankingServerDBSpec) | RemoveFromIgnoreList_Data (LobbyDBSpec) | Table (DataStructures)
ClanMemberJoinRequestAccepted_Notification (RakNet) | GetRatingForParticipant_Data (RankingServerDBSpec) | ModifyTrustedIPList_PostgreSQLImpl | Replica | Table::Cell (DataStructures)
ClanMemberJoinRequestRejected_Notification (RakNet) GetRatingForParticipant_PostgreSQLImpl
N
Replica2 (RakNet) Table::ColumnDescriptor (DataStructures)
ClanMemberJoinRequestWithdrawn_Notification (RakNet) | GetRatingForParticipants_Data (RankingServerDBSpec) | NatPunchthrough | ReplicaManager | Table::Row (DataStructures)
CombFilterMem GetRatingForParticipants_PostgreSQLImpl NatPunchthroughLogger ReplicaManager2 (RakNet) TelnetTransport
CommandParserInterface | GetTitles_Data (TitleValidationDBSpec) | NetworkIDManager | Router | ThreadPool
Connection_RM2 (RakNet) | GetTrustedIPList_Data (RankingServerDBSpec) | NetworkIDObject | RouterInterface | ThreadsafePacketLogger
Connection_RM2Factory (RakNet) GetUser_Data (LobbyDBSpec)
O
RPC3 (RakNet) TitleValidation_PostgreSQL
ConnectionGraph
H
OrderedList (DataStructures) RPCParameters TitleValidationDBCBInterface
ConnectionGraph::SystemAddressAndGroupId HTTPConnection
P
S
TransportInterface
ConsoleServer HTTPConnection::BadResponse Packet SBDecState
U
CreateUser_Data (LobbyDBSpec) | HuffmanEncodingTree | PacketConsoleLogger | SBEncState | UpdateEmailStatus_Data (LobbyDBSpec)
D
HuffmanEncodingTreeFactory PacketFileLogger SendDownloadCompleteInterface UpdateUser_Data (LobbyDBSpec)
DatabaseCellUpdate
I
PacketLogger SendEmail_Data (LobbyDBSpec) UpdateUserKey_Data (TitleValidationDBSpec)
DataBlockEncryptor InlineFunctor Page (DataStructures) SerializationContext (RakNet)
V
DataCompressor | InlineFunctorProcessor | PairedKeyDbId (RankingServerDBSpec) | SimpleMutex | VBRState
DecState InternalPacket PluginInterface

A | B | C | D | E | F | G | H | I | L | M | N | O | P | Q | R | S | T | U | V

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

FileListProgress Member List

This is the complete list of members for FileListProgress, including all inherited members.

OnAddFilesFromDirectoryStarted(FileList *fileList, char *dir) | FileListProgress | [inline, virtual]
OnDirectory(FileList *fileList, char *dir, unsigned int directoriesRemaining) | FileListProgress | [inline, virtual]
OnFile(FileList *fileList, char *dir, char *fileName, unsigned int fileSize) | FileListProgress | [inline, virtual]

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

FileListTransfer Member List

This is the complete list of members for FileListTransfer, including all inherited members.

CancelReceive(unsigned short setId) | FileListTransfer |
GetCallback(void) const | FileListTransfer |
IsHandlerActive(unsigned short setId) | FileListTransfer |
OnAttach(RakPeerInterface *peer) | FileListTransfer | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | FileListTransfer | [virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | FileListTransfer | [virtual]
OnShutdown(RakPeerInterface *peer) | FileListTransfer | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
RemoveReceiver(SystemAddress systemAddress) | FileListTransfer |
Send(FileList *fileList, RakPeerInterface *rakPeer, SystemAddress recipient, unsigned short setID, PacketPriority priority, char orderingChannel, bool compressData) | FileListTransfer |
SetCallback(FileListProgress *cb) | FileListTransfer |
SetupReceive(FileListTransferCBInterface *handler, bool deleteHandler, SystemAddress allowedSender) | FileListTransfer |
Update(RakPeerInterface *peer) | FileListTransfer | [virtual]

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

FileListTransferCBInterface Member List

This is the complete list of members for FileListTransferCBInterface, including all inherited members.

OnDereference(void) | FileListTransferCBInterface | [inline, virtual]
OnDownloadComplete(void) | FileListTransferCBInterface | [inline, virtual]
OnFile(OnFileStruct *onFileStruct)=0 | FileListTransferCBInterface | [pure virtual]
OnFileProgress(OnFileStruct *onFileStruct, unsigned int partCount, unsigned int partTotal, unsigned int partLength, char *firstDataChunk) | FileListTransferCBInterface | [inline, virtual]
Update(void) | FileListTransferCBInterface | [inline, virtual]

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

FLP_Printf Member List

This is the complete list of members for FLP_Printf, including all inherited members.

OnAddFilesFromDirectoryStarted(FileList *fileList, char *dir) | FLP_Printf | [virtual]
OnDirectory(FileList *fileList, char *dir, unsigned int directoriesRemaining) | FLP_Printf | [virtual]
OnFile(FileList *fileList, char *dir, char *fileName, unsigned int fileSize) | FileListProgress | [inline, virtual]

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

FullyConnectedMesh Member List

This is the complete list of members for FullyConnectedMesh, including all inherited members.

ConnectWithNatPunchthrough(NatPunchthrough *np, SystemAddress _facilitator) | FullyConnectedMesh |
OnAttach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | PluginInterface | [virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | FullyConnectedMesh | [virtual]
OnShutdown(RakPeerInterface *peer) | FullyConnectedMesh | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
Startup(const char *password, int _passwordLength) | FullyConnectedMesh |
Update(RakPeerInterface *peer) | FullyConnectedMesh | [virtual]

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

GetHistoryForParticipant_PostgreSQLImpl Member List

This is the complete list of members for GetHistoryForParticipant_PostgreSQLImpl, including all inherited members.

Alloc(void) | GetHistoryForParticipant_PostgreSQLImpl | [static]
gameDbId | RankingServerDBSpec::GetHistoryForParticipant_Data |
HandleResult(bool wasCancelled, void *context) | GetHistoryForParticipant_PostgreSQLImpl | [virtual]
matchHistoryList | RankingServerDBSpec::GetHistoryForParticipant_Data |
participantDbId | RankingServerDBSpec::GetHistoryForParticipant_Data |
Process(void *context) | GetHistoryForParticipant_PostgreSQLImpl | [virtual]

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

GetRatingForParticipant_PostgreSQLImpl Member List

This is the complete list of members for GetRatingForParticipant_PostgreSQLImpl, including all inherited members.

Alloc(void) | GetRatingForParticipant_PostgreSQLImpl | [static]
gameDbId | RankingServerDBSpec::GetRatingForParticipant_Data |
HandleResult(bool wasCancelled, void *context) | GetRatingForParticipant_PostgreSQLImpl | [virtual]
participantDbId | RankingServerDBSpec::GetRatingForParticipant_Data |
participantFound | RankingServerDBSpec::GetRatingForParticipant_Data |
Process(void *context) | GetRatingForParticipant_PostgreSQLImpl | [virtual]
rating | RankingServerDBSpec::GetRatingForParticipant_Data |

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

GetRatingForParticipants_PostgreSQLImpl Member List

This is the complete list of members for GetRatingForParticipants_PostgreSQLImpl, including all inherited members.

Alloc(void) | GetRatingForParticipants_PostgreSQLImpl | [static]
gameDbId | RankingServerDBSpec::GetRatingForParticipants_Data |
HandleResult(bool wasCancelled, void *context) | GetRatingForParticipants_PostgreSQLImpl | [virtual]
outputList | RankingServerDBSpec::GetRatingForParticipants_Data |
Process(void *context) | GetRatingForParticipants_PostgreSQLImpl | [virtual]

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

HTTPConnection Member List

This is the complete list of members for HTTPConnection, including all inherited members.

GetServerAddress(void) const | HTTPConnection
HasBadResponse(int *code, RakNet::RakString *data) | HTTPConnection
HTTPConnection(TCPInterface &tcp, const char *host, unsigned short port=80) | HTTPConnection
IsBusy(void) const | HTTPConnection
Post(const char *path, const char *data, const char *_contentType="application/x-www-form-urlencoded") | HTTPConnection
ProcessFinalTCPPacket(Packet *packet) | HTTPConnection
Read(void) | HTTPConnection
ResponseCodes enum name | HTTPConnection
Update(void) | HTTPConnection

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

HuffmanEncodingTree Member List

This is the complete list of members for HuffmanEncodingTree, including all inherited members.

EncodeArray(unsigned char *input, size_t sizeInBytes, RakNet::BitStream *output) | HuffmanEncodingTree
FreeMemory(void) | HuffmanEncodingTree
GenerateFromFrequencyTable(unsigned int frequencyTable[256]) | HuffmanEncodingTree

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

HuffmanEncodingTreeFactory Member List

This is the complete list of members for HuffmanEncodingTreeFactory, including all inherited members.

AddToFrequencyTable(unsigned char *array, int size) | HuffmanEncodingTreeFactory
GenerateTree(void) | HuffmanEncodingTreeFactory
GetFrequencyTable(unsigned int _frequency[256]) | HuffmanEncodingTreeFactory
GetFrequencyTable(void) | HuffmanEncodingTreeFactory
HuffmanEncodingTreeFactory() | HuffmanEncodingTreeFactory
Reset(void) | HuffmanEncodingTreeFactory

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

InlineFunctor Member List

This is the complete list of members for InlineFunctor, including all inherited members.

callDepth | InlineFunctor | [protected]
HandleResult(bool wasCancelled, void *context) | InlineFunctor | [protected, virtual]
ifp | InlineFunctor | [protected]
Process(void *context)=0 | RakNet::Functor | [pure virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

InlineFunctorProcessor Member List

This is the complete list of members for InlineFunctorProcessor, including all inherited members.

completedThreads | InlineFunctorProcessor | [protected]
functionThread | InlineFunctorProcessor | [protected]
GetCallDepth(void) const | InlineFunctorProcessor | [protected]
StartThreads(int numThreads) | InlineFunctorProcessor |
StopThreads(bool blockOnCurrentProcessing) | InlineFunctorProcessor |
YieldOnFunctor(InlineFunctor *inlineFunctor) | InlineFunctorProcessor |

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LightweightDatabaseClient Member List

This is the complete list of members for LightweightDatabaseClient, including all inherited members.

LightweightDatabaseClient() | LightweightDatabaseClient |
OnAttach(RakPeerInterface *peer) | LightweightDatabaseClient | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | PluginInterface | [virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | LightweightDatabaseClient | [virtual]
OnShutdown(RakPeerInterface *peer) | PluginInterface | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
QueryTable(const char *tableName, const char *queryPassword, const char **columnNamesSubset, unsigned char numColumnSubset, DatabaseFilter *filter, unsigned char numFilters, unsigned *rowIds, unsigned char numRowIDs, SystemAddress systemAddress, bool broadcast) | LightweightDatabaseClient |
RemoveRow(const char *tableName, const char *removePassword, unsigned rowId, SystemAddress systemAddress, bool broadcast) | LightweightDatabaseClient |
Update(RakPeerInterface *peer) | PluginInterface | [virtual]
UpdateRow(const char *tableName, const char *updatePassword, RowUpdateMode updateMode, bool hasRowId, unsigned rowId, DatabaseCellUpdate *cellUpdates, unsigned char numCellUpdates, SystemAddress systemAddress, bool broadcast) | LightweightDatabaseClient |
~LightweightDatabaseClient() | LightweightDatabaseClient | [virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LightweightDatabaseServer Member List

This is the complete list of members for LightweightDatabaseServer, including all inherited members.

AddTable(char *tableName, bool allowRemoteQuery, bool allowRemoteUpdate, bool allowRemoteRemove, const char *queryPassword, const char *updatePassword, const char *removePassword, bool oneRowPerSystemAddress, bool onlyUpdateOwnRows, bool removeRowOnPingFailure, bool removeRowOnDisconnect, bool autogenerateRowIDs) | LightweightDatabaseServer |
Clear(void) | LightweightDatabaseServer |
GetTable(char *tableName) | LightweightDatabaseServer |
GetTableRows(char *tableName) | LightweightDatabaseServer |
LightweightDatabaseServer() | LightweightDatabaseServer |
OnAttach(RakPeerInterface *peer) | LightweightDatabaseServer | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | LightweightDatabaseServer | [virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | LightweightDatabaseServer | [virtual]
OnShutdown(RakPeerInterface *peer) | LightweightDatabaseServer | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
RemoveTable(char *tableName) | LightweightDatabaseServer |
Update(RakPeerInterface *peer) | LightweightDatabaseServer | [virtual]
~LightweightDatabaseServer() | LightweightDatabaseServer | [virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDB_PostgreSQL Member List

This is the complete list of members for LobbyDB_PostgreSQL, including all inherited members.

AssignCallback(LobbyDBCBInterface *cb) | LobbyDB_PostgreSQL |
CreateLobbyServerTables(void) | LobbyDB_PostgreSQL |
DestroyLobbyServerTables(void) | LobbyDB_PostgreSQL |
PushFunctor(LobbyDBFunctor *functor, void *context) | LobbyDB_PostgreSQL | [virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBCBInterface Member List

This is the complete list of members for LobbyDBCBInterface, including all inherited members.

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::AddAccountNote_Data Member List

This is the complete list of members for LobbyDBSpec::AddAccountNote_Data, including all inherited members.

body | LobbyDBSpec::AddAccountNote_Data
id | LobbyDBSpec::AddAccountNote_Data
moderatorId | LobbyDBSpec::AddAccountNote_Data
moderatorUsername | LobbyDBSpec::AddAccountNote_Data
subject | LobbyDBSpec::AddAccountNote_Data
time | LobbyDBSpec::AddAccountNote_Data
type | LobbyDBSpec::AddAccountNote_Data
userFound | LobbyDBSpec::AddAccountNote_Data
writeModeratorId | LobbyDBSpec::AddAccountNote_Data

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::AddFriend_Data Member List

This is the complete list of members for LobbyDBSpec::AddFriend_Data, including all inherited members.

creationTime | LobbyDBSpec::AddFriend_Data
friendFound | LobbyDBSpec::AddFriend_Data
friendId | LobbyDBSpec::AddFriend_Data
id | LobbyDBSpec::AddFriend_Data
queryResult | LobbyDBSpec::AddFriend_Data
success | LobbyDBSpec::AddFriend_Data
userFound | LobbyDBSpec::AddFriend_Data

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::AddToIgnoreList_Data Member List

This is the complete list of members for LobbyDBSpec::AddToIgnoreList_Data, including all inherited members.

actions | LobbyDBSpec::AddToIgnoreList_Data
creationTime | LobbyDBSpec::AddToIgnoreList_Data
id | LobbyDBSpec::AddToIgnoreList_Data
queryResult | LobbyDBSpec::AddToIgnoreList_Data
success | LobbyDBSpec::AddToIgnoreList_Data

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::CreateUser_Data Member List

This is the complete list of members for LobbyDBSpec::CreateUser_Data, including all inherited members.

accountBalance | LobbyDBSpec::CreateUser_Data
accountNumber | LobbyDBSpec::CreateUser_Data
adminLevel | LobbyDBSpec::CreateUser_Data
billingAddress1 | LobbyDBSpec::CreateUser_Data
billingAddress2 | LobbyDBSpec::CreateUser_Data
billingCity | LobbyDBSpec::CreateUser_Data
billingCountry | LobbyDBSpec::CreateUser_Data
billingProvince | LobbyDBSpec::CreateUser_Data
billingState | LobbyDBSpec::CreateUser_Data
billingZipCode | LobbyDBSpec::CreateUser_Data
binaryData | LobbyDBSpec::CreateUser_Data
binaryDataLength | LobbyDBSpec::CreateUser_Data
caption1 | LobbyDBSpec::CreateUser_Data
caption2 | LobbyDBSpec::CreateUser_Data
caption3 | LobbyDBSpec::CreateUser_Data
creditCardCVV | LobbyDBSpec::CreateUser_Data
creditCardExpiration | LobbyDBSpec::CreateUser_Data
creditCardNumber | LobbyDBSpec::CreateUser_Data
dateOfBirth | LobbyDBSpec::CreateUser_Data
emailAddress | LobbyDBSpec::CreateUser_Data
firstName | LobbyDBSpec::CreateUser_Data
handle | LobbyDBSpec::CreateUser_Data
homeAddress1 | LobbyDBSpec::CreateUser_Data
homeAddress2 | LobbyDBSpec::CreateUser_Data
homeCity | LobbyDBSpec::CreateUser_Data
homeCountry | LobbyDBSpec::CreateUser_Data
homeProvince | LobbyDBSpec::CreateUser_Data
homeState | LobbyDBSpec::CreateUser_Data
homeZipCode | LobbyDBSpec::CreateUser_Data
lastName | LobbyDBSpec::CreateUser_Data
middleName | LobbyDBSpec::CreateUser_Data
password | LobbyDBSpec::CreateUser_Data
passwordRecoveryAnswer | LobbyDBSpec::CreateUser_Data
passwordRecoveryQuestion | LobbyDBSpec::CreateUser_Data
permissions | LobbyDBSpec::CreateUser_Data
race | LobbyDBSpec::CreateUser_Data
sex | LobbyDBSpec::CreateUser_Data
sourceIPAddress | LobbyDBSpec::CreateUser_Data

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::DeleteEmail_Data Member List

This is the complete list of members for LobbyDBSpec::DeleteEmail_Data, including all inherited members.

emailMessageID LobbyDBSpec::DeleteEmail_Data

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::GetAccountNotes_Data Member List

This is the complete list of members for LobbyDBSpec::GetAccountNotes_Data, including all inherited members.

ascendingSort | LobbyDBSpec::GetAccountNotes_Data
id | LobbyDBSpec::GetAccountNotes_Data

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::GetEmails_Data Member List

This is the complete list of members for LobbyDBSpec::GetEmails_Data, including all inherited members.

ascendingSort | LobbyDBSpec::GetEmails_Data
failureMessage | LobbyDBSpec::GetEmails_Data
id | LobbyDBSpec::GetEmails_Data
inbox | LobbyDBSpec::GetEmails_Data
validParameters | LobbyDBSpec::GetEmails_Data

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::GetFriends_Data Member List

This is the complete list of members for LobbyDBSpec::GetFriends_Data, including all inherited members.

ascendingSort | LobbyDBSpec::GetFriends_Data
id | LobbyDBSpec::GetFriends_Data

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::GetIgnoreList_Data Member List

This is the complete list of members for LobbyDBSpec::GetIgnoreList_Data, including all inherited members.

ascendingSort | LobbyDBSpec::GetIgnoreList_Data
id | LobbyDBSpec::GetIgnoreList_Data

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::GetUser_Data Member List

This is the complete list of members for LobbyDBSpec::GetUser_Data, including all inherited members.

banOrSuspensionReason | LobbyDBSpec::GetUser_Data
creationTime | LobbyDBSpec::GetUser_Data
getBinaryData | LobbyDBSpec::GetUser_Data
getCCInfo | LobbyDBSpec::GetUser_Data
getEmailAddr | LobbyDBSpec::GetUser_Data
getPassword | LobbyDBSpec::GetUser_Data
getPersonalInfo | LobbyDBSpec::GetUser_Data
id | LobbyDBSpec::GetUser_Data
isBanned | LobbyDBSpec::GetUser_Data
isSuspended | LobbyDBSpec::GetUser_Data
output | LobbyDBSpec::GetUser_Data
suspensionExpiration | LobbyDBSpec::GetUser_Data
userFound | LobbyDBSpec::GetUser_Data

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::RemoveFriend_Data Member List

This is the complete list of members for LobbyDBSpec::RemoveFriend_Data, including all inherited members.

removeFriendInput LobbyDBSpec::RemoveFriend_Data

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::RemoveFromIgnoreList_Data Member List

This is the complete list of members for LobbyDBSpec::RemoveFromIgnoreList_Data, including all inherited members.

id LobbyDBSpec::RemoveFromIgnoreList_Data

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::SendEmail_Data Member List

This is the complete list of members for LobbyDBSpec::SendEmail_Data, including all inherited members.

attachment | LobbyDBSpec::SendEmail_Data
attachmentLength | LobbyDBSpec::SendEmail_Data
body | LobbyDBSpec::SendEmail_Data
creationTime | LobbyDBSpec::SendEmail_Data
emailMessageID | LobbyDBSpec::SendEmail_Data
failureMessage | LobbyDBSpec::SendEmail_Data
id | LobbyDBSpec::SendEmail_Data
initialSenderStatus | LobbyDBSpec::SendEmail_Data
status | LobbyDBSpec::SendEmail_Data
subject | LobbyDBSpec::SendEmail_Data
to | LobbyDBSpec::SendEmail_Data
validParameters | LobbyDBSpec::SendEmail_Data
wasOpened | LobbyDBSpec::SendEmail_Data

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::UpdateEmailStatus_Data Member List

This is the complete list of members for LobbyDBSpec::UpdateEmailStatus_Data, including all inherited members.

emailMessageID | LobbyDBSpec::UpdateEmailStatus_Data
status | LobbyDBSpec::UpdateEmailStatus_Data
wasOpened | LobbyDBSpec::UpdateEmailStatus_Data

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LobbyDBSpec::UpdateUser_Data Member List

This is the complete list of members for LobbyDBSpec::UpdateUser_Data, including all inherited members.

id | LobbyDBSpec::UpdateUser_Data
input | LobbyDBSpec::UpdateUser_Data
updateBinaryData | LobbyDBSpec::UpdateUser_Data
updateCCInfo | LobbyDBSpec::UpdateUser_Data
updateEmailAddr | LobbyDBSpec::UpdateUser_Data
updatePassword | LobbyDBSpec::UpdateUser_Data
updatePersonalInfo | LobbyDBSpec::UpdateUser_Data

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LogCommandParser Member List

This is the complete list of members for LogCommandParser, including all inherited members.

AddChannel(const char *channelName) | LogCommandParser |
channelNames | LogCommandParser | [protected]
GetChannelIndexFromName(const char *channelName) | LogCommandParser | [protected]
GetName(void) const | LogCommandParser | [virtual]
IntegersToSystemAddress(int binaryAddress, int port) | CommandParserInterface | [protected]
OnCommand(const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, SystemAddress systemAddress, const char *originalString) | LogCommandParser | [virtual]
OnConnectionLost(SystemAddress systemAddress, TransportInterface *transport) | LogCommandParser | [virtual]
OnNewIncomingConnection(SystemAddress systemAddress, TransportInterface *transport) | LogCommandParser | [virtual]
OnTransportChange(TransportInterface *transport) | LogCommandParser | [virtual]
PrintChannels(SystemAddress systemAddress, TransportInterface *transport) const | LogCommandParser | [protected]
RegisterCommand(unsigned char parameterCount, const char *command, const char *commandHelp) | CommandParserInterface | [protected, virtual]
remoteUsers | LogCommandParser | [protected]
ReturnResult(bool res, const char *command, TransportInterface *transport, SystemAddress systemAddress) | CommandParserInterface | [protected, virtual]
ReturnResult(const char *command, TransportInterface *transport, SystemAddress systemAddress) | CommandParserInterface | [protected, virtual]
SendHelp(TransportInterface *transport, SystemAddress systemAddress) | LogCommandParser | [virtual]
Subscribe(SystemAddress systemAddress, const char *channelName) | LogCommandParser | [protected]
trans | LogCommandParser | [protected]
Unsubscribe(SystemAddress systemAddress, const char *channelName) | LogCommandParser | [protected]
WriteLog(const char *channelName, const char *format,...) | LogCommandParser |

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

MemoryCompressor Member List

This is the complete list of members for MemoryCompressor, including all inherited members.

Clear(void) | MemoryCompressor
Compress(char *input, const unsigned inputLength, bool finish) | MemoryCompressor

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

MessageFilter Member List

This is the complete list of members for MessageFilter, including all inherited members.

DeleteFilterSet(int filterSetID) | MessageFilter |
GetFilterSetCount(void) const | MessageFilter |
GetFilterSetIDByIndex(unsigned index) | MessageFilter |
GetSystemByIndex(int filterSetID, unsigned index) | MessageFilter |
GetSystemCount(int filterSetID) const | MessageFilter |
GetSystemFilterSet(SystemAddress systemAddress) | MessageFilter |
OnAttach(RakPeerInterface *peer) | MessageFilter | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | MessageFilter | [virtual]
OnDetach(RakPeerInterface *peer) | MessageFilter | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | MessageFilter | [virtual]
OnShutdown(RakPeerInterface *peer) | MessageFilter | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
SetActionOnDisallowedMessage(bool kickOnDisallowed, bool banOnDisallowed, RakNetTime banTimeMS, int filterSetID) | MessageFilter |
SetAllowMessageID(bool allow, int messageIDStart, int messageIDEnd, int filterSetID) | MessageFilter |
SetAllowRPC(bool allow, const char *functionName, int filterSetID) | MessageFilter |
SetAutoAddNewConnectionsToFilter(int filterSetID) | MessageFilter |
SetDisallowedMessageCallback(int filterSetID, void *userData, void(*invalidMessageCallback)(RakPeerInterface *peer, SystemAddress systemAddress, int filterSetID, void *userData, unsigned char messageID)) | MessageFilter |
SetFilterMaxTime(int allowedTimeMS, bool banOnExceed, RakNetTime banTimeMS, int filterSetID) | MessageFilter |
SetSystemFilterSet(SystemAddress systemAddress, int filterSetID) | MessageFilter |
SetTimeoutCallback(int filterSetID, void *userData, void(*invalidMessageCallback)(RakPeerInterface *peer, SystemAddress systemAddress, int filterSetID, void *userData)) | MessageFilter |
Update(RakPeerInterface *peer) | MessageFilter | [virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

ModifyTrustedIPList_PostgreSQLImpl Member List

This is the complete list of members for ModifyTrustedIPList_PostgreSQLImpl, including all inherited members.

addToList | RankingServerDBSpec::ModifyTrustedIPList_Data |
Alloc(void) | ModifyTrustedIPList_PostgreSQLImpl | [static]
gameDbId | RankingServerDBSpec::ModifyTrustedIPList_Data |
HandleResult(bool wasCancelled, void *context) | ModifyTrustedIPList_PostgreSQLImpl | [virtual]
ip | RankingServerDBSpec::ModifyTrustedIPList_Data |
Process(void *context) | ModifyTrustedIPList_PostgreSQLImpl | [virtual]
systemAddress | RankingServerDBSpec::ModifyTrustedIPList_Data |

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

NatPunchthrough Member List

This is the complete list of members for NatPunchthrough, including all inherited members.

Clear(void) | NatPunchthrough |
Connect(const char *destination, unsigned short remotePort, const char *passwordData, int passwordDataLength, SystemAddress facilitator) | NatPunchthrough |
Connect(SystemAddress destination, const char *passwordData, int passwordDataLength, SystemAddress facilitator) | NatPunchthrough |
FacilitateConnections(bool allow) | NatPunchthrough |
NatPunchthrough() | NatPunchthrough |
OnAttach(RakPeerInterface *peer) | NatPunchthrough | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | NatPunchthrough | [virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | NatPunchthrough | [virtual]
OnShutdown(RakPeerInterface *peer) | NatPunchthrough | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
SetLogger(NatPunchthroughLogger *l) | NatPunchthrough |
Update(RakPeerInterface *peer) | NatPunchthrough | [virtual]
~NatPunchthrough() | NatPunchthrough | [virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

NatPunchthroughLogger Member List

This is the complete list of members for NatPunchthroughLogger, including all inherited members.

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

NetworkIDManager Member List

This is the complete list of members for NetworkIDManager, including all inherited members.

GET_BASE_OBJECT_FROM_ID(NetworkID x) | NetworkIDManager |
GET_OBJECT_FROM_ID(NetworkID x) | NetworkIDManager |
GET_OBJECT_FROM_ID(NetworkID x) | NetworkIDManager | [inline]
GetSharedNetworkID(void) | NetworkIDManager |
IDTree | NetworkIDManager | [protected]
IsNetworkIDAuthority(void) const | NetworkIDManager |
SetExternalSystemAddress(SystemAddress systemAddress) | NetworkIDManager |
SetIsNetworkIDAuthority(bool isAuthority) | NetworkIDManager |
SetSharedNetworkID(unsigned short i) | NetworkIDManager |

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

NetworkIDObject Member List

This is the complete list of members for NetworkIDObject, including all inherited members.

callGenerationCode | NetworkIDObject | [protected]
GenerateID(void) | NetworkIDObject | [protected]
GetAllocationNumber(void) const | NetworkIDObject |
GetNetworkID(void) | NetworkIDObject | [virtual]
GetNetworkIDManager(void) | NetworkIDObject | [virtual]
GetParent(void) const | NetworkIDObject | [virtual]
networkID | NetworkIDObject | [protected]
NetworkIDObject() | NetworkIDObject |
nextAllocationNumber | NetworkIDObject | [protected, static]
parent | NetworkIDObject | [protected]
RequiresSetParent(void) const | NetworkIDObject | [virtual]
SetNetworkID(NetworkID id) | NetworkIDObject | [virtual]
SetNetworkIDManager(NetworkIDManager *manager) | NetworkIDObject | [virtual]
SetParent(void *_parent) | NetworkIDObject | [virtual]
~NetworkIDObject() | NetworkIDObject | [virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

PacketConsoleLogger Member List

This is the complete list of members for PacketConsoleLogger, including all inherited members.

LogHeader(void) | PacketLogger | [virtual]
OnAttach(RakPeerInterface *peer) | PacketLogger | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | PluginInterface | [virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PacketLogger | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PacketLogger | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PacketLogger | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | PluginInterface | [virtual]
OnShutdown(RakPeerInterface *peer) | PluginInterface | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
SetPrefix(const char *_prefix) | PacketLogger | [virtual]
SetSuffix(const char *_suffix) | PacketLogger | [virtual]
Update(RakPeerInterface *peer) | PacketLogger | [virtual]
WriteLog(const char *str) | PacketConsoleLogger | [virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

PacketFileLogger Member List

This is the complete list of members for PacketFileLogger, including all inherited members.

LogHeader(void) | PacketLogger | [virtual]
OnAttach(RakPeerInterface *peer) | PacketLogger | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | PluginInterface | [virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PacketLogger | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PacketLogger | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PacketLogger | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | PluginInterface | [virtual]
OnShutdown(RakPeerInterface *peer) | PluginInterface | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
SetPrefix(const char *_prefix) | PacketLogger | [virtual]
SetSuffix(const char *_suffix) | PacketLogger | [virtual]
Update(RakPeerInterface *peer) | PacketLogger | [virtual]
WriteLog(const char *str) | PacketFileLogger | [virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

PacketLogger Member List

This is the complete list of members for PacketLogger, including all inherited members.

LogHeader(void) | PacketLogger | [virtual]
OnAttach(RakPeerInterface *peer) | PacketLogger | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | PluginInterface | [virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PacketLogger | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PacketLogger | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PacketLogger | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | PluginInterface | [virtual]
OnShutdown(RakPeerInterface *peer) | PluginInterface | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
SetPrefix(const char *_prefix) | PacketLogger | [virtual]
SetSuffix(const char *_suffix) | PacketLogger | [virtual]
Update(RakPeerInterface *peer) | PacketLogger | [virtual]
WriteLog(const char *str) | PacketLogger | [virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

PluginInterface Member List

This is the complete list of members for PluginInterface, including all inherited members.

OnAttach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | PluginInterface | [virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | PluginInterface | [virtual]
OnShutdown(RakPeerInterface *peer) | PluginInterface | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
Update(RakPeerInterface *peer) | PluginInterface | [virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::AutoRPC Member List

This is the complete list of members for RakNet::AutoRPC, including all inherited members.

AutoRPC() | RakNet::AutoRPC |
Call(const char *uniqueIdentifier) | RakNet::AutoRPC | [inline]
Call(const char *uniqueIdentifier, P1 p1) | RakNet::AutoRPC | [inline]
Call(const char *uniqueIdentifier, P1 p1, P2 p2) | RakNet::AutoRPC | [inline]
Call(const char *uniqueIdentifier, P1 p1, P2 p2, P3 p3) | RakNet::AutoRPC | [inline]
Call(const char *uniqueIdentifier, P1 p1, P2 p2, P3 p3, P4 p4) | RakNet::AutoRPC | [inline]
Call(const char *uniqueIdentifier, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5) | RakNet::AutoRPC | [inline]
Call(const char *uniqueIdentifier, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5, P6 p6) | RakNet::AutoRPC | [inline]
Call(const char *uniqueIdentifier, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5, P6 p6, P7 p7) | RakNet::AutoRPC | [inline]
Call(const char *uniqueIdentifier, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5, P6 p6, P7 p7, P8 p8) | RakNet::AutoRPC | [inline]
CallExplicit(const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID) | RakNet::AutoRPC | [inline]
CallExplicit(const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1) | RakNet::AutoRPC | [inline]
CallExplicit(const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2) | RakNet::AutoRPC | [inline]
CallExplicit(const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2, P3 p3) | RakNet::AutoRPC | [inline]
CallExplicit(const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2, P3 p3, P4 p4) | RakNet::AutoRPC | [inline]
CallExplicit(const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5) | RakNet::AutoRPC | [inline]
CallExplicit(const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5, P6 p6) | RakNet::AutoRPC | [inline]
CallExplicit(const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5, P6 p6, P7 p7) | RakNet::AutoRPC | [inline]
CallExplicit(const char *uniqueIdentifier, RakNetTime timeStamp, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, NetworkID networkID, P1 p1, P2 p2, P3 p3, P4 p4, P5 p5, P6 p6, P7 p7, P8 p8) | RakNet::AutoRPC | [inline]
GetCurrentExecution(void) const | RakNet::AutoRPC |
GetIncomingExtraData(void) | RakNet::AutoRPC |
GetLastSenderAddress(void) const | RakNet::AutoRPC |
GetLastSenderTimestamp(void) const | RakNet::AutoRPC |
GetRakPeer(void) const | RakNet::AutoRPC |
OnAttach(RakPeerInterface *peer) | RakNet::AutoRPC | [protected, virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | RakNet::AutoRPC | [protected, virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | RakNet::AutoRPC | [protected, virtual]
OnShutdown(RakPeerInterface *peer) | RakNet::AutoRPC | [protected, virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
RegisterFunction(const char *uniqueIdentifier, void *functionPtr, bool isObjectMember, char parameterCount=-1) | RakNet::AutoRPC |
SetNetworkIDManager(NetworkIDManager *idMan) | RakNet::AutoRPC |
SetOutgoingExtraData(void) | RakNet::AutoRPC |
SetRecipientAddress(SystemAddress systemAddress, bool broadcast) | RakNet::AutoRPC |
SetRecipientObject(NetworkID networkID) | RakNet::AutoRPC |
SetSendParams(PacketPriority priority, PacketReliability reliability, char orderingChannel) | RakNet::AutoRPC |
SetTimestamp(RakNetTime timeStamp) | RakNet::AutoRPC |
UnregisterFunction(const char *uniqueIdentifier, bool isObjectMember) | RakNet::AutoRPC |
Update(RakPeerInterface *peer) | PluginInterface | [virtual]
~AutoRPC() | RakNet::AutoRPC | [virtual]

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::BitStream Member List

This is the complete list of members for RakNet::BitStream, including all inherited members.

AddBitsAndReallocate(const BitSize_t numberOfBitsToWrite) | RakNet::BitStream |
AlignReadToByteBoundary(void) | RakNet::BitStream |
AlignWriteToByteBoundary(void) | RakNet::BitStream |
AssertCopyData(void) | RakNet::BitStream |
AssertStreamEmpty(void) | RakNet::BitStream |
BitStream() | RakNet::BitStream |
BitStream(const unsigned int initialBytesToAllocate) | RakNet::BitStream |
BitStream(unsigned char *_data, const unsigned int lengthInBytes, bool _copyData) | RakNet::BitStream |
CopyData(unsigned char **_data) const | RakNet::BitStream |
DoEndianSwap(void) | RakNet::BitStream | [static]
GetData(void) const | RakNet::BitStream | [inline]
GetNumberOfBitsUsed(void) const | RakNet::BitStream | [inline]
GetNumberOfBytesUsed(void) const | RakNet::BitStream | [inline]
GetNumberOfUnreadBits(void) const | RakNet::BitStream | [inline]
GetReadOffset(void) const | RakNet::BitStream | [inline]
IgnoreBits(const BitSize_t numberOfBits) | RakNet::BitStream |
IgnoreBytes(const unsigned int numberOfBytes) | RakNet::BitStream |
PrintBits(void) const | RakNet::BitStream |
Read(templateType &var) | RakNet::BitStream | [inline]
Read(BitStream *bitStream, BitSize_t numberOfBits) | RakNet::BitStream |
Read(char *output, const unsigned int numberOfBytes) | RakNet::BitStream |
Read(bool &var) | RakNet::BitStream | [inline]
Read(SystemAddress &var) | RakNet::BitStream | [inline]
Read(NetworkID &var) | RakNet::BitStream | [inline]
Read(RakString &var) | RakNet::BitStream | [inline]
ReadAlignedBytes(unsigned char *output, const unsigned int numberOfBytesToRead) | RakNet::BitStream |
ReadAlignedBytesSafe(char *input, int &inputLength, const int maxBytesToRead) | RakNet::BitStream |
ReadAlignedBytesSafeAlloc(char **input, int &inputLength, const unsigned int maxBytesToRead) | RakNet::BitStream |
ReadBit(void) | RakNet::BitStream |
ReadBits(unsigned char *output, BitSize_t numberOfBitsToRead, const bool alignBitsToRight=true) | RakNet::BitStream |
ReadCompressed(templateType &var) | RakNet::BitStream | [inline]
ReadCompressed(float &var) | RakNet::BitStream | [inline]
ReadCompressed(double &var) | RakNet::BitStream | [inline]
ReadCompressed(RakString &var) | RakNet::BitStream | [inline]
ReadCompressedDelta(templateType &var) | RakNet::BitStream | [inline]
ReadCompressedDelta(bool &var) | RakNet::BitStream | [inline]
ReadDelta(templateType &var) | RakNet::BitStream | [inline]
ReadDelta(bool &var) | RakNet::BitStream | [inline]
ReadNormQuat(templateType &w, templateType &x, templateType &y, templateType &z) | RakNet::BitStream |
ReadNormVector(templateType &x, templateType &y, templateType &z) | RakNet::BitStream |
ReadOrthMatrix(templateType &m00, templateType &m01, templateType &m02, templateType &m10, templateType &m11, templateType &m12, templateType &m20, templateType &m21, templateType &m22) | RakNet::BitStream |
ReadPtr(templateType *var) | RakNet::BitStream | [inline]
ReadVector(templateType &x, templateType &y, templateType &z) | RakNet::BitStream |
Reset(void) | RakNet::BitStream |
ResetReadPointer(void) | RakNet::BitStream |
ResetWritePointer(void) | RakNet::BitStream |
Serialize(bool writeToBitstream, templateType &var) | RakNet::BitStream | [inline]
Serialize(bool writeToBitstream, char *input, const unsigned int numberOfBytes) | RakNet::BitStream | [inline]
SerializeBits(bool writeToBitstream, unsigned char *input, const BitSize_t numberOfBitsToSerialize, const bool rightAlignedBits=true) | RakNet::BitStream | [inline]
SerializeCompressed(bool writeToBitstream, templateType &var) | RakNet::BitStream | [inline]
SerializeCompressedDelta(bool writeToBitstream, templateType &currentValue, templateType lastValue) | RakNet::BitStream | [inline]
SerializeCompressedDelta(bool writeToBitstream, templateType &currentValue) | RakNet::BitStream | [inline]
SerializeDelta(bool writeToBitstream, templateType &currentValue, templateType lastValue) | RakNet::BitStream | [inline]
SerializeDelta(bool writeToBitstream, templateType &currentValue) | RakNet::BitStream | [inline]
SerializeNormQuat(bool writeToBitstream, templateType &w, templateType &x, templateType &y, templateType &z) | RakNet::BitStream | [inline]
SerializeNormVector(bool writeToBitstream, templateType &x, templateType &y, templateType &z) | RakNet::BitStream | [inline]
SerializeOrthMatrix(bool writeToBitstream, templateType &m00, templateType &m01, templateType &m02, templateType &m10, templateType &m11, templateType &m12, templateType &m20, templateType &m21, templateType &m22) | RakNet::BitStream | [inline]
SerializeVector(bool writeToBitstream, templateType &x, templateType &y, templateType &z) | RakNet::BitStream | [inline]
SetData(unsigned char *input) | RakNet::BitStream |
SetNumberOfBitsAllocated(const BitSize_t lengthInBits) | RakNet::BitStream |
SetWriteOffset(const BitSize_t offset) | RakNet::BitStream |
Write(templateType var) | RakNet::BitStream | [inline]
Write(const char *input, const unsigned int numberOfBytes) | RakNet::BitStream |
Write(BitStream *bitStream, BitSize_t numberOfBits) | RakNet::BitStream |
Write(bool var) | RakNet::BitStream | [inline]
Write(SystemAddress var) | RakNet::BitStream | [inline]
Write(NetworkID var) | RakNet::BitStream | [inline]
Write(RakString var) | RakNet::BitStream | [inline]
Write0(void) | RakNet::BitStream |
Write1(void) | RakNet::BitStream |
WriteAlignedBytes(const unsigned char *input, const unsigned int numberOfBytesToWrite) | RakNet::BitStream |
WriteAlignedBytesSafe(const char *input, const unsigned int inputLength, const unsigned int maxBytesToWrite) | RakNet::BitStream |
WriteBits(const unsigned char *input, BitSize_t numberOfBitsToWrite, const bool rightAlignedBits=true) | RakNet::BitStream |
WriteCompressed(templateType var) | RakNet::BitStream | [inline]
WriteCompressed(float var) | RakNet::BitStream | [inline]
WriteCompressed(double var) | RakNet::BitStream | [inline]
WriteCompressed(RakString var) | RakNet::BitStream | [inline]
WriteCompressedDelta(templateType currentValue, templateType lastValue) | RakNet::BitStream | [inline]
WriteCompressedDelta(templateType currentValue) | RakNet::BitStream | [inline]
WriteCompressedDelta(bool currentValue, bool lastValue) | RakNet::BitStream | [inline]
WriteCompressedDelta(bool currentValue) | RakNet::BitStream | [inline]
WriteDelta(templateType currentValue, templateType lastValue) | RakNet::BitStream | [inline]
WriteDelta(templateType currentValue) | RakNet::BitStream | [inline]
WriteDelta(SystemAddress currentValue, SystemAddress lastValue) | RakNet::BitStream | [inline]
WriteDelta(NetworkID currentValue, NetworkID lastValue) | RakNet::BitStream | [inline]
WriteDelta(bool currentValue, bool lastValue) | RakNet::BitStream | [inline]
WriteNormQuat(templateType w, templateType x, templateType y, templateType z) | RakNet::BitStream |
WriteNormVector(templateType x, templateType y, templateType z) | RakNet::BitStream |
WriteOrthMatrix(templateType m00, templateType m01, templateType m02, templateType m10, templateType m11, templateType m12, templateType m20, templateType m21, templateType m22) | RakNet::BitStream |
WritePtr(templateType *var) | RakNet::BitStream | [inline]
WriteVector(templateType x, templateType y, templateType z) | RakNet::BitStream |
~BitStream() | RakNet::BitStream |

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::Connection_RM2 Member List

This is the complete list of members for RakNet::Connection_RM2, including all inherited members.

Connection_RM2() | RakNet::Connection_RM2 |
Construct(RakNet::BitStream *replicaData, SystemAddress sender, SerializationType type, ReplicaManager2 *replicaManager, RakNetTime timestamp, NetworkID networkId, bool networkIDCollision)=0 | RakNet::Connection_RM2 | [pure virtual]
DeserializeDownloadComplete(RakNet::BitStream *objectData, SystemAddress sender, ReplicaManager2 *replicaManager, RakNetTime timestamp, SerializationType serializationType) | RakNet::Connection_RM2 | [virtual]
DeserializeDownloadStarted(RakNet::BitStream *objectData, SystemAddress sender, ReplicaManager2 *replicaManager, RakNetTime timestamp, SerializationType serializationType) | RakNet::Connection_RM2 | [virtual]
GetSystemAddress(void) const | RakNet::Connection_RM2 |
SerializeDownloadComplete(RakNet::BitStream *objectData, ReplicaManager2 *replicaManager, SerializationContext *serializationContext) | RakNet::Connection_RM2 | [virtual]
SerializeDownloadStarted(RakNet::BitStream *objectData, ReplicaManager2 *replicaManager, SerializationContext *serializationContext) | RakNet::Connection_RM2 | [virtual]
SetConstructionByList(DataStructures::OrderedList< Replica2 *, Replica2 *, ReplicaManager2::Replica2ObjectComp > &currentVisibility, ReplicaManager2 *replicaManager) | RakNet::Connection_RM2 | [virtual]
SetConstructionByReplicaQuery(ReplicaManager2 *replicaManager) | RakNet::Connection_RM2 | [virtual]
SetSystemAddress(SystemAddress sa) | RakNet::Connection_RM2 |
SetVisibilityByList(DataStructures::OrderedList< Replica2 *, Replica2 *, ReplicaManager2::Replica2ObjectComp > &currentVisibility, ReplicaManager2 *replicaManager) | RakNet::Connection_RM2 | [virtual]
SetVisibilityByReplicaQuery(ReplicaManager2 *replicaManager) | RakNet::Connection_RM2 | [virtual]
~Connection_RM2() | RakNet::Connection_RM2 | [virtual]

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::Connection_RM2Factory Member List

This is the complete list of members for RakNet::Connection_RM2Factory, including all inherited members.

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::FunctionThread Member List

This is the complete list of members for RakNet::FunctionThread, including all inherited members.

CallResultHandlers(void) | RakNet::FunctionThread
CancelFunctorsWithContext(bool(*cancelThisFunctor)(FunctorAndContext func, void *userData), void *userData) | RakNet::FunctionThread
Push(Functor *functor, void *context=0) | RakNet::FunctionThread
SetPostResultFunction(void(*postResult)(FunctorAndContext func)) | RakNet::FunctionThread
StartThreads(int numThreads) | RakNet::FunctionThread
StopThreads(bool blockOnCurrentProcessing) | RakNet::FunctionThread

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::Functor Member List

This is the complete list of members for RakNet::Functor, including all inherited members.

HandleResult(bool wasCancelled, void *context)=0 | RakNet::Functor | [pure virtual]
Process(void *context)=0 | RakNet::Functor | [pure virtual]

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::Lobby2::LobbyClient Member List

This is the complete list of members for RakNet::Lobby2::LobbyClient, including all inherited members.

SetCallbackInterface(LobbyClientInterfaceCB *cbi) RakNet::Lobby2::LobbyClient [virtual]

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::Lobby2::LobbyClientPC Member List

This is the complete list of members for RakNet::Lobby2::LobbyClientPC, including all inherited members.

OnAttach(RakPeerInterface *peer) | RakNet::Lobby2::LobbyClientPC | [protected, virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | RakNet::Lobby2::LobbyClientPC | [protected, virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | RakNet::Lobby2::LobbyClientPC | [protected, virtual]
OnShutdown(RakPeerInterface *peer) | RakNet::Lobby2::LobbyClientPC | [protected, virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
SetCallbackInterface(LobbyClientInterfaceCB *cbi) | RakNet::Lobby2::LobbyClient | [virtual]
SetOrderingChannel(char oc) | RakNet::Lobby2::LobbyClientPC |
SetSendPriority(PacketPriority pp) | RakNet::Lobby2::LobbyClientPC |
Update(RakPeerInterface *peer) | PluginInterface | [virtual]

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::LobbyClientInterface Member List

This is the complete list of members for RakNet::LobbyClientInterface, including all inherited members.

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::LobbyClientPC Member List

This is the complete list of members for RakNet::LobbyClientPC, including all inherited members.

AcceptAddFriendInvite(const char *friendHandle, LobbyClientUserId *friendId, const char *messageBody, unsigned char language) | RakNet::LobbyClientPC | [virtual]
AddToActionHistory(LobbyDBSpec::AddToActionHistory_Data *input) | RakNet::LobbyClientPC | [virtual]
AddToOrUpdateIgnoreList(const char *userHandle, LobbyClientUserId *userId, const char *actionsStr) | RakNet::LobbyClientPC | [virtual]
CancelQuickMatch(void) | RakNet::LobbyClientPC | [virtual]
ChangeHandle(const char *newHandle) | RakNet::LobbyClientPC | [virtual]
ChangeNumSlots(int totalSlots, int privateSlots) | RakNet::LobbyClientPC | [virtual]
CreateRoom(const char *roomName, const char *roomPassword, bool roomIsHidden, int publicSlots, int privateSlots, bool allowSpectators, DataStructures::Table *customProperties) | RakNet::LobbyClientPC | [virtual]
DeclineAddFriendInvite(const char *friendHandle, LobbyClientUserId *friendId, const char *messageBody, unsigned char language) | RakNet::LobbyClientPC | [virtual]
DeleteEmail(EmailId *emailId) | RakNet::LobbyClientPC | [virtual]
DownloadActionHistory(bool ascendingSort) | RakNet::LobbyClientPC | [virtual]
DownloadEmails(bool ascendingSort, bool inbox, unsigned char language) | RakNet::LobbyClientPC | [virtual]
DownloadFriends(bool ascendingSortByDate) | RakNet::LobbyClientPC | [virtual]
DownloadIgnoreList(bool ascendingSort) | RakNet::LobbyClientPC | [virtual]
DownloadRating(RankingServerDBSpec::GetRatingForParticipant_Data *input) | RakNet::LobbyClientPC | [virtual]
DownloadRooms(DataStructures::Table::FilterQuery *inclusionFilters, unsigned numInclusionFilters) | RakNet::LobbyClientPC | [virtual]
EqualIDs(const LobbyClientUserId *userId1, const LobbyClientUserId *userId2) | RakNet::LobbyClientPC | [virtual]
GerUserIdFromName(const char *name) | RakNet::LobbyClientPC | [virtual]
GetActionHistoryList(void) const | RakNet::LobbyClientPC | [virtual]
GetAllRoomMembers(void) const | RakNet::LobbyClientPC | [virtual]
GetAllRooms(void) | RakNet::LobbyClientPC | [virtual]
GetFriendsList(void) const | RakNet::LobbyClientPC | [virtual]
GetIgnoreList(void) const | RakNet::LobbyClientPC | [virtual]
GetInboxEmailList(void) const | RakNet::LobbyClientPC | [virtual]
GetLobbyUserStatus(void) const | RakNet::LobbyClientPC | [virtual]
GetMyId(void) | RakNet::LobbyClientPC | [virtual]
GetOpenSlotMembers(void) const | RakNet::LobbyClientPC | [virtual]
GetPrivateSlotMaxCount(void) const | RakNet::LobbyClientPC | [virtual]
GetPublicSlotMaxCount(void) const | RakNet::LobbyClientPC | [virtual]
GetRating(void) | RakNet::LobbyClientPC | [virtual]
GetRecentlyMetUsersList(void) const | RakNet::LobbyClientPC | [virtual]
GetReservedSlotMembers(void) const | RakNet::LobbyClientPC | [virtual]
GetRoomId(void) | RakNet::LobbyClientPC | [virtual]
GetRoomModerator(void) | RakNet::LobbyClientPC | [virtual]
GetRoomName(void) const | RakNet::LobbyClientPC | [virtual]
GetRoomTableRow(void) const | RakNet::LobbyClientPC | [virtual]
GetSentEmailList(void) const | RakNet::LobbyClientPC | [virtual]
GetSpectators(void) const | RakNet::LobbyClientPC | [virtual]
GetTitleId(void) const | RakNet::LobbyClientPC | [virtual]
GetTitleName(void) const | RakNet::LobbyClientPC | [virtual]
GetUserDetails(LobbyClientUserId *userId, LobbyUserClientDetails *details) | RakNet::LobbyClientPC | [virtual]
GrantModerator(LobbyClientUserId *userId) | RakNet::LobbyClientPC | [virtual]
InviteToRoom(const char *userHandle, LobbyClientUserId *userId, const char *chatMessage, unsigned char languageId, const char *chatBinaryData, int chatBinaryLength, bool inviteToPrivateSlot) | RakNet::LobbyClientPC | [virtual]
IsConnected(void) const | RakNet::LobbyClientPC | [virtual]
IsDownloadingRoomList(void) | RakNet::LobbyClientPC | [virtual]
IsFriend(const char *friendHandle) | RakNet::LobbyClientPC | [virtual]
IsFriend(LobbyClientUserId *friendId) | RakNet::LobbyClientPC | [virtual]
IsInReservedSlot(LobbyClientUserId *userId) | RakNet::LobbyClientPC | [virtual]
IsInRoom(void) const | RakNet::LobbyClientPC | [virtual]
IsRoomModerator(LobbyClientUserId *userId) | RakNet::LobbyClientPC | [virtual]
IsUserInRoom(LobbyClientUserId *userId) const | RakNet::LobbyClientPC | [virtual]
IsWaitingOnQuickMatch(void) | RakNet::LobbyClientPC | [virtual]
JoinRoom(LobbyClientRoomId *roomId, const char *roomName, const char *roomPassword, bool joinAsSpectator) | RakNet::LobbyClientPC | [virtual]
JoinRoomByFilter(DataStructures::Table::FilterQuery *inclusionFilters, unsigned numInclusionFilters, bool joinAsSpectator) | RakNet::LobbyClientPC | [virtual]
KickRoomMember(LobbyClientUserId *userId) | RakNet::LobbyClientPC | [virtual]
LeaveRoom(void) | RakNet::LobbyClientPC | [virtual]
Login(const char *userHandle, const char *userPassword, SystemAddress lobbyServerAddr) | RakNet::LobbyClientPC | [virtual]
Logoff(void) | RakNet::LobbyClientPC | [virtual]
OnAttach(RakPeerInterface *peer) | RakNet::LobbyClientPC | [protected, virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | RakNet::LobbyClientPC | [protected, virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | RakNet::LobbyClientPC | [protected, virtual]
OnShutdown(RakPeerInterface *peer) | RakNet::LobbyClientPC | [protected, virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
QuickMatch(int requiredPlayers, int timeoutInSeconds) | RakNet::LobbyClientPC | [virtual]
RegisterAccount(LobbyDBSpec::CreateUser_Data *input, SystemAddress lobbyServerAddr) | RakNet::LobbyClientPC | [virtual]
RemoveFromIgnoreList(LobbyClientUserId *userId) | RakNet::LobbyClientPC | [virtual]
RetrievePassword(const char *userHandle, const char *passwordRecoveryAnswer, SystemAddress lobbyServerAddr) | RakNet::LobbyClientPC | [virtual]
RetrievePasswordRecoveryQuestion(const char *userHandle, SystemAddress lobbyServerAddr) | RakNet::LobbyClientPC | [virtual]
RoomAllowsSpectators(void) const | RakNet::LobbyClientPC | [virtual]
RoomChat(const char *chatMessage, unsigned char languageId, const char *chatBinaryData, int chatBinaryLength) | RakNet::LobbyClientPC | [virtual]
RoomIsHidden(void) const | RakNet::LobbyClientPC | [virtual]
SendAddFriendInvite(const char *friendHandle, LobbyClientUserId *friendId, const char *messageBody, unsigned char language) | RakNet::LobbyClientPC | [virtual]
SendEmail(LobbyDBSpec::SendEmail_Data *input, unsigned char language) | RakNet::LobbyClientPC | [virtual]
SendIM(const char *userHandle, LobbyClientUserId *userId, const char *chatMessage, unsigned char languageId, const char *chatBinaryData, int chatBinaryLength) | RakNet::LobbyClientPC | [virtual]
SetCallbackInterface(LobbyClientInterfaceCB *cbi) | RakNet::LobbyClientPC | [virtual]
SetOrderingChannel(char oc) | RakNet::LobbyClientPC |
SetReadyToPlayStatus(bool isReady) | RakNet::LobbyClientPC | [virtual]
SetRoomAllowSpectators(bool spectatorsOn) | RakNet::LobbyClientPC | [virtual]
SetRoomIsHidden(bool roomIsHidden) | RakNet::LobbyClientPC | [virtual]
SetSendPriority(PacketPriority pp) | RakNet::LobbyClientPC |
SetTitleLoginId(const char *_titleIdStr, const char *_titleLoginPW, int _titleLoginPWLength) | RakNet::LobbyClientPC | [virtual]
StartGame(void) | RakNet::LobbyClientPC | [virtual]
SubmitMatch(RankingServerDBSpec::SubmitMatch_Data *input) | RakNet::LobbyClientPC | [virtual]
PluginInterface::Update(RakPeerInterface *peer) | PluginInterface | [virtual]
UpdateAccount(LobbyDBSpec::UpdateUser_Data *input) | RakNet::LobbyClientPC | [virtual]
UpdateEmailStatus(EmailId *emailId, int newStatus, bool wasOpened) | RakNet::LobbyClientPC | [virtual]

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::LobbyServer Member List

This is the complete list of members for RakNet::LobbyServer, including all inherited members.

DownloadClans_NetMsg(Packet *packet) | RakNet::LobbyServer | [protected]
OnAttach(RakPeerInterface *peer) | RakNet::LobbyServer | [protected, virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | RakNet::LobbyServer | [protected, virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | RakNet::LobbyServer | [protected, virtual]
OnShutdown(RakPeerInterface *peer) | RakNet::LobbyServer | [protected, virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
SetOrderingChannel(char oc) | RakNet::LobbyServer |
Update(RakPeerInterface *peer) | RakNet::LobbyServer | [protected, virtual]
UpdateClanMember_DBResult(bool dbSuccess, const char *queryErrorMessage, LobbyDBSpec::UpdateClanMember_Data *res, unsigned int lobbyMsgId, SystemAddress systemAddress, LobbyDBSpec::DatabaseKey clanSourceMemberId, RakNet::RakString clanSourceMemberHandle) | RakNet::LobbyServer | [protected, virtual]
ValidateUserKey_DBResult(bool dbSuccess, const char *queryErrorMessage, TitleValidationDBSpec::ValidateUserKey_Data *res, SystemAddress systemAddress) | RakNet::LobbyServer | [protected, virtual]

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::LobbyServerPostgreSQL Member List

This is the complete list of members for RakNet::LobbyServerPostgreSQL, including all inherited members.

DownloadClans_NetMsg(Packet *packet) | RakNet::LobbyServer | [protected]
OnAttach(RakPeerInterface *peer) | RakNet::LobbyServer | [protected, virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | RakNet::LobbyServer | [protected, virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | RakNet::LobbyServer | [protected, virtual]
OnShutdown(RakPeerInterface *peer) | RakNet::LobbyServer | [protected, virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
SetOrderingChannel(char oc) | RakNet::LobbyServer |
Update(RakPeerInterface *peer) | RakNet::LobbyServerPostgreSQL | [protected, virtual]
UpdateClanMember_DBResult(bool dbSuccess, const char *queryErrorMessage, LobbyDBSpec::UpdateClanMember_Data *res, unsigned int lobbyMsgId, SystemAddress systemAddress, LobbyDBSpec::DatabaseKey clanSourceMemberId, RakNet::RakString clanSourceMemberHandle) | RakNet::LobbyServer | [protected, virtual]
ValidateUserKey_DBResult(bool dbSuccess, const char *queryErrorMessage, TitleValidationDBSpec::ValidateUserKey_Data *res, SystemAddress systemAddress) | RakNet::LobbyServer | [protected, virtual]

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::RakString Member List

This is the complete list of members for RakNet::RakString, including all inherited members.

C_String(void) const | RakNet::RakString | [inline]
Clear(void) | RakNet::RakString |
Deserialize(BitStream *bs) | RakNet::RakString |
Deserialize(char *str, BitStream *bs) | RakNet::RakString | [static]
DeserializeCompressed(BitStream *bs, bool readLanguageId=false) | RakNet::RakString |
DeserializeCompressed(char *str, BitStream *bs, bool readLanguageId=false) | RakNet::RakString | [static]
Erase(unsigned index, unsigned count) | RakNet::RakString |
FPrintf(FILE *fp) | RakNet::RakString |
FreeMemory(void) | RakNet::RakString | [static]
GetLength(void) const | RakNet::RakString |
IPAddressMatch(const char *IP) | RakNet::RakString |
IsEmpty(void) const | RakNet::RakString |
nPos | RakNet::RakString | [static]
operator const char *() const | RakNet::RakString | [inline]
operator!=(const RakString &rhs) const | RakNet::RakString |
operator+=(const RakString &rhs) | RakNet::RakString |
operator=(const RakString &rhs) | RakNet::RakString |
operator==(const RakString &rhs) const | RakNet::RakString |
operator[](const unsigned int position) const | RakNet::RakString |
Printf(void) | RakNet::RakString |
RakString() | RakNet::RakString |
Replace(unsigned index, unsigned count, unsigned char c) | RakNet::RakString |
Serialize(BitStream *bs) | RakNet::RakString |
Serialize(const char *str, BitStream *bs) | RakNet::RakString | [static]
SerializeCompressed(BitStream *bs, int languageId=0, bool writeLanguageId=false) | RakNet::RakString |
SerializeCompressed(const char *str, BitStream *bs, int languageId=0, bool writeLanguageId=false) | RakNet::RakString | [static]
Set(const char *format,...) | RakNet::RakString |
StrCmp(const RakString &rhs) const | RakNet::RakString |
StrICmp(const RakString &rhs) const | RakNet::RakString |
ToLower(void) | RakNet::RakString |
ToUpper(void) | RakNet::RakString |
URLEncode(void) | RakNet::RakString |

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::Replica2 Member List

This is the complete list of members for RakNet::Replica2, including all inherited members.

AddAutoSerializeTimer(RakNetTime interval, SerializationType serializationType=AUTOSERIALIZE_DEFAULT, RakNetTime countdown=(RakNetTime)-1) | RakNet::Replica2 | [virtual]
AllowRemoteConstruction(SystemAddress sender, RakNet::BitStream *replicaData, SerializationType type, RakNetTime timestamp) | RakNet::Replica2 | [virtual]
BroadcastAutoSerialize(SerializationContext *serializationContext, RakNet::BitStream *serializedObject) | RakNet::Replica2 | [virtual]
BroadcastConstruction(SerializationContext *serializationContext=0) | RakNet::Replica2 | [virtual]
BroadcastDestruction(SerializationContext *serializationContext=0) | RakNet::Replica2 | [virtual]
BroadcastSerialize(SerializationContext *serializationContext=0) | RakNet::Replica2 | [virtual]
BroadcastVisibility(bool isVisible, SerializationContext *serializationContext=0) | RakNet::Replica2 | [virtual]
callGenerationCode | NetworkIDObject | [protected]
CancelAutoSerializeTimer(SerializationType serializationType=AUTOSERIALIZE_DEFAULT) | RakNet::Replica2 | [virtual]
ClearAutoSerializeTimers(void) | RakNet::Replica2 | [virtual]
Deserialize(RakNet::BitStream *bitStream, SerializationType serializationType, SystemAddress sender, RakNetTime timestamp) | RakNet::Replica2 | [virtual]
DeserializeDestruction(RakNet::BitStream *bitStream, SerializationType serializationType, SystemAddress sender, RakNetTime timestamp) | RakNet::Replica2 | [virtual]
DeserializeVisibility(RakNet::BitStream *bitStream, SerializationType serializationType, SystemAddress sender, RakNetTime timestamp) | RakNet::Replica2 | [virtual]
ElapseAutoSerializeTimers(RakNetTime timeElapsed, bool resynchOnly) | RakNet::Replica2 | [virtual]
ForceElapseAllAutoserializeTimers(bool resynchOnly) | RakNet::Replica2 | [virtual]
GenerateID(void) | NetworkIDObject | [protected]
GetAllocationNumber(void) const | NetworkIDObject |
GetNetworkID(void) | NetworkIDObject | [virtual]
GetNetworkIDManager(void) | NetworkIDObject | [virtual]
GetParent(void) const | NetworkIDObject | [virtual]
GetReplicaManager(void) const | RakNet::Replica2 |
GetTimeToNextAutoSerialize(SerializationType serializationType=AUTOSERIALIZE_DEFAULT) | RakNet::Replica2 |
networkID | NetworkIDObject | [protected]
NetworkIDObject() | NetworkIDObject |
nextAllocationNumber | NetworkIDObject | [protected, static]
OnAutoSerializeTimerElapsed(SerializationType serializationType, RakNet::BitStream *output, RakNet::BitStream *lastOutput, RakNetTime lastAutoSerializeCountdown, bool resynchOnly) | RakNet::Replica2 | [virtual]
parent | NetworkIDObject | [protected]
QueryConstruction(Connection_RM2 *connection) | RakNet::Replica2 | [virtual]
QueryIsConstructionAuthority(void) const | RakNet::Replica2 | [virtual]
QueryIsDestructionAuthority(void) const | RakNet::Replica2 | [virtual]
QueryIsSerializationAuthority(void) const | RakNet::Replica2 | [virtual]
QueryIsVisibilityAuthority(void) const | RakNet::Replica2 | [virtual]
QueryVisibility(Connection_RM2 *connection) | RakNet::Replica2 | [virtual]
Replica2() | RakNet::Replica2 |
RequiresSetParent(void) const | NetworkIDObject | [virtual]
SendConstruction(SystemAddress recipientAddress, SerializationType serializationType=UNDEFINED_REASON) | RakNet::Replica2 | [virtual]
SendDestruction(SystemAddress recipientAddress, SerializationType serializationType=UNDEFINED_REASON) | RakNet::Replica2 | [virtual]
SendSerialize(SystemAddress recipientAddress, SerializationType serializationType=UNDEFINED_REASON) | RakNet::Replica2 | [virtual]
SendVisibility(SystemAddress recipientAddress, SerializationType serializationType=UNDEFINED_REASON) | RakNet::Replica2 | [virtual]
Serialize(RakNet::BitStream *bitStream, SerializationContext *serializationContext) | RakNet::Replica2 | [virtual]
SerializeConstruction(RakNet::BitStream *bitStream, SerializationContext *serializationContext)=0 | RakNet::Replica2 | [pure virtual]
SerializeDestruction(RakNet::BitStream *bitStream, SerializationContext *serializationContext) | RakNet::Replica2 | [virtual]
SerializeVisibility(RakNet::BitStream *bitStream, SerializationContext *serializationContext) | RakNet::Replica2 | [virtual]
SetNetworkID(NetworkID id) | NetworkIDObject | [virtual]
SetNetworkIDManager(NetworkIDManager *manager) | NetworkIDObject | [virtual]
SetParent(void *_parent) | NetworkIDObject | [virtual]
SetReplicaManager(ReplicaManager2 *rm) | RakNet::Replica2 |
~NetworkIDObject() | NetworkIDObject | [virtual]
~Replica2() | RakNet::Replica2 | [virtual]

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::ReplicaManager2 Member List

This is the complete list of members for RakNet::ReplicaManager2, including all inherited members.

AddNewConnection(SystemAddress systemAddress) | RakNet::ReplicaManager2 |
Dereference(Replica2 *replica) | RakNet::ReplicaManager2 |
GetConnectionAtIndex(unsigned index) const | RakNet::ReplicaManager2 |
GetConnectionBySystemAddress(SystemAddress systemAddress) const | RakNet::ReplicaManager2 |
GetConnectionCount(void) const | RakNet::ReplicaManager2 |
GetConnectionIndexBySystemAddress(SystemAddress systemAddress) const | RakNet::ReplicaManager2 |
GetConnectionsWithReplicaConstructed(Replica2 *replica, DataStructures::OrderedList< SystemAddress, Connection_RM2 *, ReplicaManager2::Connection_RM2CompBySystemAddress > &output) | RakNet::ReplicaManager2 |
GetConnectionsWithSerializeVisibility(Replica2 *replica, DataStructures::OrderedList< SystemAddress, Connection_RM2 *, ReplicaManager2::Connection_RM2CompBySystemAddress > &output) | RakNet::ReplicaManager2 |
GetRakPeer(void) const | RakNet::ReplicaManager2 |
GetReplicaAtIndex(unsigned index) | RakNet::ReplicaManager2 |
GetReplicaCount(void) const | RakNet::ReplicaManager2 |
HasConnection(SystemAddress systemAddress) | RakNet::ReplicaManager2 |
OnAttach(RakPeerInterface *peer) | RakNet::ReplicaManager2 | [protected, virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | RakNet::ReplicaManager2 | [protected, virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | RakNet::ReplicaManager2 | [protected, virtual]
OnShutdown(RakPeerInterface *peer) | RakNet::ReplicaManager2 | [protected, virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
RecalculateVisibility(Replica2 *replica) | RakNet::ReplicaManager2 |
Reference(Replica2 *replica, bool *newReference) | RakNet::ReplicaManager2 |
RemoveConnection(SystemAddress systemAddress) | RakNet::ReplicaManager2 |
ReplicaManager2() | RakNet::ReplicaManager2 |
SendConstruction(Replica2 *replica, BitStream *replicaData, SystemAddress recipient, RakNetTime timestamp, bool sendMessage, DataStructures::OrderedList< SystemAddress, SystemAddress > &exclusionList, unsigned char localClientId, SerializationType type=SEND_CONSTRUCTION_GENERIC_TO_SYSTEM, PacketPriority priority=NUMBER_OF_PRIORITIES, PacketReliability reliability=NUMBER_OF_RELIABILITIES, char orderingChannel=-1) | RakNet::ReplicaManager2 |
SendDestruction(Replica2 *replica, BitStream *replicaData, SystemAddress recipient, RakNetTime timestamp, bool sendMessage, DataStructures::OrderedList< SystemAddress, SystemAddress > &exclusionList, SerializationType type=SEND_DESTRUCTION_GENERIC_TO_SYSTEM, PacketPriority priority=NUMBER_OF_PRIORITIES, PacketReliability reliability=NUMBER_OF_RELIABILITIES, char orderingChannel=-1) | RakNet::ReplicaManager2 |
SendSerialize(Replica2 *replica, BitStream *replicaData, SystemAddress recipient, RakNetTime timestamp, DataStructures::OrderedList< SystemAddress, SystemAddress > &exclusionList, SerializationType type=SEND_SERIALIZATION_GENERIC_TO_SYSTEM, PacketPriority priority=NUMBER_OF_PRIORITIES, PacketReliability reliability=NUMBER_OF_RELIABILITIES, char orderingChannel=-1) | RakNet::ReplicaManager2 |
SendVisibility(Replica2 *replica, BitStream *replicaData, SystemAddress recipient, RakNetTime timestamp, DataStructures::OrderedList< SystemAddress, SystemAddress > &exclusionList, SerializationType type=SEND_VISIBILITY_TRUE_TO_SYSTEM, PacketPriority priority=NUMBER_OF_PRIORITIES, PacketReliability reliability=NUMBER_OF_RELIABILITIES, char orderingChannel=-1) | RakNet::ReplicaManager2 |
SetAutoAddNewConnections(bool autoAdd) | RakNet::ReplicaManager2 |
SetAutoUpdateScope(bool construction, bool visibility) | RakNet::ReplicaManager2 |
SetConnectionFactory(Connection_RM2Factory *factory) | RakNet::ReplicaManager2 |
SetDefaultOrderingChannel(char def) | RakNet::ReplicaManager2 |
SetDefaultPacketPriority(PacketPriority def) | RakNet::ReplicaManager2 |
SetDefaultPacketReliability(PacketReliability def) | RakNet::ReplicaManager2 |
SetDoReplicaAutoSerializeUpdate(bool autoUpdate) | RakNet::ReplicaManager2 |
Update(RakPeerInterface *peer) | RakNet::ReplicaManager2 | [protected, virtual]
~ReplicaManager2() | RakNet::ReplicaManager2 | [virtual]

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::RPC3 Member List

This is the complete list of members for RakNet::RPC3, including all inherited members.

Call(const char *uniqueIdentifier) | RakNet::RPC3 | [inline]
CallExplicit(const char *uniqueIdentifier, const CallExplicitParameters *const callExplicitParameters) | RakNet::RPC3 | [inline]
GetCurrentExecution(void) const | RakNet::RPC3 |
GetLastSenderAddress(void) const | RakNet::RPC3 |
GetLastSenderTimestamp(void) const | RakNet::RPC3 |
GetRakPeer(void) const | RakNet::RPC3 |
IsFunctionRegistered(const char *uniqueIdentifier) | RakNet::RPC3 |
OnAttach(RakPeerInterface *peer) | RakNet::RPC3 | [protected, virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | RakNet::RPC3 | [protected, virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | RakNet::RPC3 | [protected, virtual]
OnShutdown(RakPeerInterface *peer) | RakNet::RPC3 | [protected, virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
RegisterFunction(const char *uniqueIdentifier, Function functionPtr) | RakNet::RPC3 | [inline]
RPC3() | RakNet::RPC3 |
SetNetworkIDManager(NetworkIDManager *idMan) | RakNet::RPC3 |
SetRecipientAddress(SystemAddress systemAddress, bool broadcast) | RakNet::RPC3 |
SetRecipientObject(NetworkID networkID) | RakNet::RPC3 |
SetSendParams(PacketPriority priority, PacketReliability reliability, char orderingChannel) | RakNet::RPC3 |
SetTimestamp(RakNetTime timeStamp) | RakNet::RPC3 |
UnregisterFunction(const char *uniqueIdentifier) | RakNet::RPC3 |
Update(RakPeerInterface *peer) | PluginInterface | [virtual]
~RPC3() | RakNet::RPC3 | [virtual]

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::StringTable Member List

This is the complete list of members for RakNet::StringTable, including all inherited members.

AddReference(void) | RakNet::StringTable | [static]
AddString(const char *str, bool copyString) | RakNet::StringTable |
DecodeString(char *output, int maxCharsToWrite, RakNet::BitStream *input) | RakNet::StringTable |
EncodeString(const char *input, int maxCharsToWrite, RakNet::BitStream *output) | RakNet::StringTable |
Instance(void) | RakNet::StringTable | [static]
instance | RakNet::StringTable | [protected, static]
LogStringNotFound(const char *strName) | RakNet::StringTable | [protected]
RemoveReference(void) | RakNet::StringTable | [static]
StringTable() | RakNet::StringTable | [protected]
~StringTable() | RakNet::StringTable |

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNetCommandParser Member List

This is the complete list of members for RakNetCommandParser, including all inherited members.

GetName(void) const | RakNetCommandParser | [virtual]
IntegersToSystemAddress(int binaryAddress, int port) | CommandParserInterface | [protected]
OnCommand(const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, SystemAddress systemAddress, const char *originalString) | RakNetCommandParser | [virtual]
OnConnectionLost(SystemAddress systemAddress, TransportInterface *transport) | CommandParserInterface | [virtual]
OnNewIncomingConnection(SystemAddress systemAddress, TransportInterface *transport) | CommandParserInterface | [virtual]
OnTransportChange(TransportInterface *transport) | CommandParserInterface | [virtual]
peer | RakNetCommandParser | [protected]
RegisterCommand(unsigned char parameterCount, const char *command, const char *commandHelp) | CommandParserInterface | [protected, virtual]
ReturnResult(bool res, const char *command, TransportInterface *transport, SystemAddress systemAddress) | CommandParserInterface | [protected, virtual]
ReturnResult(const char *command, TransportInterface *transport, SystemAddress systemAddress) | CommandParserInterface | [protected, virtual]
SendHelp(TransportInterface *transport, SystemAddress systemAddress) | RakNetCommandParser | [virtual]
SetRakPeerInterface(RakPeerInterface *rakPeer) | RakNetCommandParser |

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNetTransport Member List

This is the complete list of members for RakNetTransport, including all inherited members.

CloseConnection(SystemAddress systemAddress) | RakNetTransport | [virtual]
DeallocatePacket(Packet *packet) | RakNetTransport | [virtual]
GetCommandParser(void) | RakNetTransport | [virtual]
GetIncomingPassword(void) | RakNetTransport |
HasLostConnection(void) | RakNetTransport | [virtual]
HasNewConnection(void) | RakNetTransport | [virtual]
Receive(void) | RakNetTransport | [virtual]
Send(SystemAddress systemAddress, const char *data,...) | RakNetTransport | [virtual]
SetIncomingPassword(const char *password) | RakNetTransport |
Start(unsigned short port, bool serverMode) | RakNetTransport | [virtual]
Stop(void) | RakNetTransport | [virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNetTransportCommandParser Member List

This is the complete list of members for RakNetTransportCommandParser, including all inherited members.

GetName(void) const | RakNetTransportCommandParser | [virtual]
IntegersToSystemAddress(int binaryAddress, int port) | CommandParserInterface | [protected]
OnCommand(const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, SystemAddress systemAddress, const char *originalString) | RakNetTransportCommandParser | [virtual]
OnConnectionLost(SystemAddress systemAddress, TransportInterface *transport) | CommandParserInterface | [virtual]
OnNewIncomingConnection(SystemAddress systemAddress, TransportInterface *transport) | CommandParserInterface | [virtual]
OnTransportChange(TransportInterface *transport) | CommandParserInterface | [virtual]
RegisterCommand(unsigned char parameterCount, const char *command, const char *commandHelp) | CommandParserInterface | [protected, virtual]
ReturnResult(bool res, const char *command, TransportInterface *transport, SystemAddress systemAddress) | CommandParserInterface | [protected, virtual]
ReturnResult(const char *command, TransportInterface *transport, SystemAddress systemAddress) | CommandParserInterface | [protected, virtual]
SendHelp(TransportInterface *transport, SystemAddress systemAddress) | RakNetTransportCommandParser | [virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakPeer Member List

This is the complete list of members for RakPeer, including all inherited members.

AddToBanList(const char *IP, RakNetTime milliseconds=0) | RakPeer | [virtual]
AddToSecurityExceptionList(const char *ip) | RakPeer | [virtual]
AdvertiseSystem(const char *host, unsigned short remotePort, const char *data, int dataLength, unsigned connectionSocketIndex=0) | RakPeer | [virtual]
AllocatePacket(unsigned dataSize) | RakPeer | [virtual]
allowConnectionResponseIPMigration | RakPeer | [protected]
AllowConnectionResponseIPMigration(bool allow) | RakPeer | [virtual]
ApplyNetworkSimulator(double maxSendBPS, unsigned short minExtraPing, unsigned short extraPingVariance) | RakPeer | [virtual]
AssignSystemAddressToRemoteSystemList(const SystemAddress systemAddress, RemoteSystemStruct::ConnectMode connectionMode, unsigned connectionSocketIndex) | RakPeer | [protected]
AttachPlugin(PluginInterface *plugin) | RakPeer | [virtual]
bytesSentPerSecond | RakPeer | [protected]
ClearBanList(void) | RakPeer | [virtual]
CloseConnection(const SystemAddress target, bool sendDisconnectionNotification, unsigned char orderingChannel=0) | RakPeer | [virtual]
Connect(const char *host, unsigned short remotePort, const char *passwordData, int passwordDataLength, unsigned connectionSocketIndex=0) | RakPeer | [virtual]
DeallocatePacket(Packet *packet) | RakPeer | [virtual]
DeleteCompressionLayer(bool inputLayer) | RakPeer | [virtual]
DetachPlugin(PluginInterface *messageHandler) | RakPeer | [virtual]
DisableSecurity(void) | RakPeer | [virtual]
endThreads | RakPeer | [protected]
frequencyTable | RakPeer | [protected]
GenerateCompressionLayer(unsigned int inputFrequencyTable[256], bool inputLayer) | RakPeer | [virtual]
GetAveragePing(const SystemAddress systemAddress) | RakPeer | [virtual]
GetBestClockDifferential(const SystemAddress systemAddress) const | RakPeer | [protected]
GetCompressionRatio(void) const | RakPeer | [virtual]
GetConnectionList(SystemAddress *remoteSystems, unsigned short *numberOfSystems) const | RakPeer | [virtual]
GetDecompressionRatio(void) const | RakPeer | [virtual]
GetExternalID(const SystemAddress target) const | RakPeer | [virtual]
GetIncomingPassword(char *passwordData, int *passwordDataLength) | RakPeer | [virtual]
GetIndexFromSystemAddress(const SystemAddress systemAddress) | RakPeer | [virtual]
GetInternalID(const SystemAddress systemAddress=UNASSIGNED_SYSTEM_ADDRESS) const | RakPeer | [virtual]
GetLastPing(const SystemAddress systemAddress) const | RakPeer | [virtual]
GetLocalIP(unsigned int index) | RakPeer | [virtual]
GetLowestPing(const SystemAddress systemAddress) const | RakPeer | [virtual]
GetMaximumIncomingConnections(void) const | RakPeer | [virtual]
GetMaximumNumberOfPeers(void) const | RakPeer | [virtual]
GetMTUSize(const SystemAddress target) const | RakPeer | [virtual]
GetNetworkIDManager(void) const | RakPeer | [virtual]
GetNumberOfAddresses(void) | RakPeer | [virtual]
GetNumberOfRemoteInitiatedConnections(void) const | RakPeer | [protected]
GetOfflinePingResponse(char **data, unsigned int *length) | RakPeer | [virtual]
GetOutgoingFrequencyTable(unsigned int outputFrequencyTable[256]) | RakPeer | [virtual]
GetRemoteSystemFromSystemAddress(const SystemAddress systemAddress, bool calledFromNetworkThread, bool onlyActive) const | RakPeer | [protected]
GetStatistics(const SystemAddress systemAddress) | RakPeer | [virtual]
GetSystemAddressFromIndex(int index) | RakPeer | [virtual]
HandleRPCPacket(const char *data, int length, SystemAddress systemAddress) | RakPeer | [protected]
HandleRPCReplyPacket(const char *data, int length, SystemAddress systemAddress) | RakPeer | [protected]
InitializeSecurity(const char *pubKeyE, const char *pubKeyN, const char *privKeyP, const char *privKeyQ) | RakPeer | [virtual]
IsActive(void) const | RakPeer | [inline, virtual]
IsBanned(const char *IP) | RakPeer | [virtual]
IsConnected(const SystemAddress systemAddress, bool includeInProgress=false, bool includeDisconnecting=false) | RakPeer | [virtual]
IsInSecurityExceptionList(const char *ip) | RakPeer | [virtual]
IsLocalIP(const char *ip) | RakPeer | [virtual]
isMainLoopThreadActive | RakPeer | [protected]
IsNetworkSimulatorActive(void) | RakPeer | [virtual]
maximumIncomingConnections | RakPeer | [protected]
maximumNumberOfPeers | RakPeer | [protected]
mySystemAddress | RakPeer | [protected]
NotifyAndFlagForShutdown(const SystemAddress systemAddress, bool performImmediate, unsigned char orderingChannel) | RakPeer | [protected]
NumberOfConnections(void) const | RakPeer | [virtual]
OnConnectionRequest(RakPeer::RemoteSystemStruct *remoteSystem, unsigned char *AESKey, bool setAESKey) | RakPeer | [protected]
ParseConnectionRequestPacket(RakPeer::RemoteSystemStruct *remoteSystem, SystemAddress systemAddress, const char *data, int byteSize) | RakPeer | [protected]
Ping(const SystemAddress target) | RakPeer | [virtual]
Ping(const char *host, unsigned short remotePort, bool onlyReplyOnAcceptingConnections, unsigned connectionSocketIndex=0) | RakPeer | [virtual]
PushBackPacket(Packet *packet, bool pushAtHead) | RakPeer | [virtual]
RakPeer() | RakPeer |
Receive(void) | RakPeer | [virtual]
RegisterAsRemoteProcedureCall(const char *uniqueID, void(*functionPointer)(RPCParameters *rpcParms)) | RakPeer | [virtual]
RegisterClassMemberRPC(const char *uniqueID, void *functionPointer) | RakPeer | [virtual]
remoteSystemList | RakPeer | [protected]
RemoveFromBanList(const char *IP) | RakPeer | [virtual]
RemoveFromSecurityExceptionList(const char *ip) | RakPeer | [virtual]
RemoveRouterInterface(RouterInterface *routerInterface) | RakPeer | [virtual]
RPC(const char *uniqueID, const char *data, BitSize_t bitLength, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, RakNetTime *includedTimestamp, NetworkID networkID, RakNet::BitStream *replyFromTarget) | RakPeer | [virtual]
RPC(const char *uniqueID, const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, RakNetTime *includedTimestamp, NetworkID networkID, RakNet::BitStream *replyFromTarget) | RakPeer | [virtual]
rsacrypt | RakPeer | [protected]
Send(const char *data, const int length, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast) | RakPeer | [virtual]
Send(const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast) | RakPeer | [virtual]
SendList(char **data, const int *lengths, const int numParameters, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast) | RakPeer | [virtual]
SendTTL(const char *host, unsigned short remotePort, int ttl, unsigned connectionSocketIndex=0) | RakPeer | [virtual]
SetCompileFrequencyTable(bool doCompile) | RakPeer | [virtual]
SetIncomingPassword(const char *passwordData, int passwordDataLength) | RakPeer | [virtual]
SetMaximumIncomingConnections(unsigned short numberAllowed) | RakPeer | [virtual]
SetMTUSize(int size) | RakPeer | [virtual]
SetNetworkIDManager(NetworkIDManager *manager) | RakPeer | [virtual]
SetOccasionalPing(bool doPing) | RakPeer | [virtual]
SetOfflinePingResponse(const char *data, const unsigned int length) | RakPeer | [virtual]
SetPerConnectionOutgoingBandwidthLimit(unsigned maxBitsPerSecond) | RakPeer | [virtual]
SetRouterInterface(RouterInterface *routerInterface) | RakPeer | [virtual]
SetSplitMessageProgressInterval(int interval) | RakPeer | [virtual]
SetTimeoutTime(RakNetTime timeMS, const SystemAddress target) | RakPeer | [virtual]
SetUnreliableTimeout(RakNetTime timeoutMS) | RakPeer | [virtual]
ShiftIncomingTimestamp(unsigned char *data, SystemAddress systemAddress) const | RakPeer | [protected]
Shutdown(unsigned int blockDuration, unsigned char orderingChannel=0) | RakPeer | [virtual]
Startup(unsigned short maxConnections, int _threadSleepTimer, SocketDescriptor *socketDescriptors, unsigned socketDescriptorCount) | RakPeer | [virtual]
UnregisterAsRemoteProcedureCall(const char *uniqueID) | RakPeer | [virtual]
updateCycleIsRunning | RakPeer | [protected]
~RakPeer() | RakPeer | [virtual]
~RakPeerInterface() | RakPeerInterface | [inline, virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakPeerInterface Member List

This is the complete list of members for RakPeerInterface, including all inherited members.

AddToBanList(const char *IP, RakNetTime milliseconds=0)=0 | RakPeerInterface | [pure virtual]
AddToSecurityExceptionList(const char *ip)=0 | RakPeerInterface | [pure virtual]
AdvertiseSystem(const char *host, unsigned short remotePort, const char *data, int dataLength, unsigned connectionSocketIndex=0)=0 | RakPeerInterface | [pure virtual]
AllocatePacket(unsigned dataSize)=0 | RakPeerInterface | [pure virtual]
AllowConnectionResponseIPMigration(bool allow)=0 | RakPeerInterface | [pure virtual]
ApplyNetworkSimulator(double maxSendBPS, unsigned short minExtraPing, unsigned short extraPingVariance)=0 | RakPeerInterface | [pure virtual]
AttachPlugin(PluginInterface *plugin)=0 | RakPeerInterface | [pure virtual]
ClearBanList(void)=0 | RakPeerInterface | [pure virtual]
CloseConnection(const SystemAddress target, bool sendDisconnectionNotification, unsigned char orderingChannel=0)=0 | RakPeerInterface | [pure virtual]
Connect(const char *host, unsigned short remotePort, const char *passwordData, int passwordDataLength, unsigned connectionSocketIndex=0)=0 | RakPeerInterface | [pure virtual]
DeallocatePacket(Packet *packet)=0 | RakPeerInterface | [pure virtual]
DeleteCompressionLayer(bool inputLayer)=0 | RakPeerInterface | [pure virtual]
DetachPlugin(PluginInterface *messageHandler)=0 | RakPeerInterface | [pure virtual]
DisableSecurity(void)=0 | RakPeerInterface | [pure virtual]
GenerateCompressionLayer(unsigned int inputFrequencyTable[256], bool inputLayer)=0 | RakPeerInterface | [pure virtual]
GetAveragePing(const SystemAddress systemAddress)=0 | RakPeerInterface | [pure virtual]
GetCompressionRatio(void) const =0 | RakPeerInterface | [pure virtual]
GetConnectionList(SystemAddress *remoteSystems, unsigned short *numberOfSystems) const =0 | RakPeerInterface | [pure virtual]
GetDecompressionRatio(void) const =0 | RakPeerInterface | [pure virtual]
GetExternalID(const SystemAddress target) const =0 | RakPeerInterface | [pure virtual]
GetIncomingPassword(char *passwordData, int *passwordDataLength)=0 | RakPeerInterface | [pure virtual]
GetIndexFromSystemAddress(const SystemAddress systemAddress)=0 | RakPeerInterface | [pure virtual]
GetInternalID(const SystemAddress systemAddress=UNASSIGNED_SYSTEM_ADDRESS) const =0 | RakPeerInterface | [pure virtual]
GetLastPing(const SystemAddress systemAddress) const =0 | RakPeerInterface | [pure virtual]
GetLocalIP(unsigned int index)=0 | RakPeerInterface | [pure virtual]
GetLowestPing(const SystemAddress systemAddress) const =0 | RakPeerInterface | [pure virtual]
GetMaximumIncomingConnections(void) const =0 | RakPeerInterface | [pure virtual]
GetMaximumNumberOfPeers(void) const =0 | RakPeerInterface | [pure virtual]
GetMTUSize(const SystemAddress target) const =0 | RakPeerInterface | [pure virtual]
GetNetworkIDManager(void) const =0 | RakPeerInterface | [pure virtual]
GetNumberOfAddresses(void)=0 | RakPeerInterface | [pure virtual]
GetOfflinePingResponse(char **data, unsigned int *length)=0 | RakPeerInterface | [pure virtual]
GetOutgoingFrequencyTable(unsigned int outputFrequencyTable[256])=0 | RakPeerInterface | [pure virtual]
GetStatistics(const SystemAddress systemAddress)=0 | RakPeerInterface | [pure virtual]
GetSystemAddressFromIndex(int index)=0 | RakPeerInterface | [pure virtual]
InitializeSecurity(const char *pubKeyE, const char *pubKeyN, const char *privKeyP, const char *privKeyQ)=0 | RakPeerInterface | [pure virtual]
IsActive(void) const =0 | RakPeerInterface | [pure virtual]
IsBanned(const char *IP)=0 | RakPeerInterface | [pure virtual]
IsConnected(const SystemAddress systemAddress, bool includeInProgress=false, bool includeDisconnecting=false)=0 | RakPeerInterface | [pure virtual]
IsInSecurityExceptionList(const char *ip)=0 | RakPeerInterface | [pure virtual]
IsLocalIP(const char *ip)=0 | RakPeerInterface | [pure virtual]
IsNetworkSimulatorActive(void)=0 | RakPeerInterface | [pure virtual]
NumberOfConnections(void) const =0 | RakPeerInterface | [pure virtual]
Ping(const SystemAddress target)=0 | RakPeerInterface | [pure virtual]
Ping(const char *host, unsigned short remotePort, bool onlyReplyOnAcceptingConnections, unsigned connectionSocketIndex=0)=0 | RakPeerInterface | [pure virtual]
PushBackPacket(Packet *packet, bool pushAtHead)=0 | RakPeerInterface | [pure virtual]
Receive(void)=0 | RakPeerInterface | [pure virtual]
RegisterAsRemoteProcedureCall(const char *uniqueID, void(*functionPointer)(RPCParameters *rpcParms))=0 | RakPeerInterface | [pure virtual]
RegisterClassMemberRPC(const char *uniqueID, void *functionPointer)=0 | RakPeerInterface | [pure virtual]
RemoveFromBanList(const char *IP)=0 | RakPeerInterface | [pure virtual]
RemoveFromSecurityExceptionList(const char *ip)=0 | RakPeerInterface | [pure virtual]
RemoveRouterInterface(RouterInterface *routerInterface)=0 | RakPeerInterface | [pure virtual]
RPC(const char *uniqueID, const char *data, BitSize_t bitLength, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, RakNetTime *includedTimestamp, NetworkID networkID, RakNet::BitStream *replyFromTarget)=0 | RakPeerInterface | [pure virtual]
RPC(const char *uniqueID, const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast, RakNetTime *includedTimestamp, NetworkID networkID, RakNet::BitStream *replyFromTarget)=0 | RakPeerInterface | [pure virtual]
Send(const char *data, const int length, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast)=0 | RakPeerInterface | [pure virtual]
Send(const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast)=0 | RakPeerInterface | [pure virtual]
SendList(char **data, const int *lengths, const int numParameters, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddress systemAddress, bool broadcast)=0 | RakPeerInterface | [pure virtual]
SendTTL(const char *host, unsigned short remotePort, int ttl, unsigned connectionSocketIndex=0)=0 | RakPeerInterface | [pure virtual]
SetCompileFrequencyTable(bool doCompile)=0 | RakPeerInterface | [pure virtual]
SetIncomingPassword(const char *passwordData, int passwordDataLength)=0 | RakPeerInterface | [pure virtual]
SetMaximumIncomingConnections(unsigned short numberAllowed)=0 | RakPeerInterface | [pure virtual]
SetMTUSize(int size)=0 | RakPeerInterface | [pure virtual]
SetNetworkIDManager(NetworkIDManager *manager)=0 | RakPeerInterface | [pure virtual]
SetOccasionalPing(bool doPing)=0 | RakPeerInterface | [pure virtual]
SetOfflinePingResponse(const char *data, const unsigned int length)=0 | RakPeerInterface | [pure virtual]
SetPerConnectionOutgoingBandwidthLimit(unsigned maxBitsPerSecond)=0 | RakPeerInterface | [pure virtual]
SetRouterInterface(RouterInterface *routerInterface)=0 | RakPeerInterface | [pure virtual]
SetSplitMessageProgressInterval(int interval)=0 | RakPeerInterface | [pure virtual]
SetTimeoutTime(RakNetTime timeMS, const SystemAddress target)=0 | RakPeerInterface | [pure virtual]
SetUnreliableTimeout(RakNetTime timeoutMS)=0 | RakPeerInterface | [pure virtual]
Shutdown(unsigned int blockDuration, unsigned char orderingChannel=0)=0 | RakPeerInterface | [pure virtual]
Startup(unsigned short maxConnections, int _threadSleepTimer, SocketDescriptor *socketDescriptors, unsigned socketDescriptorCount)=0 | RakPeerInterface | [pure virtual]
UnregisterAsRemoteProcedureCall(const char *uniqueID)=0 | RakPeerInterface | [pure virtual]
~RakPeerInterface() | RakPeerInterface | [inline, virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RankingServer_PostgreSQL Member List

This is the complete list of members for RankingServer_PostgreSQL, including all inherited members.

AssignCallback(RankingServerCBInterface *cb) | RankingServer_PostgreSQL |
CreateRankingServerTables(void) | RankingServer_PostgreSQL |
DestroyRankingServerTables(void) | RankingServer_PostgreSQL |
PushFunctor(RankingServerFunctor *functor, void *context=0) | RankingServer_PostgreSQL | [virtual]

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RankingServerCBInterface Member List

This is the complete list of members for RankingServerCBInterface, including all inherited members.

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RankingServerDBSpec::GetHistoryForParticipant_Data Member List

This is the complete list of members for RankingServerDBSpec::GetHistoryForParticipant_Data, including all inherited members.

gameDbId | RankingServerDBSpec::GetHistoryForParticipant_Data
matchHistoryList | RankingServerDBSpec::GetHistoryForParticipant_Data
participantDbId | RankingServerDBSpec::GetHistoryForParticipant_Data

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RankingServerDBSpec::GetRatingForParticipant_Data Member List

This is the complete list of members for RankingServerDBSpec::GetRatingForParticipant_Data, including all inherited members.

gameDbId | RankingServerDBSpec::GetRatingForParticipant_Data
participantDbId | RankingServerDBSpec::GetRatingForParticipant_Data
participantFound | RankingServerDBSpec::GetRatingForParticipant_Data
rating | RankingServerDBSpec::GetRatingForParticipant_Data

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RankingServerDBSpec::GetRatingForParticipants_Data Member List

This is the complete list of members for RankingServerDBSpec::GetRatingForParticipants_Data, including all inherited members.

gameDbId | RankingServerDBSpec::GetRatingForParticipants_Data
outputList | RankingServerDBSpec::GetRatingForParticipants_Data

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RankingServerDBSpec::GetTrustedIPList_Data Member List

This is the complete list of members for RankingServerDBSpec::GetTrustedIPList_Data, including all inherited members.

ipList RankingServerDBSpec::GetTrustedIPList_Data

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RankingServerDBSpec::ModifyTrustedIPList_Data Member List

This is the complete list of members for RankingServerDBSpec::ModifyTrustedIPList_Data, including all inherited members.

addToList | RankingServerDBSpec::ModifyTrustedIPList_Data
gameDbId | RankingServerDBSpec::ModifyTrustedIPList_Data
ip | RankingServerDBSpec::ModifyTrustedIPList_Data
systemAddress | RankingServerDBSpec::ModifyTrustedIPList_Data

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RankingServerDBSpec::SubmitMatch_Data Member List

This is the complete list of members for RankingServerDBSpec::SubmitMatch_Data, including all inherited members.

gameDbId | RankingServerDBSpec::SubmitMatch_Data
matchBinaryData | RankingServerDBSpec::SubmitMatch_Data
matchBinaryDataLength | RankingServerDBSpec::SubmitMatch_Data
matchNotes | RankingServerDBSpec::SubmitMatch_Data
matchTime | RankingServerDBSpec::SubmitMatch_Data
participantADbId | RankingServerDBSpec::SubmitMatch_Data
participantANewRating | RankingServerDBSpec::SubmitMatch_Data
participantAOldRating | RankingServerDBSpec::SubmitMatch_Data
participantAScore | RankingServerDBSpec::SubmitMatch_Data
participantBDbId | RankingServerDBSpec::SubmitMatch_Data
participantBNewRating | RankingServerDBSpec::SubmitMatch_Data
participantBOldRating | RankingServerDBSpec::SubmitMatch_Data
participantBScore | RankingServerDBSpec::SubmitMatch_Data

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

ReadyEvent Member List

This is the complete list of members for ReadyEvent, including all inherited members.

AddToWaitList(int eventId, SystemAddress address) | ReadyEvent |
DeleteEvent(int eventId) | ReadyEvent |
GetEventAtIndex(unsigned index) const | ReadyEvent |
GetEventListSize(void) const | ReadyEvent |
GetFromWaitListAtIndex(int eventId, unsigned index) const | ReadyEvent |
GetReadyStatus(int eventId, SystemAddress address) | ReadyEvent |
GetRemoteWaitListSize(int eventId) const | ReadyEvent |
HasEvent(int eventId) | ReadyEvent |
IsEventCompleted(int eventId) const | ReadyEvent |
IsEventCompletionProcessing(int eventId) const | ReadyEvent |
IsEventSet(int eventId) | ReadyEvent |
IsInWaitList(int eventId, SystemAddress address) | ReadyEvent |
OnAttach(RakPeerInterface *peer) | ReadyEvent | [protected, virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | ReadyEvent | [protected, virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | ReadyEvent | [protected, virtual]
OnShutdown(RakPeerInterface *peer) | ReadyEvent | [protected, virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
ReadyEvent() | ReadyEvent |
RemoveFromWaitList(int eventId, SystemAddress address) | ReadyEvent |
SetEvent(int eventId, bool isReady) | ReadyEvent |
SetSendChannel(unsigned char newChannel) | ReadyEvent |
Update(RakPeerInterface *peer) | PluginInterface | [virtual]
~ReadyEvent() | ReadyEvent | [virtual]

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

ReceiveConstructionInterface Member List

This is the complete list of members for ReceiveConstructionInterface, including all inherited members.

ReceiveConstruction(RakNet::BitStream *inBitStream, RakNetTime timestamp, NetworkID networkID, NetworkIDObject *existingObject, SystemAddress senderId, ReplicaManager *caller)=0 ReceiveConstructionInterface [pure virtual]

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

ReceiveDownloadCompleteInterface Member List

This is the complete list of members for ReceiveDownloadCompleteInterface, including all inherited members.

ReceiveDownloadComplete(RakNet::BitStream *inBitStream, SystemAddress senderId, ReplicaManager *caller)=0 ReceiveDownloadCompleteInterface [pure virtual]

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RefCountedObj Member List

This is the complete list of members for RefCountedObj, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

ReliabilityLayer Member List

This is the complete list of members for ReliabilityLayer, including all inherited members.

AckTimeout(RakNetTimeNS curTime) | ReliabilityLayer
GetStatistics(void) | ReliabilityLayer
GetTimeoutTime(void) | ReliabilityLayer
HandleSocketReceiveFromConnectedPlayer(const char *buffer, unsigned int length, SystemAddress systemAddress, DataStructures::List< PluginInterface * > &messageHandlerList, int MTUSize) | ReliabilityLayer
IsCheater(void) const | ReliabilityLayer
IsDeadConnection(void) const | ReliabilityLayer
IsNetworkSimulatorActive(void) | ReliabilityLayer
IsOutgoingDataWaiting(void) | ReliabilityLayer
KillConnection(void) | ReliabilityLayer
Receive(unsigned char **data) | ReliabilityLayer
ReliabilityLayer() | ReliabilityLayer
Reset(bool resetVariables) | ReliabilityLayer
Send(char *data, BitSize_t numberOfBitsToSend, PacketPriority priority, PacketReliability reliability, unsigned char orderingChannel, bool makeDataCopy, int MTUSize, RakNetTimeNS currentTime) | ReliabilityLayer
SetEncryptionKey(const unsigned char *key) | ReliabilityLayer
SetTimeoutTime(RakNetTime time) | ReliabilityLayer
Update(SOCKET s, SystemAddress systemAddress, int MTUSize, RakNetTimeNS time, unsigned maxBitsPerSecond, DataStructures::List< PluginInterface * > &messageHandlerList) | ReliabilityLayer
~ReliabilityLayer() | ReliabilityLayer

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

Replica Member List

This is the complete list of members for Replica, including all inherited members.

callGenerationCode | NetworkIDObject | [protected]
Deserialize(RakNet::BitStream *inBitStream, RakNetTime timestamp, RakNetTime lastDeserializeTime, SystemAddress systemAddress)=0 | Replica | [pure virtual]
GenerateID(void) | NetworkIDObject | [protected]
GetAllocationNumber(void) const | NetworkIDObject |
GetNetworkID(void) | NetworkIDObject | [virtual]
GetNetworkIDManager(void) | NetworkIDObject | [virtual]
GetParent(void) const | NetworkIDObject | [virtual]
GetSortPriority(void) const =0 | Replica | [pure virtual]
networkID | NetworkIDObject | [protected]
NetworkIDObject() | NetworkIDObject |
nextAllocationNumber | NetworkIDObject | [protected, static]
parent | NetworkIDObject | [protected]
ReceiveDestruction(RakNet::BitStream *inBitStream, SystemAddress systemAddress, RakNetTime timestamp)=0 | Replica | [pure virtual]
ReceiveScopeChange(RakNet::BitStream *inBitStream, SystemAddress systemAddress, RakNetTime timestamp)=0 | Replica | [pure virtual]
RequiresSetParent(void) const | NetworkIDObject | [virtual]
SendConstruction(RakNetTime currentTime, SystemAddress systemAddress, unsigned int &flags, RakNet::BitStream *outBitStream, bool *includeTimestamp)=0 | Replica | [pure virtual]
SendDestruction(RakNet::BitStream *outBitStream, SystemAddress systemAddress, bool *includeTimestamp)=0 | Replica | [pure virtual]
SendScopeChange(bool inScope, RakNet::BitStream *outBitStream, RakNetTime currentTime, SystemAddress systemAddress, bool *includeTimestamp)=0 | Replica | [pure virtual]
Serialize(bool *sendTimestamp, RakNet::BitStream *outBitStream, RakNetTime lastSendTime, PacketPriority *priority, PacketReliability *reliability, RakNetTime currentTime, SystemAddress systemAddress, unsigned int &flags)=0 | Replica | [pure virtual]
SetNetworkID(NetworkID id) | NetworkIDObject | [virtual]
SetNetworkIDManager(NetworkIDManager *manager) | NetworkIDObject | [virtual]
SetParent(void *_parent) | NetworkIDObject | [virtual]
~NetworkIDObject() | NetworkIDObject | [virtual]

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

ReplicaManager Member List

This is the complete list of members for ReplicaManager, including all inherited members.

AccessSerializationFlags(Replica *replica, SystemAddress systemAddress) | ReplicaManager |
AddParticipant(SystemAddress systemAddress) | ReplicaManager |
AssertParticipantsClear(void) | ReplicaManager |
AssertReplicatedObjectsClear(void) | ReplicaManager |
Clear(void) | ReplicaManager | [protected]
Construct(Replica *replica, bool isCopy, SystemAddress systemAddress, bool broadcast) | ReplicaManager |
DereferencePointer(Replica *replica) | ReplicaManager |
Destruct(Replica *replica, SystemAddress systemAddress, bool broadcast) | ReplicaManager |
DisableReplicaInterfaces(Replica *replica, unsigned char interfaceFlags) | ReplicaManager |
EnableReplicaInterfaces(Replica *replica, unsigned char interfaceFlags) | ReplicaManager |
GetParticipantAtIndex(unsigned index) | ReplicaManager |
GetParticipantCount(void) const | ReplicaManager |
GetReplicaAtIndex(unsigned index) | ReplicaManager |
GetReplicaCount(void) const | ReplicaManager |
HasParticipant(SystemAddress systemAddress) | ReplicaManager |
IsConstructed(Replica *replica, SystemAddress systemAddress) | ReplicaManager |
IsInScope(Replica *replica, SystemAddress systemAddress) | ReplicaManager |
OnAttach(RakPeerInterface *peer) | ReplicaManager | [protected, virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | ReplicaManager | [protected, virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | ReplicaManager | [protected, virtual]
OnShutdown(RakPeerInterface *peer) | ReplicaManager | [protected, virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
participantList | ReplicaManager | [protected]
ReferencePointer(Replica *replica) | ReplicaManager |
RemoveParticipant(SystemAddress systemAddress) | ReplicaManager |
ReplicaManager() | ReplicaManager |
replicatedObjects | ReplicaManager | [protected]
SetAutoConstructToNewParticipants(bool autoConstruct) | ReplicaManager |
SetAutoParticipateNewConnections(bool autoAdd) | ReplicaManager |
SetAutoSerializeInScope(bool autoSerialize) | ReplicaManager |
SetDefaultScope(bool scope) | ReplicaManager |
SetDownloadCompleteCB(SendDownloadCompleteInterface *sendDownloadComplete, ReceiveDownloadCompleteInterface *receiveDownloadComplete) | ReplicaManager |
SetReceiveConstructionCB(ReceiveConstructionInterface *receiveConstructionInterface) | ReplicaManager |
SetScope(Replica *replica, bool inScope, SystemAddress systemAddress, bool broadcast) | ReplicaManager |
SetSendChannel(unsigned char channel) | ReplicaManager |
SignalSerializationFlags(Replica *replica, SystemAddress systemAddress, bool broadcast, bool set, unsigned int flags) | ReplicaManager |
SignalSerializeNeeded(Replica *replica, SystemAddress systemAddress, bool broadcast) | ReplicaManager |
Update(RakPeerInterface *peer) | ReplicaManager | [virtual]
~ReplicaManager() | ReplicaManager | [virtual]

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

Router Member List

This is the complete list of members for Router, including all inherited members.

AddAllowedType(unsigned char messageId) | Router |
OnAttach(RakPeerInterface *peer) | Router | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | Router | [virtual]
OnDetach(RakPeerInterface *peer) | Router | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PluginInterface | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PluginInterface | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | Router | [virtual]
OnShutdown(RakPeerInterface *peer) | Router | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
RemoveAllowedType(unsigned char messageId) | Router |
Send(char *data, BitSize_t bitLength, PacketPriority priority, PacketReliability reliability, char orderingChannel, SystemAddressList *recipients) | Router |
SetConnectionGraph(DataStructures::WeightedGraph< ConnectionGraph::SystemAddressAndGroupId, unsigned short, false > *connectionGraph) | Router |
SetRestrictRoutingByType(bool restrict__) | Router |
Update(RakPeerInterface *peer) | Router | [virtual]

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RouterInterface Member List

This is the complete list of members for RouterInterface, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SendDownloadCompleteInterface Member List

This is the complete list of members for SendDownloadCompleteInterface, including all inherited members.

SendDownloadComplete(RakNet::BitStream *outBitStream, RakNetTime currentTime, SystemAddress senderId, ReplicaManager *caller)=0 SendDownloadCompleteInterface [pure virtual]

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SimpleMutex Member List

This is the complete list of members for SimpleMutex, including all inherited members.

SimpleMutex() SimpleMutex

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

StringCompressor Member List

This is the complete list of members for StringCompressor, including all inherited members.

AddReference(void) | StringCompressor | [static]
DecodeString(char *output, int maxCharsToWrite, RakNet::BitStream *input, int languageID=0) | StringCompressor |
EncodeString(const char *input, int maxCharsToWrite, RakNet::BitStream *output, int languageID=0) | StringCompressor |
GenerateTreeFromStrings(unsigned char *input, unsigned inputLength, int languageID) | StringCompressor |
Instance(void) | StringCompressor | [static]
RemoveReference(void) | StringCompressor | [static]
~StringCompressor() | StringCompressor |

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SubmitMatch_PostgreSQLImpl Member List

This is the complete list of members for SubmitMatch_PostgreSQLImpl, including all inherited members.

Alloc(void) | SubmitMatch_PostgreSQLImpl | [static]
gameDbId | RankingServerDBSpec::SubmitMatch_Data |
HandleResult(bool wasCancelled, void *context) | SubmitMatch_PostgreSQLImpl | [virtual]
matchBinaryData | RankingServerDBSpec::SubmitMatch_Data |
matchBinaryDataLength | RankingServerDBSpec::SubmitMatch_Data |
matchNotes | RankingServerDBSpec::SubmitMatch_Data |
matchTime | RankingServerDBSpec::SubmitMatch_Data |
participantADbId | RankingServerDBSpec::SubmitMatch_Data |
participantANewRating | RankingServerDBSpec::SubmitMatch_Data |
participantAOldRating | RankingServerDBSpec::SubmitMatch_Data |
participantAScore | RankingServerDBSpec::SubmitMatch_Data |
participantBDbId | RankingServerDBSpec::SubmitMatch_Data |
participantBNewRating | RankingServerDBSpec::SubmitMatch_Data |
participantBOldRating | RankingServerDBSpec::SubmitMatch_Data |
participantBScore | RankingServerDBSpec::SubmitMatch_Data |
Process(void *context) | SubmitMatch_PostgreSQLImpl | [virtual]

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

TelnetTransport Member List

This is the complete list of members for TelnetTransport, including all inherited members.

CloseConnection(SystemAddress systemAddress) | TelnetTransport | [virtual]
DeallocatePacket(Packet *packet) | TelnetTransport | [virtual]
GetCommandParser(void) | TelnetTransport | [virtual]
HasLostConnection(void) | TelnetTransport | [virtual]
HasNewConnection(void) | TelnetTransport | [virtual]
Receive(void) | TelnetTransport | [virtual]
Send(SystemAddress systemAddress, const char *data,...) | TelnetTransport | [virtual]
Start(unsigned short port, bool serverMode) | TelnetTransport | [virtual]
Stop(void) | TelnetTransport | [virtual]

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

ThreadsafePacketLogger Member List

This is the complete list of members for ThreadsafePacketLogger, including all inherited members.

LogHeader(void) | PacketLogger | [virtual]
OnAttach(RakPeerInterface *peer) | PacketLogger | [virtual]
OnCloseConnection(RakPeerInterface *peer, SystemAddress systemAddress) | PluginInterface | [virtual]
OnDetach(RakPeerInterface *peer) | PluginInterface | [virtual]
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PacketLogger | [virtual]
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | PacketLogger | [virtual]
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNetTime time, bool isSend) | PacketLogger | [virtual]
OnReceive(RakPeerInterface *peer, Packet *packet) | PluginInterface | [virtual]
OnShutdown(RakPeerInterface *peer) | PluginInterface | [virtual]
OnStartup(RakPeerInterface *peer) | PluginInterface | [virtual]
SetPrefix(const char *_prefix) | PacketLogger | [virtual]
SetSuffix(const char *_suffix) | PacketLogger | [virtual]
Update(RakPeerInterface *peer) | ThreadsafePacketLogger | [virtual]
WriteLog(const char *str) | PacketLogger | [virtual]

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

TitleValidation_PostgreSQL Member List

This is the complete list of members for TitleValidation_PostgreSQL, including all inherited members.

AssignCallback(TitleValidationDBCBInterface *cb) | TitleValidation_PostgreSQL |
CreateTitleValidationTables(void) | TitleValidation_PostgreSQL |
DestroyTitleValidationTables(void) | TitleValidation_PostgreSQL |
PushFunctor(TitleValidationFunctor *functor, void *context=0) | TitleValidation_PostgreSQL | [virtual]

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

TitleValidationDBCBInterface Member List

This is the complete list of members for TitleValidationDBCBInterface, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

TitleValidationDBSpec::AddTitle_Data Member List

This is the complete list of members for TitleValidationDBSpec::AddTitle_Data, including all inherited members.

allowClientAccountCreation | TitleValidationDBSpec::AddTitle_Data
creationDate | TitleValidationDBSpec::AddTitle_Data
lobbyIsGameIndependent | TitleValidationDBSpec::AddTitle_Data
requireUserKeyToLogon | TitleValidationDBSpec::AddTitle_Data
titleId | TitleValidationDBSpec::AddTitle_Data
titleName | TitleValidationDBSpec::AddTitle_Data
titlePassword | TitleValidationDBSpec::AddTitle_Data
titlePasswordLength | TitleValidationDBSpec::AddTitle_Data

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

TitleValidationDBSpec::GetTitles_Data Member List

This is the complete list of members for TitleValidationDBSpec::GetTitles_Data, including all inherited members.

titles TitleValidationDBSpec::GetTitles_Data

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

TitleValidationDBSpec::UpdateUserKey_Data Member List

This is the complete list of members for TitleValidationDBSpec::UpdateUserKey_Data, including all inherited members.

binaryData | TitleValidationDBSpec::UpdateUserKey_Data
binaryDataLength | TitleValidationDBSpec::UpdateUserKey_Data
creationDate | TitleValidationDBSpec::UpdateUserKey_Data
invalidKey | TitleValidationDBSpec::UpdateUserKey_Data
invalidKeyReason | TitleValidationDBSpec::UpdateUserKey_Data
keyPassword | TitleValidationDBSpec::UpdateUserKey_Data
keyPasswordLength | TitleValidationDBSpec::UpdateUserKey_Data
numRegistrations | TitleValidationDBSpec::UpdateUserKey_Data
titleId | TitleValidationDBSpec::UpdateUserKey_Data
userId | TitleValidationDBSpec::UpdateUserKey_Data
userIP | TitleValidationDBSpec::UpdateUserKey_Data
userKeyId | TitleValidationDBSpec::UpdateUserKey_Data
userKeyIsSet | TitleValidationDBSpec::UpdateUserKey_Data

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

TransportInterface Member List

This is the complete list of members for TransportInterface, including all inherited members.

CloseConnection(SystemAddress systemAddress)=0 | TransportInterface | [pure virtual]
DeallocatePacket(Packet *packet)=0 | TransportInterface | [pure virtual]
GetCommandParser(void)=0 | TransportInterface | [pure virtual]
HasLostConnection(void)=0 | TransportInterface | [pure virtual]
HasNewConnection(void)=0 | TransportInterface | [pure virtual]
Receive(void)=0 | TransportInterface | [pure virtual]
Send(SystemAddress systemAddress, const char *data,...)=0 | TransportInterface | [pure virtual]
Start(unsigned short port, bool serverMode)=0 | TransportInterface | [pure virtual]
Stop(void)=0 | TransportInterface | [pure virtual]

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- j -

  • joinRequestAcceptorIsYou : RakNet::ClanMemberJoinRequestAccepted_Notification
  • JoinRoom() : RakNet::LobbyClientPC
  • JoinRoomByFilter() : RakNet::LobbyClientPC
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • keyPassword : TitleValidationDBSpec::UpdateUserKey_Data
  • keyPasswordLength : TitleValidationDBSpec::UpdateUserKey_Data
  • KickRoomMember() : RakNet::LobbyClientPC
  • KillConnection() : ReliabilityLayer
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • lag_factor : SpeexNBMode , SBEncState , SpeexSBMode , EncState
  • lagWindow : SBEncState , EncState
  • last_ol_gain : DecState
  • last_pitch : DecState
  • last_pitch_gain : DecState
  • lastName : LobbyDBSpec::CreateUser_Data
  • lbr_pitch : SpeexSubmode
  • LeaveRoom() : RakNet::LobbyClientPC
  • len : SpeexJitter
  • length : Packet
  • LightweightDatabaseClient() : LightweightDatabaseClient
  • LightweightDatabaseServer() : LightweightDatabaseServer
  • List() : DataStructures::List< list_type >
  • lobbyIsGameIndependent : TitleValidationDBSpec::AddTitle_Data
  • LockInput() : ThreadPool< InputType, OutputType >
  • LockOutput() : ThreadPool< InputType, OutputType >
  • LogHeader() : PacketLogger
  • Login() : RakNet::LobbyClientPC
  • Logoff() : RakNet::LobbyClientPC
  • LogStringNotFound() : RakNet::StringTable
  • longterm_margin : SpeexJitter
  • loss_rate : SpeexJitter
  • lost_count : SpeexJitter
  • loudness : SpeexPreprocessState
  • loudness2 : SpeexPreprocessState
  • loudness_weight : SpeexPreprocessState
  • low_quality_map : SpeexSBMode
  • lpc : SBEncState , EncState
  • lpc_enh_enabled : DecState
  • lpc_enh_k1 : SpeexSubmode
  • lpc_enh_k2 : SpeexSubmode
  • lpc_enh_k3 : SpeexSubmode
  • lpc_floor : SBEncState , SpeexNBMode , SpeexSBMode , EncState
  • lpcSize : EncState , DecState , SpeexNBMode , SpeexSBMode , SBEncState
  • lsp : SBEncState , EncState
  • lsp_quant : SpeexSubmode
  • lsp_unquant : SpeexSubmode
  • ltp_params : SpeexSubmode
  • ltp_quant : SpeexSubmode
  • ltp_unquant : SpeexSubmode
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • matchBinaryData : RankingServerDBSpec::SubmitMatch_Data
  • matchBinaryDataLength : RankingServerDBSpec::SubmitMatch_Data
  • matchHistoryList : RankingServerDBSpec::GetHistoryForParticipant_Data
  • matchNotes : RankingServerDBSpec::SubmitMatch_Data
  • matchTime : RankingServerDBSpec::SubmitMatch_Data
  • max_pitch : EncState , DecState
  • maximumIncomingConnections : RakPeer
  • maximumNumberOfPeers : RakPeer
  • mem_exc : EncState
  • mem_sp : EncState , DecState , SBEncState
  • mem_sw : EncState , SBEncState
  • mem_sw_whole : EncState
  • messageDataBitsResent : RakNetStatistics
  • messageDataBitsSent : RakNetStatistics
  • messageInternalOrder : InternalPacket
  • messageNumber : InternalPacket
  • messageNumberAssigned : InternalPacket
  • messageResends : RakNetStatistics
  • messageSendBuffer : RakNetStatistics
  • messagesOnResendQueue : RakNetStatistics
  • messagesReceived : RakNetStatistics
  • messagesSent : RakNetStatistics
  • messagesTotalBitsResent : RakNetStatistics
  • messagesWaitingForReassembly : RakNetStatistics
  • messageTotalBitsSent : RakNetStatistics
  • middleName : LobbyDBSpec::CreateUser_Data
  • min_pitch : DecState , EncState
  • mode : EncState , SBEncState , SBDecState , DecState , SpeexMode , SpeexHeader
  • mode_bitstream_version : SpeexHeader
  • modeID : SpeexMode
  • modeName : SpeexMode
  • moderatorId : LobbyDBSpec::AddAccountNote_Data
  • moderatorUsername : LobbyDBSpec::AddAccountNote_Data
  • mySystemAddress : RakPeer
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • NatPunchthrough() : NatPunchthrough
  • nb_adapt : SpeexPreprocessState
  • nb_channels : SpeexHeader
  • nb_loudness_adapt : SpeexPreprocessState
  • nb_mode : SpeexSBMode
  • nb_preprocess : SpeexPreprocessState
  • nbBits : SpeexBits
  • nbSubframes : SBEncState , DecState , EncState
  • networkID : NetworkIDObject
  • NetworkIDObject() : NetworkIDObject
  • nextActionTime : InternalPacket
  • nextAllocationNumber : NetworkIDObject
  • noise : SpeexPreprocessState
  • NotifyAndFlagForShutdown() : RakPeer
  • nPos : RakNet::RakString
  • numberOfBitsOfData : RPCParameters
  • NumberOfConnections() : RakPeer , RakPeerInterface
  • numberOfSplitMessages : RakNetStatistics
  • numberOfUnsplitMessages : RakNetStatistics
  • numRegistrations : TitleValidationDBSpec::UpdateUserKey_Data
  • NumThreadsWorking() : ThreadPool< InputType, OutputType >
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • ol_pitch : EncState
  • ol_voiced : EncState
  • old_lsp : SBEncState , EncState
  • old_ps : SpeexPreprocessState
  • old_qlsp : SBEncState , EncState , DecState
  • OnAddFilesFromDirectoryStarted() : FileListProgress , FLP_Printf
  • OnAttach() : PluginInterface
  • OnAutoSerializeTimerElapsed() : RakNet::Replica2
  • OnCloseConnection() : PluginInterface
  • OnCommand() : LogCommandParser , CommandParserInterface , RakNetCommandParser , RakNetTransportCommandParser
  • OnConnectionLost() : LogCommandParser , CommandParserInterface
  • OnConnectionRequest() : RakPeer
  • OnDereference() : FileListTransferCBInterface
  • OnDetach() : PluginInterface
  • OnDirectory() : FileListProgress , FLP_Printf
  • OnDirectSocketReceive() : PluginInterface
  • OnDirectSocketSend() : PacketLogger , PluginInterface
  • OnDownloadComplete() : FileListTransferCBInterface
  • OnFile() : FileListProgress , FileListTransferCBInterface
  • OnFileProgress() : FileListTransferCBInterface
  • OnInternalPacket() : PluginInterface
  • OnNewIncomingConnection() : LogCommandParser , CommandParserInterface
  • OnReceive() : PluginInterface
  • OnShutdown() : PluginInterface
  • OnStartup() : PluginInterface
  • OnTransportChange() : CommandParserInterface , LogCommandParser
  • operator const char *() : RakNet::RakString
  • operator!=() : RakNet::RakString
  • operator+=() : RakNet::RakString
  • operator=()
: DataStructures::List< list_type >
, RakNet::RakString
  • operator==() : RakNet::RakString
  • operator[]() : DataStructures::List< list_type > , RakNet::RakString
  • orderedMessagesInOrder : RakNetStatistics
  • orderedMessagesOutOfOrder : RakNetStatistics
  • orderingChannel : InternalPacket
  • orderingIndex : InternalPacket
  • outbuf : SpeexPreprocessState
  • output : LobbyDBSpec::GetUser_Data
  • outputList : RankingServerDBSpec::GetRatingForParticipants_Data
  • OutputSize() : ThreadPool< InputType, OutputType >
  • overflow : SpeexBits
  • owner : SpeexBits
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- z -

  • zeta : SpeexPreprocessState
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~AutoRPC() : RakNet::AutoRPC
  • ~BitStream() : RakNet::BitStream
  • ~Connection_RM2() : RakNet::Connection_RM2
  • ~DataBlockEncryptor() : DataBlockEncryptor
  • ~DirectoryDeltaTransfer() : DirectoryDeltaTransfer
  • ~LightweightDatabaseClient() : LightweightDatabaseClient
  • ~LightweightDatabaseServer() : LightweightDatabaseServer
  • ~List() : DataStructures::List< list_type >
  • ~NatPunchthrough() : NatPunchthrough
  • ~NetworkIDObject() : NetworkIDObject
  • ~RakPeer() : RakPeer
  • ~RakPeerInterface() : RakPeerInterface
  • ~ReadyEvent() : ReadyEvent
  • ~ReliabilityLayer() : ReliabilityLayer
  • ~Replica2() : RakNet::Replica2
  • ~ReplicaManager() : ReplicaManager
  • ~ReplicaManager2() : RakNet::ReplicaManager2
  • ~RPC3() : RakNet::RPC3
  • ~SingleProducerConsumer() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ~StringCompressor() : StringCompressor
  • ~StringTable() : RakNet::StringTable
  • ~Table() : DataStructures::Table
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • balance : SpeexStereoState
  • banOrSuspensionReason : LobbyDBSpec::GetUser_Data
  • billingAddress1 : LobbyDBSpec::CreateUser_Data
  • billingAddress2 : LobbyDBSpec::CreateUser_Data
  • billingCity : LobbyDBSpec::CreateUser_Data
  • billingCountry : LobbyDBSpec::CreateUser_Data
  • billingProvince : LobbyDBSpec::CreateUser_Data
  • billingState : LobbyDBSpec::CreateUser_Data
  • billingZipCode : LobbyDBSpec::CreateUser_Data
  • binaryAddress : SystemAddress
  • binaryData : TitleValidationDBSpec::UpdateUserKey_Data , LobbyDBSpec::CreateUser_Data
  • binaryDataLength : TitleValidationDBSpec::UpdateUserKey_Data , LobbyDBSpec::CreateUser_Data
  • bitPtr : SpeexBits
  • bitrate : SpeexHeader
  • bits_per_frame : SpeexSubmode
  • bitSize : Packet
  • bitsPerSecond : RakNetStatistics
  • bitsReceived : RakNetStatistics
  • BitStream() : RakNet::BitStream
  • bitstream_version : SpeexMode
  • bitsWithBadCRCReceived : RakNetStatistics
  • body : LobbyDBSpec::AddAccountNote_Data , LobbyDBSpec::SendEmail_Data
  • bounded_pitch : EncState
  • BroadcastAutoSerialize() : RakNet::Replica2
  • BroadcastConstruction() : RakNet::Replica2
  • BroadcastDestruction() : RakNet::Replica2
  • BroadcastSerialize() : RakNet::Replica2
  • BroadcastVisibility() : RakNet::Replica2
  • buf : SpeexJitter
  • buf_size : SpeexBits
  • buffer_size : SpeexJitter
  • bufSize : SBEncState , SpeexSBMode
  • bw_lpc1 : EncState , SBEncState
  • bw_lpc2 : EncState , SBEncState
  • bytesSentPerSecond : RakPeer
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • C_String() : RakNet::RakString
  • Call()
: RakNet::AutoRPC
, RakNet::RPC3
  • callback_id : SpeexCallback
  • callDepth : InlineFunctor
  • CallExplicit()
: RakNet::AutoRPC
, RakNet::RPC3
, RakNet::AutoRPC
  • callGenerationCode : NetworkIDObject
  • CallResultHandlers() : RakNet::FunctionThread
  • CancelAutoSerializeTimer() : RakNet::Replica2
  • CancelFunctorsWithContext() : RakNet::FunctionThread
  • CancelQuickMatch() : RakNet::LobbyClientPC
  • CancelReadLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • CancelReceive() : FileListTransfer
  • CancelWriteLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • caption1 : LobbyDBSpec::CreateUser_Data
  • caption2 : LobbyDBSpec::CreateUser_Data
  • caption3 : LobbyDBSpec::CreateUser_Data
  • ChangeHandle() : RakNet::LobbyClientPC
  • ChangeNumSlots() : RakNet::LobbyClientPC
  • channelNames : LogCommandParser
  • channels : LogCommandParser::SystemAddressAndChannel
  • charPtr : SpeexBits
  • chars : SpeexBits
  • CheckReadUnlockOrder() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • CheckSum() : CheckSum
  • clanId
: RakNet::ClanJoinInvitation_Notification
, RakNet::LeaveClan_Notification
, RakNet::ClanMemberJoinRequestWithdrawn_Notification
, RakNet::ClanMemberJoinRequestRejected_Notification
, RakNet::ClanJoinInvitationWithdrawn_Notification
, RakNet::ClanMemberJoinRequestAccepted_Notification
, RakNet::ClanMemberJoinRequest_Notification
, RakNet::ClanJoinInvitationRejected_Notification
, RakNet::ClanJoinInvitationAccepted_Notification
  • clanLeaderOrSubleaderId
: RakNet::ClanJoinInvitation_Notification
, RakNet::ClanMemberJoinRequestRejected_Notification
, RakNet::ClanMemberJoinRequestAccepted_Notification
, RakNet::ClanJoinInvitationWithdrawn_Notification
, RakNet::ClanJoinInvitationRejected_Notification
, RakNet::ClanJoinInvitationAccepted_Notification
  • Clear() : DataStructures::List< list_type > , DataStructures::Table , LightweightDatabaseServer , NatPunchthrough , RakNet::RakString , ReplicaManager , MemoryCompressor , ThreadPool< InputType, OutputType > , DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ClearAutoSerializeTimers() : RakNet::Replica2
  • ClearBanList() : RakPeer , RakPeerInterface
  • ClearInput() : ThreadPool< InputType, OutputType >
  • ClearOutput() : ThreadPool< InputType, OutputType >
  • ClearUploads() : DirectoryDeltaTransfer
  • CloseConnection() : RakNetTransport , RakPeer , RakPeerInterface , TransportInterface
  • ColumnIndex() : DataStructures::Table
  • ColumnName() : DataStructures::Table
  • comb_gain : SpeexSubmode
  • completedThreads : InlineFunctorProcessor
  • complexity : EncState
  • Compress() : MemoryCompressor , DataStructures::List< list_type >
  • Connect() : NatPunchthrough , RakPeer , RakPeerInterface
  • Connection_RM2() : RakNet::Connection_RM2
  • connectionStartTime : RakNetStatistics
  • ConnectWithNatPunchthrough() : FullyConnectedMesh
  • consec_noise : SpeexPreprocessState
  • Construct() : RakNet::Connection_RM2 , ReplicaManager
  • context : FileListNode
  • CopyData() : RakNet::BitStream
  • count_lost : DecState
  • CreateAutopatcherTables() : AutopatcherPostgreRepository , AutopatcherMySQLRepository
  • CreateLobbyServerTables() : LobbyDB_PostgreSQL
  • CreateRankingServerTables() : RankingServer_PostgreSQL
  • CreateRoom() : RakNet::LobbyClientPC
  • CreateTitleValidationTables() : TitleValidation_PostgreSQL
  • creationDate : TitleValidationDBSpec::UpdateUserKey_Data , TitleValidationDBSpec::AddTitle_Data
  • creationTime
: LobbyDBSpec::AddFriend_Data
, LobbyDBSpec::SendEmail_Data
, LobbyDBSpec::AddToIgnoreList_Data
, LobbyDBSpec::GetUser_Data
, InternalPacket
  • creditCardCVV : LobbyDBSpec::CreateUser_Data
  • creditCardExpiration : LobbyDBSpec::CreateUser_Data
  • creditCardNumber : LobbyDBSpec::CreateUser_Data
  • current_packet : SpeexJitter
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • data : FileListNode , InternalPacket , Packet , SpeexCallback
  • dataBitLength : InternalPacket
  • DataBlockEncryptor() : DataBlockEncryptor
  • dataLengthBytes : FileListNode
  • dateOfBirth : LobbyDBSpec::CreateUser_Data
  • DeallocatePacket() : RakPeerInterface , RakNetTransport , TransportInterface , RakPeer
  • dec : SpeexMode , SpeexJitter
  • dec_ctl : SpeexMode
  • dec_destroy : SpeexMode
  • dec_init : SpeexMode
  • DeclineAddFriendInvite() : RakNet::LobbyClientPC
  • DecodeString() : StringCompressor , RakNet::StringTable
  • Decrypt() : DataBlockEncryptor
  • defaultSubmode : SpeexNBMode , SpeexSBMode
  • DeleteCompressionLayer() : RakPeerInterface , RakPeer
  • DeleteEmail() : RakNet::LobbyClientPC
  • DeleteEvent() : ReadyEvent
  • DeleteFilterSet() : MessageFilter
  • Dereference() : RakNet::ReplicaManager2
  • DereferencePointer() : ReplicaManager
  • Deserialize() : RakNet::RakString , Replica , RakNet::Replica2
  • DeserializeCompressed() : RakNet::RakString
  • DeserializeDestruction() : RakNet::Replica2
  • DeserializeDownloadComplete() : RakNet::Connection_RM2
  • DeserializeDownloadStarted() : RakNet::Connection_RM2
  • DeserializeVisibility() : RakNet::Replica2
  • DestroyAutopatcherTables() : AutopatcherMySQLRepository , AutopatcherPostgreRepository
  • DestroyLobbyServerTables() : LobbyDB_PostgreSQL
  • DestroyRankingServerTables() : RankingServer_PostgreSQL
  • DestroyTitleValidationTables() : TitleValidation_PostgreSQL
  • Destruct() : ReplicaManager
  • DetachPlugin() : RakPeerInterface , RakPeer
  • DirectoryDeltaTransfer() : DirectoryDeltaTransfer
  • DisableReplicaInterfaces() : ReplicaManager
  • DisableSecurity() : RakPeer , RakPeerInterface
  • DoEndianSwap() : RakNet::BitStream
  • double_codebook : SpeexSubmode
  • DownloadActionHistory() : RakNet::LobbyClientPC
  • DownloadEmails() : RakNet::LobbyClientPC
  • DownloadFriends() : RakNet::LobbyClientPC
  • DownloadFromSubdirectory() : DirectoryDeltaTransfer
  • DownloadIgnoreList() : RakNet::LobbyClientPC
  • DownloadRating() : RakNet::LobbyClientPC
  • DownloadRooms() : RakNet::LobbyClientPC
  • dtx_count : EncState
  • dtx_enabled : EncState
  • duplicateAcknowlegementsReceived : RakNetStatistics
  • duplicateMessagesReceived : RakNetStatistics
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • e_ratio : SpeexStereoState
  • ElapseAutoSerializeTimers() : RakNet::Replica2
  • emailAddress : LobbyDBSpec::CreateUser_Data
  • emailMessageID
: LobbyDBSpec::SendEmail_Data
, LobbyDBSpec::DeleteEmail_Data
, LobbyDBSpec::UpdateEmailStatus_Data
  • EnableReplicaInterfaces() : ReplicaManager
  • enc : SpeexMode
  • enc_ctl : SpeexMode
  • enc_destroy : SpeexMode
  • enc_init : SpeexMode
  • encode_submode : DecState
  • EncodeArray() : HuffmanEncodingTree
  • EncodeString() : StringCompressor , RakNet::StringTable
  • Encrypt() : DataBlockEncryptor
  • encryptionBitsSent : RakNetStatistics
  • endThreads : RakPeer
  • EqualIDs() : RakNet::LobbyClientPC
  • Erase() : RakNet::RakString
  • exc : DecState , SBEncState , EncState
  • excBuf : EncState , SBEncState , DecState
  • extra_headers : SpeexHeader
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • FacilitateConnections() : NatPunchthrough
  • failureMessage : LobbyDBSpec::SendEmail_Data , LobbyDBSpec::GetEmails_Data
  • fft_lookup : SpeexPreprocessState
  • fileLengthBytes : FileListNode
  • filename : FileListNode
  • first : EncState , DecState , SBEncState
  • firstName : LobbyDBSpec::CreateUser_Data
  • forced_pitch_gain : SpeexSubmode
  • ForceElapseAllAutoserializeTimers() : RakNet::Replica2
  • FPrintf() : RakNet::RakString
  • frame : SpeexPreprocessState , EncState , DecState
  • frame_size : SpeexPreprocessState , SpeexEchoState_ , SBEncState , SpeexHeader , SpeexJitter
  • frame_time : SpeexJitter
  • frames_per_packet : SpeexHeader
  • frameSize : DecState , SpeexNBMode , SpeexSBMode , EncState
  • FreeMemory() : HuffmanEncodingTree , RakNet::RakString
  • frequencyTable : RakPeer
  • friendFound : LobbyDBSpec::AddFriend_Data
  • friendId : LobbyDBSpec::AddFriend_Data
  • full_frame_size : SBEncState
  • func : SpeexCallback
  • functionName : RPCParameters
  • functionThread : InlineFunctorProcessor
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • g1_mem : SBEncState
  • gain : SpeexPreprocessState
  • gain2 : SpeexPreprocessState
  • gameDbId
: RankingServerDBSpec::GetRatingForParticipants_Data
, RankingServerDBSpec::SubmitMatch_Data
, RankingServerDBSpec::GetRatingForParticipant_Data
, RankingServerDBSpec::GetHistoryForParticipant_Data
, RankingServerDBSpec::ModifyTrustedIPList_Data
  • gamma1 : EncState , SBEncState , SpeexNBMode , SpeexSBMode
  • gamma2 : SpeexSBMode , EncState , SBEncState , SpeexNBMode
  • GenerateCompressionLayer() : RakPeer , RakPeerInterface
  • GenerateFromFrequencyTable() : HuffmanEncodingTree
  • GenerateID() : NetworkIDObject
  • GenerateTree() : HuffmanEncodingTreeFactory
  • GenerateTreeFromStrings() : StringCompressor
  • GerUserIdFromName() : RakNet::LobbyClientPC
  • Get() : DataStructures::Table::Cell
  • GET_BASE_OBJECT_FROM_ID() : NetworkIDManager
  • GET_OBJECT_FROM_ID() : NetworkIDManager
  • GetActionHistoryList() : RakNet::LobbyClientPC
  • GetAllocationNumber() : NetworkIDObject
  • GetAllRoomMembers() : RakNet::LobbyClientPC
  • GetAllRooms() : RakNet::LobbyClientPC
  • GetAvailableRowId() : DataStructures::Table
  • GetAveragePing() : RakPeer , RakPeerInterface
  • GetBestClockDifferential() : RakPeer
  • getBinaryData : LobbyDBSpec::GetUser_Data
  • GetCallback() : FileListTransfer
  • GetCallDepth() : InlineFunctorProcessor
  • getCCInfo : LobbyDBSpec::GetUser_Data
  • GetCellValueByIndex() : DataStructures::Table
  • GetChangelistSinceDate() : AutopatcherMySQLRepository , AutopatcherPostgreRepository , AutopatcherRepositoryInterface
  • GetChannelIndexFromName() : LogCommandParser
  • GetColumnCount() : DataStructures::Table
  • GetColumns() : DataStructures::Table
  • GetColumnType() : DataStructures::Table
  • GetCommandParser() : TransportInterface , RakNetTransport
  • GetCompressionRatio() : RakPeer , RakPeerInterface
  • GetConnectionAtIndex() : RakNet::ReplicaManager2
  • GetConnectionBySystemAddress() : RakNet::ReplicaManager2
  • GetConnectionCount() : RakNet::ReplicaManager2
  • GetConnectionIndexBySystemAddress() : RakNet::ReplicaManager2
  • GetConnectionList() : RakPeer , RakPeerInterface
  • GetConnectionsWithReplicaConstructed() : RakNet::ReplicaManager2
  • GetConnectionsWithSerializeVisibility() : RakNet::ReplicaManager2
  • GetCurrentExecution()
: RakNet::RPC3
, RakNet::AutoRPC
  • GetData() : RakNet::BitStream
  • GetDecompressionRatio() : RakPeer , RakPeerInterface
  • getEmailAddr : LobbyDBSpec::GetUser_Data
  • GetEventAtIndex() : ReadyEvent
  • GetEventListSize() : ReadyEvent
  • GetExternalID() : RakPeer , RakPeerInterface
  • GetFilterSetCount() : MessageFilter
  • GetFilterSetIDByIndex() : MessageFilter
  • GetFrequencyTable() : HuffmanEncodingTreeFactory
  • GetFriendsList() : RakNet::LobbyClientPC
  • GetFromWaitListAtIndex() : ReadyEvent
  • GetGraph() : ConnectionGraph
  • GetIgnoreList() : RakNet::LobbyClientPC
  • GetInboxEmailList() : RakNet::LobbyClientPC
  • GetIncomingExtraData() : RakNet::AutoRPC
  • GetIncomingPassword() : RakNetTransport , RakPeer , RakPeerInterface
  • GetIndexFromSystemAddress() : RakPeer , RakPeerInterface
  • GetIndexOf() : DataStructures::List< list_type >
  • GetInputAtIndex() : ThreadPool< InputType, OutputType >
  • GetInternalID() : RakPeer , RakPeerInterface
  • GetLastError() : AutopatcherPostgreRepository , AutopatcherRepositoryInterface , AutopatcherMySQLRepository
  • GetLastPing() : RakPeer , RakPeerInterface
  • GetLastSenderAddress()
: RakNet::RPC3
, RakNet::AutoRPC
  • GetLastSenderTimestamp()
: RakNet::RPC3
, RakNet::AutoRPC
  • GetLength() : RakNet::RakString
  • GetListHead() : DataStructures::Table
  • GetLobbyUserStatus() : RakNet::LobbyClientPC
  • GetLocalIP() : RakPeer , RakPeerInterface
  • GetLowestPing() : RakPeer , RakPeerInterface
  • GetMaximumIncomingConnections() : RakPeer , RakPeerInterface
  • GetMaximumNumberOfPeers() : RakPeer , RakPeerInterface
  • GetMTUSize() : RakPeer , RakPeerInterface
  • GetMyId() : RakNet::LobbyClientPC
  • GetName() : CommandParserInterface , RakNetCommandParser , RakNetTransportCommandParser , LogCommandParser
  • GetNetworkID() : NetworkIDObject
  • GetNetworkIDManager() : RakPeerInterface , RakPeer , NetworkIDObject
  • GetNumberOfAddresses() : RakPeer , RakPeerInterface
  • GetNumberOfBitsUsed() : RakNet::BitStream
  • GetNumberOfBytesUsed() : RakNet::BitStream
  • GetNumberOfFilesForUpload() : DirectoryDeltaTransfer
  • GetNumberOfRemoteInitiatedConnections() : RakPeer
  • GetNumberOfUnreadBits() : RakNet::BitStream
  • GetOfflinePingResponse() : RakPeerInterface , RakPeer
  • GetOpenSlotMembers() : RakNet::LobbyClientPC
  • GetOutgoingFrequencyTable() : RakPeer , RakPeerInterface
  • GetOutput() : ThreadPool< InputType, OutputType >
  • GetOutputAtIndex() : ThreadPool< InputType, OutputType >
  • GetParent() : NetworkIDObject
  • GetParticipantAtIndex() : ReplicaManager
  • GetParticipantCount() : ReplicaManager
  • getPassword : LobbyDBSpec::GetUser_Data
  • GetPatches() : AutopatcherRepositoryInterface , AutopatcherPostgreRepository , AutopatcherMySQLRepository
  • getPersonalInfo : LobbyDBSpec::GetUser_Data
  • GetPrivateSlotMaxCount() : RakNet::LobbyClientPC
  • GetPublicSlotMaxCount() : RakNet::LobbyClientPC
  • GetRakPeer()
: RakNet::ReplicaManager2
, RakNet::AutoRPC
, RakNet::RPC3
  • GetRating() : RakNet::LobbyClientPC
  • GetReadOffset() : RakNet::BitStream
  • GetReadyStatus() : ReadyEvent
  • GetRecentlyMetUsersList() : RakNet::LobbyClientPC
  • GetRemoteSystemFromSystemAddress() : RakPeer
  • GetRemoteWaitListSize() : ReadyEvent
  • GetReplicaAtIndex() : RakNet::ReplicaManager2 , ReplicaManager
  • GetReplicaCount() : ReplicaManager , RakNet::ReplicaManager2
  • GetReplicaManager() : RakNet::Replica2
  • GetReservedSlotMembers() : RakNet::LobbyClientPC
  • GetRoomId() : RakNet::LobbyClientPC
  • GetRoomModerator() : RakNet::LobbyClientPC
  • GetRoomName() : RakNet::LobbyClientPC
  • GetRoomTableRow() : RakNet::LobbyClientPC
  • GetRowByID() : DataStructures::Table
  • GetRowByIndex() : DataStructures::Table
  • GetRowCount() : DataStructures::Table
  • GetRows() : DataStructures::Table
  • GetSentEmailList() : RakNet::LobbyClientPC
  • GetServerAddress() : HTTPConnection
  • GetSharedNetworkID() : NetworkIDManager
  • GetSortPriority() : Replica
  • GetSpectators() : RakNet::LobbyClientPC
  • GetStatistics() : RakPeerInterface , ReliabilityLayer , RakPeer
  • GetSystemAddress() : RakNet::Connection_RM2
  • GetSystemAddressFromIndex() : RakPeerInterface , RakPeer
  • GetSystemByIndex() : MessageFilter
  • GetSystemCount() : MessageFilter
  • GetSystemFilterSet() : MessageFilter
  • GetTable() : LightweightDatabaseServer
  • GetTableRows() : LightweightDatabaseServer
  • GetTimeoutTime() : ReliabilityLayer
  • GetTimeToNextAutoSerialize() : RakNet::Replica2
  • GetTitleId() : RakNet::LobbyClientPC
  • GetTitleName() : RakNet::LobbyClientPC
  • GetUserDetails() : RakNet::LobbyClientPC
  • GrantModerator() : RakNet::LobbyClientPC
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • handle : LobbyDBSpec::CreateUser_Data
  • HandleResult() : SubmitMatch_PostgreSQLImpl , ModifyTrustedIPList_PostgreSQLImpl , GetRatingForParticipant_PostgreSQLImpl , GetRatingForParticipants_PostgreSQLImpl , GetHistoryForParticipant_PostgreSQLImpl , RakNet::Functor
  • HandleRPCPacket() : RakPeer
  • HandleRPCReplyPacket() : RakPeer
  • HandleSocketReceiveFromConnectedPlayer() : ReliabilityLayer
  • HasBadResponse() : HTTPConnection
  • HasConnection() : RakNet::ReplicaManager2
  • HasData() : DataStructures::OrderedList< key_type, data_type, default_comparison_function >
  • HasEvent() : ReadyEvent
  • HasInput() : ThreadPool< InputType, OutputType >
  • HasInputFast() : ThreadPool< InputType, OutputType >
  • HasLostConnection() : RakNetTransport , TransportInterface
  • HasNewConnection() : RakNetTransport , TransportInterface
  • HasOutput() : ThreadPool< InputType, OutputType >
  • HasOutputFast() : ThreadPool< InputType, OutputType >
  • HasParticipant() : ReplicaManager
  • have_subframe_gain : SpeexSubmode
  • header_size : SpeexHeader
  • high : SBEncState
  • homeAddress1 : LobbyDBSpec::CreateUser_Data
  • homeAddress2 : LobbyDBSpec::CreateUser_Data
  • homeCity : LobbyDBSpec::CreateUser_Data
  • homeCountry : LobbyDBSpec::CreateUser_Data
  • homeProvince : LobbyDBSpec::CreateUser_Data
  • homeState : LobbyDBSpec::CreateUser_Data
  • homeZipCode : LobbyDBSpec::CreateUser_Data
  • hostAddress : SocketDescriptor
  • HTTPConnection() : HTTPConnection
  • HuffmanEncodingTreeFactory() : HuffmanEncodingTreeFactory
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • id
: LobbyDBSpec::GetUser_Data
, LobbyDBSpec::AddFriend_Data
, LobbyDBSpec::GetFriends_Data
, LobbyDBSpec::AddToIgnoreList_Data
, LobbyDBSpec::RemoveFromIgnoreList_Data
, LobbyDBSpec::GetIgnoreList_Data
, LobbyDBSpec::SendEmail_Data
, LobbyDBSpec::GetEmails_Data
, LobbyDBSpec::UpdateUser_Data
, LobbyDBSpec::AddAccountNote_Data
, LobbyDBSpec::GetAccountNotes_Data
  • IDTree : NetworkIDManager
  • ifp : InlineFunctor
  • IgnoreBits() : RakNet::BitStream
  • IgnoreBytes() : RakNet::BitStream
  • inbox : LobbyDBSpec::GetEmails_Data
  • inBuf : EncState , DecState
  • inbuf : SpeexPreprocessState
  • InitializeSecurity() : RakPeer , RakPeerInterface
  • initialSenderStatus : LobbyDBSpec::SendEmail_Data
  • innov : EncState , DecState
  • innovation_params : SpeexSubmode
  • innovation_quant : SpeexSubmode
  • innovation_unquant : SpeexSubmode
  • input : RPCParameters , LobbyDBSpec::UpdateUser_Data
  • InputSize() : ThreadPool< InputType, OutputType >
  • Insert() : DataStructures::List< list_type >
  • Instance() : RakNet::StringTable , StringCompressor
  • instance : RakNet::StringTable
  • IntegersToSystemAddress() : CommandParserInterface
  • internalOutputQueueSize : RakNetStatistics
  • interp_lpc : EncState , SBEncState
  • interp_lsp : EncState , SBEncState
  • interp_qlpc : EncState , DecState , SBEncState
  • interp_qlsp : EncState , SBEncState , DecState
  • invalidKey : TitleValidationDBSpec::UpdateUserKey_Data
  • invalidKeyReason : TitleValidationDBSpec::UpdateUserKey_Data
  • invalidMessagesReceived : RakNetStatistics
  • invitationSenderIsYou : RakNet::ClanJoinInvitationAccepted_Notification
  • InviteToRoom() : RakNet::LobbyClientPC
  • ip : RankingServerDBSpec::ModifyTrustedIPList_Data
  • IPAddressMatch() : RakNet::RakString
  • ipList : RankingServerDBSpec::GetTrustedIPList_Data
  • IsActive() : RakPeerInterface , RakPeer
  • IsBanned() : RakPeerInterface
  • isBanned : LobbyDBSpec::GetUser_Data
  • IsBanned() : RakPeer
  • IsBusy() : HTTPConnection
  • IsCheater() : ReliabilityLayer
  • IsConnected() : RakPeer , RakPeerInterface , RakNet::LobbyClientPC
  • IsConstructed() : ReplicaManager
  • IsConstructionCommand() : RakNet::SerializationContext
  • IsDeadConnection() : ReliabilityLayer
  • IsDestructionCommand() : RakNet::SerializationContext
  • IsDownloadCommand() : RakNet::SerializationContext
  • IsDownloadingRoomList() : RakNet::LobbyClientPC
  • IsEmpty() : RakNet::RakString
  • IsEventCompleted() : ReadyEvent
  • IsEventCompletionProcessing() : ReadyEvent
  • IsEventSet() : ReadyEvent
  • IsFriend() : RakNet::LobbyClientPC
  • IsFunctionRegistered() : RakNet::RPC3
  • IsHandlerActive() : FileListTransfer
  • IsInReservedSlot() : RakNet::LobbyClientPC
  • IsInRoom() : RakNet::LobbyClientPC
  • IsInScope() : ReplicaManager
  • IsInSecurityExceptionList() : RakPeerInterface , RakPeer
  • IsInWaitList() : ReadyEvent
  • IsKeySet() : DataBlockEncryptor
  • IsLocalIP() : RakPeer , RakPeerInterface
  • isMainLoopThreadActive : RakPeer
  • IsNetworkIDAuthority() : NetworkIDManager
  • IsNetworkSimulatorActive() : RakPeerInterface , ReliabilityLayer , RakPeer
  • IsOutgoingDataWaiting() : ReliabilityLayer
  • IsRoomModerator() : RakNet::LobbyClientPC
  • IsSerializationCommand() : RakNet::SerializationContext
  • isSuspended : LobbyDBSpec::GetUser_Data
  • IsUserInRoom() : RakNet::LobbyClientPC
  • IsVisibilityCommand() : RakNet::SerializationContext
  • IsVisible() : RakNet::SerializationContext
  • IsWaitingOnQuickMatch() : RakNet::LobbyClientPC
  • IsWorking() : ThreadPool< InputType, OutputType >
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • packetNumber : InternalPacket
  • packetsContainingOnlyAcknowlegements : RakNetStatistics
  • packetsContainingOnlyAcknowlegementsAndResends : RakNetStatistics
  • packetsReceived : RakNetStatistics
  • packetsSent : RakNetStatistics
  • packetsWithBadCRCReceived : RakNetStatistics
  • parent : NetworkIDObject
  • ParseConnectionRequestPacket() : RakPeer
  • participantADbId : RankingServerDBSpec::SubmitMatch_Data
  • participantANewRating : RankingServerDBSpec::SubmitMatch_Data
  • participantAOldRating : RankingServerDBSpec::SubmitMatch_Data
  • participantAScore : RankingServerDBSpec::SubmitMatch_Data
  • participantBDbId : RankingServerDBSpec::SubmitMatch_Data
  • participantBNewRating : RankingServerDBSpec::SubmitMatch_Data
  • participantBOldRating : RankingServerDBSpec::SubmitMatch_Data
  • participantBScore : RankingServerDBSpec::SubmitMatch_Data
  • participantDbId : RankingServerDBSpec::GetRatingForParticipant_Data , RankingServerDBSpec::GetHistoryForParticipant_Data
  • participantFound : RankingServerDBSpec::GetRatingForParticipant_Data
  • participantList : ReplicaManager
  • password : LobbyDBSpec::CreateUser_Data
  • passwordRecoveryAnswer : LobbyDBSpec::CreateUser_Data
  • passwordRecoveryQuestion : LobbyDBSpec::CreateUser_Data
  • peer : RakNetCommandParser
  • permissions : LobbyDBSpec::CreateUser_Data
  • pi_gain : EncState , DecState
  • Ping() : RakPeerInterface , RakPeer
  • pitch_gain_buf : DecState
  • pitch_gain_buf_idx : DecState
  • pitchEnd : SpeexNBMode
  • pitchStart : SpeexNBMode
  • pointer_timestamp : SpeexJitter
  • Pop() : DataStructures::List< list_type >
  • port : SocketDescriptor , SystemAddress
  • post : SpeexPreprocessState
  • Post() : HTTPConnection
  • PrintBits() : RakNet::BitStream
  • PrintChannels() : LogCommandParser
  • PrintColumnHeaders() : DataStructures::Table
  • Printf() : RakNet::RakString
  • PrintRow() : DataStructures::Table
  • prior : SpeexPreprocessState
  • priority : InternalPacket
  • Process() : ModifyTrustedIPList_PostgreSQLImpl , GetHistoryForParticipant_PostgreSQLImpl , GetRatingForParticipant_PostgreSQLImpl , SubmitMatch_PostgreSQLImpl , GetRatingForParticipants_PostgreSQLImpl , RakNet::Functor
  • ProcessFinalTCPPacket() : HTTPConnection
  • ps : SpeexPreprocessState
  • ps_size : SpeexPreprocessState
  • Push()
: RakNet::FunctionThread
, DataStructures::List< list_type >
  • PushBackPacket() : RakPeer , RakPeerInterface
  • PushFunctor() : TitleValidation_PostgreSQL , RankingServer_PostgreSQL , LobbyDB_PostgreSQL
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • qlsp : EncState , SBEncState , DecState
  • quality_map : SpeexSBMode , SpeexNBMode
  • query : SpeexMode
  • QueryConstruction() : RakNet::Replica2
  • QueryIsConstructionAuthority() : RakNet::Replica2
  • QueryIsDestructionAuthority() : RakNet::Replica2
  • QueryIsSerializationAuthority() : RakNet::Replica2
  • QueryIsVisibilityAuthority() : RakNet::Replica2
  • queryResult : LobbyDBSpec::AddToIgnoreList_Data , LobbyDBSpec::AddFriend_Data
  • QueryTable() : DataStructures::Table , LightweightDatabaseClient
  • QueryVisibility() : RakNet::Replica2
  • QuickMatch() : RakNet::LobbyClientPC
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • race : LobbyDBSpec::CreateUser_Data
  • RakPeer() : RakPeer
  • RakString() : RakNet::RakString
  • rate : SpeexHeader
  • rating : RankingServerDBSpec::GetRatingForParticipant_Data
  • Read() : RakNet::BitStream , HTTPConnection , RakNet::BitStream
  • ReadAlignedBytes() : RakNet::BitStream
  • ReadAlignedBytesSafe() : RakNet::BitStream
  • ReadAlignedBytesSafeAlloc() : RakNet::BitStream
  • ReadBit() : RakNet::BitStream
  • ReadBits() : RakNet::BitStream
  • ReadCompressed() : RakNet::BitStream
  • ReadCompressedDelta() : RakNet::BitStream
  • ReadDelta() : RakNet::BitStream
  • ReadIsLocked() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ReadLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ReadNormQuat() : RakNet::BitStream
  • ReadNormVector() : RakNet::BitStream
  • ReadOrthMatrix() : RakNet::BitStream
  • ReadPtr() : RakNet::BitStream
  • ReadUnlock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ReadVector() : RakNet::BitStream
  • ReadyEvent() : ReadyEvent
  • RecalculateVisibility() : RakNet::ReplicaManager2
  • Receive() : RakNetTransport , RakPeer , RakPeerInterface , ReliabilityLayer , TransportInterface
  • ReceiveConstruction() : ReceiveConstructionInterface
  • ReceiveDestruction() : Replica
  • ReceiveDownloadComplete() : ReceiveDownloadCompleteInterface
  • ReceiveScopeChange() : Replica
  • recipient : RPCParameters
  • recipientAddress : RakNet::SerializationContext
  • Reference() : RakNet::ReplicaManager2
  • ReferencePointer() : ReplicaManager
  • RegisterAccount() : RakNet::LobbyClientPC
  • RegisterAsRemoteProcedureCall() : RakPeer , RakPeerInterface
  • RegisterClassMemberRPC() : RakPeer , RakPeerInterface
  • RegisterCommand() : CommandParserInterface
  • RegisterFunction()
: RakNet::AutoRPC
, RakNet::RPC3
  • relative_quality : EncState
  • relaySourceAddress : RakNet::SerializationContext
  • reliability : InternalPacket
  • ReliabilityLayer() : ReliabilityLayer
  • remoteSystemList : RakPeer
  • remoteUsers : LogCommandParser
  • RemoveAllowedType() : Router
  • RemoveApplication() : AutopatcherMySQLRepository , AutopatcherPostgreRepository
  • RemoveAtIndex() : DataStructures::List< list_type >
  • RemoveAtIndexFast() : DataStructures::List< list_type >
  • RemoveColumn() : DataStructures::Table
  • RemoveCommandParser() : ConsoleServer
  • RemoveConnection() : RakNet::ReplicaManager2
  • removeFriendInput : LobbyDBSpec::RemoveFriend_Data
  • RemoveFromBanList() : RakPeer , RakPeerInterface
  • RemoveFromEnd() : DataStructures::List< list_type >
  • RemoveFromIgnoreList() : RakNet::LobbyClientPC
  • RemoveFromSecurityExceptionList() : RakPeer , RakPeerInterface
  • RemoveFromWaitList() : ReadyEvent
  • RemoveInputAtIndex() : ThreadPool< InputType, OutputType >
  • RemoveOutputAtIndex() : ThreadPool< InputType, OutputType >
  • RemoveParticipant() : ReplicaManager
  • RemoveReceiver() : FileListTransfer
  • RemoveReference() : RakNet::StringTable , StringCompressor
  • RemoveRouterInterface() : RakPeer , RakPeerInterface
  • RemoveRow() : LightweightDatabaseClient , DataStructures::Table
  • RemoveRows() : DataStructures::Table
  • RemoveTable() : LightweightDatabaseServer
  • Replace()
: RakNet::RakString
, DataStructures::List< list_type >
  • Replica2() : RakNet::Replica2
  • ReplicaManager() : ReplicaManager
  • ReplicaManager2() : RakNet::ReplicaManager2
  • replicatedObjects : ReplicaManager
  • replyToSender : RPCParameters
  • RequestConnectionGraph() : ConnectionGraph
  • RequiresSetParent() : NetworkIDObject
  • requireUserKeyToLogon : TitleValidationDBSpec::AddTitle_Data
  • res : SBEncState
  • reserved1 : SpeexStereoState , SpeexBits , SpeexHeader , SpeexCallback
  • reserved2 : SpeexCallback , SpeexStereoState , SpeexHeader , SpeexBits
  • Reset() : ReliabilityLayer , HuffmanEncodingTreeFactory , RakNet::BitStream
  • reset_state : SpeexJitter
  • ResetReadPointer() : RakNet::BitStream
  • ResetWritePointer() : RakNet::BitStream
  • RetrievePassword() : RakNet::LobbyClientPC
  • RetrievePasswordRecoveryQuestion() : RakNet::LobbyClientPC
  • ReturnResult() : CommandParserInterface
  • reverb_estimate : SpeexPreprocessState
  • RoomAllowsSpectators() : RakNet::LobbyClientPC
  • RoomChat() : RakNet::LobbyClientPC
  • RoomIsHidden() : RakNet::LobbyClientPC
  • RPC() : RakPeer , RakPeerInterface
  • RPC3() : RakNet::RPC3
  • rsacrypt : RakPeer
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • S : SpeexPreprocessState
  • safe_pitch : EncState
  • sampling_rate : SpeexPreprocessState
  • Send() : RakPeer , RakPeerInterface , EmailSender , ReliabilityLayer , FileListTransfer , Router , RakNetTransport , TransportInterface
  • SendAddFriendInvite() : RakNet::LobbyClientPC
  • SendConstruction() : Replica , RakNet::Replica2 , RakNet::ReplicaManager2
  • SendDestruction() : Replica , RakNet::ReplicaManager2 , RakNet::Replica2
  • SendDownloadComplete() : SendDownloadCompleteInterface
  • SendEmail() : RakNet::LobbyClientPC
  • sender : RPCParameters
  • SendHelp() : CommandParserInterface , LogCommandParser , RakNetCommandParser , RakNetTransportCommandParser
  • SendIM() : RakNet::LobbyClientPC
  • SendList() : RakPeer , RakPeerInterface
  • SendScopeChange() : Replica
  • SendSerialize()
: RakNet::ReplicaManager2
, RakNet::Replica2
  • SendTTL() : RakPeer , RakPeerInterface
  • SendVisibility()
: RakNet::ReplicaManager2
, RakNet::Replica2
  • sequencedMessagesInOrder : RakNetStatistics
  • sequencedMessagesOutOfOrder : RakNetStatistics
  • serializationType : RakNet::SerializationContext
  • Serialize()
: RakNet::BitStream
, RakNet::RakString
, Replica
, RakNet::Replica2
, RakNet::BitStream
  • SerializeBits() : RakNet::BitStream
  • SerializeCompressed()
: RakNet::RakString
, RakNet::BitStream
  • SerializeCompressedDelta() : RakNet::BitStream
  • SerializeConstruction() : RakNet::Replica2
  • SerializeDelta() : RakNet::BitStream
  • SerializeDestruction() : RakNet::Replica2
  • SerializeDownloadComplete() : RakNet::Connection_RM2
  • SerializeDownloadStarted() : RakNet::Connection_RM2
  • SerializeNormQuat() : RakNet::BitStream
  • SerializeNormVector() : RakNet::BitStream
  • SerializeOrthMatrix() : RakNet::BitStream
  • SerializeVector() : RakNet::BitStream
  • SerializeVisibility() : RakNet::Replica2
  • Set()
: DataStructures::Table::Cell
, RakNet::RakString
, DataStructures::Table::Cell
  • SetActionOnDisallowedMessage() : MessageFilter
  • SetAllowMessageID() : MessageFilter
  • SetAllowRPC() : MessageFilter
  • SetApplicationDirectory() : DirectoryDeltaTransfer
  • SetAutoAddNewConnections() : ConnectionGraph , RakNet::ReplicaManager2
  • SetAutoAddNewConnectionsToFilter() : MessageFilter
  • SetAutoConstructToNewParticipants() : ReplicaManager
  • SetAutoParticipateNewConnections() : ReplicaManager
  • SetAutoSerializeInScope() : ReplicaManager
  • SetAutoUpdateScope() : RakNet::ReplicaManager2
  • SetCallback() : FileListTransfer
  • SetCallbackInterface()
: RakNet::LobbyClientPC
, RakNet::Lobby2::LobbyClient
  • SetCompileFrequencyTable() : RakPeer , RakPeerInterface
  • SetCompressOutgoingSends() : DirectoryDeltaTransfer
  • SetConnectionFactory() : RakNet::ReplicaManager2
  • SetConnectionGraph() : Router
  • SetConstructionByList() : RakNet::Connection_RM2
  • SetConstructionByReplicaQuery() : RakNet::Connection_RM2
  • SetData() : RakNet::BitStream
  • SetDefaultOrderingChannel() : RakNet::ReplicaManager2
  • SetDefaultPacketPriority() : RakNet::ReplicaManager2
  • SetDefaultPacketReliability() : RakNet::ReplicaManager2
  • SetDefaultScope() : ReplicaManager
  • SetDisallowedMessageCallback() : MessageFilter
  • SetDoReplicaAutoSerializeUpdate() : RakNet::ReplicaManager2
  • SetDownloadCompleteCB() : ReplicaManager
  • SetEncryptionKey() : ReliabilityLayer
  • SetEvent() : ReadyEvent
  • SetExternalSystemAddress() : NetworkIDManager
  • SetFileListTransferPlugin() : DirectoryDeltaTransfer
  • SetFilterMaxTime() : MessageFilter
  • SetGroupId() : ConnectionGraph
  • SetIncomingPassword() : RakPeer , RakPeerInterface , RakNetTransport
  • SetIsNetworkIDAuthority() : NetworkIDManager
  • SetKey() : DataBlockEncryptor
  • SetLogger() : NatPunchthrough
  • SetMaximumIncomingConnections() : RakPeerInterface , RakPeer
  • SetMTUSize() : RakPeer , RakPeerInterface
  • SetNetworkID() : NetworkIDObject
  • SetNetworkIDManager() : RakPeer , RakPeerInterface , RakNet::AutoRPC , NetworkIDObject , RakNet::RPC3
  • SetNumberOfBitsAllocated() : RakNet::BitStream
  • SetOccasionalPing() : RakPeer , RakPeerInterface
  • SetOfflinePingResponse() : RakPeer , RakPeerInterface
  • SetOrderingChannel()
: RakNet::Lobby2::LobbyClientPC
, RakNet::LobbyClientPC
, RakNet::LobbyServer
  • SetOutgoingExtraData() : RakNet::AutoRPC
  • SetParent() : NetworkIDObject
  • SetPassword() : ConnectionGraph
  • SetPerConnectionOutgoingBandwidthLimit() : RakPeer , RakPeerInterface
  • SetPostResultFunction() : RakNet::FunctionThread
  • SetPrefix() : PacketLogger
  • SetPtr() : DataStructures::Table::Cell
  • SetRakPeerInterface() : RakNetCommandParser
  • SetReadyToPlayStatus() : RakNet::LobbyClientPC
  • SetReceiveConstructionCB() : ReplicaManager
  • SetRecipientAddress()
: RakNet::AutoRPC
, RakNet::RPC3
  • SetRecipientObject()
: RakNet::RPC3
, RakNet::AutoRPC
  • SetReplicaManager() : RakNet::Replica2
  • SetRestrictRoutingByType() : Router
  • SetRoomAllowSpectators() : RakNet::LobbyClientPC
  • SetRoomIsHidden() : RakNet::LobbyClientPC
  • SetRouterInterface() : RakPeer , RakPeerInterface
  • SetScope() : ReplicaManager
  • SetSendChannel() : ReadyEvent , ReplicaManager
  • SetSendParams()
: RakNet::AutoRPC
, RakNet::RPC3
  • SetSendPriority()
: RakNet::LobbyClientPC
, RakNet::Lobby2::LobbyClientPC
  • SetSharedNetworkID() : NetworkIDManager
  • SetSplitMessageProgressInterval() : RakPeer , RakPeerInterface
  • SetSuffix() : PacketLogger
  • SetSystemAddress() : RakNet::Connection_RM2
  • SetSystemFilterSet() : MessageFilter
  • SetTimeoutCallback() : MessageFilter
  • SetTimeoutTime() : RakPeer , RakPeerInterface , ReliabilityLayer
  • SetTimestamp()
: RakNet::AutoRPC
, RakNet::RPC3
  • SetTitleLoginId() : RakNet::LobbyClientPC
  • SetTransportProvider() : ConsoleServer
  • SetUnreliableTimeout() : RakPeer , RakPeerInterface
  • SetUploadSendParameters() : DirectoryDeltaTransfer
  • SetupReceive() : FileListTransfer
  • SetVisibilityByList() : RakNet::Connection_RM2
  • SetVisibilityByReplicaQuery() : RakNet::Connection_RM2
  • SetWriteOffset() : RakNet::BitStream
  • sex : LobbyDBSpec::CreateUser_Data
  • ShiftIncomingTimestamp() : RakPeer
  • shortterm_margin : SpeexJitter
  • Shutdown() : RakPeer , RakPeerInterface
  • SignalSerializationFlags() : ReplicaManager
  • SignalSerializeNeeded() : ReplicaManager
  • SimpleMutex() : SimpleMutex
  • SingleProducerConsumer() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • Size()
: DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
, DataStructures::List< list_type >
  • Smin : SpeexPreprocessState
  • smooth_left : SpeexStereoState
  • smooth_right : SpeexStereoState
  • SortTable() : DataStructures::Table
  • sourceIPAddress : LobbyDBSpec::CreateUser_Data
  • speex_string : SpeexHeader
  • speex_version : SpeexHeader
  • speex_version_id : SpeexHeader
  • splitPacketCount : InternalPacket
  • splitPacketId : InternalPacket
  • splitPacketIndex : InternalPacket
  • st_low : SBEncState , SBDecState
  • stack : DecState , EncState , SBEncState
  • Start() : TransportInterface , RakNetTransport
  • StartGame() : RakNet::LobbyClientPC
  • StartThreads() : RakNet::FunctionThread , InlineFunctorProcessor , ThreadPool< InputType, OutputType >
  • Startup() : FullyConnectedMesh , RakPeer , RakPeerInterface
  • status : LobbyDBSpec::SendEmail_Data , LobbyDBSpec::UpdateEmailStatus_Data
  • Stmp : SpeexPreprocessState
  • Stop() : RakNetTransport , TransportInterface
  • StopThreads() : InlineFunctorProcessor , ThreadPool< InputType, OutputType > , RakNet::FunctionThread
  • StrCmp() : RakNet::RakString
  • StrICmp() : RakNet::RakString
  • StringTable() : RakNet::StringTable
  • subframeSize : SBEncState , SpeexSBMode , DecState , SpeexNBMode , EncState
  • subject : LobbyDBSpec::SendEmail_Data , LobbyDBSpec::AddAccountNote_Data
  • SubmitMatch() : RakNet::LobbyClientPC
  • submodeID : DecState , EncState
  • submodes : SpeexNBMode , SpeexSBMode , DecState , EncState
  • submodeSelect : EncState
  • Subscribe() : LogCommandParser
  • SubscribeToGroup() : ConnectionGraph
  • success : LobbyDBSpec::AddFriend_Data , LobbyDBSpec::AddToIgnoreList_Data
  • suspensionExpiration : LobbyDBSpec::GetUser_Data
  • sw : EncState , SBEncState
  • swBuf : EncState
  • systemAddress : RankingServerDBSpec::ModifyTrustedIPList_Data , Packet , LogCommandParser::SystemAddressAndChannel
  • systemIndex : Packet
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • Table() : DataStructures::Table
  • target : SBEncState
  • time : LobbyDBSpec::AddAccountNote_Data
  • timestamp : RakNet::SerializationContext , SpeexJitter
  • titleId : TitleValidationDBSpec::AddTitle_Data , TitleValidationDBSpec::UpdateUserKey_Data
  • titleName : TitleValidationDBSpec::AddTitle_Data
  • titlePassword : TitleValidationDBSpec::AddTitle_Data
  • titlePasswordLength : TitleValidationDBSpec::AddTitle_Data
  • titles : TitleValidationDBSpec::GetTitles_Data
  • to : LobbyDBSpec::SendEmail_Data
  • ToLower() : RakNet::RakString
  • totalBitsSent : RakNetStatistics
  • totalSplits : RakNetStatistics
  • ToUpper() : RakNet::RakString
  • trans : LogCommandParser
  • type : LobbyDBSpec::AddAccountNote_Data
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • UnlockInput() : ThreadPool< InputType, OutputType >
  • UnlockOutput() : ThreadPool< InputType, OutputType >
  • UnregisterAsRemoteProcedureCall() : RakPeer , RakPeerInterface
  • UnregisterFunction()
: RakNet::AutoRPC
, RakNet::RPC3
  • UnsetKey() : DataBlockEncryptor
  • Unsubscribe() : LogCommandParser
  • UnsubscribeFromGroup() : ConnectionGraph
  • Update() : PluginInterface , HTTPConnection , ReliabilityLayer , ReplicaManager , ConsoleServer , FileListTransferCBInterface
  • update_prob : SpeexPreprocessState
  • UpdateAccount() : RakNet::LobbyClientPC
  • UpdateApplicationFiles() : AutopatcherMySQLRepository , AutopatcherPostgreRepository
  • updateBinaryData : LobbyDBSpec::UpdateUser_Data
  • updateCCInfo : LobbyDBSpec::UpdateUser_Data
  • UpdateCell()
: DataStructures::Table
, DataStructures::Table::Row
  • updateCycleIsRunning : RakPeer
  • updateEmailAddr : LobbyDBSpec::UpdateUser_Data
  • UpdateEmailStatus() : RakNet::LobbyClientPC
  • updatePassword : LobbyDBSpec::UpdateUser_Data
  • updatePersonalInfo : LobbyDBSpec::UpdateUser_Data
  • UpdateRow() : LightweightDatabaseClient
  • URLEncode() : RakNet::RakString
  • userFound
: LobbyDBSpec::AddAccountNote_Data
, LobbyDBSpec::AddFriend_Data
, LobbyDBSpec::GetUser_Data
  • userId
: RakNet::ClanJoinInvitationRejected_Notification
, RakNet::ClanJoinInvitationAccepted_Notification
, TitleValidationDBSpec::UpdateUserKey_Data
, RakNet::LeaveClan_Notification
, RakNet::ClanMemberJoinRequest_Notification
, RakNet::ClanMemberJoinRequestAccepted_Notification
, RakNet::ClanMemberJoinRequestWithdrawn_Notification
  • userIdIsYou : RakNet::ClanMemberJoinRequestAccepted_Notification , RakNet::ClanJoinInvitationAccepted_Notification
  • userIP : TitleValidationDBSpec::UpdateUserKey_Data
  • userKeyId : TitleValidationDBSpec::UpdateUserKey_Data
  • userKeyIsSet : TitleValidationDBSpec::UpdateUserKey_Data
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • vad_enabled : EncState , SBEncState
  • valid_bits : SpeexJitter
  • validParameters : LobbyDBSpec::SendEmail_Data , LobbyDBSpec::GetEmails_Data
  • vbr : EncState , SpeexHeader
  • vbr_enabled : EncState , SBEncState
  • vbr_quality : EncState , SBEncState
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • wasOpened : LobbyDBSpec::SendEmail_Data , LobbyDBSpec::UpdateEmailStatus_Data
  • WasStopped() : ThreadPool< InputType, OutputType >
  • window : SpeexPreprocessState , SBEncState , EncState
  • windowSize : EncState , SBEncState
  • Write() : RakNet::BitStream
  • Write0() : RakNet::BitStream
  • Write1() : RakNet::BitStream
  • WriteAlignedBytes() : RakNet::BitStream
  • WriteAlignedBytesSafe() : RakNet::BitStream
  • WriteBits() : RakNet::BitStream
  • WriteCompressed() : RakNet::BitStream
  • WriteCompressedDelta() : RakNet::BitStream
  • WriteDelta() : RakNet::BitStream
  • WriteLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • WriteLog() : PacketLogger , LogCommandParser
  • writeModeratorId : LobbyDBSpec::AddAccountNote_Data
  • WriteNormQuat() : RakNet::BitStream
  • WriteNormVector() : RakNet::BitStream
  • WriteOrthMatrix() : RakNet::BitStream
  • WritePtr() : RakNet::BitStream
  • WriteUnlock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • WriteVector() : RakNet::BitStream
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • x1d : SBEncState
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • y1 : SBEncState
  • YieldOnFunctor() : InlineFunctorProcessor
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- a -

  • AcceptAddFriendInvite() : RakNet::LobbyClientPC
  • AccessSerializationFlags() : ReplicaManager
  • AckTimeout() : ReliabilityLayer
  • AddAllowedType() : Router
  • AddApplication() : AutopatcherMySQLRepository , AutopatcherPostgreRepository
  • AddAutoSerializeTimer() : RakNet::Replica2
  • AddBitsAndReallocate() : RakNet::BitStream
  • AddChannel() : LogCommandParser
  • AddColumn() : DataStructures::Table
  • AddCommandParser() : ConsoleServer
  • AddInput() : ThreadPool< InputType, OutputType >
  • AddNewConnection() : RakNet::ReplicaManager2 , ConnectionGraph
  • AddParticipant() : ReplicaManager
  • AddReference() : StringCompressor , RakNet::StringTable
  • AddRow() : DataStructures::Table
  • AddString() : RakNet::StringTable
  • AddTable() : LightweightDatabaseServer
  • AddToActionHistory() : RakNet::LobbyClientPC
  • AddToBanList() : RakPeer , RakPeerInterface
  • AddToFrequencyTable() : HuffmanEncodingTreeFactory
  • AddToOrUpdateIgnoreList() : RakNet::LobbyClientPC
  • AddToSecurityExceptionList() : RakPeerInterface , RakPeer
  • AddToWaitList() : ReadyEvent
  • AddUploadsFromSubdirectory() : DirectoryDeltaTransfer
  • AdvertiseSystem() : RakPeer , RakPeerInterface
  • AlignReadToByteBoundary() : RakNet::BitStream
  • AlignWriteToByteBoundary() : RakNet::BitStream
  • Alloc() : GetRatingForParticipant_PostgreSQLImpl , ModifyTrustedIPList_PostgreSQLImpl , GetRatingForParticipants_PostgreSQLImpl , SubmitMatch_PostgreSQLImpl , GetHistoryForParticipant_PostgreSQLImpl
  • AllocatePacket() : RakPeer , RakPeerInterface
  • AllowConnectionResponseIPMigration() : RakPeer , RakPeerInterface
  • AllowRemoteConstruction() : RakNet::Replica2
  • ApplyNetworkSimulator() : RakPeerInterface , RakPeer
  • AssertCopyData() : RakNet::BitStream
  • AssertParticipantsClear() : ReplicaManager
  • AssertReplicatedObjectsClear() : ReplicaManager
  • AssertStreamEmpty() : RakNet::BitStream
  • AssignCallback() : TitleValidation_PostgreSQL , RankingServer_PostgreSQL , LobbyDB_PostgreSQL
  • AssignSystemAddressToRemoteSystemList() : RakPeer
  • AttachPlugin() : RakPeerInterface , RakPeer
  • AutoRPC() : RakNet::AutoRPC
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- j -

  • JoinRoom() : RakNet::LobbyClientPC
  • JoinRoomByFilter() : RakNet::LobbyClientPC
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- k -

  • KickRoomMember() : RakNet::LobbyClientPC
  • KillConnection() : ReliabilityLayer
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- l -

  • LeaveRoom() : RakNet::LobbyClientPC
  • LightweightDatabaseClient() : LightweightDatabaseClient
  • LightweightDatabaseServer() : LightweightDatabaseServer
  • List() : DataStructures::List< list_type >
  • LockInput() : ThreadPool< InputType, OutputType >
  • LockOutput() : ThreadPool< InputType, OutputType >
  • LogHeader() : PacketLogger
  • Login() : RakNet::LobbyClientPC
  • Logoff() : RakNet::LobbyClientPC
  • LogStringNotFound() : RakNet::StringTable
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- n -

  • NatPunchthrough() : NatPunchthrough
  • NetworkIDObject() : NetworkIDObject
  • NotifyAndFlagForShutdown() : RakPeer
  • NumberOfConnections() : RakPeerInterface , RakPeer
  • NumThreadsWorking() : ThreadPool< InputType, OutputType >
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- o -

  • OnAddFilesFromDirectoryStarted() : FileListProgress , FLP_Printf
  • OnAttach() : PluginInterface
  • OnAutoSerializeTimerElapsed() : RakNet::Replica2
  • OnCloseConnection() : PluginInterface
  • OnCommand() : LogCommandParser , CommandParserInterface , RakNetCommandParser , RakNetTransportCommandParser
  • OnConnectionLost() : LogCommandParser , CommandParserInterface
  • OnConnectionRequest() : RakPeer
  • OnDereference() : FileListTransferCBInterface
  • OnDetach() : PluginInterface
  • OnDirectory() : FileListProgress , FLP_Printf
  • OnDirectSocketReceive() : PluginInterface
  • OnDirectSocketSend() : PacketLogger , PluginInterface
  • OnDownloadComplete() : FileListTransferCBInterface
  • OnFile() : FileListProgress , FileListTransferCBInterface
  • OnFileProgress() : FileListTransferCBInterface
  • OnInternalPacket() : PluginInterface
  • OnNewIncomingConnection() : LogCommandParser , CommandParserInterface
  • OnReceive() : PluginInterface
  • OnShutdown() : PluginInterface
  • OnStartup() : PluginInterface
  • OnTransportChange() : CommandParserInterface , LogCommandParser
  • operator const char *() : RakNet::RakString
  • operator!=() : RakNet::RakString
  • operator+=() : RakNet::RakString
  • operator=()
: RakNet::RakString
, DataStructures::List< list_type >
  • operator==() : RakNet::RakString
  • operator[]() : DataStructures::List< list_type > , RakNet::RakString
  • OutputSize() : ThreadPool< InputType, OutputType >
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- ~ -

  • ~AutoRPC() : RakNet::AutoRPC
  • ~BitStream() : RakNet::BitStream
  • ~Connection_RM2() : RakNet::Connection_RM2
  • ~DataBlockEncryptor() : DataBlockEncryptor
  • ~DirectoryDeltaTransfer() : DirectoryDeltaTransfer
  • ~LightweightDatabaseClient() : LightweightDatabaseClient
  • ~LightweightDatabaseServer() : LightweightDatabaseServer
  • ~List() : DataStructures::List< list_type >
  • ~NatPunchthrough() : NatPunchthrough
  • ~NetworkIDObject() : NetworkIDObject
  • ~RakPeer() : RakPeer
  • ~RakPeerInterface() : RakPeerInterface
  • ~ReadyEvent() : ReadyEvent
  • ~ReliabilityLayer() : ReliabilityLayer
  • ~Replica2() : RakNet::Replica2
  • ~ReplicaManager() : ReplicaManager
  • ~ReplicaManager2() : RakNet::ReplicaManager2
  • ~RPC3() : RakNet::RPC3
  • ~SingleProducerConsumer() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ~StringCompressor() : StringCompressor
  • ~StringTable() : RakNet::StringTable
  • ~Table() : DataStructures::Table
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- b -

  • BitStream() : RakNet::BitStream
  • BroadcastAutoSerialize() : RakNet::Replica2
  • BroadcastConstruction() : RakNet::Replica2
  • BroadcastDestruction() : RakNet::Replica2
  • BroadcastSerialize() : RakNet::Replica2
  • BroadcastVisibility() : RakNet::Replica2
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- c -

  • C_String() : RakNet::RakString
  • Call()
: RakNet::AutoRPC
, RakNet::RPC3
, RakNet::AutoRPC
  • CallExplicit()
: RakNet::AutoRPC
, RakNet::RPC3
, RakNet::AutoRPC
  • CallResultHandlers() : RakNet::FunctionThread
  • CancelAutoSerializeTimer() : RakNet::Replica2
  • CancelFunctorsWithContext() : RakNet::FunctionThread
  • CancelQuickMatch() : RakNet::LobbyClientPC
  • CancelReadLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • CancelReceive() : FileListTransfer
  • CancelWriteLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ChangeHandle() : RakNet::LobbyClientPC
  • ChangeNumSlots() : RakNet::LobbyClientPC
  • CheckReadUnlockOrder() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • CheckSum() : CheckSum
  • Clear() : NatPunchthrough , MemoryCompressor , RakNet::RakString , DataStructures::List< list_type > , ReplicaManager , ThreadPool< InputType, OutputType > , DataStructures::SingleProducerConsumer< SingleProducerConsumerType > , LightweightDatabaseServer , DataStructures::Table
  • ClearAutoSerializeTimers() : RakNet::Replica2
  • ClearBanList() : RakPeer , RakPeerInterface
  • ClearInput() : ThreadPool< InputType, OutputType >
  • ClearOutput() : ThreadPool< InputType, OutputType >
  • ClearUploads() : DirectoryDeltaTransfer
  • CloseConnection() : RakNetTransport , RakPeer , RakPeerInterface , TransportInterface
  • ColumnIndex() : DataStructures::Table
  • ColumnName() : DataStructures::Table
  • Compress() : MemoryCompressor , DataStructures::List< list_type >
  • Connect() : NatPunchthrough , RakPeerInterface , RakPeer
  • Connection_RM2() : RakNet::Connection_RM2
  • ConnectWithNatPunchthrough() : FullyConnectedMesh
  • Construct() : RakNet::Connection_RM2 , ReplicaManager
  • CopyData() : RakNet::BitStream
  • CreateAutopatcherTables() : AutopatcherMySQLRepository , AutopatcherPostgreRepository
  • CreateLobbyServerTables() : LobbyDB_PostgreSQL
  • CreateRankingServerTables() : RankingServer_PostgreSQL
  • CreateRoom() : RakNet::LobbyClientPC
  • CreateTitleValidationTables() : TitleValidation_PostgreSQL
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- d -

  • DataBlockEncryptor() : DataBlockEncryptor
  • DeallocatePacket() : RakPeer , TransportInterface , RakNetTransport , RakPeerInterface
  • DeclineAddFriendInvite() : RakNet::LobbyClientPC
  • DecodeString() : RakNet::StringTable , StringCompressor
  • Decrypt() : DataBlockEncryptor
  • DeleteCompressionLayer() : RakPeer , RakPeerInterface
  • DeleteEmail() : RakNet::LobbyClientPC
  • DeleteEvent() : ReadyEvent
  • DeleteFilterSet() : MessageFilter
  • Dereference() : RakNet::ReplicaManager2
  • DereferencePointer() : ReplicaManager
  • Deserialize() : RakNet::RakString , Replica , RakNet::Replica2
  • DeserializeCompressed() : RakNet::RakString
  • DeserializeDestruction() : RakNet::Replica2
  • DeserializeDownloadComplete() : RakNet::Connection_RM2
  • DeserializeDownloadStarted() : RakNet::Connection_RM2
  • DeserializeVisibility() : RakNet::Replica2
  • DestroyAutopatcherTables() : AutopatcherMySQLRepository , AutopatcherPostgreRepository
  • DestroyLobbyServerTables() : LobbyDB_PostgreSQL
  • DestroyRankingServerTables() : RankingServer_PostgreSQL
  • DestroyTitleValidationTables() : TitleValidation_PostgreSQL
  • Destruct() : ReplicaManager
  • DetachPlugin() : RakPeer , RakPeerInterface
  • DirectoryDeltaTransfer() : DirectoryDeltaTransfer
  • DisableReplicaInterfaces() : ReplicaManager
  • DisableSecurity() : RakPeer , RakPeerInterface
  • DoEndianSwap() : RakNet::BitStream
  • DownloadActionHistory() : RakNet::LobbyClientPC
  • DownloadEmails() : RakNet::LobbyClientPC
  • DownloadFriends() : RakNet::LobbyClientPC
  • DownloadFromSubdirectory() : DirectoryDeltaTransfer
  • DownloadIgnoreList() : RakNet::LobbyClientPC
  • DownloadRating() : RakNet::LobbyClientPC
  • DownloadRooms() : RakNet::LobbyClientPC
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- e -

  • ElapseAutoSerializeTimers() : RakNet::Replica2
  • EnableReplicaInterfaces() : ReplicaManager
  • EncodeArray() : HuffmanEncodingTree
  • EncodeString() : RakNet::StringTable , StringCompressor
  • Encrypt() : DataBlockEncryptor
  • EqualIDs() : RakNet::LobbyClientPC
  • Erase() : RakNet::RakString
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- f -

  • FacilitateConnections() : NatPunchthrough
  • ForceElapseAllAutoserializeTimers() : RakNet::Replica2
  • FPrintf() : RakNet::RakString
  • FreeMemory() : RakNet::RakString , HuffmanEncodingTree
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- g -

  • GenerateCompressionLayer() : RakPeer , RakPeerInterface
  • GenerateFromFrequencyTable() : HuffmanEncodingTree
  • GenerateID() : NetworkIDObject
  • GenerateTree() : HuffmanEncodingTreeFactory
  • GenerateTreeFromStrings() : StringCompressor
  • GerUserIdFromName() : RakNet::LobbyClientPC
  • Get() : DataStructures::Table::Cell
  • GET_BASE_OBJECT_FROM_ID() : NetworkIDManager
  • GET_OBJECT_FROM_ID() : NetworkIDManager
  • GetActionHistoryList() : RakNet::LobbyClientPC
  • GetAllocationNumber() : NetworkIDObject
  • GetAllRoomMembers() : RakNet::LobbyClientPC
  • GetAllRooms() : RakNet::LobbyClientPC
  • GetAvailableRowId() : DataStructures::Table
  • GetAveragePing() : RakPeer , RakPeerInterface
  • GetBestClockDifferential() : RakPeer
  • GetCallback() : FileListTransfer
  • GetCallDepth() : InlineFunctorProcessor
  • GetCellValueByIndex() : DataStructures::Table
  • GetChangelistSinceDate() : AutopatcherMySQLRepository , AutopatcherPostgreRepository , AutopatcherRepositoryInterface
  • GetChannelIndexFromName() : LogCommandParser
  • GetColumnCount() : DataStructures::Table
  • GetColumns() : DataStructures::Table
  • GetColumnType() : DataStructures::Table
  • GetCommandParser() : TransportInterface , RakNetTransport
  • GetCompressionRatio() : RakPeer , RakPeerInterface
  • GetConnectionAtIndex() : RakNet::ReplicaManager2
  • GetConnectionBySystemAddress() : RakNet::ReplicaManager2
  • GetConnectionCount() : RakNet::ReplicaManager2
  • GetConnectionIndexBySystemAddress() : RakNet::ReplicaManager2
  • GetConnectionList() : RakPeerInterface , RakPeer
  • GetConnectionsWithReplicaConstructed() : RakNet::ReplicaManager2
  • GetConnectionsWithSerializeVisibility() : RakNet::ReplicaManager2
  • GetCurrentExecution()
: RakNet::RPC3
, RakNet::AutoRPC
  • GetData() : RakNet::BitStream
  • GetDecompressionRatio() : RakPeer , RakPeerInterface
  • GetEventAtIndex() : ReadyEvent
  • GetEventListSize() : ReadyEvent
  • GetExternalID() : RakPeer , RakPeerInterface
  • GetFilterSetCount() : MessageFilter
  • GetFilterSetIDByIndex() : MessageFilter
  • GetFrequencyTable() : HuffmanEncodingTreeFactory
  • GetFriendsList() : RakNet::LobbyClientPC
  • GetFromWaitListAtIndex() : ReadyEvent
  • GetGraph() : ConnectionGraph
  • GetIgnoreList() : RakNet::LobbyClientPC
  • GetInboxEmailList() : RakNet::LobbyClientPC
  • GetIncomingExtraData() : RakNet::AutoRPC
  • GetIncomingPassword() : RakPeerInterface , RakNetTransport , RakPeer
  • GetIndexFromSystemAddress() : RakPeer , RakPeerInterface
  • GetIndexOf() : DataStructures::List< list_type >
  • GetInputAtIndex() : ThreadPool< InputType, OutputType >
  • GetInternalID() : RakPeer , RakPeerInterface
  • GetLastError() : AutopatcherMySQLRepository , AutopatcherPostgreRepository , AutopatcherRepositoryInterface
  • GetLastPing() : RakPeer , RakPeerInterface
  • GetLastSenderAddress()
: RakNet::RPC3
, RakNet::AutoRPC
  • GetLastSenderTimestamp()
: RakNet::AutoRPC
, RakNet::RPC3
  • GetLength() : RakNet::RakString
  • GetListHead() : DataStructures::Table
  • GetLobbyUserStatus() : RakNet::LobbyClientPC
  • GetLocalIP() : RakPeer , RakPeerInterface
  • GetLowestPing() : RakPeer , RakPeerInterface
  • GetMaximumIncomingConnections() : RakPeerInterface , RakPeer
  • GetMaximumNumberOfPeers() : RakPeerInterface , RakPeer
  • GetMTUSize() : RakPeer , RakPeerInterface
  • GetMyId() : RakNet::LobbyClientPC
  • GetName() : LogCommandParser , CommandParserInterface , RakNetCommandParser , RakNetTransportCommandParser
  • GetNetworkID() : NetworkIDObject
  • GetNetworkIDManager() : RakPeer , RakPeerInterface , NetworkIDObject
  • GetNumberOfAddresses() : RakPeer , RakPeerInterface
  • GetNumberOfBitsUsed() : RakNet::BitStream
  • GetNumberOfBytesUsed() : RakNet::BitStream
  • GetNumberOfFilesForUpload() : DirectoryDeltaTransfer
  • GetNumberOfRemoteInitiatedConnections() : RakPeer
  • GetNumberOfUnreadBits() : RakNet::BitStream
  • GetOfflinePingResponse() : RakPeerInterface , RakPeer
  • GetOpenSlotMembers() : RakNet::LobbyClientPC
  • GetOutgoingFrequencyTable() : RakPeer , RakPeerInterface
  • GetOutput() : ThreadPool< InputType, OutputType >
  • GetOutputAtIndex() : ThreadPool< InputType, OutputType >
  • GetParent() : NetworkIDObject
  • GetParticipantAtIndex() : ReplicaManager
  • GetParticipantCount() : ReplicaManager
  • GetPatches() : AutopatcherRepositoryInterface , AutopatcherPostgreRepository , AutopatcherMySQLRepository
  • GetPrivateSlotMaxCount() : RakNet::LobbyClientPC
  • GetPublicSlotMaxCount() : RakNet::LobbyClientPC
  • GetRakPeer()
: RakNet::AutoRPC
, RakNet::RPC3
, RakNet::ReplicaManager2
  • GetRating() : RakNet::LobbyClientPC
  • GetReadOffset() : RakNet::BitStream
  • GetReadyStatus() : ReadyEvent
  • GetRecentlyMetUsersList() : RakNet::LobbyClientPC
  • GetRemoteSystemFromSystemAddress() : RakPeer
  • GetRemoteWaitListSize() : ReadyEvent
  • GetReplicaAtIndex() : ReplicaManager , RakNet::ReplicaManager2
  • GetReplicaCount() : RakNet::ReplicaManager2 , ReplicaManager
  • GetReplicaManager() : RakNet::Replica2
  • GetReservedSlotMembers() : RakNet::LobbyClientPC
  • GetRoomId() : RakNet::LobbyClientPC
  • GetRoomModerator() : RakNet::LobbyClientPC
  • GetRoomName() : RakNet::LobbyClientPC
  • GetRoomTableRow() : RakNet::LobbyClientPC
  • GetRowByID() : DataStructures::Table
  • GetRowByIndex() : DataStructures::Table
  • GetRowCount() : DataStructures::Table
  • GetRows() : DataStructures::Table
  • GetSentEmailList() : RakNet::LobbyClientPC
  • GetServerAddress() : HTTPConnection
  • GetSharedNetworkID() : NetworkIDManager
  • GetSortPriority() : Replica
  • GetSpectators() : RakNet::LobbyClientPC
  • GetStatistics() : ReliabilityLayer , RakPeer , RakPeerInterface
  • GetSystemAddress() : RakNet::Connection_RM2
  • GetSystemAddressFromIndex() : RakPeerInterface , RakPeer
  • GetSystemByIndex() : MessageFilter
  • GetSystemCount() : MessageFilter
  • GetSystemFilterSet() : MessageFilter
  • GetTable() : LightweightDatabaseServer
  • GetTableRows() : LightweightDatabaseServer
  • GetTimeoutTime() : ReliabilityLayer
  • GetTimeToNextAutoSerialize() : RakNet::Replica2
  • GetTitleId() : RakNet::LobbyClientPC
  • GetTitleName() : RakNet::LobbyClientPC
  • GetUserDetails() : RakNet::LobbyClientPC
  • GrantModerator() : RakNet::LobbyClientPC
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- h -

  • HandleResult() : RakNet::Functor , SubmitMatch_PostgreSQLImpl , ModifyTrustedIPList_PostgreSQLImpl , GetRatingForParticipant_PostgreSQLImpl , GetRatingForParticipants_PostgreSQLImpl , GetHistoryForParticipant_PostgreSQLImpl
  • HandleRPCPacket() : RakPeer
  • HandleRPCReplyPacket() : RakPeer
  • HandleSocketReceiveFromConnectedPlayer() : ReliabilityLayer
  • HasBadResponse() : HTTPConnection
  • HasConnection() : RakNet::ReplicaManager2
  • HasData() : DataStructures::OrderedList< key_type, data_type, default_comparison_function >
  • HasEvent() : ReadyEvent
  • HasInput() : ThreadPool< InputType, OutputType >
  • HasInputFast() : ThreadPool< InputType, OutputType >
  • HasLostConnection() : TransportInterface , RakNetTransport
  • HasNewConnection() : TransportInterface , RakNetTransport
  • HasOutput() : ThreadPool< InputType, OutputType >
  • HasOutputFast() : ThreadPool< InputType, OutputType >
  • HasParticipant() : ReplicaManager
  • HTTPConnection() : HTTPConnection
  • HuffmanEncodingTreeFactory() : HuffmanEncodingTreeFactory
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- i -

  • IgnoreBits() : RakNet::BitStream
  • IgnoreBytes() : RakNet::BitStream
  • InitializeSecurity() : RakPeerInterface , RakPeer
  • InputSize() : ThreadPool< InputType, OutputType >
  • Insert() : DataStructures::List< list_type >
  • Instance() : StringCompressor , RakNet::StringTable
  • IntegersToSystemAddress() : CommandParserInterface
  • InviteToRoom() : RakNet::LobbyClientPC
  • IPAddressMatch() : RakNet::RakString
  • IsActive() : RakPeerInterface , RakPeer
  • IsBanned() : RakPeerInterface , RakPeer
  • IsBusy() : HTTPConnection
  • IsCheater() : ReliabilityLayer
  • IsConnected() : RakPeerInterface , RakNet::LobbyClientPC , RakPeer
  • IsConstructed() : ReplicaManager
  • IsConstructionCommand() : RakNet::SerializationContext
  • IsDeadConnection() : ReliabilityLayer
  • IsDestructionCommand() : RakNet::SerializationContext
  • IsDownloadCommand() : RakNet::SerializationContext
  • IsDownloadingRoomList() : RakNet::LobbyClientPC
  • IsEmpty() : RakNet::RakString
  • IsEventCompleted() : ReadyEvent
  • IsEventCompletionProcessing() : ReadyEvent
  • IsEventSet() : ReadyEvent
  • IsFriend() : RakNet::LobbyClientPC
  • IsFunctionRegistered() : RakNet::RPC3
  • IsHandlerActive() : FileListTransfer
  • IsInReservedSlot() : RakNet::LobbyClientPC
  • IsInRoom() : RakNet::LobbyClientPC
  • IsInScope() : ReplicaManager
  • IsInSecurityExceptionList() : RakPeerInterface , RakPeer
  • IsInWaitList() : ReadyEvent
  • IsKeySet() : DataBlockEncryptor
  • IsLocalIP() : RakPeerInterface , RakPeer
  • IsNetworkIDAuthority() : NetworkIDManager
  • IsNetworkSimulatorActive() : RakPeer , ReliabilityLayer , RakPeerInterface
  • IsOutgoingDataWaiting() : ReliabilityLayer
  • IsRoomModerator() : RakNet::LobbyClientPC
  • IsSerializationCommand() : RakNet::SerializationContext
  • IsUserInRoom() : RakNet::LobbyClientPC
  • IsVisibilityCommand() : RakNet::SerializationContext
  • IsVisible() : RakNet::SerializationContext
  • IsWaitingOnQuickMatch() : RakNet::LobbyClientPC
  • IsWorking() : ThreadPool< InputType, OutputType >
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- p -

  • ParseConnectionRequestPacket() : RakPeer
  • Ping() : RakPeerInterface , RakPeer , RakPeerInterface
  • Pop() : DataStructures::List< list_type >
  • Post() : HTTPConnection
  • PrintBits() : RakNet::BitStream
  • PrintChannels() : LogCommandParser
  • PrintColumnHeaders() : DataStructures::Table
  • Printf() : RakNet::RakString
  • PrintRow() : DataStructures::Table
  • Process() : ModifyTrustedIPList_PostgreSQLImpl , GetRatingForParticipant_PostgreSQLImpl , SubmitMatch_PostgreSQLImpl , GetRatingForParticipants_PostgreSQLImpl , GetHistoryForParticipant_PostgreSQLImpl , RakNet::Functor
  • ProcessFinalTCPPacket() : HTTPConnection
  • Push()
: RakNet::FunctionThread
, DataStructures::List< list_type >
  • PushBackPacket() : RakPeerInterface , RakPeer
  • PushFunctor() : LobbyDB_PostgreSQL , TitleValidation_PostgreSQL , RankingServer_PostgreSQL
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- q -

  • QueryConstruction() : RakNet::Replica2
  • QueryIsConstructionAuthority() : RakNet::Replica2
  • QueryIsDestructionAuthority() : RakNet::Replica2
  • QueryIsSerializationAuthority() : RakNet::Replica2
  • QueryIsVisibilityAuthority() : RakNet::Replica2
  • QueryTable() : LightweightDatabaseClient , DataStructures::Table
  • QueryVisibility() : RakNet::Replica2
  • QuickMatch() : RakNet::LobbyClientPC
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- r -

  • RakPeer() : RakPeer
  • RakString() : RakNet::RakString
  • Read() : RakNet::BitStream , HTTPConnection , RakNet::BitStream
  • ReadAlignedBytes() : RakNet::BitStream
  • ReadAlignedBytesSafe() : RakNet::BitStream
  • ReadAlignedBytesSafeAlloc() : RakNet::BitStream
  • ReadBit() : RakNet::BitStream
  • ReadBits() : RakNet::BitStream
  • ReadCompressed() : RakNet::BitStream
  • ReadCompressedDelta() : RakNet::BitStream
  • ReadDelta() : RakNet::BitStream
  • ReadIsLocked() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ReadLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ReadNormQuat() : RakNet::BitStream
  • ReadNormVector() : RakNet::BitStream
  • ReadOrthMatrix() : RakNet::BitStream
  • ReadPtr() : RakNet::BitStream
  • ReadUnlock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ReadVector() : RakNet::BitStream
  • ReadyEvent() : ReadyEvent
  • RecalculateVisibility() : RakNet::ReplicaManager2
  • Receive() : ReliabilityLayer , RakNetTransport , RakPeer , TransportInterface , RakPeerInterface
  • ReceiveConstruction() : ReceiveConstructionInterface
  • ReceiveDestruction() : Replica
  • ReceiveDownloadComplete() : ReceiveDownloadCompleteInterface
  • ReceiveScopeChange() : Replica
  • Reference() : RakNet::ReplicaManager2
  • ReferencePointer() : ReplicaManager
  • RegisterAccount() : RakNet::LobbyClientPC
  • RegisterAsRemoteProcedureCall() : RakPeer , RakPeerInterface
  • RegisterClassMemberRPC() : RakPeer , RakPeerInterface
  • RegisterCommand() : CommandParserInterface
  • RegisterFunction()
: RakNet::AutoRPC
, RakNet::RPC3
  • ReliabilityLayer() : ReliabilityLayer
  • RemoveAllowedType() : Router
  • RemoveApplication() : AutopatcherMySQLRepository , AutopatcherPostgreRepository
  • RemoveAtIndex() : DataStructures::List< list_type >
  • RemoveAtIndexFast() : DataStructures::List< list_type >
  • RemoveColumn() : DataStructures::Table
  • RemoveCommandParser() : ConsoleServer
  • RemoveConnection() : RakNet::ReplicaManager2
  • RemoveFromBanList() : RakPeer , RakPeerInterface
  • RemoveFromEnd() : DataStructures::List< list_type >
  • RemoveFromIgnoreList() : RakNet::LobbyClientPC
  • RemoveFromSecurityExceptionList() : RakPeer , RakPeerInterface
  • RemoveFromWaitList() : ReadyEvent
  • RemoveInputAtIndex() : ThreadPool< InputType, OutputType >
  • RemoveOutputAtIndex() : ThreadPool< InputType, OutputType >
  • RemoveParticipant() : ReplicaManager
  • RemoveReceiver() : FileListTransfer
  • RemoveReference() : RakNet::StringTable , StringCompressor
  • RemoveRouterInterface() : RakPeerInterface , RakPeer
  • RemoveRow() : DataStructures::Table , LightweightDatabaseClient
  • RemoveRows() : DataStructures::Table
  • RemoveTable() : LightweightDatabaseServer
  • Replace()
: RakNet::RakString
, DataStructures::List< list_type >
  • Replica2() : RakNet::Replica2
  • ReplicaManager() : ReplicaManager
  • ReplicaManager2() : RakNet::ReplicaManager2
  • RequestConnectionGraph() : ConnectionGraph
  • RequiresSetParent() : NetworkIDObject
  • Reset() : RakNet::BitStream , HuffmanEncodingTreeFactory , ReliabilityLayer
  • ResetReadPointer() : RakNet::BitStream
  • ResetWritePointer() : RakNet::BitStream
  • RetrievePassword() : RakNet::LobbyClientPC
  • RetrievePasswordRecoveryQuestion() : RakNet::LobbyClientPC
  • ReturnResult() : CommandParserInterface
  • RoomAllowsSpectators() : RakNet::LobbyClientPC
  • RoomChat() : RakNet::LobbyClientPC
  • RoomIsHidden() : RakNet::LobbyClientPC
  • RPC() : RakPeerInterface , RakPeer , RakPeerInterface
  • RPC3() : RakNet::RPC3
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- s -

  • Send() : EmailSender , FileListTransfer , RakNetTransport , RakPeer , Router , TransportInterface , RakPeerInterface , ReliabilityLayer
  • SendAddFriendInvite() : RakNet::LobbyClientPC
  • SendConstruction()
: RakNet::ReplicaManager2
, RakNet::Replica2
, Replica
  • SendDestruction()
: RakNet::ReplicaManager2
, RakNet::Replica2
, Replica
  • SendDownloadComplete() : SendDownloadCompleteInterface
  • SendEmail() : RakNet::LobbyClientPC
  • SendHelp() : RakNetTransportCommandParser , RakNetCommandParser , CommandParserInterface , LogCommandParser
  • SendIM() : RakNet::LobbyClientPC
  • SendList() : RakPeer , RakPeerInterface
  • SendScopeChange() : Replica
  • SendSerialize()
: RakNet::ReplicaManager2
, RakNet::Replica2
  • SendTTL() : RakPeer , RakPeerInterface
  • SendVisibility()
: RakNet::ReplicaManager2
, RakNet::Replica2
  • Serialize()
: RakNet::BitStream
, RakNet::Replica2
, RakNet::BitStream
, RakNet::RakString
, Replica
  • SerializeBits() : RakNet::BitStream
  • SerializeCompressed()
: RakNet::BitStream
, RakNet::RakString
  • SerializeCompressedDelta() : RakNet::BitStream
  • SerializeConstruction() : RakNet::Replica2
  • SerializeDelta() : RakNet::BitStream
  • SerializeDestruction() : RakNet::Replica2
  • SerializeDownloadComplete() : RakNet::Connection_RM2
  • SerializeDownloadStarted() : RakNet::Connection_RM2
  • SerializeNormQuat() : RakNet::BitStream
  • SerializeNormVector() : RakNet::BitStream
  • SerializeOrthMatrix() : RakNet::BitStream
  • SerializeVector() : RakNet::BitStream
  • SerializeVisibility() : RakNet::Replica2
  • Set()
: DataStructures::Table::Cell
, RakNet::RakString
  • SetActionOnDisallowedMessage() : MessageFilter
  • SetAllowMessageID() : MessageFilter
  • SetAllowRPC() : MessageFilter
  • SetApplicationDirectory() : DirectoryDeltaTransfer
  • SetAutoAddNewConnections() : RakNet::ReplicaManager2 , ConnectionGraph
  • SetAutoAddNewConnectionsToFilter() : MessageFilter
  • SetAutoConstructToNewParticipants() : ReplicaManager
  • SetAutoParticipateNewConnections() : ReplicaManager
  • SetAutoSerializeInScope() : ReplicaManager
  • SetAutoUpdateScope() : RakNet::ReplicaManager2
  • SetCallback() : FileListTransfer
  • SetCallbackInterface()
: RakNet::LobbyClientPC
, RakNet::Lobby2::LobbyClient
  • SetCompileFrequencyTable() : RakPeer , RakPeerInterface
  • SetCompressOutgoingSends() : DirectoryDeltaTransfer
  • SetConnectionFactory() : RakNet::ReplicaManager2
  • SetConnectionGraph() : Router
  • SetConstructionByList() : RakNet::Connection_RM2
  • SetConstructionByReplicaQuery() : RakNet::Connection_RM2
  • SetData() : RakNet::BitStream
  • SetDefaultOrderingChannel() : RakNet::ReplicaManager2
  • SetDefaultPacketPriority() : RakNet::ReplicaManager2
  • SetDefaultPacketReliability() : RakNet::ReplicaManager2
  • SetDefaultScope() : ReplicaManager
  • SetDisallowedMessageCallback() : MessageFilter
  • SetDoReplicaAutoSerializeUpdate() : RakNet::ReplicaManager2
  • SetDownloadCompleteCB() : ReplicaManager
  • SetEncryptionKey() : ReliabilityLayer
  • SetEvent() : ReadyEvent
  • SetExternalSystemAddress() : NetworkIDManager
  • SetFileListTransferPlugin() : DirectoryDeltaTransfer
  • SetFilterMaxTime() : MessageFilter
  • SetGroupId() : ConnectionGraph
  • SetIncomingPassword() : RakNetTransport , RakPeer , RakPeerInterface
  • SetIsNetworkIDAuthority() : NetworkIDManager
  • SetKey() : DataBlockEncryptor
  • SetLogger() : NatPunchthrough
  • SetMaximumIncomingConnections() : RakPeer , RakPeerInterface
  • SetMTUSize() : RakPeer , RakPeerInterface
  • SetNetworkID() : NetworkIDObject
  • SetNetworkIDManager() : RakPeer , RakNet::RPC3 , RakPeerInterface , RakNet::AutoRPC , NetworkIDObject
  • SetNumberOfBitsAllocated() : RakNet::BitStream
  • SetOccasionalPing() : RakPeer , RakPeerInterface
  • SetOfflinePingResponse() : RakPeerInterface , RakPeer
  • SetOrderingChannel()
: RakNet::LobbyClientPC
, RakNet::Lobby2::LobbyClientPC
, RakNet::LobbyServer
  • SetOutgoingExtraData() : RakNet::AutoRPC
  • SetParent() : NetworkIDObject
  • SetPassword() : ConnectionGraph
  • SetPerConnectionOutgoingBandwidthLimit() : RakPeer , RakPeerInterface
  • SetPostResultFunction() : RakNet::FunctionThread
  • SetPrefix() : PacketLogger
  • SetPtr() : DataStructures::Table::Cell
  • SetRakPeerInterface() : RakNetCommandParser
  • SetReadyToPlayStatus() : RakNet::LobbyClientPC
  • SetReceiveConstructionCB() : ReplicaManager
  • SetRecipientAddress()
: RakNet::AutoRPC
, RakNet::RPC3
  • SetRecipientObject()
: RakNet::RPC3
, RakNet::AutoRPC
  • SetReplicaManager() : RakNet::Replica2
  • SetRestrictRoutingByType() : Router
  • SetRoomAllowSpectators() : RakNet::LobbyClientPC
  • SetRoomIsHidden() : RakNet::LobbyClientPC
  • SetRouterInterface() : RakPeer , RakPeerInterface
  • SetScope() : ReplicaManager
  • SetSendChannel() : ReplicaManager , ReadyEvent
  • SetSendParams()
: RakNet::AutoRPC
, RakNet::RPC3
  • SetSendPriority()
: RakNet::LobbyClientPC
, RakNet::Lobby2::LobbyClientPC
  • SetSharedNetworkID() : NetworkIDManager
  • SetSplitMessageProgressInterval() : RakPeer , RakPeerInterface
  • SetSuffix() : PacketLogger
  • SetSystemAddress() : RakNet::Connection_RM2
  • SetSystemFilterSet() : MessageFilter
  • SetTimeoutCallback() : MessageFilter
  • SetTimeoutTime() : ReliabilityLayer , RakPeer , RakPeerInterface
  • SetTimestamp()
: RakNet::RPC3
, RakNet::AutoRPC
  • SetTitleLoginId() : RakNet::LobbyClientPC
  • SetTransportProvider() : ConsoleServer
  • SetUnreliableTimeout() : RakPeer , RakPeerInterface
  • SetUploadSendParameters() : DirectoryDeltaTransfer
  • SetupReceive() : FileListTransfer
  • SetVisibilityByList() : RakNet::Connection_RM2
  • SetVisibilityByReplicaQuery() : RakNet::Connection_RM2
  • SetWriteOffset() : RakNet::BitStream
  • ShiftIncomingTimestamp() : RakPeer
  • Shutdown() : RakPeerInterface , RakPeer
  • SignalSerializationFlags() : ReplicaManager
  • SignalSerializeNeeded() : ReplicaManager
  • SimpleMutex() : SimpleMutex
  • SingleProducerConsumer() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • Size()
: DataStructures::List< list_type >
, DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • SortTable() : DataStructures::Table
  • Start() : TransportInterface , RakNetTransport
  • StartGame() : RakNet::LobbyClientPC
  • StartThreads() : ThreadPool< InputType, OutputType > , InlineFunctorProcessor , RakNet::FunctionThread
  • Startup() : FullyConnectedMesh , RakPeerInterface , RakPeer
  • Stop() : TransportInterface , RakNetTransport
  • StopThreads() : InlineFunctorProcessor , RakNet::FunctionThread , ThreadPool< InputType, OutputType >
  • StrCmp() : RakNet::RakString
  • StrICmp() : RakNet::RakString
  • StringTable() : RakNet::StringTable
  • SubmitMatch() : RakNet::LobbyClientPC
  • Subscribe() : LogCommandParser
  • SubscribeToGroup() : ConnectionGraph
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- t -

  • Table() : DataStructures::Table
  • ToLower() : RakNet::RakString
  • ToUpper() : RakNet::RakString
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- u -

  • UnlockInput() : ThreadPool< InputType, OutputType >
  • UnlockOutput() : ThreadPool< InputType, OutputType >
  • UnregisterAsRemoteProcedureCall() : RakPeer , RakPeerInterface
  • UnregisterFunction()
: RakNet::RPC3
, RakNet::AutoRPC
  • UnsetKey() : DataBlockEncryptor
  • Unsubscribe() : LogCommandParser
  • UnsubscribeFromGroup() : ConnectionGraph
  • Update() : ReliabilityLayer , ReplicaManager , HTTPConnection , FileListTransferCBInterface , ConsoleServer , PluginInterface
  • UpdateAccount() : RakNet::LobbyClientPC
  • UpdateApplicationFiles() : AutopatcherMySQLRepository , AutopatcherPostgreRepository
  • UpdateCell()
: DataStructures::Table
, DataStructures::Table::Row
  • UpdateEmailStatus() : RakNet::LobbyClientPC
  • UpdateRow() : LightweightDatabaseClient
  • URLEncode() : RakNet::RakString
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- w -

  • WasStopped() : ThreadPool< InputType, OutputType >
  • Write() : RakNet::BitStream
  • Write0() : RakNet::BitStream
  • Write1() : RakNet::BitStream
  • WriteAlignedBytes() : RakNet::BitStream
  • WriteAlignedBytesSafe() : RakNet::BitStream
  • WriteBits() : RakNet::BitStream
  • WriteCompressed() : RakNet::BitStream
  • WriteCompressedDelta() : RakNet::BitStream
  • WriteDelta() : RakNet::BitStream
  • WriteLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • WriteLog() : PacketLogger , LogCommandParser
  • WriteNormQuat() : RakNet::BitStream
  • WriteNormVector() : RakNet::BitStream
  • WriteOrthMatrix() : RakNet::BitStream
  • WritePtr() : RakNet::BitStream
  • WriteUnlock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • WriteVector() : RakNet::BitStream
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- y -

  • YieldOnFunctor() : InlineFunctorProcessor
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- a -

  • abr_enabled : EncState , SBEncState
  • accountBalance : LobbyDBSpec::CreateUser_Data
  • accountNumber : LobbyDBSpec::CreateUser_Data
  • acknowlegementBitsSent : RakNetStatistics
  • acknowlegementsPending : RakNetStatistics
  • acknowlegementsReceived : RakNetStatistics
  • acknowlegementsSent : RakNetStatistics
  • actions : LobbyDBSpec::AddToIgnoreList_Data
  • addToList : RankingServerDBSpec::ModifyTrustedIPList_Data
  • adminLevel : LobbyDBSpec::CreateUser_Data
  • allowClientAccountCreation : TitleValidationDBSpec::AddTitle_Data
  • allowConnectionResponseIPMigration : RakPeer
  • ascendingSort
: LobbyDBSpec::GetAccountNotes_Data
, LobbyDBSpec::GetFriends_Data
, LobbyDBSpec::GetEmails_Data
, LobbyDBSpec::GetIgnoreList_Data
  • attachment : LobbyDBSpec::SendEmail_Data
  • attachmentLength : LobbyDBSpec::SendEmail_Data
  • autocorr : EncState , SBEncState
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- j -

  • joinRequestAcceptorIsYou : RakNet::ClanMemberJoinRequestAccepted_Notification
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- k -

  • keyPassword : TitleValidationDBSpec::UpdateUserKey_Data
  • keyPasswordLength : TitleValidationDBSpec::UpdateUserKey_Data
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- l -

  • lag_factor : SpeexNBMode , SBEncState , SpeexSBMode , EncState
  • lagWindow : SBEncState , EncState
  • last_ol_gain : DecState
  • last_pitch : DecState
  • last_pitch_gain : DecState
  • lastName : LobbyDBSpec::CreateUser_Data
  • lbr_pitch : SpeexSubmode
  • len : SpeexJitter
  • length : Packet
  • lobbyIsGameIndependent : TitleValidationDBSpec::AddTitle_Data
  • longterm_margin : SpeexJitter
  • loss_rate : SpeexJitter
  • lost_count : SpeexJitter
  • loudness : SpeexPreprocessState
  • loudness2 : SpeexPreprocessState
  • loudness_weight : SpeexPreprocessState
  • low_quality_map : SpeexSBMode
  • lpc : EncState , SBEncState
  • lpc_enh_enabled : DecState
  • lpc_enh_k1 : SpeexSubmode
  • lpc_enh_k2 : SpeexSubmode
  • lpc_enh_k3 : SpeexSubmode
  • lpc_floor : SBEncState , SpeexNBMode , SpeexSBMode , EncState
  • lpcSize : SpeexNBMode , DecState , SBEncState , EncState , SpeexSBMode
  • lsp : EncState , SBEncState
  • lsp_quant : SpeexSubmode
  • lsp_unquant : SpeexSubmode
  • ltp_params : SpeexSubmode
  • ltp_quant : SpeexSubmode
  • ltp_unquant : SpeexSubmode
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- m -

  • matchBinaryData : RankingServerDBSpec::SubmitMatch_Data
  • matchBinaryDataLength : RankingServerDBSpec::SubmitMatch_Data
  • matchHistoryList : RankingServerDBSpec::GetHistoryForParticipant_Data
  • matchNotes : RankingServerDBSpec::SubmitMatch_Data
  • matchTime : RankingServerDBSpec::SubmitMatch_Data
  • max_pitch : EncState , DecState
  • maximumIncomingConnections : RakPeer
  • maximumNumberOfPeers : RakPeer
  • mem_exc : EncState
  • mem_sp : EncState , DecState , SBEncState
  • mem_sw : EncState , SBEncState
  • mem_sw_whole : EncState
  • messageDataBitsResent : RakNetStatistics
  • messageDataBitsSent : RakNetStatistics
  • messageInternalOrder : InternalPacket
  • messageNumber : InternalPacket
  • messageNumberAssigned : InternalPacket
  • messageResends : RakNetStatistics
  • messageSendBuffer : RakNetStatistics
  • messagesOnResendQueue : RakNetStatistics
  • messagesReceived : RakNetStatistics
  • messagesSent : RakNetStatistics
  • messagesTotalBitsResent : RakNetStatistics
  • messagesWaitingForReassembly : RakNetStatistics
  • messageTotalBitsSent : RakNetStatistics
  • middleName : LobbyDBSpec::CreateUser_Data
  • min_pitch : DecState , EncState
  • mode : EncState , SBEncState , SBDecState , DecState , SpeexMode , SpeexHeader
  • mode_bitstream_version : SpeexHeader
  • modeID : SpeexMode
  • modeName : SpeexMode
  • moderatorId : LobbyDBSpec::AddAccountNote_Data
  • moderatorUsername : LobbyDBSpec::AddAccountNote_Data
  • mySystemAddress : RakPeer
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- n -

  • nb_adapt : SpeexPreprocessState
  • nb_channels : SpeexHeader
  • nb_loudness_adapt : SpeexPreprocessState
  • nb_mode : SpeexSBMode
  • nb_preprocess : SpeexPreprocessState
  • nbBits : SpeexBits
  • nbSubframes : EncState , DecState , SBEncState
  • networkID : NetworkIDObject
  • nextActionTime : InternalPacket
  • nextAllocationNumber : NetworkIDObject
  • noise : SpeexPreprocessState
  • nPos : RakNet::RakString
  • numberOfBitsOfData : RPCParameters
  • numberOfSplitMessages : RakNetStatistics
  • numberOfUnsplitMessages : RakNetStatistics
  • numRegistrations : TitleValidationDBSpec::UpdateUserKey_Data
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- o -

  • ol_pitch : EncState
  • ol_voiced : EncState
  • old_lsp : SBEncState , EncState
  • old_ps : SpeexPreprocessState
  • old_qlsp : SBEncState , DecState , EncState
  • orderedMessagesInOrder : RakNetStatistics
  • orderedMessagesOutOfOrder : RakNetStatistics
  • orderingChannel : InternalPacket
  • orderingIndex : InternalPacket
  • outbuf : SpeexPreprocessState
  • output : LobbyDBSpec::GetUser_Data
  • outputList : RankingServerDBSpec::GetRatingForParticipants_Data
  • overflow : SpeexBits
  • owner : SpeexBits
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- z -

  • zeta : SpeexPreprocessState
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- b -

  • balance : SpeexStereoState
  • banOrSuspensionReason : LobbyDBSpec::GetUser_Data
  • billingAddress1 : LobbyDBSpec::CreateUser_Data
  • billingAddress2 : LobbyDBSpec::CreateUser_Data
  • billingCity : LobbyDBSpec::CreateUser_Data
  • billingCountry : LobbyDBSpec::CreateUser_Data
  • billingProvince : LobbyDBSpec::CreateUser_Data
  • billingState : LobbyDBSpec::CreateUser_Data
  • billingZipCode : LobbyDBSpec::CreateUser_Data
  • binaryAddress : SystemAddress
  • binaryData : TitleValidationDBSpec::UpdateUserKey_Data , LobbyDBSpec::CreateUser_Data
  • binaryDataLength : TitleValidationDBSpec::UpdateUserKey_Data , LobbyDBSpec::CreateUser_Data
  • bitPtr : SpeexBits
  • bitrate : SpeexHeader
  • bits_per_frame : SpeexSubmode
  • bitSize : Packet
  • bitsPerSecond : RakNetStatistics
  • bitsReceived : RakNetStatistics
  • bitstream_version : SpeexMode
  • bitsWithBadCRCReceived : RakNetStatistics
  • body : LobbyDBSpec::AddAccountNote_Data , LobbyDBSpec::SendEmail_Data
  • bounded_pitch : EncState
  • buf : SpeexJitter
  • buf_size : SpeexBits
  • buffer_size : SpeexJitter
  • bufSize : SBEncState , SpeexSBMode
  • bw_lpc1 : SBEncState , EncState
  • bw_lpc2 : EncState , SBEncState
  • bytesSentPerSecond : RakPeer
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- c -

  • callback_id : SpeexCallback
  • callDepth : InlineFunctor
  • callGenerationCode : NetworkIDObject
  • caption1 : LobbyDBSpec::CreateUser_Data
  • caption2 : LobbyDBSpec::CreateUser_Data
  • caption3 : LobbyDBSpec::CreateUser_Data
  • channelNames : LogCommandParser
  • channels : LogCommandParser::SystemAddressAndChannel
  • charPtr : SpeexBits
  • chars : SpeexBits
  • clanId
: RakNet::ClanJoinInvitation_Notification
, RakNet::ClanMemberJoinRequestWithdrawn_Notification
, RakNet::LeaveClan_Notification
, RakNet::ClanJoinInvitationWithdrawn_Notification
, RakNet::ClanMemberJoinRequestRejected_Notification
, RakNet::ClanMemberJoinRequestAccepted_Notification
, RakNet::ClanMemberJoinRequest_Notification
, RakNet::ClanJoinInvitationRejected_Notification
, RakNet::ClanJoinInvitationAccepted_Notification
  • clanLeaderOrSubleaderId
: RakNet::ClanJoinInvitation_Notification
, RakNet::ClanMemberJoinRequestRejected_Notification
, RakNet::ClanMemberJoinRequestAccepted_Notification
, RakNet::ClanJoinInvitationWithdrawn_Notification
, RakNet::ClanJoinInvitationRejected_Notification
, RakNet::ClanJoinInvitationAccepted_Notification
  • comb_gain : SpeexSubmode
  • completedThreads : InlineFunctorProcessor
  • complexity : EncState
  • connectionStartTime : RakNetStatistics
  • consec_noise : SpeexPreprocessState
  • context : FileListNode
  • count_lost : DecState
  • creationDate : TitleValidationDBSpec::AddTitle_Data , TitleValidationDBSpec::UpdateUserKey_Data
  • creationTime
: InternalPacket
, LobbyDBSpec::AddFriend_Data
, LobbyDBSpec::GetUser_Data
, LobbyDBSpec::AddToIgnoreList_Data
, LobbyDBSpec::SendEmail_Data
  • creditCardCVV : LobbyDBSpec::CreateUser_Data
  • creditCardExpiration : LobbyDBSpec::CreateUser_Data
  • creditCardNumber : LobbyDBSpec::CreateUser_Data
  • current_packet : SpeexJitter
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- d -

  • data : FileListNode , InternalPacket , Packet , SpeexCallback
  • dataBitLength : InternalPacket
  • dataLengthBytes : FileListNode
  • dateOfBirth : LobbyDBSpec::CreateUser_Data
  • dec : SpeexMode , SpeexJitter
  • dec_ctl : SpeexMode
  • dec_destroy : SpeexMode
  • dec_init : SpeexMode
  • defaultSubmode : SpeexNBMode , SpeexSBMode
  • double_codebook : SpeexSubmode
  • dtx_count : EncState
  • dtx_enabled : EncState
  • duplicateAcknowlegementsReceived : RakNetStatistics
  • duplicateMessagesReceived : RakNetStatistics
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- e -

  • e_ratio : SpeexStereoState
  • emailAddress : LobbyDBSpec::CreateUser_Data
  • emailMessageID
: LobbyDBSpec::SendEmail_Data
, LobbyDBSpec::DeleteEmail_Data
, LobbyDBSpec::UpdateEmailStatus_Data
  • enc : SpeexMode
  • enc_ctl : SpeexMode
  • enc_destroy : SpeexMode
  • enc_init : SpeexMode
  • encode_submode : DecState
  • encryptionBitsSent : RakNetStatistics
  • endThreads : RakPeer
  • exc : EncState , DecState , SBEncState
  • excBuf : DecState , EncState , SBEncState
  • extra_headers : SpeexHeader
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- f -

  • failureMessage : LobbyDBSpec::SendEmail_Data , LobbyDBSpec::GetEmails_Data
  • fft_lookup : SpeexPreprocessState
  • fileLengthBytes : FileListNode
  • filename : FileListNode
  • first : EncState , DecState , SBEncState
  • firstName : LobbyDBSpec::CreateUser_Data
  • forced_pitch_gain : SpeexSubmode
  • frame : SpeexPreprocessState , EncState , DecState
  • frame_size : SpeexPreprocessState , SBEncState , SpeexEchoState_ , SpeexHeader , SpeexJitter
  • frame_time : SpeexJitter
  • frames_per_packet : SpeexHeader
  • frameSize : SpeexSBMode , SpeexNBMode , DecState , EncState
  • frequencyTable : RakPeer
  • friendFound : LobbyDBSpec::AddFriend_Data
  • friendId : LobbyDBSpec::AddFriend_Data
  • full_frame_size : SBEncState
  • func : SpeexCallback
  • functionName : RPCParameters
  • functionThread : InlineFunctorProcessor
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- g -

  • g1_mem : SBEncState
  • gain : SpeexPreprocessState
  • gain2 : SpeexPreprocessState
  • gameDbId
: RankingServerDBSpec::GetRatingForParticipants_Data
, RankingServerDBSpec::SubmitMatch_Data
, RankingServerDBSpec::GetRatingForParticipant_Data
, RankingServerDBSpec::GetHistoryForParticipant_Data
, RankingServerDBSpec::ModifyTrustedIPList_Data
  • gamma1 : EncState , SBEncState , SpeexNBMode , SpeexSBMode
  • gamma2 : EncState , SBEncState , SpeexSBMode , SpeexNBMode
  • getBinaryData : LobbyDBSpec::GetUser_Data
  • getCCInfo : LobbyDBSpec::GetUser_Data
  • getEmailAddr : LobbyDBSpec::GetUser_Data
  • getPassword : LobbyDBSpec::GetUser_Data
  • getPersonalInfo : LobbyDBSpec::GetUser_Data
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- h -

  • handle : LobbyDBSpec::CreateUser_Data
  • have_subframe_gain : SpeexSubmode
  • header_size : SpeexHeader
  • high : SBEncState
  • homeAddress1 : LobbyDBSpec::CreateUser_Data
  • homeAddress2 : LobbyDBSpec::CreateUser_Data
  • homeCity : LobbyDBSpec::CreateUser_Data
  • homeCountry : LobbyDBSpec::CreateUser_Data
  • homeProvince : LobbyDBSpec::CreateUser_Data
  • homeState : LobbyDBSpec::CreateUser_Data
  • homeZipCode : LobbyDBSpec::CreateUser_Data
  • hostAddress : SocketDescriptor
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- i -

  • id
: LobbyDBSpec::GetUser_Data
, LobbyDBSpec::AddFriend_Data
, LobbyDBSpec::GetFriends_Data
, LobbyDBSpec::AddToIgnoreList_Data
, LobbyDBSpec::RemoveFromIgnoreList_Data
, LobbyDBSpec::GetIgnoreList_Data
, LobbyDBSpec::SendEmail_Data
, LobbyDBSpec::GetEmails_Data
, LobbyDBSpec::UpdateUser_Data
, LobbyDBSpec::AddAccountNote_Data
, LobbyDBSpec::GetAccountNotes_Data
  • IDTree : NetworkIDManager
  • ifp : InlineFunctor
  • inbox : LobbyDBSpec::GetEmails_Data
  • inBuf : EncState , DecState
  • inbuf : SpeexPreprocessState
  • initialSenderStatus : LobbyDBSpec::SendEmail_Data
  • innov : EncState , DecState
  • innovation_params : SpeexSubmode
  • innovation_quant : SpeexSubmode
  • innovation_unquant : SpeexSubmode
  • input : RPCParameters , LobbyDBSpec::UpdateUser_Data
  • instance : RakNet::StringTable
  • internalOutputQueueSize : RakNetStatistics
  • interp_lpc : SBEncState , EncState
  • interp_lsp : EncState , SBEncState
  • interp_qlpc : EncState , DecState , SBEncState
  • interp_qlsp : EncState , DecState , SBEncState
  • invalidKey : TitleValidationDBSpec::UpdateUserKey_Data
  • invalidKeyReason : TitleValidationDBSpec::UpdateUserKey_Data
  • invalidMessagesReceived : RakNetStatistics
  • invitationSenderIsYou : RakNet::ClanJoinInvitationAccepted_Notification
  • ip : RankingServerDBSpec::ModifyTrustedIPList_Data
  • ipList : RankingServerDBSpec::GetTrustedIPList_Data
  • isBanned : LobbyDBSpec::GetUser_Data
  • isMainLoopThreadActive : RakPeer
  • isSuspended : LobbyDBSpec::GetUser_Data
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- p -

  • packetNumber : InternalPacket
  • packetsContainingOnlyAcknowlegements : RakNetStatistics
  • packetsContainingOnlyAcknowlegementsAndResends : RakNetStatistics
  • packetsReceived : RakNetStatistics
  • packetsSent : RakNetStatistics
  • packetsWithBadCRCReceived : RakNetStatistics
  • parent : NetworkIDObject
  • participantADbId : RankingServerDBSpec::SubmitMatch_Data
  • participantANewRating : RankingServerDBSpec::SubmitMatch_Data
  • participantAOldRating : RankingServerDBSpec::SubmitMatch_Data
  • participantAScore : RankingServerDBSpec::SubmitMatch_Data
  • participantBDbId : RankingServerDBSpec::SubmitMatch_Data
  • participantBNewRating : RankingServerDBSpec::SubmitMatch_Data
  • participantBOldRating : RankingServerDBSpec::SubmitMatch_Data
  • participantBScore : RankingServerDBSpec::SubmitMatch_Data
  • participantDbId : RankingServerDBSpec::GetRatingForParticipant_Data , RankingServerDBSpec::GetHistoryForParticipant_Data
  • participantFound : RankingServerDBSpec::GetRatingForParticipant_Data
  • participantList : ReplicaManager
  • password : LobbyDBSpec::CreateUser_Data
  • passwordRecoveryAnswer : LobbyDBSpec::CreateUser_Data
  • passwordRecoveryQuestion : LobbyDBSpec::CreateUser_Data
  • peer : RakNetCommandParser
  • permissions : LobbyDBSpec::CreateUser_Data
  • pi_gain : DecState , EncState
  • pitch_gain_buf : DecState
  • pitch_gain_buf_idx : DecState
  • pitchEnd : SpeexNBMode
  • pitchStart : SpeexNBMode
  • pointer_timestamp : SpeexJitter
  • port : SocketDescriptor , SystemAddress
  • post : SpeexPreprocessState
  • prior : SpeexPreprocessState
  • priority : InternalPacket
  • ps : SpeexPreprocessState
  • ps_size : SpeexPreprocessState
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- q -

  • qlsp : EncState , SBEncState , DecState
  • quality_map : SpeexSBMode , SpeexNBMode
  • query : SpeexMode
  • queryResult : LobbyDBSpec::AddFriend_Data , LobbyDBSpec::AddToIgnoreList_Data
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- r -

  • race : LobbyDBSpec::CreateUser_Data
  • rate : SpeexHeader
  • rating : RankingServerDBSpec::GetRatingForParticipant_Data
  • recipient : RPCParameters
  • recipientAddress : RakNet::SerializationContext
  • relative_quality : EncState
  • relaySourceAddress : RakNet::SerializationContext
  • reliability : InternalPacket
  • remoteSystemList : RakPeer
  • remoteUsers : LogCommandParser
  • removeFriendInput : LobbyDBSpec::RemoveFriend_Data
  • replicatedObjects : ReplicaManager
  • replyToSender : RPCParameters
  • requireUserKeyToLogon : TitleValidationDBSpec::AddTitle_Data
  • res : SBEncState
  • reserved1 : SpeexCallback , SpeexStereoState , SpeexHeader , SpeexBits
  • reserved2 : SpeexBits , SpeexCallback , SpeexHeader , SpeexStereoState
  • reset_state : SpeexJitter
  • reverb_estimate : SpeexPreprocessState
  • rsacrypt : RakPeer
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- s -

  • S : SpeexPreprocessState
  • safe_pitch : EncState
  • sampling_rate : SpeexPreprocessState
  • sender : RPCParameters
  • sequencedMessagesInOrder : RakNetStatistics
  • sequencedMessagesOutOfOrder : RakNetStatistics
  • serializationType : RakNet::SerializationContext
  • sex : LobbyDBSpec::CreateUser_Data
  • shortterm_margin : SpeexJitter
  • Smin : SpeexPreprocessState
  • smooth_left : SpeexStereoState
  • smooth_right : SpeexStereoState
  • sourceIPAddress : LobbyDBSpec::CreateUser_Data
  • speex_string : SpeexHeader
  • speex_version : SpeexHeader
  • speex_version_id : SpeexHeader
  • splitPacketCount : InternalPacket
  • splitPacketId : InternalPacket
  • splitPacketIndex : InternalPacket
  • st_low : SBDecState , SBEncState
  • stack : EncState , DecState , SBEncState
  • status : LobbyDBSpec::SendEmail_Data , LobbyDBSpec::UpdateEmailStatus_Data
  • Stmp : SpeexPreprocessState
  • subframeSize : SpeexSBMode , EncState , DecState , SBEncState , SpeexNBMode
  • subject : LobbyDBSpec::SendEmail_Data , LobbyDBSpec::AddAccountNote_Data
  • submodeID : DecState , EncState
  • submodes : SpeexNBMode , DecState , SpeexSBMode , EncState
  • submodeSelect : EncState
  • success : LobbyDBSpec::AddToIgnoreList_Data , LobbyDBSpec::AddFriend_Data
  • suspensionExpiration : LobbyDBSpec::GetUser_Data
  • sw : SBEncState , EncState
  • swBuf : EncState
  • systemAddress : RankingServerDBSpec::ModifyTrustedIPList_Data , LogCommandParser::SystemAddressAndChannel , Packet
  • systemIndex : Packet
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- t -

  • target : SBEncState
  • time : LobbyDBSpec::AddAccountNote_Data
  • timestamp : SpeexJitter , RakNet::SerializationContext
  • titleId : TitleValidationDBSpec::AddTitle_Data , TitleValidationDBSpec::UpdateUserKey_Data
  • titleName : TitleValidationDBSpec::AddTitle_Data
  • titlePassword : TitleValidationDBSpec::AddTitle_Data
  • titlePasswordLength : TitleValidationDBSpec::AddTitle_Data
  • titles : TitleValidationDBSpec::GetTitles_Data
  • to : LobbyDBSpec::SendEmail_Data
  • totalBitsSent : RakNetStatistics
  • totalSplits : RakNetStatistics
  • trans : LogCommandParser
  • type : LobbyDBSpec::AddAccountNote_Data
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- u -

  • update_prob : SpeexPreprocessState
  • updateBinaryData : LobbyDBSpec::UpdateUser_Data
  • updateCCInfo : LobbyDBSpec::UpdateUser_Data
  • updateCycleIsRunning : RakPeer
  • updateEmailAddr : LobbyDBSpec::UpdateUser_Data
  • updatePassword : LobbyDBSpec::UpdateUser_Data
  • updatePersonalInfo : LobbyDBSpec::UpdateUser_Data
  • userFound
: LobbyDBSpec::AddAccountNote_Data
, LobbyDBSpec::AddFriend_Data
, LobbyDBSpec::GetUser_Data
  • userId
: RakNet::ClanJoinInvitationAccepted_Notification
, RakNet::ClanMemberJoinRequest_Notification
, TitleValidationDBSpec::UpdateUserKey_Data
, RakNet::LeaveClan_Notification
, RakNet::ClanMemberJoinRequestWithdrawn_Notification
, RakNet::ClanJoinInvitationRejected_Notification
, RakNet::ClanMemberJoinRequestAccepted_Notification
  • userIdIsYou : RakNet::ClanJoinInvitationAccepted_Notification , RakNet::ClanMemberJoinRequestAccepted_Notification
  • userIP : TitleValidationDBSpec::UpdateUserKey_Data
  • userKeyId : TitleValidationDBSpec::UpdateUserKey_Data
  • userKeyIsSet : TitleValidationDBSpec::UpdateUserKey_Data
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- v -

  • vad_enabled : EncState , SBEncState
  • valid_bits : SpeexJitter
  • validParameters : LobbyDBSpec::SendEmail_Data , LobbyDBSpec::GetEmails_Data
  • vbr : EncState , SpeexHeader
  • vbr_enabled : EncState , SBEncState
  • vbr_quality : EncState , SBEncState
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- w -

  • wasOpened : LobbyDBSpec::SendEmail_Data , LobbyDBSpec::UpdateEmailStatus_Data
  • window : SpeexPreprocessState , SBEncState , EncState
  • windowSize : SBEncState , EncState
  • writeModeratorId : LobbyDBSpec::AddAccountNote_Data
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- x -

  • x1d : SBEncState
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- y -

  • y1 : SBEncState
Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- l -

  • le_int() : misc.h
  • LOW_PRIORITY : PacketPriority.h
  • lsp_quant_func : modes.h
  • lsp_unquant_func : modes.h
  • ltp_quant_func : modes.h
  • ltp_unquant_func : modes.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- m -

  • MEDIUM_PRIORITY : PacketPriority.h
  • MessageID : RakNetTypes.h
  • MessageNumberType : InternalPacket.h
  • mode_query_func : speex.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- n -

  • nb_decode() : nb_celp.h
  • nb_decoder_ctl() : nb_celp.h
  • nb_decoder_destroy() : nb_celp.h
  • nb_decoder_init() : nb_celp.h
  • nb_encode() : nb_celp.h
  • nb_encoder_ctl() : nb_celp.h
  • nb_encoder_destroy() : nb_celp.h
  • nb_encoder_init() : nb_celp.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- o -

  • OrderingIndexType : InternalPacket.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- a -

  • AUTOSERIALIZE_DEFAULT : ReplicaManager2.h
  • AUTOSERIALIZE_RESYNCH_ONLY : ReplicaManager2.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- b -

  • be_int() : misc.h
  • BQR_ALWAYS : ReplicaManager2.h
  • BQR_NO : ReplicaManager2.h
  • BQR_YES : ReplicaManager2.h
  • BROADCAST_AUTO_SERIALIZE_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_CONSTRUCTION_GENERIC_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_CONSTRUCTION_REQUEST_ACCEPTED_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_DESTRUCTION_GENERIC_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_SERIALIZATION_CONSTRUCTION_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_SERIALIZATION_GENERIC_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_VISIBILITY_FALSE_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_VISIBILITY_TRUE_TO_SYSTEM : ReplicaManager2.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- d -

  • decode_func : speex.h
  • decoder_ctl_func : speex.h
  • decoder_destroy_func : speex.h
  • decoder_init_func : speex.h
  • defaultMapKeyComparison() : DS_Map.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- e -

  • encode_func : speex.h
  • encoder_ctl_func : speex.h
  • encoder_destroy_func : speex.h
  • encoder_init_func : speex.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- f -

  • f32 : Types.h
  • f64 : Types.h
  • forced_pitch_quant() : ltp.h
  • forced_pitch_unquant() : ltp.h
  • frandomMT() : Rand.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- g -

  • GetTime() : GetTime.cpp
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- h -

  • HIGH_PRIORITY : PacketPriority.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- i -

  • ID_ADVERTISE_SYSTEM : MessageIdentifiers.h
  • ID_ALREADY_CONNECTED : MessageIdentifiers.h
  • ID_AUTO_RPC_CALL : MessageIdentifiers.h
  • ID_AUTO_RPC_REMOTE_INDEX : MessageIdentifiers.h
  • ID_AUTO_RPC_UNKNOWN_REMOTE_INDEX : MessageIdentifiers.h
  • ID_AUTOPATCHER_CREATION_LIST : MessageIdentifiers.h
  • ID_AUTOPATCHER_DELETION_LIST : MessageIdentifiers.h
  • ID_AUTOPATCHER_FINISHED_INTERNAL : MessageIdentifiers.h
  • ID_AUTOPATCHER_GET_CHANGELIST_SINCE_DATE : MessageIdentifiers.h
  • ID_AUTOPATCHER_GET_PATCH : MessageIdentifiers.h
  • ID_AUTOPATCHER_PATCH_LIST : MessageIdentifiers.h
  • ID_AUTOPATCHER_REPOSITORY_FATAL_ERROR : MessageIdentifiers.h
  • ID_AUTOPATCHER_RESTART_APPLICATION : MessageIdentifiers.h
  • ID_CONNECTED_PONG : MessageIdentifiers.h
  • ID_CONNECTION_ATTEMPT_FAILED : MessageIdentifiers.h
  • ID_CONNECTION_BANNED : MessageIdentifiers.h
  • ID_CONNECTION_GRAPH_CONNECTION_LOST : MessageIdentifiers.h
  • ID_CONNECTION_GRAPH_DISCONNECTION_NOTIFICATION : MessageIdentifiers.h
  • ID_CONNECTION_GRAPH_NEW_CONNECTION : MessageIdentifiers.h
  • ID_CONNECTION_GRAPH_REPLY : MessageIdentifiers.h
  • ID_CONNECTION_GRAPH_REQUEST : MessageIdentifiers.h
  • ID_CONNECTION_GRAPH_UPDATE : MessageIdentifiers.h
  • ID_CONNECTION_LOST : MessageIdentifiers.h
  • ID_CONNECTION_REQUEST : MessageIdentifiers.h
  • ID_CONNECTION_REQUEST_ACCEPTED : MessageIdentifiers.h
  • ID_DATABASE_INCORRECT_PASSWORD : MessageIdentifiers.h
  • ID_DATABASE_QUERY_REPLY : MessageIdentifiers.h
  • ID_DATABASE_QUERY_REQUEST : MessageIdentifiers.h
  • ID_DATABASE_REMOVE_ROW : MessageIdentifiers.h
  • ID_DATABASE_UNKNOWN_TABLE : MessageIdentifiers.h
  • ID_DATABASE_UPDATE_ROW : MessageIdentifiers.h
  • ID_DDT_DOWNLOAD_REQUEST : MessageIdentifiers.h
  • ID_DETECT_LOST_CONNECTIONS : MessageIdentifiers.h
  • ID_DISCONNECTION_NOTIFICATION : MessageIdentifiers.h
  • ID_FILE_LIST_TRANSFER_FILE : MessageIdentifiers.h
  • ID_FILE_LIST_TRANSFER_HEADER : MessageIdentifiers.h
  • ID_INTERNAL_PING : MessageIdentifiers.h
  • ID_INVALID_PASSWORD : MessageIdentifiers.h
  • ID_LOBBY_GENERAL : MessageIdentifiers.h
  • ID_MODIFIED_PACKET : MessageIdentifiers.h
  • ID_NAT_CONNECT_AT_TIME : MessageIdentifiers.h
  • ID_NAT_IN_PROGRESS : MessageIdentifiers.h
  • ID_NAT_PUNCHTHROUGH_REQUEST : MessageIdentifiers.h
  • ID_NAT_SEND_OFFLINE_MESSAGE_AT_TIME : MessageIdentifiers.h
  • ID_NAT_TARGET_CONNECTION_LOST : MessageIdentifiers.h
  • ID_NAT_TARGET_NOT_CONNECTED : MessageIdentifiers.h
  • ID_NEW_INCOMING_CONNECTION : MessageIdentifiers.h
  • ID_NO_FREE_INCOMING_CONNECTIONS : MessageIdentifiers.h
  • ID_OPEN_CONNECTION_REPLY : MessageIdentifiers.h
  • ID_OPEN_CONNECTION_REQUEST : MessageIdentifiers.h
  • ID_OUT_OF_BAND_INTERNAL : MessageIdentifiers.h
  • ID_PING : MessageIdentifiers.h
  • ID_PING_OPEN_CONNECTIONS : MessageIdentifiers.h
  • ID_PONG : MessageIdentifiers.h
  • ID_RAKVOICE_CLOSE_CHANNEL : MessageIdentifiers.h
  • ID_RAKVOICE_DATA : MessageIdentifiers.h
  • ID_RAKVOICE_OPEN_CHANNEL_REPLY : MessageIdentifiers.h
  • ID_RAKVOICE_OPEN_CHANNEL_REQUEST : MessageIdentifiers.h
  • ID_READY_EVENT_ALL_SET : MessageIdentifiers.h
  • ID_READY_EVENT_QUERY : MessageIdentifiers.h
  • ID_READY_EVENT_SET : MessageIdentifiers.h
  • ID_READY_EVENT_UNSET : MessageIdentifiers.h
  • ID_REMOTE_CONNECTION_LOST : MessageIdentifiers.h
  • ID_REMOTE_DISCONNECTION_NOTIFICATION : MessageIdentifiers.h
  • ID_REMOTE_NEW_INCOMING_CONNECTION : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_CONSTRUCTION : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_DESTRUCTION : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_DOWNLOAD_COMPLETE : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_DOWNLOAD_STARTED : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_SCOPE_CHANGE : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_SERIALIZE : MessageIdentifiers.h
  • ID_ROUTE_AND_MULTICAST : MessageIdentifiers.h
  • ID_RPC : MessageIdentifiers.h
  • ID_RPC_MAPPING : MessageIdentifiers.h
  • ID_RPC_REMOTE_ERROR : MessageIdentifiers.h
  • ID_RPC_REPLY : MessageIdentifiers.h
  • ID_RSA_PUBLIC_KEY_MISMATCH : MessageIdentifiers.h
  • ID_SECURED_CONNECTION_CONFIRMATION : MessageIdentifiers.h
  • ID_SECURED_CONNECTION_RESPONSE : MessageIdentifiers.h
  • ID_TIMESTAMP : MessageIdentifiers.h
  • ID_TRANSPORT_STRING : MessageIdentifiers.h
  • innovation_quant_func : modes.h
  • innovation_unquant_func : modes.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- p -

  • pitch_search_3tap() : ltp.h
  • print_vec() : misc.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- r -

  • randomMT() : Rand.h
  • RegisteredCommandComp() : CommandParserInterface.h
  • RELAY_DESTRUCTION_TO_SYSTEMS : ReplicaManager2.h
  • RELAY_SERIALIZATION_TO_SYSTEMS : ReplicaManager2.h
  • RELAY_VISIBILITY_FALSE_TO_SYSTEMS : ReplicaManager2.h
  • RELAY_VISIBILITY_TRUE_TO_SYSTEMS : ReplicaManager2.h
  • RELIABLE : PacketPriority.h
  • RELIABLE_ORDERED : PacketPriority.h
  • RELIABLE_SEQUENCED : PacketPriority.h
  • REPLICA_CANCEL_PROCESS : ReplicaEnums.h
  • REPLICA_PROCESS_AGAIN : ReplicaEnums.h
  • REPLICA_PROCESS_IMPLICIT : ReplicaEnums.h
  • REPLICA_PROCESS_LATER : ReplicaEnums.h
  • REPLICA_PROCESSING_DONE : ReplicaEnums.h
  • RES_ALL_READY : ReadyEvent.h
  • RES_NOT_WAITING : ReadyEvent.h
  • RES_READY : ReadyEvent.h
  • RES_UNKNOWN_EVENT : ReadyEvent.h
  • RES_WAITING : ReadyEvent.h
  • RPC_ERROR_CALLING_C_AS_CPP : RPC3.h , AutoRPC.h
  • RPC_ERROR_CALLING_CPP_AS_C : RPC3.h , AutoRPC.h
  • RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE : RPC3.h , AutoRPC.h
  • RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED : RPC3.h , AutoRPC.h
  • RPC_ERROR_FUNCTION_NOT_REGISTERED : AutoRPC.h , RPC3.h
  • RPC_ERROR_INCORRECT_NUMBER_OF_PARAMETERS : AutoRPC.h
  • RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE : RPC3.h , AutoRPC.h
  • RPC_ERROR_OBJECT_DOES_NOT_EXIST : RPC3.h , AutoRPC.h
  • RPC_ERROR_STACK_DESERIALIZATION_FAILED : AutoRPC.h
  • RPC_ERROR_STACK_TOO_SMALL : AutoRPC.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- s -

  • s16 : Types.h
  • s32 : Types.h
  • s8 : Types.h
  • sb_decode() : sb_celp.h
  • sb_decoder_destroy() : sb_celp.h
  • sb_decoder_init() : sb_celp.h
  • sb_encode() : sb_celp.h
  • sb_encoder_destroy() : sb_celp.h
  • sb_encoder_init() : sb_celp.h
  • seedMT() : Rand.h
  • SEND_AUTO_SERIALIZE_TO_SYSTEM : ReplicaManager2.h
  • SEND_CONSTRUCTION_GENERIC_TO_SYSTEM : ReplicaManager2.h
  • SEND_CONSTRUCTION_REPLY_ACCEPTED_TO_CLIENT : ReplicaManager2.h
  • SEND_CONSTRUCTION_REPLY_DENIED_TO_CLIENT : ReplicaManager2.h
  • SEND_CONSTRUCTION_REQUEST_TO_SERVER : ReplicaManager2.h
  • SEND_CONSTRUCTION_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM : ReplicaManager2.h
  • SEND_CONSTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM : ReplicaManager2.h
  • SEND_DATA_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM : ReplicaManager2.h
  • SEND_DESTRUCTION_GENERIC_TO_SYSTEM : ReplicaManager2.h
  • SEND_DESTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM : ReplicaManager2.h
  • SEND_SERIALIZATION_CONSTRUCTION_TO_SYSTEM : ReplicaManager2.h
  • SEND_SERIALIZATION_GENERIC_TO_SYSTEM : ReplicaManager2.h
  • SEND_VISIBILITY_FALSE_TO_SYSTEM : ReplicaManager2.h
  • SEND_VISIBILITY_TRUE_TO_SYSTEM : ReplicaManager2.h
  • sfp16_16 : Types.h
  • sfp22_10 : Types.h
  • SOCKET : TCPInterface.h , SocketLayer.h
  • speex_alloc() : misc.h
  • speex_alloc_scratch() : misc.h
  • speex_bits_advance() : speex_bits.h
  • speex_bits_destroy() : speex_bits.h
  • speex_bits_init() : speex_bits.h
  • speex_bits_init_buffer() : speex_bits.h
  • speex_bits_insert_terminator() : speex_bits.h
  • speex_bits_nbytes() : speex_bits.h
  • speex_bits_pack() : speex_bits.h
  • speex_bits_peek() : speex_bits.h
  • speex_bits_peek_unsigned() : speex_bits.h
  • speex_bits_read_from() : speex_bits.h
  • speex_bits_read_whole_bytes() : speex_bits.h
  • speex_bits_remaining() : speex_bits.h
  • speex_bits_reset() : speex_bits.h
  • speex_bits_rewind() : speex_bits.h
  • speex_bits_unpack_signed() : speex_bits.h
  • speex_bits_unpack_unsigned() : speex_bits.h
  • speex_bits_write() : speex_bits.h
  • speex_bits_write_whole_bytes() : speex_bits.h
  • speex_callback_func : speex_callbacks.h
  • speex_decode() : speex.h
  • speex_decode_int() : speex.h
  • speex_decode_stereo() : speex_stereo.h
  • speex_decode_stereo_int() : speex_stereo.h
  • speex_decoder_ctl() : speex.h
  • speex_decoder_destroy() : speex.h
  • speex_decoder_init() : speex.h
  • speex_default_user_handler() : speex_callbacks.h
  • speex_echo_cancel() : speex_echo.h
  • speex_echo_ctl() : speex_echo.h
  • speex_echo_state_destroy() : speex_echo.h
  • speex_echo_state_init() : speex_echo.h
  • speex_echo_state_reset() : speex_echo.h
  • speex_encode() : speex.h
  • speex_encode_int() : speex.h
  • speex_encode_stereo() : speex_stereo.h
  • speex_encode_stereo_int() : speex_stereo.h
  • speex_encoder_ctl() : speex.h
  • speex_encoder_destroy() : speex.h
  • speex_encoder_init() : speex.h
  • speex_error() : misc.h
  • speex_free() : misc.h
  • speex_free_scratch() : misc.h
  • speex_header_to_packet() : speex_header.h
  • speex_inband_handler() : speex_callbacks.h
  • speex_init_header() : speex_header.h
  • speex_jitter_destroy() : speex_jitter.h
  • speex_jitter_get() : speex_jitter.h
  • speex_jitter_get_pointer_timestamp() : speex_jitter.h
  • speex_jitter_init() : speex_jitter.h
  • speex_jitter_put() : speex_jitter.h
  • speex_lib_ctl() : speex.h
  • speex_lib_get_mode() : speex.h
  • speex_memcpy_bytes() : misc.h
  • speex_memset_bytes() : misc.h
  • speex_mode_list : speex.h
  • speex_mode_query() : speex.h
  • speex_move() : misc.h
  • speex_nb_mode : speex.h
  • speex_packet_to_header() : speex_header.h
  • speex_pcm_wrapper : pcm_wrapper.h
  • speex_preprocess() : speex_preprocess.h
  • speex_preprocess_ctl() : speex_preprocess.h
  • speex_preprocess_estimate_update() : speex_preprocess.h
  • speex_preprocess_state_destroy() : speex_preprocess.h
  • speex_preprocess_state_init() : speex_preprocess.h
  • speex_rand() : misc.h
  • speex_rand_vec() : misc.h
  • speex_realloc() : misc.h
  • speex_std_char_handler() : speex_callbacks.h
  • speex_std_high_mode_request_handler() : speex_callbacks.h
  • speex_std_mode_request_handler() : speex_callbacks.h
  • speex_std_stereo_request_handler() : speex_stereo.h
  • speex_uwb_mode : speex.h
  • speex_warning() : misc.h
  • speex_warning_int() : misc.h
  • speex_wb_mode : speex.h
  • StatisticsToString() : RakNetStatistics.h
  • StringTableType : StringTable.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u

Here is a list of all documented file members with links to the documentation:

- u -

  • u16 : Types.h
  • u32 : Types.h
  • u8 : Types.h
  • ufp16_16 : Types.h
  • ufp22_10 : Types.h
  • UNASSIGNED_NETWORK_ID : RakNetTypes.h
  • UNASSIGNED_PLAYER_INDEX : RakNetTypes.h
  • UNASSIGNED_SYSTEM_ADDRESS : RakNetTypes.h
  • UNDEFINED_REASON : ReplicaManager2.h
  • UniqueIDType : RakNetTypes.h
  • UNRELIABLE : PacketPriority.h
  • UNRELIABLE_SEQUENCED : PacketPriority.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • a
  • b
  • h
  • i
  • l
  • m
  • r
  • s
  • u

- a -

  • AUTOSERIALIZE_DEFAULT : ReplicaManager2.h
  • AUTOSERIALIZE_RESYNCH_ONLY : ReplicaManager2.h

- b -

  • BROADCAST_AUTO_SERIALIZE_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_CONSTRUCTION_GENERIC_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_CONSTRUCTION_REQUEST_ACCEPTED_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_DESTRUCTION_GENERIC_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_SERIALIZATION_CONSTRUCTION_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_SERIALIZATION_GENERIC_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_VISIBILITY_FALSE_TO_SYSTEM : ReplicaManager2.h
  • BROADCAST_VISIBILITY_TRUE_TO_SYSTEM : ReplicaManager2.h

- h -

  • HIGH_PRIORITY : PacketPriority.h

- i -

  • ID_ADVERTISE_SYSTEM : MessageIdentifiers.h
  • ID_ALREADY_CONNECTED : MessageIdentifiers.h
  • ID_AUTO_RPC_CALL : MessageIdentifiers.h
  • ID_AUTO_RPC_REMOTE_INDEX : MessageIdentifiers.h
  • ID_AUTO_RPC_UNKNOWN_REMOTE_INDEX : MessageIdentifiers.h
  • ID_AUTOPATCHER_CREATION_LIST : MessageIdentifiers.h
  • ID_AUTOPATCHER_DELETION_LIST : MessageIdentifiers.h
  • ID_AUTOPATCHER_FINISHED_INTERNAL : MessageIdentifiers.h
  • ID_AUTOPATCHER_GET_CHANGELIST_SINCE_DATE : MessageIdentifiers.h
  • ID_AUTOPATCHER_GET_PATCH : MessageIdentifiers.h
  • ID_AUTOPATCHER_PATCH_LIST : MessageIdentifiers.h
  • ID_AUTOPATCHER_REPOSITORY_FATAL_ERROR : MessageIdentifiers.h
  • ID_AUTOPATCHER_RESTART_APPLICATION : MessageIdentifiers.h
  • ID_CONNECTED_PONG : MessageIdentifiers.h
  • ID_CONNECTION_ATTEMPT_FAILED : MessageIdentifiers.h
  • ID_CONNECTION_BANNED : MessageIdentifiers.h
  • ID_CONNECTION_GRAPH_CONNECTION_LOST : MessageIdentifiers.h
  • ID_CONNECTION_GRAPH_DISCONNECTION_NOTIFICATION : MessageIdentifiers.h
  • ID_CONNECTION_GRAPH_NEW_CONNECTION : MessageIdentifiers.h
  • ID_CONNECTION_GRAPH_REPLY : MessageIdentifiers.h
  • ID_CONNECTION_GRAPH_REQUEST : MessageIdentifiers.h
  • ID_CONNECTION_GRAPH_UPDATE : MessageIdentifiers.h
  • ID_CONNECTION_LOST : MessageIdentifiers.h
  • ID_CONNECTION_REQUEST : MessageIdentifiers.h
  • ID_CONNECTION_REQUEST_ACCEPTED : MessageIdentifiers.h
  • ID_DATABASE_INCORRECT_PASSWORD : MessageIdentifiers.h
  • ID_DATABASE_QUERY_REPLY : MessageIdentifiers.h
  • ID_DATABASE_QUERY_REQUEST : MessageIdentifiers.h
  • ID_DATABASE_REMOVE_ROW : MessageIdentifiers.h
  • ID_DATABASE_UNKNOWN_TABLE : MessageIdentifiers.h
  • ID_DATABASE_UPDATE_ROW : MessageIdentifiers.h
  • ID_DDT_DOWNLOAD_REQUEST : MessageIdentifiers.h
  • ID_DETECT_LOST_CONNECTIONS : MessageIdentifiers.h
  • ID_DISCONNECTION_NOTIFICATION : MessageIdentifiers.h
  • ID_FILE_LIST_TRANSFER_FILE : MessageIdentifiers.h
  • ID_FILE_LIST_TRANSFER_HEADER : MessageIdentifiers.h
  • ID_INTERNAL_PING : MessageIdentifiers.h
  • ID_INVALID_PASSWORD : MessageIdentifiers.h
  • ID_LOBBY_GENERAL : MessageIdentifiers.h
  • ID_MODIFIED_PACKET : MessageIdentifiers.h
  • ID_NAT_CONNECT_AT_TIME : MessageIdentifiers.h
  • ID_NAT_IN_PROGRESS : MessageIdentifiers.h
  • ID_NAT_PUNCHTHROUGH_REQUEST : MessageIdentifiers.h
  • ID_NAT_SEND_OFFLINE_MESSAGE_AT_TIME : MessageIdentifiers.h
  • ID_NAT_TARGET_CONNECTION_LOST : MessageIdentifiers.h
  • ID_NAT_TARGET_NOT_CONNECTED : MessageIdentifiers.h
  • ID_NEW_INCOMING_CONNECTION : MessageIdentifiers.h
  • ID_NO_FREE_INCOMING_CONNECTIONS : MessageIdentifiers.h
  • ID_OPEN_CONNECTION_REPLY : MessageIdentifiers.h
  • ID_OPEN_CONNECTION_REQUEST : MessageIdentifiers.h
  • ID_OUT_OF_BAND_INTERNAL : MessageIdentifiers.h
  • ID_PING : MessageIdentifiers.h
  • ID_PING_OPEN_CONNECTIONS : MessageIdentifiers.h
  • ID_PONG : MessageIdentifiers.h
  • ID_RAKVOICE_CLOSE_CHANNEL : MessageIdentifiers.h
  • ID_RAKVOICE_DATA : MessageIdentifiers.h
  • ID_RAKVOICE_OPEN_CHANNEL_REPLY : MessageIdentifiers.h
  • ID_RAKVOICE_OPEN_CHANNEL_REQUEST : MessageIdentifiers.h
  • ID_READY_EVENT_ALL_SET : MessageIdentifiers.h
  • ID_READY_EVENT_QUERY : MessageIdentifiers.h
  • ID_READY_EVENT_SET : MessageIdentifiers.h
  • ID_READY_EVENT_UNSET : MessageIdentifiers.h
  • ID_REMOTE_CONNECTION_LOST : MessageIdentifiers.h
  • ID_REMOTE_DISCONNECTION_NOTIFICATION : MessageIdentifiers.h
  • ID_REMOTE_NEW_INCOMING_CONNECTION : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_CONSTRUCTION : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_DESTRUCTION : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_DOWNLOAD_COMPLETE : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_DOWNLOAD_STARTED : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_SCOPE_CHANGE : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_SERIALIZE : MessageIdentifiers.h
  • ID_ROUTE_AND_MULTICAST : MessageIdentifiers.h
  • ID_RPC : MessageIdentifiers.h
  • ID_RPC_MAPPING : MessageIdentifiers.h
  • ID_RPC_REMOTE_ERROR : MessageIdentifiers.h
  • ID_RPC_REPLY : MessageIdentifiers.h
  • ID_RSA_PUBLIC_KEY_MISMATCH : MessageIdentifiers.h
  • ID_SECURED_CONNECTION_CONFIRMATION : MessageIdentifiers.h
  • ID_SECURED_CONNECTION_RESPONSE : MessageIdentifiers.h
  • ID_TIMESTAMP : MessageIdentifiers.h
  • ID_TRANSPORT_STRING : MessageIdentifiers.h

- l -

  • LOW_PRIORITY : PacketPriority.h

- m -

  • MEDIUM_PRIORITY : PacketPriority.h

- r -

  • RELAY_DESTRUCTION_TO_SYSTEMS : ReplicaManager2.h
  • RELAY_SERIALIZATION_TO_SYSTEMS : ReplicaManager2.h
  • RELAY_VISIBILITY_FALSE_TO_SYSTEMS : ReplicaManager2.h
  • RELAY_VISIBILITY_TRUE_TO_SYSTEMS : ReplicaManager2.h
  • RELIABLE : PacketPriority.h
  • RELIABLE_ORDERED : PacketPriority.h
  • RELIABLE_SEQUENCED : PacketPriority.h
  • REPLICA_CANCEL_PROCESS : ReplicaEnums.h
  • REPLICA_PROCESS_AGAIN : ReplicaEnums.h
  • REPLICA_PROCESS_IMPLICIT : ReplicaEnums.h
  • REPLICA_PROCESS_LATER : ReplicaEnums.h
  • REPLICA_PROCESSING_DONE : ReplicaEnums.h
  • RES_ALL_READY : ReadyEvent.h
  • RES_NOT_WAITING : ReadyEvent.h
  • RES_READY : ReadyEvent.h
  • RES_UNKNOWN_EVENT : ReadyEvent.h
  • RES_WAITING : ReadyEvent.h
  • RPC_ERROR_CALLING_C_AS_CPP : AutoRPC.h , RPC3.h
  • RPC_ERROR_CALLING_CPP_AS_C : RPC3.h , AutoRPC.h
  • RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE : RPC3.h , AutoRPC.h
  • RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED : RPC3.h , AutoRPC.h
  • RPC_ERROR_FUNCTION_NOT_REGISTERED : AutoRPC.h , RPC3.h
  • RPC_ERROR_INCORRECT_NUMBER_OF_PARAMETERS : AutoRPC.h
  • RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE : RPC3.h , AutoRPC.h
  • RPC_ERROR_OBJECT_DOES_NOT_EXIST : RPC3.h , AutoRPC.h
  • RPC_ERROR_STACK_DESERIALIZATION_FAILED : AutoRPC.h
  • RPC_ERROR_STACK_TOO_SMALL : AutoRPC.h

- s -

  • SEND_AUTO_SERIALIZE_TO_SYSTEM : ReplicaManager2.h
  • SEND_CONSTRUCTION_GENERIC_TO_SYSTEM : ReplicaManager2.h
  • SEND_CONSTRUCTION_REPLY_ACCEPTED_TO_CLIENT : ReplicaManager2.h
  • SEND_CONSTRUCTION_REPLY_DENIED_TO_CLIENT : ReplicaManager2.h
  • SEND_CONSTRUCTION_REQUEST_TO_SERVER : ReplicaManager2.h
  • SEND_CONSTRUCTION_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM : ReplicaManager2.h
  • SEND_CONSTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM : ReplicaManager2.h
  • SEND_DATA_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM : ReplicaManager2.h
  • SEND_DESTRUCTION_GENERIC_TO_SYSTEM : ReplicaManager2.h
  • SEND_DESTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM : ReplicaManager2.h
  • SEND_SERIALIZATION_CONSTRUCTION_TO_SYSTEM : ReplicaManager2.h
  • SEND_SERIALIZATION_GENERIC_TO_SYSTEM : ReplicaManager2.h
  • SEND_VISIBILITY_FALSE_TO_SYSTEM : ReplicaManager2.h
  • SEND_VISIBILITY_TRUE_TO_SYSTEM : ReplicaManager2.h

- u -

  • UNDEFINED_REASON : ReplicaManager2.h
  • UNRELIABLE : PacketPriority.h
  • UNRELIABLE_SEQUENCED : PacketPriority.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • _
  • b
  • d
  • f
  • g
  • l
  • n
  • p
  • r
  • s

- _ -

  • _speex_putc() : misc.h

- b -

  • be_int() : misc.h

- d -

  • defaultMapKeyComparison() : DS_Map.h

- f -

  • forced_pitch_quant() : ltp.h
  • forced_pitch_unquant() : ltp.h
  • frandomMT() : Rand.h

- g -

  • GetTime() : GetTime.cpp

- l -

  • le_int() : misc.h

- n -

  • nb_decode() : nb_celp.h
  • nb_decoder_ctl() : nb_celp.h
  • nb_decoder_destroy() : nb_celp.h
  • nb_decoder_init() : nb_celp.h
  • nb_encode() : nb_celp.h
  • nb_encoder_ctl() : nb_celp.h
  • nb_encoder_destroy() : nb_celp.h
  • nb_encoder_init() : nb_celp.h

- p -

  • pitch_search_3tap() : ltp.h
  • print_vec() : misc.h

- r -

  • randomMT() : Rand.h
  • RegisteredCommandComp() : CommandParserInterface.h

- s -

  • sb_decode() : sb_celp.h
  • sb_decoder_destroy() : sb_celp.h
  • sb_decoder_init() : sb_celp.h
  • sb_encode() : sb_celp.h
  • sb_encoder_destroy() : sb_celp.h
  • sb_encoder_init() : sb_celp.h
  • seedMT() : Rand.h
  • speex_alloc() : misc.h
  • speex_alloc_scratch() : misc.h
  • speex_bits_advance() : speex_bits.h
  • speex_bits_destroy() : speex_bits.h
  • speex_bits_init() : speex_bits.h
  • speex_bits_init_buffer() : speex_bits.h
  • speex_bits_insert_terminator() : speex_bits.h
  • speex_bits_nbytes() : speex_bits.h
  • speex_bits_pack() : speex_bits.h
  • speex_bits_peek() : speex_bits.h
  • speex_bits_peek_unsigned() : speex_bits.h
  • speex_bits_read_from() : speex_bits.h
  • speex_bits_read_whole_bytes() : speex_bits.h
  • speex_bits_remaining() : speex_bits.h
  • speex_bits_reset() : speex_bits.h
  • speex_bits_rewind() : speex_bits.h
  • speex_bits_unpack_signed() : speex_bits.h
  • speex_bits_unpack_unsigned() : speex_bits.h
  • speex_bits_write() : speex_bits.h
  • speex_bits_write_whole_bytes() : speex_bits.h
  • speex_decode() : speex.h
  • speex_decode_int() : speex.h
  • speex_decode_stereo() : speex_stereo.h
  • speex_decode_stereo_int() : speex_stereo.h
  • speex_decoder_ctl() : speex.h
  • speex_decoder_destroy() : speex.h
  • speex_decoder_init() : speex.h
  • speex_default_user_handler() : speex_callbacks.h
  • speex_echo_cancel() : speex_echo.h
  • speex_echo_ctl() : speex_echo.h
  • speex_echo_state_destroy() : speex_echo.h
  • speex_echo_state_init() : speex_echo.h
  • speex_echo_state_reset() : speex_echo.h
  • speex_encode() : speex.h
  • speex_encode_int() : speex.h
  • speex_encode_stereo() : speex_stereo.h
  • speex_encode_stereo_int() : speex_stereo.h
  • speex_encoder_ctl() : speex.h
  • speex_encoder_destroy() : speex.h
  • speex_encoder_init() : speex.h
  • speex_error() : misc.h
  • speex_free() : misc.h
  • speex_free_scratch() : misc.h
  • speex_header_to_packet() : speex_header.h
  • speex_inband_handler() : speex_callbacks.h
  • speex_init_header() : speex_header.h
  • speex_jitter_destroy() : speex_jitter.h
  • speex_jitter_get() : speex_jitter.h
  • speex_jitter_get_pointer_timestamp() : speex_jitter.h
  • speex_jitter_init() : speex_jitter.h
  • speex_jitter_put() : speex_jitter.h
  • speex_lib_ctl() : speex.h
  • speex_lib_get_mode() : speex.h
  • speex_memcpy_bytes() : misc.h
  • speex_memset_bytes() : misc.h
  • speex_mode_query() : speex.h
  • speex_move() : misc.h
  • speex_packet_to_header() : speex_header.h
  • speex_preprocess() : speex_preprocess.h
  • speex_preprocess_ctl() : speex_preprocess.h
  • speex_preprocess_estimate_update() : speex_preprocess.h
  • speex_preprocess_state_destroy() : speex_preprocess.h
  • speex_preprocess_state_init() : speex_preprocess.h
  • speex_rand() : misc.h
  • speex_rand_vec() : misc.h
  • speex_realloc() : misc.h
  • speex_std_char_handler() : speex_callbacks.h
  • speex_std_high_mode_request_handler() : speex_callbacks.h
  • speex_std_mode_request_handler() : speex_callbacks.h
  • speex_std_stereo_request_handler() : speex_stereo.h
  • speex_warning() : misc.h
  • speex_warning_int() : misc.h
  • StatisticsToString() : RakNetStatistics.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator
  • d
  • e
  • f
  • i
  • l
  • m
  • o
  • s
  • u

- d -

  • decode_func : speex.h
  • decoder_ctl_func : speex.h
  • decoder_destroy_func : speex.h
  • decoder_init_func : speex.h

- e -

  • encode_func : speex.h
  • encoder_ctl_func : speex.h
  • encoder_destroy_func : speex.h
  • encoder_init_func : speex.h

- f -

  • f32 : Types.h
  • f64 : Types.h

- i -

  • innovation_quant_func : modes.h
  • innovation_unquant_func : modes.h

- l -

  • lsp_quant_func : modes.h
  • lsp_unquant_func : modes.h
  • ltp_quant_func : modes.h
  • ltp_unquant_func : modes.h

- m -

  • MessageID : RakNetTypes.h
  • MessageNumberType : InternalPacket.h
  • mode_query_func : speex.h

- o -

  • OrderingIndexType : InternalPacket.h

- s -

  • s16 : Types.h
  • s32 : Types.h
  • s8 : Types.h
  • sfp16_16 : Types.h
  • sfp22_10 : Types.h
  • SOCKET : SocketLayer.h , TCPInterface.h
  • speex_callback_func : speex_callbacks.h
  • StringTableType : StringTable.h

- u -

  • u16 : Types.h
  • u32 : Types.h
  • u8 : Types.h
  • ufp16_16 : Types.h
  • ufp22_10 : Types.h
  • UniqueIDType : RakNetTypes.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerator

  • BQR_ALWAYS : ReplicaManager2.h
  • BQR_NO : ReplicaManager2.h
  • BQR_YES : ReplicaManager2.h
  • speex_mode_list : speex.h
  • speex_nb_mode : speex.h
  • speex_pcm_wrapper : pcm_wrapper.h
  • speex_uwb_mode : speex.h
  • speex_wb_mode : speex.h
  • UNASSIGNED_NETWORK_ID : RakNetTypes.h
  • UNASSIGNED_PLAYER_INDEX : RakNetTypes.h
  • UNASSIGNED_SYSTEM_ADDRESS : RakNetTypes.h
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Main Page

RakNet Documentation

3.011

Generated on Sun Jul 27 15:10:16 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerator
  • a
  • b
  • r
  • s
  • u

- a -

  • AUTOSERIALIZE_DEFAULT : RakNet
  • AUTOSERIALIZE_RESYNCH_ONLY : RakNet

- b -

  • BROADCAST_AUTO_SERIALIZE_TO_SYSTEM : RakNet
  • BROADCAST_CONSTRUCTION_GENERIC_TO_SYSTEM : RakNet
  • BROADCAST_CONSTRUCTION_REQUEST_ACCEPTED_TO_SYSTEM : RakNet
  • BROADCAST_DESTRUCTION_GENERIC_TO_SYSTEM : RakNet
  • BROADCAST_SERIALIZATION_CONSTRUCTION_TO_SYSTEM : RakNet
  • BROADCAST_SERIALIZATION_GENERIC_TO_SYSTEM : RakNet
  • BROADCAST_VISIBILITY_FALSE_TO_SYSTEM : RakNet
  • BROADCAST_VISIBILITY_TRUE_TO_SYSTEM : RakNet

- r -

  • RELAY_DESTRUCTION_TO_SYSTEMS : RakNet
  • RELAY_SERIALIZATION_TO_SYSTEMS : RakNet
  • RELAY_VISIBILITY_FALSE_TO_SYSTEMS : RakNet
  • RELAY_VISIBILITY_TRUE_TO_SYSTEMS : RakNet
  • RPC_ERROR_CALLING_C_AS_CPP : RakNet
  • RPC_ERROR_CALLING_CPP_AS_C : RakNet
  • RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE : RakNet
  • RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED : RakNet
  • RPC_ERROR_FUNCTION_NOT_REGISTERED : RakNet
  • RPC_ERROR_INCORRECT_NUMBER_OF_PARAMETERS : RakNet
  • RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE : RakNet
  • RPC_ERROR_OBJECT_DOES_NOT_EXIST : RakNet
  • RPC_ERROR_STACK_DESERIALIZATION_FAILED : RakNet
  • RPC_ERROR_STACK_TOO_SMALL : RakNet

- s -

  • SEND_AUTO_SERIALIZE_TO_SYSTEM : RakNet
  • SEND_CONSTRUCTION_GENERIC_TO_SYSTEM : RakNet
  • SEND_CONSTRUCTION_REPLY_ACCEPTED_TO_CLIENT : RakNet
  • SEND_CONSTRUCTION_REPLY_DENIED_TO_CLIENT : RakNet
  • SEND_CONSTRUCTION_REQUEST_TO_SERVER : RakNet
  • SEND_CONSTRUCTION_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM : RakNet
  • SEND_CONSTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM : RakNet
  • SEND_DATA_SERIALIZATION_AUTO_INITIAL_DOWNLOAD_TO_SYSTEM : RakNet
  • SEND_DESTRUCTION_GENERIC_TO_SYSTEM : RakNet
  • SEND_DESTRUCTION_VISIBILITY_RECALCULATION_TO_SYSTEM : RakNet
  • SEND_SERIALIZATION_CONSTRUCTION_TO_SYSTEM : RakNet
  • SEND_SERIALIZATION_GENERIC_TO_SYSTEM : RakNet
  • SEND_VISIBILITY_FALSE_TO_SYSTEM : RakNet
  • SEND_VISIBILITY_TRUE_TO_SYSTEM : RakNet

- u -

  • UNDEFINED_REASON : RakNet
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerator

  • defaultMapKeyComparison() : DataStructures
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Enumerator

  • f32 : cat
  • f64 : cat
  • s16 : cat
  • s32 : cat
  • s8 : cat
  • sfp16_16 : cat
  • sfp22_10 : cat
  • u16 : cat
  • u32 : cat
  • u8 : cat
  • ufp16_16 : cat
  • ufp22_10 : cat
Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

CombFilterMem Member List

This is the complete list of members for CombFilterMem, including all inherited members.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

ConnectionGraph::SystemAddressAndGroupId Member List

This is the complete list of members for ConnectionGraph::SystemAddressAndGroupId, including all inherited members.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DatabaseCellUpdate Member List

This is the complete list of members for DatabaseCellUpdate, including all inherited members.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::Page< KeyType, DataType, order > Member List

This is the complete list of members for DataStructures::Page< KeyType, DataType, order >, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::Table::Cell Member List

This is the complete list of members for DataStructures::Table::Cell, including all inherited members.

Get(int *output) | DataStructures::Table::Cell
Get(char *output) | DataStructures::Table::Cell
Get(char *output, int *outputLength) | DataStructures::Table::Cell
Set(int input) | DataStructures::Table::Cell
Set(const char *input) | DataStructures::Table::Cell
Set(const char *input, int inputLength) | DataStructures::Table::Cell
SetPtr(void *p) | DataStructures::Table::Cell

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::Table::ColumnDescriptor Member List

This is the complete list of members for DataStructures::Table::ColumnDescriptor, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DataStructures::Table::Row Member List

This is the complete list of members for DataStructures::Table::Row, including all inherited members.

UpdateCell(unsigned columnIndex, int value) | DataStructures::Table::Row
UpdateCell(unsigned columnIndex, const char *str) | DataStructures::Table::Row
UpdateCell(unsigned columnIndex, int byteLength, const char *data) | DataStructures::Table::Row

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

DecState Member List

This is the complete list of members for DecState, including all inherited members.

count_lost | DecState
encode_submode | DecState
exc | DecState
excBuf | DecState
first | DecState
frame | DecState
frameSize | DecState
inBuf | DecState
innov | DecState
interp_qlpc | DecState
interp_qlsp | DecState
last_ol_gain | DecState
last_pitch | DecState
last_pitch_gain | DecState
lpc_enh_enabled | DecState
lpcSize | DecState
max_pitch | DecState
mem_sp | DecState
min_pitch | DecState
mode | DecState
nbSubframes | DecState
old_qlsp | DecState
pi_gain | DecState
pitch_gain_buf | DecState
pitch_gain_buf_idx | DecState
qlsp | DecState
stack | DecState
subframeSize | DecState
submodeID | DecState
submodes | DecState

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

drft_lookup Member List

This is the complete list of members for drft_lookup, including all inherited members.

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

EncState Member List

This is the complete list of members for EncState, including all inherited members.

abr_enabled | EncState
autocorr | EncState
bounded_pitch | EncState
bw_lpc1 | EncState
bw_lpc2 | EncState
complexity | EncState
dtx_count | EncState
dtx_enabled | EncState
exc | EncState
excBuf | EncState
first | EncState
frame | EncState
frameSize | EncState
gamma1 | EncState
gamma2 | EncState
inBuf | EncState
innov | EncState
interp_lpc | EncState
interp_lsp | EncState
interp_qlpc | EncState
interp_qlsp | EncState
lag_factor | EncState
lagWindow | EncState
lpc | EncState
lpc_floor | EncState
lpcSize | EncState
lsp | EncState
max_pitch | EncState
mem_exc | EncState
mem_sp | EncState
mem_sw | EncState
mem_sw_whole | EncState
min_pitch | EncState
mode | EncState
nbSubframes | EncState
ol_pitch | EncState
ol_voiced | EncState
old_lsp | EncState
old_qlsp | EncState
pi_gain | EncState
qlsp | EncState
relative_quality | EncState
safe_pitch | EncState
stack | EncState
subframeSize | EncState
submodeID | EncState
submodes | EncState
submodeSelect | EncState
sw | EncState
swBuf | EncState
vad_enabled | EncState
vbr | EncState
vbr_enabled | EncState
vbr_quality | EncState
window | EncState
windowSize | EncState

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

FileListNode Member List

This is the complete list of members for FileListNode, including all inherited members.

context | FileListNode
data | FileListNode
dataLengthBytes | FileListNode
fileLengthBytes | FileListNode
filename | FileListNode

Generated on Sun Jul 27 15:10:17 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

HTTPConnection::BadResponse Member List

This is the complete list of members for HTTPConnection::BadResponse, including all inherited members.

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

InternalPacket Member List

This is the complete list of members for InternalPacket, including all inherited members.

creationTime | InternalPacket
data | InternalPacket
dataBitLength | InternalPacket
messageInternalOrder | InternalPacket
messageNumber | InternalPacket
messageNumberAssigned | InternalPacket
nextActionTime | InternalPacket
orderingChannel | InternalPacket
orderingIndex | InternalPacket
packetNumber | InternalPacket
priority | InternalPacket
reliability | InternalPacket
splitPacketCount | InternalPacket
splitPacketId | InternalPacket
splitPacketIndex | InternalPacket

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

LogCommandParser::SystemAddressAndChannel Member List

This is the complete list of members for LogCommandParser::SystemAddressAndChannel, including all inherited members.

channels | LogCommandParser::SystemAddressAndChannel
systemAddress | LogCommandParser::SystemAddressAndChannel

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

ltp_params Member List

This is the complete list of members for ltp_params, including all inherited members.

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

Packet Member List

This is the complete list of members for Packet, including all inherited members.

bitSize | Packet
data | Packet
length | Packet
systemAddress | Packet
systemIndex | Packet

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::ClanJoinInvitation_Notification Member List

This is the complete list of members for RakNet::ClanJoinInvitation_Notification, including all inherited members.

clanId | RakNet::ClanJoinInvitation_Notification
clanLeaderOrSubleaderId | RakNet::ClanJoinInvitation_Notification

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::ClanJoinInvitationAccepted_Notification Member List

This is the complete list of members for RakNet::ClanJoinInvitationAccepted_Notification, including all inherited members.

clanId | RakNet::ClanJoinInvitationAccepted_Notification
clanLeaderOrSubleaderId | RakNet::ClanJoinInvitationAccepted_Notification
invitationSenderIsYou | RakNet::ClanJoinInvitationAccepted_Notification
userId | RakNet::ClanJoinInvitationAccepted_Notification
userIdIsYou | RakNet::ClanJoinInvitationAccepted_Notification

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::ClanJoinInvitationRejected_Notification Member List

This is the complete list of members for RakNet::ClanJoinInvitationRejected_Notification, including all inherited members.

clanId | RakNet::ClanJoinInvitationRejected_Notification
clanLeaderOrSubleaderId | RakNet::ClanJoinInvitationRejected_Notification
userId | RakNet::ClanJoinInvitationRejected_Notification

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::ClanJoinInvitationWithdrawn_Notification Member List

This is the complete list of members for RakNet::ClanJoinInvitationWithdrawn_Notification, including all inherited members.

clanId | RakNet::ClanJoinInvitationWithdrawn_Notification
clanLeaderOrSubleaderId | RakNet::ClanJoinInvitationWithdrawn_Notification

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::ClanMemberJoinRequest_Notification Member List

This is the complete list of members for RakNet::ClanMemberJoinRequest_Notification, including all inherited members.

clanId | RakNet::ClanMemberJoinRequest_Notification
userId | RakNet::ClanMemberJoinRequest_Notification

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::ClanMemberJoinRequestAccepted_Notification Member List

This is the complete list of members for RakNet::ClanMemberJoinRequestAccepted_Notification, including all inherited members.

clanId | RakNet::ClanMemberJoinRequestAccepted_Notification
clanLeaderOrSubleaderId | RakNet::ClanMemberJoinRequestAccepted_Notification
joinRequestAcceptorIsYou | RakNet::ClanMemberJoinRequestAccepted_Notification
userId | RakNet::ClanMemberJoinRequestAccepted_Notification
userIdIsYou | RakNet::ClanMemberJoinRequestAccepted_Notification

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::ClanMemberJoinRequestRejected_Notification Member List

This is the complete list of members for RakNet::ClanMemberJoinRequestRejected_Notification, including all inherited members.

clanId | RakNet::ClanMemberJoinRequestRejected_Notification
clanLeaderOrSubleaderId | RakNet::ClanMemberJoinRequestRejected_Notification

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::ClanMemberJoinRequestWithdrawn_Notification Member List

This is the complete list of members for RakNet::ClanMemberJoinRequestWithdrawn_Notification, including all inherited members.

clanId | RakNet::ClanMemberJoinRequestWithdrawn_Notification
userId | RakNet::ClanMemberJoinRequestWithdrawn_Notification

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::LeaveClan_Notification Member List

This is the complete list of members for RakNet::LeaveClan_Notification, including all inherited members.

clanId | RakNet::LeaveClan_Notification
userId | RakNet::LeaveClan_Notification

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNet::SerializationContext Member List

This is the complete list of members for RakNet::SerializationContext, including all inherited members.

IsConstructionCommand(SerializationType r) | RakNet::SerializationContext | [static]
IsDestructionCommand(SerializationType r) | RakNet::SerializationContext | [static]
IsDownloadCommand(SerializationType r) | RakNet::SerializationContext | [static]
IsSerializationCommand(SerializationType r) | RakNet::SerializationContext | [static]
IsVisibilityCommand(SerializationType r) | RakNet::SerializationContext | [static]
IsVisible(SerializationType r) | RakNet::SerializationContext | [static]
recipientAddress | RakNet::SerializationContext |
relaySourceAddress | RakNet::SerializationContext |
serializationType | RakNet::SerializationContext |
timestamp | RakNet::SerializationContext |

Generated on Sun Jul 27 15:10:20 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakNetStatistics Member List

This is the complete list of members for RakNetStatistics, including all inherited members.

acknowlegementBitsSent | RakNetStatistics
acknowlegementsPending | RakNetStatistics
acknowlegementsReceived | RakNetStatistics
acknowlegementsSent | RakNetStatistics
bitsPerSecond | RakNetStatistics
bitsReceived | RakNetStatistics
bitsWithBadCRCReceived | RakNetStatistics
connectionStartTime | RakNetStatistics
duplicateAcknowlegementsReceived | RakNetStatistics
duplicateMessagesReceived | RakNetStatistics
encryptionBitsSent | RakNetStatistics
internalOutputQueueSize | RakNetStatistics
invalidMessagesReceived | RakNetStatistics
messageDataBitsResent | RakNetStatistics
messageDataBitsSent | RakNetStatistics
messageResends | RakNetStatistics
messageSendBuffer | RakNetStatistics
messagesOnResendQueue | RakNetStatistics
messagesReceived | RakNetStatistics
messagesSent | RakNetStatistics
messagesTotalBitsResent | RakNetStatistics
messagesWaitingForReassembly | RakNetStatistics
messageTotalBitsSent | RakNetStatistics
numberOfSplitMessages | RakNetStatistics
numberOfUnsplitMessages | RakNetStatistics
orderedMessagesInOrder | RakNetStatistics
orderedMessagesOutOfOrder | RakNetStatistics
packetsContainingOnlyAcknowlegements | RakNetStatistics
packetsContainingOnlyAcknowlegementsAndResends | RakNetStatistics
packetsReceived | RakNetStatistics
packetsSent | RakNetStatistics
packetsWithBadCRCReceived | RakNetStatistics
sequencedMessagesInOrder | RakNetStatistics
sequencedMessagesOutOfOrder | RakNetStatistics
totalBitsSent | RakNetStatistics
totalSplits | RakNetStatistics

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RakPeer::MemoryBlock Member List

This is the complete list of members for RakPeer::MemoryBlock, including all inherited members.

Generated on Sun Jul 27 15:10:18 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RankingServerDBSpec::PairedKeyDbId Member List

This is the complete list of members for RankingServerDBSpec::PairedKeyDbId, including all inherited members.

Generated on Sun Jul 27 15:10:21 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RemoteClient Member List

This is the complete list of members for RemoteClient, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

RPCParameters Member List

This is the complete list of members for RPCParameters, including all inherited members.

functionName | RPCParameters
input | RPCParameters
numberOfBitsOfData | RPCParameters
recipient | RPCParameters
replyToSender | RPCParameters
sender | RPCParameters

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SBDecState Member List

This is the complete list of members for SBDecState, including all inherited members.

mode | SBDecState
st_low | SBDecState

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SBEncState Member List

This is the complete list of members for SBEncState, including all inherited members.

abr_enabled | SBEncState
autocorr | SBEncState
bufSize | SBEncState
bw_lpc1 | SBEncState
bw_lpc2 | SBEncState
exc | SBEncState
excBuf | SBEncState
first | SBEncState
frame_size | SBEncState
full_frame_size | SBEncState
g1_mem | SBEncState
gamma1 | SBEncState
gamma2 | SBEncState
high | SBEncState
interp_lpc | SBEncState
interp_lsp | SBEncState
interp_qlpc | SBEncState
interp_qlsp | SBEncState
lag_factor | SBEncState
lagWindow | SBEncState
lpc | SBEncState
lpc_floor | SBEncState
lpcSize | SBEncState
lsp | SBEncState
mem_sp | SBEncState
mem_sw | SBEncState
mode | SBEncState
nbSubframes | SBEncState
old_lsp | SBEncState
old_qlsp | SBEncState
qlsp | SBEncState
res | SBEncState
st_low | SBEncState
stack | SBEncState
subframeSize | SBEncState
sw | SBEncState
target | SBEncState
vad_enabled | SBEncState
vbr_enabled | SBEncState
vbr_quality | SBEncState
window | SBEncState
windowSize | SBEncState
x1d | SBEncState
y1 | SBEncState

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SocketDescriptor Member List

This is the complete list of members for SocketDescriptor, including all inherited members.

hostAddress | SocketDescriptor
port | SocketDescriptor

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SpeexBits Member List

This is the complete list of members for SpeexBits, including all inherited members.

bitPtr | SpeexBits
buf_size | SpeexBits
charPtr | SpeexBits
chars | SpeexBits
nbBits | SpeexBits
overflow | SpeexBits
owner | SpeexBits
reserved1 | SpeexBits
reserved2 | SpeexBits

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SpeexCallback Member List

This is the complete list of members for SpeexCallback, including all inherited members.

callback_id | SpeexCallback
data | SpeexCallback
func | SpeexCallback
reserved1 | SpeexCallback
reserved2 | SpeexCallback

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SpeexEchoState_ Member List

This is the complete list of members for SpeexEchoState_, including all inherited members.

frame_size SpeexEchoState_

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SpeexHeader Member List

This is the complete list of members for SpeexHeader, including all inherited members.

bitrate | SpeexHeader
extra_headers | SpeexHeader
frame_size | SpeexHeader
frames_per_packet | SpeexHeader
header_size | SpeexHeader
mode | SpeexHeader
mode_bitstream_version | SpeexHeader
nb_channels | SpeexHeader
rate | SpeexHeader
reserved1 | SpeexHeader
reserved2 | SpeexHeader
speex_string | SpeexHeader
speex_version | SpeexHeader
speex_version_id | SpeexHeader
vbr | SpeexHeader

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SpeexJitter Member List

This is the complete list of members for SpeexJitter, including all inherited members.

buf | SpeexJitter
buffer_size | SpeexJitter
current_packet | SpeexJitter
dec | SpeexJitter
frame_size | SpeexJitter
frame_time | SpeexJitter
len | SpeexJitter
longterm_margin | SpeexJitter
loss_rate | SpeexJitter
lost_count | SpeexJitter
pointer_timestamp | SpeexJitter
reset_state | SpeexJitter
shortterm_margin | SpeexJitter
timestamp | SpeexJitter
valid_bits | SpeexJitter

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SpeexMode Member List

This is the complete list of members for SpeexMode, including all inherited members.

bitstream_version | SpeexMode
dec | SpeexMode
dec_ctl | SpeexMode
dec_destroy | SpeexMode
dec_init | SpeexMode
enc | SpeexMode
enc_ctl | SpeexMode
enc_destroy | SpeexMode
enc_init | SpeexMode
mode | SpeexMode
modeID | SpeexMode
modeName | SpeexMode
query | SpeexMode

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SpeexNBMode Member List

This is the complete list of members for SpeexNBMode, including all inherited members.

defaultSubmode | SpeexNBMode
frameSize | SpeexNBMode
gamma1 | SpeexNBMode
gamma2 | SpeexNBMode
lag_factor | SpeexNBMode
lpc_floor | SpeexNBMode
lpcSize | SpeexNBMode
pitchEnd | SpeexNBMode
pitchStart | SpeexNBMode
quality_map | SpeexNBMode
subframeSize | SpeexNBMode
submodes | SpeexNBMode

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SpeexPreprocessState Member List

This is the complete list of members for SpeexPreprocessState, including all inherited members.

consec_noise | SpeexPreprocessState
fft_lookup | SpeexPreprocessState
frame | SpeexPreprocessState
frame_size | SpeexPreprocessState
gain | SpeexPreprocessState
gain2 | SpeexPreprocessState
inbuf | SpeexPreprocessState
loudness | SpeexPreprocessState
loudness2 | SpeexPreprocessState
loudness_weight | SpeexPreprocessState
nb_adapt | SpeexPreprocessState
nb_loudness_adapt | SpeexPreprocessState
nb_preprocess | SpeexPreprocessState
noise | SpeexPreprocessState
old_ps | SpeexPreprocessState
outbuf | SpeexPreprocessState
post | SpeexPreprocessState
prior | SpeexPreprocessState
ps | SpeexPreprocessState
ps_size | SpeexPreprocessState
reverb_estimate | SpeexPreprocessState
S | SpeexPreprocessState
sampling_rate | SpeexPreprocessState
Smin | SpeexPreprocessState
Stmp | SpeexPreprocessState
update_prob | SpeexPreprocessState
window | SpeexPreprocessState
zeta | SpeexPreprocessState

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SpeexSBMode Member List

This is the complete list of members for SpeexSBMode, including all inherited members.

bufSize | SpeexSBMode
defaultSubmode | SpeexSBMode
frameSize | SpeexSBMode
gamma1 | SpeexSBMode
gamma2 | SpeexSBMode
lag_factor | SpeexSBMode
low_quality_map | SpeexSBMode
lpc_floor | SpeexSBMode
lpcSize | SpeexSBMode
nb_mode | SpeexSBMode
quality_map | SpeexSBMode
subframeSize | SpeexSBMode
submodes | SpeexSBMode

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SpeexStereoState Member List

This is the complete list of members for SpeexStereoState, including all inherited members.

balance | SpeexStereoState
e_ratio | SpeexStereoState
reserved1 | SpeexStereoState
reserved2 | SpeexStereoState
smooth_left | SpeexStereoState
smooth_right | SpeexStereoState

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SpeexSubmode Member List

This is the complete list of members for SpeexSubmode, including all inherited members.

bits_per_frame | SpeexSubmode
comb_gain | SpeexSubmode
double_codebook | SpeexSubmode
forced_pitch_gain | SpeexSubmode
have_subframe_gain | SpeexSubmode
innovation_params | SpeexSubmode
innovation_quant | SpeexSubmode
innovation_unquant | SpeexSubmode
lbr_pitch | SpeexSubmode
lpc_enh_k1 | SpeexSubmode
lpc_enh_k2 | SpeexSubmode
lpc_enh_k3 | SpeexSubmode
lsp_quant | SpeexSubmode
lsp_unquant | SpeexSubmode
ltp_params | SpeexSubmode
ltp_quant | SpeexSubmode
ltp_unquant | SpeexSubmode

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

split_cb_params Member List

This is the complete list of members for split_cb_params, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

StrAndBool Member List

This is the complete list of members for StrAndBool, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

SystemAddress Member List

This is the complete list of members for SystemAddress, including all inherited members.

binaryAddress | SystemAddress
port | SystemAddress

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

ThreadPool< InputType, OutputType > Member List

This is the complete list of members for ThreadPool< InputType, OutputType >, including all inherited members.

AddInput(OutputType(*workerThreadCallback)(InputType, bool *returnOutput, void *perThreadData), InputType inputData) | ThreadPool< InputType, OutputType >
Clear(void) | ThreadPool< InputType, OutputType >
ClearInput(void) | ThreadPool< InputType, OutputType >
ClearOutput(void) | ThreadPool< InputType, OutputType >
GetInputAtIndex(unsigned index) | ThreadPool< InputType, OutputType >
GetOutput(void) | ThreadPool< InputType, OutputType >
GetOutputAtIndex(unsigned index) | ThreadPool< InputType, OutputType >
HasInput(void) | ThreadPool< InputType, OutputType >
HasInputFast(void) | ThreadPool< InputType, OutputType >
HasOutput(void) | ThreadPool< InputType, OutputType >
HasOutputFast(void) | ThreadPool< InputType, OutputType >
InputSize(void) | ThreadPool< InputType, OutputType >
IsWorking(void) | ThreadPool< InputType, OutputType >
LockInput(void) | ThreadPool< InputType, OutputType >
LockOutput(void) | ThreadPool< InputType, OutputType >
NumThreadsWorking(void) | ThreadPool< InputType, OutputType >
OutputSize(void) | ThreadPool< InputType, OutputType >
RemoveInputAtIndex(unsigned index) | ThreadPool< InputType, OutputType >
RemoveOutputAtIndex(unsigned index) | ThreadPool< InputType, OutputType >
StartThreads(int numThreads, int stackSize, void *(*_perThreadDataFactory)()=0, void(*_perThreadDataDestructor)(void *)=0) | ThreadPool< InputType, OutputType >
StopThreads(void) | ThreadPool< InputType, OutputType >
UnlockInput(void) | ThreadPool< InputType, OutputType >
UnlockOutput(void) | ThreadPool< InputType, OutputType >
WasStopped(void) const | ThreadPool< InputType, OutputType >

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1


RakNet: Member List

VBRState Member List

This is the complete list of members for VBRState, including all inherited members.

Generated on Sun Jul 27 15:10:19 2008 for RakNet by doxygen 1.5.1-p1